Bố trí linh kiện
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Bạn sẽ hiểu footprint của linh kiện PCB bao gồm những gì, từ các pad và chi tiết trên lớp in lụa đến các khối 3D tùy chọn.
- Bạn sẽ biết những thuộc tính nào của linh kiện trong Altium Designer ảnh hưởng đến vị trí bố trí, hướng, việc gán lớp và khả năng nhận diện linh kiện.
- Bạn sẽ thấy cách trình biên tập PCB xử lý các loại linh kiện và các định nghĩa diện tích khác nhau.
Có câu nói rằng thiết kế PCB gồm 90% bố trí linh kiện và 10% đi dây. Dù tỷ lệ cụ thể có thể còn gây tranh luận, nhìn chung mọi người đều công nhận rằng bố trí linh kiện tốt là yếu tố then chốt để có một thiết kế bo mạch tốt. Hãy nhớ rằng bạn cũng có thể cần điều chỉnh vị trí linh kiện trong quá trình đi dây.
Footprint linh kiện xác định không gian và các điểm kết nối cần thiết để lắp linh kiện thực tế lên bảng mạch in. Đây là một đối tượng nhóm được tạo thành từ tập hợp các đối tượng cơ bản đơn giản, bao gồm pad, đường thẳng và cung tròn, cũng như các đối tượng thiết kế khác.

Footprint linh kiện xác định cách lắp đặt và kết nối linh kiện trên PCB và cũng có thể bao gồm các đối tượng khối 3D để mô tả linh kiện thực tế.
Các pad cung cấp điểm lắp đặt và kết nối cho chân linh kiện. Các đối tượng thiết kế cơ bản bổ sung, chẳng hạn như đường thẳng và cung tròn, thường được dùng để xác định đường bao hình dạng linh kiện trên lớp in ký hiệu (silkscreen).
Footprint linh kiện cũng có thể bao gồm các đối tượng khối 3D tùy chọn, dùng để xác định không gian vật lý hoặc đường bao của linh kiện thực tế được lắp trên bo mạch. Nếu linh kiện thực tế đã được mô tả bằng các đối tượng khối 3D hoặc mô hình STEP được nhập vào, bạn có thể thực hiện kiểm tra khoảng hở giữa các linh kiện trong không gian ba chiều.
Footprint linh kiện được tạo trong trình biên tập footprint PCB bằng cách đặt các đối tượng thiết kế phù hợp để tạo ra hình dạng cần thiết cho việc lắp đặt và kết nối linh kiện. Điểm tham chiếu của linh kiện là gốc tọa độ của không gian thiết kế trong trình biên tập footprint PCB. Trong trình biên tập, bạn có thể đặt điểm này tại: chân 1, tâm hình học hoặc một vị trí do người dùng xác định trên linh kiện. Để tìm hiểu thêm về cách tạo footprint, hãy tham khảo trang Tạo footprint PCB.
Thuộc tính linh kiện

Chế độ Component của bảng Properties.
Thẻ Tổng quát
Vị trí
-
(X/Y)
-
X (trường thứ nhất) – tọa độ X (ngang) hiện tại của điểm tham chiếu linh kiện so với gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của linh kiện. Có thể nhập giá trị theo hệ mét hoặc hệ inch; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Điểm tham chiếu của footprint linh kiện được thiết lập trong Trình biên tập thư viện.
-
Y (trường thứ hai) – tọa độ Y (dọc) hiện tại của điểm tham chiếu linh kiện so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của linh kiện. Có thể nhập giá trị theo hệ mét hoặc hệ inch; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Điểm tham chiếu của footprint linh kiện được thiết lập trong Trình biên tập thư viện.
-
-
Rotation – góc xoay của linh kiện (tính bằng độ), được đo ngược chiều kim đồng hồ từ góc 0 (phương ngang 3 o'clock). Chỉnh sửa để thay đổi góc xoay của linh kiện. Độ phân giải góc nhỏ nhất là 0,001°.
Thuộc tính
-
Layer – thiết lập lớp đặt linh kiện. Linh kiện có thể được gán cho lớp Top hoặc lớp Bottom. Sử dụng danh sách thả xuống để chọn một lớp khác. Khi thay đổi lớp, tất cả các đối tượng cơ bản của linh kiện sẽ được chuyển sang lớp đối diện tương ứng. Ví dụ, khi chuyển một linh kiện từ lớp Top sang lớp Bottom, các pad một lớp sẽ được chuyển từ lớp trên xuống lớp dưới, các đối tượng cơ bản trên lớp Top Overlay được gán lại sang lớp Bottom Overlay, và các đối tượng cơ bản trên một lớp cơ khí được ghép cặp sẽ được chuyển sang lớp cơ khí còn lại trong cặp đó. Hướng của linh kiện sẽ được lật theo trục X và văn bản trên lớp in ký hiệu linh kiện sẽ được đọc từ mặt dưới.
-
Reuse Block – khi linh kiện thuộc một khối tái sử dụng, trường này hiển thị tên của khối tái sử dụng chứa linh kiện đó. Nhấp vào siêu liên kết Reuse Block để xem các thuộc tính của khối tái sử dụng này.
-
Designator – ký hiệu định danh của linh kiện là một chuỗi chữ và số có độ dài tối đa 255 ký tự. Mỗi linh kiện phải có một chuỗi ký hiệu định danh duy nhất. Nhấp vào
hoặc
để hiển thị/ẩn ký hiệu định danh. Nhấp vào siêu liên kết Designator để mở các thuộc tính của ký hiệu định danh linh kiện.
-
Comment – chú thích của linh kiện là một chuỗi chữ và số có độ dài tối đa 255 ký tự. Nhấp vào
hoặc
để hiển thị/ẩn chú thích. Nhấp vào siêu liên kết Comment để mở các thuộc tính của chú thích linh kiện.
-
Area – diện tích của linh kiện đã đặt, được hiển thị theo đơn vị hiện tại của bo mạch. Diện tích này có thể do người dùng xác định; nếu không, nó sẽ được tự động tính từ vùng chọn của linh kiện:
-
Để xác định diện tích linh kiện, hãy chỉnh sửa Area trong bảng Properties của footprint trong trình chỉnh sửa PCB Footprint. Để cập nhật footprint cho một PCB đang mở, nhấp chuột phải vào tên footprint trong bảng PCB Library, rồi chọn Update PCB With <ComponentName> từ menu ngữ cảnh.
-
Bạn cũng có thể tự xác định diện tích của một linh kiện đã được đặt trên PCB bằng cách chọn linh kiện rồi nhập giá trị vào trường này.
-
Để chuyển từ diện tích do người dùng xác định sang diện tích được tính toán cho một linh kiện đã đặt trên PCB, hãy xóa giá trị trong trường này; trường sẽ tự động được điền lại bằng giá trị tính toán tự động.
-
Diện tích được tính toán tự động là vùng được tô sáng khi bạn nhấp để chọn linh kiện. Vùng chọn được xác định từ các đối tượng hình học trên lớp Courtyard; khi không có lớp này, vùng chọn được xác định từ tổ hợp các đối tượng hình học trên lớp Silkscreen, các đối tượng 3D Body và các lớp đồng (không bao gồm chuỗi văn bản). Các hình phía trên được hiển thị bên dưới minh họa diện tích linh kiện khi có đường bao được xác định trên lớp Courtyard; hình phía dưới minh họa diện tích khi được tính từ các đối tượng hình học trên lớp Silkscreen, các đối tượng 3D Body và các lớp đồng.
► Tìm hiểu thêm về cách tính toán vùng chọn và các chế độ khác có sẵn để xác định vùng chọn.
► Tìm hiểu thêm về Làm việc với các lớp cơ khí.
-
-
Description – mô tả ở cấp linh kiện cho linh kiện này. Thông thường, mô tả được xác định trong quá trình tạo linh kiện, nhưng cũng có thể chỉnh sửa/thêm mô tả cho linh kiện trên sơ đồ nguyên lý. Đây là mô tả được hiển thị trong bảng Components.
-
Type – chọn một trong các loại linh kiện sau cho footprint linh kiện tại đây. Các loại có sẵn gồm:
-
Standard– các linh kiện này có thuộc tính điện tiêu chuẩn, luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và các phép gán net đều phải khớp nhau), và được đưa vào BOM. Ví dụ là một linh kiện điện tiêu chuẩn, chẳng hạn như điện trở. -
Mechanical– các linh kiện này không có thuộc tính điện, không được đồng bộ (bạn phải đặt chúng theo cách thủ công trong cả hai trình chỉnh sửa), và được đưa vào BOM. Ví dụ là bộ tản nhiệt. -
Graphical– các linh kiện này không có thuộc tính điện, không được đồng bộ (bạn phải đặt chúng theo cách thủ công trong cả hai trình chỉnh sửa), và not được đưa vào BOM. Ví dụ là logo công ty. -
Net Tie (in BOM)– các linh kiện này được dùng để nối tắt hai hoặc nhiều net khác nhau với nhau. Chúng luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và các phép gán net đều phải khớp nhau), và được đưa vào BOM. Chúng khác với linh kiện Standard ở chỗ kết nối được tạo bởi phần đồng bên trong footprint không được kiểm tra – chính phần đồng này cho phép nối tắt các net. Lưu ý: bật tùy chọn Verify Shorting Copper trong hộp thoại Design Rule Checker để xác minh rằng không có phần đồng nào chưa được kết nối bên trong linh kiện. -
Net Tie– các linh kiện này được dùng để nối tắt hai hoặc nhiều net khác nhau với nhau. Chúng luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và các phép gán net đều phải khớp nhau), và not được đưa vào BOM. Chúng khác với linh kiện Standard ở chỗ kết nối được tạo bởi phần đồng bên trong footprint không được kiểm tra – chính phần đồng này cho phép nối tắt các net. Lưu ý: bật tùy chọn Verify Shorting Copper trong hộp thoại Design Rule Checker để xác minh rằng không có phần đồng nào chưa được kết nối trong linh kiện. -
Standard (No BOM)– các linh kiện này có thuộc tính điện tiêu chuẩn, luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và các phép gán net đều phải khớp nhau), và not được đưa vào BOM. Ví dụ là một linh kiện điểm kiểm tra mà bạn muốn loại khỏi BOM. -
Jumper– các linh kiện này được dùng để đưa cầu nối dây vào thiết kế PCB, ví dụ như trên PCB một mặt không thể đi dây hoàn toàn trên một lớp. Với loại linh kiện này, footprint và các chân linh kiện được đồng bộ giữa sơ đồ nguyên lý và PCB nhưng các phép gán net thì không, và linh kiện được đưa vào BOM. Ngoài việc chọn tùy chọn này ở cấp linh kiện, cả hai pad trong linh kiện phải có JumperID được đặt thành cùng một giá trị khác không. Các linh kiện loại Jumper không cần được nối dây trên sơ đồ nguyên lý; chỉ cần đưa chúng vào sơ đồ nguyên lý nếu chúng cần có trong BOM. Nếu không cần có trong BOM, chúng có thể được đặt trực tiếp trên PCB, tại đó Component Type được thiết lập, JumperIDs được thiết lập, và Nets được gán thủ công cho các pad.
-
-
Design Item ID – hiển thị Design Item ID của linh kiện được chọn. Không thể chỉnh sửa trường này.
-
Source – hiển thị tài liệu nguồn của linh kiện. Nhấp vào
để mở hộp thoại duyệt và chọn một tài liệu nguồn khác.
-
Revision State – hiển thị trạng thái của bản sửa đổi linh kiện thư viện Workspace xét theo trạng thái vòng đời và cả trạng thái bản sửa đổi, tức là liệu đó là bản sửa đổi được phát hành mới nhất của linh kiện đó (
Up to date) hay là một bản sửa đổi trước đó (Out of date). -
Height – trường chiều cao của linh kiện. Trường này được dùng để xác định chiều cao của linh kiện PCB trước khi có đối tượng 3D Body; tuy nhiên, mô hình 3D cung cấp phương pháp tốt hơn để xác định chiều cao linh kiện cho các tác vụ như phát hiện va chạm 3D. Lưu ý rằng Altium MCAD CoDesigner sử dụng giá trị được xác định trong trường Height này, chứ không phải chiều cao của mô hình 3D (tìm hiểu thêm).
-
3D Body Opacity – nhập tỷ lệ phần trăm độ mờ đục mong muốn hoặc sử dụng thanh trượt.
-
Primitives – nhấp vào biểu tượng khóa tương ứng để khóa/mở khóa.
– khóa tất cả các đối tượng nguyên thủy của linh kiện để có thể xử lý linh kiện như một đối tượng duy nhất.
– mở khóa để chỉnh sửa từng đối tượng nguyên thủy cấu thành linh kiện. Sau khi chỉnh sửa, cần khóa lại các đối tượng nguyên thủy của linh kiện.
-
Strings – nhấp vào biểu tượng khóa tương ứng để khóa/mở khóa.
– khóa tất cả các chuỗi văn bản của linh kiện.
– mở khóa để chỉnh sửa các chuỗi văn bản của linh kiện.
Footprint
- Footprint Name – hiển thị tên footprint tương ứng với linh kiện đã chọn.
- Design Item ID – thông tin nhận dạng của linh kiện đã chọn.
- Source – tên của Workspace chứa linh kiện đã chọn.
- Description – mô tả footprint của linh kiện, được xác định trong trình chỉnh sửa footprint PCB.
Tùy chọn hoán đổi
- Enable Pin Swapping – chọn để cho phép chức năng hoán đổi chân.
- Enable Part Swapping – chọn để cho phép chức năng hoán đổi phần tử (ví dụ: bốn phần tử của một IC dòng 74).
Thông tin tham chiếu sơ đồ nguyên lý
- Designator – ký hiệu định danh của linh kiện trên sơ đồ nguyên lý đã được ghép với linh kiện PCB này.
- Hierarchical Path – hiển thị vị trí có thể tìm thấy linh kiện này trong cấu trúc phân cấp của sơ đồ nguyên lý.
- Channel Offset – khi một thiết kế được chuyển từ sơ đồ nguyên lý sang PCB lần đầu, mỗi linh kiện trên mỗi trang sơ đồ nguyên lý được gán một độ lệch kênh duy nhất.
Tab Tham số
- Table – hiển thị Name, Value và Source của từng tham số được liệt kê.
Ký hiệu định danh và chú thích của linh kiện
Các trường ký hiệu định danh và chú thích là các đối tượng tham số con của một linh kiện (phần tử) PCB. Ký hiệu định danh được dùng để nhận diện duy nhất từng phần tử đã đặt, nhằm phân biệt nó với tất cả các phần tử khác được đặt trong mọi tài liệu PCB của dự án. Chú thích được dùng để bổ sung thông tin cho một đối tượng đã đặt. Cả chú thích và ký hiệu định danh đều được cấu hình sau khi đối tượng linh kiện cha được đặt. Đây không phải là đối tượng thiết kế mà bạn có thể đặt trực tiếp.

Một đối tượng Ký hiệu định danh đã đặt

Một đối tượng Chú thích đã đặt
Ký hiệu định danh của linh kiện PCB 2D/3D sẽ tự động tăng thêm một trong quá trình đặt nếu linh kiện ban đầu có ký hiệu định danh kết thúc bằng một chữ số. Thay đổi ký hiệu định danh của linh kiện đầu tiên trước khi đặt trong bảng Thuộc tính.
Để tăng ký hiệu định danh theo chữ cái hoặc số với bước tăng khác 1, hãy sử dụng tính năng Paste Array. Các điều khiển cho tính năng này có trong hộp thoại Thiết lập mảng dán, được truy cập bằng cách nhấn nút Paste Array trong hộp thoại Paste Special (Edit » Paste Special).
Phương pháp chỉnh sửa đồ họa cho phép bạn chọn trực tiếp đối tượng ký hiệu định danh hoặc chú thích đã đặt trong không gian thiết kế và thay đổi vị trí, góc xoay, hướng và kích thước của nó.
Khi một đối tượng ký hiệu định danh hoặc chú thích được chọn, các tay nắm chỉnh sửa sau sẽ xuất hiện:

Một Ký hiệu định danh được chọn
- Nhấp và kéo B để xoay ký hiệu định danh/chú thích quanh điểm tham chiếu của nó A (được biểu thị bằng dấu x nhỏ).
- Nhấp và kéo C để thay đổi đồng thời kích thước khung bao của ký hiệu định danh/chú thích theo cả chiều dọc và chiều ngang.
- Nhấp và kéo D để thay đổi riêng kích thước khung bao của ký hiệu định danh/chú thích theo chiều dọc hoặc chiều ngang.
-
Nhấp vào vị trí bất kỳ trên ký hiệu định danh/chú thích, ngoài các tay nắm chỉnh sửa, rồi kéo để di chuyển nó. Trong khi kéo, có thể xoay hoặc lật đối xứng chú thích:
- Nhấn Spacebar để xoay ký hiệu định danh/chú thích ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Góc xoay tuân theo giá trị của Rotation Step được xác định trên trang Trình chỉnh sửa PCB – Chung của hộp thoại Preferences.
- Nhấn phím X hoặc Y để lật đối xứng ký hiệu định danh/chú thích theo trục X hoặc trục Y.
Có thể thay đổi các thuộc tính của đối tượng Ký hiệu định danh hoặc Chú thích trong chế độ Parameter của bảng Properties.
Thuộc tính tham số

Chế độ Parameter của bảng Properties.
Vị trí
-
(X/Y)
-
X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của ký hiệu định danh so với gốc tọa độ hiện tại của không gian làm việc. Chỉnh sửa để thay đổi vị trí X của ký hiệu định danh. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
-
Y (trường thứ hai) - Tọa độ Y (dọc) hiện tại của điểm tham chiếu của ký hiệu định danh so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của ký hiệu định danh. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
-
- Rotation - góc xoay của ký hiệu định danh (tính bằng độ) được đo ngược chiều kim đồng hồ từ góc không (phương ngang 3 o'clock). Chỉnh sửa để thay đổi góc xoay của ký hiệu định danh. Độ phân giải góc tối thiểu là 0,001°.
Thuộc tính
-
Parameter type - hiển thị loại tham số (Linh kiện, Ký hiệu trang sơ đồ, v.v.) và tên tham số.
-
Name - tên của ký hiệu định danh.
-
Value - sử dụng trường này để nhập giá trị mong muốn của ký hiệu định danh. Nhấp vào biểu tượng con mắt để bật/tắt hiển thị giá trị trong không gian thiết kế.
-
Layer - sử dụng danh sách thả xuống để chọn lớp mong muốn. Bật Mirror nếu cần.
-
Autoposition - sử dụng danh sách thả xuống để chọn vị trí tự động mong muốn so với đối tượng liên quan.
-
Text Height - sử dụng trường này để nhập chiều cao văn bản mong muốn.
-
Font Type
-
TrueType - chọn để sử dụng các phông chữ có sẵn trên PC của bạn (trong thư mục \Windows\Fonts ). Phông chữ TrueType hỗ trợ Unicode đầy đủ. Theo mặc định, phần mềm liên kết đến phông chữ TrueType được sử dụng (phông chữ không được lưu trong tệp PCB), nghĩa là mỗi PC mà thiết kế được chuyển đến đều phải có cùng phông chữ đó. Ngoài ra, bạn có thể nhúng các phông chữ TrueType được sử dụng vào tệp PCB bằng các tùy chọn trên trang PCB Editor - True Type Fonts của hộp thoại Preferences, tại đây bạn cũng có thể chọn một Substitution Font để sử dụng nếu phông chữ không được nhúng không có sẵn.
-
Justification - sử dụng để đặt vị trí của ký hiệu định danh trong hình chữ nhật bao quanh.
- Left - nhấp vào nút bên trái để căn văn bản theo phương ngang sang trái.
- Center - nhấp vào nút ở giữa để căn giữa văn bản theo phương ngang.
- Right - nhấp vào nút bên trái để căn văn bản theo phương ngang sang phải.
- Above - nhấp vào nút phía trên để căn văn bản theo phương dọc lên trên.
- Middle - nhấp vào nút ở giữa để căn giữa văn bản theo phương dọc.
- Below - nhấp vào nút phía dưới để căn văn bản theo phương dọc xuống dưới.
-
Font - sử dụng danh sách thả xuống để chọn phông chữ TrueType mong muốn. Sử dụng các tùy chọn B (bold) và/hoặc I (italic) để nhấn mạnh văn bản theo yêu cầu.
-
Inverted - sử dụng để hiển thị văn bản ở dạng đảo ngược và kiểm soát kích thước đường viền xung quanh văn bản. Bạn có thể sử dụng các tùy chọn sau để cấu hình thêm cho văn bản:
-
Size (Width/Height) -
- Width - chiều rộng của hình chữ nhật bao quanh.
- Height - chiều cao của hình chữ nhật bao quanh.
-
Size (Width/Height) -
-
Inverted - sử dụng để hiển thị văn bản ở dạng đảo ngược và kiểm soát kích thước đường viền xung quanh văn bản. Bạn có thể sử dụng các tùy chọn sau để cấu hình thêm cho văn bản:
-
-
Stroke
-
Justification - sử dụng để đặt vị trí của ký hiệu định danh trong hình chữ nhật bao quanh.
- Left - nhấp vào nút bên trái để căn văn bản theo phương ngang sang trái.
- Center - nhấp vào nút ở giữa để căn giữa văn bản theo phương ngang.
- Right - nhấp vào nút bên trái để căn văn bản theo phương ngang sang phải.
- Above - nhấp vào nút phía trên để căn văn bản theo phương dọc lên trên.
- Middle - nhấp vào nút ở giữa để căn giữa văn bản theo phương dọc.
- Below - nhấp vào nút phía dưới để căn văn bản theo phương dọc xuống dưới.
-
Font - sử dụng danh sách thả xuống để chọn phông chữ nét mong muốn. Các lựa chọn gồm:
-
Default- phông chữ vectơ đơn giản được thiết kế để vẽ bằng bút và quang vẽ vectơ. -
Sans Serif- phông chữ phức tạp sẽ làm chậm quá trình tạo đầu ra vectơ, chẳng hạn như Gerber. -
Serif- phông chữ phức tạp sẽ làm chậm quá trình tạo đầu ra vectơ, chẳng hạn như Gerber.
-
- Stroke Width - hiển thị độ rộng nét.
-
Justification - sử dụng để đặt vị trí của ký hiệu định danh trong hình chữ nhật bao quanh.
-
TrueType - chọn để sử dụng các phông chữ có sẵn trên PC của bạn (trong thư mục \Windows\Fonts ). Phông chữ TrueType hỗ trợ Unicode đầy đủ. Theo mặc định, phần mềm liên kết đến phông chữ TrueType được sử dụng (phông chữ không được lưu trong tệp PCB), nghĩa là mỗi PC mà thiết kế được chuyển đến đều phải có cùng phông chữ đó. Ngoài ra, bạn có thể nhúng các phông chữ TrueType được sử dụng vào tệp PCB bằng các tùy chọn trên trang PCB Editor - True Type Fonts của hộp thoại Preferences, tại đây bạn cũng có thể chọn một Substitution Font để sử dụng nếu phông chữ không được nhúng không có sẵn.
-
Border Mode
-
Margin - nhấp vào nút này để cho phép chỉnh sửa tùy chọn Đường viền lề.
- Text Offset - khoảng lùi của ký hiệu định danh so với cạnh/góc mà nó được căn theo. Tùy chọn này không có tác dụng khi chọn chế độ căn chỉnh Center . Tùy chọn này không khả dụng đối với Margin.
-
Offset - nhấp vào nút này để cho phép chỉnh sửa tùy chọn Độ lệch văn bản.
- Margin Border - sử dụng để chỉ định kích thước đường viền lề bao quanh ký hiệu định danh. Tùy chọn này không khả dụng đối với Offset.
-
Margin - nhấp vào nút này để cho phép chỉnh sửa tùy chọn Đường viền lề.
Tính sẵn có của linh kiện trên PCB
Khi thiết kế được chuyển từ trình biên tập sơ đồ nguyên lý sang trình biên tập PCB, các footprint linh kiện PCB được tự động đặt từ các thư viện có sẵn. Đây được gọi là Đồng bộ hóa thiết kế, một quá trình phát hiện và giải quyết các khác biệt giữa sơ đồ nguyên lý và PCB.
Altium Designer hỗ trợ một bộ công cụ giúp đặt footprint linh kiện cần thiết vào không gian thiết kế PCB. Xem các trang sau để tìm hiểu về những công cụ này:
Duyệt các linh kiện đã đặt
Ở chế độ Components của bảng PCB, ba vùng chính của bảng thay đổi để phản ánh cấu trúc phân cấp linh kiện của thiết kế PCB hiện tại (theo thứ tự từ trên xuống):
- Component Classes
- Components trong một lớp
- Component Primitives

Các vùng của bảng PCB cho phép lựa chọn bộ lọc tích lũy từ các lớp linh kiện đến từng linh kiện, rồi đến các đối tượng cơ bản của linh kiện.
Nhấp chuột phải vào một mục linh kiện hoặc đối tượng cơ bản của linh kiện, sau đó chọn lệnh Properties (hoặc nhấp đúp trực tiếp vào mục đó) để truy cập bảng Properties, nơi bạn có thể xem/sửa đổi các thuộc tính của linh kiện/đối tượng cơ bản theo yêu cầu.
Nhấp chuột phải vào một mục lớp linh kiện, sau đó chọn Properties (hoặc nhấp đúp trực tiếp vào mục đó) để mở hộp thoại Chỉnh sửa lớp linh kiện cho lớp đó. Từ hộp thoại này, bạn có thể xem/sửa đổi các linh kiện thuộc lớp, đổi tên lớp hoặc thêm các lớp khác.

Chỉnh sửa một lớp linh kiện đã chọn.
Việc hiển thị/bao gồm từng loại đối tượng cơ bản của linh kiện trong vùng Component Primitives của bảng phụ thuộc vào việc tùy chọn tương ứng cho từng loại đã được bật hay chưa trong menu chuột phải được truy cập từ vùng Components hoặc Component Primitives.

Nhấp chuột phải vào một mục linh kiện hoặc đối tượng cơ bản của linh kiện để chọn các mục cần bao gồm.
Trong khi duyệt, bạn có thể dễ dàng khóa hoặc mở khóa linh kiện bằng cách nhấp đúp vào ô bên phải cột Footprint trong vùng Components.

Khóa/Mở khóa từ bảng PCB giúp bạn không phải thao tác qua bảng Properties.
Khung bao chọn linh kiện
Khi bạn nhấp và chọn một linh kiện, khung bao vùng chọn sẽ xuất hiện. Để kiểm soát những lớp được dùng để xác định khung bao, bạn có thể sử dụng tùy chọn PCB.ComponentSelection trong hộp thoại Advanced Settings. Tùy chọn này hỗ trợ ba chế độ (nhập giá trị 0, 1 hoặc 2; chế độ mặc định là 2):
-
0 - legacy mode- chế độ này kết hợp các hình dạng hình học từ tất cả các lớp, ngoại trừ các chuỗi ký hiệu định danh và chú thích trên lớp in lụa. -
1 - by layer mode- sử dụng các hình dạng hình học từ lớp đầu tiên có chứa đối tượng trong danh sách dưới đây, theo thứ tự ưu tiên sau:-
Loại lớp Courtyard
-
Lớp thân 3D (các mô hình STEP được lưu trong một đối tượng thân 3D có kích thước bằng khối hộp chữ nhật nhỏ nhất bao chứa mô hình. Khi chọn linh kiện, thân 3D này được sử dụng, chứ không phải hình dạng của mô hình STEP)
-
Lớp in lụa cộng với các lớp đồng
-
Các lớp đồng
-
-
2 - by graphic mode- chế độ này kết hợp các hình dạng hình học được phát hiện trên loại lớp Courtyard, lớp in lụa, các đối tượng thân 3D và các lớp đồng. Các chuỗi văn bản được loại trừ.
Thêm đối tượng cơ bản vào linh kiện
Có thể thêm các đối tượng cơ bản đã chọn vào một linh kiện bằng cách chọn lệnh Tools » Convert » Add Selected Primitives to Component từ các menu chính. Sau khi chọn lệnh, hãy chọn linh kiện mà bạn muốn thêm các đối tượng cơ bản đã chọn vào. Khi được xác nhận, các đối tượng cơ bản mới sẽ được nhận diện là một phần của đối tượng linh kiện duy nhất và có thể được sử dụng kết hợp với các đối tượng cơ bản ban đầu của linh kiện.
Các đối tượng cơ bản của linh kiện đích phải được mở khóa để thực hiện thao tác này. Sử dụng biểu tượng khóa Primitives trong phần thuộc tính của linh kiện để mở khóa các đối tượng cơ bản của linh kiện.
Tách linh kiện thành các đối tượng cơ bản
Có thể chuyển một linh kiện thành các đối tượng cơ bản cấu thành nó bằng lệnh Tools » Convert » Explode Component to Free Primitives từ các menu chính hoặc bằng cách nhấp chuột phải lên một linh kiện đã được đặt (dù được chọn hay chưa), rồi chọn lệnh Component Actions » Explode Component To Free Primitives (hoặc Explode Selected Components To Free Primitives) từ menu ngữ cảnh. Linh kiện sau khi tách không còn là một linh kiện nữa, vì vậy ký hiệu định danh và chú thích sẽ bị xóa, còn linh kiện sẽ trở lại thành các đối tượng cơ bản đã tạo nên nó.
Thao tác tách không ảnh hưởng đến mô hình footprint được lưu trong thư viện nguồn tương ứng, mà chỉ tác động đến các phiên bản linh kiện được chuyển đổi đã được đặt trên tài liệu PCB.
Truy cập các liên kết có thể nhấp đến thông tin tham khảo
Khi các liên kết tài liệu có tên đã được thêm vào linh kiện, bạn có thể mở URL tài liệu/trang được chỉ định — thông qua một tham số liên kết URL nền đã được định nghĩa — cho linh kiện đang được chọn hoặc linh kiện dưới con trỏ. Tính năng này cho phép các liên kết tài liệu có tên được chuyển từ linh kiện trên sơ đồ nguyên lý hiển thị dưới dạng các liên kết có tên của linh kiện PCB đến tệp PDF, tệp văn bản hoặc trang HTML. Điều này xảy ra khi các liên kết tài liệu có tên của linh kiện được cập nhật từ sơ đồ nguyên lý sang PCB (Design » Update PCB Document). Trong quá trình cập nhật đó (thông qua ECO), các liên kết tài liệu có tên trên sơ đồ nguyên lý được chuyển thành các cặp tham số ComponentLink (ComponentLinknDescription/ComponentLinknURL) cho linh kiện PCB tương ứng. Ví dụ:
| Tham số linh kiện trên sơ đồ nguyên lý | Các tham số linh kiện PCB | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
Số chỉ mục liên kết (n) được dùng trong các tham số linh kiện sẽ xác định vị trí theo thứ tự của liên kết linh kiện PCB tương ứng trong menu con References. Khi một linh kiện trên PCB được chọn, các cặp tham số ComponentLink đã định nghĩa sẽ hiển thị trong mục Parameters của bảng Properties.
Sau khi chạy lệnh, trang đích của URL trên web hoặc tài liệu được chỉ định sẽ mở trực tiếp (nếu có).

).