Kỹ thuật bố trí và chỉnh sửa PCB
Sơ lược
- Hiểu sự khác biệt giữa đối tượng nguyên thủy và đối tượng nhóm, cũng như ảnh hưởng của sự khác biệt này đến việc đặt và thao tác với đối tượng trong trình chỉnh sửa PCB.
- Tìm hiểu quy trình chỉnh sửa thông thường trước, trong và sau khi đặt đối tượng, bao gồm thiết lập giá trị mặc định, truy cập Properties và chuyển đổi đơn vị hiển thị.
- Khám phá các lệnh chọn đối tượng PCB giúp bạn làm việc với các đối tượng chồng lấp, cấu trúc phân cấp net logic, vùng đồng liên thông và chọn các đường đi dây theo linh kiện.
Có nhiều loại đối tượng để sử dụng khi thiết kế PCB. Hầu hết các đối tượng được đặt trong tài liệu PCB sẽ xác định các vùng đồng hoặc vùng trống. Điều này áp dụng cho cả đối tượng điện, như đường mạch và pad, lẫn đối tượng phi điện, như văn bản và kích thước. Vì vậy, cần lưu ý độ rộng của các đường dùng để xác định từng đối tượng và lớp mà đối tượng được đặt.
Có hai loại đối tượng trong trình chỉnh sửa PCB – đối tượng nguyên thủy và đối tượng nhóm:
-
Đối tượng nguyên thủy là các phần tử cơ bản của thiết kế, bao gồm đường mạch, pad, via, vùng tô, cung tròn và đối tượng văn bản. Chúng được gọi là 'nguyên thủy' vì có tính chất sơ khai hoặc cơ bản nhất.
-
Bất kỳ đối tượng nào được tạo thành từ các đối tượng nguyên thủy và được xác định là một đối tượng thiết kế đều là đối tượng nhóm. Ví dụ về đối tượng nhóm bao gồm linh kiện, kích thước và vùng đổ đồng đa giác. Có thể thao tác với đối tượng nhóm như một đối tượng duy nhất trong không gian thiết kế. Ví dụ, có thể đặt, chọn, sao chép, thay đổi, di chuyển và xóa đối tượng đó.
Điểm chung khi đặt và chỉnh sửa đối tượng
Trong Altium Designer, quy trình đặt đối tượng gần như giống nhau bất kể loại đối tượng được đặt. Ở mức đơn giản nhất, quy trình như sau:
-
Chọn đối tượng cần đặt từ một trong các thanh công cụ hoặc menu Place .
-
Dùng chuột để xác định vị trí của đối tượng được đặt trong không gian thiết kế của trình chỉnh sửa PCB và kích thước của đối tượng (nếu áp dụng).
-
Nhấp chuột phải (hoặc nhấn Esc) để kết thúc lệnh và thoát chế độ đặt.
Chỉnh sửa trước khi đặt
Có thể thay đổi các thuộc tính mặc định của đối tượng bất cứ lúc nào trên trang Trình chỉnh sửa PCB – Mặc định của hộp thoại Preferences . Các thuộc tính này sẽ được áp dụng khi đặt những đối tượng tiếp theo.

Sử dụng cột Primitives để truy cập các thuộc tính của đối tượng và chỉnh sửa giá trị mặc định theo nhu cầu.
Chỉnh sửa trong khi đặt
Có thể chỉnh sửa một số thuộc tính ngay khi đặt đối tượng lần đầu. Để truy cập các thuộc tính này, nhấn phím Tab khi đang ở chế độ đặt để mở bảng Properties tương ứng. Nhấn phím Tab sẽ tạm dừng thao tác đặt để bạn thực hiện các chỉnh sửa cần thiết cho đối tượng.
Ví dụ về hộp thoại thuộc tính của đối tượng Pad .
Sau khi chỉnh sửa xong, nhấp vào nút tạm dừng hiển thị đè trên không gian thiết kế (
) để tiếp tục đặt.
Chỉnh sửa sau khi đặt
Sau khi đặt đối tượng, bạn có thể chỉnh sửa đối tượng theo một số cách. Các cách này được mô tả bên dưới.
Bảng hoặc hộp thoại thuộc tính tương ứng
Phương pháp chỉnh sửa này sử dụng chế độ bảng Properties và hộp thoại tương ứng để sửa đổi thuộc tính của đối tượng đã đặt.
Sau khi đặt, có thể truy cập hộp thoại tương ứng bằng cách:
-
Nhấp đúp vào đối tượng đã đặt.
-
Đặt con trỏ lên đối tượng, nhấp chuột phải rồi chọn Properties từ menu ngữ cảnh.
Sau khi đặt, có thể truy cập chế độ tương ứng của bảng Properties theo một trong các cách sau:
- Nếu bảng Properties đã được kích hoạt, hãy chọn đối tượng.
- Sau khi chọn đối tượng, chọn bảng Properties từ nút Panels ở góc dưới bên phải không gian thiết kế hoặc chọn View » Panels » Properties từ các menu chính.
Các lệnh chọn đối tượng PCB
Ngoài các lệnh chọn/bỏ chọn đối tượng tiêu chuẩn, trình chỉnh sửa PCB còn có một số lệnh đặc biệt giúp thao tác chọn/bỏ chọn đối tượng thuận tiện hơn. Có thể truy cập các lệnh này từ các menu con Edit » Select và Edit » DeSelect trong các menu chính. Cũng có thể truy cập các lệnh chọn từ menu của nút
trong Active Bar.
-
Select overlapped - dùng để chọn riêng đối tượng thiết kế tiếp theo trong một tập hợp các đối tượng cùng vị trí (chồng lấp) mà không cần dùng cửa sổ chọn bật lên. Việc chọn tuân theo thứ tự ưu tiên cố định sau đây và luân phiên theo thứ tự này mỗi lần sử dụng lệnh:
- Pad
- Via
- Đường mạch/Cung tròn
- Linh kiện
- Đa giác
- Vùng/Vùng tô
- Văn bản
Ngoài ra, khi dùng phím Shift để thêm đối tượng vào tập hợp đang chọn, bạn có thể dùng Shift+Tab để lần lượt chọn các đối tượng chồng lấp mà không làm mất các đối tượng đã chọn ban đầu.
-
Select next (phím tắt: Tab) - khi đã chọn một đối tượng ban đầu trong thiết kế, lệnh này được dùng để mở rộng vùng chọn nhằm bao gồm đối tượng (hoặc các đối tượng) ở cấp cao hơn tiếp theo theo phân cấp logic. Các chuỗi chọn theo logic có tính tuần hoàn sau được hỗ trợ:
- Đoạn đường mạch ---> Tất cả đường mạch nối liền (liên tục) trên cùng một lớp ---> Tất cả phần đồng được nối liền ---> Tất cả đối tượng điện trong net liên quan
- Pad đã kết nối ---> Tất cả đường mạch nối liền (liên tục) trên cùng một lớp ---> Tất cả phần đồng được nối liền ---> Tất cả đối tượng điện trong net liên quan
- Pad chưa kết nối ---> Tất cả đối tượng điện trong net liên quan
- Via ---> Tất cả đường mạch nối liền (liên tục) trên các lớp liên quan đến via ---> Tất cả phần đồng được nối liền ---> Tất cả đối tượng điện trong net liên quan
- Đồng (Vùng/Vùng đổ đồng/Vùng tô đồng) ---> Tất cả phần đồng được nối liền ---> Tất cả đối tượng điện trong net liên quan
- Pad/Via tự do ---> Tất cả đường mạch nối liền (liên tục) trên cùng lớp với pad hoặc trên các lớp liên quan đến via ---> Tất cả phần đồng được nối liền ---> Tất cả đối tượng điện trong net liên quan.
- Linh kiện ---> Fanout qua via, đường thoát, đường liên kết
Ngoài ra, tính năng này còn hỗ trợ mở rộng vùng chọn cho nhiều đối tượng thuộc các net khác nhau trong thiết kế.

Ví dụ về việc chọn trên nhiều net, mở rộng từ các đoạn đường mạch được chọn ban đầu lên các cấp cao hơn trong phân cấp logic.Lệnh này đặc biệt hữu ích khi chọn các net đã đi dây. Tìm hiểu thêm về Các phương pháp chọn đường mạch.
-
Board - dùng để chọn tất cả đối tượng nằm trong ranh giới của hình dạng bo mạch đã xác định.
-
Net - dùng để chọn tất cả đối tượng điện thuộc một net cụ thể.
Sau khi khởi chạy lệnh, bạn có thể nhấp vào một đối tượng điện hoặc kết nối để chọn tất cả đối tượng điện trong net liên quan. Hoặc, nếu biết tên net muốn chọn, hãy nhấp vào một vùng của thiết kế không có đối tượng nào; hộp thoại Net Name sẽ mở ra. Từ đó, bạn có thể nhập tên net mong muốn; net đó sẽ được chọn khi bạn đóng hộp thoại. Nếu không chắc tên net, hãy nhập ? rồi nhấp OK để mở hộp thoại Nets Loaded, trong đó liệt kê tất cả các net hiện được tải cho thiết kế.
-
Connected Copper - dùng để chọn tất cả đối tượng điện được nối với cùng một phần đồng.
-
Physical Connection - dùng để chọn tất cả đường mạch đã đi dây thực tế giữa các đối tượng pad. Nhấp vào một đường mạch, pad hoặc via; tất cả đường mạch liên tục đến pad tiếp theo sẽ được chọn, bao gồm cả các via (bản thân các pad sẽ không được đưa vào vùng chọn).
-
Physical Connection Single Layer - dùng để chọn tất cả đường mạch đã đi dây thực tế giữa các đối tượng pad trên một lớp duy nhất. Nhấp vào một đường mạch hoặc via; tất cả đường mạch liên tục trên cùng lớp đến pad tiếp theo sẽ được chọn (bản thân các pad và via sẽ không được đưa vào vùng chọn).
-
Component Connections - dùng để chọn tất cả kết nối đã đi dây xuất phát từ các pad của linh kiện được chọn (bao gồm đường mạch và via) đến pad tiếp theo gặp được trên mỗi kết nối. Bản thân các pad sẽ không được đưa vào vùng chọn.
Bạn cũng có thể truy cập lệnh này bằng cách nhấp chuột phải lên một linh kiện đã đặt, rồi chọn lệnh Component Actions » Select Component Connections từ menu ngữ cảnh.
-
Component Nets - dùng để chọn tất cả các net (và các đối tượng thuộc những net đó) nối với linh kiện được chọn trong tài liệu hiện tại.
Bạn cũng có thể truy cập lệnh này bằng cách nhấp chuột phải lên một linh kiện đã đặt, rồi chọn lệnh Component Actions » Select Component Nets từ menu ngữ cảnh.
-
Room Connections - dùng để chọn tất cả kết nối đã đi dây giữa các pad nằm hoàn toàn trong ranh giới của room được chọn trong tài liệu hiện tại.
Bạn cũng có thể truy cập lệnh này bằng cách nhấp chuột phải lên một room đã đặt, rồi chọn lệnh Room Actions » Select Room Connections từ menu ngữ cảnh.
-
All on Layer - dùng để chọn/bỏ chọn tất cả đối tượng trên lớp hiện tại.
-
Free Objects - dùng để chọn tất cả đối tượng cơ bản tự do trong thiết kế. Các đối tượng linh kiện, tọa độ, kích thước, hiệu chỉnh chiều dài, OLE và vùng đổ đồng đều là đối tượng nhóm, do đó sẽ không bị ảnh hưởng bởi lệnh này.
-
All Locked - dùng để chọn tất cả đối tượng thiết kế có thuộc tính Locked được bật.
-
Off Grid Pads - dùng để chọn tất cả pad không nằm trên lưới bắt điểm hiện tại.
Chỉnh sửa đồ họa
Phương pháp chỉnh sửa này cho phép bạn chọn trực tiếp một đối tượng đã đặt trong không gian thiết kế và thay đổi kích thước, hình dạng hoặc vị trí bằng thao tác đồ họa. Việc thay đổi hình dạng và/hoặc kích thước (nếu áp dụng) được thực hiện thông qua các “điểm điều khiển” chỉnh sửa xuất hiện khi đối tượng được chọn.

Ví dụ về các điểm điều khiển chỉnh sửa của một đối tượng Fill được chọn.
Nhấp vào vị trí bất kỳ trên đối tượng ngoài các điểm điều khiển chỉnh sửa (nếu có) để kéo đối tượng đến vị trí mới. Tùy theo loại đối tượng, bạn có thể xoay và/hoặc lật đối tượng trong khi kéo.
- Nhấn Spacebar để xoay đối tượng ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Góc xoay tuân theo giá trị của Rotation Step được xác định trên trang PCB Editor – General trong hộp thoại Preferences.
- Nhấn phím L để lật đối tượng sang mặt còn lại của bo mạch (nếu áp dụng).
- Nhấn phím X hoặc Y để lật đối tượng theo trục X hoặc trục Y nếu áp dụng.
- Nhấn phím Alt để giới hạn hướng di chuyển theo trục ngang hoặc trục dọc tùy theo hướng di chuyển ban đầu.
- Dịch chuyển đối tượng từng bước nhỏ (theo giá trị lưới bắt dính hiện tại) bằng cách nhấn các phím mũi tên trong khi giữ phím Ctrl . Dịch chuyển từng bước lớn hơn (gấp 10 lần giá trị lưới bắt dính) bằng cách nhấn các phím mũi tên trong khi giữ các phím Ctrl+Shift.
Các lệnh di chuyển
Có thể thay đổi vị trí đối tượng bằng các lệnh trong menu con Edit » Move của các menu chính hoặc menu con di chuyển trong Active Bar.
-
Move - lệnh này dùng để di chuyển bất kỳ đối tượng nào trong tài liệu hiện tại. Mọi net gắn với đối tượng vẫn được kết nối và các đường kết nối sẽ đi theo đối tượng khi đối tượng được di chuyển (có hiển thị hay không tùy theo chế độ kết nối đang áp dụng). Các đường mạch đã đi dây kết nối với đối tượng sẽ không được di chuyển.
-
Drag - lệnh này dùng để di chuyển bất kỳ đối tượng nào trong tài liệu hiện tại. Nếu đối tượng có các đường mạch và/hoặc cung tròn kết nối với nó (ví dụ: linh kiện, pad hoặc via), các đối tượng này sẽ duy trì kết nối khi đối tượng được di chuyển.
-
Component - lệnh này cho phép bạn di chuyển các linh kiện trong tài liệu hiện tại. Sau khi khởi chạy lệnh, nhấp vào linh kiện trong thiết kế mà bạn muốn di chuyển, đưa linh kiện đến vị trí mong muốn rồi nhấp chuột. Ngoài ra, bạn có thể nhấp vào vùng trống trong không gian thiết kế để mở hộp thoại Chọn linh kiện. Dùng hộp thoại này để tìm linh kiện cần di chuyển (bằng cách chuyển đến linh kiện hoặc đưa linh kiện đến con trỏ), rồi đặt lại vị trí theo cách đã mô tả ở trên. Lưu ý rằng tính năng này chỉ hoạt động nếu linh kiện đích not bị khóa.
Bạn cũng có thể truy cập lệnh bằng cách nhấp chuột phải lên một linh kiện trong không gian thiết kế rồi chọn lệnh Component Actions » Move Component từ menu ngữ cảnh.
-
Move Selection - lệnh này cho phép bạn đặt lại vị trí thủ công cho các đối tượng đã chọn trong tài liệu hiện tại. Mọi net gắn với một đối tượng trong vùng chọn vẫn được kết nối và các đường kết nối sẽ đi theo đối tượng khi đối tượng được di chuyển (có hiển thị hay không tùy theo chế độ kết nối đang áp dụng). Các đường mạch đã đi dây kết nối với đối tượng sẽ không được di chuyển.
-
Move Selection by X, Y - lệnh này dùng để dịch chuyển các đối tượng đang được chọn một khoảng chính xác theo hướng X và/hoặc Y. Sau khi khởi chạy lệnh, hộp thoại Get X/Y Offsets sẽ mở ra. Dùng hộp thoại này để chỉ định các giá trị gia số delta X và/hoặc delta Y để dịch chuyển vùng chọn.

Hộp thoại Get X/Y OffsetsCác tùy chọn và điều khiển của hộp thoại Get X/Y Offsets
- X Offset - dùng trường này để chỉ định khoảng cách dịch chuyển vùng chọn theo trục ngang. Có thể nhập giá trị dương hoặc âm tùy theo hướng di chuyển mong muốn. Dùng nút bên phải trường này để nhanh chóng chuyển giá trị đã nhập giữa dương và âm.
- Y Offset - dùng trường này để chỉ định khoảng cách dịch chuyển vùng chọn theo trục dọc. Có thể nhập giá trị dương hoặc âm tùy theo hướng di chuyển mong muốn. Dùng nút bên phải trường này để nhanh chóng chuyển giá trị đã nhập giữa dương và âm.
- Toggle X/Y Offsets - nhấp nút này để nhanh chóng hoán đổi các giá trị độ lệch. Giá trị X Offset sẽ được dùng làm giá trị Y Offset và ngược lại.
- Reset X/Y Offsets - nhấp nút này để nhanh chóng đặt lại cả hai giá trị độ lệch về không.
- Define X/Y Offsets Interactively - nhấp nút này để tính toán độ lệch bằng thao tác tương tác. Bạn sẽ được chuyển đến không gian làm việc và lần lượt được yêu cầu chọn điểm đầu và điểm cuối. Nhấp vào các vị trí mong muốn; các giá trị dX và dY sẽ được điền lần lượt vào các trường X Offset và Y Offset.
-
Rotate Selection - lệnh này được dùng để xoay các đối tượng đã chọn trong không gian thiết kế ngược chiều kim đồng hồ hoặc cùng chiều kim đồng hồ theo một góc xoay xác định. Sau khi chạy lệnh, hộp thoại Rotation Angle (Degrees) sẽ mở ra. Nhập góc xoay mong muốn từ 0.001° đến 360.00° (độ phân giải 0.001°). Nhập giá trị dương để xoay ngược chiều kim đồng hồ hoặc giá trị âm để xoay cùng chiều kim đồng hồ. Nhấp vào OK để đóng hộp thoại, sau đó đặt con trỏ và nhấp để xác định điểm tham chiếu cho phép xoay. Các đối tượng đã chọn sẽ được xoay quanh điểm tham chiếu theo góc đã nhập.

Hộp thoại Rotation Angle -
Flip Selection - lật các đối tượng đã chọn theo chiều ngang (quanh trục Y) sang lớp tương ứng ở mặt đối diện của bo mạch. Ví dụ, các đối tượng trên Top Layer sẽ được lật sang Bottom Layer, các đối tượng trên Top Overlay sẽ được lật sang Bottom Overlay, v.v.
Các lệnh căn chỉnh
Cũng có thể di chuyển các đối tượng bằng cách thay đổi cách căn chỉnh chúng. Để căn chỉnh các đối tượng với những đối tượng khác, nhấp chuột phải vào một đối tượng đã chọn, sau đó chọn Align. Ngoài ra, có thể sử dụng menu con Edit » Align trong các menu chính hoặc menu con căn chỉnh trong Active Bar. Menu con căn chỉnh có một số tùy chọn để phân bố các đối tượng đã chọn.
Lệnh Align được dùng để mở hộp thoại Align Objects, cung cấp các điều khiển để nhanh chóng căn chỉnh tập hợp các đối tượng thiết kế đang được chọn theo yêu cầu. Sử dụng hộp thoại để thiết lập các tùy chọn căn chỉnh Vertical và/hoặc Horizontal cho các đối tượng đã chọn theo yêu cầu, sau đó nhấp vào OK để thực hiện căn chỉnh.

Hộp thoại Align Objects
Các tùy chọn và điều khiển của hộp thoại Căn chỉnh đối tượng
-
Horizontal - chọn một trong các tùy chọn sau để xác định cách căn chỉnh theo chiều ngang cho các đối tượng đã chọn:
- No Change - giữ nguyên cách căn chỉnh theo chiều ngang của các đối tượng.
- Left - căn chỉnh các đối tượng sao cho mép ngoài của các phần tử cơ bản nằm xa nhất về bên trái có cùng tọa độ X. Đối tượng có phần tử cơ bản nằm xa nhất về bên trái được dùng làm tham chiếu.
- Center - di chuyển các đối tượng theo chiều ngang sao cho tâm của chúng thẳng hàng. Sau khi nhấp vào OK, bạn sẽ được yêu cầu nhấp để chọn đối tượng tham chiếu.
- Right - căn chỉnh các đối tượng sao cho mép ngoài của các phần tử cơ bản nằm xa nhất về bên phải có cùng tọa độ X. Đối tượng có phần tử cơ bản nằm xa nhất về bên phải được dùng làm tham chiếu.
- Space equally - các đối tượng được phân bố cách đều theo chiều ngang giữa đối tượng ngoài cùng bên trái và đối tượng ngoài cùng bên phải (hai đối tượng này không di chuyển).
-
Vertical - chọn một trong các tùy chọn sau để xác định cách căn chỉnh theo chiều dọc cho các đối tượng đã chọn:
- No Change - giữ nguyên cách căn chỉnh theo chiều dọc của các đối tượng đã chọn.
- Top - căn chỉnh các đối tượng sao cho mép ngoài của các phần tử cơ bản nằm cao nhất có cùng tọa độ Y. Đối tượng có phần tử cơ bản nằm cao nhất được dùng làm tham chiếu.
- Center - di chuyển các đối tượng theo chiều dọc sao cho tâm của chúng thẳng hàng. Sau khi nhấp vào OK, bạn sẽ được yêu cầu nhấp để chọn đối tượng tham chiếu.
- Bottom - căn chỉnh các đối tượng sao cho mép ngoài của các phần tử cơ bản nằm thấp nhất có cùng tọa độ Y. Đối tượng có phần tử cơ bản nằm thấp nhất được dùng làm tham chiếu.
- Space equally - các đối tượng được phân bố cách đều theo chiều dọc giữa đối tượng trên cùng và đối tượng dưới cùng (hai đối tượng này không di chuyển).
Lệnh Position Component Text được dùng để mở hộp thoại Component Text Position, từ đó bạn có thể thay đổi vị trí của văn bản ký hiệu định danh và/hoặc chú thích cho một hoặc nhiều linh kiện đã chọn trong tài liệu hiện tại.

Hộp thoại Component Text Position
Về cơ bản, hộp thoại được chia thành hai vùng — văn bản ký hiệu định danh và chú thích. Đối với cả ký hiệu định danh và chú thích, hình minh họa linh kiện được dùng để giúp hiển thị vị trí văn bản sẽ xuất hiện dựa trên vị trí đã chọn. Có chín kiểu vị trí sau đây cho văn bản, tất cả đều được phân loại là 'vị trí tự động', nghĩa là văn bản vẫn giữ ở vị trí đã chọn khi linh kiện được di chuyển và xoay:
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Để giữ văn bản ở vị trí hiện tại mà không thay đổi, hãy giữ tùy chọn No Change ở trạng thái bật.
Lệnh Align Left / Align Right / Align Top / Align Bottom cho phép bạn căn chỉnh các đối tượng thiết kế đã chọn lần lượt theo mép trái/phải/trên/dưới của chúng. Sau khi chạy lệnh, mép trái/phải/trên/dưới của đối tượng ngoài cùng bên trái/phải/trên/dưới được dùng làm tham chiếu, và tất cả các đối tượng khác trong vùng chọn sẽ được di chuyển sang trái/phải/lên/xuống sao cho các mép trái của chúng thẳng hàng với tham chiếu này.
Lệnh Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) cho phép bạn căn chỉnh các đối tượng thiết kế đã chọn theo cạnh trái/phải/trên/dưới, đồng thời duy trì khoảng cách phù hợp theo các quy tắc thiết kế áp dụng. Sau khi thực thi lệnh, cạnh trái/phải/trên/dưới của đối tượng nằm ngoài cùng bên trái/phải/trên/dưới được dùng làm tham chiếu, và tất cả các đối tượng còn lại trong vùng chọn sẽ được di chuyển sang trái/phải/lên trên/xuống dưới sao cho các cạnh trái của chúng thẳng hàng với tham chiếu này. Đối tượng sẽ được di chuyển sang trái/phải/lên trên/xuống dưới đến gần đối tượng tham chiếu nhất có thể trong phạm vi cho phép của quy tắc khoảng hở áp dụng:
- Khi chỉ căn chỉnh các linh kiện, quy tắc khoảng hở linh kiện được áp dụng.
- Khi chỉ căn chỉnh các đối tượng không phải linh kiện, quy tắc khoảng hở được áp dụng.
- Khi căn chỉnh cả linh kiện và các đối tượng không phải linh kiện, quy tắc khoảng hở được áp dụng.
Lệnh Align Horizontal Centers / Align Vertical Centers cho phép bạn sắp xếp các đối tượng đã chọn thành một cột/hàng, căn chỉnh theo tâm ngang/dọc của chúng. Sau khi thực thi lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ được nhắc chọn một đối tượng trong vùng chọn; hãy nhấp vào đối tượng đó. Đối tượng này sẽ trở thành đối tượng tham chiếu. Tất cả các đối tượng còn lại trong vùng chọn sẽ được di chuyển tương ứng với đối tượng tham chiếu này, căn chỉnh theo tâm ngang/dọc của chúng.
Lệnh Distribute Horizontally / Distribute Vertically cho phép bạn làm cho khoảng cách ngang/dọc giữa các đối tượng đã chọn bằng nhau. Sau khi thực thi lệnh, các đối tượng ngoài cùng bên trái và bên phải / trên cùng và dưới cùng trong vùng chọn sẽ giữ nguyên vị trí, còn tất cả các đối tượng khác sẽ được giãn cách đều giữa chúng. Vị trí theo chiều dọc/ngang của các đối tượng không thay đổi.
Lệnh Increase Horizontal Spacing / Increase Vertical Spacing cho phép bạn tăng khoảng cách ngang/dọc giữa các đối tượng đã chọn. Sau khi thực thi lệnh, đối tượng ngoài cùng bên trái/dưới cùng sẽ giữ nguyên vị trí, còn các đối tượng khác trong vùng chọn sẽ được di chuyển sang phải/lên trên. Việc di chuyển làm tăng khoảng cách ngang/dọc giữa các điểm tham chiếu của những đối tượng liên tiếp theo giá trị được chỉ định trong trường Step X / Step Y của Global Board Snap Grid mặc định.
Lệnh Decrease Horizontal Spacing / Decrease Vertical Spacing cho phép bạn giảm khoảng cách ngang/dọc giữa các đối tượng đã chọn. Sau khi thực thi lệnh, đối tượng ngoài cùng bên trái/dưới cùng sẽ giữ nguyên vị trí, còn các đối tượng khác trong vùng chọn sẽ được di chuyển sang trái/xuống dưới. Việc di chuyển làm giảm khoảng cách ngang/dọc giữa các điểm tham chiếu của những đối tượng liên tiếp theo giá trị được chỉ định trong trường Step X / Step Y của Global Board Snap Grid mặc định.
Lệnh Align To Grid được dùng để di chuyển các linh kiện đã chọn đến điểm gần nhất trên lưới bắt điểm đang áp dụng và đã được điều chỉnh. Sau khi thực thi lệnh, các điểm tham chiếu của từng linh kiện đã chọn sẽ được di chuyển đến điểm gần nhất trên lưới bắt điểm đang áp dụng.
Lệnh Move All Components Origin To Grid được dùng để di chuyển điểm tham chiếu của tất cả các linh kiện lên lưới bắt điểm hiện tại. Sau khi thực thi lệnh, tất cả các linh kiện trong không gian thiết kế có pad nằm trên lưới sẽ được di chuyển sao cho các điểm tham chiếu của chúng khớp với lưới bắt điểm hiện tại. Theo mặc định, một báo cáo - Move Component(s) Origin To Grid - <PCBDocumentName>.html - sẽ tự động được tạo và mở làm tài liệu đang hoạt động, trình bày chi tiết những linh kiện đã và chưa được di chuyển.
Thông qua bảng PCB List
Bảng PCB List cho phép bạn hiển thị các đối tượng thiết kế dưới dạng bảng, giúp nhanh chóng kiểm tra và sửa đổi các thuộc tính của đối tượng. Khi được sử dụng kết hợp với bảng PCB Filter, bảng này cho phép bạn chỉ hiển thị những đối tượng nằm trong phạm vi của bộ lọc đang hoạt động – giúp xác định và chỉnh sửa nhiều đối tượng thiết kế chính xác và hiệu quả hơn.
Chọn lớp đang hoạt động
Lớp đang hoạt động là lớp mà bạn sẽ đặt các đối tượng lên. Bạn có thể chọn lớp đang hoạt động từ các lớp hiện đang hiển thị bằng cách nhấp vào tab của lớp đó ở phía dưới không gian thiết kế hoặc sử dụng danh sách thả xuống Active Layer trong vùng Layers trên tab Layers & Colors của bảng View Configuration.
Bạn cũng có thể sử dụng các phím tắt sau để nhanh chóng chọn lớp đang hoạt động:
- * (trên bàn phím số) – chuyển sang lớp tín hiệu được bật tiếp theo.
-
Shift+* (trên bàn phím số) – chuyển sang lớp tín hiệu được bật trước đó.
- + (trên bàn phím số) – chuyển sang lớp được bật tiếp theo.
- - (trên bàn phím số) – chuyển sang lớp được bật trước đó.
Sử dụng Cắt/Sao chép và Dán
Trong trình chỉnh sửa PCB, bạn có thể cắt/sao chép và dán các đối tượng trong cùng một tài liệu PCB hoặc giữa các tài liệu PCB, ví dụ: có thể sao chép một hoặc nhiều linh kiện từ một PCB sang tài liệu PCB khác. Bạn có thể cắt/sao chép các đối tượng vào bộ nhớ tạm của Windows và dán chúng vào các tài liệu khác.
Khi sử dụng 2D Layout Mode, hãy chọn các đối tượng bạn muốn cắt/sao chép, nhấp vào Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) trên các menu chính hoặc chọn lệnh Cut/Copy từ menu chuột phải. Con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ được nhắc chọn một điểm tham chiếu. Đây là một tọa độ tương đối so với các đối tượng đã chọn, được dùng để định vị chính xác vùng chọn khi sử dụng lệnh dán.
Để sao chép (các) đối tượng thiết kế hiện đang được chọn vào bộ nhớ tạm ở dạng văn bản, có thể sử dụng lệnh Edit » Copy As Text từ các menu chính. Sau đó, có thể dán thông tin này vào bất kỳ trường văn bản hoặc tài liệu văn bản bên ngoài nào. Các thông tin được sao chép vào bộ nhớ tạm bao gồm:
- Loại đối tượng.
- Ký hiệu định danh và chú thích (đối với đối tượng linh kiện).
- Vị trí của đối tượng trong không gian thiết kế.
- Lớp chứa đối tượng (hoặc lớp bắt đầu và kết thúc đối với via).
Ví dụ về một linh kiện được sao chép vào bộ nhớ tạm dưới dạng văn bản:
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Ví dụ về một đường mạch và via được sao chép vào bộ nhớ tạm dưới dạng văn bản:
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Để đưa nội dung được cắt/sao chép gần nhất vào bộ nhớ tạm vào tài liệu đang hoạt động, hãy chọn lệnh Edit » Paste từ các menu chính hoặc nhấp chuột phải trong không gian thiết kế và chọn lệnh Paste từ menu ngữ cảnh (phím tắt: Ctrl+V). Nội dung mới nhất trong bộ nhớ tạm sẽ xuất hiện và di chuyển theo con trỏ. Vị trí của con trỏ so với nội dung được xác định bởi điểm tham chiếu đã chỉ định khi sử dụng Cut hoặc Copy để đưa phần được chọn vào bộ nhớ tạm.
Để đưa văn bản đã sao chép từ một ứng dụng hỗ trợ OLE vào bất kỳ tài liệu PCB đang mở nào, có thể sử dụng lệnh Edit » Paste Text từ các menu chính. Văn bản được chuyển đổi và dán dưới dạng các đối tượng chuỗi văn bản PCB thay vì một đối tượng OLE duy nhất. Các loại tệp được hỗ trợ bao gồm những định dạng phổ biến như bảng tính định dạng CSV và XLS cũng như tài liệu văn bản DOC và RTF.
Để kiểm soát cách xử lý một số thuộc tính của đối tượng khi dán chúng trở lại không gian thiết kế, có thể sử dụng lệnh Edit » Paste Special từ các menu chính. Sau khi chạy lệnh, hộp thoại Paste Special sẽ mở ra.

Hộp thoại Paste Special
Các tùy chọn và điều khiển của hộp thoại Dán đặc biệt
Thuộc tính khi dán
- Paste on current layer - bật tùy chọn này để dán các đối tượng vào lớp hiện tại.
- Keep net name - bật tùy chọn này để giữ nguyên tên net ban đầu của các đối tượng.
- Duplicate designator - bật tùy chọn này để dán linh kiện với cùng ký hiệu định danh mà không tự động tăng.
- Add to component class - bật tùy chọn này để thêm linh kiện được dán vào cùng lớp linh kiện với linh kiện nguồn.
Các nút
- Paste - nhấp để dán đối tượng với tất cả các thuộc tính đã chỉ định.
- Paste Array - nhấp để mở hộp thoại Thiết lập dán mảng, nơi bạn có thể thiết lập các tùy chọn dán mảng.
Tùy thuộc vào nội dung cụ thể được dán, có thể kiểm soát các thuộc tính sau:
-
Có thể dán các đối tượng vào lớp hiện tại thay vì cách dán mặc định là dán vào cùng lớp với các đối tượng nguồn đã sao chép.
- Khả năng giữ nguyên tên net đã gán.
- Khả năng giữ trùng ký hiệu định danh (đối với linh kiện được dán).
- Khả năng thêm linh kiện được dán vào cùng lớp linh kiện với linh kiện nguồn ban đầu.
Thiết lập các tùy chọn theo yêu cầu, sau đó nhấp vào nút Paste để bắt đầu thao tác dán.
Nhấp vào nút Paste Array trong hộp thoại Paste Special sẽ mở hộp thoại Setup Paste Array, cho phép bạn dán nhiều bản sao của các đối tượng trong bộ nhớ tạm vào tài liệu hiện tại.

Hộp thoại Setup Paste Array
Các tùy chọn và điều khiển của hộp thoại Thiết lập dán mảng
Các biến đặt đối tượng
- Item Count - số lần đặt lặp lại cần thực hiện. Ví dụ, nhập 4 sẽ đặt 4 bản sao của nội dung hiện tại trong bộ nhớ tạm.
-
Text Increment - nhập bước tăng tự động cho văn bản hiển thị (ví dụ: ký hiệu định danh linh kiện hoặc pad). Hỗ trợ bước tăng bằng chữ cái và số khác 1. Ví dụ, bằng cách đặt ký hiệu định danh cho pad trước khi sao chép vào bộ nhớ tạm và thiết lập trường Text Increment, bạn có thể đặt các chuỗi ký hiệu định danh pad theo những dạng sau:
- Dạng số (1, 3, 5)
- Dạng chữ cái (A, B, C)
- Kết hợp chữ cái và số (A1, A2 hoặc 1A, 1B hoặc A1, B1 hoặc 1A, 2A, v.v.)
Loại mảng
- Circular- bật tùy chọn này để dán một mảng tròn, sử dụng các thiết lập Circular Array hiện tại.
- Linear - bật tùy chọn này để dán mảng theo đường thẳng, sử dụng các thiết lập Linear Array hiện tại.
Mảng tròn
- Rotate Item to Match - nếu bật, các phần tử trong mảng sẽ được xoay một góc bằng với giá trị Khoảng cách của chúng.
- Spacing (degrees) - khoảng cách góc giữa hai phần tử được dán liền kề.
Mảng tuyến tính
- X-Spacing - nhập khoảng cách X mong muốn giữa hai phần tử liền kề.
- Y- Spacing - nhập khoảng cách Y mong muốn giữa hai phần tử liền kề.
Nhập các giá trị phù hợp trong hộp thoại này, sau đó nhấp vào OK để đặt mảng.
- Nếu đặt một mảng tuyến tính, bạn sẽ được yêu cầu chọn điểm bắt đầu của mảng. Định vị con trỏ rồi nhấp chuột hoặc nhấn Enter để đặt mảng.
- Nếu đặt một mảng tròn, bạn sẽ được nhắc chọn tâm của mảng, sau đó chọn điểm bắt đầu của mảng. Di chuyển con trỏ đến từng vị trí rồi nhấp hoặc nhấn Enter để đặt mảng. Các đối tượng sẽ được đặt ngược chiều kim đồng hồ quanh tâm đã chỉ định.
Thứ tự ưu tiên khi dán đối tượng
Khi một đối tượng được dán lên lớp đồng và chồng lên một tập hợp đối tượng thuộc các loại khác nhau, net của đối tượng có độ ưu tiên cao nhất sẽ được gán cho đối tượng vừa dán. Thứ tự ưu tiên như sau (1 là mức ưu tiên cao nhất):
- Pad
- Vùng đồng đặc
- Vùng
- Đường mạch
- Cung
- Via
- Vùng đổ đồng đa giác

Net của đối tượng có độ ưu tiên cao nhất được gán cho đối tượng vừa dán. Hình minh họa cho thấy một đối tượng (đường mạch) được dán chồng lên một tập hợp đối tượng thuộc các loại khác nhau và được gán các net khác nhau. Vì pad là đối tượng có độ ưu tiên cao nhất trong tập hợp này, net của nó (Pad_Net) sẽ được gán cho đối tượng vừa dán. Di con trỏ lên hình để xem kết quả.
Khi một đối tượng được dán lên lớp đồng và chồng lên một tập hợp đối tượng cùng loại, net của đối tượng nằm dưới con trỏ tại thời điểm nhấp để dán sẽ được gán cho đối tượng vừa dán.

Net của đối tượng nằm dưới con trỏ được gán cho đối tượng vừa dán. Hình minh họa cho thấy một đối tượng (đường mạch) được dán chồng lên một tập hợp đối tượng cùng loại (pad). Vì pad 2 là đối tượng nằm dưới con trỏ tại thời điểm nhấp để dán, net của pad này (Pad2_Net) sẽ được gán cho đối tượng vừa dán. Di con trỏ lên hình để xem kết quả.
Khi một tập hợp đối tượng có kết nối vật lý với nhau được dán lên lớp đồng, và các đối tượng thuộc những loại khác nhau trong tập hợp này chồng lên các đối tượng hiện có mang các net khác nhau, net của đối tượng có độ ưu tiên cao nhất trong tập hợp sẽ được gán cho tất cả đối tượng vừa dán. Thứ tự ưu tiên nêu trên được áp dụng trong trường hợp này.

Net được gán cho đối tượng có độ ưu tiên cao nhất sẽ được gán cho cả tập hợp đối tượng có kết nối vật lý với nhau. Hình minh họa cho thấy một tập hợp đối tượng được kết nối (từ trái sang phải: vùng đồng đặc, vùng, đường mạch, cung, via, vùng đổ đồng đa giác) được dán chồng lên các đối tượng (via) mang các net khác nhau. Vì vùng đồng đặc là đối tượng có độ ưu tiên cao nhất trong tập hợp vừa dán này, net được gán cho nó (Via1_Net) sẽ được gán cho từng đối tượng trong tập hợp. Di con trỏ lên hình để xem kết quả.
Khóa đối tượng thiết kế
Bạn có thể khóa các đối tượng thiết kế để ngăn di chuyển hoặc chỉnh sửa chúng trong tài liệu PCB bằng cách bật thuộc tính Locked của chúng. Ví dụ, nếu vị trí hoặc kích thước của một số đối tượng cụ thể là yếu tố quan trọng, hãy khóa chúng. Bạn có thể khóa trong bảng Properties bằng cách nhấp vào biểu tượng ổ khóa của đối tượng mong muốn, như minh họa trong các ví dụ sau.
Ví dụ về biểu tượng Lock trong bảng Properties đối với một linh kiện và một pad được chọn.
Để chuyển đổi trạng thái của thuộc tính Locked cho một đối tượng đã đặt có thuộc tính Locked , bạn cũng có thể nhấp chuột phải lên đối tượng trong không gian thiết kế và chọn lệnh <ObjectType> Locked từ menu ngữ cảnh. Khi đối tượng đã được khóa, mục lệnh trên menu sẽ hiển thị dấu kiểm ở bên trái.
Nếu bạn cố di chuyển hoặc xoay một đối tượng thiết kế đang bật thuộc tính Locked, một hộp thoại sẽ xuất hiện yêu cầu xác nhận tiếp tục chỉnh sửa.
Khóa các phần tử cơ bản của linh kiện
Nếu các phần tử cơ bản của một linh kiện PCB đã được khóa (tùy chọn Primitives trong chế độ Linh kiện của bảng Thuộc tính đang ở trạng thái , tất cả hoặc phần lớn thuộc tính của các phần tử này sẽ không thể được sửa đổi bằng phương pháp chỉnh sửa đồ họa (ví dụ: kéo và thả) hoặc phi đồ họa (ví dụ: dùng bảng Properties hoặc List). Điều này giúp ngăn các thay đổi ngoài ý muốn đối với phần tử cơ bản của linh kiện, vốn có thể dẫn đến dữ liệu đầu ra lắp ráp và chế tạo không chính xác.
Ví dụ, hình bên dưới hiển thị chế độ Pad của bảng Thuộc tính đối với một pad là thành phần của linh kiện PCB có các phần tử cơ bản đã được khóa. Lưu ý rằng tất cả thuộc tính của pad (ngoại trừ các thuộc tính Net và Testpoint) đều bị làm mờ và không thể chỉnh sửa. Đồng thời, biểu tượng
được hiển thị ở ngoài cùng bên phải của Component của pad trường, cho biết rằng các đối tượng nguyên thủy của linh kiện cha đã bị khóa và không thể sửa đổi thuộc tính của pad.

Chế độ Pad của bảng Properties (bên trái) dành cho một pad của linh kiện PCB có các đối tượng nguyên thủy bị khóa (bên phải).
Chỉnh sửa lồng thao tác
Trình biên tập PCB có một tính năng mạnh mẽ gọi là re-entrant editing. Tính năng này cho phép thực hiện một thao tác thứ hai bằng phím tắt mà không kết thúc thao tác hiện tại. Chỉnh sửa lồng thao tác giúp bạn làm việc linh hoạt và trực quan hơn. Ví dụ, khi bắt đầu đặt một đường mạch, bạn nhận ra rằng cần xóa một đoạn đường mạch khác. Bạn không cần thoát khỏi chế độ Đi dây tương tác. Nhấn các phím tắt E, D, xóa đoạn đường mạch cần xóa rồi nhấn phím Esc để quay lại đi dây tương tác cho thiết kế.
Thiết lập hình dạng con trỏ PCB
Theo mặc định, con trỏ PCB là một dấu chữ thập nhỏ màu xanh lá cây với góc 90 độ. Bạn có thể cấu hình con trỏ bằng các thiết lập Cursor Type và Cursor Color trên trang Trình biên tập PCB – Chung của hộp thoại Preferences . Ví dụ, một dấu chữ thập lớn với góc 90 độ kéo dài đến các cạnh của cửa sổ thiết kế (tùy chọn Large 90) có thể hữu ích khi đặt và căn chỉnh các đối tượng thiết kế. Ngoài ra, dấu chữ thập ở góc 45 độ (tùy chọn Small 45) có thể hữu ích nếu các tùy chọn 90 độ khó nhìn trên nền các đường lưới.
Hỗ trợ phông chữ TrueType
Trình biên tập PCB cho phép sử dụng phông chữ dạng nét hoặc TrueType cho các đối tượng liên quan đến văn bản trong thiết kế (chuỗi/khung văn bản, kích thước, bảng lỗ khoan và/hoặc bảng xếp chồng lớp). Việc chọn phông chữ được thực hiện trong bảng Properties tương ứng. Có ba tùy chọn phông chữ dạng nét: Default, Sans Serif và Serif. Kiểu Default là một phông chữ vectơ đơn giản, hỗ trợ vẽ bằng bút và vẽ quang vectơ. Các phông chữ Sans Serif và Serif phức tạp hơn và sẽ làm chậm quá trình tạo đầu ra vectơ, chẳng hạn như Gerber. Các phông chữ dạng nét được tích hợp sẵn trong phần mềm và không thể thay đổi. Cả ba phông chữ đều có đầy đủ bộ ký tự ASCII mở rộng của IBM, hỗ trợ tiếng Anh và các ngôn ngữ châu Âu khác. Khi sử dụng phông chữ TrueType, bạn có thể dùng các phông chữ TrueType và OpenType (một tập mở rộng của TrueType) trong thư mục \Windows\Fonts. Tính năng này cũng hỗ trợ đầy đủ Unicode.
Hình học của các đối tượng văn bản sử dụng phông chữ TrueType được tự động lưu trong tài liệu PCB. Khi các đối tượng trong tài liệu PCB sử dụng một phông chữ TrueType, chúng sẽ được hiển thị với cùng hình học phông chữ khi tài liệu PCB được mở trên máy tính khác, ngay cả khi phông chữ TrueType đó chưa được cài đặt.
Khi chọn một đối tượng sử dụng phông chữ bị thiếu, thông báo cảnh báo sẽ xuất hiện ở đầu bảng Properties. Khi thay đổi các thuộc tính đối tượng ảnh hưởng đến văn bản (ví dụ: chiều cao văn bản hoặc chính nội dung văn bản), hộp thoại Missing fonts sẽ mở ra để bạn chọn phông chữ thay thế (Replacement). Bật tùy chọn Apply to all text elements để áp dụng phông chữ thay thế cho tất cả các đối tượng trong tài liệu PCB đang sử dụng phông chữ bị thiếu.
Hộp thoại cũng xuất hiện khi thay đổi các thuộc tính liên quan đến văn bản từ bảng PCB List.
Khi chỉnh sửa nhiều đối tượng sử dụng các phông chữ bị thiếu khác nhau, hộp thoại cho phép bạn chọn phông chữ thay thế cho từng phông chữ bị thiếu.
Hỗ trợ hiển thị cung tròn thực
Các cung tròn thực được tạo trong không gian thiết kế của cả trình biên tập PCB và trình biên tập thư viện PCB đều được hỗ trợ, thay vì các dạng xấp xỉ. Khả năng hỗ trợ này áp dụng cho các chế độ Bố trí 2D/3D (và chế độ Quy hoạch bo mạch đối với trình biên tập PCB). Bạn có thể thấy việc hiển thị cung tròn thực trong các khu vực sau:
-
Vùng đổ đồng đa giác (đặc, gạch chéo, không đổ)
-
Vùng khoét của vùng đổ đồng đa giác
-
Đường bao lựa chọn của vùng đổ đồng đa giác và vùng
-
Vùng
-
Độ mở rộng mặt nạ hàn và mặt nạ kem hàn
-
Tô sáng net
-
Đường biên khoảng hở
-
Lớp phủ hiển thị vi phạm (vùng đổ đồng đa giác riêng biệt trên vùng hoặc vùng đổ đồng đa giác)
Các ví dụ về hiển thị cung tròn thực của vùng đổ đồng đa giác được đổ quanh các đối tượng khác trên PCB được trình bày bên dưới.
Thông tin net
Đối với các đối tượng đồng trên PCB (đường mạch, via, đa giác, v.v.), những thông tin sau được hiển thị trong khu vực Net Information của bảng Properties khi đối tượng được chọn:
- Net, Diff Pair và/hoặc xSignal cấp cha cùng lớp liên quan trong từng trường hợp. Lưu ý rằng các mục Diff Pair và xSignal chỉ được hiển thị khi đối tượng thuộc một cặp vi sai hoặc xSignal, tương ứng.
-
Delay – độ trễ của (các) đối tượng được chọn và độ trễ của các đoạn đã đi dây trên toàn bộ net. Bao gồm các giá trị Propagation Delay của pad và via nếu các giá trị này đã được xác định cho pad và via.
-
Length – tổng chiều dài của các đối tượng được chọn và tổng Signal Length. Signal Length là kết quả tính toán chính xác tổng khoảng cách từ nút đến nút. Các đối tượng đã đặt được phân tích để: xử lý các đối tượng xếp chồng hoặc chồng lấn và các đường đi ngoằn ngoèo trong pad; đồng thời tính cả chiều dài via. Pin Package Length cũng được tính vào nếu đã được xác định cho các pad. Nếu net chưa được đi dây hoàn toàn, chiều dài Manhattan (X + Y) của đường kết nối cũng được tính vào. Để biết thêm thông tin về Chiều dài tín hiệu và các ứng dụng của nó, hãy xem thông tin về bảng PCB - Nets.
-
Max Current - dòng điện tối đa mà các đối tượng Đường mạch, Cung tròn hoặc Via được chọn có thể chịu được, được xác định theo công thức IPC-2221A (Mục 6.2):
I = k * ΔT0.44 * A0.725
trong đó:
I = dòng điện [ampe]
A = diện tích tiết diện [mil vuông] (chiều rộng đường mạch * độ dày đồng trong cấu trúc lớp, hoặc Athành lỗ, như minh họa bên dưới)
ΔT = độ tăng nhiệt độ cho phép so với nhiệt độ môi trường [°C]
k = hằng số, với:k = 0.048 cho các lớp ngoài
k = 0.024 cho các lớp trong -
Resistance - tổng điện trở của các đối tượng Đường mạch, Cung tròn và Via được chọn, được xác định theo công thức suy ra:
R = (ρ * L / A)
trong đó:
R = điện trở [Ω]
ρ = điện trở suất của đồng [Ω*mm2/m]
L = chiều dài đường mạch [m] (hoặc Chiều dài via, như mô tả bên dưới)
A = diện tích tiết diện = T * W [mm2] (hoặc Athành lỗ, như minh họa bên dưới)
T = độ dày đường mạch (từ cấu trúc lớp) [mm]
W = Chiều rộng đường mạch [mm]Assumptions:
- Nhiệt độ môi trường = 22 °C
- Độ tăng nhiệt độ cho phép = 20 °C
- Độ dày thành đồng của lỗ xuyên = 0.018mm
- Điện trở suất của đồng = 0.017 Ω*mm2/m

Vùng Net Information của bảng Properties. Ở đây minh họa một ví dụ cho đường mạch được chọn.
Nhấp vào một liên kết trong vùng Net Information để mở net/cặp vi sai/xSignal tương ứng trong bảng PCB.
Gán net cho đối tượng
Trình biên tập PCB cung cấp một số cách để gán net cho các đối tượng cơ bản:
- Khi một hoặc nhiều đối tượng được chọn, hãy sử dụng danh sách thả xuống của trường Nets trong bảng Properties. Tất cả các net của thiết kế bo mạch đang hoạt động sẽ được liệt kê trong danh sách thả xuống. Chọn No Net để chỉ định rằng đường mạch không được kết nối với bất kỳ net nào. Ngoài ra, bạn có thể nhấp vào biểu tượng Assign Net để chọn một đối tượng trong không gian thiết kế - net của đối tượng đó sẽ được gán cho các đối tượng được chọn.
- Nhấp chuột phải lên một hoặc nhiều đối tượng được chọn, sau đó chọn Net Actions » Assign Net. Sau khi khởi chạy lệnh, con trỏ hình chữ thập sẽ xuất hiện. Di chuyển con trỏ hình chữ thập đến net mà bạn muốn gán cho các đối tượng, rồi nhấp để chọn net đó.
- Để đồng bộ lại tên net của các đối tượng đi dây với tên net trên các pad mà chúng kết nối, hãy chọn lệnh Design » Netlist » Update Free Primitives From Component Pads từ menu chính. Sau khi chạy lệnh, một hộp thoại xác nhận sẽ mở ra, hỏi bạn có muốn cập nhật net của các đối tượng tự do theo net của pad linh kiện hay không. Sau khi nhấp Yes, bắt đầu từ từng pad, phần đồng được kết nối sẽ được chọn và tên net của từng đối tượng sẽ được đặt trùng với tên net của pad. Thao tác này không ảnh hưởng đến netlist nội bộ của PCB.
Để kiểm tra và xác nhận rằng các đối tượng được kết nối vật lý đã được gán đúng net để thuộc về net vật lý đó (trong trường hợp này, physical net có nghĩa là connected copper), bạn có thể sử dụng hộp thoại Configure Physical Nets, được truy cập bằng cách chọn lệnh Design » Netlist » Configure Physical Nets từ menu chính. Phần mềm phân tích thiết kế, kiểm tra xem tất cả các pad và các đối tượng kết nối vật lý giữa chúng (đường mạch, cung, vùng đồng đặc, v.v.) có được gán cùng tên net hay không. Khi tất cả các đối tượng của net đều đúng, net được hiển thị bằng màu xanh lá. Nếu phát hiện các đối tượng tiếp xúc nhau nhưng được gán net khác nhau, chúng sẽ được đánh dấu bằng màu đỏ. Một trường hợp thường gặp là footprint của linh kiện có thêm các đối tượng đồng bên trong footprint. Khi footprint này được tải trong quá trình đồng bộ, tên net được áp dụng cho từng pad nhưng không được áp dụng cho phần đồng bổ sung. Hộp thoại có tính tương tác; hãy nhấp vào một net hoặc đối tượng để định vị chéo đối tượng đó trong thiết kế. Nhấp chuột phải hoặc nhấp nút Menu để truy cập các lệnh khả dụng. Vùng Action của hộp thoại cung cấp các điều khiển để chỉ định hành động cần thực hiện nhằm giải quyết các vấn đề với phần đồng được kết nối. Theo mặc định, các hành động sẽ được thiết lập tự động nhưng có thể điều chỉnh theo nhu cầu. Sau khi thiết lập các hành động, hãy nhấp nút Execute để cập nhật việc gán net.

Hộp thoại Configure Physical Nets (hiển thị tùy chọn Only Show Errors được bật (phía sau) và tùy chọn Only Show Errors bị tắt (phía trước)).
Các tùy chọn và điều khiển của hộp thoại Configure Physical Nets
-
Electrically Connected Copper - vùng này liệt kê các nhóm đối tượng đồng riêng biệt được kết nối điện với nhau, theo kết quả phát hiện trong hệ thống dây dẫn của thiết kế. Với mỗi nhóm, thông tin sau được trình bày:
-
Primitive - ở cấp cao nhất, mục này cho biết có bao nhiêu đối tượng trong phần đồng được kết nối. Các đối tượng có thể được hiển thị dưới dạng danh sách phẳng hoặc được nhóm theo loại đối tượng. Cách hiển thị thứ hai được cấu hình bằng cách bật tùy chọn Show Primitive Groups trong các tùy chọn của nút Menu . Khi bật tùy chọn này, các đối tượng sẽ được chia thành những nhóm sau:
- Connected Component Primitives - liệt kê tất cả các đối tượng pad linh kiện dưới dạng các mục con. Các đối tượng này có thể được nhóm tiếp theo linh kiện mẹ bằng cách bật tùy chọn Show Components của nút Menu .
- Connected Free Primitives - liệt kê tất cả các đối tượng đồng không thuộc linh kiện dưới dạng các mục con, được nhóm tiếp theo loại đối tượng (vùng đồng đặc, polygon, đường mạch, via).
-
Primitive - ở cấp cao nhất, mục này cho biết có bao nhiêu đối tượng trong phần đồng được kết nối. Các đối tượng có thể được hiển thị dưới dạng danh sách phẳng hoặc được nhóm theo loại đối tượng. Cách hiển thị thứ hai được cấu hình bằng cách bật tùy chọn Show Primitive Groups trong các tùy chọn của nút Menu . Khi bật tùy chọn này, các đối tượng sẽ được chia thành những nhóm sau:
- Original Net Names - trường này cho biết tên net hiện được gán cho đối tượng, tức là net mà đối tượng hiện đang kết nối. Mục này sẽ là một trong các net đã được định nghĩa cho bo mạch. Tuy nhiên, nếu đối tượng không được kết nối với net nào, mục này sẽ là <Unassigned>.
-
Status - trường này cung cấp trạng thái ở cấp cao nhất cho nhóm, có thể là một trong bốn trạng thái:
- Blank - việc gán net cho nhóm đồng liên thông hoàn toàn chính xác và không cần cập nhật. Mục cấp cao nhất của nhóm có màu xanh lá.
- 1. Update Required - Unassigned Nets - ở trạng thái này, chưa có đối tượng cơ bản nào trong nhóm được gán vào net. Mục cấp cao nhất của nhóm có màu vàng.
- 2. Update Required - Some Unassigned Nets - ở trạng thái này, một số đối tượng cơ bản đã được gán vào cùng một net, nhưng các đối tượng khác chưa được gán. Mục cấp cao nhất của nhóm có màu cam.
- 3. Ambiguous - Multiple Net Names - ở trạng thái này, có các đối tượng cơ bản trong nhóm được gán vào những net khác nhau. Cũng có thể có các đối tượng chưa được gán. Mục cấp cao nhất của nhóm có màu đỏ.
-
Action - vùng này cung cấp các tùy chọn để xác định thao tác cần thực hiện nhằm giải quyết vấn đề với phần đồng liên thông, cùng với kết quả thực hiện các thay đổi đã cấu hình. Với mỗi nhóm, các thông tin sau được hiển thị:
-
Proposed Action - trường này được dùng để xác định thao tác cần thực hiện, nếu có. Ở cấp cao nhất của một nhóm, mục này có thể được đặt thành Update Net To hoặc Don't Update Net To. Khi cập nhật, hãy chọn net đích mới trong trường New Net Name. Dựa trên hai thiết lập này, phần mềm tính toán các thao tác cần thực hiện ở cấp đối tượng cơ bản con và đưa ra một trong các đề xuất sau:
- No Action Required - đối tượng cơ bản đã được gán/kết nối với net đích.
- Update - đưa đối tượng cơ bản vào quá trình cập nhật để đối tượng được gán/kết nối với net đích mới.
- Don't Update - không đưa đối tượng cơ bản vào quá trình cập nhật. Đối tượng sẽ vẫn kết nối với net hiện tại.
- New Net Name - sử dụng trường này để đặt net đích mới mà các đối tượng cơ bản cần kết nối tới. Danh sách thả xuống của trường liệt kê tất cả các net được phát hiện trong các đối tượng cơ bản thuộc nhóm đồng liên thông. Nếu cần sử dụng một net khác, hãy nhấp chuột phải vào trường và sử dụng lệnh Change Copper Net To Board Net trong menu ngữ cảnh. Thao tác này mở hộp thoại Choose Net, liệt kê tất cả các net hiện được định nghĩa cho bo mạch. Chọn net bạn cần rồi nhấp OK. Net đó sẽ được điền vào trường.
- Done - trường này phản ánh việc cập nhật thành công hay thất bại sau khi nhấn nút Execute và áp dụng các thay đổi.
-
Proposed Action - trường này được dùng để xác định thao tác cần thực hiện, nếu có. Ở cấp cao nhất của một nhóm, mục này có thể được đặt thành Update Net To hoặc Don't Update Net To. Khi cập nhật, hãy chọn net đích mới trong trường New Net Name. Dựa trên hai thiết lập này, phần mềm tính toán các thao tác cần thực hiện ở cấp đối tượng cơ bản con và đưa ra một trong các đề xuất sau:
- Execute - khi đã hài lòng với các thao tác được chỉ định cho netlist, hãy nhấp nút này để cập nhật việc gán net.
-
Menu - nhấp để truy cập menu lệnh sau, liên quan đến danh sách chính nói chung hoặc các đối tượng cơ bản hiện được chọn. Các lệnh này giống với những lệnh có trong menu chuột phải của vùng danh sách chính.
- Update/Don't Update/No Action - sử dụng để nhanh chóng chuyển đổi thao tác đề xuất cho các đối tượng cơ bản được chọn. Ở cấp cha cao hơn trong hệ thống phân cấp đối tượng cơ bản, sử dụng lệnh này để chuyển đổi thao tác đề xuất cho tất cả các đối tượng con bên dưới.
- Select All - sử dụng để nhanh chóng chọn tất cả các nhóm đồng liên thông (các mục cấp cao nhất trong danh sách).
- Select All With Same Status - khi một mục nhóm đồng liên thông cấp cao nhất được chọn, sử dụng lệnh này để nhanh chóng chọn tất cả các nhóm cấp cao nhất khác có cùng trạng thái.
- Clear All Selected - sử dụng để bỏ chọn tất cả các mục trong danh sách.
- Expand All In Connected Copper - sử dụng để nhanh chóng mở rộng tất cả các nhóm con trong nhóm đồng liên thông hiện đang được chú trọng.
- Expand All - sử dụng để nhanh chóng mở rộng tất cả các nhóm thuộc mọi nhóm đồng liên thông trong danh sách.
- Expand Children - sử dụng để nhanh chóng mở rộng tất cả các nhóm con ở mọi cấp bên dưới nhóm hiện được chọn.
- Collapse All In Connected Copper - sử dụng để nhanh chóng thu gọn tất cả các nhóm con trong nhóm đồng liên thông hiện đang được chú trọng.
- Collapse All - sử dụng để nhanh chóng thu gọn tất cả các nhóm thuộc mọi nhóm đồng liên thông trong danh sách.
- Collapse Children - sử dụng để nhanh chóng thu gọn tất cả các nhóm con ở mọi cấp bên dưới nhóm hiện được chọn.
- Only Show Errors - bật để chỉ hiển thị lỗi trong hộp thoại. Danh sách sẽ chỉ hiển thị các nhóm đồng liên thông có Status ở cấp 1, 2 hoặc 3. Tắt để hiển thị cả phần đồng liên thông đã được gán chính xác.
- Show Components - bật để nhóm các đối tượng pad của linh kiện theo linh kiện cha của chúng.
- Show Primitive Groups - bật để nhóm các đối tượng cơ bản theo loại đối tượng.
- Animate Action Execution - bật để hộp thoại cuộn qua danh sách trong quá trình thực thi, giúp bạn theo dõi trực quan tiến độ thay đổi net theo thời gian thực. Khi tắt tùy chọn này, các thay đổi sẽ được thực hiện mà không có hiệu ứng cuộn đó.
-
Warn On Netlist Change - bật để nhận cảnh báo khi các thay đổi sẽ ảnh hưởng đến netlist của bo mạch. Hộp thoại Netlist Change sẽ mở, thông báo số lượng đối tượng cơ bản sẽ bị thay đổi net và cho biết việc này sẽ ảnh hưởng đến netlist. Bạn có thể nhấp để Continue hoặc nhấp Filter Affected để kiểm tra kỹ hơn các thay đổi được đề xuất.

Hộp thoại Netlist Change - Show Component Pads - bật để hiển thị các đối tượng cơ bản thuộc linh kiện đã kết nối trong danh sách.
- Show Non Component Pads - bật để hiển thị các đối tượng cơ bản tự do đã kết nối trong danh sách.
- Show Changes That Affect Netlist - bật để chỉ hiển thị danh sách các thao tác (thay đổi) được đề xuất sẽ ảnh hưởng đến netlist của bo mạch.
- Change Copper Net To - một hoặc nhiều mục menu loại này xuất hiện khi có ít net hiện được gán cho các đối tượng cơ bản trong nhóm đồng liên thông đang được chú trọng. Sử dụng mục này để nhanh chóng chọn net đích cho trường New Net Name.
- Change Copper Net To Net - mục menu này xuất hiện khi có quá nhiều net hiện được gán cho các đối tượng cơ bản trong một nhóm đồng liên thông nên không thể hiển thị thành các mục menu riêng lẻ. Sử dụng lệnh này để truy cập hộp thoại Choose Net, liệt kê tất cả các net hiện được gán cho các đối tượng cơ bản trong nhóm. Chọn net bạn cần rồi nhấp OK; net đó sẽ được điền vào trường New Net Name của nhóm đồng liên thông đang được chú trọng.
- Change Copper Net To Board Net - sử dụng lệnh này nếu bạn cần dùng một net khác với những net hiện được gán cho các đối tượng cơ bản của nhóm đồng liên thông đang được chú trọng. Thao tác này mở hộp thoại Choose Net, liệt kê tất cả các net hiện được định nghĩa cho bo mạch. Chọn net bạn cần rồi nhấp OK; net đó sẽ được điền vào trường New Net Name.
- Show All Primitives - nhấp nút này để nhanh chóng hiển thị tất cả các đối tượng cơ bản. Nút này khả dụng khi tùy chọn Show Component Pads và/hoặc Show Non Component Pads trong menu bị tắt.
Bạn cũng có thể xóa tất cả các net khỏi tài liệu thiết kế hiện tại, về cơ bản là làm trống netlist nội bộ của PCB. Điều này có thể hữu ích nếu bạn đã thay đổi thông tin net trong các tài liệu sơ đồ nguyên lý nguồn và muốn đồng bộ lại hoàn toàn PCB với thông tin netlist của sơ đồ nguyên lý nguồn. Để thực hiện, hãy chọn Design » Netlist » Clear All Nets từ các menu chính. Sau khi chạy lệnh, một hộp thoại xác nhận sẽ mở ra, thông báo rằng thao tác này sẽ xóa toàn bộ thông tin net khỏi PCB. Sau khi nhấp vào Yes, toàn bộ thông tin net sẽ bị xóa. Mọi đường mạch đã đi dây vẫn được giữ nguyên nhưng sẽ được gán No Net. Mọi kết nối logic chưa đi dây sẽ bị xóa.
Để tạo tệp netlist dựa trên các kết nối được hình thành từ việc đi dây trong thiết kế hiện tại, hãy chọn lệnh Design » Netlist » Create Netlist From Connected Copper từ các menu chính. Sau khi nhấp vào Yes trong hộp thoại xác nhận vừa mở, một netlist (Generated <PCBDocumentName>.Net, được thêm vào bảng Projects dưới dạng tài liệu độc lập trong thư mục con Source Documents) sẽ được tạo trong cùng thư mục với tài liệu thiết kế PCB và tự động mở làm tài liệu đang hoạt động. Mỗi net trong netlist được đặt tên theo một trong các pad mà phần đồng đã đi dây kết nối tới.

