Erstellen und Definieren der Datenbankbibliothek

Auf einen Blick

Erfahren Sie, wie Sie standardmäßige und versionsverwaltete Datenbankbibliotheken in Altium Designer erstellen und definieren. Dieser Artikel erläutert, wie Sie eine Verbindung zu einer externen Datenbank herstellen, eine SVNDbLib mit einem Subversion-Repository verknüpfen, die einzubeziehenden Datenbanktabellen auswählen und Übereinstimmungskriterien festlegen, die platzierte Bauteile mit ihren Quelldatensätzen verknüpfen. Lesen Sie weiter und machen Sie den nächsten Schritt beim Einrichten Ihrer Datenbankbibliothek.

- Verstehen Sie die Funktionen von DbLib- und SVNDbLib-Dateien und erfahren Sie, wo Sie diese erstellen können.
- Lernen Sie die verschiedenen Möglichkeiten zur Datenbankanbindung kennen, darunter Schnellzugriffe für Access und Excel, Verbindungszeichenfolgen und Microsoft Data Link-Dateien.
- Erfahren Sie, wie Sie verbundene Tabellen durchsuchen und bearbeiten, deren Einbindung in die Bibliothek steuern und für jede Tabelle individuelle Kriterien für den Bauteilabgleich festlegen.
Mit KI tiefer einsteigen:

Die Grundlage der Datenbankbibliotheksfunktion ist die Datenbankbibliotheksdatei. Diese gibt es in zwei Varianten, je nachdem, ob Sie eine Standard-Datenbankbibliothek oder eine versionsverwaltete Datenbankbibliothek verwenden:

  • Standard Database Library – die Datenbankbibliotheksdatei. Diese Datei wird mit dem DatabaseLib-Editor von Altium Designer erstellt und verwaltet. Dieser Editor ist verfügbar, wenn das aktive Dokument im Hauptentwurfsfenster eine *.DbLib-Datei ist.
  • Version-Controlled Database Library – die SVN-Datenbankbibliotheksdatei. Diese Datei wird mit dem SVNDatabaseLib-Editor von Altium Designer erstellt und verwaltet. Dieser Editor ist verfügbar, wenn das aktive Dokument im Hauptentwurfsfenster eine *.SVNDbLib-Datei ist.

Beispiel einer DbLib-Datei, geöffnet im DatabaseLib-Editor. Bewegen Sie den Mauszeiger über das Bild, um ein Beispiel einer SVNDbLib-Datei im SVNDatabaseLib-Editor anzuzeigen.Beispiel einer DbLib-Datei, geöffnet im DatabaseLib-Editor. Bewegen Sie den Mauszeiger über das Bild, um ein Beispiel einer SVNDbLib-Datei im SVNDatabaseLib-Editor anzuzeigen.

Erstellen Sie eine neue Datei eines dieser Typen, indem Sie in den Hauptmenüs den Befehl File » New » Library  wählen und im Bereich Database des sich öffnenden Dialogs New Library die Option Database Library oder SVN Database Library auswählen.

Verbindung zu einer externen Datenbank herstellen

Tabellen- und Zuordnungsdaten werden erst dann im Hauptanzeigefenster eines Editors angezeigt, wenn die aktive Datenbankbibliotheks-/SVN-Datenbankbibliotheksdatei erfolgreich mit der gewünschten externen Datenbank verbunden ist. Die Verbindung wird über die Steuerelemente im Bereich Source of Connection definiert.

Festlegen der Verbindung zur externen Datenbank über eine DbLib-Datei. Bewegen Sie den Mauszeiger über das Bild, um die Verbindung über eine SVNDbLib-Datei anzuzeigen.Festlegen der Verbindung zur externen Datenbank über eine DbLib-Datei. Bewegen Sie den Mauszeiger über das Bild, um die Verbindung über eine SVNDbLib-Datei anzuzeigen.

Es kann eine Verbindung zu jeder Datenbank hergestellt werden, die OLE DB unterstützt. Die Optionen in diesem Bereich verwenden jeweils eine OLE-DB-Verbindungszeichenfolge, um eine Verbindung zur Zieldatenbank herzustellen. Einige Datenbanken bieten möglicherweise keine OLE-DB-Unterstützung. Auf nahezu alle heute verwendeten Datenbankverwaltungssysteme kann jedoch über die ODBC-Schnittstelle (Open Database Connectivity) zugegriffen werden. Die Datenbankverknüpfungsfunktion verwendet den ODBC-Anbieter von Microsoft, mit dem ein ADO (ActiveX Data Object) eine Verbindung zu jeder ODBC-Datenquelle herstellen kann. Somit kann eine Verbindung zu jeder ODBC-Datenbank hergestellt werden. Der OLE-DB-Anbieter für die ODBC-Datenbank wird als Teil der Verbindungszeichenfolge angegeben.

Die Verbindung kann auch auf der Registerkarte Connection des Dialogs Database Connection definiert werden. Diesen öffnen Sie, indem Sie in den Hauptmenüs den Befehl Tools » Database Connection wählen oder auf die Schaltfläche Advanced klicken (rechts neben der Schaltfläche Connect am unteren Rand des Bereichs).

Schnelle Verbindung zu Access- und Excel-Datenbanken

Die Option Select Database Type bietet eine schnelle Möglichkeit zum Erstellen einer Verbindungszeichenfolge, wenn die Zieldatenbank mit Microsoft Access oder Microsoft Excel erstellt wurde. Wählen Sie bei dieser Option den Datenbanktyp aus, suchen Sie anschließend die gewünschte Datenbankdatei und wählen Sie sie aus. Die entsprechende Verbindungszeichenfolge wird automatisch erstellt und in das Feld für die Option Use Connection String eingetragen.

Sie können den vollständigen Pfad angeben oder den Pfad relativ zur Datenbankbibliotheks-/SVN-Datenbankbibliotheksdatei speichern.

Erstellen einer Verbindungszeichenfolge

Wenn Ihre Unternehmensdatenbank nicht auf Access oder Excel basiert und Sie die Verbindungszeichenfolge explizit erstellen möchten, aktivieren Sie die Option Use Connection String und klicken Sie anschließend auf die zugehörige Schaltfläche Build rechts daneben. Der Dialog Data Link Properties wird angezeigt.

Erstellen einer Verbindungszeichenfolge über den Dialog Data Link Properties.Erstellen einer Verbindungszeichenfolge über den Dialog Data Link Properties.

Der Dialog wird mit der Registerkarte Connection geöffnet. Auf der Registerkarte Provider des Dialogs ist standardmäßig der OLE-DB-Anbieter Microsoft Office <Version> Access Database Engine OLE DB Provider eingestellt. Dies ist die standardmäßige Anbietereinstellung für neue Datenbankbibliotheks-/SVN-Datenbankbibliotheksdateien und wird auch für die Verbindung zu Access-Datenbankdateien (*.mdb) verwendet. Ändern Sie den Anbieter nach Bedarf.

Geben Sie auf der Registerkarte Connection den Namen (einschließlich Pfad) der Datenbank ein, zu der Sie eine Verbindung herstellen möchten.

Wenn Ihre Datenbank eine Anmeldung erfordert, geben Sie die erforderlichen Anmeldedaten sowie alle weiteren erweiterten Einstellungen ein, die auf der Registerkarte Advanced des Dialogs verfügbar sind. Die Registerkarte All bietet eine Übersicht der definierten Verknüpfungsoptionen sowie erweiterte Optionen für den ausgewählten OLE-DB-Anbieter. Die Optionen können auf dieser Registerkarte nach Bedarf geändert werden.

Nachdem Sie die Verknüpfungsoptionen definiert haben, können Sie die Verbindung durch Klicken auf die Schaltfläche Test Connection (auf der Registerkarte Connection ) überprüfen. Bei erfolgreicher Verbindung wird ein entsprechender Bestätigungsdialog angezeigt.

Der Dialog Data Link Properties ist ein Microsoft-Dialog. Daher wird durch Drücken von F1 oder über die verfügbare Schaltfläche Help die Datei Microsoft Data Link Help geöffnet. Diese Datei ist nicht Teil der Dokumentation von Altium Designer.

Angeben einer Data Link-Datei

Wenn die Datenquelle, zu der Sie eine Verbindung herstellen möchten, durch eine Microsoft Data Link-Datei (*.udl) beschrieben wird, aktivieren Sie die dritte Verbindungsoption – Use Data Link File – und klicken Sie auf die zugehörige Schaltfläche Browse , um die gewünschte Datei zu suchen. Eine Data Link-Datei dient im Wesentlichen als Speicher für eine Verbindungszeichenfolge.

Verbindung herstellen

Nachdem Sie die Verbindung zur externen Datenbank definiert haben, wird der Text der Schaltfläche Connect fett dargestellt. Dies zeigt an, dass Sie die Verbindung herstellen können. Wenn die Verbindungsdaten korrekt sind, werden die Tabellen- und Zuordnungsinformationen der Zieldatenbank in die Database Library-/SVN Database Library-Datei geladen. Der Text der Schaltfläche Connect ändert sich in Connected, und die Schaltfläche wird ausgegraut.

Wenn es ein Problem mit den Verbindungsdaten gibt, beispielsweise eine fehlerhaft erstellte Verbindungszeichenfolge oder einen falsch eingegebenen Pfad, schlägt die Verbindung fehl und eine entsprechende Meldung wird angezeigt. Überprüfen Sie Ihre Verbindungseinstellungen und klicken Sie erneut auf die Schaltfläche Connect .

Beispiele für die Anzeige einer fehlgeschlagenen Verbindung in einer Datenbankbibliothek. Beispiele für die Anzeige einer fehlgeschlagenen Verbindung in einer Datenbankbibliothek.

Wenn Sie die Verbindungseinstellungen ändern, während eine Verbindung zu einer Datenbank besteht, wird die aktive Verbindung unterbrochen, und der Text der Schaltfläche Connect ändert sich in Reconnect. Klicken Sie darauf, um die Verbindung wiederherzustellen.

Nach der ersten erfolgreichen Verbindung und dem Speichern der Database Library-/SVN Database Library-Datei wird die Verbindung bei jedem Öffnen der Datei automatisch hergestellt, sofern Speicherort und Dateiname der Zieldatenbank nicht geändert werden.

Verknüpfung zum Versionskontroll-Repository festlegen (nur SVNDbLib)

Bei einer DbLib werden die Symbol- und Modellbibliotheken auf Ihrer Festplatte oder einem anderen lokalen Medium bzw. Netzwerkmedium gespeichert. Beachten Sie, dass diese Bibliotheken bei einer SVNDbLib unter Versionskontrolle in einem Subversion-Repository gespeichert werden. In der SVNDbLib-Datei müssen Sie die Verknüpfung zu diesem Repository definieren. Die Verbindung zum SVN-Repository wird auf der Registerkarte SVN Repository des Dialogfelds Database Library Options (Tools » Options) definiert. Sie können dieses Dialogfeld auch öffnen, indem Sie im Bereich Field Settings der Dokumentansicht auf die Schaltfläche Options klicken.

Beispiel einer Verbindung zu einem dateibasierten SVN-Repository.Beispiel einer Verbindung zu einem dateibasierten SVN-Repository.

Auflistung der Datenbanktabellen

Nach erfolgreicher Verbindung zur externen Datenbank werden die Tabellen- und Zuordnungsdaten geladen. Auf der linken Seite des DbLib-/SVNDbLib-Dokuments werden alle Tabellen aufgelistet, die in der verbundenen Datenbank vorhanden sind.

Bei einer Excel-basierten Datenbank entspricht eine Tabelle einem Arbeitsblatt in der verknüpften Tabellenkalkulationsdatei. Der Tabellenname erhält das Suffix $.

In der verbundenen Datenbank vorhandene Tabellen.In der verbundenen Datenbank vorhandene Tabellen.

Mit der Option Enable neben jedem Tabelleneintrag können Sie festlegen, ob die jeweilige Tabelle Teil der resultierenden Datenbankbibliothek sein soll. Wenn die Datenbankbibliothek zur Liste der verfügbaren dateibasierten Bibliotheken hinzugefügt wird, um sie im Panel „Components“ zu durchsuchen, erscheint jede Tabelle als eigenständige Bibliothek. Obwohl also tatsächlich nur eine Datenbankbibliothek hinzugefügt wird, verhält es sich aus Sicht des Panels Components so, als hätten Sie mehrere separate Bibliotheken hinzugefügt. Weitere Informationen finden Sie unter Suche nach Bauteilen in dateibasierten Bibliotheken und Datenbankbibliotheken.

Wenn Sie in der Liste auf einen Tabelleneintrag klicken, ändert sich dessen Symbol von Database table icon, inactive table zu Database table icon, active table, um ihn als aktuell aktive Tabelle zu kennzeichnen. Die Tabelle wird mit all ihren Daten auf der Registerkarte Table Browser des Dokuments angezeigt. In dieser bearbeitbaren Tabellenansicht können Sie die Inhalte schnell einsehen und bei Bedarf ändern, ohne die externe Datenbank selbst öffnen zu müssen.

Durchsuchen einer Quelltabelle in der verbundenen Datenbank.Durchsuchen einer Quelltabelle in der verbundenen Datenbank.

Um den Bereich des Tabellenbrowsers zu vergrößern (wie in der Abbildung oben gezeigt), klappen Sie den gesamten darüberliegenden Bereich (Verbindungs- und Feldeinstellungen) ein, indem Sie oben rechts in der Dokumentansicht auf das Steuerelement Collapse icon - collapse a region of the database library document klicken. Klicken Sie zum Ausklappen auf Expand icon - expand a region of the database library document. Die Tabelle unterstützt außerdem die bekannten Funktionen zum Gruppieren, Sortieren und Filtern.

Abgleichkriterien festlegen

Nachdem ein Bauteil aus der externen Datenbank platziert wurde, muss die Verknüpfung zwischen dem platzierten Bauteil und dem Datenbankdatensatz, dessen Informationen zur Erstellung des Bauteils verwendet wurden, erhalten bleiben. Im Wesentlichen müssen die beiden einander zugeordnet werden.

Beim Platzieren eines Bauteils werden dessen Parameterinformationen anhand der entsprechenden Felder des Datenbankdatensatzes dynamisch erstellt. Die Verknüpfung zwischen dem Schaltplanbauteil und dem Datenbankdatensatz nach der Platzierung wird über einen oder mehrere dieser Parameter hergestellt. Im Bereich Field Settings des Dokuments können Sie die Abgleichkriterien definieren – entweder als einfache Suche anhand eines einzelnen Schlüssels oder als erweiterten Abgleich mithilfe einer WHERE-Klausel.

Die Abgleichkriterien werden für jede Tabelle separat festgelegt.

Festlegen der Abgleichkriterien nach der Platzierung.Festlegen der Abgleichkriterien nach der Platzierung.

Suche anhand eines einzelnen Schlüssels

Wenn die Option Single key lookup aktiviert ist (Standardeinstellung), werden die Felder Database field und Part parameter verfügbar. Das erste Feld listet alle verfügbaren Feldnamen (Spaltenüberschriften) in der aktiven Tabelle der Datenbank auf. Da die Parameter eines Schaltplanbauteils beim Platzieren hinzugefügt werden, entspricht das Feld Part parameter dem jeweils ausgewählten Datenbankfeld.

Als Suchschlüsselfeld wird üblicherweise ein Feld verwendet, das jedes Bauteil in der externen Datenbank eindeutig identifiziert, beispielsweise eine Teilenummer. Das ausgewählte Suchfeld wird auf der Registerkarte Field Mappings des Dokuments durch den ausgegrauten Eintrag Design Parameter gekennzeichnet.

Zuordnung über einen einzelnen Schlüssel anhand der Teilenummer.Zuordnung über einen einzelnen Schlüssel anhand der Teilenummer.

Wenn Sie nach der Platzierung die Funktion Update Parameters From Database verwenden, werden die Informationen aus dem ausgewählten Schlüsselparameter der platzierten Schaltplanbauteile gelesen. Anschließend wird im ausgewählten Schlüsselfeld der Datenbank über alle aktivierten Tabellen hinweg nach diesen Informationen gesucht. Bei einer Übereinstimmung können Informationen aus anderen Zellen dieses Datensatzes der zugehörigen Tabelle in die zugeordneten Parameter des Schaltplanbauteils übernommen werden.

Erweiterter Abgleich – die WHERE-Klausel

Die Option Single key lookup funktioniert gut, wenn eine eindeutige Teilenummer oder ID für den Abgleich vorhanden ist. Beim Abgleich anhand eines nicht eindeutigen Parameters wie Kapazität oder Widerstand ist sie jedoch weniger geeignet. In diesem Fall sollten Sie die erweiterte WHERE-Klausel verwenden. Damit können Sie einen Abgleich anhand mehrerer Schlüssel festlegen, um das Schaltplanbauteil mit seinem ursprünglichen Datenbankdatensatz zu verknüpfen.

In ihrer einfachsten Form bildet die WHERE-Klausel (in SQL-Syntax geschrieben) die ausgewählten Einträge ab, die die Suche anhand eines einzelnen Schlüssels definieren. Wenn beispielsweise für Database field der Standardwert Part Number ausgewählt wurde, würde das Feld Part parameter automatisch ebenfalls auf Part Number gesetzt, und der Eintrag für die WHERE-Klausel würde lauten:

[Part Number] = '{Part Number}'

Die eckigen Klammern um das Datenbankfeld (die Tabellenspalte) sind Begrenzungszeichen, wie sie auf der Registerkarte Advanced des Dialogfelds Database Connection festgelegt sind. Öffnen Sie dieses Dialogfeld entweder durch Klicken auf die Schaltfläche Advanced im Bereich Source of Connection des Dokuments oder über das Hauptmenü Tools .

Mapping between the component parameters and the database, using a Where clause Die Registerkarte Advanced des Dialogfelds Database Connection bietet zusätzliche SQL-Optionen zum Einschließen von
Tabellennamen in Begrenzungszeichen oder zur Verwendung von Tabellenschemanamen in einer erstellten WHERE-Klausel.

Welche Begrenzungszeichen beim Einschließen von Tabellennamen verwendet werden, hängt von der verwendeten Datenbank ab. Beispielsweise können eckige Klammern [ ] nur in Microsoft-Datenbanken wie Access, Excel über ADO oder MSSQL (neuere Versionen) verwendet werden. MYSQL verwendet dafür das Zeichen ` (Backtick). In jeder Datenbank müssen Spaltennamen eigentlich nur dann in Begrenzungszeichen eingeschlossen werden, wenn sie Leerzeichen enthalten oder reservierte Wörter (der jeweiligen Datenbank) sind. Welche Begrenzungszeichen gegebenenfalls verwendet werden, entnehmen Sie der Dokumentation Ihrer Datenbanksoftware.

Die geschweiften Klammern geben an, dass der referenzierte Eintrag ein Designparameter ist. Die einfachen Anführungszeichen legen fest, dass der Designparameter als Zeichenfolge und nicht als Zahl (ohne Anführungszeichen) behandelt wird. Die Übereinstimmung der Datentypen ist sehr wichtig, da SQL zwischen Datentypen unterscheidet. Der Designparameter sollte denselben Datentyp wie die Spalte in der Datenbank haben.

Mit der Standard-SQL-Syntax kann die WHERE-Klausel dann erweitert werden, um einen Abgleich anhand mehrerer Database field/Part parameter-Einträge durchzuführen, zum Beispiel:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

In diesem Fall würde mithilfe von drei verschiedenen Designparametern eine Verknüpfung zu einem einzelnen Datensatz in der entsprechenden Datenbanktabelle hergestellt. Beachten Sie, dass der Eintrag für den Designparameter Tolerance nicht in Anführungszeichen steht. Das bedeutet, dass der Datentyp der Spalte in der zugehörigen Datenbanktabelle Number und nicht String ist.

Mit der Standard-SQL-Syntax können Sie die WHERE-Klausel grundsätzlich so einfach oder komplex gestalten, wie Sie möchten.

Zuordnung von Datenbankfeldern zu Designparametern

Designparameter für ein Bauteil, das aus einer Datenbankbibliothek platziert wird, werden beim Platzieren erstellt bzw. hinzugefügt. Welche Parameter tatsächlich erstellt werden und welche Optionen zur Aktualisierung ihrer Informationen nach der Platzierung mit dem Befehl Tools » Update Parameters From Database verwendet werden, wird durch die Zuordnungs- und Aktualisierungsinformationen in der Datei der Datenbankbibliothek/SVN-Datenbankbibliothek festgelegt. Diese Einstellungen werden auf der Registerkarte Field Mappings der Hauptdokumentansicht vorgenommen.

Zuordnungs- und Aktualisierungsoptionen werden für jede Tabelle separat festgelegt.

Legen Sie die Optionen für die Parameterzuordnung und -aktualisierung auf der Registerkarte Field Mappings des DbLib/SVNDbLib-Dokuments fest.Legen Sie die Optionen für die Parameterzuordnung und -aktualisierung auf der Registerkarte Field Mappings des DbLib/SVNDbLib-Dokuments fest.

Modell- und Parameterzuordnung

Die ersten beiden Spalten (von links) auf der Registerkarte Field Mappings steuern, welche Informationen aus der Datenbank den Attributen, Modellen und Parametern des Bauteils zugeordnet werden.

  • Database Field Name – Diese Spalte listet alle Feldnamen (Spaltennamen) in der aktuell aktiven Datenbanktabelle auf.
  • Design Parameter – Diese Spalte legt fest, wie das jeweilige Feld in der Datenbank verwendet werden soll. Es kann als Quelle für das Symbol- oder Footprint-Modell eines Bauteils dienen (in diesem Fall steht der Eintrag in eckigen Klammern) oder als Bauteilparameter übernommen werden (diese Einträge stehen nicht in Klammern).
Wenn Sie ein DbLib/SVNDbLib-Dokument öffnen, das mit einer Datenbank verbunden ist, werden Sie feststellen, dass einige Designparameter in eckigen Klammern stehen und andere nicht. Die eckigen Klammern kennzeichnen einen reservierten Namen, beispielsweise [Library Ref]. Diese Daten werden verwendet, um die Attribute und Modelle des Bauteils zu befüllen. Designparameter, die nicht in eckigen Klammern stehen, werden zu Bauteilparametern.

Die erste Zuordnung erfolgt automatisch beim Herstellen der Verbindung zur Datenbank. Dabei werden alle Datenbankfelder zugeordnet.

Beachten Sie, dass die automatische Zuordnung voraussetzt, dass die Datenbankfeldnamen mit den in Altium Designer verwendeten reservierten Namen übereinstimmen. Ist dies nicht der Fall, muss die Zuordnung manuell konfiguriert werden.

Attribute & Modelle

Wenn der Datenbankfeldname einem der folgenden reservierten Namen entspricht, wird der zugehörige Zuordnungseintrag für das Attribut/Modell automatisch im Feld Design Parameter festgelegt:

  • Description → [Description]
  • Footprint Ref → [Footprint Ref]
  • Footprint Path → [Footprint Path]
  • Footprint Ref n → [Footprint Ref n]
  • Footprint Path n → [Footprint Path n]
In einer Datenbanktabelle können beliebig viele Footprint-Modellreferenzen (und Pfade) angegeben und in der DbLib/SVNDbLib-Datei zugeordnet werden. In den reservierten Namen steht n für eine positive ganze Zahl, beginnend mit 2.
  • Library Ref → [Library Ref]
  • Library Path → [Library Path]
  • Orcad Footprint → [Orcad Footprint]
  • Orcad Library → [Orcad Library]
Diese Referenzen werden beim Importieren einer OrCAD CIS-Konfigurationsdatei und von Bibliotheken sowie beim Erstellen einer Standard-Datenbankbibliothek (DbLib) verwendet.
  • PCB3D Ref → [PCB3D Ref]
  • PCB3D Path → [PCB3D Path]

    • Referenzen auf PCB3D beziehen sich auf den veralteten 3D-Viewer und sollten für neue Designs nicht verwendet werden. Die native 3D-Engine des PCB-Editors kann Bauteilkörper und importierte 3D-Modelldateien darstellen, die mit Bauteil-Footprints verknüpft sind.
    • PCB3D-Modellzuordnungen können in einer SVNDbLib-Datei definiert werden. Die Speicherung von PCB3D-Modellbibliotheken im Subversion-Repository wird jedoch nicht unterstützt.
  • Sim Description → [Sim Description]
  • Sim Excluded Parts → [Sim Excluded Parts]
  • Sim File → [Sim File]
  • Sim Kind → [Sim Kind]
  • Sim Model Name → [Sim Model Name]
  • Sim Netlist → [Sim Netlist]
  • Sim Parameters → [Sim Parameters]
  • Sim Port Map → [Sim Port Map]
  • Sim Spice Prefix → [Sim Spice Prefix]
  • Sim SubKind → [Sim SubKind]

    Weitere Informationen zu den Feldern für Simulationsmodelle finden Sie unten unter Zuordnung von Simulationsmodellen.
    Für ein Bauteil in einer externen Datenbank kann nur eine Simulationsmodell-Verknüpfung definiert werden. Üblicherweise ist mit einem Bauteil ohnehin nur ein einzelnes Simulationsmodell verknüpft. Wenn Sie mehrere Simulationsmodell-Verknüpfungen einrichten möchten, müssen die weiteren Verknüpfungen zusammen mit diesem Bauteil in der Quell-Schaltplanbibliotheksdatei definiert und gespeichert werden.
    Verknüpfte Simulationsmodelle werden für eine versionsverwaltete Datenbankbibliothek (SVNDbLib) unterstützt. Die Speicherung von Simulationsmodelldateien im Subversion-Repository wird jedoch nicht unterstützt.

Diese Zuordnungen legen die Attribut- und Modellinformationen des Bauteils fest. Beim Platzieren des Bauteils wird das im Feld [Library Ref] des entsprechenden Datenbankdatensatzes angegebene Schaltplansymbol aus der angegebenen Schaltplanbibliothek extrahiert. Ebenso werden die im Datensatz gespeicherten Informationen zu PCB-Footprints und Simulationsmodellen dem Bauteil als verknüpfte Footprint- bzw. Simulationsmodelle hinzugefügt.

Der Eintrag [Library Ref] muss in der Spalte Design Parameter vorhanden und dem Database Field Name zugeordnet sein, das das Schaltplansymbol angibt, damit ein Bauteil aus der Datenbankbibliothek/SVN-Datenbankbibliothek in einem Schaltplan platziert werden kann. Wenn die Datenbanktabelle die Symbolreferenz unter einem anderen Database Field Name enthält, beispielsweise SCH Symbol, müssen Sie den zugehörigen Design Parameter-Eintrag für dieses Feld über die Dropdown-Liste der betreffenden Zelle manuell auf [Library Ref] setzen.

Wenn Modellreferenzinformationen unter anderen Feldnamen in die Datenbank eingetragen wurden, müssen Sie die Zuordnung ebenfalls manuell vornehmen. Wählen Sie dazu für jedes Feld den entsprechenden Design Parameter-Eintrag ([Footprint Ref], [Footprint Ref n], [PCB3D Ref], [Sim Model Name] usw.) aus der Dropdown-Liste aus.

Mapping the symbol and footprint models from the database to the design componentUm die Symbol- und Modellinformationen eines Bauteils beim Platzieren festzulegen, sind die Symbol- und Modellreferenzfelder in der Datenbank die entscheidenden
Zuordnungselemente. Stellen Sie sicher, dass die definierte Zuordnung eine Symbolreferenz und mindestens eine PCB-Footprint-Referenz enthält.

Wie bereits erwähnt, können mehrere PCB-Modelle zugeordnet werden. Der Database Field Name, der Design Parameter [Footprint Ref] zugeordnet ist, wird beim Platzieren des Bauteils im Schaltplan zum Standard-Footprint. Dieser Footprint wird platziert, wenn das Design in die PCB-Umgebung übertragen wird.
Bei der Zuordnung von Symbolen und Modellen für eine DbLib/SVNDbLib-Datei sind Pfadangaben in der externen Datenbank optional. Weitere Informationen finden Sie unter Speicherorte für Symbol- und Modellbibliotheken festlegen.

Zuordnung von Simulationsmodellen

Dieser Abschnitt beschreibt die einzelnen Datenbankfelder, die einer externen Datenbanktabelle hinzugefügt werden können, um die Verknüpfung zum Simulationsmodell zu definieren, die beim Platzieren des Bauteils erstellt wird.

  • Sim Model Name – der Name des Modells, das Sie verwenden möchten. Nach dem Platzieren des Bauteils wird diese Information im Feld Model Name des Dialogs Sim Model angezeigt.

    Bei der Zuordnung von Datenbankfeldern zu Designparametern in der DBLib-Datei entspricht das Feld „Sim Model Name“ den Feldern „Footprint Ref“, „Library Ref“ usw.
  • Sim Description – eine Beschreibung des verknüpften Modells. Diese Information ist optional und hat keinen Einfluss auf die Funktion der Simulationsmodellverknüpfung.
  • Sim File – eine bestimmte Modelldatei, in der nach dem im Feld Sim Model Name angegebenen Simulationsmodell gesucht werden soll. Dieses Feld kann auf verschiedene Weise verwendet werden:

    • Sie können einen absoluten Pfad zu einer Modelldatei eingeben (z. B. C:\DbLibs\Switching Diodes\Libraries\JAS33.mdl). In dieser Datei wird nach dem im Feld Sim Model Name angegebenen Modell gesucht. Wird es gefunden, wird es verwendet.
    • Sie können einen relativen Pfad (bezogen auf die DbLib-Datei) zu einer Modelldatei eingeben (z. B. Libraries\JAS33.mdl). In dieser Datei wird nach dem im Feld Sim Model Name angegebenen Modell gesucht. Wird es gefunden, wird es verwendet.
    • Sie können nur den Namen der Modelldatei eingeben (z. B. JAS33.mdl). Die in der DbLib-Datei definierten Suchpfade werden verwendet, um die erste Modelldatei zu finden, die dem angegebenen Namen entspricht und das im Feld Sim Model Name angegebene Modell enthält.
    • Sie können das Feld leer lassen. Die in der DbLib-Datei definierten Suchpfade werden verwendet, um die erste Modelldatei zu finden, die das im Feld Sim Model Name angegebene Modell enthält.
    Suchpfade für die DbLib-Datei werden auf der Registerkarte Symbol & Model Search Paths des Dialogs Database Library Options definiert (Tools » Options).
  • Sim Kind – die übergeordnete Kategorie des zu verknüpfenden Modells.
  • Sim SubKind – der Typ des zu verknüpfenden Modells.
  • Sim Netlist – die Informationen zur Netzlistenvorlage entsprechend dem Typ des zu verknüpfenden Modells. Dieses Feld ist besonders wichtig, wenn Sie eine eigene Netzlistenvorlage angeben und das Feld Sim SubKind auf Generic Editor gesetzt haben. Dadurch können Sie genauer steuern, welche Informationen in die Netzliste aufgenommen werden.

    Dieses Feld muss ausgefüllt werden und darf nicht leer bleiben. Andernfalls wird kein Eintrag für das Modell in der Simulationsnetzliste erstellt, und das aus der Datenbankbibliothek platzierte Bauteil wird nicht simuliert.
  • Sim Spice Prefix – das SPICE-Präfix für den Modelltyp, mit dem Sie eine Verknüpfung herstellen.
  • Sim Port Map – die Zuordnung der Pins des Schaltplanbauteils zu den Pins des verknüpften Modells. Nach dem Platzieren des Bauteils werden diese Informationen im Bereich Pin Mapping des Dialogs Sim Model angezeigt.

    Jede Pin-Paarung muss im folgenden Format eingegeben werden:

    (SchematicPinNumber:ModelPinNumber),

    wobei die einzelnen Zuordnungspaare durch Kommas getrennt werden.

    Wenn Sie beispielsweise ein Dioden-Simulationsmodell zuordnen, bei dem Schaltplan-Pin 1 (Anode) dem Modell-Pin 1 (Anode) und Schaltplan-Pin 3 (Kathode) dem Modell-Pin 2 (Kathode) zugeordnet werden muss, lautet der Eintrag im Datenbankfeld:

    (1:1),(3:2)

  • Sim Excluded Parts – erstellen Sie dieses Feld in der Datenbank, wenn Sie bestimmte Teilbauteile eines mehrteiligen Bauteils von der Simulation ausschließen möchten. Diese Information entspricht der Option Exclude part from simulation im Bereich Pin Mapping des Dialogs Sim Model.

    Standardmäßig werden alle Teilbauteile eines mehrteiligen Bauteils in eine Simulation einbezogen. Sie müssen daher nur die Nummern der Teilbauteile angeben, die Sie ausschließen möchten. Trennen Sie mehrere Teilbauteile in der Ausschlussliste durch Kommas. Wenn ein Bauteil beispielsweise aus vier Teilbauteilen besteht und die Teilbauteile 2 und 4 in keiner Simulation berücksichtigt werden sollen, geben Sie Folgendes in das Datenbankfeld ein:

    2,4

  • Sim Parameters – erstellen Sie dieses Feld in der Datenbank, wenn Sie den Simulationsparametern des Modells Werte zuweisen möchten. Dies sind Parameter, die auf Bauteilebene definiert werden können, im Gegensatz zu den erweiterten Parametern, die in einer Modelldatei enthalten sein können.

    Ein Parameter muss im folgenden Format eingegeben werden:

    ParameterName=Value,

    Mehrere Parameter müssen durch einen senkrechten Strich (|) getrennt werden.

    Wie Sie vielleicht wissen, kann ein Simulationsparameter auf Bauteilebene auch als Bauteilparameter festgelegt werden. Er erscheint dann im Bereich Parameters des zugehörigen Dialogs Component Properties und kann anschließend auf dem Schaltplanblatt angezeigt werden. Standardmäßig wird ein Parametereintrag im Feld Sim Parameters automatisch als Bauteilparameter hinzugefügt. Wenn Sie nicht möchten, dass ein Simulationsparameter als Bauteilparameter hinzugefügt wird, stellen Sie dem Parameternamen einfach ein Ausrufezeichen voran (z. B. !Initial Voltage=100mV).

    Betrachten wir ein Diodenmodell mit den folgenden vier Parametern auf Bauteilebene:

    • Flächenfaktor
    • Anfangsbedingung
    • Anfangsspannung
    • Temperatur.

    Nehmen wir nun an, dass in der Datenbank Werte für den Flächenfaktor (z. B. 2) und die Temperatur (z. B. 22 °C) hinzugefügt werden sollen. Außerdem sollen beide nicht als Bauteilparameter hinzugefügt werden. Der Eintrag im Feld Sim Parameters würde lauten:

    !Area Factor=2|!Temperature=22

Nachdem Sie das Bauteil aus der Datenbankbibliothek platziert haben, können Sie überprüfen, ob die für die Simulationsverknüpfung definierten Informationen tatsächlich den Anforderungen entsprechen. Wählen Sie bei im Designbereich ausgewähltem Bauteil den Simulationsmodelleintrag im Bereich Parameters des Panels Properties aus und klicken Sie auf die Schaltfläche , um den Dialog Sim Model zu öffnen. Dort können Sie Folgendes überprüfen:

  • Die Modelldatei wurde wie erwartet gefunden. Wenn sie gefunden wurde, wird ihr Inhalt auf der Registerkarte Model File des Dialogs angezeigt.
  • Die übrigen Simulationsinformationen aus der Datenbank wurden wie erwartet zum Dialog hinzugefügt.

Die in den Datenbankfeldern gespeicherten Werte werden bei der Ausführung einer Simulation für das aus der Datenbankbibliothek platzierte Bauteil verwendet. Beachten Sie jedoch: Wenn Sie für ein aus einer Datenbankbibliothek platziertes Bauteil den Dialog Sim Model eines Simulationsmodells öffnen und auf OK klicken, werden die Felder Sim Netlist und Sim Spice Prefix für dieses Bauteil automatisch anhand des ausgewählten Modelltextes festgelegt.

Parameter

Alle anderen Datenbankfeldnamen werden automatisch gleichnamigen Designparametern zugeordnet. Wenn ein Feld in der Datenbank beispielsweise Tolerance heißt, wird ihm ein Designparameter mit dem Namen Tolerance zugeordnet. Sie können den Namen eines Designparameters ändern, indem Sie in seine Zelle klicken und den neuen Namen direkt eingeben. Diese Designparameternamen werden im Bereich Parameters des zugehörigen Eigenschaftendialogs des Bauteils angezeigt, sobald es auf einem Schaltplanblatt platziert wurde.

Einer Komponente in der Datenbank können zahlreiche Datenfelder zugeordnet sein, die Sie beim Platzieren auf einem Schaltplanblatt nicht alle als Designparameter zur Komponente hinzufügen möchten oder müssen. Viele dieser Informationen werden möglicherweise erst beim Erstellen einer Stückliste benötigt. Im Dialog „Report Manager“ können Sie einer Stückliste Parameterinformationen direkt aus einer verknüpften Datenbank hinzufügen. Dadurch lässt sich die Informationsmenge reduzieren, die in den Schaltplan-Quelldokumenten „mitgeführt“ wird. Weitere Informationen finden Sie im Abschnitt Vorbereiten einer Stückliste im Report Manager.

Setzen Sie bei Feldern, die Sie ausdrücklich nicht aus der Datenbank zuordnen möchten, den Eintrag Design Parameter auf [None]. Nicht zugeordnete Datenbankfelder sind auf der Registerkarte durch ein rotes Kreuz (Cross icon, indicating that a database field is not mapped to a component parameter) gekennzeichnet. Zugeordnete Datenbankfelder sind durch ein grünes Häkchen (Tick icon, indicating that a database field is mapped to a component parameter) gekennzeichnet.

Konfigurieren Sie die Parameterzuordnung nach Bedarf. Wählen Sie [None], um zu verhindern, dass ein Parameter aus der Datenbank der platzierten Komponente zugeordnet wird. Nicht zugeordnete Parameter können bei Bedarf direkt in die Stückliste aufgenommen werden.Konfigurieren Sie die Parameterzuordnung nach Bedarf. Wählen Sie [None], um zu verhindern, dass ein Parameter aus der Datenbank der platzierten Komponente zugeordnet wird. Nicht zugeordnete Parameter können bei Bedarf direkt in die Stückliste aufgenommen werden.

Um ein nicht zugeordnetes Feld schnell wieder zuzuordnen, klicken Sie in die Zeile dieses Feldes und verwenden Sie die Tastenkombination Ctrl+D. Beachten Sie, dass Sie bei Modellzuordnungen die Auswahl manuell über die zugehörige Dropdown-Liste Design Parameter vornehmen müssen.

Optionen zur Parameteraktualisierung

In den übrigen Spalten auf der Registerkarte Field Mappings können Sie festlegen, welche Aktionen für Parameter ausgeführt werden, wenn eine Komponente erstmals aus der Datenbankbibliothek platziert oder eine bereits platzierte Komponente mit dem Befehl Tools » Update Parameters From Database aktualisiert wird.

Es handelt sich um die folgenden vier Spalten:

  • Update Values – Eine Zelle in dieser Spalte legt fest, welche Aktion ausgeführt werden soll, wenn der Parameter sowohl auf einem Schaltplanblatt als auch in der Datenbank vorhanden ist, die Werte jedoch voneinander abweichen. Sie können den Parameter der platzierten Komponente mit dem in der Datenbank gespeicherten Wert aktualisieren (Update) oder auf eine Aktualisierung verzichten (Do not update). Diese Option wird beim Ausführen des Befehls Update Parameters From Database nach dem Platzieren der Komponente berücksichtigt.
  • Add To Design – Eine Zelle in dieser Spalte legt fest, welche Aktion ausgeführt werden soll, wenn der Parameter in der Datenbank vorhanden ist, bei der platzierten Komponente jedoch fehlt. Sie können den Parameter hinzufügen (Add), ihn nicht hinzufügen (Do not add) oder ihn nur dann hinzufügen, wenn ihm in der Datenbank ein Wert zugewiesen ist (Add only if not blank in database). Diese Option wird sowohl beim erstmaligen Platzieren der Komponente aus der Datenbankbibliothek als auch beim Ausführen des Befehls Update Parameters From Database nach dem Platzieren berücksichtigt.
  • Visible On Add – Ein Kontrollkästchen in dieser Spalte legt fest, ob ein neu hinzugefügter Parameter, der beim erstmaligen Platzieren oder bei einer anschließenden Aktualisierung entsteht, für die Komponente auf dem Schaltplanblatt sichtbar ist (aktiviert) oder nicht (deaktiviert).
  • Remove From Design – Eine Zelle in dieser Spalte legt fest, welche Aktion ausgeführt werden soll, wenn der Parameter bei der platzierten Komponente vorhanden ist, in der Datenbank jedoch entweder fehlt oder keinen Wert hat. Sie können festlegen, dass der Parameter grundsätzlich nicht entfernt wird (Do not remove) oder dass er nur entfernt wird, wenn ihm in der Datenbank kein Wert zugewiesen ist (Remove only if blank in database). Diese Option wird beim Ausführen des Befehls „Update Parameters From Database“ nach dem Platzieren der Komponente berücksichtigt.

Zu Beginn sind die Felder Update Values, Add To Design und Remove From Design für jedes zugeordnete Datenbankfeld auf den Eintrag Default gesetzt, und die Option Visible On Add ist deaktiviert, wie in der folgenden Abbildung dargestellt.

Anfängliche (standardmäßige) Optionen zur Parameteraktualisierung.Anfängliche (standardmäßige) Optionen zur Parameteraktualisierung.

Anhand der Abbildung lassen sich vier wichtige Punkte zu den Aktualisierungsoptionen festhalten:

  1. Nicht zugeordnete Datenbankfelder haben keine zugehörigen Aktualisierungsoptionen.
  2. Attribut- und modellbasierte Zuordnungen (Einträge in eckigen Klammern in der Spalte Design Parameter) haben keine zugehörigen Aktualisierungsoptionen, da es sich hierbei nicht um Designparameter handelt.
  3. Das Schlüsselfeld (z. B. Part Number in der Abbildung) hat keine zugehörigen Aktualisierungsoptionen. Dieses Feld dient ausschließlich dem Parameterabgleich.
  4. Bei der Einstellung Default richtet sich eine Aktualisierungsoption nach der entsprechenden Standarddefinition auf der Registerkarte Default Actions des Dialogs Database Library Options (Tools » Options über die Hauptmenüs oder Options über das Kontextmenü der Registerkarte Table Browser). Sie können diesen Dialog auch öffnen, indem Sie im Bereich Field Settings der Dokumentansicht auf die Schaltfläche Options klicken.

Legen Sie die Standardoptionen zur Parameteraktualisierung für eine DbLib an zentraler Stelle fest. Bewegen Sie den Mauszeiger über das Bild, um die entsprechende Ansicht für eine SVNDbLib zu sehen.Legen Sie die Standardoptionen zur Parameteraktualisierung für eine DbLib an zentraler Stelle fest. Bewegen Sie den Mauszeiger über das Bild, um die entsprechende Ansicht für eine SVNDbLib zu sehen.

Der vierte Punkt bietet den Vorteil, dass Sie Aktualisierungsoptionen an zentraler Stelle festlegen und beim Definieren der Aktualisierungsoptionen für jedes zugeordnete Feld auf diese Stelle verweisen können. Deshalb wird der Eintrag Default beim Zuordnen eines Datenbankfeldes zu einem Designparameter automatisch in die entsprechenden Aktualisierungsfelder übernommen.

Wenn Sie die Standardeinstellung einer Aktualisierungsoption überschreiben möchten, klicken Sie auf der Registerkarte Field Mappings in das entsprechende Aktualisierungsfeld. Klicken Sie anschließend erneut, um eine Dropdown-Liste mit den verfügbaren Aktualisierungsoptionen zu öffnen.

Die Optionen zur Parameteraktualisierung können bei Bedarf manuell überschrieben werden.Die Optionen zur Parameteraktualisierung können bei Bedarf manuell überschrieben werden.

Auf diese Weise haben Sie die volle Kontrolle darüber, wie die Parameter im Design aktualisiert werden. Sie können alle Felder auf Default setzen und die erforderlichen Aktualisierungsentscheidungen im Dialog Database Library Options treffen, jedes Aktualisierungsfeld einzeln festlegen oder beide Vorgehensweisen kombinieren – die Entscheidung liegt ganz bei Ihnen. Bei bereits platzierten Komponenten erfolgt die Aktualisierung über einen Dialog Engineering Change Order. Falls Sie zu diesem Zeitpunkt bestimmte Aktualisierungen nicht durchführen möchten, können Sie die betreffenden Änderungen ausschließen. So haben Sie letztlich das letzte Wort darüber, welche Designparameter aktualisiert werden.

Speicherorte für Symbol- und Modellbibliotheken festlegen

Wenn Sie eine Komponente aus einer Datenbankbibliothek platzieren, wird ihr Symbol – das über die Zuordnung [Library Ref] festgelegt ist – aus der angegebenen Schaltplanbibliothek (*.SchLib) extrahiert. Ebenso befinden sich die in der Datenbank angegebenen Modellreferenzen (Footprint, PCB3D, Simulation) in den zugrunde liegenden Dateien für PCB-Bibliotheken (*.PcbLib), PCB3D-Bibliotheken (*.PCB3DLib) und Simulationsmodelle (*.mdl, *.ckt). Die Pfade zu diesen Dateien können in der Datenbank explizit angegeben werden, indem Sie:

  • einen absoluten Pfad zur Datei eingeben.
  • einen relativen Pfad zur Datei eingeben.

Wenn Sie in Ihrer Datenbank Felder für Pfadangaben definiert haben, müssen diese den entsprechenden Designparametern zugeordnet werden – [Library Path], [Footprint Path], [PCB3D Path], [Sim File] usw. (siehe auch Modell- und Parameterzuordnung).

Die Eingabe von Pfaden – auch relativen – in einer Datenbanktabelle kann etwas unflexibel sein. Wenn Sie den Speicherort einer Bibliotheks- oder Modelldatei ändern, müssen Sie die Datenbanktabelle entsprechend aktualisieren. Für mehr Flexibilität können Sie Angaben zur Bibliothekssuche direkt in der DbLib-/SVNDbLib-Datei hinterlegen. Dadurch können Sie in der Datenbank lediglich den Namen der Quellbibliothek oder Modelldatei angeben oder ganz auf diese Angabe verzichten.

Using Search Paths with a large number of symbol/model files - Suchpfade bieten zwar mehr Flexibilität und vereinfachen die Konfiguration der Suche nach Symbolen und Modellen, doch wird dieser Ansatz nicht empfohlen, wenn sich am Suchort sehr viele Symbol- oder Modelldateien befinden. Je nach verwendetem Dateibenennungsschema kann es bei Suchpfaden erforderlich sein, bei jeder Anforderung eines Symbols oder Modells sämtliche Bibliotheks-/Modelldateien im Pfad zu durchsuchen, beispielsweise beim Durchsuchen von Bauteilen oder beim Übertragen des Designs vom Schaltplan auf die Leiterplatte.

Für eine Datenbankbibliothek

Bei einer DbLib werden die Bibliothekssuchpfade auf der Registerkarte Symbol and Model Search Paths des Dialogs Database Library Options (Tools » Options) definiert. Dieser Dialog kann auch durch Klicken auf die Schaltfläche Options im Bereich Field Settings der Dokumentansicht geöffnet werden.

Festlegen von Suchpfaden für Symbol- und Modellbibliotheken.Festlegen von Suchpfaden für Symbol- und Modellbibliotheken.

So fügen Sie der Liste einen Pfad hinzu:

  1. Geben Sie den Pfad entweder direkt in das Feld unterhalb des Bereichs „Library Search Paths“ ein oder klicken Sie auf die Schaltfläche Browse for a folder button, um den Dialog Browse for Folder zu öffnen. Dort können Sie das Verzeichnis auswählen, in dem sich die benötigten Bibliotheks-/Modelldateien befinden.
  2. Sie können einen vollständigen oder einen relativen Pfad (relativ zum Speicherort der DbLib-Datei) hinzufügen. Dies steuern Sie mit der Option Add/Update As Relative Path.
  3. Nachdem Sie den gewünschten Pfad angegeben haben, fügen Sie ihn durch Klicken auf die Schaltfläche Add zur Liste der Suchpfade hinzu.
  4. Fügen Sie bei Bedarf weitere Suchpfade hinzu.
Wenn Sie bei der direkten Eingabe einen falschen Pfad angeben (z. B. zu einem nicht vorhandenen Ordner), kann der Eintrag zwar hinzugefügt werden, wird jedoch in der Liste ausgegraut dargestellt, um auf einen ungültigen Suchpfad hinzuweisen. Wenn Sie feststellen, dass Sie einen Pfad falsch eingegeben haben, können Sie ihn in der Liste auswählen und entweder auf die Schaltfläche Remove klicken oder seine Pfaddefinition ändern und auf die Schaltfläche Update klicken.

Die Bibliothekssuchpfade legen fest, wo Bibliotheks- und Modelldateien beim Platzieren aus der Datenbankbibliothek und bei der Suche nach einem Modell nach der Platzierung gefunden werden können. Welches Modell konkret verwendet wird, hängt davon ab, wie Sie Ihre Bibliothekssuchpfade eingerichtet haben und ob Sie Ihrer Datenbank spezifische Bibliotheksinformationen hinzugefügt haben. Die Suche erfolgt in der folgenden Reihenfolge:

  1. Wenn im zugeordneten Pfadfeld für das Symbol oder Modell ein vollständiger Pfad vorhanden ist, wird diese Bibliotheks-/Modelldatei verwendet und das im entsprechenden Referenzfeld angegebene Symbol oder Modell daraus extrahiert.
  2. Wenn im zugeordneten Pfadfeld für das Symbol oder Modell ein relativer Pfad vorhanden ist, wird diese Bibliotheks-/Modelldatei verwendet und das im entsprechenden Referenzfeld angegebene Symbol oder Modell daraus extrahiert.
  3. Wenn im zugeordneten Pfadfeld für das Symbol oder Modell nur ein Bibliotheks-/Modelldateiname vorhanden ist, werden die Suchpfade verwendet, um die erste Bibliotheks-/Modelldatei zu finden, deren Name mit dem angegebenen Namen übereinstimmt und die das im entsprechenden Referenzfeld angegebene Symbol oder Modell enthält.
  4. Wenn in der Datenbank keine Informationen zur Bibliotheks-/Modelldatei vorhanden sind, werden die Suchpfade verwendet, um die erste Bibliotheks-/Modelldatei zu finden, die das im entsprechenden Referenzfeld angegebene Symbol oder Modell enthält.

Für eine SVN-Datenbankbibliothek

Bei einer SVNDbLib werden die Basisverzeichnisse im Subversion-Repository, in denen sich die Symbole und Footprint-Modelle befinden, auf der Registerkarte SVN Repository des Dialogs Database Library Options (Tools » Options) angegeben. Dieser Dialog kann auch durch Klicken auf die Schaltfläche Options im Bereich Field Settings der Dokumentansicht geöffnet werden.

Festlegen der Basisverzeichnisse im Repository für Symbole und Footprints.Festlegen der Basisverzeichnisse im Repository für Symbole und Footprints.

Verwenden Sie die verfügbaren Felder im Bereich Models Location, um das Basisverzeichnis für die Symbole und Footprints anzugeben. Klicken Sie auf die Schaltfläche Click the ellipsis button to select the repository folder for the symbols and footprints rechts neben einem Feld, um den Dialog Browse for directory zu öffnen, der einen Einblick in das verknüpfte Repository bietet. Wählen Sie in diesem Dialog den gewünschten Ordner aus.

Suchen nach dem entsprechenden Verzeichnis im verknüpften SVN-Repository.Suchen nach dem entsprechenden Verzeichnis im verknüpften SVN-Repository.

Es ist wichtig zu betonen, dass sich die Symbole und Footprints innerhalb der angegebenen Basisverzeichnisse des Repositorys befinden müssen. Sie können sich selbstverständlich in Unterordnern dieser Verzeichnisse befinden, und die für Symbole und Footprints angegebenen Pfade können auf dasselbe Verzeichnis im Repository verweisen.

Die Modellspeicherorte legen fest, wo Bibliotheks- und Modelldateien beim Platzieren aus der versionsverwalteten Datenbankbibliothek und bei der Suche nach einem Modell nach der Platzierung gefunden werden können. Welche Schaltplansymbole und Footprint-Modelle konkret verwendet werden, hängt davon ab, wie Sie diese Speicherorte eingerichtet haben und ob Sie Ihrer Datenbank spezifische Bibliotheksinformationen hinzugefügt haben. Die Suche erfolgt in der folgenden Reihenfolge:

  1. Wenn im zugeordneten Pfadfeld für das Symbol oder Footprint-Modell ein vollständiger Pfad vorhanden ist (z. B. http://MyServer/svn/MyCompany/ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), wird diese Bibliotheksdatei verwendet und das im entsprechenden Referenzfeld angegebene Symbol oder der Footprint daraus extrahiert.
  2. Wenn im zugeordneten Pfadfeld für das Symbol oder Footprint-Modell ein relativer Pfad (relativ zum Stammverzeichnis des Repositorys) vorhanden ist (z. B. /ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), wird diese Bibliotheksdatei verwendet und das im entsprechenden Referenzfeld angegebene Symbol oder der Footprint daraus extrahiert. Die im Bereich „Repository Server Connection“ des Dialogs angegebene URL des Repositorys wird dem eingegebenen Pfad vorangestellt, um die absolute Adresse zu erhalten.
  3. Wenn im zugeordneten Pfadfeld für das Symbol oder Footprint-Modell nur ein Bibliotheksdateiname vorhanden ist (z. B. Capacitor_NonPolarized.SchLib), werden die angegebenen Modellspeicherorte innerhalb des Repositorys verwendet, um die erste Bibliotheksdatei zu finden, deren Name mit dem angegebenen Namen übereinstimmt und die das im entsprechenden Referenzfeld angegebene Symbol oder Footprint-Modell enthält.
Bei der Suche nach einem passenden Symbol oder Modell werden die zu einer flachen Liste zusammengefassten Ordnerpfade im Basisverzeichnis für Symbole oder Footprints alphabetisch sortiert und durchsucht. Wenn der Assistent zum Aufteilen von Bibliotheken verwendet wird, gibt es immer eine entsprechende Bibliothek mit dem Namen des jeweiligen Symbols oder Footprints.
  1. Wenn in der Datenbank keine Informationen zur Bibliotheksdatei vorhanden sind, werden die angegebenen Modellspeicherorte verwendet, um die erste Bibliotheksdatei zu finden, die das im entsprechenden Referenzfeld angegebene Symbol oder Footprint-Modell enthält.
Bei der Suche nach dem Symbol oder Footprint sucht das System zunächst nach der ersten Bibliothek, die genauso heißt wie das Symbol oder der Footprint selbst. Wenn beispielsweise der logische Symbolname in der Datenbank (angegeben durch die Zuordnung [Library Ref]) Capacitor_NonPolarized lautet, sucht das System nach der ersten Datei mit dem Namen Capacitor_NonPolarized.SchLib und sucht innerhalb dieser Datei nach dem Symbol. Wenn das Symbol oder der Footprint auf diese Weise nicht gefunden werden kann, sucht das System in allen Bibliotheken nach einer Übereinstimmung.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents