Verknüpfen vorhandener Komponenten mit einer Unternehmensdatenbank mithilfe einer Datenbankverknüpfungsdatei

Auf einen Blick

Verknüpfen Sie vorhandene Schaltplan- oder Bibliotheksbauteile über eine Database-Link-Datei in Altium Designer mit der zentralen Bauteildatenbank Ihres Unternehmens. Dieser Artikel erläutert, wie sich DbLink von Ansätzen mit Datenbankbibliotheken unterscheidet, wie Sie eine DbLink-Datei erstellen und wie Sie eine Verbindung zu einer externen Datenbank konfigurieren. Außerdem erfahren Sie, wie Sie zugeordnete Bauteilparameter mit Datenbankeinträgen synchronisieren, damit diese Informationen in Ihre Stückliste aufgenommen werden können. Lesen Sie weiter und machen Sie den nächsten Schritt zu synchronisierten Bauteildaten.

- Erfahren Sie, wann Sie DbLink anstelle von DbLib oder SVNDbLib verwenden sollten.
- Lernen Sie, wie Sie eine Database-Link-Datei erstellen und Verbindungen zu Access, Excel und anderen unterstützten Datenbanken konfigurieren.
- Machen Sie sich mit den Anforderungen an die Verknüpfung über Schlüsselfelder und den Besonderheiten von 64-Bit-Datenbank-Engines vertraut.
Mit KI tiefer einsteigen:

Eine häufige Anforderung vieler Unternehmen ist die Verknüpfung von Bauteilen im Elektronik-CAD mit der zentralen Bauteildatenbank des Unternehmens. Altium Designer unterstützt dies, indem vorhandene Bauteile durch das Erstellen und Verwenden einer Database Link-Datei mit Datensätzen in der Unternehmensdatenbank verknüpft werden können. Die Database-Link-Datei wird Ihrem Designprojekt oder Bibliothekspaket hinzugefügt. Damit können Sie bereits auf Schaltplanblättern platzierte Bauteile beziehungsweise – was häufiger der Fall ist – in einer Quell-Schaltplanbibliothek definierte Bauteile mit der Datenbank verknüpfen.

Nach der Verknüpfung können Sie mit dem Befehl Tools » Update Parameters From Database zugeordnete Parameterinformationen aus den Datenbankdatensätzen in die Designparameter der Bauteile übertragen. Diese Informationen können anschließend in die endgültige Stückliste (BOM) für die Bauteilbeschaffung aufgenommen werden.

The Move from 32-bit to 64-bit Software

Mit der Veröffentlichung von Altium Designer Version 18.0 und Altium NEXUS Version 1.0 wurde die Designsoftware auf 64 Bit umgestellt. Um Designbauteile in einer 64-Bit-Version der Altium-Software mit einer Datenbank zu verknüpfen, muss auch das Backend-Datenbankmodul in einer 64-Bit-Version vorliegen. Wenn Sie Microsoft Access oder Excel zur Verwaltung der Backend-Daten verwenden und eine 32-Bit-Version von Office installiert haben, können Sie zusätzlich das 64-Bit-Datenbankmodul von Microsoft Access installieren. Ausführliche Informationen dazu finden Sie in den Anweisungen auf der Seite Datenbankbibliotheken mit 32-Bit- und 64-Bit-Versionen von Altium Designer auf demselben Computer verwenden.

Wenn Sie versuchen, eine Verbindung über das 32-Bit-Datenbankmodul von Microsoft Access herzustellen, wird die folgende Fehlermeldung angezeigt.

Error dialog, reporting that a 64-bit version of the Microsoft Access Database engine is required for database linking

Beachten Sie, dass bestimmte Verbindungsfehler, beispielsweise eine falsche Syntax in den Provider-Angaben von Connection String, dazu führen können, dass auch nach der Installation des 64-Bit-Datenbankmoduls das falsche Datenbankmodul aufgerufen und der oben gezeigte Fehlerdialog angezeigt wird.

Ein Wort zu den Verknüpfungsmöglichkeiten ...

Altium Designer bietet drei Methoden, um ein Bauteil mit einer Datenbank zu verknüpfen: über eine Database-Link-Datei (*.DbLink), eine Database-Library-Datei (*.DbLib) oder eine SVN-Database-Library-Datei (*.SVNDbLib). Der DbLink-Ansatz bietet eine effiziente Möglichkeit, die in Ihrem Design oder Ihren Bibliotheken verwendeten Bauteile mit den in der Datenbank hinterlegten Daten zu verknüpfen und synchron zu halten. Der DbLib/SVNDbLib-Ansatz erweitert diese bewährte Verknüpfungsmethode um die Möglichkeit, ein Bauteil direkt aus der Datenbank zu platzieren. Dabei wird das Bauteil dynamisch aus den Informationen erstellt, die im zugehörigen Datenbankdatensatz gespeichert sind.

Bevor wir näher auf die Datenbankverknüpfung eingehen, lohnt es sich, die Unterschiede zwischen diesen beiden Methoden hinsichtlich ihrer Anwendung zu erläutern.

Verknüpfung über eine Database-Link-Datei

  • Bei dieser Methode definiert die Database-Link-Datei die Verknüpfung zwischen dem Schaltplanbauteil und einem passenden Datensatz in einer Datenbank. Die Zuordnung des Datensatzes erfolgt über Schlüsselfelder. Dabei kann ein einzelnes Schlüsselfeld (beispielsweise eine Teilenummer) oder eine Kombination mehrerer Schlüsselfelder (durch die Definition einer WHERE-Klausel) verwendet werden.
  • Bei dieser Verknüpfungsmethode müssen die Modell- und Parameterinformationen des Bauteils bereits als Teil des Altium Designer-Bibliotheksbauteils definiert sein. Auch die erforderlichen Schlüsselfeldinformationen müssen in der Definition des Bibliotheksbauteils enthalten sein. Sobald dies definiert ist, fügen Sie Ihrem Bibliothekspaket oder Designprojekt eine Database-Link-Datei hinzu. Anschließend können Sie die Bauteilinformationen (Parameter) mit den Feldinhalten der Datenbank synchronisieren.
  • Obwohl nicht jedes durch einen Datenbankdatensatz definierte physische Bauteil einem eigenen Altium Designer-Bibliotheksbauteil zugeordnet sein muss – mehrere Datenbankbauteile können dasselbe Bauteilsymbol verwenden –, wird diese Verknüpfungsmethode üblicherweise nach dem Prinzip „ein Datenbankdatensatz zu einem Altium Designer-Bauteil“ eingesetzt. Das jeweilige Altium Designer-Bauteil kann entweder eine auf einem Schaltplanblatt platzierte Instanz oder ein eigenständiges Bauteil in einer Bauteilbibliothek sein.
  • Bei einer Datenbankverknüpfung nach dem DbLink-Prinzip wird die Database-Link-Datei in das Bibliothekspaket oder Designprojekt aufgenommen.

Eine Verknüpfung zwischen Bibliotheksbauteilen und einer externen Datenbank ist nur möglich, wenn die Bibliothek Teil eines integrierten Bibliothekspakets (*.LibPkg) ist. Wählen Sie den Befehl File » New » Library » Integrated Library, um ein neues Bibliothekspaket zu erstellen, und fügen Sie diesem anschließend die Quell-Schaltplanbibliotheken hinzu.

► Erfahren Sie mehr über integrierte Bibliotheken.

Verknüpfung über eine Database-Library-Datei

Related page: Datenbankbibliotheken

  • Bei dieser Methode definiert die Database-Library-Datei ebenfalls die Verknüpfung zwischen dem Schaltplanbauteil und einem passenden Datensatz in einer Datenbank. Auch hier erfolgt die Zuordnung des Datensatzes über Schlüsselfelder. Dabei kann ein einzelnes Schlüsselfeld (beispielsweise eine Teilenummer) oder eine Kombination mehrerer Schlüsselfelder (durch die Definition einer WHERE-Klausel) verwendet werden.
  • Bei dieser Verknüpfungsmethode werden das Bauteilsymbol sowie die Modell- und Parameterinformationen eines Bauteils als Teil seiner Datensatzdefinition in der externen Datenbank gespeichert. Das referenzierte Schaltplanbauteil, das in einer zugrunde liegenden Bauteilbibliothek (*.SchLib) gespeichert ist, besteht lediglich aus dem Symbol. Es besitzt weder verknüpfte Modelle noch definierte Designparameter.
  • Beim Platzieren des Bauteils werden dessen Parameter- und Modellinformationen dynamisch anhand der entsprechenden Felder im zugeordneten Datenbankdatensatz und gemäß der definierten Zuordnung erstellt. Einer oder mehrere dieser Parameter werden anschließend verwendet, um anhand der definierten Zuordnungskriterien eine dauerhafte Verknüpfung mit der Datenbank aufrechtzuerhalten. Dadurch ist auch nach der Platzierung eine Synchronisierung möglich.
  • Da die Bauteile bei dieser Verknüpfungsmethode zum Zeitpunkt der Platzierung dynamisch erstellt werden, eignet sie sich besonders gut für das Prinzip „mehrere Datenbankdatensätze zu einem Altium Designer-Bauteil“. Beispielsweise könnte Ihre Datenbank die E96-Widerstandsreihe enthalten, wobei jeder Datensatz auf dasselbe Widerstandssymbol im Schaltplan und denselben PCB-Footprint verweist.
  • Anders als bei einer Datenbankverknüpfung nach dem DbLink-Prinzip, bei der die DbLink-Datei in das Bibliothekspaket oder Designprojekt aufgenommen werden muss, muss die DbLib/SvnDbLib-Datei nicht zum Projekt hinzugefügt werden. Die Datenbankbibliothek (DbLib) wird in die verfügbaren Bibliotheken aufgenommen, auf die Sie über das Components-Panel zugreifen können. Beachten Sie, dass die verfügbaren Bibliotheken aus Projektbibliotheken, installierten Bibliotheken oder Bibliotheken bestehen können, die über festgelegte Suchpfade gefunden werden.
  • DbLib/SVNDbLib-Dateien werden üblicherweise nach Bibliothekskategorien eingerichtet. Beispielsweise könnten Sie eine Datei für alle in Ihrer Unternehmensdatenbank aufgeführten Widerstände, eine weitere für Kondensatoren usw. verwenden.
Eine SVN-Datenbankbibliothek (*.SVNDbLib) ist eine Erweiterung des DbLib-Verknüpfungsmodells. Dieser Dateityp wird genauso wie eine DbLib verwendet, allerdings werden das Schaltplansymbol und die zugehörigen Modelle in Bibliotheken unter Versionskontrolle (Subversion) gespeichert.

Erstellen der Database-Link-Datei

Wie bereits erwähnt, bildet die Database-Link-Datei die Grundlage der Datenbankverknüpfung. Diese Datei wird mit dem DatabaseLink-Editor von Altium Designer erstellt und verwaltet. Dieser Editor steht zur Verfügung, wenn das aktive Dokument im Hauptfenster der Designumgebung eine *.DbLink-Datei ist.

Beispiel einer im DatabaseLink-Editor geöffneten DbLink-Datei.Beispiel einer im DatabaseLink-Editor geöffneten DbLink-Datei.

Erstellen Sie eine neue Datei dieses Typs auf eine der folgenden Arten:

  • Wählen Sie in den Hauptmenüs den Befehl File » New » Library » Database Link File.
  • Klicken Sie im Projects-Panel mit der rechten Maustaste auf den Eintrag des gewünschten Projekts und wählen Sie im Kontextmenü den Befehl Add New to Project » Database Link File.

Wenn Database-Link-Dateien einem Projekt hinzugefügt werden, erscheinen sie im Projects -Panel im Unterordner Settings\Database Link Files.

The DbLink file appears in the Settings folder in the Projects panel

Wenn auf der Seite „System – Standardwerte für neue Dokumente“ des Dialogs Preferences ein Standarddokument festgelegt wurde, wird die Database-Link-Datei mit diesem Standarddokument als Vorlage erstellt. Für eine Database-Link-Datei, die als Teil eines PCB-Projekts, eines integrierten Bibliothekspakets oder als freies Dokument erstellt wird, kann jeweils ein anderes Standarddokument zugewiesen werden.

Verbindung mit einer externen Datenbank herstellen

Tabellen- und Zuordnungsdaten werden erst dann im Hauptanzeigefenster des Editors angezeigt, wenn die aktive Database-Link-Datei erfolgreich mit der gewünschten externen Datenbank verbunden wurde. Die Verbindung wird über die Steuerelemente im Bereich Source of Connection definiert.

Festlegen der Verbindung zur externen Datenbank.Festlegen der Verbindung zur externen Datenbank.

Es kann eine Verbindung zu jeder Datenbank hergestellt werden, die OLE DB unterstützt. Die Optionen in diesem Bereich verwenden jeweils eine OLE-DB-Verbindungszeichenfolge, um eine Verbindung zur Zieldatenbank herzustellen. Einige Datenbanken unterstützen OLE DB möglicherweise nicht. Allerdings kann auf nahezu alle heute verwendeten Datenbankmanagementsysteme über die Open-Database-Connectivity-Schnittstelle (ODBC) zugegriffen werden. Die Datenbankverknüpfungsfunktion verwendet den ODBC-Anbieter von Microsoft, mit dem ein ADO (ActiveX Data Object) eine Verbindung zu jeder ODBC-Datenquelle herstellen kann. Somit kann jede ODBC-Datenbank angebunden werden. Der OLE-DB-Anbieter für die ODBC-Datenbank wird als Teil der Verbindungszeichenfolge angegeben.

Die Verbindung kann auch auf der Registerkarte Connection des Dialogs Database Connection definiert werden. Dieser lässt sich über das Hauptmenü Tools oder durch Klicken auf die Schaltfläche Advanced öffnen (rechts neben der Schaltfläche Connect am unteren Rand des Bereichs).

Schnellverbindung zu Access- und Excel-Datenbanken

Die Option Select Database Type bietet eine schnelle Möglichkeit zum Erstellen einer Verbindungszeichenfolge, wenn die Zieldatenbank mit Microsoft Access oder Microsoft Excel erstellt wurde. Wählen Sie bei dieser Option den Datenbanktyp aus und suchen und wählen Sie anschließend die gewünschte Datenbankdatei. Die entsprechende Verbindungszeichenfolge wird automatisch zusammengestellt und in das Feld für die Option Use Connection String eingetragen.

Sie können den vollständigen Pfad angeben oder den Pfad relativ zur Database-Link-Datei speichern.

Eine Verbindungszeichenfolge erstellen

Wenn Ihre Unternehmensdatenbank nicht auf Access oder Excel basiert und Sie die Verbindungszeichenfolge explizit erstellen möchten, aktivieren Sie die Option Use Connection String und klicken Sie anschließend auf die zugehörige Schaltfläche Build rechts daneben. Der Dialog Data Link Properties wird geöffnet.

Erstellen einer Verbindungszeichenfolge über den Dialog Data Link Properties. Erstellen einer Verbindungszeichenfolge über den Dialog Data Link Properties.

Der Dialog wird mit der Registerkarte Connection geöffnet. Auf der Registerkarte Provider des Dialogs ist standardmäßig der OLE-DB-Anbieter Microsoft Office <Version> Access Database Engine OLE DB Provider eingestellt. Dies ist die Standardeinstellung für den Anbieter bei neuen Database-Link-Dateien. Sie wird auch für die Verbindung zu Access-Datenbankdateien (*.mdb) verwendet. Ändern Sie den Anbieter bei Bedarf.

Geben Sie auf der Registerkarte Connection den Namen (einschließlich Pfad) der Datenbank ein, zu der Sie eine Verbindung herstellen möchten.

Wenn Ihre Datenbank eine Anmeldeberechtigung erfordert, geben Sie die entsprechenden Anmeldedaten sowie gegebenenfalls weitere erweiterte Einstellungen auf der Registerkarte Advanced des Dialogs ein. Die Registerkarte All enthält eine Zusammenfassung der definierten Verknüpfungsoptionen sowie erweiterte Optionen für den ausgewählten OLE-DB-Anbieter. Die Optionen können bei Bedarf auch auf dieser Registerkarte geändert werden.

Nachdem die Verknüpfungsoptionen definiert wurden, können Sie durch Klicken auf die Schaltfläche Test Connection (auf der Registerkarte Connection ) prüfen, ob die Verbindung erfolgreich hergestellt werden kann. Bei erfolgreicher Verbindung wird ein entsprechender Bestätigungsdialog angezeigt.

Der Dialog Data Link Properties ist ein Microsoft-Dialog. Wenn Sie F1 drücken oder die verfügbare Schaltfläche Help verwenden, wird daher die Datei Microsoft Data Link Help geöffnet. Diese Datei gehört nicht zur Dokumentation von Altium.

Eine Data-Link-Datei angeben

Wenn die Datenquelle, zu der Sie eine Verbindung herstellen möchten, durch eine Microsoft-Data-Link-Datei (*.udl) beschrieben wird, aktivieren Sie die dritte Verbindungsoption – Use Data Link File – und klicken Sie auf die zugehörige Schaltfläche Browse , um die gewünschte Datei zu suchen. Eine Data-Link-Datei dient im Wesentlichen als Speicher für eine Verbindungszeichenfolge.

Die Verbindung herstellen

Nachdem Sie die Verbindung zur externen Datenbank definiert haben, wird der Text der Schaltfläche Connect fett dargestellt. Dies signalisiert, dass Sie die Verbindung nun herstellen können. Wenn die Verbindungsangaben korrekt sind, werden die Tabellen- und Zuordnungsinformationen für die Zieldatenbank in die Database-Link-Datei geladen. Der Text der Schaltfläche Connect ändert sich in Connected, und die Schaltfläche wird ausgegraut.

Wenn ein Problem mit den Verbindungsangaben vorliegt, beispielsweise eine falsch aufgebaute Verbindungszeichenfolge oder ein fehlerhaft eingegebener Pfad, schlägt die Verbindung fehl und eine entsprechende Meldung wird angezeigt. Überprüfen Sie Ihre Verbindungseinstellungen und klicken Sie erneut auf die Schaltfläche Connect .

Beispiele für Meldungen bei fehlgeschlagener Verbindung.Beispiele für Meldungen bei fehlgeschlagener Verbindung.

Wenn Sie die Verbindungseinstellungen ändern, während eine Verbindung zu einer Datenbank besteht, wird die aktive Verbindung unterbrochen und der Text der Schaltfläche Connect ändert sich in Reconnect. Klicken Sie darauf, um die Verbindung wiederherzustellen.

Nach der ersten erfolgreichen Verbindung und dem Speichern der Database-Link-Datei wird die Verbindung bei jedem Öffnen der Datei automatisch hergestellt, sofern Speicherort und Dateiname der Zieldatenbank unverändert bleiben.

Liste der Datenbanktabellen

Nach erfolgreicher Verbindung zur externen Datenbank werden die Tabellen- und Zuordnungsdaten geladen. Auf der linken Seite des DbLink-Dokuments werden alle Tabellen aufgeführt, die in der verbundenen Datenbank vorhanden sind.

In der verbundenen Datenbank vorhandene Tabellen.In der verbundenen Datenbank vorhandene Tabellen.

Mit der Option Enable neben jedem Tabelleneintrag können Sie festlegen, ob diese Tabelle beim Aktualisieren von Parametern aus der Datenbank verwendet werden soll.

Wenn Sie auf einen Tabelleneintrag in der Liste klicken, ändert sich dessen Symbol von Database table icon, inactive table in Database table icon, active table, um die Tabelle als aktuell aktiv zu kennzeichnen. Die Tabelle wird mit allen ihren Daten auf der Registerkarte Table Browser des Dokuments angezeigt. Dabei handelt es sich um eine nicht bearbeitbare Kopie der Tabelle, mit der Sie deren Inhalt schnell einsehen können, ohne die externe Datenbank selbst öffnen zu müssen.

Durchsuchen einer Quelltabelle in der verbundenen Datenbank.Durchsuchen einer Quelltabelle in der verbundenen Datenbank.

Um den Bereich des Tabellenbrowsers zu vergrößern (wie in der Abbildung oben gezeigt), klappen Sie den gesamten darüberliegenden Bereich (Verbindungs- und Feldeinstellungen) ein, indem Sie auf das Steuerelement Collapse icon - collapse a region of the DbLink document oben rechts in der DbLink-Dokumentansicht klicken. Klicken Sie auf Expand icon - expand a region of the DbLink document, um ihn wieder aufzuklappen.

Abgleichkriterien festlegen

Um die Parameterinformationen von Bauteilen anhand der in den Feldern der externen Datenbank gespeicherten Informationen zu aktualisieren, muss jedes Bauteil im Design zunächst einer Zeile aus einer Tabelle der Datenbank zugeordnet werden. Im Bereich Field Settings des Dokuments können Sie die Abgleichkriterien definieren – entweder eine einfache Suche anhand eines einzelnen Schlüssels oder einen erweiterten Abgleich mithilfe einer WHERE-Klausel.

Die Abgleichkriterien werden für jede Tabelle einzeln festgelegt.

Festlegen der Abgleichkriterien.Festlegen der Abgleichkriterien.

Suche anhand eines einzelnen Schlüssels

Wenn die Option Single key lookup aktiviert ist (Standardeinstellung), sind die Felder Database field und Part parameter verfügbar. Database field listet alle verfügbaren Feldnamen (Spaltenüberschriften) in der aktiven Tabelle der Datenbank auf. Das Feld Part parameter listet alle Parameter auf, die in den Bauteilen des Designs vorhanden sind – sowohl Systemparameter als auch benutzerdefinierte Parameter.

Verwenden Sie diese Felder, um die Zuordnung zwischen einem Feld in der Tabelle und einem Parameter eines Bauteils festzulegen, der allen Bauteilen gemeinsam ist. Üblicherweise wird in beiden Fällen ein Feld für den Abgleich verwendet, das jede Komponente in der externen Datenbank eindeutig identifiziert, beispielsweise eine Teilenummer. Das gewählte Suchfeld wird auf der Registerkarte Field Mappings des Dokuments durch den ausgegrauten Eintrag Design Parameter gekennzeichnet.

Zuordnung über einen einzelnen Schlüssel anhand der TeilenummerZuordnung über einen einzelnen Schlüssel anhand der Teilenummer

Bei Verwendung der Funktion Tools » Update Parameters From Database werden Informationen aus dem gewählten Schlüsselparameter der platzierten Schaltplankomponenten gelesen. Anschließend wird im gewählten (Schlüssel-)Feld der Datenbank über alle aktivierten Tabellen hinweg danach gesucht. Bei einer Übereinstimmung können Informationen aus anderen Zellen dieses Datensatzes der übergeordneten Tabelle in die zugeordneten Parameter der Schaltplankomponente übernommen werden.

Erweiterter Abgleich – die WHERE-Klausel

Die Option Single key lookup funktioniert gut, wenn eine eindeutige Teilenummer oder ID für den Abgleich vorhanden ist. Bei einem Abgleich anhand eines nicht eindeutigen Parameters, beispielsweise der Kapazität oder des Widerstands, ist sie jedoch weniger geeignet. In diesem Fall sollte die erweiterte WHERE-Klausel verwendet werden. Mit ihr können Sie einen Abgleich über mehrere Schlüssel festlegen, um die Schaltplankomponente mit der erforderlichen Zeile in der entsprechenden Datenbanktabelle zu verknüpfen.

In ihrer einfachsten Form bildet die in SQL-Syntax geschriebene WHERE-Klausel die gewählten Einträge ab, die die Suche über einen einzelnen Schlüssel definieren. Wenn beispielsweise für Database field der Eintrag Part Number gewählt wurde und für den eindeutigen Part parameter (der für alle Bauteile im Design vorhanden ist) der Eintrag Part Number, würde die WHERE-Klausel wie folgt lauten:

[Part Number] = '{Part Number}'

Die eckigen Klammern um das Datenbankfeld (die Tabellenspalte) dienen als Begrenzungszeichen, wie auf der Registerkarte Advanced des Dialogs Database Connection festgelegt. Öffnen Sie diesen Dialog entweder durch Klicken auf die Schaltfläche Advanced im Bereich Source of Connection des Dokuments oder über das Hauptmenü Tools .

Die Registerkarte Advanced  des Dialogs Database Connection bietet zusätzliche SQL-Optionen, um Tabellennamen in einer erstellten WHERE-Klausel mit Begrenzungszeichen zu versehen oder Tabellenschemanamen zu verwenden. Die Registerkarte Advanced des Dialogs Database Connection bietet zusätzliche SQL-Optionen, um Tabellennamen in einer erstellten WHERE-Klausel mit Begrenzungszeichen zu versehen oder Tabellenschemanamen zu verwenden.

Welche Begrenzungszeichen für Tabellennamen verwendet werden, hängt von der verwendeten Datenbank ab. Beispielsweise können eckige Klammern [ ] nur in Microsoft-Datenbanken wie Access, Excel über ADO oder MSSQL (neuere Versionen) verwendet werden. MYSQL würde das Zeichen ' als Begrenzungszeichen verwenden. Spaltennamen müssen in einer Datenbank eigentlich nur dann mit Begrenzungszeichen versehen werden, wenn sie Leerzeichen enthalten oder reservierte Wörter der jeweiligen Datenbank sind. Welche Begrenzungszeichen gegebenenfalls verwendet werden, entnehmen Sie der Dokumentation Ihrer Datenbanksoftware.

Die geschweiften Klammern geben an, dass der referenzierte Eintrag ein Designparameter ist. Die einfachen Anführungszeichen legen fest, dass der Designparameter als Zeichenfolge und nicht als Zahl (ohne Anführungszeichen) behandelt wird. Die Übereinstimmung der Datentypen ist sehr wichtig, da SQL zwischen Datentypen unterscheidet. Der Designparameter sollte denselben Datentyp haben wie die Spalte in der Datenbank.

Mit der Standard-SQL-Syntax kann die WHERE-Klausel anschließend erweitert werden, um den Abgleich anhand mehrerer Database field/Part parameter-Einträge durchzuführen, beispielsweise:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

In diesem Fall würde über drei verschiedene Designparameter eine Verknüpfung zu einem einzelnen Datensatz in der entsprechenden Datenbanktabelle hergestellt. Beachten Sie, dass der Eintrag für den Designparameter Tolerance nicht in Anführungszeichen steht. Das bedeutet, dass der Datentyp der Spalte in der zugehörigen Datenbanktabelle Number und nicht String ist.

Mit der Standard-SQL-Syntax können Sie die WHERE-Klausel so einfach oder komplex gestalten, wie Sie möchten. Ein Beispiel für eine komplexere Klausel wäre:

[Tolerance] BETWEEN {Min Tolerance} AND {Max Tolerance} AND [Price] <= {Max Price} AND [Manufacturer] IN ('{Preferred Manufacturer 1}', '{Preferred Manufacturer 2}')

In diesem Fall würde die Tabelle anhand von drei Datenbankfeldern – Tolerance, Price und Manufacturer – nach passenden Bauteilen durchsucht. Die Toleranz muss innerhalb des durch die Designparameter Min Tolerance und Max Tolerance definierten Bereichs liegen. Der Preis muss kleiner oder gleich dem im Designparameter Max Price angegebenen Wert sein, und der Hersteller kann einer der beiden durch die Designparameter Preferred Manufacturer 1 und Preferred Manufacturer 2 angegebenen Kandidaten sein.

Erstellen eines Bauteilparameters

Wenn in Ihren Altium Designer-Komponenten kein geeigneter Parameter vorhanden ist, der in der DbLink-Datei als Part parameter für den Abgleich verwendet werden kann, müssen Sie einen erstellen. Dieser „Basisparameter“ lässt sich schnell über den Befehl Tools » Parameter Manager oder das Panel Properties des jeweiligen Editors hinzufügen.

Hinzufügen eines Parameters mithilfe der Parameterverwaltung

So fügen Sie mithilfe der Parameterverwaltung einen neuen Parameter hinzu:

  1. Wählen Sie in einem Schaltplandokument (oder Schaltplanbibliotheksdokument) über die Hauptmenüs Tools » Parameter Manager. Der Dialog Parametereditor-Optionen wird geöffnet. Um den neuen Parameter allen Bauteilen hinzuzufügen, stellen Sie sicher, dass die Option Parts im Bereich Include Parameters Owned By aktiviert ist und im Bereich That Meet the Following Criteria das Kriterium All Objects festgelegt ist.

Festlegen der Optionen für die Parameterverwaltung.Festlegen der Optionen für die Parameterverwaltung.

  1. Durch Klicken auf OK wird der Dialog Parametertabellen-Editor geöffnet. Er zeigt alle Parameter an, die derzeit zu den Bauteilobjekten auf den Schaltplan-Quelldokumenten im aktiven Projekt gehören (bzw. zu den Schaltplankomponenten in der aktiven Schaltplanbibliothek). Klicken Sie auf die Schaltfläche Add Column und legen Sie im daraufhin angezeigten Dialog Parameter hinzufügen den Namen des Parameters fest. Stellen Sie sicher, dass die Option Add to all objects aktiviert ist, damit der neue Parameter allen Bauteilen hinzugefügt wird.

Lassen Sie beim ersten Durchgang Value für den Parameter unzugewiesen und fügen Sie zunächst nur den Parameter zu jedem Bauteil hinzu. Sie können den Parametertabellen-Editor ein zweites Mal aufrufen, um den Wert jedes Parameters festzulegen. Der Dialog unterstützt die üblichen Windows-Tastenkombinationen zur Bearbeitung, beispielsweise das Wechseln zwischen Zellen mit den Pfeiltasten, das Bearbeiten des Werts der aktuellen Zelle mit F2 sowie das blockweise Kopieren und Einfügen aus einem Texteditor oder einer Tabellenkalkulation in die ausgewählte Zelle und die erforderliche Anzahl darunterliegender Zellen im Dialog.

Beispiel für die Verwendung der Parameterverwaltung zum Hinzufügen eines neuen Parameters zu allen Bauteilen auf sämtlichen Quellschaltplänen eines Designprojekts.Beispiel für die Verwendung der Parameterverwaltung zum Hinzufügen eines neuen Parameters zu allen Bauteilen auf sämtlichen Quellschaltplänen eines Designprojekts.

  1. Klicken Sie nach dem Hinzufügen der neuen Spalte auf die Schaltfläche Accept Changes (Create ECO). Verwenden Sie den daraufhin angezeigten Dialog Engineering Change Order, um die Änderungen zunächst mit Validate und anschließend mit Execute zu verarbeiten. Dabei wird der Parameter allen erforderlichen Bauteilen hinzugefügt.

Ausführen der Parameteränderungen (Hinzufügen des neuen Parameters zu allen Bauteilen) über einen Engineering Change Order.Ausführen der Parameteränderungen (Hinzufügen des neuen Parameters zu allen Bauteilen) über einen Engineering Change Order.

Hinzufügen eines Parameters über das Properties-Panel

Über das Panel Properties kann allen ausgewählten Bauteilen ein neuer Parameter hinzugefügt werden. Das folgende Verfahren beschreibt, wie Sie allen Komponenten im aktiven Schaltplanbibliotheksdokument denselben Parameter hinzufügen. Dazu werden die Panels SCHLIB Filter und Properties verwendet.

Das Verfahren zum Hinzufügen eines Parameters zu platzierten Bauteilen auf Schaltplan-Quelldokumenten ist ähnlich. In diesem Fall werden das Panel SCH Filter und das Panel Properties des Schaltplaneditors verwendet.
  1. Wählen Sie zunächst mithilfe des Panels SCH Filter und der Abfrage IsPart alle Komponenten in der Bibliothek aus. Stellen Sie sicher, dass die Option Whole Library aktiviert ist, da andernfalls nur die aktive Bibliothekskomponente berücksichtigt wird.

Konfigurieren eines Filters zur Auswahl aller Bauteile im aktiven Schaltplanbibliotheksdokument.Konfigurieren eines Filters zur Auswahl aller Bauteile im aktiven Schaltplanbibliotheksdokument.

  1. Überprüfen Sie im Panel Properties des Bibliothekseditors anhand des Textes am unteren Rand des Panels, ob derzeit alle Bauteile in der Bibliothek ausgewählt sind. Wenn das Panel Properties nicht sichtbar ist, klicken Sie unten rechts im Arbeitsbereich auf die Schaltfläche  Panels button, click to display a menu of available panels, um es einzublenden.

Überprüfen Sie, ob alle Bauteile ausgewählt sind. Überprüfen Sie, ob alle Bauteile ausgewählt sind.

  1. Fügen Sie den benötigten Parameter über die Registerkarte Parameters des Panels hinzu. Klicken Sie auf die Schaltfläche Add, um einen neuen Standardparameter hinzuzufügen, und passen Sie anschließend den Namen nach Bedarf an. Beachten Sie, dass der Parameter bereits allen ausgewählten Bauteilen hinzugefügt wurde. Wenn Sie erneut auf die Schaltfläche Add klicken, wird ein zweiter neuer Parameter hinzugefügt.

Fügen Sie den benötigten neuen Parameter allen ausgewählten Bauteilen hinzu. Fügen Sie den benötigten neuen Parameter allen ausgewählten Bauteilen hinzu.

Datenbankfelder Designparametern zuordnen

Designparameter vorhandener Bauteile – entweder auf den Quellschaltplanblättern eines Designprojekts platzierte Bauteile oder in einer Schaltplan-Bauteilbibliothek definierte Bauteile, die einem Bibliothekspaket hinzugefügt wurde – werden mithilfe des Befehls Update Parameters From Database mit extern gespeicherten Informationen aus einer Unternehmensdatenbank aktualisiert. Dieser Befehl ist im Hauptmenü Tools verfügbar, wenn das Schaltplandokument bzw. das Schaltplanbibliotheksdokument aktiv ist.

Wenn eine Übereinstimmung zwischen einem Bauteil im Design und einem Datensatz in einer Tabelle der verknüpften Datenbank gefunden wird, bestimmen die in der Database-Link-Datei festgelegten Zuordnungs- und Aktualisierungsinformationen das weitere Vorgehen. Diese Einstellungen werden auf der Registerkarte Field Mappings der Hauptdokumentansicht konfiguriert.

Zuordnungs- und Aktualisierungsoptionen werden für jede Tabelle separat festgelegt.

Legen Sie die Optionen für die Parameterzuordnung und -aktualisierung auf der Registerkarte Field Mappings des DbLink-Dokuments fest.Legen Sie die Optionen für die Parameterzuordnung und -aktualisierung auf der Registerkarte Field Mappings des DbLink-Dokuments fest.

Parameterzuordnung

Über die ersten beiden Spalten (von links) auf der Registerkarte Field Mappings können Sie steuern, welche Informationen aus der Datenbank den Parametern eines Bauteils zugeordnet werden sollen.

In der Spalte Database Field Name werden alle Feldnamen (Spaltennamen) der derzeit aktiven Datenbanktabelle aufgeführt. In der Spalte Design Parameter können Sie den Designparameter angeben, der dem entsprechenden Feld in der Datenbank zugeordnet werden soll. Die anfängliche Zuordnung erfolgt automatisch beim Herstellen der Verbindung zur Datenbank. Dabei werden alle Datenbankfelder gleichnamigen Designparametern zugeordnet. Wenn ein Feld in der Datenbank beispielsweise Tolerance heißt, wird ihm ein Designparameter mit dem Namen Tolerance zugeordnet.

Sie können den Eintrag für einen Designparameter auf folgende Weise ändern:

  • Klicken Sie in die entsprechende Zelle und geben Sie direkt den Namen eines anderen Parameters ein.
  • Wählen Sie über die Dropdown-Liste der Zelle einen vorhandenen Designparameter aus.

Einem Bauteil in der Datenbank kann eine große Anzahl von Datenfeldern zugeordnet sein, die Sie nicht alle als Designparameter zum vorhandenen Bauteil im Design hinzufügen möchten oder müssen. Ein Großteil dieser Informationen wird möglicherweise nur zum Erstellen einer Stückliste benötigt. Der Dialog Report Manager enthält eine Option, mit der Sie Parameterinformationen direkt aus einer verknüpften Datenbank zu einer Stückliste hinzufügen können. Dadurch lässt sich die Informationsmenge reduzieren, die in den Schaltplan-Quelldokumenten „mitgeführt“ wird. Weitere Informationen finden Sie im Abschnitt Datenbankinformationen direkt zu einer Stückliste hinzufügen.

Setzen Sie für Felder, die Sie ausdrücklich nicht aus der Datenbank zuordnen möchten, den Eintrag Design Parameter auf [None]. Nicht zugeordnete Datenbankfelder werden auf der Registerkarte durch ein rotes Kreuzsymbol (Cross icon, indicating that a database field is not mapped to a component parameter) gekennzeichnet. Zugeordnete Datenbankfelder sind durch ein grünes Häkchensymbol (Tick icon, indicating that a database field is mapped to a component parameter) gekennzeichnet.

Legen Sie die Parameterzuordnung nach Bedarf fest. Legen Sie die Parameterzuordnung nach Bedarf fest.

Um ein nicht zugeordnetes Feld schnell erneut zuzuordnen, klicken Sie in die Zeile dieses Felds und verwenden Sie die Tastenkombination Ctrl+D. Der Name des Designparameters ist dann identisch mit dem des entsprechenden Database Field Name.

Optionen zur Parameteraktualisierung

In den übrigen Spalten auf der Registerkarte Field Mappings können Sie festlegen, welche Aktionen für Parameter beim Aktualisieren eines Bauteils mit dem Befehl Tools » Update Parameters From Database ausgeführt werden. In den folgenden Beschreibungen bezeichnet der Begriff Altium component ein auf einem Schaltplanblatt platziertes Bauteil oder ein in einer Schaltplan-Bauteilbibliothek definiertes Bauteil (die Teil eines Bibliothekspakets ist).

Die vier Spalten sind:

  • Update Values – Eine Zelle in dieser Spalte legt fest, welche Aktion ausgeführt werden soll, wenn der Parameter sowohl für das Altium-Bauteil als auch in der Datenbank vorhanden ist, die Werte jedoch derzeit unterschiedlich sind. Sie können den Parameter des Altium-Bauteils mit dem in der Datenbank gespeicherten Wert aktualisieren (Update) oder auf eine Aktualisierung verzichten (Do not update).
  • Add To Design – Eine Zelle in dieser Spalte legt fest, welche Aktion ausgeführt werden soll, wenn der Parameter in der Datenbank vorhanden ist, jedoch nicht für das Altium Designer-Bauteil. Sie können den Parameter hinzufügen (Add), ihn nicht hinzufügen (Do not add) oder ihn nur dann hinzufügen, wenn ihm in der Datenbank ein Wert zugewiesen ist (Add only if not blank in database).
  • Visible On Add – Ein Kontrollkästchen in dieser Spalte legt fest, ob ein neu hinzugefügter Parameter für das Altium-Bauteil sichtbar ist (aktiviert) oder nicht (deaktiviert).
  • Remove From Design – Eine Zelle in dieser Spalte legt fest, welche Aktion ausgeführt werden soll, wenn der Parameter für das Altium Designer-Bauteil vorhanden ist, in der Datenbank jedoch entweder fehlt oder keinen Wert hat. Sie können festlegen, dass der Parameter grundsätzlich nicht entfernt wird (Do not remove) oder nur dann entfernt wird, wenn ihm in der Datenbank kein Wert zugewiesen ist (Remove only if blank in database).

Anfangs sind die Felder Update Values, Add To Design und Remove From Design für jedes zugeordnete Datenbankfeld auf den Eintrag Default gesetzt, und die Option Visible On Add ist deaktiviert, wie in der folgenden Abbildung dargestellt.

Anfängliche (standardmäßige) Optionen zur Parameteraktualisierung.Anfängliche (standardmäßige) Optionen zur Parameteraktualisierung.

Mit Blick auf die Abbildung sind drei wichtige Punkte zu den Aktualisierungsoptionen hervorzuheben:

  1. Nicht zugeordneten Datenbankfeldern sind keine Aktualisierungsoptionen zugewiesen.
  2. Dem Schlüsselfeld (z. B. Part Number in der Abbildung) sind keine Aktualisierungsoptionen zugewiesen. Dieses Feld dient ausschließlich dem Parameterabgleich.
  3. Bei der Einstellung Default folgt eine Aktualisierungsoption ihrer entsprechenden Standarddefinition, die auf der Registerkarte Default Actions des Dialogs Database Link Options (Tools » Options) festgelegt ist. Dieser Dialog kann auch durch Klicken auf die Schaltfläche Options im Bereich Field Settings der Dokumentansicht geöffnet werden.

Legen Sie die Standardoptionen zur Parameteraktualisierung an einer zentralen Stelle fest.Legen Sie die Standardoptionen zur Parameteraktualisierung an einer zentralen Stelle fest.

Der dritte Punkt bietet den Vorteil, dass Sie Aktualisierungsoptionen an einer zentralen Stelle festlegen und beim Definieren der Aktualisierungsoptionen für jedes zugeordnete Feld auf diese Stelle verweisen können. Deshalb wird der Eintrag Default automatisch in die entsprechenden Aktualisierungsfelder übernommen, sobald ein Datenbankfeld einem Designparameter zugeordnet wird.

Wenn Sie die Standardeinstellung einer Aktualisierungsoption überschreiben möchten, klicken Sie auf der Registerkarte Field Mappings in das entsprechende Aktualisierungsfeld. Klicken Sie anschließend erneut, um eine Dropdown-Liste mit den verfügbaren Aktualisierungsoptionen zu öffnen.

Optionen zur Parameteraktualisierung können bei Bedarf manuell überschrieben werden.Optionen zur Parameteraktualisierung können bei Bedarf manuell überschrieben werden.

Auf diese Weise haben Sie die volle Kontrolle darüber, wie die Parameter im Design aktualisiert werden. Sie können alle Felder auf Default setzen und die erforderlichen Aktualisierungsentscheidungen im Dialog Database Link Options treffen, jedes Aktualisierungsfeld einzeln festlegen oder beide Vorgehensweisen kombinieren – die Entscheidung liegt ganz bei Ihnen. Die Aktualisierung erfolgt über einen Dialog Engineering Change Order. Falls es zu diesem Zeitpunkt Aktualisierungen gibt, die Sie lieber nicht durchführen möchten, können Sie die betreffenden Änderungen ausschließen. Damit haben Sie das letzte Wort darüber, welche Designparameter aktualisiert werden.

Synchronität sicherstellen

Nachdem Sie die Zuordnungs- und Aktualisierungsoptionen in der Database-Link-Datei wie gewünscht festgelegt und die Datei gespeichert haben, können Sie Informationen aus der Datenbank an die zugeordneten Parameter der Altium Designer-Komponenten übertragen. Denken Sie daran, dass der gewählte Schlüsselfeldparameter sicherstellt, dass eine Altium Designer-Komponente mit dem entsprechenden Datensatz für diese Komponente in der externen Datenbank verknüpft bleibt. So lassen sich auch zu jedem späteren Zeitpunkt Änderungen an den Parameterinformationen in der Datenbank einfach an die Altium Designer-Komponente übertragen, um beide zu synchronisieren. Aktualisierungen werden mit dem Befehl Update Parameters From Database durchgeführt, der im Hauptmenü Tools des Schaltplan- bzw. Schaltplanbibliothekseditors verfügbar ist.

Duale Synchronisierung – DbLib/SVNDbLib und DBLink

Möglicherweise verfügen Sie über ein bestehendes Designprojekt, in dem die meisten platzierten Bauteile über eine DbLink-Datei mit einer externen Datenbank verknüpft sind. Designänderungen können zusätzliche Schaltungen erforderlich machen, deren Komponenten mithilfe der Funktion Datenbankbibliothek platziert werden. Die zugehörige DbLib/SVNDbLib-Datei kann dabei durchaus auf eine andere externe Datenbank verweisen.

Bei Verwendung des Befehls Update Parameters From Database werden alle verknüpften Parameter der platzierten Komponenten abgefragt – über alle verknüpften Datenbanken hinweg und unabhängig von der verwendeten Verknüpfungsmethode. Erkannte Unterschiede für diese Parameter werden im Dialog Parameteränderungen auswählen angezeigt.

Wenn in der DbLink- und der DbLib/SVNDbLib-Datei dasselbe Datenbankfeld für den Abgleich verwendet wird, wird zuerst die über die DbLink-Datei verknüpfte Datenbank nach einer Übereinstimmung durchsucht und anschließend die über die DbLib/SVNDbLib-Datei verknüpfte Datenbank. Ist die Komponente in beiden Datenbanken vorhanden, kann es passieren, dass der Abgleich und die Aktualisierung anhand des falschen externen Datensatzes erfolgen.

Datenbankinformationen direkt zu einer Stückliste hinzufügen

Related page: Stücklistenkonfiguration im Report Manager

Die Quelldaten für eine Stückliste (BOM) wurden bisher aus den Parameterinformationen der im Design platzierten Komponenten übernommen. Das kann jedoch dazu führen, dass ein Schaltplan viele Informationen enthält, die ausschließlich für die Stückliste verwendet werden. Wenn Ihre platzierten Altium Designer-Komponenten über eine DbLink-Datei mit einer externen Datenbank verknüpft sind, kann der Stücklistengenerator auch weitere Datensatzinformationen abrufen, die den Komponenten nicht als Designparameter hinzugefügt wurden.

Parameter aus einer externen Datenbank können unabhängig davon einbezogen werden, welche Methode zur Verknüpfung mit dieser Datenbank verwendet wird – DbLink, DbLib oder SVNDbLib.

Wenn Sie den Stücklistenbericht im Dialog Report Manager konfigurieren, klicken Sie auf der Registerkarte „Columns“ des Dialogs auf die Schaltfläche Database Parameters (  Database Parameters source button, click to make linked database parameters available in the Report Manager ), um diese Parameter wie unten gezeigt als Quelle für die Stückliste einzubeziehen. Diese Option ist nur verfügbar, wenn mindestens eine Komponente in Ihrem Design mit einer externen Datenbank verknüpft ist.

In der Spaltenliste kennzeichnet das Symbol Database icon, indicates that this parameter comes from the database einen Parameter, der für eine oder mehrere platzierte Komponenten in einer verknüpften externen Datenbank vorhanden ist. Klicken Sie auf das Sichtbarkeitssymbol, sodass es als Auge ( Visibility icon ) angezeigt wird, um diese Spalte (diesen Parameter) in Ihre Stückliste aufzunehmen.

Beziehen Sie zusätzliche Komponenteninformationen ein, die nur in einer externen Datenbank vorhanden sind.Beziehen Sie zusätzliche Komponenteninformationen ein, die nur in einer externen Datenbank vorhanden sind.

Bei einem Design mit Varianten werden die zur Datenbankabfrage verwendeten Parameter im Dialog Variantenverwaltung variiert. Da diese Parameterwerte nur im Dialog Variant Management vorhanden sind, werden sie nur dann zum Abfragen und Abgleichen von Datensätzen in der Datenbank verwendet, wenn eine Stückliste für die Erstellung konfiguriert wird. Stellen Sie dazu sicher, dass die Unteroption Include DB Parameters in Variations auf der Registerkarte „General“ der Eigenschaften von Report Manager aktiviert ist.

Altium Designer enthält außerdem einen leistungsstarken Stücklisteneditor namens ActiveBOM. ActiveBOM bietet umfangreiche Funktionen zur Stücklistenverwaltung, darunter die Möglichkeit, zusätzliche Stücklistenpositionen hinzuzufügen, sowie eine enge Integration mit der Komponentenlieferkette.

► Erfahren Sie mehr über ActiveBOM

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents