Verknüpfung mit Lieferkettendaten für datenbank- und dateibasierte Komponentenbibliotheken

Auf einen Blick

Greifen Sie beim Entwerfen mit datenbank- und dateibasierten Bauteilbibliotheken in Altium Designer auf aktuelle Lieferanteninformationen zu. Dieser Artikel stellt den Zugriff auf Lieferantendaten in SchLib-, DbLib- und SVNDbLib-Workflows vor, erläutert die Konfiguration der Lieferanteneinstellungen und zeigt, wie Sie im Panel „Manufacturer Part Search“ Bauteile finden sowie Preis-, Bestands- und Lebenszyklusinformationen prüfen. Lesen Sie weiter, um in Ihrem Design-Workflow fundiertere Entscheidungen zur Bauteilbeschaffung zu treffen.

- Konfigurieren Sie bevorzugte Lieferanten, geografische Regionen und Währungen für die Bauteilsuche.
- Nutzen Sie Stichwörter, Kategorien und parametrische Filter, um geeignete Herstellerbauteile zu finden.
- Prüfen Sie Lieferantenpreise, Verfügbarkeit und Bauteildetails als Grundlage für Auswahl und Beschaffung.
Mit KI tiefer einsteigen:

Altium Designer ermöglicht es Ihnen, Ihre Designbauteile mit realen Bauteilen zu verknüpfen und so während des Entwurfs auf aktuelle Lieferantendaten zuzugreifen. Über eine direkte Verbindung zu den Webdiensten für Bauteildaten von Altium können Sie nach Herstellerteilen suchen und aus den unterstützten Lieferanten auswählen, die diese Teile anbieten. Diese aktuellen Lieferantendaten lassen sich dann in den Designprozess integrieren – beim Erstellen von Bibliotheken, während des Entwurfs und bei der Designfreigabe. Kurz gesagt ermöglicht diese Funktion den Zugriff auf Lieferantendatenbanken direkt aus Altium Designer, indem Sie nach Herstellerbauteilen für Ihr Design suchen und diese auswählen.

Die verknüpften Bauteil- und Lieferantendaten werden bei der Designfreigabe auch in eine Stückliste aufgenommen oder können dieser hinzugefügt werden – besonders nützlich für die Projektkalkulation und Beschaffung.

Um Lieferantendaten verknüpfen zu können, ist es not erforderlich, bei Ihrem Altium-Konto angemeldet zu sein. Die Suche nach Herstellerteilen und Lieferanten erfolgt über die Webdienste von Altium. Bei der Anzeige von Preisinformationen in anderen Währungen werden die Wechselkurse für die Währungsumrechnung jedoch täglich aktualisiert, sofern Sie bei Ihrem Konto are angemeldet sind.

Dieses Dokument behandelt die Verknüpfung mit Lieferantendaten für Methoden der Bauteilverwaltung, die SchLib, DbLib oder SVNDbLib als Grundlage für die Bauteilspeicherung verwenden. Wenn Sie einen verbundenen Workspace und Workspace-Bauteile verwenden, wird über sogenannte Part Choices eine ähnliche, jedoch klar getrennte und leistungsfähigere Verbindung zwischen Designbauteil und Lieferkette hergestellt. Wenn die Funktion Custom Parts Provider Synchronization in Altium Designer aktiviert ist (weitere Informationen zum Ändern der installierten Kernfunktionen finden Sie auf der Seite Installing & Managing (Altium Designer Develop, Altium Designer Agile, Altium Designer)), bietet ein verbundener Workspace eine Schnittstelle zu jeder im Workspace eingerichteten Bauteildatenbankverbindung, beispielsweise zur unternehmenseigenen internen Bauteildatenbank (direkt oder über eine ODBC- bzw. OLE-DB-Schnittstelle). Sie müssen mit dem Workspace verbunden sein, um auf diese Bauteildaten zugreifen zu können. Diese Funktion steht daher bei dateibasierten Methoden der Bauteilverwaltung nicht zur Verfügung und hat nichts mit deren Möglichkeit zur Verknüpfung mit Lieferantendaten zu tun.

Weitere Informationen zur zentralen Konfiguration von Lieferanten im Rahmen einer Altium On-Prem Enterprise Server-Installation, einschließlich der Einrichtung einer Schnittstelle zu einer Bauteildatenbank, finden Sie unter Konfiguration der Bauteilquellen.

Lieferanteneinstellungen

Die Seite Datenverwaltung – Bauteilanbieter im Dialogfeld Preferences ist die zentrale Anlaufstelle, um festzulegen, welche Lieferanten bei der Suche nach Bauteildaten verfügbar sind, und weitere Optionen zur Verknüpfung mit Lieferantendaten zu konfigurieren.

Konfigurieren Sie die Optionen zur Verknüpfung mit Lieferantendaten in den Voreinstellungen von Altium Designer.
Konfigurieren Sie die Optionen zur Verknüpfung mit Lieferantendaten in den Voreinstellungen von Altium Designer.

Verwenden Sie den Abschnitt Altium Parts Options auf dieser Seite, um den Dienst an Ihre Anforderungen anzupassen.

Folgende Optionen stehen zur Verfügung:

  • Location – Aktivieren Sie die geografischen Regionen, aus denen der Bauteildienst Bauteildaten zusammenstellen soll. Viele Lieferanten sind zwar in mehreren Regionen tätig, doch wenn ein Bauteil nur an einem bestimmten Standort verfügbar ist, wird es nur aufgeführt, wenn diese Region aktiviert ist. Legen Sie die Priorität der Standorte fest, indem Sie die Einträge in der Liste per Drag-and-drop anordnen.

  • Currency – Aktivieren Sie die internationalen Währungen, die bei der Suche nach Bauteilen und der Prüfung der Ergebnisse zur Auswahl stehen sollen. Legen Sie die Priorität der Währungen fest, indem Sie die Währungssymbole in der Liste per Drag-and-drop anordnen.

  • Supplier – Aktivieren Sie die Lieferanten, die bei einer Suche nach Lieferantendaten berücksichtigt werden sollen. Es werden nur Bauteilergebnisse dieser Lieferanten zurückgegeben. Wenn Sie mehr Lieferanten für diese Funktion einbeziehen, können Sie Angebote vergleichen und die besten Konditionen für die in Ihrem Design benötigten Bauteile finden. Ein Lieferant mit einem -Symbol in der Spalte Verified zeigt an, dass der Altium Parts Provider Daten direkt von diesem Lieferanten erhält.

Beachten Sie, dass der Bereich Altium Parts Options schreibgeschützt wird und die vom Server definierten Einstellungen übernimmt, wenn Sie bei einem Server angemeldet sind. Dies wird durch das Symbol neben dem Seitennamen im Navigationsbaum angezeigt.

Nach Lieferantendaten für Bauteile suchen

Die wichtigste Schnittstelle zu verfügbaren Herstellerteilen und den zugehörigen aktuellen Lieferantendaten ist das Panel Herstellerteilsuche. Mit seinen leistungsfähigen Funktionen zum Suchen und Auffinden von Bauteilen anhand von Kategorien und Parameterfiltern dient das Panel auch als direktes Portal zu realen Bauteilen, die von den verschiedenen für diese Funktion aktivierten Lieferanten angeboten werden. Öffnen Sie dieses Panel, indem Sie im Hauptmenü View » Panels » Manufacturer Part Search oder im Menü der Schaltfläche unten rechts im Hauptbildschirm die Option Manufacturer Part Search auswählen.

Suchen Sie über das Panel Manufacturer Part Search nach realen Lieferantenartikeln.Suchen Sie über das Panel Manufacturer Part Search nach realen Lieferantenartikeln.

Wie dargestellt, ist das Panel im Wesentlichen in drei Funktionsbereiche unterteilt:

  • Component Search, Type and Filtering:
    • Geben Sie im oberen Feld Search ein oder mehrere Schlüsselwörter ein, die sich auf das Bauteil beziehen. Die zurückgegebenen Ergebnisse enthalten Lieferantenverknüpfungen für jedes aufgeführte Herstellerteil.
    • Verwenden Sie die Dropdown-Liste Categories (), um die Ergebnisse auf den ausgewählten Bauteiltyp einzuschränken.
    • Aktivieren Sie die relevanten Parameteroptionen im linken Bereich Filters (eingeblendet über das Symbol ), um die Ergebnisse auf Bauteile mit diesen Parameterwerten zu filtern.
Alle oben genannten Funktionen können gemeinsam genutzt werden, um die benötigten Bauteile und die damit verbundenen aktuellen Lieferantendaten schnell und präzise zu finden.
  • Search Results:
    • Dieser zentrale Bereich des Panels wird mit allen Herstellerteilen gefüllt, die den aktuellen Such-, Kategorie- und Filterkriterien entsprechen. Die Spalte Supply Info bietet für jeden Eintrag eine Übersicht der Lieferdaten auf Grundlage des Stückpreises, der Mindestbestellmenge (MOQ) und des verfügbaren Lagerbestands beim am besten geeigneten Anbieter. Der Farbstreifen bei jedem Herstellerteil ermöglicht eine schnelle Einschätzung seines Lebenszyklusstatus – Grün zeigt beispielsweise an, dass sich das Bauteil für die Serienproduktion eignet, während ein roter Streifen ein als abgekündigt eingestuftes Bauteil kennzeichnet.
    • Ein ausgewählter Bauteileintrag enthält in der Spalte Manufacturer Part eine Verknüpfung zu Lieferantendaten (zum Beispiel 9 SPNs), über die eine horizontale Liste mit Kacheln zur Lieferantenauswahl für dieses Herstellerteil geöffnet wird. Jede Kachel in dieser Liste bezieht sich auf einen bestimmten Anbieter und bietet einen Überblick über den aktuellen Lagerbestand, die Preise und die Lieferanten-Teilenummer. Informationen dazu, wie diese auf Designbauteile angewendet werden, finden Sie weiter unten unter Mit einem Lieferantenartikel verknüpfen.
    • Die Optionseinstellungen des Panels, verfügbar über  Schaltfläche oben rechts im Panel können Sie festlegen, wie die Suchergebnisdaten angezeigt werden:
      • Currency Menü – Die für die Preisinformationen im Panel verwendete Währung wird durch die Einstellung der Währungspriorität auf der Seite Datenverwaltung – Teileanbieter bestimmt. Um die aktuelle Einstellung des Panels schnell zu ändern, wählen Sie in diesem Dropdown-Menü eine andere Währung aus.

      • Exclude Invalid SPNs Option – Aktivieren Sie diese Option, um den Link zu den Lieferantendaten in der Spalte Manufacturer Part für Einträge zu entfernen, deren Lieferantendaten für das betreffende Bauteil ungeeignet (ungültig) sind – beispielsweise, wenn keine Preis- oder Lagerbestandsinformationen verfügbar sind.

      • Einstellungen für Teileanbieter Link – Bietet direkten Zugriff auf die Seite Datenverwaltung – Teileanbieter Preferences. Nur Lieferanten, die auf der Einstellungsseite aktiviert sind, werden in die Liste der Lieferanten/Anbieter für ein Herstellerbauteil aufgenommen.

  • Component Details:
    • Der Bereich Details des Panels (geöffnet über die Schaltfläche oben rechts) zeigt alle verfügbaren Daten für das ausgewählte Bauteil an, einschließlich seiner Parameter, Modelle, Datenblätter und Links zu webbasierten Lieferanteninformationen.
    • Der Bereich enthält außerdem Download-Optionen zum Anzeigen/Speichern der Spezifikationen des Herstellerbauteils () oder zum lokalen Speichern des Bauteils selbst () durch:
      • Speichern des Bauteils im aktuell verbundenen Altium Workspace oder
      • Herunterladen des Bauteils als ZIP-Dateibibliothek oder 
      • Platzieren des Bauteils auf dem aktiven Schaltplanblatt.

► Ausführliche Informationen zu den Funktionen und zur Verwendung finden Sie auf der Seite Herstellerbauteilsuche.

Lieferantenverknüpfungen anzeigen und bearbeiten

Die derzeit für ein Bibliotheksbauteil oder ein auf einem Schaltplanblatt platziertes Bauteil definierten Lieferantenverknüpfungen können im Dialog Supplier Links for angezeigt und bearbeitet werden. So öffnen Sie diesen Dialog:

  • For a schematic library component – Klicken Sie mit der rechten Maustaste an eine beliebige Stelle im Designbereich und wählen Sie den Befehl Supplier Links aus dem Kontextmenü.
  • For a Database library / SVN Database Library component – Klicken Sie mit der rechten Maustaste auf einen Bauteileintrag auf der Registerkarte Table Browser der entsprechenden DbLib-/SVNDbLib-Datei und wählen Sie den Befehl Edit Supplier Links aus dem Kontextmenü.
  • For a placed component on a schematic sheet – Klicken Sie mit der rechten Maustaste auf das Bauteil und wählen Sie den Befehl Supplier Links aus dem Kontextmenü.

Nach dem Aufrufen des Befehls öffnet sich der Dialog Supplier Links for. Der Dialog listet alle derzeit für das Bauteil definierten Verknüpfungen auf. Wenn mehrere Herstellerbauteile verfügbar sind – also mehrere Lösungen vorliegen –, werden diese anhand von Verfügbarkeit, Preis und Hersteller-Lebenszyklusstatus automatisch in absteigender Reihenfolge bewertet. Das Herstellerbauteil wird links angezeigt, die Details zum ausgewählten verfügbaren Lieferanten rechts.

Der Dialog Supplier Links for
Der Dialog Supplier Links for

Alle derzeit für ein Schaltplanbibliotheksbauteil definierten Lieferantenverknüpfungen können auch direkt im Properties-Panel des ausgewählten Bauteils angezeigt und bearbeitet werden. Die definierten Lieferantenverknüpfungen für das ausgewählte Bauteil werden im Bereich Part Choices des Panels angezeigt. Detaillierte Daten zur ausgewählten Lieferantenverknüpfung sind über den anklickbaren Link in der Lieferantenkachel (wie unten gezeigt) oder durch eine Suche nach dem Wert des Parameters Supplier Part Number 1 dieses Bauteils im Manufacturer Part Search-Panel verfügbar.

Um eine weitere Lieferantenverknüpfung hinzuzufügen, klicken Sie auf die Schaltfläche unten im Bereich Part Choices. Der Dialog Supplier Links for wird geöffnet. Klicken Sie auf die Schaltfläche  , um den Dialog Add Supplier Links zu öffnen, in dem Sie nach weiteren Verknüpfungen zum gewünschten Artikel suchen und diese hinzufügen können. Verwenden Sie die Schaltfläche im Dialog Add Supplier Links, um die ausgewählte Lieferantenverknüpfung aus dem Bibliotheksbauteil zu entfernen.

Der Dialog Add Supplier Links bietet eine Suchfunktion mit Kategorien und parametrischer Filterung, ähnlich wie das Manufacturer Part Search-Panel. Weitere Einzelheiten finden Sie auf der entsprechenden Seite.

Viele Lieferanten bieten Rabatte für Großbestellungen an. Klicken Sie auf den Link Show more in der SPN-Kachel, um die verschiedenen Stückpreise abhängig von der beim Lieferanten bestellten Menge anzuzeigen. (Anschließend können Sie auf den Link Show less klicken, um die Mengenstaffelpreisliste einzuklappen.)

Anpassen des Suchprozesses – Vorgeschlagene Schlüsselwörter

Wenn der Dialog Lieferantenverknüpfungen hinzufügen zum Suchen und Auswählen geeigneter Lieferantendaten für Bauteile verwendet wird, führt die Software automatisch eine Herstellerteilsuche anhand von Parameterdaten durch, die aus dem Zielbauteil extrahiert werden. Der von der Software verwendete Sucheintrag wird im Bereich Suggested Keywords auf der Seite Datenverwaltung – Teileanbieter des Dialogs Preferences definiert. Dort können Sie den verwendeten Suchausdruck an die Struktur Ihrer Bauteilbibliothek anpassen. Sie haben die volle Kontrolle darüber, welche Teileparameter als Suchbegriffe verwendet werden und in welcher Reihenfolge.

Standardmäßig vorgeschlagene Schlüsselwörter, die bei der automatischen Suche nach Teilen in Lieferantendatenbanken verwendet werden.Standardmäßig vorgeschlagene Schlüsselwörter, die bei der automatischen Suche nach Teilen in Lieferantendatenbanken verwendet werden.

Die standardmäßige Prioritätszuweisung im Bereich Suggested Keywords des Dialogs (mit der höchsten Priorität oben in der Liste) bedeutet, dass zunächst der Wert Comment als Suchkriterium verwendet wird. Wenn das Quellbauteil keinen Kommentar enthält, wird beim nächsten Versuch der Wert Description verwendet. Ist dieser ebenfalls leer, wird Name des Bauteils verwendet.

Sie können bei Bedarf eigene Schlüsselwortparameter hinzufügen, indem Sie auf die Schaltfläche Add klicken. Dadurch wird am Ende der Liste ein neuer Parametereintrag (mit dem Standardnamen Parameter Name) hinzugefügt, dem somit die niedrigste Priorität zugewiesen wird. Der neue Parameter erhält automatisch den Fokus, sodass Sie den Namen direkt ändern können. Um den Namen eines vorhandenen Parameters zu ändern, klicken Sie einmal auf dessen Namensfeld, um es zu aktivieren, und geben Sie dann den gewünschten neuen Namen ein. Alternativ können Sie einen Parameter durch Klicken auf das zugehörige Prioritätsfeld auswählen und anschließend auf die Schaltfläche Edit klicken.

Klicken Sie an eine beliebige Stelle in der Spalte Priority , um die Namensänderung zu übernehmen. Sie können auch Enter drücken. Beachten Sie jedoch, dass dadurch die Änderung übernommen und der Dialog Preferences geschlossen wird.

Mit den Schaltflächen Move Up bzw. Move Down verschieben Sie den aktuell ausgewählten Parameter in der Liste nach oben bzw. unten und erhöhen bzw. verringern damit die ihm zugewiesene Priority .

Beispiel eines benutzerdefinierten Parameters für vorgeschlagene Schlüsselwörter, der hinzugefügt und mit der höchsten Priorität versehen wurde.Beispiel eines benutzerdefinierten Parameters für vorgeschlagene Schlüsselwörter, der hinzugefügt und mit der höchsten Priorität versehen wurde.

Die Standardparameter können bearbeitet oder auch entfernt werden. Sie lassen sich jedoch über die Dropdown-Liste eines Parametereintrags wiederherstellen.

Mengen und Preise

Lieferanten bieten in der Regel unterschiedliche Preise an, abhängig von der Menge eines Artikels, die bei ihnen gekauft werden soll. Die Mengenstufen, ab denen zunehmend niedrigere Stückpreise gelten, unterscheiden sich nicht nur zwischen den Lieferanten, sondern auch zwischen den einzelnen Artikeln desselben Lieferanten. Wenn Sie im Panel Herstellerteilsuche Lieferantendaten für ein Herstellerteil auswählen, können Sie durch Auswahl des Links Show more in der Lieferantenkachel eines Teils eine Zusammenfassung dieser Informationen anzeigen. So können Sie bei der Auswahl einer Lieferantenverknüpfung anhand aktueller Daten eine fundierte Entscheidung hinsichtlich Preis und Lagerbestand treffen.

Lieferantenpreise und Lagerbestände ändern sich. Beachten Sie, dass die Aktualisierung der Lieferanteninformationen in der Datenbank des Aggregatordienstes, der über Altium Parts Provider bereitgestellt wird, zeitverzögert erfolgt. Bewegen Sie den Mauszeiger über das Symbol in einer Lieferantenkachel, um zu sehen, wann die Informationen zuletzt aktualisiert wurden.

Lieferantenverknüpfungen, die einem Bibliotheksbauteil hinzugefügt wurden, bieten für das aktuell ausgewählte Bibliotheksbauteil auch detaillierte Preis- und Mengeninformationen im Bereich Part Choices des Panels Properties. 

Beispiel der angezeigten Unit Price auf Grundlage der angegebenen Order Quantity: Bei einer Bestellung von 100 Stück sinkt der Preis pro Kondensator von 0,1 USD auf 0,018 USD. Beispiel der angezeigten Unit Price auf Grundlage der angegebenen Order Quantity: Bei einer Bestellung von 100 Stück sinkt der Preis pro Kondensator von 0,1 USD auf 0,018 USD.

Währungsumrechnung

Verschiedene Lieferanten sind in unterschiedlichen, oft mehreren Regionen der Welt tätig. Daher werden Produktpreise häufig in unterschiedlichen Währungen angegeben. Altium Designer bietet die Möglichkeit, solche Preisinformationen für die Anzeige in eine der unterstützten Währungen umzurechnen.

Um alle Preisinformationen im Panel Herstellerteilsuche schnell in einer einzigen Währung anzuzeigen, wählen Sie die gewünschte Währung aus dem Dropdown-Menü Currency, das über die Schaltfläche des Panels zugänglich ist. Um Preise in der vom Lieferanten verwendeten Standardwährung anzuzeigen, wählen Sie den Menüeintrag None.

Die Währungsumrechnung erfolgt anhand der geltenden Wechselkurse. Diese Kurse werden täglich (alle 24 Stunden) aktualisiert. Sie müssen jedoch bei Ihrem Altium-Konto angemeldet sein, damit die aktuellen Wechselkurse angewendet werden.

Um die Einstellungen zur Währungsverwendung in Altium Designer festzulegen, aktivieren bzw. deaktivieren Sie Währungen und legen Sie deren Priorität auf der Seite Datenverwaltung – Bauteilanbieter des Dialogs Preferences fest.

► Weitere Informationen finden Sie oben unter Lieferanteneinstellungen.

Bestimmte Parameter importieren

Bestimmte Hersteller-/Lieferantenparameter können mithilfe des Befehls Add Parameter(s) To aus dem Panel Hersteller-Bauteilsuche in ein Bibliotheksbauteil oder ein platziertes Bauteil importiert werden. Der Befehl ist im Bereich Details des Panels verfügbar, der über die Schaltfläche geöffnet wird.

Wählen Sie dazu in der Suchergebnisliste des Panels ein Herstellerbauteil oder einen seiner Lieferantenuntereinträge und anschließend im Bereich Details des Panels die gewünschten Parametereinträge aus. Klicken Sie mit der rechten Maustaste auf einen ausgewählten (hervorgehobenen) Parametereintrag und wählen Sie die Befehlsoption Add Parameter(s) To, um die Parameter auf das Zielbauteil zu übertragen.

  • Bei einem Bibliotheksbauteil ist das Ziel der im Panel SCH-Bibliothek ausgewählte Eintrag oder (bei einer Datenbankbibliothek) die DBLib Table Browser.

  • Bei einem platzierten Bauteil wird das Ziel im Schaltplaneditor mit dem Fadenkreuz ausgewählt.

Bei der Übertragung von Parameter-Wert-Paaren sind folgende Punkte zu beachten:

  • Wenn der Parameter im Zielbauteil bereits vorhanden ist, wird sein Wert aktualisiert – siehe Voltage Rating in den obigen Beispielabbildungen.

  • Wenn der Parameter noch nicht vorhanden ist, wird das importierte Parameter-Wert-Paar zum Zielbauteil hinzugefügt – Tolerance und Material in der obigen Abbildung.

  • Der Vorgang berücksichtigt die Einstellungen im Bereich Parameter Import Options auf der Seite Datenverwaltung – Bauteilanbieter des Dialogs Preferences. Wenn beispielsweise Capacitance dem Parameter Value zugeordnet ist, wird letzterer dem Zielbauteil als Kapazitätswert hinzugefügt – Value 1nF.

  • Lieferantenparameter wie Stock und Pricing sind im Bereich Details des Panels Manufacturer Part Search nur verfügbar, wenn eine Lieferantenkachel (anstelle des Herstellerbauteils) als Quelle ausgewählt ist.

  • Wie bei anderen Parametern werden hinzugefügte Lieferantendaten vorhandene Lieferantenparameter im Zielbauteil update. Das Suffix der Lieferantendaten bleibt bei 1; durch weitere Ergänzungen wird der Suffixwert nicht erhöht.

Lieferantendaten in eine Stückliste aufnehmen

Lieferantendatenverknüpfungen, die Bauteilen in einem Design hinzugefügt wurden oder bereits in einem aus einer Bibliothek platzierten Bauteil enthalten sind, werden mit dem Design gespeichert und können in eine Bill of Materials (BOM) aufgenommen werden.

Stücklistenbericht

Im einfachsten Fall stehen die Lieferantenverknüpfungen der Bauteile in einem Stücklistenbericht zur Verfügung, der aus den Projektquelldaten generiert wird. Wählen Sie Reports » Bill of Materials, um den Dialog Stückliste für Projekt zu öffnen. Der Bericht lässt sich an Ihre Anforderungen anpassen und in verschiedenen Formaten (Excel, PDF, HTML usw.) generieren. Der Stücklistenbericht kann auch als Berichtsausgabe in einen Ausgabeauftrag des Projekts aufgenommen werden.

► Ausführliche Informationen finden Sie unter Stücklistenkonfiguration im Report Manager.

Ein einfacher Stücklistenbericht zeigt Lieferantendatenparameter für Bauteile an, die Lieferantenverknüpfungen enthalten.Ein einfacher Stücklistenbericht zeigt Lieferantendatenparameter für Bauteile an, die Lieferantenverknüpfungen enthalten.

Wenn im Projekt ein ActiveBOM-Dokument vorhanden ist (siehe unten), extrahiert ein Stücklistenbericht die Daten der Lieferantenverknüpfungen aus diesem Dokument und nicht aus den Designdokumenten des Projekts.

ActiveBOM-Dokument

Der deutlich fortschrittlichere und empfohlene Ansatz zur Verwaltung von Hersteller- und Lieferantenverknüpfungen in einer Projektstückliste besteht darin, ein ActiveBOM-Dokument in Ihr Projekt aufzunehmen – File » New » ActiveBOM Document. Beachten Sie, dass die Vorteile dieses Ansatzes bei Verwendung von Workspace-Bibliotheksbauteilen vollständig zum Tragen kommen.

► Ausführliche Informationen finden Sie unter Stücklistenverwaltung mit ActiveBOM.

ActiveBOM verwendet Bauteildaten Solutions, um umfassende aktuelle Bauteilinformationen hinzuzufügen, beispielsweise Details zum Herstellerbauteil (einschließlich Lebenszyklusstatus), Lieferantenpreise und Lagerbestände.

Vorhandene Lieferantenverknüpfungen von Bauteilen, die zuvor auf Bibliotheks- oder Schaltplandokumentebene hinzugefügt wurden, werden automatisch in ActiveBOM-Lösungen umgewandelt. Beachten Sie, dass diese weiterhin nur den einzelnen Lieferanten anzeigen, der beim Definieren der Lieferantenverknüpfung hinzugefügt wurde, auch wenn das betreffende Herstellerbauteil möglicherweise bei mehreren Lieferanten erhältlich ist.

Der nächste Schritt über Stücklistenlösungen hinaus, die aus vorhandenen Lieferantenverknüpfungen der Bauteile in der Bibliothek oder im Schaltplan abgeleitet wurden, besteht darin, neue Bauteillösungen über die ActiveBOM-Oberfläche hinzuzufügen.

Die nativen, herstellerorientierten Lösungen von ActiveBOM bieten eine erweiterte Datenzuordnung zwischen dem Designbauteil und dem Herstellerbauteil sowie all of the approved Suppliers dieses Bauteils. Die Echtzeitdaten der Lösung stehen während des gesamten Designprozesses zur Verfügung und dienen als Quelle für alle stücklistenbezogenen Ausgaben.

Sie können Ihrem Designbauteil (Lösung) nicht nur mehrere Lieferanten eines bestimmten Herstellerbauteils zuordnen, sondern dieser Lösung auch mehrere Herstellerbauteile zuweisen. Wenn die DesignPart - ManufacturerPart-Zuordnung als Bestandteil des Designbauteils in Ihrem Workspace gespeichert wird, wird dieser Ansatz als Part Choices bezeichnet. Wird die Zuordnung im ActiveBOM-Dokument (BomDoc) gespeichert, wird er als Manufacturer Links bezeichnet.

Dieser leistungsfähige Ansatz bedeutet, dass das Designbauteil keine Informationen zu Lieferanten oder Lieferanten-Bauteilnummern speichern muss. 

► Erfahren Sie mehr unter Lieferketteninformationen zu einem Bauteil in Altium Designer hinzufügen.

Wenn Ihr Design keine Workspace-Bauteile verwendet, wählen Sie die Option Create/Edit Manufacturer Links im Menü der Schaltfläche , um dem aktuell ausgewählten Bauteileintrag eine ActiveBOM-Lösung hinzuzufügen. Wählen Sie im daraufhin angezeigten Dialog Edit Manufacturer Links die Schaltfläche und anschließend im Dialog Add Part Choices einen passenden Herstellerbauteileintrag aus. Nach der Bestätigung (OK) wird diese Bauteilverknüpfung als neuer Eintrag im Dialog Edit Manufacturer Links hinzugefügt.

Nachdem Sie das Hinzufügen im Dialog bestätigt haben (), wird die ActiveBOM-Lösung dem Stücklisten-Bauteileintrag hinzugefügt. Beachten Sie, dass die Lösung in diesem Fall die vollständige Liste der Lieferantenoptionen enthält. Die ausgewählte Option (grün markiert) ist dabei als „beste“ Lieferantenlösung für das Herstellerbauteil gekennzeichnet.

Verwenden Sie das zugehörige Panel Eigenschaften, um die ActiveBOM-Funktionen zu konfigurieren, beispielsweise die verwendete Währung, die Datenquelle für Herstellerverknüpfungen, sichtbare Datenspalten, Gruppierungen von Stücklistenpositionen, Warnungen der Stücklistenprüfung usw.

► Weitere Informationen finden Sie unter Stücklistenverwaltung mit ActiveBOM.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents