Synchronisierung von Lieferkettendatenbankdaten mit Workspace-Daten

Über das Konzept der Bauteiloptionen können Komponenten, die in einem Altium 365 Workspace oder Enterprise Server Workspace gehostet werden, anhand ihres angegebenen Herstellerbauteils mit realen Lieferantenartikeln verknüpft werden. Standardmäßig werden diese Lieferkettendaten über den Cloud-Dienst Altium Parts Provider bezogen und umfassen Echtzeitinformationen zu Lieferantenartikeln, etwa Lagerbestände, Stückpreise und Preisstaffeln.

In vielen Unternehmen werden jedoch Daten zu Komponentenlieferanten aus einem internen Unternehmenssystem bezogen – und müssen auch von dort bezogen werden. Dieses System stellt einen unternehmensspezifischen Satz von Lieferantendaten bereit, der beispielsweise auf einer streng freigegebenen Auswahl von Lieferanten und/oder speziellen Preisstrukturen basiert. Für diesen Fall steht alternativ Altium Custom Parts Provider zur Verfügung. Wird dies für die Synchronisierung über Altium Designer konfiguriert, lassen sich die Lieferantendaten aus einer angegebenen Datenbankquelle den Lieferkettendaten im Workspace zuordnen.

Mit der nachfolgend beschriebenen Funktion Custom Parts Provider Synchronization von Altium Designer werden Lieferantendaten aus einer ausgewählten Tabelle einer zentralen Datenbank als alternative Datenquelle für die in Altium Designer festgelegten Bauteiloptionen zugeordnet. In der Praxis wird die von Ihnen erstellte Zuordnungskonfiguration verwendet, um die Quelldatenbank zeitgesteuert oder einfach bei Bedarf mit den Lieferantendaten im Workspace zu synchronisieren. Dadurch werden Aktualisierungen der Lieferantendaten in der zentralen Datenbank an die entsprechenden Lieferantendaten der Komponenten im verbundenen Workspace weitergegeben.

Mit dieser Funktion können Unternehmen, die ihre Komponentenlieferantendaten zentral in der Datenbank eines Unternehmenssystems verwalten, die Vorteile eines Altium Workspace nutzen und gleichzeitig die Synchronisierung mit ihrem Unternehmenssystem (PLM, PDM, ERP usw.) aufrechterhalten – oder einfach mit einer gemeinsam genutzten Datenbank oder CSV-Datei. Im automatischen Synchronisierungsmodus führt eine geplante Windows-Aufgabe die Datenaktualisierung von der Datenbank zum Workspace unabhängig vom Altium Designer-Designclient aus.

Um in Altium Designer auf die Synchronisierungsfunktionen für benutzerdefinierte Bauteildatenanbieter zugreifen zu können, muss die Funktion Custom Data Synchronization für Ihre Installation von Altium Designer aktiviert sein. Diese Funktion kann nach der Installation aktiviert oder deaktiviert werden.

Weitere Informationen zum Ändern der installierten Kernfunktionen finden Sie auf der Seite Installing & Managing (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Erstellen einer Synchronisierungskonfiguration für einen benutzerdefinierten Bauteildatenanbieter

Die Synchronisierung der Lieferantendaten von Bauteilen zwischen Datenbank und Workspace wird durch das Erstellen und Einrichten eines Custom Parts Provider Synchronization Configuration-Dokuments (*.PrtSync) in Altium Designer eingerichtet. Die Benutzeroberfläche und die Funktionalität des Dokuments ähneln denen des Komponenten-Synchronisierers. Erstellen Sie bei bestehender Verbindung zu Ihrem Altium Workspace das neue Dokument über den Menübefehl File » New » Custom Parts Provider Synchronization Configuration.

Fügen Sie der Synchronisierungskonfiguration die gewünschte zentrale Datenquelle über die Schaltfläche hinzu, oder ziehen Sie kompatible Datendateien per Drag-and-drop in den Bereich Data Sources der Benutzeroberfläche. Die Konfiguration unterstützt die folgenden Datenquellen für Komponentenparameter:

  • Access-Datenbankdateien (*.mdb, *.accdb)

  • Excel-Tabellen (*.xlsx)

  • CSV-Dateien (*.csv)

  • Andere Datenquellen, etwa serverbasierte OLE DB-kompatible Schnittstellen (einschließlich PostgreSQL-Datenbanken), über eine spezifische Verbindungszeichenfolge. Die Vorgehensweise für die MySQL-ODBC-Verbindung finden Sie unten im Abschnitt zur MySQL-Konfiguration.

Für die Datenbankverbindung benötigt der Bauteildatenanbieter-Synchronisierer Zugriff auf die 64-Bit-Version von Microsoft OLE DB Provider.

Im hier gezeigten Beispiel wurde der Konfiguration eine Datenbank hinzugefügt, die Lieferantendaten für Bauteile (Zenerdioden) enthält. Die Quelldatenbank (SupplierData.mdb) enthält zwei Tabellen – CustomSupplierParts1 und CustomSupplierParts2 –, wobei die erste Tabelle für die Zuordnung und Synchronisierung aktiviert ist.

Zuordnung der Lieferantendatenparameter

Die neue Konfiguration für den benutzerdefinierten Bauteildatenanbieter greift auf die Datenbanktabelle als parametrische Datenquelle zu. Wenn die Tabelle in der Baumstruktur Data Sources der Konfiguration ausgewählt wird, kann sie den standardmäßigen Lieferantendatenparametern zugeordnet werden, die von Altium Designer und dem Altium Workspace verwendet werden.

Beachten Sie, dass der Schlüsselparameter (eindeutige Kennung), der die Lieferantendateneinträge mit den Workspace-Komponenten verknüpft, Manufacturer Part Number ist.

Im hier gezeigten Beispiel werden somit für eine Workspace-Komponente mit dem Wert 1N4741A für Manufacturer Part Number (Name) letztlich benutzerdefinierte Lieferantendaten aus den Einträgen der Quelldatenbank bereitgestellt, deren Wert für Part Number gleich 1N4741A ist – siehe die Parameterzuordnung im Panel Properties unten.

Lieferantendatenparameter werden im Bereich Parameter Mapping des Panels Properties aus der Quelldatenbank der Bauteildatenanbieter-Konfiguration zugeordnet. Verwenden Sie die Optionen im Dropdown-Menü des Eintrags Column, um einen Datenbankquellparameter auszuwählen, der dem jeweiligen Lieferantendatenparameter entspricht, oder um einen Parameter aus der Synchronisierung zu entfernen (<Skip>). Bei der Zuordnung wird jeder Satz von Parameterdaten der Liste Components Preview hinzugefügt. Diese Spalten können durch Ziehen ihrer Überschriften neu angeordnet und über das Menü Select Columns aktiviert oder deaktiviert werden. Dieses Menü öffnen Sie durch einen Rechtsklick auf eine Überschrift.

Eine Reihe von Systemparametern für Lieferantendaten wird unterstützt, darunter Manufacturer Name, Manufacturer Part Number, Category, Datasheet usw. Sie können auch benutzerdefinierte Lieferantendatenparameter über die Schaltflächen  und  im Bereich Parameter Mapping des Panels Properties hinzufügen und entfernen.

Preisstaffelgrenzen für Bauteile geben an, wie viele Bauteile bei einem Lieferanten bestellt werden müssen, um einen niedrigeren Stückpreis zu erhalten. Die erforderlichen Bestellmengen sind in der Regel in Zehnerpotenzen gestaffelt – 10 Stück, 100 Stück usw. – und werden von den Bauteilauswahl-Einträgen in den Lieferantendaten von Altium unterstützt.

Diese numerischen Daten können aus Einträgen der Quelldatenbank den Lieferantendaten im Workspace zugeordnet werden. Fügen Sie dazu im Abschnitt Price Breaks des Panels Properties Preisstaffel-Einträge vom Typ Quantity hinzu, deren Mengen jeweils um eine Zehnerpotenz steigen, und ordnen Sie diese Einträge anschließend den entsprechenden Datenbankfeldern zu. Beachten Sie, dass der herkömmliche Kostenparameter unit (Price) im allgemeinen Abschnitt Parameter Mapping enthalten ist.

Ein Quelldatenbankparameter, der dem Systemparameter Product Photo URL für Lieferantendaten zugeordnet ist, unterstützt einen URI mit dem vollständigen Pfad zu einem Bild. Dieser Pfad kann auf eine lokale Ressource (z. B. C:\Component_Images\smd_cap.png) oder auf eine Ressource im Internet (z. B. http://my-website/images/smd_cap.png) verweisen. Alle gängigen Bildformate (*.bmp, *.png, *.jpeg, *.jpg usw.) werden unterstützt.

Synchronisierung zwischen Datenbank und Workspace

Wenn Sie mit der Zuordnung der Lieferantendaten zufrieden sind, speichern Sie das Konfigurationsdokument für den benutzerdefinierten Bauteilanbieter (File » Save) und führen Sie über die Schaltfläche eine Synchronisierung der Quelldatenbank mit den Serverdaten durch. Alternativ können Sie eine geplante Synchronisierung () einrichten. Bei der ersten Synchronisierung werden die zugeordneten Lieferantendaten aus Ihrer Unternehmensdatenbank in den Altium Workspace hochgeladen. Nachfolgende Synchronisierungen aktualisieren diese Daten.

Detaillierte Synchronisierungsprotokolle sind im Ordner C:\Users\Public\Documents\Altium\Logs\ComponentSync des Systems verfügbar.

Im hier gezeigten Beispiel stehen die Lieferantendaten für die Zenerdioden, die aus der Quelldatenbank mit dem Workspace synchronisiert wurden, als Custom Parts Provider-Daten für diese Bauteile zur Verfügung – zusätzlich zu den üblichen Bauteil-Lieferantendaten, die vom Cloud-Dienst Altium Parts Provider bereitgestellt werden.

Dies ist unmittelbar im Panel „Manufacturer Part Search“ zu erkennen, wenn die Kategorie Custom Parts Provider ausgewählt ist. Dort werden Beschaffungsoptionen für Bauteile angeboten, die über den Dienst „Custom Parts Provider“ aus der Lieferantendatenbank Ihres Unternehmens synchronisiert wurden.

Die Parameter Category und Datasheet sowie benutzerdefinierte Parameter werden im Panel Manufacturer Part Search () unterstützt.

Diese Funktion ist verfügbar, wenn die Option EDMS.CustomOffersMerge im Dialog „Advanced Settings“ aktiviert ist. Beachten Sie, dass sie nur bei einer Verbindung mit einem Workspace auf der Altium Platform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) verfügbar ist, für den BOM Portal aktiviert ist. Bei einer Verbindung mit einem lokal gehosteten Enterprise Server Workspace ist sie nicht verfügbar.

Zusammenführung von Lieferantendaten

Diese Funktion ist verfügbar, wenn die Option EDMS.CustomOffersMerge im Dialog „Advanced Settings“ aktiviert ist. Beachten Sie, dass sie nur bei einer Verbindung mit einem Workspace auf der Altium Platform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) verfügbar ist, für den BOM Portal aktiviert ist. Bei einer Verbindung mit einem lokal gehosteten Enterprise Server Workspace ist sie nicht verfügbar.

Wenn der Herstellername und die Herstellerteilenummer eines Bauteils in der von Ihnen synchronisierten Lieferantendatenbank mit dem Herstellernamen und der Herstellerteilenummer eines vom Altium Parts Provider bereitgestellten Bauteils übereinstimmen, werden die Lieferantendaten Ihres konfigurierten Custom Parts Provider mit denen des Altium Parts Provider zusammengeführt. So werden alle Lieferanteninformationen gemeinsam angezeigt, überall dort, wo Lieferantendaten (SPNs) in der Benutzeroberfläche der Software erscheinen – einschließlich des Panels Manufacturer Part Search, in ActiveBOM und beim Hinzufügen von Bauteilauswahlen.

Bauteilauswahlen aus benutzerdefinierten Anbieterdaten

Wenn Sie Bauteileinträgen im Panel „Components“ Informationen zur Bauteilauswahl hinzufügen (Rechtsklick, Operations » Create/Edit PCL), erscheinen die vom Custom Parts Provider bereitgestellten Lieferantendaten oben in der Liste im Dialog Add Part Choices – wie hier für den Zenerdioden-Eintrag 1N4747A gezeigt. Der ausgewählte (hervorgehobene) Eintrag wird als Bauteilauswahl für das ausgewählte Bauteil im Panel Components hinzugefügt.

Der Dialog Add Part Choices wird mit Lieferantendaten gefüllt, die von den derzeit auf der Seite Catalog Management des verbundenen Workspace (Admin » Part Providers) aktivierten Parts-Provider-Diensten bereitgestellt werden. Sowohl Altium Parts Provider als auch Custom Parts Provider sind standardmäßig aktiviert.

Wie der Dienst Altium Parts Provider unterstützt auch Custom Parts Provider Lieferantendaten für mehrere Hersteller und von mehreren Lieferanten. Diese stammen aus mehreren separaten Einträgen in der Quelldatenbanktabelle. Beachten Sie außerdem, dass die benutzerdefinierten Anbieterdaten Informationen zu Preisstaffeln und Lagerbeständen enthalten, die aus der Quelldatenbank synchronisiert wurden.

Neben dem hier gezeigten Panel Components können Bauteilauswahlen mit Lieferantendaten in den folgenden Altium Designer-Oberflächen einer Bauteilreferenz zugeordnet werden:

Beachten Sie, dass Änderungen an den Lieferantendaten in der Quelldatenbank bei der nächsten Synchronisierung in die Custom-Parts-Provider-Daten des Workspace übernommen werden – unabhängig davon, ob die Synchronisierung manuell oder durch einen Zeitplanungsdienst gestartet wird. Aktualisieren Sie die oben aufgeführten Ansichten in Altium Designer mit der Taste F5 oder der Schaltfläche , um die neuesten Lieferantendaten anzuzeigen.

Geplante Synchronisierung

Gespeicherte Konfigurationen für die Bauteilsynchronisierung werden über den Dialog Auto Synchronization Schedule für die automatische Datenverarbeitung zwischen Datenbank und Workspace eingerichtet. Dieser wird über die Schaltfläche in der Hauptoberfläche geöffnet.

Die geplante Synchronisierung gemäß dem aktuellen Konfigurationsprofil kann täglich zu einer bestimmten Uhrzeit, an bestimmten Wochentagen zu einer festgelegten Uhrzeit oder bei der Anmeldung an Windows ausgeführt werden. Sie können die Synchronisierung auch deaktivieren, wenn Sie nicht angemeldet sind. Wenn Sie Ihre Einstellungen mit der Schaltfläche bestätigen, wird die Konfiguration als wiederkehrende Aufgabe in Windows Task Scheduler hinzugefügt. Wählen Sie No automatic synchronization, um einen vorhandenen Synchronisierungszeitplan zu entfernen.

Die Synchronisierung zwischen Datenbank und Bauteildaten kann auch manuell über die Befehlszeile mit der Anwendung ComponentSync.Executor.exe ausgeführt werden, die sich im Ordner \System der Softwareinstallation befindet. Die Befehlssyntax lautet ComponentSync.Executor.exe [configuration file name]. In der folgenden Abbildung wurde die Konfiguration MyPrtSyncConfig aus diesem Beispiel mit der folgenden Befehlszeichenfolge ausgeführt:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync

Je nach Betriebssystem müssen Pfade, die Leerzeichen enthalten, gegebenenfalls in Anführungszeichen gesetzt werden (wie hier gezeigt).

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents