Synchronisierung von Lieferkettendatenbankdaten mit Workspace-Daten

Auf einen Blick

Halten Sie die Lieferantendaten in Ihrem Workspace mithilfe der Synchronisierung benutzerdefinierter Bauteilanbieter in Altium Designer mit den internen Datenquellen Ihres Unternehmens auf dem gleichen Stand. Dieser Artikel erläutert, wie Sie eine Datenbank, eine Tabellenkalkulation oder eine CSV-Datei anbinden, Lieferanteninformationen den Bauteiloptionen im Workspace zuordnen und Aktualisierungen bei Bedarf oder nach einem Zeitplan synchronisieren. Lesen Sie weiter und erfahren Sie, wie Sie die Lieferantendaten Ihres Unternehmens in Ihren Workspace übernehmen können.

- Erfahren Sie, wie Sie eine Synchronisierungskonfiguration erstellen und unterstützte Datenquellen anbinden.
- Lernen Sie, wie Sie Lieferantenparameter und Preisstaffeln zuordnen und Lieferanteneinträge anhand der Herstellerteilenummer mit Workspace-Komponenten verknüpfen.
- Entdecken Sie, wie Sie die Synchronisierung ausführen oder zeitlich planen und die daraus resultierenden Daten des benutzerdefinierten Bauteilanbieters in Altium Designer finden.
Mit KI tiefer einsteigen:

Über das Konzept der Teileauswahl können Komponenten, die in einem Altium 365 Workspace oder Enterprise Server Workspace gehostet werden, anhand des angegebenen Herstellerteils mit tatsächlich verfügbaren Lieferantenteilen verknüpft werden. Standardmäßig werden diese Lieferkettendaten über den Cloud-Dienst Altium Parts Provider bezogen. Sie umfassen Echtzeitinformationen zu Lieferantenteilen wie Lagerbestände, Stückpreise und Preisstaffeln.

In vielen Unternehmen werden Komponentenlieferantendaten jedoch aus einem internen Unternehmenssystem bezogen – und müssen auch von dort bezogen werden. Dieses stellt einen unternehmenseigenen Satz von Lieferantendaten bereit, der beispielsweise auf einem streng freigegebenen Lieferantenkreis und/oder speziellen Preisstrukturen basiert. Für diesen Fall steht der alternative Altium Custom Parts Provider zur Verfügung. Wird dieser für die Synchronisierung über Altium Designer konfiguriert, können Lieferantendaten aus einer bestimmten Datenbankquelle den Lieferkettendaten des Workspace zugeordnet werden.

Mit der nachfolgend beschriebenen Funktion Custom Parts Provider Synchronization in Altium Designer werden Lieferantendaten aus einer ausgewählten Tabelle einer zentralen Datenbank als alternative Datenquelle für die in Altium Designer vorgenommene Teileauswahl von Komponenten zugeordnet. In der Praxis dient die von Ihnen erstellte Zuordnungskonfiguration dazu, die Quelldatenbank zeitgesteuert oder bei Bedarf mit den Lieferantendaten im Workspace zu synchronisieren. Dadurch werden Aktualisierungen der Lieferantendaten in der zentralen Datenbank an die entsprechenden Komponentenlieferantendaten im verbundenen Workspace weitergegeben.

Mit dieser Funktion können Unternehmen, die Komponentenlieferantendaten zentral in der Datenbank eines Unternehmenssystems verwalten, die Vorteile eines Altium Workspace nutzen und gleichzeitig die Synchronisierung mit ihrem Unternehmenssystem (PLM, PDM, ERP usw.) aufrechterhalten – oder auch einfach mit einer gemeinsam genutzten Datenbank oder CSV-Datei. Im automatischen Synchronisierungsmodus führt eine geplante Windows-Aufgabe die Datenaktualisierung von der Datenbank zum Workspace unabhängig vom Altium Designer-Designclient aus.

Um die Synchronisierungsfunktionen für benutzerdefinierte Teileanbieter in Altium Designer nutzen zu können, muss die Funktion Custom Data Synchronization für Ihre Altium Designer-Installation aktiviert sein. Diese Funktion kann nach der Installation aktiviert bzw. deaktiviert werden.

Weitere Informationen zum Ändern der installierten Kernfunktionen finden Sie auf der Seite Installing & Managing (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Synchronisierungskonfiguration für einen benutzerdefinierten Teileanbieter erstellen

Die Synchronisierung von Teilelieferantendaten zwischen einer Datenbank und dem Workspace wird durch das Erstellen und Einrichten eines Custom Parts Provider Synchronization Configuration-Dokuments (*.PrtSync) in Altium Designer eingerichtet. Die Benutzeroberfläche und die Funktionen des Dokuments ähneln denen des Components Synchronizer. Wenn Sie mit Ihrem Altium Workspace verbunden sind, erstellen Sie das neue Dokument über den Menübefehl File » New » Custom Parts Provider Synchronization Configuration.

Fügen Sie der Synchronisierungskonfiguration die gewünschte zentrale Datenquelle über die Schaltfläche hinzu, oder ziehen Sie kompatible Datendateien per Drag-and-drop in den Bereich Data Sources der Benutzeroberfläche. Die Konfiguration unterstützt die folgenden Quellen für Komponentenparameterdaten:

  • Access-Datenbankdateien (*.mdb, *.accdb)

  • Excel-Tabellen (*.xlsx)

  • CSV-Dateien (*.csv)

  • Andere Datenquellen, beispielsweise serverbasierte OLE DB-kompatible Schnittstellen (einschließlich PostgreSQL-Datenbanken), über eine spezifische Verbindungszeichenfolge. Die Vorgehensweise für die MySQL-ODBC-Verbindung finden Sie weiter unten im Abschnitt zur MySQL-Konfiguration.

Für die Datenbankanbindung benötigt der Parts Provider Synchronizer Zugriff auf die 64-Bit-Version von Microsoft OLE DB Provider.

Im hier gezeigten Beispiel wurde der Konfiguration eine Datenbank hinzugefügt, die Teilelieferantendaten für Zenerdioden enthält. Die Quelldatenbank (SupplierData.mdb) enthält zwei Tabellen – CustomSupplierParts1 und CustomSupplierParts2 –, wobei die erste Tabelle für die Zuordnung und Synchronisierung aktiviert ist.

Zuordnung der Lieferantendatenparameter

Die neue Konfiguration für den benutzerdefinierten Teileanbieter greift auf die Datenbanktabelle als parametrische Datenquelle zu. Wenn die Tabelle in der Baumstruktur Data Sources der Konfiguration ausgewählt ist, kann sie den standardmäßigen Lieferantendatenparametern zugeordnet werden, die von Altium Designer und dem Altium Workspace verwendet werden.

Beachten Sie, dass der Schlüsselparameter (eindeutige Kennung), der die Lieferantendateneinträge mit Workspace-Komponenten verknüpft, Manufacturer Part Number ist.

Im hier gezeigten Beispiel werden einer Workspace-Komponente mit dem Wert 1N4741A für Manufacturer Part Number (Name) somit benutzerdefinierte Lieferantendaten aus den Quelldatenbankeinträgen angeboten, deren Part Number-Wert 1N4741A lautet – siehe die Parameterzuordnung im unten gezeigten Panel Properties.

Lieferantendatenparameter werden im Bereich Parameter Mapping des Panels Properties aus der Quelldatenbank der Teileanbieter-Konfiguration zugeordnet. Verwenden Sie die Optionen im Dropdown-Menü des Eintrags Column, um einen Datenbankquellparameter auszuwählen, der einem Lieferantendatenparameter korrekt entspricht, oder um einen Parameter aus der Synchronisierung zu entfernen (<Skip>). Jeder Parameterdatensatz wird bei der Zuordnung der Liste Components Preview hinzugefügt. Diese Spalten können durch Ziehen ihrer Überschriften neu angeordnet und über das Menü Select Columns aktiviert bzw. deaktiviert werden. Dieses Menü öffnen Sie durch einen Rechtsklick auf eine Überschrift.

Eine Reihe von Systemparametern für Lieferantendaten wird unterstützt, darunter Manufacturer Name, Manufacturer Part Number, Category, Datasheet usw. Sie können auch benutzerdefinierte Lieferantendatenparameter über die Schaltflächen  und  im Bereich Parameter Mapping des Panels Properties hinzufügen und entfernen.

Preisstaffelgrenzen für Bauteile geben an, wie viele Bauteile bei einem Lieferanten bestellt werden müssen, um einen niedrigeren Stückpreis zu erhalten. Die erforderlichen Bestellmengen sind üblicherweise in Zehnerpotenzen gestaffelt – 10 Stück, 100 Stück usw. – und werden von den Part-Choice-Einträgen der Altium-Lieferantendaten unterstützt.

Diese numerischen Daten lassen sich aus Einträgen der Quelldatenbank den Lieferantendaten im Workspace zuordnen. Fügen Sie dazu im Abschnitt Price Breaks des Panels Properties Preisstaffeleinträge vom Typ Quantity hinzu, deren Mengen jeweils um eine Zehnerpotenz steigen, und ordnen Sie diese Einträge anschließend den entsprechenden Datenbankfeldern zu. Beachten Sie, dass der herkömmliche Kostenparameter unit (Price) im allgemeinen Abschnitt Parameter Mapping enthalten ist.

Ein Datenbank-Quellparameter, der dem Systemparameter Product Photo URL für Lieferantendaten zugeordnet ist, unterstützt einen URI, der den vollständigen Pfad zu einem Bild enthält. Dieser Pfad kann auf eine lokale Ressource (z. B. C:\Component_Images\smd_cap.png) oder auf eine Ressource im Internet (z. B. http://my-website/images/smd_cap.png) verweisen. Alle gängigen Bildformate (*.bmp, *.png, *.jpeg, *.jpg usw.) werden unterstützt.

Synchronisierung zwischen Datenbank und Workspace

Wenn Sie mit der Zuordnung der Lieferantendaten zufrieden sind, speichern Sie das Konfigurationsdokument für den benutzerdefinierten Bauteilanbieter (File » Save) und führen Sie über die Schaltfläche eine Synchronisierung der Quelldatenbank mit den Serverdaten durch. Alternativ können Sie eine geplante Synchronisierung () einrichten. Bei der ersten Synchronisierung werden die zugeordneten Lieferantendaten aus Ihrer Unternehmensdatenbank in den Altium Workspace hochgeladen. In nachfolgenden Synchronisierungszyklen werden diese Daten aktualisiert.

Detaillierte Synchronisierungsprotokolle sind im Ordner C:\Users\Public\Documents\Altium\Logs\ComponentSync des Systems verfügbar.

Im hier gezeigten Beispiel stehen die Lieferantendaten für die Zenerdioden, die aus der Quelldatenbank mit dem Workspace synchronisiert wurden, als Custom Parts Provider-Daten für diese Bauteile zur Verfügung – zusätzlich zu den üblichen Bauteil-Lieferantendaten, die vom Cloud-Dienst Altium Parts Provider bereitgestellt werden.

Dies ist unmittelbar im Panel Manufacturer Part Search zu erkennen, wenn die Kategorie Custom Parts Provider ausgewählt ist. Dort werden Beschaffungsoptionen für Bauteile angeboten, die über den Dienst Custom Parts Provider aus der Lieferantendatenbank Ihres Unternehmens synchronisiert wurden.

Die Parameter Category und Datasheet sowie benutzerdefinierte Parameter werden im Panel Manufacturer Part Search () unterstützt.

Diese Funktion ist verfügbar, wenn die Option EDMS.CustomOffersMerge im Dialog Erweiterte Einstellungen aktiviert ist. Beachten Sie, dass sie nur bei einer Verbindung mit einem Workspace auf der Altium-Plattform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) verfügbar ist, für den BOM Portal aktiviert ist. Bei einer Verbindung mit einem lokal gehosteten Enterprise Server Workspace ist sie nicht verfügbar.

Zusammenführen von Lieferantendaten

Diese Funktion ist verfügbar, wenn die Option EDMS.CustomOffersMerge im Dialog Erweiterte Einstellungen aktiviert ist. Beachten Sie, dass sie nur bei einer Verbindung mit einem Workspace auf der Altium-Plattform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) verfügbar ist, für den BOM Portal aktiviert ist. Bei einer Verbindung mit einem lokal gehosteten Enterprise Server Workspace ist sie nicht verfügbar.

Wenn der Herstellername und die Herstellerteilenummer eines Bauteils in der von Ihnen synchronisierten Lieferantendatenbank mit dem Herstellernamen und der Herstellerteilenummer eines vom Altium Parts Provider bereitgestellten Bauteils übereinstimmen, werden die Lieferantendaten Ihres konfigurierten Custom Parts Provider mit denen des Altium Parts Provider zusammengeführt. So werden sämtliche Lieferanteninformationen überall dort gebündelt angezeigt, wo Lieferantendaten (SPNs) in der Benutzeroberfläche der Software dargestellt werden, einschließlich des Panels Manufacturer Part Search, in ActiveBOM und beim Hinzufügen von Part Choices.

Part Choices aus Daten benutzerdefinierter Anbieter

Wenn Sie Bauteileinträgen im Panel Components Informationen zu Part Choices hinzufügen (Rechtsklick, Operations » Create/Edit PCL), erscheinen die vom Custom Parts Provider bereitgestellten Lieferantendaten oben in der Liste im Dialog Add Part Choices – wie hier für den Zenerdioden-Eintrag 1N4747A gezeigt. Der ausgewählte (hervorgehobene) Eintrag wird als Part Choice für das ausgewählte Bauteil im Panel Components hinzugefügt.

Der Dialog Add Part Choices wird mit Lieferantendaten gefüllt, die von den derzeit auf der Seite Catalog Management des verbundenen Workspace (Admin » Part Providers) aktivierten Parts-Provider-Diensten bereitgestellt werden. Sowohl Altium Parts Provider als auch Custom Parts Provider sind standardmäßig aktiviert.

Wie der Dienst Altium Parts Provider unterstützt auch Custom Parts Provider Lieferantendaten für mehrere Hersteller und von mehreren Lieferanten. Diese werden aus mehreren separaten Einträgen in der Tabelle der Quelldatenbank abgeleitet. Beachten Sie außerdem, dass die Daten des benutzerdefinierten Anbieters auch Informationen zu Preisstaffeln und Lagerbeständen enthalten, die aus der Quelldatenbank synchronisiert wurden.

Neben dem hier gezeigten Panel Components können Part Choices mit Bauteil-Lieferantendaten in den folgenden Oberflächen von Altium Designer einer Bauteilreferenz zugeordnet werden:

Beachten Sie, dass Änderungen an den Lieferantendaten in der Quelldatenbank bei der nächsten Synchronisierung in die Daten des Custom Parts Provider im Workspace übernommen werden – unabhängig davon, ob die Synchronisierung manuell oder durch einen Zeitplanungsdienst ausgelöst wird. Aktualisieren Sie die oben aufgeführten Ansichten der Altium Designer-Oberfläche mit der Taste F5 oder der Schaltfläche , um die aktuellen Lieferantendaten anzuzeigen.

Geplante Synchronisierung

Gespeicherte Konfigurationen für die Bauteilsynchronisierung werden über den Dialog Auto Synchronization Schedule für die automatisierte Datenverarbeitung zwischen Datenbank und Workspace eingerichtet. Sie öffnen diesen Dialog über die Schaltfläche in der Hauptoberfläche.

Die geplante Synchronisierung gemäß dem aktuellen Konfigurationsprofil kann täglich zu einer bestimmten Uhrzeit, an bestimmten Wochentagen zu einer bestimmten Uhrzeit oder bei Ihrer Anmeldung bei Windows ausgeführt werden. Sie können die Synchronisierung auch für Zeiten deaktivieren, in denen Sie nicht angemeldet sind. Wenn Sie Ihre Einstellungen mit der Schaltfläche bestätigen, wird die Konfiguration als wiederkehrende Aufgabe in Windows Task Scheduler hinzugefügt. Wählen Sie No automatic synchronization, um einen vorhandenen Synchronisierungszeitplan zu entfernen.

Die Synchronisierung der Bauteildaten mit der Datenbank kann auch manuell über die Befehlszeile mit der Anwendung ComponentSync.Executor.exe ausgeführt werden. Diese befindet sich im Ordner \System der Softwareinstallation. Die Befehlssyntax lautet ComponentSync.Executor.exe [configuration file name]. In der folgenden Abbildung wurde die Konfiguration MyPrtSyncConfig aus diesem Beispiel mit der folgenden Befehlszeichenfolge ausgeführt:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync

Je nach Betriebssystem müssen Pfade, die Leerzeichen enthalten, möglicherweise in Anführungszeichen gesetzt werden (wie hier gezeigt).

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents