Ausgaben vorbereiten und das Projekt freigeben
Auf einen Blick
- Konfigurieren Sie Gerber- und NC-Bohrdatenausgaben, einschließlich Einheiten, Genauigkeit und Ausgabepfaden.
- Richten Sie BOM-, Draftsman- und Pick-&-Place-Ausgaben für die Bestückungsdokumentation ein.
- Fügen Sie einen DRC-Validierungsbericht hinzu, um die Designregeln zu prüfen, bevor weitere Freigabeausgaben generiert werden.
Main page: Ihr Design für die Fertigung vorbereiten
Nachdem Sie das Design und Layout der Leiterplatte abgeschlossen haben, können Sie nun die Ausgabedokumentation erstellen, die zur Prüfung, Fertigung und Bestückung der Leiterplatte benötigt wird.
Da bei der Leiterplattenfertigung unterschiedliche Technologien und Verfahren zum Einsatz kommen, kann Altium Designer zahlreiche Ausgabetypen für verschiedene Zwecke erzeugen, darunter Gerber-Dateien, ODB++-Dateien, Pick-and-Place-Dateien, Stücklistenberichte usw.
Eine Output-Job-Datei zum Projekt hinzufügen
Main page: Fertigungsdaten mit Output Jobs vorbereiten
Sie können die benötigten Ausgaben zwar gezielt aus bestimmten Editoren erzeugen (z. B. über Befehle in den Untermenüs Fabrication Outputs und Assembly Outputs des Hauptmenüs File im PCB-Editor), Altium Designer unterstützt jedoch auch Output-Job-Dateien. Eine Output-Job-Datei (kurz „OutJob“) speichert die Einstellungen für jeden Ausgabetyp. Mit einem OutJob können Sie jeden Ausgabetyp sowie dessen Benennung, Format und Ausgabeort konfigurieren. Ausgaben lassen sich direkt aus einem OutJob oder im Rahmen des integrierten Projektfreigabeprozesses erzeugen.
-
Klicken Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag und wählen Sie im Kontextmenü den Befehl Add New to Project » Output Job File. Eine neue Output-Job-Datei wird geöffnet. Im Panel Projects erscheint unter dem Eintrag Settings\Output Job Files ein mit dem Projekt verknüpfter Eintrag für diese Datei.
-
Klicken Sie im Panel Projects mit der rechten Maustaste auf den OutJob-Eintrag und wählen Sie den Befehl Save As. Das Dialogfeld Save As wird geöffnet und ist so voreingestellt, dass das Dokument am selben Speicherort wie die Projektdatei gespeichert wird. Geben Sie im Feld File name den Namen
Fabricationein und klicken Sie auf die Schaltfläche Save. -
Durch das Hinzufügen des OutJobs wurde das Projekt geändert. Speichern Sie das Projekt daher lokal, indem Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag klicken und Save auswählen.
Ausgaben für die Leiterplattenfertigung hinzufügen und konfigurieren
Main page: Daten für die Leiterplattenfertigung vorbereiten
In diesem Teil des Tutorials konfigurieren Sie die für die Fertigung der Leiterplatte erforderlichen Ausgaben: Gerber- und NC-Bohrdateien.
-
Um eine neue Gerber-Ausgabe hinzuzufügen, klicken Sie im Abschnitt Fabrication Outputs des Bereichs Outputs des OutJobs auf den Link Add New Fabrication Output und wählen Sie Gerber Files » [PCB Document].
-
Doppelklicken Sie auf den hinzugefügten Ausgabeeintrag Gerber Files. Das Dialogfeld Gerber Setup wird geöffnet. Konfigurieren Sie die Optionen im Dialogfeld wie folgt:
-
Da die Leiterplatte im metrischen System entworfen wurde, stellen Sie sicher, dass die Option Units auf Millimeters eingestellt ist.
-
Die kleinste auf der Leiterplatte verwendete Einheit beträgt 0,25 mm für die Leiterbahnführung und die Abstände. Da die meisten Bauteile ihren Referenzpunkt jedoch in ihrem geometrischen Mittelpunkt haben (und auf einem 1-mm-Raster platziert wurden), liegen einige ihrer Pads tatsächlich auf einem 0,01-mm-Raster. Stellen Sie die Option Decimal auf 0.001 mm ein. Dadurch ist die Auflösung der Ausgabedaten mehr als ausreichend, um diese Rasterpositionen abzubilden.
-
Klicken Sie unten auf der Registerkarte Layer to plot auf die Schaltfläche
und wählen Sie Select Used. Die im Design verwendeten Lagen werden in der Spalte Plot der darüberliegenden Tabelle aktiviert.
-
-
Klicken Sie auf Apply, um die übrigen Standardeinstellungen zu übernehmen und das Dialogfeld Gerber Setup zu schließen.
-
Da die Leiterplatte Bohrungen enthält, muss auch eine NC-Bohrdatei erzeugt werden. Fügen Sie die NC-Bohrausgabe auf dieselbe Weise zur OutJob-Datei hinzu: Klicken Sie im Abschnitt Fabrication Outputs des Bereichs Outputs des OutJobs auf den Link Add New Fabrication Output und wählen Sie NC Drill Files » [PCB Document].
-
Doppelklicken Sie auf den hinzugefügten Ausgabeeintrag NC Drill Files, um das Dialogfeld NC Drill Setup zu öffnen. Damit die NC-Bohrdateien im selben Format wie die Gerber-Dateien erstellt werden, setzen Sie Units auf Millimeters und Format auf 4:3. Stellen Sie sicher, dass die Option Coordinate Position auf Reference to relative origin eingestellt ist.
-
Klicken Sie auf OK, um die übrigen Standardeinstellungen zu übernehmen und das Dialogfeld NC Drill Setup zu schließen.
-
Nachdem die Gerber- und NC-Bohreinstellungen konfiguriert sind, müssen Sie als Nächstes deren Benennung und Ausgabeort festlegen. Dazu ordnen Sie sie einem Ausgabecontainer auf der rechten Seite des OutJobs zu. Verwenden Sie für einzelne Dateien mit eigenem Dateiformat einen Ordnerstruktur-Container. Ein neuer OutJob enthält standardmäßig bereits einige Container. Wählen Sie in der Liste der Ausgabecontainer den Eintrag Folder Structure und klicken Sie anschließend in der Spalte Enabled des Bereichs Outputs auf die Optionsfelder für die Gerber- und NC-Bohrdateien, um diese Ausgaben dem ausgewählten Container zuzuordnen, wie unten gezeigt.
-
Im letzten Schritt konfigurieren Sie den Container. Klicken Sie dazu bei ausgewähltem Containereintrag auf den Link Change, um das Dialogfeld Folder Structure settings zu öffnen. Oben im Dialogfeld befinden sich Steuerelemente zum Konfigurieren des Ausgabeorts. Stellen Sie sicher, dass das erste Steuerelement auf Release Managed eingestellt ist. Im unteren Teil des Dialogfelds wird angezeigt, wie sich die Namen und die Ordnerstruktur ändern, wenn Sie unterschiedliche Optionen auswählen.
-
Klicken Sie auf OK, um das Dialogfeld Folder Structure settings zu schließen.
Einen DRC-Validierungsbericht hinzufügen und konfigurieren
Main page: Validierungsberichte vorbereiten
Altium Designer bietet eine Reihe von Validierungsprüfungen, die bei der Ausgabeerzeugung als Ausgabe eingebunden werden können. Jede Prüfung erzeugt eine HTML-Berichtsdatei. Während des Projektfreigabeprozesses werden diese Prüfungen vor der Erzeugung anderer Ausgaben durchgeführt. Wird eine der Validierungsprüfungen nicht erfolgreich bestanden, schlägt die Freigabe fehl.
-
Um eine neue DRC-Validierungsausgabe hinzuzufügen, klicken Sie im Abschnitt Validation Outputs des Bereichs Outputs des OutJobs auf den Link Add Validation Output und wählen Sie Design Rules Check » [PCB Document].
-
Ordnen Sie den hinzugefügten Bericht dem vorhandenen Container Folder Structure zu. Wählen Sie in der Liste auf der rechten Seite des OutJobs den Eintrag Folder Structure und klicken Sie anschließend in der Spalte Enabled des Bereichs Outputs auf das Optionsfeld für die Ausgabe Design Rules Check.
-
Speichern Sie die Output-Job-Datei lokal, indem Sie im Panel Projects mit der rechten Maustaste auf ihren Eintrag klicken und im Kontextmenü Save auswählen.
-
Schließen Sie die Output-Job-Datei, indem Sie mit der rechten Maustaste auf ihre Registerkarte oben im Designbereich klicken und den Befehl Close Fabrication.OutJob aus dem Kontextmenü auswählen.
Hinzufügen und Konfigurieren von Bestückungsausgaben
Main page: Stücklistenkonfiguration im Report Manager
Die eigentliche Stücklisten-Ausgabedatei wird über den Dialog Report Manager erzeugt – eine umfassend konfigurierbare Berichtsgenerierungs-Engine, die Ausgaben in verschiedenen Formaten wie Text, CSV, PDF, HTML und Excel erstellen kann. Auf Stücklisten im Excel-Format können Sie außerdem eine der vordefinierten Vorlagen oder eine eigene Vorlage anwenden.
-
Fügen Sie dem Projekt eine neue OutJob-Datei hinzu, indem Sie mit der rechten Maustaste auf den Projekteintrag im Panel Projects klicken und den Befehl Add New to Project » Output Job File aus dem Kontextmenü auswählen.
-
Klicken Sie mit der rechten Maustaste auf den OutJob-Eintrag im Panel Projects und wählen Sie den Befehl Save As aus. Der Dialog Save As wird geöffnet, sodass Sie das Dokument am selben Speicherort wie die Projektdatei speichern können. Geben Sie den Namen
Assemblyin das Feld File name ein und klicken Sie auf die Schaltfläche Save. -
Speichern Sie das Projekt lokal, indem Sie mit der rechten Maustaste auf den Projekteintrag im Panel Projects klicken und Save auswählen.
-
Um eine neue Stücklistenausgabe hinzuzufügen, klicken Sie im Abschnitt Report Outputs der OutJob-Datei auf den Link Add New Report Output und wählen Sie Bill of Materials » [ActiveBOM Document] aus.
-
Doppelklicken Sie auf die hinzugefügte Ausgabe Bill of Materials, um den Dialog Report Manager zu öffnen.
-
Wählen Sie im Bereich Export Options des Fensters Properties auf der rechten Seite des Dialogs über die Dropdown-Liste File Format die Option Generic XLS (*.xls, *.xlsx, *.xlsm) aus. Wählen Sie anschließend über die Dropdown-Liste Template die Vorlage BOM Template Single Supplier aus den in Ihrem Workspace gespeicherten Vorlagen aus.
-
Klicken Sie auf OK, um die Änderungen zu speichern und den Dialog Report Manager zu schließen.
-
Fügen Sie eine neue Draftsman-Ausgabe hinzu, indem Sie im Abschnitt Documentation Outputs der OutJob-Datei auf den Link Add New Documentation Output klicken und Draftsman » All Draftsman Documents auswählen.
-
Ordnen Sie die hinzugefügten Stücklisten- und Draftsman-Ausgaben dem vorhandenen Ausgabecontainer PDF zu. Wählen Sie dazu den Eintrag PDF in der Liste der Ausgabecontainer auf der rechten Seite der OutJob-Datei aus und klicken Sie anschließend auf die Optionsfelder für die Ausgaben Bill of Materials und Draftsman in der Spalte Enabled des Bereichs Outputs.
-
Wenn der Eintrag des PDF-Containers ausgewählt ist, klicken Sie im Eintrag auf den Link Change, um den Dialog PDF settings zu öffnen.
-
Klicken Sie oben im Dialog PDF settings auf den Eintrag Assembly.PDF, wählen Sie Separate file for each output using output name aus und klicken Sie auf die Schaltfläche
. Die ausgegebene Stückliste und Zeichnung erhalten jeweils den Namen, der für die Ausgabe in der OutJob-Datei festgelegt ist (Bill of Materials.pdf bzw. Draftsman.pdf). Dieser wird im Bereich Preview des Dialogs angezeigt.
-
Klicken Sie auf OK, um den Dialog zu schließen.
-
Fügen Sie eine neue Pick-&-Place-Ausgabe hinzu, indem Sie im Abschnitt Documentation Outputs der OutJob-Datei auf den Link Add New Documentation Output klicken und Generates pick and place files » [PCB Document] auswählen.
-
Doppelklicken Sie auf die hinzugefügte Ausgabe Generates pick and place files, um den Dialog Pick and Place Setup zu öffnen.
-
Setzen Sie im Bereich Output Setting unten links im Dialog die Einstellung Units auf Metric.
-
Klicken Sie auf OK, um die übrigen Standardeinstellungen zu übernehmen und den Dialog Pick and Place Setup zu schließen.
-
Ordnen Sie die hinzugefügte Pick-&-Place-Ausgabe dem vorhandenen Ausgabecontainer Folder Structure zu. Wählen Sie dazu den Eintrag Folder Structure in der Liste der Ausgabecontainer auf der rechten Seite der OutJob-Datei aus und klicken Sie anschließend auf das Optionsfeld für die Ausgabe Generates pick and place files in der Spalte Enabled des Bereichs Outputs.
-
Speichern Sie die Output-Job-Datei lokal, indem Sie mit der rechten Maustaste auf ihren Eintrag im Panel Projects klicken und Save aus dem Kontextmenü auswählen.
-
Schließen Sie die Output-Job-Datei, indem Sie mit der rechten Maustaste auf ihre Registerkarte oben im Designbereich klicken und den Befehl Close Assembly.OutJob aus dem Kontextmenü auswählen.
Freigeben des Projekts
Main page: Freigabe des Designprojekts
Nachdem die Ausgabedokumentation in den Output-Job-Dateien konfiguriert wurde, kann das Projekt für den verbundenen Workspace freigegeben werden. Der Freigabeprozess für das Leiterplattendesign ist automatisiert, sodass Sie Ihre Leiterplattendesignprojekte ohne die Risiken manueller Freigabeverfahren freigeben können. Bei der Freigabe eines Projekts wird eine Momentaufnahme der Designquelldaten erstellt und zusammen mit allen erzeugten Ausgaben archiviert. Diese bildet ein konkretes Produkt ab, das auf Grundlage dieses Designprojekts gefertigt und vom Unternehmen verkauft wird.
Der eigentliche Freigabeprozess wird mit dem Project Releaser von Altium Designer durchgeführt. Seine Benutzeroberfläche steht in einer eigenen Ansicht zur Verfügung – der Release-Ansicht. Der Freigabeprozess ist in mehrere Phasen gegliedert. Die Einträge auf der linken Seite der Ansicht zeigen Ihnen auf einen Blick, in welcher Phase Sie sich gerade befinden.
-
Klicken Sie mit der rechten Maustaste auf den Projekteintrag im Panel Projects und wählen Sie den Befehl Project Releaser aus dem Kontextmenü aus. Die Release-Ansicht wird als separate Dokumentregisterkarte geöffnet.
-
In der ersten Phase – 1. Configure Server Release – legen Sie fest, welche Datentypen Sie erzeugen möchten. Klicken Sie auf die Steuerelemente Details ganz rechts in der Kopfzeile jedes Datensatzes, um Details dazu anzuzeigen, was genau durch den jeweiligen Datensatz erzeugt wird.
-
Klicken Sie unten links in der Ansicht auf die Schaltfläche
, um den Dialog Project Release Options zu öffnen. Stellen Sie auf der Registerkarte Release Options des Dialogs sicher, dass Managed - <WorkspaceName> als Release Target ausgewählt ist, dass Fabrication dem Satz Fabrication Data zugewiesen ist und dass Assembly dem Satz Assembly Data zugewiesen ist.
-
Klicken Sie auf OK, um den Dialog zu schließen und zur Release-Ansicht zurückzukehren.
-
Stellen Sie sicher, dass die beiden Optionen Include Fabrication Data und Include Assembly Data for No Variant aktiviert sind.
-
Klicken Sie unten rechts in der Ansicht auf die Schaltfläche
, um fortzufahren.
-
Der Dialog Item Creation wird mit der Liste der im Workspace zu erstellenden Ziel-Freigabeelemente geöffnet. Wählen Sie die Option Create items aus, um die Erstellung der Elemente zu bestätigen.
-
Wählen Sie im daraufhin geöffneten Dialog Project Modified die Option Save and Commit changes aus, um die Änderungen lokal zu speichern und anschließend mit dem Speichern der Änderungen im Workspace fortzufahren.
-
Geben Sie im sich öffnenden Dialog Commit to Version Control einen aussagekräftigen Kommentar in das Feld Comment ein (z. B.
The project is ready for release) und klicken Sie dann auf die Schaltfläche
.
-
Die nächste Phase des Freigabeprozesses – 2. Validate Project – wird automatisch ausgeführt, da die Output-Job-Datei
Fabricationden Bericht zur Prüfung der Designregeln enthält. -
Nach erfolgreicher Validierung wird die nächste Phase des Freigabeprozesses – 3. Generate Data – automatisch ausgeführt. Dabei werden alle weiteren Ausgaben erzeugt, die in den OutJob-Dateien definiert sind, welche den enthaltenen Datenelementen zugewiesen sind. So werden die Daten generiert, die in den entsprechenden Zielelementen im Workspace freigegeben werden sollen.
-
Nachdem alle Validierungsprüfungen bestanden und die Ausgabedaten erzeugt wurden, können Sie in der nächsten Phase des Freigabeprozesses – 4. Review Data – die erzeugten Daten überprüfen. Setzen Sie die Freigabe fort, indem Sie unten rechts in der Ansicht auf die Schaltfläche
klicken.
-
Der Dialog Confirm Release wird geöffnet und zeigt eine Zusammenfassung der Projektkonfigurationen, die im Workspace freigegeben werden. Geben Sie einen Release Note ein (z. B.
Initial Release) und klicken Sie auf OK.
-
Nachdem Sie die Freigabe in der vorherigen Phase bestätigt haben, beginnt automatisch die nächste Phase – 5. Upload Data. Sie zeigt lediglich den Fortschritt beim Hochladen der Daten in die Revisionen der entsprechenden Datenelemente im Workspace an.
-
Die letzte Phase des Prozesses – 6. Execution Report – bietet eine Zusammenfassung der Freigabe. Schließen Sie die Freigabeansicht, indem Sie unten rechts in der Ansicht auf die Schaltfläche
klicken.
Gemeinsame Entwicklung mit einem Workspace
In der Regel sind mehrere Personen an der Entwicklung eines elektronischen Produkts beteiligt. Damit dies effektiv gelingt, müssen die Mitglieder des Entwicklungsteams zusammenarbeiten können. Altium Designer unterstützt in Verbindung mit einem angebundenen Workspace eine Reihe von Funktionen für die gemeinsame Entwicklung. Einige davon sind nachfolgend aufgeführt.
-
Project history – die spezielle History-Ansicht bietet eine erweiterte, grafisch aufbereitete Zeitleiste des Projektverlaufs. Sie stellt wichtige Ereignisse im Zusammenhang mit dem Projekt chronologisch dar – Erstellung, Commits, Freigaben, Klone und MCAD-Datenaustausch – und unterstützt gegebenenfalls verschiedene Aktionen Die History-Ansicht für ein Workspace-Projekt lässt sich in Altium Designer öffnen, indem Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag klicken und im Kontextmenü den Befehl History & Version Control » Show Project History auswählen.
Mehr erfahren: Projektverlauf, Project History (Altium 365 Workspace, Enterprise Server Workspace)
-
Web Viewer – die Web-Viewer-Oberfläche des Workspace ermöglicht den universellen Zugriff auf Projektdokumente über einen Standardbrowser. Sie ist weit mehr als nur ein browserbasierter Viewer: Dank ihrer fortschrittlichen Browsertechnologie können Benutzer durch die Projektstruktur navigieren, mit Designdokumenten interagieren, Bereiche oder Objekte zum Kommentieren hervorheben sowie im gesamten Design nach Bauteilen und Netzen suchen, diese per Cross-Probing verfolgen, auswählen und untersuchen. Der Web Viewer für ein Workspace-Projekt lässt sich in Altium Designer öffnen, indem Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag klicken und im Kontextmenü den Befehl Show in Web Browser auswählen.
Mehr erfahren: Web Viewer (Altium 365 Plattform, Enterprise Server Workspace)
-
Document commenting – ein Kommentar ist eine vom Benutzer hinzugefügte Notiz, die je nach unterstützter Datenansicht einem bestimmten Punkt, Objekt oder Bereich zugewiesen wird und auf die andere Benutzer antworten können. Kommentare fördern die Zusammenarbeit zwischen Benutzern, ohne die gemeinsam genutzten Daten selbst zu verändern, da sie vom Workspace unabhängig von diesen Daten gespeichert werden. Kommentare, die an den folgenden Stellen in der Web-Viewer-Oberfläche hinzugefügt werden, sind auch in Altium Designer verfügbar und umgekehrt. In Altium Designer wird die Kommentarfunktion über das Panel Comments and Tasks verwaltet
Mehr erfahren: Dokumente kommentieren, Web Viewer (Altium 365 Plattform, Enterprise Server Workspace)
-
Sharing a project – sobald ein Projekt im Workspace gespeichert ist, können Sie festlegen, welche Benutzer tatsächlich auf dieses Projekt zugreifen dürfen, um gemeinsam daran zu arbeiten und/oder es zu überprüfen. Dazu geben Sie das Projekt frei bzw. konfigurieren seine Zugriffsberechtigungen. In Altium Designer wird die Projektfreigabe über den Dialog Share verwaltet. Diesen öffnen Sie, indem Sie im Panel Projects mit der rechten Maustaste auf den Projekteintrag klicken und im Kontextmenü den Befehl Share auswählen.
Mehr erfahren: Ein Design teilen, Workspace Projects (Altium 365 Workspace, Enterprise Server Workspace)



















).
).
)