Configuring Visual Settings for the Active PCB Document using the View Configuration Panel in CircuitMaker

Created: July 30, 2020 | Updated: February 11, 2022

The View Configuration button opens the View Configuration panel, which is used to configure what is currently displayed in the design space and how it is displayed. This includes layer visibility and color, object visibility and transparency, masking and dimming levels, the current single layer mode, and a number of additional design space display features, such as the display of net names on pads, vias, and tracks. The panel is also used to add mechanical layers to the design, an unlimited number of mechanical layers can be added. Mechanical layers can also be paired in the panel to function as special-purpose Component Layers, for roles such as component courtyards or glue dots.

The button can be accessed from the PCB editor by choosing View | PCB | View Configuration.

You also can use Ctrl+D to open the panel with the View Options tab displayed.

Displaying or Hiding a Layer

Each layer or system attribute (such as selections or DRC errors), can be displayed or hidden. Click the visibility icon () to toggle the visibility off and on.

Controlling Visibility from the Keyboard

In a busy PCB design, layers are often toggled on and off during the design process. To help with this, layer visibility can be changed using keystrokes in the following way:

  • A shortcut key is displayed in parentheses next to each layer or layer set. Press the appropriate shortcut key to go to that layer or set of layers in the panel. For example, the C shortcut in the image above goes to Component Layer Pairs.
  • When you select a set of layers, press Spacebar to toggle the visibility of all layers in that set.
  • Press the Up or Down arrow keys on the keyboard to move up or down through the list.

Permanently Display a Layer in the Single Layer Mode Display

To include a layer in the Single Layer Mode display, press Ctrl+Click when hovering over the eye icon associated with the desired layer. A square appears around the eye icon () to denote that layer will be permanently displayed in Single Layer Mode.

Layers & Colors Tab

The Layers & Colors tab includes options to control the visibility of available layers, and add, rename or delete mechanical layers.

  • Signal and Plane Layers – click the color button to change that layer's color, as described previously in the Displaying or Hiding a Layer section. Click the visibility icon () to toggle the display of an individual signal or plane layer. Signal and Plane layers are added, named, and removed in the Pad-Via Layer Editor.
  • Component Layer Pairs – these layers are paired so that when a component is flipped from the top side to the bottom side of the board (L shortcut as a component is being moved), the software can flip the top side layer contents onto their paired bottom side layers. User-defined component layer pairs can be defined using Mechanical layers.
  • Mechanical Layers – these are general-purpose drawing layers. These layers can also be paired and when paired, they become a Component Layer Pair. Component Layer Pairs are used for special-purpose roles, for example, glue dots, or 3D component bodies. To rename a mechanical layer, right-click on it to open the Edit Layer dialog from the context menu.
  • Other Layers – these are system-managed layers, for example, objects placed on the multi-layer automatically appear on all signal layers, and objects placed on the keepout layer act as a keep-clear boundary on all signal layers.
  • Layers Sets - use the drop-down to select an existing Layer Set. The following buttons are used to create, save, and delete Layer Sets:
    • - click to create a new Layer Set. The set will appear as My Layers in the drop-down. Each subsequent Layer Set added will be numbered.
    •  - click to save when you create a new Layer Set or if you have edited the currently selected Layer Set. The creating and renaming of a Layer Set do not require a save action, as those functions save automatically. Changing the configuration of enabled layers, including your own Layer Set, does require a save action.
    • - click to delete the currently selected Layer Set.
  • Active Layer - use the drop-down to view one of the various Active Layers on the PCB individually.
    • View From Bottom Side - check this box to view the Layer Sets from the bottom side.

To configure and edit a pair of mechanical layers as a Component Layer Pair:

  • Right-click anywhere in the Layers region of the Layers & Colors tab, then select Layer Stack Manager to open the Layer Stack Manager. Here, you can assign a name or comment to a Layer, add Stack Symmetry and Library Compliance for a board, and view the number of Layers, Dielectrics, Conductive Thickness, Dielectric Thickness, and Total Thickness of the board.
  • Right-click anywhere in the Layers region of the Layers & Colors tab, then select Add Component Layer Pair from the context menu. A new mechanical layer will be automatically added to bottom of the Component Layer Pairs (C) section.
  • Right-click anywhere in the Layers region of the Layers & Colors tab, then select Add Mechanical Layer from the context menu. A new mechanical layer will be automatically added to the Mechanical Layers (M) section.

  •  Right-click or double-click on a Mechanical Layer to open the Edit Layer dialog. A Mechanical Layer may reside in the Component Layer Pairs (C) or Mechanical Layers (M) section.

Any number of Mechanical Layers can be added to the PCB. Mechanical Layers also support defining the Layer Number and setting the Layer Type. There are two sets of Layer Type options: a set for individual mechanical layers, and a set for Layer Pairs, as shown below.

As with other component layers, the software will automatically prepend the word Top or Bottom to the name to distinguish to which layer the pair is being referred.

To delete a layer, you can right-click on the desired layer and select Delete Layer. Depending on how the layer is being utilized, you will come across three options:

  • If the layer can not be deleted because it contains component primitives that cannot be removed, an error pop-up will appear to alert you that the action cannot be completed.
  • If the layer is associated with primitives that can be removed, a pop-up will appear to ask for confirmation of the deletion.
  • If the layer is not associated with primitives, it will be deleted immediately upon clicking Delete Layer without confirmation.

Only unused mechanical layers can be paired.

System Colors

Use the controls to configure the color and visibility of special display features, such as Pad Holes, Origin Marker, and Custom Snap Points.

 

View Options Tab

The View Options tab includes options to select, save or load the Configuration of layer colors/visibility, configure the visibility of object-types, control the masking and dimming levels, and configure other display related options.

  • 3D - use the buttons to switch between the 2D layout mode and the 3D layout mode. Alternatively, press the 2 or 3 shortcut keys or use the commands in the View menu. Additional options will appear in 3D mode and are described below.
  • Single Layer Mode – use the buttons to turn the single-layer mode off and on or use the Shift+S shortcut.
  • Show Grid (2D mode only) - the software has two display grids, referred to as the Fine and Coarse grids. The Fine grid is the current snap grid (as shown on the Status bar); the Coarse grid can be set to be equal or any whole-number multiple of this grid.
    • Show Grid checkbox - the checkbox gives a quick way to toggle the visibility of both the Fine and Coarse grids on and off.
    • Show Grid color selector - allows the color of both grids to be changed. The color you choose is applied to the Fine grid, with the Coarse grid being automatically set to a lighter shade of the same color.
  • Projection (3D mode only) - determines the projection of the 3D view. Choose from:
    • Orthographic - choose this option to see the exact position of objects and text on the PCB without being obscured by surrounding objects.
    • Perspective - choose this option for a more realistic 3D view of the PCB.
  • Show 3D Bodies (3D mode only) - controls the display of 3D Bodies. Use the Shift+Z shortcut to toggle this option on/off at any time when working in 3D mode.

3D Settings

Available only in 3D mode, these options are used to control the presentation of the board in 3D Layout Mode.

  • Board thickness (Scale) - controls the vertical scale of the 3D view to make it easier to differentiate the layers, for example, when reviewing the layer-to-layer connections of an internal blind via. Drag the slider to set the vertical scaling between 1 and 100 times the actual board thickness.
  • Colors - the default presentation is to render the 3D board using Realistic colors based on the Configuration currently selected in the General Settings section of this panel. Click the By Layer button to display the 3D view using the current 2D layer color assignments.
  • Layer - click a color swatch to display the color selector.
  • Transparency - use the sliders to control the transparency of each layer. 

Object Visibility

This region of the panel is used to control the visibility of objects based on their object type.

  • Name – lists all objects that can be adjusted visually.
  • Draft – enable to display that object type as an outline.

Additional Options

  • Test Points – enable this option to display additional information on pads and vias that have been configured as testpoints. A Pad or a Via can be configured as a testpoint by enabling the Fabrication and/or Assembly Testpoint options in the relevant mode of the Inspector panel. Testpoints are indicated by the addition of the string <Layer> Fab Testpoint or <Layer> Assy Testpoint to the pad/via.
  • Status Info – enable this option to have summary information, such as coordinate position and layer, displayed in the Status Bar when hovering over an object in the design space.
  • Pad Nets – enable this option to display the associated net name on a pad. Note that net names will only become visible if you are zoomed in close enough.
  • Pad Numbers – enable this option to display pad numbers. Note that pad numbers will only become visible if you are zoomed in close enough.
  • Via Nets – enable this option to display the relevant net name on a via. Note that net names will only become visible if you are zoomed in close enough.
  • Via Span – enable this option to display the length in which the via is allowed to span. The properties of placed vias (diameter, hole size, etc.,) are then defined either by design rules or manually. Note that net names will only become visible if you are zoomed in close enough. The layer numbers in the via span can be displayed inside all via types.
  • All Connections in Single Layer Mode – enable this option to always display all of the connection lines when in Single Layer Mode. With this option disabled, all connection lines that do not start or end on the current layer are also hidden when switching to Single Layer Mode as it is assumed that they are not relevant.
  • Net Color Override – each net can be assigned a color. To configure the color, double-click on that net's name in the Nets mode of the PCB panel; the Edit Net dialog will open. The color is automatically applied to that net's connection lines and also can be applied to the routing by enabling this option. Press the F5 shortcut to toggle the Net Color Override option on and off.
  • Use Layer Colors for Connection Drawing – enable this option to display the connection lines using the colors of the start and end layers that the connection line travels between. The connection lines are displayed in pure layer color at the object they start/end at, morphing between those layer colors along the length of the connection line. This feature is helpful when you are routing a multi-layer board as it indicates the target layer that the connection being routed, must go to. Note that color morphing is only applied to connections that travel from one layer to another, if the connection starts and ends on the same layer it retains the assigned net color.
  • Repeated Net Names on Tracks – enable to show repeated net names on tracks.
  • Special Strings – when the option is enabled, any placed Strings that are formed from converted Special Strings will be superimposed (labeled) with the unconverted Special String name. Zoom in on a String to see its label overlay.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: