Altium NEXUS Documentation

ChangeObject

Modified by Tania Mashkoory on Mar 1, 2019

Parent page: Schematic Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: Action=PartToSheetSymbol

Summary

This command is used to convert a part on the current document, to a sheet symbol. This feature is ideal where an existing part has become obsolete and needs to be replaced by a functionally-equivalent sub-circuit, defined on a separate sheet.

Access

This command is accessed from the Schematic Editor by choosing the Tools » Convert » Convert Part To Sheet Symbol command, from the main menus.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select a part. Simply position the cursor over the part that you wish to convert to a sheet symbol and click, or press Enter. The part will be converted to a sheet symbol, with Designator initially set to the part's designator and File Name initially set to the part's comment text. Connectivity is retained, with the sheet entries named as per the original pin naming, and I/O Type set to reflect the original pin electrical type.

Continue to select other parts to convert, or right-click, or press Esc, to exit

Tips

  1. If the required child sheet exists, simply change the sheet symbol's File Name to point to that sheet. If not, a sub-sheet can quickly be created by right-clicking on the sheet symbol and choosing the Sheet Symbol Actions » Create Sheet From Sheet Symbol command. In this latter case, ports corresponding to the symbol's sheet entries will be placed on the new sub-sheet, ready for the replacement sub-circuitry to be defined and hooked up.


Applied Parameters: ContextSensitive=True|Action=PartToSheetSymbol

Summary

This command is used to convert the part that is currently under the cursor on the current document, to a sheet symbol. This feature is ideal where an existing part has become obsolete and needs to be replaced by a functionally-equivalent sub-circuit, defined on a separate sheet.

Access

This command is accessed from the Schematic Editor by right-clicking over the required part and choosing the Part Actions » Convert Part To Sheet Symbol command, from the context menu.

Use

First, ensure that the cursor is positioned over the required component in the main design workspace.

After launching the command, the part will be converted to a sheet symbol, with Designator initially set to the part's designator and File Name initially set to the part's comment text. Connectivity is retained, with the sheet entries named as per the original pin naming, and I/O Type set to reflect the original pin electrical type.

Tips

  1. If the required child sheet exists, simply change the sheet symbol's File Name to point to that sheet. If not, a sub-sheet can quickly be created by right-clicking on the sheet symbol and choosing the Sheet Symbol Actions » Create Sheet From Sheet Symbol command. In this latter case, ports corresponding to the symbol's sheet entries will be placed on the new sub-sheet, ready for the replacement sub-circuitry to be defined and hooked up.


Applied Parameters: Action=PartToPorts

Summary

This command is used to convert a part on the current document, into a set of ports. This feature is ideal for when an existing standalone sub-design, such as a power supply or a satellite board, is to be made into a sub-circuit, to be used within a larger, single board design – perhaps to minimize manufacturing costs. This is the process of plugging a sub-circuit into the higher-level design, making it available for connection to a point above in the hierarchy.

Access

This command is accessed from the Schematic Editor by choosing the Tools » Convert » Convert Part To Ports command, from the main menus.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to choose a component to convert. Simply position the cursor over the part that you wish to convert to ports and click, or press Enter. The component will be converted into a set of standard ports. Connectivity is retained, with the ports named as per the original pin naming, and I/O Type set to reflect the original pin electrical type.

Continue converting further components, or right-click, or press Esc, to exit conversion mode.

Tips

  1. The sub-circuit's insertion into the hierarchy is then completed by adding a sheet symbol on the relevant higher-level parent sheet. This can be done quickly by making that sheet active and using the Create Sheet Symbol From Sheet command.


Applied Parameters: ContextSensitive=True|Action=PartToPorts

Summary

This command is used to convert the part that is currently under the cursor on the current document, into a set of ports. This feature is ideal for when an existing standalone sub-design, such as a power supply or a satellite board, is to be made into a sub-circuit, to be used within a larger, single board design – perhaps to minimize manufacturing costs. This is the process of plugging a sub-circuit into the higher-level design, making it available for connection to a point above in the hierarchy.

Access

This command is accessed from the Schematic Editor by right-clicking over the required part and choosing the Part Actions » Convert Part To Ports command, from the context menu.

Use

First, ensure that the cursor is positioned over the required component in the main design workspace.

After launching the command, the component will be converted into a set of standard ports. Connectivity is retained, with the ports named as per the original pin naming, and I/O Type set to reflect the original pin electrical type.

Tips

  1. The sub-circuit's insertion into the hierarchy is then completed by adding a sheet symbol on the relevant higher-level parent sheet. This can be done quickly by making that sheet active and using the Create Sheet Symbol From Sheet command.


Applied Parameters: Action=PushComponentToSheet

Summary

This command is used to push a part on the current document to a new sub-sheet, replacing the original part with a sheet symbol that references that sheet. This feature is ideal where an existing part has become obsolete and needs to be replaced by a functionally-equivalent sub-circuit, defined on a separate sheet.

Access

This command is accessed from the Schematic Editor by choosing the Tools » Convert » Push Part to Sheet command, from the main menus.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select a part. Simply position the cursor over the part that you wish to push to a new sub-sheet and click, or press Enter. The following sequence of steps are essentially performed:

  1. The part is copied.
  2. The original part is converted to a sheet symbol with Designator set to the designator of the original part, and File Name set to <OriginalPartComment>.SchDoc. Connectivity is retained, with the sheet entries named as per the original pin naming, and I/O Type set to reflect the original pin electrical type.
  3. A new schematic sheet is created from the sheet symbol, named using the symbol's File Name value.
  4. The copy of the original part is pasted at the center of the sheet, with ports corresponding to the sheet symbol's sheet entries placed and wired to the part's pins.

Tips

  1. The copy of the original part - on the new sub-sheet - can then be removed, and replaced with functionally-equivalent circuitry as required.


Applied Parameters: ContextSensitive=True|Action=PushComponentToSheet

Summary

This command is used to push the part that is currently under the cursor on the current document, to a new sub-sheet, replacing the original part with a sheet symbol that references that sheet. This feature is ideal where an existing part has become obsolete and needs to be replaced by a functionally-equivalent sub-circuit, defined on a separate sheet.

Access

This command is accessed from the Schematic Editor by right-clicking over the required part and choosing the Part Actions » Push Part to Sheet command, from the context menu.

Use

First, ensure that the cursor is positioned over the required component in the main design workspace.

After launching the command, the following sequence of steps are essentially performed:

  1. The part is copied.
  2. The original part is converted to a sheet symbol with Designator set to the designator of the original part, and File Name set to <OriginalPartComment>.SchDoc. Connectivity is retained, with the sheet entries named as per the original pin naming, and I/O Type set to reflect the original pin electrical type.
  3. A new schematic sheet is created from the sheet symbol, named using the symbol's File Name value.
  4. The copy of the original part is pasted at the center of the sheet, with ports corresponding to the sheet symbol's sheet entries placed and wired to the part's pins.

Tips

  1. The copy of the original part - on the new sub-sheet - can then be removed, and replaced with functionally-equivalent circuitry as required.


Applied Parameters: ContextSensitive=True|Action=ConfigurePart

Summary

This command is used to access a dialog with which to configure the component under the cursor.

Access

This command is accessed from the Schematic Editor by right-clicking over the required part and choosing the Configure command, from the context menu.

Use

First, ensure that the cursor is positioned over the required component in the main design workspace.

After launching the command, the relevant configuration dialog for that component will appear. Use this dialog to define applicable properties as required.

Tips

  1. Press F1 over the focused dialog to access information about the options and controls available in that specific dialog.


Applied Parameters: Action = BreakPolyline

Summary

This command is used to break a segment of a polyline object (wire, bus, or signal harness) into two pieces at a chosen location on the schematic sheet.

Access

This command is accessed from the Schematic Editor by choosing the Edit » Break Wire command, from the main menus.

Use

After launching the command, the cursor will appear in accordance with settings defined for the Cutter Box, and Extremity Markers, on the Schematic - Break Wire page of the Preferences dialog.

If the cutter box is set to never be displayed, or only be displayed when the cursor passes over a polyline segment, the cutting area will be distinguished in the workspace through use of a central cross marker, while the cursor is away from a wire segment. If both cutter box and extremity markers are set to never display, passing the cursor over a wire segment will cause the relevant portion of that segment, or its entirety, to become highlighted - thus distinguishing the portion of wire that will be cut when clicked.

Position the cursor over the segment of wire, bus, or signal harness that you want to effectively break into two and click, or press Enter. The indicated length of segment will be removed, thereby breaking the segment into two.

Continue breaking further polyline objects, or right-click, or press Esc, to exit.

While in break wire mode, the following additional actions can be performed:

  • Press the Spacebar to cycle through the following cutting length modes:
    • Snap To Segment - in this mode, the cutter will auto-size to snap to an entire polyline segment.
    • Snap Grid Size Multiple - in this mode, the cutter is sized to a defined multiple of the current snap grid.
    • Fixed Length - in this mode, the cutter is sized to a defined fixed length.
  • Press the Tab key to access the Properties panel, from where modifications to the behavior of the cutting tool can be made.

Tips

  1. Regardless of the size of cutter, with options other than Snap To Segment, the cutter will shrink to accommodate smaller-sized wire segments in their entirety - as it passes over them - as though Snap To Segment were selected.
  2. Properties for the cutting tool can be defined from the Properties panel, or on the Schematic - Break Wire page of the Preferences dialog. Values modified at the local document level will be instantly reflected back at the preferences level.
  3. You can also remove selected wire segments (not segments of bus or signal harness objects) with the tap of the Delete key, with auto-junctions also accounted for - allowing you to remove a segment of a wire up to that junction only (and including that junction if only two other wire segments would otherwise remain connected to it). Simply click twice (with a pause in between) on a particular segment of wire to select it, denoted by its end-point editing handes turning red. You can delete multiple segments across different wires, ensure that each is selected (Shift+click twice on each subsequent segment to include it in the overall segment selection).
 


Applied Parameters: ContextSensitive=True|Action = EditVertex

Summary

This command is used to edit the specific vertex currently under the cursor, for the parent polygon/polyline (wire, bus, signal harness, line) object.

Access

This command can be accessed from the Schematic Editor, and Schematic Library Editor:

  • Schematic Editor - right-click over the required vertex of a placed polygon, wire, bus, signal harness, or line object, and choose the Edit <ObjectType> Vertex n command, from the context menu.
  • Schematic Library Editor - right-click over the required vertex of a placed polygon, or line object, and choose the Edit <ObjectType> Vertex n command, from the context menu.

Use

First, position the cursor over the required vertex point for the polygon/polyline object you wish to edit, in the main design workspace.

After launching the command, the Object Properties dialog  will appear (if not visible already), presenting the properties for the parent object. The chosen vertex will be selected ready for editing in the Vertices section of the panel.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.