Naviguer dans un document

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Lorsque vous travaillez sur un document graphique, tel qu'une feuille de schéma, un document PCB ou un document Draftsman, vous pouvez effectuer des zooms et des déplacements panoramiques pour vous concentrer sur une zone précise du document. Les raccourcis de base permettant ces opérations sont les suivants :

  • Ctrl+Mouse Wheel pour effectuer un zoom avant ou arrière
  • Right-Click, Hold&Drag pour déplacer le document

Le menu principal View comprend plusieurs commandes permettant de contrôler l'affichage du document actif.

Utilisez les commandes du menu principal View pour contrôler l'affichage de votre document. L'image du haut présente le menu View de l'éditeur de schémas. L'image du bas présente le menu View de l'éditeur PCB.

Utilisez les commandes du menu principal View pour contrôler l'affichage de votre document. L'image du haut présente le menu View de l'éditeur de schémas. L'image du bas présente le menu View de l'éditeur PCB.

Ces commandes comprennent :

  • Fit Document - afficher toute la surface du document actif.

  • Fit All Objects - afficher tous les objets de conception du document actif.

  • Area - effectuer un zoom avant sur une zone du document actif définie par l'utilisateur.

  • Around Point - redéfinir la zone d'affichage autour d'un point spécifié dans le document actif.

  • Selected Objects - modifier la vue dans l'espace de conception afin que tous les objets sélectionnés soient visibles.

  • Zoom In - agrandir la vue de la conception dans le document actif, par rapport à la position du curseur.

  • Zoom Out - réduire la vue de la conception dans le document actif, par rapport à la position du curseur.

  • Zoom Last - rétablir la vue précédente du document actif.

Vous pouvez également utiliser le raccourci Z pour accéder au menu contextuel contenant les commandes de zoom.

Dans les éditeurs PCB et d'empreintes PCB, ce menu permet d'accéder à la commande Select, qui ouvre la boîte de dialogue Zoom Value (0.001x..4x). Vous pouvez y modifier le facteur de zoom du document actif en indiquant une valeur précise. Saisissez une valeur supérieure à 1 pour effectuer un zoom avant plus important (augmenter le grossissement). Utilisez une valeur inférieure à 1 pour effectuer un zoom arrière plus important (réduire le grossissement).

La boîte de dialogue Zoom Value
La boîte de dialogue Zoom Value

Lorsque vous affichez un document PCB ou d'empreinte PCB en 3D, des commandes, raccourcis et contrôles supplémentaires sont disponibles pour naviguer dans la vue de manière fluide. Consultez la page Contrôle de la vue 3D pour en savoir plus.

Accéder à un point précis d'un document

Les commandes du sous-menu Edit » Jump, accessible depuis les menus principaux des éditeurs de schémas, de symboles schématiques, de PCB ou d'empreintes PCB, permettent d'accéder à un point précis du document actif. Vous pouvez également accéder au menu contextuel Jump en appuyant sur la touche J dans l'espace de conception. Par exemple, vous pouvez accéder aux éléments suivants :

  • les coordonnées d'origine du document :
    • le point d'origine d'une feuille de schéma (qui correspond au coin inférieur gauche) - Origin;

    • l'origine absolue du document PCB - Absolute Origin;

    • l'origine relative du document PCB actif - Current Origin;

    • l'emplacement du point de référence du composant dans le document d'empreinte PCB - Reference;

  • n'importe quel emplacement du document actif, à partir de coordonnées XY définies par l'utilisateur - sélectionnez la commande New Location pour saisir, dans la boîte de dialogue Jump To Location qui s'affiche, les coordonnées X et Y de l'emplacement de l'espace de conception auquel vous souhaitez déplacer le curseur. Dans l'éditeur PCB, vous pouvez également utiliser les champs Delta X et Delta Y pour spécifier les décalages en X et en Y de l'emplacement auquel vous souhaitez accéder.

    La boîte de dialogue Jump To Location - dans l'éditeur de schémas (première image) et dans l'éditeur PCB (deuxième image)
    La boîte de dialogue Jump To Location - dans l'éditeur de schémas (première image) et dans l'éditeur PCB (deuxième image)

  • un objet du document. Utilisez les commandes suivantes pour accéder à l'objet souhaité :
    • un composant sur la feuille de schéma - Jump Component. Après l'exécution de la commande, la boîte de dialogue Component Designator s'affiche. Saisissez le repère du composant auquel vous souhaitez accéder. Si le repère est valide et que le composant existe dans un document schématique source du projet actif, le document schématique concerné devient le document actif, et la vue est agrandie et centrée sur le composant cible (dans la mesure du possible) dans l'espace de conception. Le composant trouvé (ou toutes les parties d'un composant à plusieurs parties) est également répertorié dans le panneau Messages . Double-cliquez sur une entrée de message pour accéder à ce composant (ou à l'une de ses parties) dans l'espace de conception.

      La boîte de dialogue Component Designator
      La boîte de dialogue Component Designator

      Lorsque vous recherchez un composant à plusieurs parties, saisissez uniquement le repère de base, sans le suffixe de la partie. Par exemple, pour accéder à un circuit intégré à deux parties dont les repères sont IC1_CPA et IC1_CPB, saisissez IC1_CP dans la boîte de dialogue Component Designator. Pour un composant à plusieurs parties, la première partie est mise en surbrillance et la boîte de dialogue Find Text - Jump s'ouvre. Utilisez cette boîte de dialogue pour passer d'une partie du composant à une autre.
      Activez l'option Physical dans la boîte de dialogue Component Designator pour limiter la fonction de navigation aux seuls repères physiques des composants, c'est-à-dire ceux qui apparaissent dans les vues à onglets Compiled Document des documents schématiques sources. Lorsque cette option est désactivée, la fonction de navigation prend uniquement en compte les repères logiques, c'est-à-dire ceux qui apparaissent dans les vues à onglets Editor des documents schématiques sources.
    • un composant précis dans le document PCB - Component. Après l'exécution de la commande, la boîte de dialogue Component Designator s'affiche. Saisissez le repère du composant pour y accéder. Si vous ne connaissez pas son repère, saisissez ? et cliquez sur OK pour ouvrir la boîte de dialogue Components Placed, qui répertorie tous les composants de la conception. Saisissez du texte dans le champ Mask pour rechercher le composant souhaité. Au fur et à mesure de la saisie, la liste est filtrée pour n'afficher que les chaînes correspondant au masque de recherche. Vous pouvez utiliser les caractères génériques ? (un caractère quelconque) et * (une suite quelconque de caractères) dans la chaîne. Le curseur se déplace vers le point de référence du composant sélectionné.

      Saisissez ? dans la boîte de dialogue Component Designator pour accéder à la boîte de dialogue Components Placed, qui répertorie tous les composants du PCB.
      Saisissez ? dans la boîte de dialogue Component Designator pour accéder à la boîte de dialogue Components Placed, qui répertorie tous les composants du PCB.

    • un net précis dans le document PCB - Net. Après l'exécution de la commande, la boîte de dialogue Net Name s'affiche. Saisissez le nom du net auquel vous souhaitez accéder, ou saisissez ? et appuyez sur OK pour ouvrir la boîte de dialogue Nets Loaded, qui contient la liste de tous les nets chargés pour la conception. Saisissez du texte dans le champ Mask pour rechercher le net souhaité. Au fur et à mesure de la saisie, la liste est filtrée pour n'afficher que les chaînes correspondant au masque de recherche. Vous pouvez utiliser les caractères génériques ? (un caractère quelconque) et * (une suite quelconque de caractères) dans le masque de recherche. Si le net cible est déjà affiché dans la fenêtre principale de conception, le curseur se déplace vers l'objet de conception le plus proche appartenant à ce net. Si le net n'est pas visible, le curseur est positionné sur l'objet de conception le plus proche appartenant à ce net, et la vue est centrée sur cet objet dans l'espace de conception (dans la mesure du possible).

      Saisissez ? dans la boîte de dialogue Net Name pour accéder à la boîte de dialogue Nets Loaded, qui répertorie tous les nets du PCB.Saisissez ? dans la boîte de dialogue Net Name pour accéder à la boîte de dialogue Nets Loaded, qui répertorie tous les nets du PCB.

    • une pastille spécifique d’un composant dans le document PCB - Pad. Après le lancement de la commande, la boîte de dialogue Jump To Pad Number apparaît. Saisissez la pastille requise du composant souhaité sous la forme ComponentDesignator-PadDesignator (par exemple, U1-6), puis cliquez sur OK. Si la pastille cible est déjà affichée dans l’espace de conception, le curseur se déplace simplement au centre de cette pastille. Si la pastille n’est pas visible, le curseur est placé au centre de la pastille, elle-même centrée dans l’espace de conception (dans la mesure du possible).

      La boîte de dialogue Jump To Pad Number
      La boîte de dialogue Jump To Pad Number

    • une chaîne de caractères spécifique dans le document PCB - String. Après le lancement de la commande, la boîte de dialogue Jump To String apparaît. Saisissez la chaîne de caractères à laquelle vous souhaitez accéder, ou saisissez ? et cliquez sur OK pour ouvrir la boîte de dialogue Strings, qui contient une liste de toutes les chaînes de caractères présentes dans le document PCB actif (indépendantes ou appartenant à d’autres objets de groupe). Utilisez cette boîte de dialogue pour trouver rapidement la chaîne de caractères à laquelle vous souhaitez accéder. Si la chaîne cible est déjà affichée dans l’espace de conception, le curseur se déplace simplement vers son point d’ancrage, c’est-à-dire le point par lequel elle est saisie lors d’un déplacement ou autour duquel elle pivote. Si la chaîne n’est pas visible, le curseur est placé sur son point d’ancrage, centré dans l’espace de conception (dans la mesure du possible).

      Saisissez ? dans la boîte de dialogue Jump To String pour accéder à la boîte de dialogue Strings, qui répertorie tous les nets du PCB.
      Saisissez ? dans la boîte de dialogue Jump To String pour accéder à la boîte de dialogue Strings, qui répertorie tous les nets du PCB.

      Le système effectue trois recherches : d’abord une chaîne correspondant exactement à la chaîne spécifiée en termes de casse, de caractères et de longueur ; ensuite une chaîne contenant les mêmes caractères, mais éventuellement des caractères supplémentaires ; et enfin une chaîne contenant les mêmes caractères, sans tenir compte de la casse.

    • accéder successivement à tous les marqueurs d’erreur du document de conception actif - Error Marker. Après le lancement de la commande, le curseur se déplace vers le premier marqueur d’erreur de vérification des règles de conception (DRC), centré dans la fenêtre principale de conception. Chaque nouvelle utilisation de la commande permet d’accéder au marqueur d’erreur suivant, et ainsi de suite. Cette commande permet d’accéder à un marqueur d’erreur, que la violation fasse ou non l’objet d’une dérogation.

      Consultez les violations associées à l’objet sous le curseur en cliquant avec le bouton droit de la souris et en choisissant la commande appropriée dans le sous-menu Violations .

  • accéder successivement à tous les objets de conception sélectionnés dans le document actif - Selection. Après le lancement de la commande, le curseur se déplace vers le premier objet sélectionné, sur lequel la vue est zoomée et centrée dans la fenêtre principale de conception. Chaque nouvelle utilisation de la commande permet d’accéder à l’objet sélectionné suivant, et ainsi de suite, en parcourant tous les objets sélectionnés dans le document actif. La commande parcourt les objets sélectionnés dans l’ordre dans lequel ils ont été initialement ajoutés à la sélection.

  • une position dans le document schématique ou PCB actif, dont les coordonnées ont été préalablement enregistrées dans le repère de position indiqué - sélectionnez la commande Location Marks » n pour accéder à la position enregistrée dans le repère de position indiqué à l’aide de la commande Set Location Marks » n.

    Dans un document schématique, une position enregistrée n’est disponible que tant que le document reste ouvert (qu’il soit actif ou non). Si le document est fermé puis rouvert, le repère de position sera vide. Dans un document PCB, les repères de position sont enregistrés avec la conception, ce qui permet de retrouver les positions définies par l’utilisateur d’une session de conception à l’autre.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.