Partager une conception

La collaboration consiste avant tout à travailler à plusieurs pour atteindre un objectif commun. Un facteur essentiel est donc la possibilité de fournir et de gérer l’accès à cet élément commun, en l’occurrence un projet de conception et ses données associées. Le Workspace offre cette possibilité grâce au partage contrôlé, fondé sur des autorisations, d’une conception de projet dans son état actuel, en cours de réalisation (WIP), ou sous la forme d’un instantané figé de la conception à un moment donné.

Notez qu’un projet nouvellement créé ou mis à disposition dans le Workspace est partagé par défaut avec les personnes suivantes :

  • Le propriétaire du projet, généralement le concepteur qui l’a créé (ou mis à disposition dans le Workspace) : avec des autorisations d’accès complètes (lecture/écriture).

  • Le rôle Administrators : avec des autorisations d’accès complètes (lecture/écriture).

Les niveaux de partage suivants sont pris en charge depuis Altium Designer :

  • Sharing of a live design – la conception en cours de réalisation (WIP) elle-même, qui peut être partagée :
    • Avec d’autres membres de votre équipe Workspace, pour modification et/ou consultation. Un membre invité de l’équipe peut consulter la conception dans Altium Designer ou dans le Workspace de l’équipe. Les modifications s’effectuent uniquement dans Altium Designer. Le membre invité doit être inscrit sur AltiumLive et disposer d’un abonnement actif pour sa licence Altium Designer.
    • Avec des personnes extérieures à votre équipe Workspace, pour consultation ou modification, sur invitation par e-mail. Cette fonctionnalité est disponible uniquement lorsque vous êtes connecté à un Workspace Altium 365. Ce type de partage permet aux parties prenantes invitées de consulter/modifier (selon les autorisations accordées) un projet de conception en cours de réalisation, sans accéder à l’ensemble de votre Workspace ou de vos données de conception. La personne invitée doit être inscrite sur AltiumLive et peut accéder à la conception partagée depuis son espace personnel Altium 365 (ou le Workspace de son organisation, le cas échéant), ou l’ouvrir dans Altium Designer.

    Si elle dispose uniquement d’un accès en consultation, la partie prenante invitée peut consulter et commenter la conception depuis Altium Designer ou depuis l’interface de son Workspace Altium 365. À mesure que les personnes disposant de droits de modification apportent des changements à la conception et les valident, ces changements sont visibles « en direct » par les personnes externes. Pour consulter la conception partagée depuis l’interface du navigateur, où que vous soyez, une simple inscription sur AltiumLive suffit.

    Si la partie prenante invitée dispose de droits de modification sur la conception, elle peut l’ouvrir et la modifier dans Altium Designer, ce qui est idéal pour les prestataires externes.

    Notez que le partage de conceptions WIP en direct avec des personnes extérieures à votre équipe Workspace est possible lorsque vous êtes connecté à un Workspace Altium 365, mais pas lorsque vous utilisez un Workspace Enterprise Server. Vous pouvez toutefois partager un instantané de conception avec une personne extérieure à votre équipe Workspace, pour consultation et téléchargement (voir ci-dessous).

    Altium Designer propose des fonctionnalités supplémentaires qui complètent la collaboration autour des conceptions via le partage de projets dans le Workspace, notamment les commentaires sur les documents et la prévention des conflits entre collaborateurs.

    Lorsque vous êtes connecté à un Workspace Altium 365 mis à jour vers le nouveau système d’héritage des autorisations (en savoir plus), notez qu’il n’est pas impossible de réduire ou de supprimer les autorisations d’un projet si celles-ci sont héritées du dossier parent. Lorsque vous tentez de le faire, un message d’erreur s’affiche (). L’option Inherit permissions from parent du projet doit être désactivée dans l’interface Web du Workspace pour rompre délibérément l’héritage des autorisations du dossier parent.

  • Sharing of a design 'snapshot' – un instantané statique de la conception à un moment donné, partagé :
    • Par lien, accessible à toute personne via un navigateur. À ce niveau, l’accès à la conception partagée ne nécessite ni abonnement actif pour votre licence Altium Designer ni inscription sur AltiumLive. Le destinataire du lien partagé ouvre la visionneuse autonome Altium 365 pour consulter la conception (sans pouvoir la commenter). La consultation ne nécessite aucune inscription sur AltiumLive et le lien reste disponible pendant 48 heures.

    • Avec des personnes spécifiques, sur invitation par e-mail. À ce niveau, l’accès à la conception partagée nécessite une inscription sur AltiumLive, mais pas d’abonnement actif pour la licence Altium Designer. Depuis son invitation par e-mail, le destinataire accède à l’instantané de conception dans la visionneuse Web de l’interface Workspace de la plateforme Altium 365. La consultation nécessite une inscription sur AltiumLive, mais l’instantané reste disponible en permanence. Il est également possible de commenter la conception.

    Notez qu’un instantané de conception partagé de cette manière est essentiellement en lecture seule. Il peut être téléchargé ou consulté dans un Workspace Altium 365, mais contrairement à une conception WIP partagée, il ne peut pas être ouvert dans Altium Designer pour consultation ou modification.

    Si le destinataire d’une conception (ou d’un instantané de conception) partagée via la plateforme Altium 365 ne possède pas de compte AltiumLive, il devra d’abord en créer un. Un lien est fourni sur la page Altium 365 Sign In.

Pour les projets Altium 365, la création et la gestion d’instances de revue de conception sont prises en charge. Ces instances peuvent être consultées dans Altium Designer – en savoir plus.  

Accéder aux commandes de partage

Les commandes permettant de partager une conception depuis Altium Designer se trouvent dans la boîte de dialogue Share, accessible des manières suivantes :

  • Pour le projet actif : en cliquant sur le bouton en haut à droite de la fenêtre principale de l’application, ou en choisissant la commande Project » Share dans les menus principaux.
  • Pour le projet sélectionné dans le panneau Projects : en cliquant avec le bouton droit sur l’entrée du projet, puis en choisissant la commande Share dans le menu contextuel.
  • Lorsque vous commentez un document de conception, en publiant un commentaire mentionnant un utilisateur qui n’a pas accès au projet actuel.

Si aucun projet n’est actif, c’est-à-dire si aucun document de projet n’est ouvert, le bouton agit sur le projet actuellement sélectionné dans le panneau Projects.

Accès à la boîte de dialogue Share, le centre de commande du partage d’une conception depuis Altium Designer.
Accès à la boîte de dialogue Share, le centre de commande du partage d’une conception depuis Altium Designer.

Partage d’une conception en cours

Lorsqu’un projet de conception est enregistré dans un espace de travail Altium 365 (mis à sa disposition), vous pouvez le partager avec d’autres personnes. Il peut s’agir d’autres membres de l’équipe de votre espace de travail ou de personnes extérieures à l’équipe. Pour effectuer ce type de partage, cliquez sur l’entrée dans la partie gauche de la boîte de dialogue Share.

Les administrateurs de l’équipe de l’espace de travail peuvent toujours partager un projet avec d’autres personnes pour modification ou consultation. Les membres non administrateurs de l’équipe de l’espace de travail, ou les utilisateurs extérieurs à l’équipe avec lesquels un projet a été partagé, peuvent partager ce projet avec d’autres personnes pour modification ou consultation, selon leur propre niveau d’accès. Ainsi, s’ils disposent de droits de modification, ils peuvent le partager avec d’autres personnes pour modification ou consultation. S’ils disposent uniquement de droits de consultation, ils ne peuvent le partager avec d’autres utilisateurs que pour consultation et ajout de commentaires.

Accès aux commandes permettant de partager une conception en cours avec d’autres personnes. Notez que l’image illustre le cas d’un projet déjà disponible dans un espace de travail connecté.Accès aux commandes permettant de partager une conception en cours avec d’autres personnes. Notez que l’image illustre le cas d’un projet déjà disponible dans un espace de travail connecté.

Utilisez la commande Copy Link pour copier un lien direct vers le projet. Les personnes qui disposent déjà d’un accès au projet peuvent utiliser ce lien pour l’ouvrir dans le Web Viewer de l’espace de travail.

Partage avec de nouvelles personnes

Une fois la préparation terminée, le projet sélectionné et la connexion à l’espace de travail cible établie, vous pouvez préciser avec quelle personne (ou quelles personnes) partager le projet. Pour vérifier qui a déjà accès au projet, cliquez sur la commande Shared with. La zone se développe pour afficher les personnes avec lesquelles le projet est partagé et indiquer si elles disposent de droits de modification (Can Edit) ou si elles peuvent uniquement consulter le projet et y ajouter des commentaires (Can View).

Vérifiez avec qui le projet est actuellement partagé en cliquant sur le champ Share with. Survolez l’image pour voir le résultat.
Vérifiez avec qui le projet est actuellement partagé en cliquant sur le champ Share with. Survolez l’image pour voir le résultat.

Vous pouvez partager le projet avec n’importe qui : d’autres utilisateurs AltiumLive de votre organisation, des utilisateurs AltiumLive d’autres organisations et des personnes qui n’utilisent pas AltiumLive (qui devront alors créer un compte AltiumLive). Notez que lorsque vous êtes connecté à un espace de travail Enterprise Server, vous ne pouvez partager le projet en cours qu’avec les utilisateurs inscrits de cet espace de travail. Pour un partage externe, consultez la section Partage d’un instantané de conception ou la méthode de partage disponible dans votre espace personnel Altium 365.

Pour ajouter une entrée, commencez à saisir le nom, l’adresse e-mail ou le rôle souhaité dans le champ, puis sélectionnez l’utilisateur ou le rôle correspondant dans la liste dynamique. Celle-ci ne contient que les utilisateurs filtrés de l’équipe de votre espace de travail ou de votre organisation, ainsi que les rôles existants définis pour l’espace de travail. Vous pouvez sélectionner plusieurs utilisateurs ou rôles. Pour supprimer un utilisateur ou un rôle saisi, cliquez sur la commande associée à l’entrée.

Pour partager le projet avec une personne extérieure à votre organisation, qu’elle dispose ou non d’un compte AltiumLive, vous devez saisir son adresse e-mail complète et appuyer sur Enter.

Définissez les autorisations d’accès des personnes ou rôles ajoutés dans le menu déroulant associé en sélectionnant Can View () ou Can Edit (), cette dernière option incluant également la possibilité de consulter le projet. Ce paramètre s’applique initialement à toutes les entrées (personnes ou rôles) figurant dans le champ. Utilisez le champ de note facultatif pour ajouter des informations relatives aux modalités de partage de ce projet.

Les administrateurs de l’équipe de l’espace de travail peuvent toujours partager un projet avec d’autres personnes pour modification ou consultation. Les membres non administrateurs de l’équipe de l’espace de travail peuvent partager un projet avec d’autres personnes pour modification ou consultation, selon leur propre niveau d’accès.

Seuls les utilisateurs avec lesquels le projet est partagé et qui disposent des autorisations Edit peuvent le repartager avec d’autres personnes. Tous les utilisateurs avec lesquels le projet est partagé et qui disposent des droits Edit peuvent télécharger les fichiers de conception du projet. Des autorisations de partage supplémentaires sont disponibles pour les administrateurs et le propriétaire du projet dans la boîte de dialogue Share. Utilisez Advanced Settings options permettant de définir les droits de repartage et de téléchargement des utilisateurs avec lesquels la conception doit être partagée.

Les options supplémentaires de partage et de téléchargement sont regroupées comme suit :

  • Member Rights – pour les membres de l’espace de travail :

    • Editors can share – autoriser les membres de l’espace de travail disposant de droits Edit sur la conception partagée à la repartager avec d’autres personnes.

    • Viewers can download – autoriser les membres de l’espace de travail disposant de droits View sur la conception partagée à télécharger les fichiers de conception.

  • Guest and External Share Rights – pour les utilisateurs invités externes avec lesquels des projets ont été partagés :

    • Editors can share – autoriser les personnes qui ne sont pas membres de l’espace de travail et qui disposent de droits Edit sur la conception partagée à la repartager avec d’autres personnes.

    • Viewers can download – autoriser les personnes qui ne sont pas membres de l’espace de travail et qui disposent de droits View sur le projet partagé à télécharger les fichiers de conception.

Pour confirmer les modifications apportées aux paramètres avancés, cliquez sur le bouton  dans la boîte de dialogue principale Share.

Une fois les destinataires définis et les droits d’accès spécifiés, cliquez sur le bouton pour partager le projet. La boîte de dialogue affiche un message confirmant que le projet a bien été partagé. Vous pouvez alors cliquer sur la commande Who has access pour revenir à la liste des utilisateurs ayant accès au projet, cliquer sur le bouton  pour copier le lien direct vers le projet, ou simplement fermer la boîte de dialogue en cliquant sur OK.

Partage avec une personne extérieure à l’équipe

Lorsque vous êtes connecté à un espace de travail Enterprise Server, une conception en cours de développement (WIP) ne peut pas être partagée avec des personnes qui ne sont pas des utilisateurs enregistrés de cet espace de travail (personnes extérieures à l’équipe). Pour un partage externe depuis un espace de travail Enterprise Server, consultez Partage d’un instantané de conception ou la méthode de partage par téléversement disponible dans votre espace personnel Altium 365.

Si vous tentez de partager un projet d’un espace de travail Altium 365 avec une personne extérieure à l’équipe, la boîte de dialogue Confirm s’affiche pour vous avertir que l’utilisateur aura accès aux documents sources du projet partagé, aux commentaires ajoutés et aux packages de publication. Cliquez sur OK pour poursuivre le partage du projet.

Vous pouvez partager un projet avec toute personne extérieure à l’équipe de l’espace de travail, pour modification ou consultation.Vous pouvez partager un projet avec toute personne extérieure à l’équipe de l’espace de travail, pour modification ou consultation.

Le partage pour modification avec un utilisateur extérieur à l’équipe de l’espace de travail est idéal pour les sous-traitants : vous leur permettez ainsi de travailler activement sur la conception sans les intégrer à votre équipe.

Partage d’un projet local

Si vous partagez un projet local (qui n’est pas géré par un VCS externe), celui-ci sera rendu disponible dans l’espace de travail auquel vous êtes connecté au moment du partage avec les personnes désignées. Le déroulement dépend du type de partage : pour consultation ou pour modification.

  • Partage pour consultation uniquement (avec une connexion à un espace de travail Altium 365) : le projet est rendu disponible via Simple Sync. Dans ce mode, le projet de conception ne peut être modifié que par une seule personne (son propriétaire). Simple Sync est particulièrement utile lorsque vous ne souhaitez pas que d’autres personnes modifient votre conception, mais que vous voulez profiter du modèle Global Sharing d’Altium 365 et partager cette conception avec plusieurs autres personnes pour consultation et commentaires. Pour plus d’informations sur cette fonctionnalité, consultez Mise en miroir d’un projet dans l’espace de travail à l’aide de Simple Sync.
  • Partage pour modification : le projet doit être ajouté au dépôt de conception Git Versioned Storage de l’espace de travail. Dans ce mode, le projet peut être partagé avec plusieurs personnes pour modification, tout en permettant d’utiliser la prise en charge du partage global d’Altium 365 pour la consultation et les commentaires. Une boîte de dialogue vous en informe et vous propose l’option Use Altium 365 VCS pour effectuer cette opération. Cliquez sur Learn More pour accéder à la page Partage, qui vous guidera dans le partage du projet.

Lors du partage d’un projet local (non géré par un VCS) avec une personne pour modification, le projet doit être placé sous contrôle de version en étant ajouté au dépôt de conception Git Versioned Storage de l’espace de travail.Lors du partage d’un projet local (non géré par un VCS) avec une personne pour modification, le projet doit être placé sous contrôle de version en étant ajouté au dépôt de conception Git Versioned Storage de l’espace de travail.

Si le projet local est déjà sous contrôle de version (dans un dépôt de conception externe), il restera dans le dépôt de conception VCS externe et ne sera pas ajouté au dépôt de conception VCS (Git) intégré à l’espace de travail. Dans ce cas, Simple Sync (mise en miroir) s’applique, mais plusieurs collaborateurs peuvent bien entendu continuer à travailler sur la conception et à la modifier, puisqu’elle est sous contrôle de version.

Toutefois, pour bénéficier de l’ensemble des fonctionnalités offertes par la plateforme Altium 365 — ou, plus précisément, par un espace de travail Altium 365 — votre projet doit être entièrement stocké dans le VCS natif de l’espace de travail (au sein de son dépôt Git Versioned Storage). Vous pouvez migrer votre projet du système VCS externe vers le système VCS natif de l’espace de travail à l’aide de la fonctionnalité de migration de dépôt VCS intégrée à Altium Designer.

► Pour plus d’informations à ce sujet, consultez Passage d’un VCS externe au VCS natif de l’espace de travail.

  • Lorsque vous êtes connecté à un espace de travail Enterprise Server, un projet local à partager avec un autre utilisateur de l’espace de travail est automatiquement ajouté au VCS de l’espace de travail. Le projet, désormais hébergé dans l’espace de travail, sera partagé avec l’utilisateur spécifié avec des droits de consultation ou de modification, selon le choix effectué dans la boîte de dialogue Share.
  • Notez qu’un espace de travail Enterprise Server ne peut pas partager un projet en cours de développement (WIP) avec une personne extérieure à l’équipe de l’espace de travail, c’est-à-dire qui n’est pas un utilisateur enregistré de celui-ci.

Résultat du partage

La suite dépend du type d’utilisateur invité :

  • Un utilisateur qui fait déjà partie de l’équipe de votre espace de travail sera directement ajouté à la liste des personnes ayant accès au projet et recevra un e-mail l’informant que le projet a été partagé avec lui. Il pourra ouvrir le projet dans Altium Designer ou y accéder via l’interface de l’espace de travail (depuis la page Projects ).
  • Lorsqu’un rôle existant de l’espace de travail est ajouté, il apparaît dans la liste d’accès au projet et tous les membres de ce rôle reçoivent un e-mail les informant que le projet a été partagé avec eux. Ils peuvent ouvrir le projet dans Altium Designer ou y accéder via l’interface de l’espace de travail (depuis la page Projects ).
  • Lorsque vous utilisez un espace de travail Altium 365 pour partager un projet avec une personne extérieure à l’équipe de votre espace de travail, celle-ci est ajoutée à la liste de partage et reçoit un e-mail l’informant que le projet a été partagé avec elle. Elle peut ouvrir le projet dans Altium Designer à l’aide de l’option Partagés avec moi, ou y accéder via l’interface de son espace personnel sur la plateforme Altium 365 (depuis la page Shared with Me ). L’e-mail reçu permet d’accéder directement à la conception via Altium 365. Après avoir cliqué sur le bouton dans l’e-mail, elle est redirigée vers la page Altium 365 Sign In (sauf si elle est déjà connectée à la plateforme ou à son compte AltiumLive). Une fois connectée, elle accède directement à la visionneuse Web, dans laquelle la conception partagée est chargée.

    Vous ne pouvez pas partager une conception en cours de développement (WIP) avec des personnes extérieures à l’équipe (utilisateurs externes) lorsque vous êtes connecté à un espace de travail Enterprise Server. Toutefois :

Si la personne ne possède pas de compte AltiumLive, elle devra d’abord en créer un. Un lien est fourni sur la page Altium 365 Sign In.

Accès à une conception partagée en direct depuis l’invitation par e-mail reçue par un utilisateur qui n’est pas membre de l’équipe de l’espace de travail.
Accès à une conception partagée en direct depuis l’invitation par e-mail reçue par un utilisateur qui n’est pas membre de l’équipe de l’espace de travail.

Modification des droits d’accès des personnes existantes

À tout moment, un administrateur (ou un membre de l’équipe de l’espace de travail disposant de droits de modification) peut modifier les autorisations d’accès existantes pour un projet. Pour accéder à la liste des personnes et des rôles avec lesquels un projet est déjà partagé, cliquez sur l’entrée à gauche de la boîte de dialogue Share , puis développez le champ Shared with à droite.

Accès à la liste des personnes et des rôles disposant actuellement d’un accès partagé au projet.Accès à la liste des personnes et des rôles disposant actuellement d’un accès partagé au projet.

Points à prendre en compte :

  • En matière d’autorisations, une personne ou un rôle dispose d’un accès complet en modification au projet lorsque l’option Can Edit () est sélectionnée. Dans le cas contraire, l’accès est en lecture seule ().
  • Le Owner et le rôle Administrators disposent toujours d’un accès complet en modification (Can Edit).
  • À l’exception du Owner et du rôle Administrators, les autorisations de toutes les personnes et de tous les rôles inclus peuvent être définies individuellement sur Can View ou Can Edit, ou leurs droits d’accès peuvent être entièrement supprimés. La propriété du projet peut également être transférée à un autre utilisateur (voir ci-dessous). Cliquez sur l’autorisation actuelle pour accéder aux commandes.

  • Un projet peut être partagé explicitement avec des personnes et/ou des rôles spécifiques, ou simplement avec tous les membres de l’équipe de l’espace de travail. Dans ce dernier cas, définissez l’accès requis pour l’entrée Workspace Members . Pour ne pas partager le projet avec toute l’équipe, définissez cette entrée sur None.

Modifiez les autorisations d’accès selon vos besoins. Chaque entité modifiée est mise en évidence dans la liste par un arrière-plan plus sombre.

Exemple de modification des autorisations de deux personnes existantes avec lesquelles un projet est actuellement partagé.Exemple de modification des autorisations de deux personnes existantes avec lesquelles un projet est actuellement partagé.

Pour appliquer les modifications, cliquez sur le bouton . Les modifications sont appliquées et une confirmation s’affiche dans la boîte de dialogue. Pour consulter la liste actualisée des accès partagés, cliquez sur le lien Who has access.

Après avoir enregistré les modifications des autorisations, vous pouvez consulter le résultat actualisé directement dans la boîte de dialogue Share.Après avoir enregistré les modifications des autorisations, vous pouvez consulter le résultat actualisé directement dans la boîte de dialogue Share.

  • Notez que le partage d’un projet avec un autre utilisateur peut être révoqué à tout moment en choisissant l’option Remove pour cet utilisateur dans la boîte de dialogue Share.
  • Notez également que si vous définissez les autorisations sur Can Edit pour une personne extérieure à l’équipe de l’espace de travail Altium 365, une alerte s’affiche dans la boîte de dialogue Sharing Outside of the Workspace pour vous demander de confirmer si vous souhaitez lui accorder des droits de lecture seule ou de modification.

Transfert de la propriété du projet

Les administrateurs et les propriétaires peuvent transférer la propriété à un autre utilisateur à l’aide de l’option Owner  du menu déroulant de l’autorisation actuelle. Cette option peut être utilisée par le propriétaire actuel du projet ou par un administrateur de l’espace de travail.

La propriété ne peut être transférée qu’à un autre membre de l’espace de travail. Le transfert à un utilisateur extérieur à l’espace de travail n’est pas possible.

Lorsque vous sélectionnez l’option Owner pour un utilisateur, la boîte de dialogue Transfer Ownership s’ouvre. Cliquez sur Yes pour effectuer le transfert.

Les modifications des autorisations du propriétaire actuel et du nouveau propriétaire s’affichent dans la boîte de dialogue. Cliquez sur Save pour appliquer les modifications.

Lors du transfert, les droits d’accès du propriétaire actuel sont attribués comme suit :

  • Des droits de modification lui sont attribués si le projet est sous contrôle de version.
  • Des droits de lecture lui sont attribués si le projet utilise SimpleSync.

L’utilisateur auquel la propriété est transférée reçoit une notification par e-mail.

Accès à une conception partagée en direct

L’accès à un projet partagé avec un utilisateur dépend de son appartenance ou non à l’équipe de l’espace de travail.

Membre de l’équipe de l’espace de travail

Un membre de l’équipe de l’espace de travail peut accéder au projet partagé depuis Altium Designer ou depuis la page Projects de l’interface de l’espace de travail. Notez que la modification du projet, si l’utilisateur dispose des droits correspondants, n’est possible que dans Altium Designer.

Dans Altium Designer, accédez au projet à l’aide de la commande File » Open Project ou du bouton à points de suspension associé à l’entrée de l’espace de travail dans le panneau Projets. La boîte de dialogue Ouvrir un projet s’affiche. Vous pouvez y choisir le projet à ouvrir dans l’espace de travail auquel vous êtes connecté. Lorsque vous êtes connecté à un espace de travail, celui-ci apparaît dans la zone Locations de la boîte de dialogue, avec l’icône et le nom qui lui a été attribué. Seuls les projets de l’espace de travail qui ont été partagés avec vous et auxquels vous êtes autorisé à accéder sont répertoriés.

Une fois ouvert, le projet apparaît sous une entrée correspondant à l’espace de travail dans le panneau Projets.

Depuis Altium Designer, choisissez le projet à ouvrir dans l’espace de travail auquel vous êtes connecté, parmi ceux actuellement partagés avec vous. Depuis Altium Designer, choisissez le projet à ouvrir dans l’espace de travail auquel vous êtes connecté, parmi ceux actuellement partagés avec vous.

Vous pouvez ouvrir le projet dans le chemin d’extraction par défaut ou utiliser le menu déroulant pour spécifier un chemin personnalisé. Le chemin d’extraction par défaut provient du champ Document Path de la page Système – Emplacements par défaut de la boîte de dialogue Preferences.
Lorsque vous parcourez le projet dans le panneau Explorateur d’Altium Designer, configuré dans son mode Project View par défaut plutôt que dans le mode Classic View, cliquez sur le bouton , en haut à droite du panneau, pour ouvrir le projet dans Altium Designer et l’ajouter au panneau Projects. Utilisez le bouton pour ouvrir le projet et le consulter dans l’interface Web de l’espace de travail connecté.

Partie prenante invitée extérieure à l’équipe de l’espace de travail

Une personne extérieure à l’équipe de l’espace de travail Altium 365 avec laquelle le projet a été partagé peut y accéder depuis Altium Designer ou depuis l’interface de la plateforme Altium 365 (sur la page Partagés avec moi). Pour ouvrir le projet, sélectionnez la vignette de la conception et cliquez sur le nom du projet, ou choisissez l’option Open dans le menu à points de suspension de la vignette. Vous pouvez également double-cliquer directement sur la vignette. Notez que la modification du projet, si l’utilisateur dispose des droits correspondants, n’est possible que dans Altium Designer.

Une conception de projet en cours (WIP) ne peut pas être partagée en dehors de l’équipe (avec des utilisateurs externes) lors de l’utilisation d’un espace de travail Enterprise Server.

Toutefois, si vous êtes le destinataire d’une conception partagée par un membre d’un espace de travail Altium 365, elle sera disponible dans Altium Designer à l’emplacement Shared with Me, comme décrit ci-dessous, et pourra également être consultée dans votre espace personnel.

Dans Altium Designer, accédez au projet à l’aide de la commande File » Open Project. La boîte de dialogue Ouvrir un projet s’affiche et vous permet de choisir le projet de l’espace de travail à ouvrir depuis l’emplacement Shared With Me.

Une fois ouvert, le projet apparaît sous l’entrée Shared with me, dans le panneau Projets. Les actions possibles sur le projet dépendent des droits d’accès qui vous ont été accordés. Si vous disposez de droits de modification, vous pouvez modifier la conception normalement, ce qui est généralement le cas pour un prestataire externe. La conception étant partagée depuis un espace de travail, les modifications sont synchronisées dans les deux sens. Si vous ne disposez que de droits de consultation, vous pouvez néanmoins commenter la conception en cours.

Depuis Altium Designer, choisissez le projet de l’espace de travail à ouvrir parmi ceux qui sont actuellement partagés avec vous en tant qu’intervenant externe. Notez que vous pouvez accéder à ces projets sans avoir accès à l’espace de travail.Depuis Altium Designer, choisissez le projet de l’espace de travail à ouvrir parmi ceux qui sont actuellement partagés avec vous en tant qu’intervenant externe. Notez que vous pouvez accéder à ces projets sans avoir accès à l’espace de travail.

Vous pouvez ouvrir le projet dans le dossier d’extraction par défaut ou utiliser le menu déroulant pour spécifier un chemin personnalisé. Le chemin d’extraction par défaut est défini dans le champ Document Path de la page Système – Emplacements par défaut de la boîte de dialogue Preferences.

Partage d’un instantané de conception

La création d’un instantané en lecture seule d’une conception permet de la partager rapidement, à un moment précis du développement du projet, afin de collaborer plus largement avec d’autres personnes sur le Web. Cela peut être utile pour une revue de conception improvisée, pour partager un jalon particulier de la conception ou encore pour susciter une discussion en contexte. Pour effectuer ce type de partage, cliquez sur l’entrée , à gauche de la boîte de dialogue Share.

Accès aux commandes de partage d’un instantané de conception.Accès aux commandes de partage d’un instantané de conception.

Tout utilisateur qui consulte un projet dans Altium Designer peut partager un instantané de cette conception.

Partage par lien

Par défaut, la boîte de dialogue est configurée sur Partager par lien. Toute personne disposant du lien peut ainsi consulter l’instantané de conception dans son navigateur pendant une durée limitée à 48 heures. Ce mode de partage ne permet pas de commenter la conception.

Ce mode de partage ne nécessite pas d’être connecté à votre compte Altium dans Altium Designer.
Notez que les instantanés de conception partagés par lien peuvent être indexés par les moteurs de recherche et accessibles à leurs utilisateurs.

Cliquez sur le bouton pour générer le lien vers l’instantané de conception. En arrière-plan, le projet est regroupé dans une archive ZIP à l’aide de l’outil Project Packager d’Altium Designer. Une fois le lien prêt, cliquez sur le bouton pour le copier, puis partagez-le avec les personnes concernées selon vos besoins.

Génération du lien à durée limitée, qui peut être partagé avec n’importe qui, où que ce soit.Génération du lien à durée limitée, qui peut être partagé avec n’importe qui, où que ce soit.

Lorsque le destinataire ouvre le lien dans un navigateur, il accède à une instance d’Altium 365 Viewer, sur le site principal altium.com, dans laquelle la conception a été traitée et chargée.

À l’aide du lien partagé, le destinataire peut parcourir l’instantané de conception dans Altium 365 Viewer, chargé sur le site principal altium.com. Un schéma est présenté ici : survolez l’image pour voir le PCB.À l’aide du lien partagé, le destinataire peut parcourir l’instantané de conception dans Altium 365 Viewer, chargé sur le site principal altium.com. Un schéma est présenté ici : survolez l’image pour voir le PCB.

Lorsque la conception, contenue dans l’archive ZIP, est téléversée vers Altium 365 Viewer, elle est supprimée dès la fin de son traitement. Sa consultation est donc limitée à la durée de votre session de navigation : elle n’est plus accessible si vous fermez l’onglet du navigateur. Vous pouvez toutefois réutiliser le lien à tout moment pendant la période autorisée de 48 heures.

Partage avec des personnes spécifiques

Un clic sur la commande Share with specific people change le mode de partage de l’instantané de conception pour vous permettre de le partager avec une ou plusieurs personnes spécifiques, par invitation électronique. Les destinataires pourront consulter, partager ou télécharger l’instantané de conception via l’interface Web de la plateforme Altium 365. Ce type d’instantané reste disponible en permanence sur la plateforme, et ce mode de partage permet de commenter la conception.

Ce mode de partage nécessite d’être connecté à votre compte Altium dans Altium Designer, à l’aide de vos identifiants AltiumLive. Si vous n’êtes pas connecté à votre compte Altium, la boîte de dialogue affiche un lien pour vous connecter, qui ouvre la boîte de dialogue Connexion, ou pour vous inscrire à AltiumLive si vous ne disposez pas encore d’identifiants.

Changez de mode pour partager durablement un instantané de conception avec des personnes spécifiques.Changez de mode pour partager durablement un instantané de conception avec des personnes spécifiques.

Saisissez l’adresse e-mail complète d’une personne avec laquelle vous souhaitez partager l’instantané, puis appuyez sur Enter. Vous pouvez ajouter plusieurs personnes de cette manière, selon vos besoins. Vous pouvez également ajouter une note facultative pour leur communiquer toute information pertinente concernant cet instantané.

Exemple de partage d’un instantané de conception avec une personne spécifique, par e-mail.Exemple de partage d’un instantané de conception avec une personne spécifique, par e-mail.

Utilisez les options Advanced Settings de la boîte de dialogue Share pour définir les autorisations appliquées à l’instantané du projet partagé (). Sélectionnez Allow sharing pour autoriser la personne spécifiée à partager à son tour l’instantané du projet, et l’option Allow downloading pour permettre le téléchargement de l’instantané au format ZIP.

Lorsque tout est prêt, cliquez sur le bouton . Le projet est regroupé dans une archive ZIP à l’aide de l’outil Project Packager d’Altium Designer, puis téléversé vers la plateforme Altium 365. Une confirmation du téléversement s’affiche une fois l’opération terminée.

L’instantané partagé est regroupé dans une archive, puis téléversé vers la plateforme Altium 365, où il reste disponible en permanence.L’instantané partagé est regroupé dans une archive, puis téléversé vers la plateforme Altium 365, où il reste disponible en permanence.

La personne avec laquelle vous avez partagé l’instantané de conception téléversé reçoit une invitation par e-mail pour y accéder via Altium 365. Lorsqu’elle clique sur le bouton dans l’e-mail, elle est redirigée vers la page Altium 365 Sign In, sauf si elle est déjà connectée à la plateforme ou à son compte AltiumLive. Après s’être connectée, elle accède à la visionneuse Web, dans laquelle l’instantané de conception partagé est chargé.

Si cette personne ne possède pas de compte AltiumLive, elle doit d’abord en créer un. Un formulaire de création de compte est proposé à l’ouverture du lien Altium 365.

Accès à l’instantané de conception depuis l’invitation reçue par e-mail par l’utilisateur avec lequel il a été partagé.Accès à l’instantané de conception depuis l’invitation reçue par e-mail par l’utilisateur avec lequel il a été partagé.

Accès à un instantané de conception partagé

Outre le lien figurant dans son invitation par e-mail, une personne avec laquelle un instantané de conception permanent a été partagé peut accéder à cet instantané à tout moment pour l’ouvrir, le partager et le consulter depuis la Shared with Me page de l’  interface de la plateforme Altium 365. Un instantané de conception est signalé par l’icône dans sa vignette.

Pour ouvrir une conception dans la visionneuse intégrée, sélectionnez sa vignette et cliquez sur le nom du projet, ou choisissez l’option Open dans le menu à trois points de la vignette. Vous pouvez également double-cliquer directement sur la vignette. Notez qu’un instantané de conception partagé ne peut pas être modifié et n’est donc pas accessible dans Altium Designer depuis l’emplacement Shared With Me de la boîte de dialogue Open Project. Il peut toutefois être téléchargé si l’autorisation correspondante a été activée lors du partage.

Accès à un instantané de conception depuis la page Shared with Me  de l’interface de la plateforme Altium 365. Dans cet exemple, un commentaire a été ajouté à la conception partagée.Accès à un instantané de conception depuis la page Shared with Me de l’interface de la plateforme Altium 365. Dans cet exemple, un commentaire a été ajouté à la conception partagée.

La personne qui a initialement partagé l’instantané de conception, en le téléversant de manière permanente sur la plateforme Altium 365, pourra également y accéder depuis la page Files de son espace personnel.

Désactivation du partage

Pour désactiver complètement le partage, décochez l’option Altium Cloud sur la page System – Network Activity de la boîte de dialogue Preferences. Si vous tentez de partager une conception via la boîte de dialogue Share, en direct ou sous forme d’instantané, une boîte de dialogue d’avertissement s’affiche pour vous signaler que cette option a été désactivée.

La désactivation de la connectivité à Altium Cloud empêche le partage des projets de conception.
La désactivation de la connectivité à Altium Cloud empêche le partage des projets de conception.

Prise en charge des revues de conception

La boîte de dialogue Share vous permet de consulter la liste des instances de revue de conception du projet.

La fonctionnalité de revue de conception permet de créer et de gérer des instances de revue structurées pour vos projets dans un espace de travail Altium 365.

Pour en savoir plus, consultez la page Revues de conception.

Lorsque l’entrée  est sélectionnée dans la partie gauche de la boîte de dialogue Share, la partie droite répertorie les revues de conception actives du projet (celles à l’état In Progress) pour lesquelles vous êtes désigné comme réviseur. Chaque instance de revue de conception est présentée avec les informations suivantes :

  • Nom de l’instance. Cliquez sur le lien pour ouvrir l’instance dans l’interface Web d’Altium 365.

  • Description.

  • Horodatage du commit ou de la publication pour lequel l’instance de revue de conception est créée.

  • Initiateur et horodatage de création de l’instance.

Si le projet ne comporte aucune instance à l’état In Progress, le bouton  est disponible en bas à droite de la boîte de dialogue. Cliquez dessus pour fermer la boîte de dialogue et accéder à la page Design Reviews du projet dans l’interface Web de l’espace de travail. La fenêtre Create Design Review s’ouvre et vous permet de définir les réviseurs, la description et le modèle de liste de contrôle à utiliser.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents