Préparation d'un fichier PDF 3D

En un coup d'œil

Partagez une vue 3D interactive de votre conception de PCB avec les fabricants, les entreprises d’assemblage et les clients grâce à la fonction d’exportation PDF3D d’Altium Designer. Cet article explique comment générer un PDF 3D, configurer le contenu et l’apparence de la conception, puis explorer la carte exportée dans Adobe Acrobat Reader. Poursuivez votre lecture pour préparer un PDF 3D adapté aux besoins de votre public.

- Découvrez comment accéder à l’exportation PDF3D et configurer la géométrie, les palettes de couleurs, les vues initiales et, si nécessaire, les vues enregistrées sous forme d’images clés.
- Comprenez l’incidence du contenu de conception inclus sur la taille du fichier et les performances d’affichage.
- Découvrez comment la barre d’outils 3D et l’arborescence du modèle d’Acrobat Reader facilitent la navigation, la mise en surbrillance et le contrôle de la visibilité des composants et des nets.
Approfondissez avec l'IA :

Les utilisateurs d'Altium Designer bénéficient depuis longtemps de la possibilité de visualiser de manière interactive les conceptions de circuits imprimés dans un rendu 3D complet, offrant un aperçu unique de la structure réelle de la carte, de ses composants et des pièces mécaniques associées.

Permettre aux personnes extérieures à l'équipe de conception, telles que les fabricants, les prestataires d'assemblage et, surtout, les clients, d'accéder à cette fonctionnalité 3D présente des avantages considérables. C'est ce que permet la fonction d'exportation PDF 3D d'Altium Designer. Ce format 3D interactif est accessible à toute personne disposant d'une version récente du très répandu Adobe® Acrobat® Reader.

Visualisez de manière interactive une conception 3D exportée dans Adobe Reader : zoomez, faites-la pivoter et sélectionnez les éléments de conception à afficher.
Visualisez de manière interactive une conception 3D exportée dans Adobe Reader : zoomez, faites-la pivoter et sélectionnez les éléments de conception à afficher.

Contrairement à une vue fixe d'une conception de carte en 3D, qui offre une perspective selon un angle donné, le format PDF 3D exporté est, dans son principe, équivalent à la vue interactive d'Altium Designer 3D Layout Mode. Le fichier PDF 3D exporté offre ainsi les mêmes fonctions de rotation, de zoom et de déplacement panoramique, ainsi que des signets pour chaque composant et chaque équipotentielle, et peut utiliser l'un des jeux de couleurs prédéfinis.

Pour accéder à la fonction d'exportation PDF 3D dans Altium Designer, l'extension logicielle PDF3D Exporter doit être installée. Cette extension est installée par défaut avec Altium Designer. Elle peut être installée ou supprimée manuellement.

Pour en savoir plus sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

La 3D dans Acrobat Reader

La visualisation 3D interactive des fichiers PDF est devenue possible avec l'introduction de fonctions avancées de visualisation 3D dans Acrobat Reader, à partir de la version 7. Progressivement enrichis au fil des versions suivantes d'Acrobat Reader, le niveau de détail élevé et les options de configuration proposés par l'exportation PDF 3D d'Altium Designer sont compatibles avec les versions 9 et ultérieures.

Cette fonctionnalité 3D repose sur le format de fichiers d'infographie Universal 3D (U3D), développé par l'industrie et normalisé par l'European Computer Manufacturers Association (ECMA) sous la référence Norme ECMA-363 - Format de fichier Universal 3D. Le format U3D est pris en charge nativement par le format PDF et peut être facilement intégré (et compressé) dans un fichier PDF pour une visualisation 3D interactive dans Acrobat Reader.

Il en résulte un format de fichier 3D multiplateforme de taille modeste, qui ne nécessite aucun logiciel spécialisé de visualisation 3D. Dans le cas des fichiers PDF 3D exportés depuis Altium Designer, le contenu intégré comprend la majorité des données visibles dans la vue 3D d'Altium Designer, notamment toutes les pistes, pastilles, vias, polygones, etc., tous les composants et l'ensemble des couches de la carte.

Génération d'un PDF

Pour exporter un fichier PDF 3D, ouvrez le document de conception de circuit imprimé souhaité dans l'espace de conception et choisissez la commande File » Export » PDF3D dans les menus principaux (un fichier PDF 3D sera créé au format 3D, quel que soit le mode d'affichage actuel de l'éditeur de circuits imprimés, 2D ou 3D).

Contrairement à une vue fixe d'une conception de carte en 3D selon un angle donné, la nouvelle exportation PDF 3D est, dans son principe, équivalente à la vue 3D interactive d'Altium Designer.

Le fichier PDF 3D exporté offre ainsi les mêmes fonctions de rotation, de zoom et de déplacement panoramique, et peut utiliser n'importe lequel des jeux de couleurs définis par la configuration d'affichage active. Pour examiner ou modifier la configuration actuelle, et donc les couleurs de rendu disponibles pour le PDF exporté, passez à l'affichage 3D de la carte (raccourci clavier : 3) et ouvrez le panneau View Configuration. Les couleurs de rendu sont visibles dans la section 3D Settings, sous l'onglet View Options du panneau.

L'onglet View Options du panneau View Configuration est rapidement accessible à l'aide du raccourci clavier Ctrl+D.

Un fichier PDF 3D sera créé au format 3D, quel que soit le mode d'affichage actuel de l'éditeur de circuits imprimés (2D ou 3D).

Options d'exportation

Une fois l'exportation PDF 3D lancée (File » Export » PDF3D) et le nom ainsi que l'emplacement du fichier cible définis dans la boîte de dialogue Windows standard Export File, la boîte de dialogue Export 3D s'ouvre pour vous permettre de définir le rendu, le comportement et le contenu de conception à inclure dans le PDF.

La boîte de dialogue Export 3D vous permet de configurer l'apparence et le comportement du PDF exporté.
La boîte de dialogue Export 3D vous permet de configurer l'apparence et le comportement du PDF exporté.

Utilisez la boîte de dialogue Export 3D pour configurer les options d’exportation selon vos besoins, puis cliquez sur le bouton Export pour générer le fichier PDF 3D.

Les fichiers 3D peuvent être volumineux, même avec la compression des données inhérente au format. Il convient donc de déterminer quel niveau de contenu de conception est important pour l’utilisateur cible. Par exemple, le contenu des couches de cuivre (pistes, pastilles, etc.) n’est pas forcément nécessaire à une personne qui s’intéresse aux aspects mécaniques de la conception d’un circuit imprimé.

  • Notez qu’Acrobat Reader permet aux utilisateurs d’activer ou de désactiver l’affichage des éléments du modèle (par groupes ou individuellement) selon leurs besoins — voir ci-dessous.

  • Les images clés définies dans un document PCB peuvent être intégrées à l’exportation PDF 3D en cochant l’option Use 3D Movie views dans la boîte de dialogue Export 3D. Les images clés exportées dans le document PDF 3D seront alors disponibles sous forme de vues sélectionnables dans Acrobat Reader.

Lors du choix du contenu 3D à inclure, il est également utile de tenir compte des capacités de rendu 3D du PC de l’utilisateur. Même si la taille du fichier PDF 3D obtenu reste raisonnable, le processeur et le système graphique de la machine cible peuvent avoir du mal à assurer un rendu fluide d’une conception multicouche complexe.

Les options ci-dessus définissent les paramètres initiaux à l’ouverture du PDF dans Acrobat Reader et peuvent facilement être modifiées selon les préférences de l’utilisateur depuis la barre d’outils 3D du lecteur. Notez que si la barre d’outils est désactivée dans les options d’exportation PDF 3D, l’utilisateur ne pourra pas modifier la vue.

Affichage d’un PDF 3D

Comme vous pouvez l’imaginer, l’affichage d’un PDF 3D dans Acrobat Reader est assez simple, avec des commandes et des menus qui prolongent logiquement les fonctions 2D habituelles.

Vous pouvez déplacer, agrandir, réduire et faire pivoter les objets 3D par de simples glissements de souris et à l’aide de la molette, les fonctions étant sélectionnées dans la barre d’outils flottante 3D.

La barre d’outils 3D d’Acrobat propose des commandes de navigation 3D ainsi que des paramètres d’éclairage et d’affichage.
La barre d’outils 3D d’Acrobat propose des commandes de navigation 3D ainsi que des paramètres d’éclairage et d’affichage.

Le volet de navigation Model Tree est une fonctionnalité particulièrement utile du lecteur. Vous pouvez l’ouvrir (s’il ne l’est pas déjà) à l’aide du bouton . Il permet à l’utilisateur de parcourir tous les objets du PDF 3D, de sélectionner et de mettre en surbrillance ceux qui l’intéressent, tout en activant ou en désactivant leur visibilité.


Le volet de navigation Arborescence du modèle est particulièrement utile
pour contrôler l’affichage de composants et de réseaux spécifiques.

Le volet de navigation Model Tree offre un moyen efficace d’examiner tous les aspects d’une conception 3D avec un niveau de détail élevé. Qu’il s’agisse d’examiner de près le positionnement et l’implantation des composants ou d’inspecter en détail la structure interne du circuit imprimé, l’arborescence de navigation permet de rechercher et d’afficher les objets appropriés.

La conception affichée avec les composants et les couches de sérigraphie du circuit imprimé désélectionnés, illustrant le niveau de contrôle 3D disponible dans Acrobat Reader.
La conception affichée avec les composants et les couches de sérigraphie du circuit imprimé désélectionnés, illustrant le niveau de contrôle 3D disponible dans Acrobat Reader.

Lorsqu’ils sont sélectionnés dans le volet Model Tree, les objets individuels sont mis en surbrillance dans la fenêtre d’affichage avec la couleur définie en haut du volet (rouge dans ce cas). Cela facilite le repérage d’un composant ou d’un réseau particulier et évite d’avoir à activer ou désactiver la visibilité d’un objet pour le localiser. De même, la sélection d’un objet dans la fenêtre de vue 3D met en surbrillance son entrée dans le volet Model Tree.

Pour plus d’informations sur l’utilisation des différentes commandes, fonctions et paramètres d’Acrobat Reader, consultez la rubrique correspondante de l’aide Adobe : Affichage de modèles 3D dans des fichiers PDF.

Les métadonnées de base de la conception provenant d’Altium Designer sont également incluses dans le document PDF 3D exporté. Ces données comprennent le fichier source de la conception, son auteur, la version d’Altium Designer, les dates de création et de modification, etc. Ces informations peuvent être consultées dans Adobe Reader sous l’onglet Description de la boîte de dialogue Document Properties — File » Properties.

Exportation PDF 3D via un OutJob

Pour inclure une exportation de fichier PDF 3D dans un OutJob de projet, cliquez sur Add New Documentation Output sous l’entrée Documentation Outputs, sélectionnez PDF3D, puis sélectionnez le document source souhaité : soit un document PCB spécifique à exporter, soit [PCB Document] pour que l’OutJob reste réutilisable de manière générique.

Ajout d’un générateur de sortie PDF3D à un fichier de configuration des tâches de sortie.Ajout d’un générateur de sortie PDF3D à un fichier de configuration des tâches de sortie.

Les paramètres de génération du PDF 3D peuvent être préconfigurés en sélectionnant l’entrée du générateur de sortie, puis en effectuant un clic droit et en choisissant Configure dans le menu contextuel. La boîte de dialogue de configuration Export 3D s’ouvre alors (comme décrit précédemment).

Lorsque la tâche de sortie est exécutée ou lancée manuellement, le fichier PDF 3D est exporté selon les paramètres définis dans la section Output Containers de l’OutJob. Il est exporté vers l’espace de travail et le chemin configurés, ou vers la destination de publication locale ou distante définie sur la page Gestion des données – Destinations de publication de la boîte de dialogue Preferences.

Génération d’un fichier PDF 3D vers un conteneur de sortie PDF défini, depuis un OutJob configuré.
Génération d’un fichier PDF 3D vers un conteneur de sortie PDF défini, depuis un OutJob configuré.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents