Votre vue du PCB
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Comprenez les différences entre les modes Planification de la carte, Implantation 2D et Implantation 3D, ainsi que les situations dans lesquelles chacun est utilisé.
- Découvrez comment le panneau Configuration de la vue permet de contrôler les couches, les couleurs, la visibilité des objets et les autres paramètres d’affichage.
- Découvrez comment les outils de visibilité des couches et les ensembles de couches peuvent rendre la navigation dans les conceptions de PCB complexes plus rapide et plus simple.
Historiquement, les PCB ont été conçus dans un espace de conception bidimensionnel utilisant des couleurs pour représenter les différentes couches du PCB. Cependant, le PCB physique est un objet tridimensionnel, ce qui oblige le concepteur à convertir mentalement la représentation 2D multicouche affichée à l’écran en une représentation 3D.
Les progrès considérables des cartes graphiques 3D et des technologies logicielles associées ont permis à Altium de développer une solution à ce problème : la véritable édition de PCB en trois dimensions. Au-delà de la simple visualisation, les fonctionnalités 3D d’Altium Designer vous permettent de :
-
Vérifier les distances d’isolement en 3D : les composants peuvent être alignés avec précision les uns par rapport aux autres et par rapport au boîtier, selon les besoins.
-
Repérer visuellement les connecteurs et autres composants qui doivent rester accessibles pour la maintenance.
-
Mieux définir les procédés de fabrication et l’ordre d’assemblage, en sachant que toutes les contraintes mécaniques ont été prises en compte.
-
Créer des instructions d’assemblage manuel, des manuels d’utilisation et des consignes plus détaillés à l’aide d’images beaucoup plus proches de ce qu’une personne verra réellement.
-
Essayer différentes couleurs de vernis épargne afin de créer un produit plus esthétique, en harmonie avec son boîtier et son environnement.
-
Obtenir plus facilement l’adhésion des principales parties prenantes en leur présentant une vue plus concrète du produit final.

Vues 2D et 3D de la même zone d’une carte.
Modes d’affichage
Altium Designer permet d’afficher et de modifier la carte en 2D ou en 3D ; ces modes sont appelés display modes. Sélectionnez le mode souhaité dans le menu View, ou appuyez sur le raccourci 1, 2 ou 3 pour passer directement à ce mode.
Il existe trois modes d’affichage, chacun offrant des fonctions distinctes.
-
Board Planning Mode (touche de raccourci 1) - permet de définir la forme de la carte ainsi que de positionner et de configurer les lignes de séparation et de pliage d’une conception rigide-flexible. Les lignes de séparation servent à diviser la carte en régions, et chaque région peut ensuite recevoir un empilage de couches différent. Pour en savoir plus sur les régions de la carte et les lignes de séparation et de pliage, consultez Définition de l’empilage de couches.
-
2D Layout Mode (touche de raccourci 2) - la vue 2D multicouche traditionnelle du PCB. Altium Designer intègre un ensemble de fonctionnalités pour vous aider à gérer l’affichage de la carte, appelé système Board Insight.
-
3D Layout Mode (touche de raccourci 3) - la véritable conception en 3D. Combinez le mode d’affichage 3D avec une souris 3D pour visualiser et manipuler la carte 3D chargée comme si vous la teniez dans la main. Pour en savoir plus sur le contrôle de la vue du PCB en 3D, consultez la page Contrôle de la vue 3D.
La même carte est présentée en mode Planification de la carte, en mode Implantation 2D et en mode Implantation 3D.
Le panneau de configuration de l’affichage
Les éléments actuellement affichés dans l’espace de conception de l’éditeur PCB et leur mode d’affichage peuvent être configurés dans le panneau View Configuration. Cela comprend la visibilité et la couleur des couches, la visibilité et la transparence des objets, les niveaux de masquage et d’atténuation, le mode monocouche actuel ainsi que plusieurs fonctions supplémentaires d’affichage de l’espace de conception, comme l’affichage des noms de nets sur les pastilles, les vias et les pistes.
Outre les méthodes habituelles d’accès à un panneau (à partir du bouton Panels en bas à droite de l’espace de conception ou du menu View » Panels), vous pouvez également accéder au panneau View Configuration à l’aide des touches de raccourci L ou Ctrl+D (pour ouvrir le panneau en affichant respectivement l’onglet Layers & Colors ou View Options), ou en cliquant sur l’échantillon de couleur de la commande Jeux de couches en bas à gauche de l’espace de conception
Le contenu du panneau est réparti sur deux onglets. Cliquez sur un onglet en haut du panneau pour afficher les options qu’il propose :
-
Layers and Colors onglet – comprend des options pour contrôler la visibilité des couches disponibles, ajouter, renommer ou supprimer des couches mécaniques, et configurer la couleur et la visibilité d’éléments d’affichage système spécifiques, tels que les trous des pastilles, le repère d’origine et les erreurs DRC.
-
View Options onglet – comprend des options pour sélectionner, enregistrer ou charger la configuration des couleurs et de la visibilité des couches, configurer la visibilité des types d’objets, contrôler les niveaux de masquage et d’atténuation, et configurer d’autres options liées à l’affichage.
Les options disponibles dépendent du mode d’implantation actuel (2D ou 3D).
Configuration de la visibilité des couches
Chaque couche peut être affichée ou masquée depuis la zone Layers de l’onglet Layers & Colors du panneau View Configuration. Cliquez sur l’icône de visibilité pour activer ou désactiver son affichage.

Gérez la visibilité des couches à l’aide des icônes de visibilité
Lorsque cela est pertinent, chaque groupe comprend également une icône de visibilité. Par exemple, dans l’image ci-dessus :
- L’icône de visibilité située à gauche du texte Component Layer Pairs (C) active ou désactive l’affichage des couches de composants all.
- L’icône de visibilité située à gauche du texte Top permet d’afficher ou de masquer les couches de composants all top side. Les couches du côté Bottom peuvent également être affichées ou masquées de la même manière.
Contrôle de la visibilité des couches au clavier
Dans une conception de PCB complexe, les couches sont souvent affichées et masquées au cours du processus de conception. Pour faciliter cette opération, vous pouvez modifier leur visibilité à l’aide de raccourcis clavier comme suit :
- Appuyez sur la touche de raccourci L pour afficher et activer l’onglet Layers & Colors du panneau View Configuration. La barre de titre du panneau se colore, indiquant qu’il s’agit de l’élément actif dans le logiciel.
- Notez que des lettres et des chiffres apparaissent entre parenthèses à droite de certaines couches et de certains ensembles de couches, par exemple Component Layer Pairs (C) et [1] Top (T). La lettre ou le chiffre entre parenthèses correspond à une touche de raccourci clavier. Par exemple, appuyez sur le raccourci L pour activer le panneau, puis sur le raccourci T pour afficher ou masquer la couche de signal supérieure.
- Si vous avez sélectionné un ensemble de couches, appuyez sur Spacebar pour afficher ou masquer toutes les couches de cet ensemble.
- Si vous avez sélectionné une couche, sa visibilité change immédiatement et vous pouvez ensuite utiliser Spacebar pour la modifier à nouveau.
- Appuyez sur les touches fléchées Up ou Down pour parcourir la liste vers le haut ou vers le bas, par exemple pour sélectionner une couche mécanique spécifique ou une paire de couches de composants. Vous pouvez ensuite utiliser Spacebar pour afficher ou masquer cette couche ou cette paire de couches.
Ensembles de couches
Un ensemble de couches est un groupe nommé de couches visibles. Utilisez la liste déroulante Layers Sets dans la section Layers de l’onglet Layers & Colors du panneau View Configuration pour sélectionner un ensemble de couches existant ; l’affichage est mis à jour pour ne montrer que les couches activées dans cet ensemble.
Plusieurs ensembles de couches sont disponibles par défaut :
-
All Layers – sélectionnez cette option pour afficher toutes les couches.
-
Signal Layers – sélectionnez cette option pour afficher uniquement les couches définies comme étant de type Signal dans le gestionnaire d’empilage de couches, ainsi que les couches Die et Wire Bonding si elles existent.
-
Plane Layers – sélectionnez cette option pour afficher uniquement les couches définies comme étant de type Plane dans le gestionnaire d’empilage de couches.
-
NonSignal Layers – sélectionnez cette option pour afficher uniquement les couches Overlay, Paste, Solder et Other Layers (Drill Drawing, Drill Guide, Keep-Out Layer et Multi-Layer).
-
Mechanical Layers – sélectionnez cette option pour afficher uniquement les couches mécaniques et les paires de couches de composants.
Vous pouvez créer autant d’ensembles de couches personnalisés que vous le souhaitez et modifier l’ensemble de couches actuellement sélectionné.
-
Pour créer un nouvel ensemble de couches personnalisé, configurez la visibilité des couches dans la section Layers selon vos besoins, puis cliquez sur le bouton
. L’ensemble apparaît sous le nom My Layers dans la liste déroulante. Chaque ensemble de couches ajouté par la suite est numéroté.
-
Pour modifier la configuration des couches activées dans un ensemble de couches personnalisé existant, sélectionnez-le dans la liste déroulante Layers Sets, configurez la visibilité des couches selon vos besoins, puis cliquez sur le bouton
pour enregistrer les modifications dans l’ensemble de couches.
-
Pour renommer un ensemble de couches personnalisé existant, sélectionnez-le dans la liste déroulante Layers Sets et saisissez le nom souhaité dans les champs Layer Sets. Notez qu’il n’est pas nécessaire d’effectuer une opération d’enregistrement pour renommer un ensemble de couches : le nouveau nom est enregistré automatiquement.
-
Pour supprimer un ensemble de couches personnalisé existant, sélectionnez-le dans la liste déroulante Layers Sets et cliquez sur le bouton
.
-
Pour importer l’ensemble de couches souhaité depuis un fichier d’ensemble de couches de PCB
(*.layerset)ou l’exporter sous forme de fichier d’ensemble de couches de PCB, utilisez respectivement les boutons Import et Export.
Utilisez les méthodes suivantes pour changer d’ensemble de couches visible :
- Layer Set liste déroulante du panneau View Configuration
- Design » Manage Layer Sets sous-menu
- Layer Set commande accessible en cliquant sur la partie LS du bouton situé à gauche des onglets de couches, en bas de l’espace de conception
Couleurs système
La section System Colors permet de configurer les couleurs utilisées sur le PCB pour les éléments répertoriés. Les couleurs et la visibilité se configurent à l’aide des méthodes habituelles.
Onglets de couches
Les onglets associés à chaque couche actuellement définie comme visible dans le panneau View Configuration se trouvent le long du bord inférieur de l’espace de conception.
Ils permettent de changer de couche active (la couche sur laquelle vous placez les objets) et indiquent visuellement quelles couches sont actuellement affichées et laquelle est active (l’onglet en surbrillance). Si tous les onglets de couches ne peuvent pas être affichés simultanément, utilisez les flèches
pour les faire défiler.
Les couleurs des couches sont affichées à gauche des onglets de couches. Double-cliquez sur la couleur d’une couche pour ouvrir la boîte de dialogue Choose Color.
Double-cliquez sur le nom d’une couche pour ouvrir la boîte de dialogue Edit Layer, dans laquelle vous pouvez modifier le nom de la couche (et le nom du net pour une couche de plan interne).

La boîte de dialogue Edit Layer
Mode monocouche
Mode d’affichage 2D monocouche
Les fonctionnalités du mode monocouche sont intégrées à Board Insight et se configurent sur la page Éditeur de PCB - Affichage Board Insight de Preferences boîte de dialogue. Le mode monocouche affiche le contenu de la couche active tout en masquant ou en atténuant le contenu de toutes les autres couches. Outre la possibilité de masquer tous les objets des autres couches pour n’afficher que le contenu de la couche active, le mode monocouche propose des modes d’affichage en niveaux de gris et monochrome. La conversion des couleurs de toutes les autres couches en niveaux de gris ou en monochrome permet de conserver les informations sur la position relative des autres objets dans la conception, sans détourner votre attention de la couche qui vous intéresse. Pour passer de l’affichage complet à chacun des modes monocouches activés, appuyez sur le raccourci Shift+S. À chaque pression sur Shift+S, le logiciel passe au mode activé suivant, puis revient finalement au mode d’affichage complet. Les modes monocouches sont activés sur la page PCB Editor - Board Insight Display de la boîte de dialogue Preferences. Désactivez (décochez) les modes que vous ne souhaitez pas inclure dans le cycle lorsque vous appuyez sur Shift+S. Ces paramètres s’appliquent à toutes les conceptions de cette installation d’Altium Designer.
Les modes monocouches disponibles sont les suivants :
- Hide Other Layers - toutes les autres couches sont masquées ; seul le contenu de la couche active est affiché.
- Gray Scale Other Layers - toutes les autres couches sont affichées dans une nuance de gris dérivée de leur couleur actuelle ; la couche active est affichée dans sa couleur habituelle.
- Monochrome Other Layers - toutes les autres couches sont affichées dans la même nuance de gris ; la couche active est affichée dans sa couleur habituelle.
Les images ci-dessous montrent l’affichage multicouche habituel et les trois modes d’affichage monocouches.
Le mode monocouche actuellement sélectionné est affiché dans la zone General Settings de l’onglet View Options du panneau View Configuration. Cliquez sur le lien du mode (à côté du bouton On ) pour accéder à la page PCB Editor - Board Insight Display de la boîte de dialogue Preferences, dans laquelle vous pouvez configurer les modes monocouches disponibles selon vos besoins.
Utilisez le curseur Masked Objects dans la zone Mask and Dim Settings de l’onglet View Options du panneau View Configuration pour régler la luminosité des autres couches dans les modes monocouches en niveaux de gris ou monochrome.
Mode d’affichage monocouche 3D
Le mode monocouche est également disponible lorsque la carte est affichée en 3D Layout Mode. Utilisez-le pour examiner, par exemple, la qualité du routage sur une couche donnée ou la qualité d’une couche de plan d’alimentation. En mode monocouche, utilisez le raccourci Ctrl+Shift+Wheel Roll pour parcourir les couches.
Afficher une couche en permanence en mode monocouche
Pour inclure une couche dans l’affichage en mode monocouche, effectuez un Ctrl+Click sur l’icône en forme d’œil associée à la couche souhaitée dans l’onglet Layers & Colors du panneau View Configuration afin de l’ajouter à cet affichage ; un carré apparaît derrière l’icône en forme d’œil pour indiquer que cette couche sera affichée en permanence en mode monocouche.
Afficher la carte vue de dessous
Pour afficher la carte vue de dessous (autrement dit, pour la retourner), activez l’option View From Bottom Side dans la zone Layers de l’onglet Layers & Colors du panneau View Configuration, sélectionnez la commande View » Flip Board dans les menus principaux ou utilisez le raccourci clavier Ctrl+F.
Toutes les actions et commandes d’édition sont prises en charge lorsque la carte ou les composants sont retournés. L’espace de coordonnées reste logiquement identique : l’origine de l’espace de conception passe du coin inférieur gauche au coin inférieur droit. La position actuelle sur la grille augmente dans la direction X (horizontale) lorsque vous déplacez la souris de droite à gauche, au lieu du sens habituel de gauche à droite. Toute sortie générée lorsque la vue est retournée conserve les coordonnées correctes correspondant à une vue de dessus.
Lorsque la carte ou le composant est retourné, l’ordre de tracé des couches est également modifié selon un processus logique de permutation par paires : Top Overlay échange sa position dans l’ordre de tracé actuel avec Bottom Overlay, Top Layer avec Bottom Layer, Mid-Layer 1 avec Mid-Layer 30, Internal Plane 1 avec Internal Plane 16, et ainsi de suite. L’ordre de tracé des couches mécaniques n’est pas modifié.
Contrôler la visibilité des objets
Outre le contrôle de l’affichage des objets dans l’espace de conception en activant ou en désactivant les couches, vous pouvez contrôler leur visibilité et leur transparence en fonction de leur type. En mode de disposition 2D, utilisez les options de la zone Object Visibility de l’onglet View Options du panneau View Configuration pour configurer la visibilité et la transparence des objets selon leur type.

La section Object Visibility de l’onglet View Options du panneau
-
– contrôlez la visibilité de types d’objets spécifiques en cliquant sur l’icône de visibilité correspondante. Cliquez sur l’icône de visibilité All Objects pour basculer la visibilité de tous les objets, puis activez celle des types d’objets souhaités.
-
Name – répertorie tous les objets dont l’apparence peut être ajustée.
-
Draft – activez cette option pour afficher uniquement le contour des objets de ce type.
-
Transparency – réglez la transparence de ce type d’objet à l’aide du curseur, ou cliquez sur la valeur et saisissez manuellement le pourcentage souhaité entre 0 et 100 (0 % correspond à un objet entièrement visible et opaque ; 100 % à un objet entièrement transparent et invisible). Rendre un objet transparent permet de voir lorsqu’il en recouvre un autre, par exemple à l’endroit où l’extrémité d’un segment de piste rejoint une pastille.
-
Advanced – cliquez pour ouvrir la boîte de dialogue Object Visibility, dans laquelle vous pouvez définir un niveau de transparence commun pour un objet donné sur différentes couches, ainsi que des niveaux de transparence différents pour différents objets sur une couche donnée.
Paramètres de masquage et d’atténuation
Pour faciliter la gestion de l’affichage du grand nombre d’objets pouvant être présents, même dans une conception de PCB simple, l’éditeur de PCB permet d’atténuer les objets qui ne vous intéressent pas. Par exemple, si vous cliquez sur un net dans le mode Nets du panneau PCB et que la liste déroulante du panneau est réglée sur Dim ou Mask, tous les objets qui n’appartiennent pas à ce net sont atténués. Vous pouvez ainsi concentrer plus facilement votre attention sur un élément précis de la conception, tel qu’un net, une classe de nets, une classe de composants, des objets ciblés par une règle de conception donnée, etc. Utilisez les curseurs de la zone Mask and Dim Settings de l’onglet View Options du panneau View Configuration pour configurer les niveaux de masquage et d’atténuation.

La zone Mask and Dim Settings de l’onglet View Options du panneau View Configuration
-
Dimmed Objects – les objets actuellement estompés conservent leur couleur mais apparaissent atténués. Utilisez ce curseur pour régler le degré d’atténuation des objets estompés. Les objets estompés peuvent être modifiés.
- Highlighted Objects – lorsque l’estompage est activé et que vous cliquez sur un objet dans un panneau, par exemple sur un net dans le mode Nets du panneau PCB, ce net est mis en surbrillance tandis que tous les autres nets sont estompés. La couleur des objets en surbrillance est éclaircie par ajout de blanc pour les faire ressortir. Ce curseur permet de régler la quantité de blanc ajoutée aux objets en surbrillance.
- Masked Objects – les objets actuellement masqués sont affichés en gris et ne peuvent pas être modifiés. Utilisez ce curseur pour régler le degré d’atténuation des objets masqués.
Gestion des configurations
Une configuration est un ensemble prédéfini de paramètres de couleur et de visibilité des couches. Sélectionnez une configuration existante dans la liste déroulante Configuration de la zone General Settings de l’onglet View Options du panneau View Configuration, ou utilisez les boutons à côté de la liste déroulante pour créer, enregistrer ou supprimer une configuration. Les configurations personnalisées enregistrent les paramètres d’affichage 2D et 3D actuels ou utilisés en dernier.
-
– cliquez pour créer une configuration personnalisée, puis saisissez un nouveau nom et cliquez sur le bouton
.
-
– cliquez pour enregistrer une configuration personnalisée que vous venez de créer ou les modifications apportées à la configuration personnalisée actuellement sélectionnée.
-
– cliquez pour supprimer la configuration personnalisée actuellement sélectionnée.
Options supplémentaires
La zone Additional Options de l’onglet View Options du panneau View Configuration propose des options supplémentaires pour contrôler l’affichage d’éléments spécifiques.

La section Additional Options de l’onglet View Options du panneau View Configuration
-
Test Points – activez cette option pour afficher des informations supplémentaires sur les pastilles et les vias configurés comme points de test. Une pastille ou un via peut être configuré comme point de test en activant les options de point de test Fabrication et/ou Assembly dans le mode approprié du panneau Properties. Les points de test sont signalés par l’ajout de la chaîne
<Layer> Fab Testpointou<Layer> Assy Testpointà la pastille ou au via. - Status Info – activez cette option pour afficher des informations récapitulatives, telles que les coordonnées et la couche, dans Status Bar lorsque vous survolez un objet dans l’espace de conception.
- Pad Nets – activez cette option pour afficher le nom du net associé sur une pastille. Notez que les noms des nets ne sont visibles que si le niveau de zoom est suffisant.
- Pad Numbers – activez cette option pour afficher les numéros des pastilles. Notez que les numéros des pastilles ne sont visibles que si le niveau de zoom est suffisant.
- Via Nets – activez cette option pour afficher le nom du net associé sur un via. Notez que les noms des nets ne sont visibles que si le niveau de zoom est suffisant.
- Via Span – activez cette option pour afficher l’étendue autorisée du via entre les couches. Les propriétés des vias placés (diamètre, diamètre de perçage, etc.) sont ensuite définies soit par les règles de conception, soit manuellement. Notez que les noms des nets ne sont visibles que si le niveau de zoom est suffisant. Les numéros des couches couvertes par le via peuvent être affichés à l’intérieur de tous les types de vias.
- All Connections in Single Layer Mode – activez cette option pour toujours afficher toutes les lignes de connexion en mode monocouche. Lorsque cette option est désactivée, toutes les lignes de connexion qui ne commencent ni ne se terminent sur la couche actuelle sont également masquées lors du passage en mode monocouche, car elles sont considérées comme non pertinentes.
- Net Color Override – une couleur peut être attribuée à chaque net. Pour configurer cette couleur, double-cliquez sur le nom du net dans le mode Nets du panneau PCB ; la boîte de dialogue Edit Net s’ouvre. La couleur est automatiquement appliquée aux lignes de connexion de ce net et peut également être appliquée au routage en activant cette option. La couleur est appliquée au routage conformément aux paramètres actuels de la page PCB Editor – Board Insight Color Overrides de la boîte de dialogue Preferences, où vous choisissez une option de motif pour définir la façon dont la couleur est appliquée et un comportement de zoom pour définir quand elle est appliquée. Appuyez sur le raccourci F5 pour activer ou désactiver l’option de remplacement de la couleur du net.
- Use Layer Colors for Connection Drawing – activez cette option pour afficher les lignes de connexion avec les couleurs des couches de départ et d’arrivée entre lesquelles elles passent. Les lignes de connexion sont affichées dans la couleur exacte de la couche au niveau de leurs objets de départ et d’arrivée, avec une transition progressive entre ces couleurs sur toute leur longueur. Cette fonctionnalité est utile lors du routage d’une carte multicouche, car elle indique la couche cible que la connexion en cours de routage doit atteindre. Notez que cette transition de couleur s’applique uniquement aux connexions passant d’une couche à une autre. Si la connexion commence et se termine sur la même couche, elle conserve la couleur attribuée au net.
- Repeated Net Names on Tracks – activez cette option pour afficher les noms des nets de manière répétée sur les pistes.
- Special Strings – lorsque cette option est activée, toute chaîne placée issue de la conversion d’une chaîne spéciale est surmontée d’une étiquette indiquant le nom de la chaîne spéciale non convertie. Zoomez sur une chaîne pour voir son étiquette superposée.

