Préparation des données imprimées
En un coup d'œil
- Comprenez les différences entre les configurations Output Job et l’impression directe depuis un éditeur.
- Apprenez à régler les paramètres d’impression, notamment la couleur, le format de papier, l’orientation, l’échelle et la position.
- Explorez les options permettant d’inclure des objets de schéma et de configurer les pages d’impression, les couches et les aperçus du circuit imprimé.
Les sorties imprimées de votre projet PCB dans Altium Designer sont disponibles en créant un fichier de configuration des tâches de sortie (*.OutJob). Lorsque vous créez une tâche de sortie, vous disposez de divers documents de fabrication à générer, notamment des impressions bidimensionnelles courantes de PCB, telles que des dessins composites et des schémas.
Préparation des sorties imprimées de schémas
Les sorties imprimées de schémas peuvent être ajoutées au fichier Output Job actif en sélectionnant une option dans le menu Schematic Prints de la commande [Add New Documentation Output] dans la zone Documentation Outputs du fichier, ou dans le sous-menu Edit » Add Documentation Outputs » Schematic Prints des menus principaux.
Les impressions de schémas sont configurées dans la boîte de dialogue Print.
Options et commandes de la boîte de dialogue d’impression des schémas
Onglet Général
L’onglet General propose des options permettant de configurer l’imprimante et les paramètres de page.
Paramètres d’impression et de préréglages
-
Printer – ce champ indique l’imprimante actuelle à laquelle la sortie imprimée sera envoyée. Utilisez la liste déroulante pour choisir une autre imprimante parmi celles actuellement installées sur votre ordinateur. Cliquez sur le bouton
pour accéder aux options suivantes :
- Printer Settings – permet d’ouvrir la boîte de dialogue Microsoft Print to PDF Document Properties, dans laquelle vous pouvez configurer les fichiers d’imprimante en fonction de votre imprimante ou de votre système d’exploitation.
- Set as Default – permet de définir l’imprimante sélectionnée comme imprimante par défaut.
- Add Printer – permet d’ajouter une nouvelle imprimante depuis votre système Windows.
-
Print to file – permet de créer un dossier Out dans votre projet. Vous pouvez générer des fichiers (
*.ini) pour toutes les pages et exporter toutes les pages au format (*.emf).
- Copies – utilisez ce champ pour indiquer le nombre de copies de la page (ou de l’ensemble de pages) à imprimer.
-
Print Range – utilisez les commandes de cette zone pour indiquer les pages à imprimer lorsque la tâche d’impression prévue comporte plusieurs pages. Choisissez l’une des options suivantes :
- All Pages – activez cette option pour imprimer toutes les pages de la sortie imprimée en cours de génération.
- Current Page – lorsque la boîte de dialogue est ouverte depuis l’éditeur de schémas, activez cette option pour imprimer la feuille de schéma depuis laquelle la boîte de dialogue a été ouverte.
- Page From – activez cette option pour imprimer une plage de pages. Utilisez les champs pour indiquer la première et la dernière page (incluses) de la plage souhaitée.
Paramètres de page
- Color Set – utilisez cette option pour choisir le jeu de couleurs à utiliser pour la sortie imprimée. Les jeux de couleurs disponibles sont : Gray, Mono et Color.
- Page Size – sélectionnez un format de papier dans la liste déroulante.
- Orientation – utilisez ces options pour choisir une impression en orientation Portrait ou Landscape.
Paramètres d’échelle et de position
-
Scale Mode – utilisez la liste déroulante pour sélectionner le mode de mise à l’échelle souhaité. Choisissez entre
Actual SizeetFit On Page. -
Scale – ce champ est disponible lorsque Scale Mode est défini sur
Actual Size. Utilisez-le pour définir le facteur de mise à l’échelle du document. Une valeur supérieure à1agrandit l’impression (effet de zoom avant), tandis qu’une valeur inférieure à1la réduit (effet de zoom arrière). - Horizontal Offset – permet d’ajuster manuellement la position horizontale du contenu imprimé sur la page. Saisissez une valeur positive pour décaler le contenu imprimé vers la droite de la page ou une valeur négative pour le décaler vers la gauche. Si le champ est défini sur zéro, la marge gauche minimale requise par l’imprimante est utilisée. Activez l’option Center pour positionner automatiquement le contenu imprimé de manière à le centrer horizontalement sur la page.
- Vertical Offset – permet d’ajuster manuellement la position verticale du contenu imprimé sur la page. Saisissez une valeur positive pour décaler le contenu imprimé vers le haut de la page ou une valeur négative pour le décaler vers le bas. Si le champ est défini sur zéro, la marge inférieure minimale requise par l’imprimante est utilisée. Activez l’option Center pour positionner automatiquement le contenu imprimé de manière à le centrer verticalement sur la page.
Onglet Dessins
Dessins
Utilisez ces commandes pour configurer l’inclusion des objets suivants dans les sorties imprimées :
- No-ERC Markers with Symbols – désactivez/décochez cette option pour exclure tous les marqueurs No ERC des impressions générées ; activez/cochez-la pour inclure les marqueurs No ERC. Lorsque cette option est activée, les sous-options permettent de préciser les types de marqueurs No ERC à inclure en fonction des types de symboles affichés : Thin Cross, Thick Cross, Small Cross, Checkbox et Triangle.
- Parameter Sets – cochez cette option pour inclure les ensembles de paramètres dans l’impression.
- Probes – cochez cette option pour inclure les sondes dans l’impression.
- Blankets – cochez cette option pour inclure les couvertures dans l’impression.
- Notes – désactivez cette option pour exclure tous les objets de note des impressions générées ; activez-la pour inclure les objets de note. Lorsque cette option est activée, utilisez Include collapsed notes pour déterminer si toutes les notes sont affichées (option activée/cochée) ou uniquement celles qui sont entièrement développées (option désactivée/décochée).
Lorsque la boîte de dialogue est ouverte depuis une sortie d’impression de schémas dans un fichier Outjob et que l’option [Project Physical Documents] est sélectionnée comme Data Source de la sortie, les options Name Expansions permettent de choisir l’élément pour lequel les noms physiques doivent être développés lors de l’impression.
Menu contextuel de l’aperçu
Faites un clic droit dans la zone d’aperçu pour accéder au menu suivant :
- Copy – utilisez cette commande pour copier l’aperçu actuel dans le Presse-papiers Windows.
- Zoom In – utilisez cette commande pour effectuer un zoom avant par incréments.
- Zoom Out – utilisez cette commande pour effectuer un zoom arrière par incréments.
- Show Print Region – utilisez cette commande pour afficher la zone qui sera imprimée.
- Show Grid – utilisez cette commande pour afficher les lignes de la grille dans la zone d’aperçu. Notez que les lignes de la grille n’apparaîtront pas sur l’impression.
- Export to Image – utilisez cette commande pour exporter l’aperçu actuel sous forme d’image (PNG, JPEG, BMP, GIF, WMF, EMF).
Commandes supplémentaires
Set as Default – lorsque la boîte de dialogue est ouverte depuis l’éditeur de schémas, utilisez cette commande pour définir les paramètres prédéfinis de l’onglet Drawings de la boîte de dialogue comme valeurs par défaut.
Préparation des sorties d’impression 2D de PCB
Les impressions de PCB diffèrent des autres impressions en ce qu’elles peuvent être configurées pour inclure un nombre quelconque de pages, chacune pouvant contenir n’importe quelle combinaison de couches utilisées dans la conception, y compris les couches mécaniques et système.
Des sorties d’impression de PCB peuvent être ajoutées au fichier Output Job actif à partir des menus des commandes suivantes :
-
la commande
[Add New Documentation Output]dans la zone Documentation Outputs (ou les sous-menus Edit » Add Documentation Outputs des menus principaux) - Composite Drawing, PCB Prints. -
la commande
[Add New Assembly Output]dans la zone Assembly Outputs (ou les sous-menus Edit » Add Assembly Outputs des menus principaux) - Assembly Drawings. -
la commande
[Add New Fabrication Output]dans la zone Fabrication Outputs (ou les sous-menus Edit » Add Fabrication Outputs des menus principaux) - Composite Drill Guide, Drill Drawings, Final, Mask Set, Power-Plane Set.
Faites un clic droit sur la sortie souhaitée, puis choisissez Configure pour accéder à la boîte de dialogue Print, dans laquelle vous pouvez définir les éléments à imprimer, visualiser les impressions et modifier leurs paramètres de configuration.
Les options et commandes de la boîte de dialogue Print sont réparties sur trois onglets :
- L’onglet General propose des options permettant de configurer l’imprimante et les paramètres de page.
- L’onglet Pages comprend des options d’affichage et de gestion des paramètres des couches, et permet d’ajouter ou de supprimer des pages.
- L’onglet Advanced propose des options de paramétrage des désignateurs ainsi que des options de police et de couleur.
La zone d’aperçu, située à droite de la boîte de dialogue, reflète les modifications des paramètres. Une actualisation (F5) est nécessaire lorsque les paramètres changent.
Configuration des paramètres généraux de l’impression
Les paramètres de base de l’impression sont configurés dans l’onglet General de la boîte de dialogue Print.
Les paramètres de cet onglet comprennent :
- Les paramètres de l’imprimante et des préréglages (notez que lorsque vous accédez à la boîte de dialogue Print depuis un fichier OutJob, le champ Printer n’est pas configurable, car les paramètres de l’imprimante sont définis dans le fichier OutJob lui-même).
- Les paramètres de page, notamment le mode de couleur à utiliser pour l’impression (niveaux de gris, monochrome ou couleur), le format et l’orientation de la page.
- Les paramètres d’échelle et de position.
- La zone du document PCB à imprimer (la feuille entière ou une zone spécifique pouvant être définie en saisissant les coordonnées de ses points opposés ou de manière interactive dans le document PCB).
Ajout d’une nouvelle page
Une nouvelle page d’impression peut être ajoutée à la configuration actuelle en cliquant sur le bouton Add Page dans l’onglet Pages de la boîte de dialogue.

Ajout d’une nouvelle page à l’impression.
La page sera ajoutée sous les impressions existantes et recevra le nom par défaut New PrintOut. Utilisez Move Page Up/Move Page Down (accessible en cliquant sur pour déplacer la page sélectionnée vers le haut ou vers le bas dans la liste, ce qui modifie l’ordre d’impression des pages.
Configuration d’une page
Une page d’impression nouvellement ajoutée peut être configurée (et la configuration d’une page existante peut être modifiée) dans la zone Printout Properties associée, lorsque la page est sélectionnée dans la liste des pages de l’onglet Pages de la boîte de dialogue.

Configurez la page sélectionnée dans la zone Printout Properties de la boîte de dialogue.
Les options et commandes suivantes sont disponibles lors de la configuration de la page sélectionnée :
- La commande Edit (accessible en cliquant sur permet de modifier le nom de la page selon les besoins afin de lui attribuer un nom plus explicite, permettant d’identifier facilement sa nature et sa fonction.
- Les options situées sous le nom de la page peuvent être activées pour contrôler les composants inclus dans les impressions associées (par exemple, pour afficher ou non les composants montés en surface), ainsi que d’autres aspects de l’affichage (comme l’affichage des couches en miroir).
- La zone Pad Display Options propose des options permettant de contrôler l’affichage des pastilles sur l’impression, c’est-à-dire d’afficher ou non les numéros des pastilles et les nets associés.
- L’option Pad Font Size permet de déterminer la taille de la police utilisée pour les numéros des pastilles et le texte des nets.
Gestion des couches d’une page
Le « cœur » de la configuration d’une page est la zone de gestion des couches de la boîte de dialogue Print, qui fournit les commandes nécessaires pour définir l’ensemble des couches de la page, ordonner les couches qui la composent et configurer les paramètres de chaque couche. Pour accéder à cette zone, sélectionnez une page dans la liste de l’onglet Pages de la boîte de dialogue, puis cliquez sur le bouton Edit Layer, ou double-cliquez directement sur la page dans la liste.

Configurez les couches de la page sélectionnée en accédant à la zone appropriée de la boîte de dialogue Print.
Configuration d’une couche
Une couche de l’ensemble de couches d’une page d’impression peut être configurée dans la zone Settings associée lorsqu’elle est sélectionnée dans la liste des couches.

Configurez la couche sélectionnée dans la zone Settings.
Les options et commandes suivantes sont disponibles pour configurer la couche sélectionnée :
- First Drill Layer – utilisez la liste déroulante pour définir la couche de départ de la paire de perçage souhaitée. La liste déroulante répertorie toutes les couches de signal et de plan interne disponibles définies dans l’empilage des couches du circuit imprimé.
- Last Drill Layer – utilisez la liste déroulante pour définir la couche d’arrivée de la paire de perçage souhaitée. La liste déroulante répertorie toutes les couches de signal et de plan interne disponibles définies dans l’empilage des couches du circuit imprimé.
- Configure Drill Symbols – cliquez pour ouvrir la boîte de dialogue Drill Symbol, dans laquelle vous pouvez attribuer des symboles ou des lettres à chaque diamètre de perçage.
- Free Primitives – sélectionnez cette option pour déterminer comment les primitives libres d’une couche sont affichées sur l’impression.
- Component Primitives – sélectionnez cette option pour déterminer comment les primitives des composants d’une couche sont affichées sur l’impression.
- Other – sélectionnez cette option pour déterminer comment les autres objets d’une couche sont affichés sur l’impression.
Prenons, par exemple, un plan d’assemblage comprenant les couches suivantes :
- Sérigraphie des composants
- Couche supérieure (pour les pastilles de montage en surface)
- Multicouche (pour les pastilles traversantes)
La couche supérieure serait configurée pour afficher les primitives des composants afin que les pastilles de montage en surface soient visibles, et pour masquer les primitives libres afin que le routage ne soit pas visible. La couche multicouche serait également configurée pour afficher les primitives des composants afin que les pastilles des composants traversants soient visibles, et pour masquer les primitives libres afin que les vias ne soient pas visibles.
Configuration des paramètres avancés de l’impression
Les paramètres avancés de l’impression se configurent dans l’onglet Advanced de la boîte de dialogue Print.

Les paramètres avancés de l’impression se configurent dans l’onglet Advanced de la boîte de dialogue Print.
Les paramètres de cet onglet comprennent :
- Designator Print Settings – sélectionnez le type d’informations de repérage à inclure dans les impressions.
- L’option Print Keepout Objects vous permet de contrôler entièrement l’inclusion ou non des objets de conception de zone interdite dans le document imprimé.
- Remplacement des polices – chacune des trois polices standard utilisées dans l’éditeur PCB (Default, Serif et SansSerif) peut être remplacée par une autre police Windows lors de la génération de l’impression. Utilisez les options de la zone Replace Stroke fonts by TT fonts pour activer le remplacement des polices et choisir les polices.
- Paramètres de couleur – utilisez les commandes de la zone Color Settings pour définir les paramètres globaux de couleur à utiliser pour l’impression actuelle. Les options permettent notamment d’utiliser la couleur de substitution du net plutôt que celle de la couche (option Use Net override color) et d’appliquer les couleurs configurées pour la conception du circuit imprimé dans l’éditeur PCB (bouton Retrieve Layer Colors from PCB). Des commandes permettent également de définir la configuration de couleurs actuelle comme configuration par défaut et de rétablir la configuration par défaut.
Options et commandes de la boîte de dialogue d’impression pour les impressions PCB 2D
Onglet Général
L’onglet General propose des options pour configurer votre imprimante et les paramètres de page.
Paramètres d’impression et de préréglages
-
Printer – ce champ indique l’imprimante actuelle à laquelle la sortie imprimée sera envoyée. Utilisez la liste déroulante pour choisir une autre imprimante parmi celles actuellement installées sur votre ordinateur. Cliquez sur le bouton
pour accéder aux options suivantes :
- Printer Settings – permet d’ouvrir la boîte de dialogue des propriétés du document Microsoft Print to PDF, dans laquelle vous pouvez configurer les fichiers d’imprimante en fonction de votre imprimante ou de votre système d’exploitation.
- Set as Default – permet de définir l’imprimante sélectionnée comme imprimante par défaut.
- Add Printer – permet d’ajouter une imprimante depuis votre système Windows.
-
Print to file – permet de créer un dossier Out dans votre projet. Vous pouvez générer des fichiers (
*.ini) pour toutes les pages et exporter toutes les pages au format (*.emf).
- Copies – utilisez ce champ pour indiquer le nombre d’exemplaires de la page (ou de l’ensemble de pages) à imprimer.
-
Print Range – utilisez les commandes de cette zone pour indiquer les pages à imprimer lorsque la tâche d’impression prévue comprend plusieurs pages. Choisissez l’une des options suivantes :
- All Pages – activez cette option pour imprimer toutes les pages de la sortie d’impression en cours de génération.
- Pages From – activez cette option pour imprimer une plage de pages. Utilisez les champs pour indiquer la première et la dernière page (incluses) de la plage souhaitée.
Paramètres de page
- Color Set – utilisez cette option pour choisir le jeu de couleurs à utiliser pour la sortie imprimée. Les jeux de couleurs disponibles sont : Gray, Mono et Color.
- Page Size – sélectionnez un format de papier dans la liste déroulante.
- Orientation – utilisez ces options pour choisir l’impression en orientation Portrait ou Landscape.
Paramètres d’échelle et de position
-
Scale Mode – utilisez la liste déroulante pour sélectionner le mode de mise à l’échelle souhaité. Choisissez entre
Actual SizeetFit On Page. -
Scale – ce champ est disponible lorsque Scale Mode est défini sur
Actual Size. Utilisez-le pour définir le facteur de mise à l’échelle du document. Une valeur supérieure à1agrandit l’impression (effet de zoom avant), tandis qu’une valeur inférieure à1la réduit (effet de zoom arrière). - Horizontal Offset – permet d’ajuster manuellement la position horizontale du contenu imprimé sur la page. Saisissez une valeur positive pour déplacer le contenu imprimé vers la droite de la page, ou une valeur négative pour le déplacer vers la gauche. Si ce champ est défini sur zéro, la marge gauche horizontale minimale requise par l’imprimante est utilisée. Activez l’option Center pour centrer automatiquement le contenu imprimé horizontalement sur la page.
- Vertical Offset – permet d’ajuster manuellement la position verticale du contenu imprimé sur la page. Saisissez une valeur positive pour déplacer le contenu imprimé vers le haut de la page, ou une valeur négative pour le déplacer vers le bas. Si ce champ est défini sur zéro, la marge inférieure verticale minimale requise par l’imprimante est utilisée. Activez l’option Center pour centrer automatiquement le contenu imprimé verticalement sur la page.
Zone à imprimer
-
Type – utilisez les commandes de cette zone pour définir la zone du circuit imprimé à imprimer. Choisissez parmi les options suivantes :
- Entire Sheet – imprime l’intégralité du circuit imprimé.
-
Specific Area – imprime uniquement la zone définie. Lorsque cette option est activée, les commandes suivantes deviennent disponibles :
- Start Point (X/Y) – utilisez ces champs pour définir les coordonnées X et Y du coin inférieur gauche de la zone à imprimer.
- End Point (X/Y) – utilisez ces champs pour définir les coordonnées X et Y du coin supérieur droit de la zone à imprimer.
- Select Area on PCB – utilisez ce bouton pour définir de manière interactive la zone à imprimer dans l’espace de conception du document PCB.
Onglet Pages
L’onglet Pages comprend des options d’affichage et de gestion des paramètres des couches, et permet d’ajouter ou de supprimer des pages.
-
Add Page – cliquez sur ce bouton pour ajouter une page avec les paramètres par défaut et sans aucune couche sélectionnée. Cliquez sur la flèche de menu déroulant associée au bouton pour accéder aux options suivantes :
- Create Final – permet de créer rapidement un jeu complet et prédéfini d’impressions des typons finaux pour le document PCB source.
- Create Composite – permet de créer rapidement une impression composite multicouche prédéfinie pour le document PCB source.
- Create Power-Plane Set – permet de créer rapidement des dessins prédéfinis des plans d’alimentation pour le document PCB source.
- Create Mask Set – permet de créer rapidement des dessins prédéfinis des masques de soudure et de pâte à braser pour le document PCB source.
- Create Drill Drawings – permet de créer rapidement un ensemble prédéfini de plans et de guides de perçage pour le document PCB source.
- Create Assembly Drawings – permet de créer rapidement des plans d’assemblage prédéfinis pour le document PCB source.
- Create Composite Drill Guide – permet de créer rapidement un plan de perçage composite prédéfini pour le document PCB source.
-
Page list – liste des pages à imprimer. Chaque page est représentée par une vignette donnant accès aux options suivantes :
-
– utilisez le bouton à points de suspension pour accéder aux options de gestion de la page :
- Edit – utilisez cette option pour renommer la page et lui donner un nom plus explicite permettant d’identifier facilement sa nature et son objectif.
- Move Page Up / Move Page Down – utilisez ces options pour modifier la position de la page dans la liste, ce qui modifie l’ordre de rendu à l’impression.
- Delete Page – utilisez cette option pour supprimer la page de la liste.
-
Printout Properties – utilisez la commande de droite pour accéder aux différentes options de propriétés d’impression. Selon l’état de ces options, la commande apparaît sous la forme Default ou Custom. Ces options permettent de choisir les composants à inclure dans les impressions associées (par exemple, d’afficher ou non les composants montés en surface), ainsi que de définir des paramètres supplémentaires (comme l’affichage en miroir des couches et la taille de la police utilisée pour les numéros de pastilles et les textes des nets).
-
Displayed Layers – utilisez la commande de droite pour accéder aux options de gestion de la liste des couches et de leurs paramètres d’affichage pour la page actuelle. Les nombres indiqués dans cette commande représentent le nombre de couches sélectionnées pour la page par rapport au nombre total de couches du PCB.
-
– utilisez cette commande pour basculer entre le mode Displayed Layers, qui permet de sélectionner les couches à imprimer, et le modeDisplayed Layer Order, qui permet de définir l’ordre des couches sélectionnées.-
En mode
Displayed Layers, utilisez l’icône
/
d’une couche ou d’un groupe de couches pour l’activer ou le désactiver pour la page actuelle.
-
En mode
Displayed Layer Order, utilisez les boutons
pour déplacer la couche sélectionnée vers le haut ou vers le bas dans la liste.
-
En mode
-
– cliquez pour accéder au champ de recherche. Commencez à saisir du texte dans ce champ pour afficher uniquement les couches dont le nom contient la chaîne recherchée.
- Cliquez sur le bouton de couleur pour modifier la couleur de cette couche.
-
Cliquez sur le nom d’une couche activée pour afficher la fenêtre contextuelle des paramètres, dans laquelle vous pouvez configurer des paramètres supplémentaires pour la couche sélectionnée.
- First Drill Layer / Last Drill Layer – utilisez ces champs pour spécifier les couches de départ et d’arrivée de la paire de perçage souhaitée. Les listes déroulantes répertorient toutes les couches de signal et de plans internes disponibles définies dans l’empilage des couches du circuit imprimé.
- Configure Drill Symbols – cliquez sur cette commande pour ouvrir la boîte de dialogue Drill Symbol, dans laquelle vous pouvez attribuer des symboles ou des lettres à chaque diamètre de perçage.
-
Free Primitives – cette liste déroulante propose des commandes permettant de définir l’affichage des primitives libres d’une couche à l’impression. Pour les objets primitifs libres suivants, utilisez le champ déroulant associé pour choisir d’afficher l’objet entièrement (
Full), uniquement sous forme de contour (Draft) ou de le masquer (Hide). ChoisissezSelect Primitivepour définir des paramètres individuels pour chaque type d’objet concerné. -
Component Primitives – cette liste déroulante propose des commandes permettant de définir l’affichage des primitives de composants d’une couche à l’impression. Pour les objets primitifs de composants suivants, utilisez le champ déroulant associé pour choisir d’afficher l’objet entièrement (
Full), uniquement sous forme de contour (Draft) ou de le masquer (Hide). ChoisissezSelect Primitivepour définir des paramètres individuels pour chaque type d’objet concerné. -
Other – cette zone propose des commandes permettant de définir l’affichage des autres objets d’une couche à l’impression. Pour les objets suivants, utilisez le champ déroulant associé pour choisir d’afficher l’objet entièrement (
Full), uniquement sous forme de contour (Draft) ou de le masquer (Hide). ChoisissezSelect Primitivepour définir des paramètres individuels pour chaque type d’objet concerné.
-
-
Onglet Avancé
L’onglet Advanced propose des options de paramétrage des désignateurs ainsi que des options de police et de couleur.
Paramètres d’impression des désignateurs
Utilisez la commande de cette zone pour spécifier le type d’informations de désignateur à inclure dans les impressions. Dans la liste déroulante, choisissez Print Physical Designators ou Print Logical Designators.
Options
Print Keepout Objects – activez cette option pour inclure dans le document imprimé les objets de conception définis comme zones d’exclusion.
Remplacer les polices vectorielles par des polices TrueType
- Enable Fonts Replacement – cochez cette case pour activer le remplacement des polices.
- Default – cochez cette case pour utiliser les paramètres par défaut. Vous pouvez utiliser la liste déroulante pour modifier la police.
- Serif – cochez cette case pour utiliser la police avec empattement. Vous pouvez utiliser la liste déroulante pour modifier la police.
- Sans Serif – cochez cette case pour utiliser la police sans empattement. Vous pouvez utiliser la liste déroulante pour modifier la police.
Paramètres des couleurs
- Use Net override color – activez cette option pour utiliser la couleur des nets dans les impressions plutôt que celle des couches.
- Retrieve Layer Colors from PCB – cliquez sur ce bouton pour imprimer avec les couleurs configurées pour la conception du PCB dans PCB Editor.
- Save as Default – cliquez pour remplacer le jeu de couleurs par défaut par votre jeu de couleurs local.
Menu contextuel de l’aperçu
Cliquez avec le bouton droit dans la zone d’aperçu pour accéder au menu suivant :
- Copy – utilisez cette commande pour copier l’aperçu actuel dans le Presse-papiers Windows.
- Zoom In – utilisez cette commande pour effectuer un zoom avant par incréments.
- Zoom Out – utilisez cette commande pour effectuer un zoom arrière par incréments.
- Show Print Region – utilisez cette commande pour afficher la zone qui sera imprimée.
- Show Grid – utilisez cette commande pour afficher le quadrillage dans la zone d’aperçu. Notez que le quadrillage n’apparaîtra pas sur l’impression.
- Export to Image – utilisez cette commande pour exporter l’aperçu actuel sous forme d’image (PNG, JPEG, BMP, GIF, WMF, EMF).
Commandes supplémentaires
Set as Default – permet de définir les paramètres prédéfinis des onglets Pages et Advanced de la boîte de dialogue comme paramètres par défaut.
Préparation des sorties d’impression 3D du PCB
La boîte de dialogue PCB 3D Print Settings vous permet de sélectionner ou de créer des impressions 3D de votre PCB à inclure dans le fichier de tâches de sortie. N’oubliez pas que vous pouvez disposer de plusieurs instances d’une même impression (utilisez pour cela la commande Add New Documentation Output du fichier OutJob, dans la zone Output Containers), ce qui est particulièrement utile en 3D, car vous pouvez ainsi imprimer des vues de la carte sous différents angles.

La boîte de dialogue PCB 3D Print Settings
La boîte de dialogue est divisée en quatre zones :
- Render Resolution – comprend des options de qualité de l’« image » du modèle 3D à imprimer. Les résolutions disponibles ne dépendent pas de l’imprimante.
- View to Print – vous permet de sélectionner des vues à plat de la carte, c’est-à-dire avec une perspective de caméra perpendiculaire à la carte, depuis le dessus ou le dessous, ou une vue Custom.
- View Configuration – vous permet d’appliquer la configuration de vue actuelle concernant les couleurs des surfaces, la visibilité, l’opacité et l’épaisseur de la carte.
- Preview – vous montre exactement ce qui sera imprimé.
Options et commandes de la boîte de dialogue des paramètres d’impression 3D du PCB
Résolution du rendu
Utilisez cette zone pour spécifier la qualité du modèle 3D à imprimer en termes de résolution. Les résolutions prises en charge sont 75 DPI, 150 DPI, 300 DPI et 600 DPI.
Vue à imprimer
Utilisez cette zone pour sélectionner la vue de la carte à imprimer. Choisissez parmi les options suivantes :
- Entire Board From Above – choisissez cette option pour imprimer la vue 3D de la carte directement depuis le dessus (la perspective de la caméra est perpendiculaire à la carte).
- Entire Board From Below – choisissez cette option pour imprimer la vue 3D de la carte directement depuis le dessous (la perspective de la caméra est perpendiculaire à la carte).
- Custom – choisissez cette option, puis cliquez sur Take Current Camera Position pour imprimer la vue 3D de la carte telle qu’elle est actuellement affichée dans l’éditeur de PCB.
Configuration de la vue
Cliquez sur Take Current View Configuration pour appliquer les paramètres actuels de configuration de la vue de l’espace de conception concernant les couleurs des surfaces, la visibilité, l’opacité et l’épaisseur de la carte.
Format d’image pour la sortie vers un dossier
Utilisez le menu déroulant pour sélectionner le format d’image de l’impression générée. Choisissez parmi .bmp, .jpg et .png.
Aperçu
Cette zone affiche un aperçu de ce qui sera imprimé. Il est mis à jour dynamiquement à mesure que des modifications sont apportées dans les zones View to Print et/ou View Configuration de la boîte de dialogue.
Création d’impressions 3D personnalisées
Une vue personnalisée de votre carte peut présenter celle-ci sous un angle donné, avec un zoom et différents paramètres de couleurs des surfaces, de visibilité, d’opacité et d’épaisseur de carte. Vous pouvez utiliser ces options pour générer des vues très détaillées afin de mettre en évidence certaines zones de votre conception, voire de créer des effets.
Pour créer une vue 3D personnalisée de votre carte à imprimer, procédez comme suit :
- Accédez à la fenêtre de l’éditeur de PCB et passez en mode 3D (raccourci : 3).
- Utilisez les commandes de vue 3D pour obtenir la perspective souhaitée.
- Revenez au fichier de tâches de sortie et double-cliquez n’importe où sur la ligne PCB 3D Print (ou cliquez dessus avec le bouton droit et sélectionnez Configure dans le menu contextuel) pour ouvrir la boîte de dialogue PCB 3D Print Settings.
- Cliquez sur l’option Custom, puis sur le bouton Take Current Camera Position. Le volet Preview est mis à jour avec la nouvelle perspective.
- Cliquez sur OK pour appliquer le paramètre personnalisé à l’impression 3D actuelle du PCB.
Si vous souhaitez appliquer des couleurs de surfaces personnalisées, etc., procédez comme suit :
- Accédez à la fenêtre de l’éditeur de PCB et ouvrez le panneau Configuration de la vue (View » Panels » View Configuration dans les menus principaux, ou cliquez sur le bouton Panels en bas à droite de l’éditeur principal et sélectionnez View Configuration, ou utilisez le raccourci L.
- Définissez les options souhaitées. Notez que vous n’avez pas besoin d’enregistrer les options pour les appliquer à une impression 3D du PCB.
- Revenez au fichier de tâches de sortie, ouvrez la boîte de dialogue PCB 3D Print Settings, activez l’option Custom, puis cliquez sur le bouton Take Current View Configuration. Le volet Preview est mis à jour avec les nouveaux paramètres de configuration de la vue. Une fois appliquée, la configuration de la vue s’applique à toutes les options View to Print.
- Cliquez sur OK pour appliquer la configuration de la vue à l’impression 3D actuelle du PCB.
- Enregistrez le fichier OutJob pour conserver les nouvelles impressions 3D.
Préparation des sorties d’impression Draftsman
Des sorties d’impression Draftsman peuvent être ajoutées au fichier de tâches de sortie actif en sélectionnant une option dans le menu Draftsman de la commande [Add New Documentation Output] dans la zone Documentation Outputs du fichier, ou dans le sous-menu Edit » Add Documentation Outputs » Draftsman des menus principaux.
Cliquez avec le bouton droit sur la sortie souhaitée, puis choisissez Page Setup pour accéder à la boîte de dialogue PCBDrawing Properties dans laquelle vous pouvez configurer les paramètres de papier, de mise à l’échelle et de couleur de l’impression.
Lors de la génération d’une sortie directement depuis Draftsman à l’aide de la commande de menu File » Print, la boîte de dialogue Print permet de configurer la sortie.
Options et commandes de la boîte de dialogue d’impression pour les impressions Draftsman
Onglet Général
L’onglet General propose des options permettant de configurer votre imprimante et les paramètres de page.
-
Printer – ce champ indique l’ imprimante actuelle vers laquelle la sortie imprimée sera envoyée. Utilisez la liste déroulante pour choisir une autre imprimante parmi celles installées sur votre ordinateur. Cliquez sur le bouton
pour accéder aux options suivantes :
- Printer Settings – permet d’ouvrir la boîte de dialogue des propriétés du document Microsoft Print to PDF, dans laquelle vous pouvez configurer les fichiers d’impression en fonction de votre imprimante ou de votre système d’exploitation.
- Set as Default – permet de définir l’imprimante sélectionnée comme imprimante par défaut.
- Add Printer – permet d’ajouter une imprimante depuis votre système Windows.
-
Print to file – permet de créer un dossier Out dans votre dossier de projet. Vous pouvez générer des fichiers (
*.ini) pour toutes les pages et exporter toutes les pages au format (*.emf).
- Copies – utilisez ce champ pour spécifier le nombre de copies de la page (ou de l’ensemble de pages) à imprimer.
-
Print Range – utilisez les commandes de cette zone pour spécifier les pages à imprimer lorsque la tâche d’impression prévue comporte plusieurs pages. Choisissez l’une des options suivantes :
- All Pages – activez cette option pour imprimer toutes les pages de la sortie d’impression en cours de génération.
- Pages From – activez cette option pour imprimer une plage de pages. Utilisez les champs pour spécifier les pages de début et de fin (incluses) de la plage souhaitée.
Paramètres de page
- Page Size – sélectionnez un format de papier dans la liste déroulante.
- Orientation – utilisez ces options pour choisir l’orientation d’impression : Portrait ou Landscape.
Paramètres d’échelle et de position
-
Scale Mode – utilisez la liste déroulante pour sélectionner le mode de mise à l’échelle souhaité. Choisissez entre
Actual SizeetFit On Page. -
Scale – ce champ est disponible lorsque Scale Mode est défini sur
Actual Size. Utilisez-le pour définir le facteur de mise à l’échelle du document. Une valeur supérieure à1agrandit l’impression (effet de zoom avant), tandis qu’une valeur inférieure à1la réduit (effet de zoom arrière).
Menu contextuel de l’aperçu
Effectuez un clic droit dans la zone d’aperçu pour accéder au menu suivant :
- Copy – utilisez cette commande pour copier l’aperçu actuel dans le Presse-papiers Windows.
- Zoom In – utilisez cette commande pour effectuer un zoom avant par incréments.
- Zoom Out – utilisez cette commande pour effectuer un zoom arrière par incréments.
- Show Print Region – utilisez cette commande pour afficher la zone qui sera imprimée.
- Show Grid – utilisez cette commande pour afficher les lignes de grille dans la zone d’aperçu. Notez que ces lignes ne figureront pas sur votre impression.
Préparation des documents à imprimer avec l’assistant Smart PDF
Le Smart PDF Wizard génère un seul fichier PDF pour un ou plusieurs documents sélectionnés ou pour l’ensemble du projet, y compris les schémas, le PCB et la nomenclature. Des signets PDF sont créés pour chaque net et chaque composant de la conception. Vous pouvez enregistrer les paramètres Smart PDF dans un fichier OutJob afin de régénérer votre PDF en un seul clic.
Le Smart PDF Wizard se lance en sélectionnant File » Smart PDF dans les menus principaux.
Après le lancement de la commande, le Smart PDF Wizard s’affiche. Parcourez les pages successives et intuitives de l’assistant afin de rassembler toutes les informations nécessaires pour exporter efficacement votre conception dans un seul document PDF, selon vos besoins. L’assistant permet :
- De documenter le document actif, certains documents ou tous les documents du projet, y compris les schémas, le PCB et la nomenclature.
- De configurer les paramètres d’impression lors de l’exportation d’un document PCB.
- D’ajouter des informations supplémentaires, notamment des informations sur les nets (ajoutées sous forme de signets de broches, d’étiquettes de net et/ou de ports), les paramètres des composants et des signets globaux pour les composants et les nets.
- De contrôler le rendu des couleurs des schémas et du PCB : couleur, niveaux de gris ou monochrome.
- De gérer les éléments spécifiques à inclure dans les feuilles de schéma ou à en exclure : marqueurs No ERC, jeux de paramètres, sondes, zones de couverture (Blankets) et notes.
- De définir une qualité d’impression, exprimée en dots per inch (dpi).
- De choisir d’exporter la conception logique ou physique. Pour cette dernière, vous pouvez sélectionner la variante de conception utilisée et choisir d’utiliser ou non les noms physiques développés pour les différents identifiants de nets.
- D’enregistrer les paramètres dans un fichier de configuration Output Job (*.OutJob) : vous pouvez ainsi publier la même tâche avec les mêmes paramètres autant de fois que nécessaire, sans devoir parcourir l’assistant à chaque fois.
Une fois les différentes pages de l’assistant configurées selon vos besoins, cliquez sur Finish pour générer le PDF. Si vous avez choisi d’ouvrir le PDF après sa génération, il s’affichera dans le lecteur Acrobat Reader par défaut installé sur votre PC. Le PDF généré regroupe les documents selon leur type : schéma, PCB ou nomenclature :
- Pour chaque schéma, des signets sont créés selon vos paramètres afin de vous permettre de parcourir les documents ainsi que les composants et les nets qu’ils contiennent. Si les schémas sources sont hiérarchiques, cette hiérarchie est reproduite dans les signets PDF : la feuille de niveau supérieur apparaît à un niveau et toutes les sous-feuilles apparaissent sous forme de sous-signets. Si vous avez activé l’option Use Physical Structure lors de l’exportation, le document PDF obtenu contiendra des feuilles distinctes pour chaque canal d’une conception multicanal.
- Pour un document PCB, des signets sont créés pour chacune des impressions exportées.
- Pour la nomenclature, des signets sont créés afin de vous permettre d’accéder à chaque composant.
Si vous avez activé les paramètres de signets supplémentaires pour générer les informations de net relatives aux broches, aux étiquettes de net et aux ports, vous verrez ces informations lorsque vous parcourrez un schéma ou un PCB (broches uniquement).
Un clic sur un signet effectue un zoom sur la zone du document où se trouve l’objet correspondant. Le niveau de zoom appliqué est déterminé par la position du curseur de zoom configurée dans l’assistant. Dans la mesure du possible, l’objet est centré dans la fenêtre d’affichage principale du lecteur PDF. Une surbrillance est appliquée lors de la navigation par composants, broches, ports ou étiquettes de net afin de faciliter leur repérage.
Options et commandes de l’assistant Smart PDF
Parcourez les pages du Smart PDF Wizard pour exporter la conception au format PDF.
Navigation dans l’assistant
- Cliquez sur Cancel pour fermer le Smart PDF Wizard.
- Cliquez sur Back pour revenir à l’écran précédent.
- Cliquez sur Next pour passer à l’écran suivant.
- Cliquez sur Finish à n’importe quelle étape de l’assistant pour créer un PDF avec les paramètres précédemment saisis.
Choisir la cible d’exportation
La page Choose Export Target vous permet de préciser les éléments à exporter et leur emplacement d’enregistrement. Choisissez d’exporter soit Current Project, soit Current Document. Les deux choix affichent le nom du projet actuel et du document actuel.
Utilisez la zone de texte Output File Name pour spécifier le nom du PDF et son emplacement d’enregistrement. Cliquez sur le bouton Parcourir pour ouvrir une boîte de dialogue dans laquelle vous pourrez choisir le chemin souhaité.
Choisir les fichiers du projet
Si vous avez choisi Current Project à la page précédente (Choose Export Target), la page Choose Project Files s’affiche et vous permet de préciser les documents à inclure dans votre PDF. Sélectionnez les fichiers souhaités à l’aide des fonctions standard de sélection multiple (Ctrl+click, Shift+click). Vous pouvez également utiliser les options de sélection disponibles dans le menu contextuel : Select All pour sélectionner tous les documents répertoriés, Select All PCB pour sélectionner tous les documents PCB répertoriés et Select All Schematic pour sélectionner tous les documents schématiques.
Exporter la nomenclature
Sur la page Export Bill of Materials, activez l’option Export a Bill of Materials pour exporter une nomenclature avec le PDF.
Utilisez le menu déroulant Variant pour sélectionner une variante d’assemblage et un modèle, si nécessaire.
Utilisez le menu déroulant Template pour sélectionner le modèle souhaité ou cliquez sur
pour ouvrir une boîte de dialogue standard dans laquelle vous pourrez choisir le modèle souhaité. Cochez la case Relative Path to Template File pour afficher le chemin relatif du modèle sélectionné.
Paramètres d’impression du PCB
Si vous avez choisi d’exporter des documents PCB sur la page Choose Project Files, la page PCB Printout Settings s’affiche et vous permet de configurer l’impression.
Cette page comporte trois zones principales (décrites en détail ci-dessous) :
- Printouts & Layers Grid - permet de configurer l’impression de chaque couche.
- Designator Print Settings - permet de configurer les données des repères de composants à imprimer.
- Area to Print - permet de définir la zone à imprimer.
Tableau des impressions et des couches
Cochez les cases Include Components et Printout Options souhaitées pour Multilayer Composite Print.
Menu contextuel
Utilisez le menu contextuel pour configurer plus précisément l’impression de chaque couche. Ce menu propose les options suivantes :
- Create Final - permet de créer un jeu complet de typons définitifs. Une boîte de dialogue vous demande confirmation avant de poursuivre.
- Create Composite - permet de créer un jeu d’impressions composites multicouches. Une boîte de dialogue vous demande confirmation avant de poursuivre.
- Create Power-Plane Set - permet de créer un jeu de dessins des plans d’alimentation. Une boîte de dialogue vous demande confirmation avant de poursuivre.
- Create Mask Set - permet de créer des dessins des masques de pâte à braser et de soudure. Une boîte de dialogue vous demande confirmation avant de poursuivre.
- Create Drill Drawings - permet de créer un jeu de plans et de guides de perçage. Une boîte de dialogue vous demande confirmation avant de poursuivre.
- Create Assembly Drawings - permet de créer des plans d’assemblage. Une boîte de dialogue vous demande confirmation avant de poursuivre.
- Create Composite Drill Guide - permet de créer un plan de perçage composite. Une boîte de dialogue vous demande confirmation avant de poursuivre.
-
Insert Printout - permet d’insérer une nouvelle impression en haut de la liste. Les noms des nouvelles impressions sont numérotés séquentiellement sous la forme New Printout x, où x vaut 1, 2, 3,, etc. Pour renommer une nouvelle impression, cliquez dans le champ Name et saisissez le nouveau nom souhaité.
-
Insert Printout Set - permet d’insérer un nouvel élément Printout Set for Class All Layers.
-
Insert Drill Printout Set - permet d’insérer un nouvel élément Drill Guide Printout Set.
-
Insert Layer - permet d’insérer une nouvelle couche. La boîte de dialogue Layer Properties s’ouvre et vous permet de configurer la nouvelle couche.

La boîte de dialogue Layer Properties -
Insert Layer Class - permet d’insérer une nouvelle classe de couches. La boîte de dialogue Layer Class Properties s’ouvre et vous permet de configurer la nouvelle classe de couches.

La boîte de dialogue Layer Class Properties -
Move Up - déplace la couche sélectionnée d’une position vers le haut dans la liste.
-
Move Down - déplace la couche sélectionnée d’une position vers le bas dans la liste.
-
Delete - supprime la couche sélectionnée.
-
Properties - permet d’ouvrir la boîte de dialogue Layer Properties dans laquelle vous pouvez modifier les propriétés de la couche sélectionnée.
-
Preferences - permet d’ouvrir la boîte de dialogue PCB Print Preferences dans laquelle vous pouvez modifier les préférences d’impression.

La boîte de dialogue PCB Print Preferences
Paramètres d’impression des repères
Utilisez le menu déroulant pour sélectionner les données des repères de composants à imprimer. Les choix proposés sont les suivants :
- Print Physical Designators
- Print Logical Designators
Zone à imprimer
-
Entire Sheet - sélectionnez cette option pour imprimer la feuille entière.
-
Specific Area - sélectionnez cette option pour imprimer des zones spécifiques. Utilisez les commandes disponibles pour configurer la zone, puis utilisez Define pour définir la zone d’impression.
Commandes supplémentaires
-
Preferences - cliquez pour ouvrir la boîte de dialogue PCB Print Preferences dans laquelle vous pouvez configurer les préférences d’impression.
Paramètres PDF supplémentaires
La page Additional PDF Settings propose plusieurs options d’exportation supplémentaires :
- Zoom - utilisez le curseur pour régler le niveau de zoom utilisé dans le PDF lors de la navigation parmi les composants et les nets.
- Additional Information - permet de déterminer si les informations sur les nets sont générées dans le PDF. Si cette option est activée, vous pouvez choisir de générer ou non des signets supplémentaires dans le PDF pour les nets de Pins, Net Labels et Ports.
-
Include Component Parameters - activez cette option pour inclure les paramètres des composants. Consultez la section Component Parameters in PDF Output ci-dessous pour plus d’informations sur l’utilisation de cette option.
-
Exclusions - cliquez pour ouvrir la boîte de dialogue Exclude Parameters dans laquelle vous pouvez choisir les paramètres à exclure du PDF généré.
La boîte de dialogue Exclude Parameters
- Parameter Names - saisissez le nom du ou des paramètres à exclure.
- Add - cliquez sur ce bouton pour ajouter le ou les paramètres saisis.
-
- cliquez sur ce bouton pour supprimer le paramètre sélectionné.
-
- Global Bookmarks for Components and Nets - activez cette option pour utiliser des signets globaux pour les composants et les nets. Les signets globaux créés se trouvent sous la liste des feuilles de schéma incluses dans le PDF généré.
-
Schematics include - utilisez les cases à cocher pour inclure (case cochée) ou exclure (case décochée) les éléments suivants dans le PDF :
-
No ERC Markers - détermine si les marqueurs de directive No ERC sont inclus lors de l’exportation des feuilles de schéma. Lorsque cette case est cochée, les options suivantes sont disponibles :
-
Thin Cross
-
Thick Cross
-
Small Cross
-
Checkbox
-
Triangle
-
-
Parameter Sets - détermine si les objets de type ensemble de paramètres sont inclus lors de l’exportation des feuilles de schéma.
-
Probes - détermine si les objets de type sonde sont inclus lors de l’exportation des feuilles de schéma.
-
Blankets - détermine si les zones de couverture sont incluses lors de l’exportation des feuilles de schéma.
-
Notes - détermine si les notes sont incluses lors de l’exportation des feuilles de schéma.
-
Collapsed notes - détermine si les notes sont incluses lors de l’exportation des feuilles de schéma.
-
-
- Schematics Color Mode - permet de définir le mode de couleur utilisé lors de l’exportation des feuilles de schéma. Choisissez entre Color, Greyscale et Monochrome. Cette option est accessible uniquement lors de l’exportation de documents schématiques.
- PCB Color Mode - permet de définir le mode de couleur utilisé lors de l’exportation des impressions de PCB. Choisissez entre Color, Greyscale et Monochrome. Cette option est accessible uniquement lors de l’exportation de documents PCB.
-
Quality - utilisez la liste déroulante pour sélectionner la qualité souhaitée pour l’impression PDF. Les choix proposés sont les suivants :
- High (600 dpi)
- Medium (300 dpi)
- Low (150 dpi)
- Draft (75 dpi)
Configurer les paramètres de structure
La page Structure Settings permet de configurer la structure du PDF.
Si l’option Use Physical Structure est cochée, les feuilles de schéma exportées seront développées en feuilles physiques plutôt qu’en feuilles logiques. Si cette option n’est pas cochée, aucune autre option n’est disponible.
Utilisez la liste déroulante Variant pour sélectionner la variante à utiliser, si nécessaire.
Cochez les cases suivantes si vous souhaitez afficher les noms physiques développés des éléments suivants :
- Designators
-
Net Labels
- Ports and Sheet Entries
- Sheet Number Parameter
- Document Number Parameter
Dernières étapes
La page Final Steps présente quelques options de configuration supplémentaires avant la génération du PDF.
- Open PDF file after export - activez cette option pour ouvrir le PDF généré une fois l’exportation terminée.
- Save Settings to Output Job document - activez cette option pour enregistrer vos paramètres dans un document de tâche de sortie. En activant cette option, vous pouvez publier la même tâche avec les mêmes paramètres à plusieurs reprises sans utiliser l’ assistant Smart PDF.
- File Name of Output Job Document - indiquez le nom du fichier du document de tâche de sortie, ainsi que son chemin d’accès. Vous pouvez choisir d’écraser un document de tâche de sortie existant ou d’en créer un nouveau.
- Open Output Job file after export - activez cette option pour ouvrir le fichier de tâche de sortie après l’exportation du PDF.
L’éditeur OutputJob
Vos paramètres Smart PDF peuvent être enregistrés dans un document de tâche de sortie. Modifiez ce document dans l’éditeur OutputJob, qui devient actif lorsque le document actif est un fichier *.OutJob.
Formats de papier pour le PDF généré
Les formats de papier utilisés par le générateur PDF ne sont pas récupérés à partir de l’imprimante par défaut actuelle de Windows sur votre ordinateur. Les formats disponibles pour la génération de PDF sont fixes et indépendants de ceux proposés par l’imprimante par défaut, quel que soit le type d’imprimante choisi par défaut. Autrement dit, si vous sélectionnez le format A3 lors de la génération d’un PDF à partir d’un fichier de tâche de sortie, ce format sera conservé, même si vous définissez ensuite comme imprimante par défaut la petite imprimante à jet d’encre A4 au bout du couloir. L’imprimante PDF propose les formats de papier fixes suivants :
- A0
- A1
- A2
- A3
- A4
- A5
- A6
- A
- B
- C
- D
- E
- Legal
- Letter
- Tabloid
Paramètres de l’imprimante système
Vous pouvez également définir des formats de page personnalisés pour les sorties générées au format PDF. Les formats de page personnalisés sont définis sur la page Système - Paramètres de l’imprimante de la boîte de dialogue Preferences . Le menu déroulant associé au bouton Add de la boîte de dialogue Preferences propose différents formats personnalisés prédéfinis :
- ARCH A
- ARCH B
- ARCH C
- ARCH D
- ARCH E
- ARCH E1
- Enveloppe C5 (162 x 229 mm)
- Enveloppe DL (110 x 220 mm)
- Folio (8,5 x 13 pouces)
- JIS B1
- JIS B2
- JIS B3
- JIS B4
- JIS B5
- Ledger (17 x 11 pouces)
- Enveloppe Monarch (3,87 x 7,5 pouces)
- Enveloppe nº 10 (4,125 x 9,5 pouces)
- Note (7,5 x 10 pouces)
- Statement (5,5 x 8,5 pouces)
Choisissez une entrée pour ajouter ce format à la liste. Si vous avez besoin d’un autre format, ajoutez simplement un format prédéfini, sélectionnez son entrée dans la liste, puis cliquez sur le bouton Edit Page . Une boîte de dialogue s’affiche alors pour vous permettre de définir :
- Un Title pour le format de page personnalisé : choisissez un nom explicite, contenant par exemple la largeur et la hauteur (ainsi que les unités !), afin de le retrouver facilement.
- La Width et la Heightde la page.
- Les unités de mesure (mm ou pouces).
Les formats de page personnalisés définis seront proposés dans le menu du champ Size lors de la configuration des propriétés de page avant l’exportation au format PDF.
Indication d’un format de papier non pris en charge par la cible
Lorsque la cible d’un générateur de sortie est remplacée par une imprimante physique (copie papier) au lieu d’un conteneur de sortie PDF, il est tout à fait possible que le format de papier défini pour le générateur — dans la boîte de dialogue de propriétés correspondante (clic droit, Page Setup) — ne soit pas pris en charge par le support cible. Dans ce cas, la ligne reliant le générateur au support devient rouge.
Navigation dans le PDF généré
Le PDF généré regroupe les documents par type : schéma, PCB et nomenclature. Pour chaque schéma, des signets sont créés selon vos paramètres, ce qui vous permet de parcourir les documents ainsi que les composants et les nets qu’ils contiennent.
Si les schémas sources sont hiérarchiques, cette hiérarchie est reproduite dans les signets du PDF : la feuille de niveau supérieur apparaît à un niveau donné, et toutes les sous-feuilles apparaissent sous forme de sous-signets. Si vous avez activé l’option Use Physical Structure lors de l’exportation, le document PDF obtenu contiendra des feuilles distinctes pour chaque canal d’une conception multicanal.
Pour un document PCB, des signets sont créés pour chacune des impressions exportées.
Pour la nomenclature, des signets vous permettent d’accéder à chaque composant.
Si vous avez activé les signets supplémentaires sur la page Additional PDF Settings de l’assistant afin de générer les informations de net pour les broches, les étiquettes de net et les ports, ces informations s’afficheront lorsque vous parcourrez un schéma ou un PCB (broches uniquement).
Un clic sur un signet effectue un zoom sur la zone du document où se trouve l’objet concerné. Le niveau de zoom appliqué est déterminé par la position du curseur de zoom sur la page Additional PDF Settings. Dans la mesure du possible, l’objet est centré dans la fenêtre d’affichage principale du lecteur PDF. Une mise en surbrillance est appliquée lors de la navigation par composants, broches, ports ou étiquettes de net afin de faciliter leur repérage.
Paramètres des composants dans la sortie PDF
Altium Designer inclut les paramètres des composants dans la sortie PDF générée. Une fois le PDF généré, vous pouvez cliquer sur un composant d’une feuille et consulter ses paramètres dans une fenêtre contextuelle pratique. Si vous ne souhaitez pas autoriser la consultation des paramètres des composants de cette manière, désactivez (décochez) l’option Include Component Parameters dans la zone Additional Information de la page Additional PDF Settings.
Si un composant contient un paramètre dont la valeur est l’URL d’une page Web au format http://<siteaddress>, cette entrée sera un lien actif dans la fenêtre contextuelle des paramètres. Vous pouvez cliquer dessus pour suivre le lien et accéder à l’URL dans votre navigateur Web externe.
Remarque
Lorsque vous générez une sortie destinée à l’impression directement depuis l’éditeur approprié à l’aide de la commande de menu File » Print, cette fonctionnalité se configure indépendamment des configurations définies dans un fichier OutJob. Dans ce cas, utilisez l’onglet Impressions par défaut de la boîte de dialogue Options du projet (Project » Project Options) pour définir la configuration d’impression et la mise en page par défaut de chacune des sorties liées à l’impression pouvant être générées.

L’onglet Default Prints de la boîte de dialogue Project Options




















