Lavorare con pad e via

A colpo d'occhio

Questo articolo illustra il funzionamento di pad e via in Altium Designer, spiegando cosa sono, in cosa differiscono, dove vengono utilizzati e come vengono posizionati e modificati negli editor PCB e PCB Footprint. Presenta inoltre i principali tipi di via, descrive i flussi di lavoro per il posizionamento diretto e la conversione e accenna alle funzionalità del software per la gestione di modelli e via che influiscono sulle prestazioni. Se desideri comprendere meglio gli oggetti fondamentali dei PCB che consentono il collegamento dei componenti e l'instradamento tra strati, continua a leggere: questo articolo ti aiuterà a padroneggiare questi concetti essenziali con sicurezza.

- Imparerai la differenza pratica tra pad e via, comprese la loro struttura, la loro funzione e i principali tipi di via utilizzati nella progettazione di PCB.
- Scoprirai come posizionare, spostare, convertire e assegnare pad e via nei flussi di lavoro di Altium Designer.
- Avrai una panoramica della gestione delle proprietà di pad e via, inclusi l'utilizzo dei modelli e le principali opzioni di modifica nel pannello Properties.
Approfondisci con l'IA:

Panoramica di pad e via

I pad vengono utilizzati per fornire sia il fissaggio meccanico sia le connessioni elettriche ai pin dei componenti I pad vengono utilizzati per fornire sia il fissaggio meccanico sia le connessioni elettriche ai pin dei componenti

Un pad è un oggetto primitivo di progettazione. I pad vengono utilizzati per fissare il componente alla scheda e per creare i punti di interconnessione tra i pin del componente e le piste sulla scheda. I pad possono essere presenti su un singolo layer, ad esempio come pad per un dispositivo a montaggio superficiale, oppure possono essere pad tridimensionali a foro passante, con un corpo cilindrico lungo l'asse Z (verticale) e un'area piatta su ciascun layer di rame (orizzontale). Il corpo cilindrico del pad si forma quando la scheda viene forata e i fori vengono metallizzati durante la fabbricazione. Nel piano XY, i pad possono avere una forma circolare, rettangolare, ottagonale, rettangolare con angoli arrotondati, rettangolare con angoli smussati o personalizzata. I pad possono essere utilizzati singolarmente come pad liberi in un progetto oppure, più comunemente, nell'editor delle librerie PCB, dove vengono combinati con altre primitive per creare i footprint dei componenti.

Un via che si estende dal layer superiore (rosso) a quello inferiore (blu), collegandoli, e si collega anche a un piano di alimentazione interno (verde). 
Un via che si estende dal layer superiore (rosso) a quello inferiore (blu), collegandoli, e si collega anche a un piano di alimentazione interno (verde).

Un via è un oggetto primitivo di progettazione. I via vengono utilizzati per realizzare una connessione elettrica verticale tra due o più layer elettrici di un PCB. I via sono oggetti tridimensionali e hanno un corpo cilindrico lungo l'asse Z (verticale), con un anello piatto su ciascun layer di rame (orizzontale). Il corpo cilindrico del via si forma quando la scheda viene forata e i fori vengono metallizzati durante la fabbricazione. Nel piano XY, i via sono circolari, come i pad rotondi. La differenza principale tra un via e un pad è che, oltre a poter attraversare tutti i layer della scheda (da quello superiore a quello inferiore), un via può anche estendersi da un layer superficiale a un layer interno o tra due layer interni.

I via possono essere di uno dei seguenti tipi:

  • Thru-Hole – questo tipo di via attraversa la scheda dal layer superiore a quello inferiore e consente connessioni a tutti i layer di segnale interni.
  • Blind – questo tipo di via collega la superficie della scheda a un layer di segnale interno.
  • Buried – questo tipo di via collega un layer di segnale interno a un altro layer di segnale interno.

I tipi di via utilizzabili nel progetto sono definiti in Layer Stack Manager. Per saperne di più, consulta la pagina Definizione di via ciechi, interrati e microvia.

Le definizioni di pad e via possono anche essere memorizzate nelle librerie di modelli di pad e via; consulta la pagina Utilizzo di modelli e librerie di pad e via per saperne di più.

I modelli di pad e via non collegati a una libreria esterna di pad e via vengono memorizzati all'interno del documento PCB, consentendo tempi di caricamento più rapidi.

Questa funzionalità è disponibile quando l'opzione PCB.Performance.PadViaTemplate.LoadingOptimization è abilitata nella finestra di dialogo Impostazioni avanzate.

L'editor PCB utilizza il concetto di «istanziazione dei via», un approccio che consente di costruire la geometria di un'istanza di un via, anziché di un modello di via. Questo migliora le prestazioni riducendo sia il consumo di memoria sia il tempo di costruzione della scena.

Questa funzionalità è in fase di beta aperta ed è disponibile quando l'opzione PCB.ViaInstancing è abilitata nella finestra di dialogo Impostazioni avanzate.

Posizionamento diretto di pad e via

I pad e i via possono essere posizionati sia nell'editor PCB sia nell'editor dei footprint PCB. I via vengono generalmente posizionati automaticamente durante lo sbroglio interattivo o automatico, ma possono essere posizionati manualmente se necessario. I via posizionati manualmente vengono definiti via «liberi». Dopo aver avviato il comando di posizionamento dei pad (Place » Pad) o dei via (Place » Via), il cursore diventa una croce e si entra nella modalità di posizionamento.

  1. Posiziona il cursore, quindi fai clic o premi Enter per posizionare un pad/via.
  2. Continua a posizionare altri pad/via oppure fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento.
Un pad/via assume il nome della net se viene posizionato sopra un oggetto già collegato a una net.

Durante il posizionamento, premi il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale, a seconda della direzione iniziale del movimento.

In genere, i via non vengono posizionati manualmente, ma automaticamente durante lo sbroglio interattivo. Consulta la sezione Posizionamento dei via durante lo sbroglio interattivo per saperne di più.

I pad liberi sul layer Multi-layer possono essere convertiti in via. Un pad libero è un pad che non appartiene a un oggetto componente padre. La conversione dei pad liberi in via può essere utile quando si riconvertono manualmente i file Gerber importati nel formato PCB. Seleziona tutti i pad liberi che desideri convertire nell'area di progettazione e scegli il comando Tools » Convert » Convert Selected Free Pads to Vias dai menu principali. I pad liberi verranno convertiti in via con la stessa dimensione del foro. Il valore più alto tra tutte le coppie di dimensioni XY disponibili per il pad (corrispondenti alle dimensioni del pad sui diversi layer) verrà utilizzato come diametro del via.

È anche possibile convertire i via in pad liberi. La conversione dei via in pad liberi può essere utile quando si importano file PADS-PCB e PADS 2000, nei quali i via vengono utilizzati per collegarsi ai layer di alimentazione e di massa. Ciò consente una corretta connessione ai piani di alimentazione interni mediante pad modificabili. Seleziona tutti i via che desideri convertire nell'area di progettazione e scegli il comando Tools » Convert » Convert Selected Vias to Free Pads dai menu principali. I via verranno convertiti in pad liberi dello stesso stile (Simple, Top-Middle-Bottom o Full Stack) e con la stessa dimensione del foro. Il diametro del via viene utilizzato per le dimensioni XY del pad sui layer pertinenti. La forma del pad verrà impostata su Round.

Modifica grafica

Le proprietà dei pad e dei via non possono essere modificate graficamente, ad eccezione della posizione.

  • Per spostare un pad libero insieme alle piste collegate, fai clic sul pad e trascinalo tenendo premuto il pulsante del mouse. Le piste collegate rimarranno agganciate al pad durante lo spostamento. Nota che il pad non si sposterà se appartiene a un componente.
  • Per spostare una piazzola libera senza spostare le piste collegate nell'editor PCB o PCB Library, selezionare il comando Edit » Move » Move, quindi fare clic sulla piazzola, tenere premuto e spostarla.
  • Se si fa clic e si trascina un rettangolo di selezione attorno alle piazzole component, queste non verranno selezionate, poiché sono in realtà oggetti figli del componente. Per selezionare solo le piazzole, tenere premuto Ctrl mentre si fa clic e si trascina la finestra di selezione.
  • Se si sposta un via insieme alle piste per creare più spazio per lo sbroglio o per i componenti, può essere più efficiente eseguire nuovamente lo sbroglio anziché spostare le piste. Il software include una funzione chiamata Loop Removal. Quando questa funzione è abilitata, è possibile sbrogliare lungo un nuovo percorso (iniziando e terminando in un punto qualsiasi del percorso originale); non appena si fa clic con il pulsante destro del mouse per uscire dalla modalità di sbroglio interattivo, il vecchio percorso (anello) viene rimosso, compresi eventuali via ridondanti.

Modifica non grafica tramite il pannello Properties

Questo metodo di modifica utilizza la modalità associata del pannello Properties per modificare le proprietà di un oggetto piazzola/via.

Connessioni termiche di pad e via

Il campo Thermal Relief nella sezione Pad Stack / Via Stack del pannello Properties riepiloga la configurazione delle connessioni termiche attualmente applicata. Ad esempio, Relief, 15mil, 10mil, 4, 90 significa che:

  • è applicata la connessione termica;
  • lo spazio di isolamento ha una larghezza di 15 mil;
  • i conduttori della connessione termica hanno una larghezza di 10 mil;
  • i conduttori della connessione termica hanno una rotazione di 90 gradi.

Quando la casella di controllo nel campo Thermal Relief è disabilitata, le connessioni termiche dei pad e dei via ai poligoni sono rules-driven, ovvero sono definite dalle regole di progettazione Stile di connessione ai poligoni applicabili. Per i singoli pad, la configurazione delle connessioni termiche può essere personalizzata abilitando l'opzione Thermal Relief associata al layer desiderato. In questo caso, le connessioni termiche sono considerate custom. Per ulteriori informazioni, vedere Definizione di connessioni termiche personalizzate.

Espansioni della maschera di saldatura e della maschera per la pasta saldante

La solder mask viene creata automaticamente in corrispondenza di ogni pad/via sul layer Solder Mask. La solder mask è definita in negativo, ovvero gli oggetti posizionati definiscono le aperture nel layer Solder Mask. La maschera per la pasta saldante viene creata automaticamente in corrispondenza di ogni pad sul layer Paste Mask. La forma creata sul layer della maschera corrisponde a quella del pad/via, espansa o contratta della quantità specificata dalle regole di progettazione Espansione della solder mask e Espansione della maschera per la pasta saldante impostate nell'editor PCB oppure come specificato nel pannello Properties.

Pad con la solder mask visualizzata.
Pad con la solder mask visualizzata.

Quando modifichi un pad o un via, le impostazioni di espansione della solder mask e della maschera per la pasta saldante sono visualizzate rispettivamente nelle sezioni Pad Stack e Solder Mask Expansion del pannello Properties. Sebbene queste impostazioni consentano di controllare localmente i requisiti di espansione di un pad/via, normalmente non è necessario utilizzarle. In genere, è più semplice controllare i requisiti della maschera per la pasta saldante e della solder mask definendo le regole di progettazione appropriate nell'editor PCB. Con le regole di progettazione, si definisce una regola per impostare l'espansione per tutti i componenti sulla scheda; quindi, se necessario, si possono aggiungere altre regole per situazioni specifiche, ad esempio tutte le istanze di un determinato tipo di footprint utilizzato sulla scheda oppure un pad specifico di un componente specifico, ecc.

  

Per impostare le espansioni delle maschere nelle regole di progettazione:

  1. Verifica che l'opzione Rule Expansion sia selezionata come Shape nella sezione Pad Stack del pannello Properties (per i pad) e/o che l'opzione Rule sia selezionata nella sezione Solder Mask Expansion del pannello Properties (per i via).

  2. Nell'editor PCB, seleziona Design » Rules dai menu principali ed esamina le regole di progettazione della categoria Mask nella finestra di dialogo dell'editor delle regole e dei vincoli PCB. Queste regole verranno rispettate quando il footprint viene posizionato sul PCB.

Per ignorare le regole di progettazione relative all'espansione e specificare un'espansione della maschera come attributo del pad/via, seleziona Manual Expansion come Shape nella sezione Pad Stack del pannello Properties (per i pad) e/o Manual nella sezione Solder Mask Expansion del pannello Properties (per i via) e inserisci i valori richiesti.

Il layer della maschera per la pasta saldante per i pad a foro passante è supportato nei documenti Draftsman e negli output Gerber, Gerber X2, ODB++, IPC-2581 e di stampa PCB.
Per i pad, puoi anche selezionare manualmente una forma da un insieme standard di forme predefinite per la maschera oppure creare una forma personalizzata – scopri di più.

Tenting di pad e via

Il tenting parziale e completo di pad e via può essere ottenuto definendo un valore appropriato per l'espansione della solder mask. Questo vincolo di espansione può essere definito per ogni singolo oggetto nel pannello Properties oppure mediante apposite regole di progettazione per l'espansione della solder mask. Impostando un valore di espansione adeguato, puoi ottenere quanto segue:

  • Per eseguire il tenting parziale di un pad/via, coprendo solo l'area della piazzola, imposta l'espansione su un valore negativo che chiuda la maschera fino al foro del pad/via.
  • Per eseguire il tenting completo di un pad/via, coprendo la piazzola e il foro, imposta l'espansione su un valore negativo di valore assoluto pari o superiore al raggio del pad/via.
  • Per eseguire il tenting di tutti i pad/via su un singolo layer, imposta il valore di espansione appropriato e assicurati che l'ambito di applicazione (Full Query) di una regola di espansione della solder mask includa tutti i pad/via sul layer desiderato.
  • Per eseguire il tenting completo di tutti i pad/via in un progetto con via di dimensioni diverse, imposta l'espansione su un valore negativo di valore assoluto pari o superiore al raggio del pad/via più grande. Quando si esegue il tenting di un singolo pad/via, sono disponibili opzioni per utilizzare l'espansione definita nella regola di progettazione applicabile oppure per ignorare la regola e applicare un'espansione specificata direttamente al singolo pad/via in questione.

Punti di test

Related page: Assegnazione dei punti di test sulla scheda

Il software offre supporto completo per i punti di test, consentendo di utilizzare pad (a foro passante o SMD) e via come punti di test durante i collaudi di fabbricazione e/o assemblaggio. Un pad/via viene designato come punto di test impostando le relative proprietà: se deve essere un punto di test per la fabbricazione o per l'assemblaggio e su quale lato della scheda deve essere utilizzato. Queste proprietà si trovano nella sezione Testpoint del pannello Proprietà .

Per semplificare il processo e ridurre la necessità di impostare manualmente le proprietà dei punti di test, il software offre un metodo per assegnarli automaticamente in base alle regole di progettazione definite, utilizzando il Gestore dei punti di test (Tools » Testpoint Manager). In ciascun caso, questa assegnazione automatica imposta le proprietà pertinenti del pad/via.

Caratteristiche specifiche dei pad

Designatori dei pad

Ogni pad deve essere identificato con un designatore (che solitamente rappresenta il numero di un pin del componente) composto da un massimo di 20 caratteri alfanumerici. I designatori dei pad vengono incrementati automaticamente di uno durante il posizionamento se il pad iniziale ha un designatore che termina con un carattere numerico. Prima del posizionamento, modifica il designatore del primo pad dal pannello Proprietà .

Per ottenere incrementi alfabetici, ad esempio 1A, 1B, oppure incrementi numerici diversi da 1, utilizza la finestra di dialogo di configurazione dell'incolla matrice, accessibile premendo il pulsante Paste Array nella finestra di dialogo Incolla speciale (Edit » Paste Special).

Funzione Incolla matrice

Impostando il designatore del pad prima di copiarlo negli appunti, puoi utilizzare la finestra di dialogo Setup Paste Array per applicare automaticamente una sequenza di designatori durante il posizionamento dei pad. Utilizzando il campo Text Increment nella finestra di dialogo Setup Paste Array, puoi creare le seguenti sequenze di designatori dei pad:

  • Numerica (1, 3, 5)
  • Alfabetica (A, B, C)
  • Combinazione alfanumerica (A1 A2, 1A 1B, A1 B1 oppure 1A 2A, ecc.)

Per incrementare numericamente, imposta il campo Text Increment sul valore dell'incremento desiderato. Per incrementare alfabeticamente, imposta il campo Text Increment sulla lettera dell'alfabeto che rappresenta il numero di posizioni di cui avanzare. Ad esempio, se il pad iniziale ha il designatore 1A, imposta il campo su A, (prima lettera dell'alfabeto) per incrementare i designatori di 1. Se imposti il campo su C (terza lettera dell'alfabeto), i designatori diventeranno 1A, 1D (tre lettere dopo A), 1G, ecc.

Collegamenti tramite ponticelli

I collegamenti tramite ponticelli definiscono connessioni elettriche tra i pad dei componenti che non sono fisicamente sbrogliate con primitive sul PCB. Sono particolarmente utili sulle schede a singolo layer, dove viene utilizzato un filo per scavalcare le piste sull'unico layer fisico.

I pad all'interno di un componente possono essere contrassegnati con un Jumper valore dal pannello Properties. I pad che condividono lo stesso Jumper e la stessa net elettrica indicano al sistema che tra di essi esiste una connessione valida, anche se non sono fisicamente collegati.

Le connessioni jumper sono visualizzate come linee di connessione curve nell'editor PCB. Il controllo delle regole di progettazione non segnala le connessioni jumper come net non sbrogliate.

Specifiche dei via

Definizione delle proprietà dei via

Mentre i requisiti di attraversamento degli strati (piano Z) di ciascun tipo di via sono definiti nella scheda Via Types del Layer Stack Manager, le proprietà dimensionali del via sono definite tramite:

Configurazione della regola di progettazione Routing Via Style

Main page: Definizione, ambito di applicazione e gestione delle regole di progettazione PCB

Le proprietà dimensionali dei via posizionati durante lo sbroglio interattivo, ActiveRouting o lo sbroglio automatico sono controllate dalla regola di progettazione Routing Via Style applicabile. Per individuare i via a cui applicare la regola di progettazione, è disponibile una serie di parole chiave di query relative ai via, utilizzabili nell'ambito di applicazione della regola (Where the Object Matches); queste sono descritte in dettaglio di seguito.

Quando si cambia strato durante lo sbroglio, il software esamina gli strati iniziale e finale del passaggio e sceglie un tipo di via consentito da Layer Stack Manager. Quindi identifica la regola di progettazione Routing Via Style applicabile con la priorità più alta e applica al via da posizionare le impostazioni dimensionali della sezione Constraints di tale regola.

Ad esempio, potrebbe esserci un insieme di net DRAM_DATA che richiedono µVia per il passaggio dallo strato TopLayer allo strato S2 e dallo strato S2 allo strato S3, e un via passante con foro meccanico per tutti gli altri passaggi tra strati (anch'esso diverso dal via richiesto dalle altre net). Questo caso può essere gestito creando due regole di progettazione Routing Via Style da applicare a queste net DRAM_DATA. Di seguito è mostrato un esempio di regola di progettazione adatta ai µVia; passare il cursore sull'immagine per visualizzare la regola per i via passanti.

È possibile definire l'ambito delle regole di progettazione in modo che si applichino a tipi specifici di via.
È possibile definire l'ambito delle regole di progettazione in modo che si applichino a tipi specifici di via.

Quando un via viene posizionato in uno spazio libero, il software non può applicare una regola di progettazione dello stile di sbroglio durante il posizionamento. In questo caso, viene posizionato il via predefinito.

Query Keywords

Per semplificare la definizione dell'ambito di applicazione delle regole di progettazione Routing Via Style, sono disponibili le seguenti parole chiave di query relative ai via:

Via Type Query Returns
IsVia Tutti gli oggetti via, indipendentemente dal tipo di via.
IsThruVia Tutti i via che si estendono dallo strato superiore a quello inferiore.
IsBlindVia Tutti i via che iniziano su uno strato superficiale e terminano su uno strato interno e che non sono µVia.
IsBuriedVia Tutti i via che iniziano su uno strato interno e terminano su un altro strato interno e che non sono µVia.
IsMicroVia Tutti i via con l'opzione µVia abilitata che collegano strati adiacenti.
IsSkipVia Tutti i via con l'opzione µVia abilitata che attraversano 2 strati.

Utilizzare la funzione Mask nel Query Helper per trovare le parole chiave disponibili relative ai via. Premere F1 quando una parola chiave di query è selezionata nell'elenco per visualizzare la relativa guida.

Posizionamento dei via durante lo sbroglio interattivo

Quando si cambia strato durante lo sbroglio interattivo, il software inserisce automaticamente un via. Il via scelto dipende dai seguenti fattori:

  • I tipi di via disponibili per gli strati attraversati durante il cambio di strato.
  • La regola di progettazione Routing Via Style applicabile al tipo di via selezionato per quel cambio di strato.

Per cambiare strato durante lo sbroglio interattivo:

  • Premere il tasto * sul tastierino numerico per passare allo strato di segnale successivo.
  • Utilizzare la combinazione Ctrl+Shift+WheelRoll per passare agli strati superiori o inferiori.

Posizionamento di µVia impilati durante un cambio di strato da L1 a L4. La modalità Interactive Routing del pannello Properties visualizza i tipi di via che verranno posizionati; premere 6 per scorrere le possibili pile di via; premere 8 per visualizzare un elenco delle possibili pile di via.

Controllo del via posizionato durante lo sbroglio interattivo

  • Quando si cambia strato di sbroglio, il software sceglie automaticamente il tipo di via più adatto all'intervallo di strati da attraversare.

  • Se è possibile utilizzare più tipi di via o combinazioni (pile di via), premere il tasto di scelta rapida 6 per scorrere in modo interattivo tutte le pile di via disponibili per quel cambio di strato; premere la scorciatoia 8 per visualizzare un elenco. Le pile di via vengono presentate nell'ordine: uso di µVia, uso di µVia a salto, uso di via ciechi, uso di via passanti. È possibile posizionare via impilati se il cambio di strato comprende più di uno strato e sono definiti tipi di via adatti. I tipi di via proposti sono indicati nella barra di stato e nella visualizzazione Heads Up, ad esempio [µVia 1:2, µVia 2:3, µVia 3:4], come mostrato nell'immagine sopra.

  • L'ultima pila di via utilizzata viene mantenuta come predefinita per la net successiva da sbrogliare. La pila di via predefinita viene mantenuta solo per la sessione di modifica corrente.

  • Le proprietà dimensionali dei via sono specificate dalla regola di progettazione Routing Via Style applicabile; le strategie per definire una regola di progettazione Routing Via Style adeguata sono illustrate sopra.

  • Per modificare in modo interattivo le dimensioni del via durante un cambio di strato, premere la scorciatoia 4. In questo modo si scorrono le modalità Via Size: Rule Minimum; Rule Preferred; Rule Maximum; User Choice; la modalità Via Size corrente viene visualizzata nella visualizzazione Heads Up e nella barra di stato (come mostrato nell'immagine sopra). Se è selezionata l'opzione User Choice, premere Shift+V per aprire la finestra di dialogo Choose Via Sizes e selezionare la dimensione del via desiderata. L'elenco delle dimensioni disponibili visualizzato nella finestra di dialogo viene ricavato dall'elenco dei via già utilizzati nel progetto; è possibile esaminarli nella modalità Pad and Via Templates del pannello PCB.

    Se nella regola di progettazione Routing Via Style applicabile viene utilizzata la modalità Template preferred, la scorciatoia 4 consente di scorrere i modelli di via abilitati.

  • Una vista laterale dei tipi di via proposti viene mostrata nel pannello Properties, come illustrato sopra.

  • Per posizionare un via e continuare lo sbroglio sullo stesso strato, premere la scorciatoia 2.

  • Per posizionare un via e sospendere lo sbroglio di questa connessione, premere la scorciatoia / sul tastierino numerico.

  • Se la net che si sta sbrogliando deve essere collegata a un piano di alimentazione interno, premere il tasto / (sul tastierino numerico) per posizionare un via collegato al piano di alimentazione appropriato. Questa funzione è disponibile in tutte le modalità di posizionamento delle piste tranne la modalità Any Angle .

  • Premi Shift+F1 durante lo sbroglio per visualizzare un menu con tutte le scorciatoie disponibili nel comando.

Lavorare con via impilati

  • I via impilati che formano una connessione continua possono essere gestiti come un unico via: click and drag sulla pila per spostarli tutti insieme alle piste collegate.

  • Fai clic una volta per selezionare il via più in alto nella pila. Se il mouse non viene spostato, i successivi clic singoli selezioneranno a turno ciascuno degli altri via nella pila.

    Se l'opzione Display popup selection dialog è abilitata nella pagina PCB Editor – General della finestra di dialogo Preferences, facendo clic su una pila di via si apre un popup di selezione da cui puoi scegliere il via desiderato.

  • Ctrl+Click and drag per spostare solo il via selezionato insieme alle piste collegate.

  • Per selezionare tutti i via di una pila, fai clic una volta per selezionarne uno, quindi premi Tab per estendere la selezione a tutti i via della pila.

Configurazione della visualizzazione dei via

Sono disponibili diverse funzionalità di visualizzazione per facilitare il lavoro con i via.

Colori dei via

I colori dei via vengono configurati nel pannello View Configuration. L'anello di rame del via viene mostrato con l'impostazione corrente Multi-Layer nella sezione Layers . Il colore del foro del via viene mostrato con l'impostazione Via Holes nella sezione System Colors . Puoi anche disabilitare la visualizzazione dei fori attivando o disattivando  per le impostazioni desiderate.

La prima immagine mostra un via passante. Il via nella seconda immagine è un via cieco; il foro viene mostrato nei colori degli strati iniziale e finale.
La prima immagine mostra un via passante. Il via nella seconda immagine è un via cieco; il foro viene mostrato nei colori degli strati iniziale e finale.

Via e solder mask

Per impostazione predefinita, nell'editor PCB lo strato Multi-Layer viene sempre visualizzato sopra tutti gli altri. Questo può rendere difficile visualizzare con precisione il contenuto degli strati della solder mask, specialmente quando un pad o un via utilizza un'espansione negativa della maschera, poiché il contenuto dello strato della solder mask viene nascosto sotto l'oggetto multistrato. Puoi modificare questo comportamento cambiando l'ordine di disegno degli strati nella pagina PCB Editor – Display della finestra di dialogo Preferences. Imposta lo strato corrente in modo che venga disegnato sopra tutti gli altri.

Modificando l'ordine di disegno degli strati per visualizzare lo strato corrente in primo piano, quando imposti Top Solder come strato corrente, le aperture della maschera vengono rappresentate con precisione, come mostrato nell'immagine seguente. Le frecce verdi indicano le dimensioni dell'apertura della solder mask per un via a sinistra, un pad con apertura della maschera ridotta al centro e un pad con apertura ampliata a destra.

Configura le impostazioni di visualizzazione per poter esaminare le aperture della solder mask.
Configura le impostazioni di visualizzazione per poter esaminare le aperture della solder mask.

Visualizzazione dei via impilati

Se sono presenti via impilati, i numeri visualizzati indicano gli strati iniziale e finale di tutti i via nella pila. Passa il cursore sull'immagine seguente per visualizzare i via in 3D; sulla destra dell'immagine è presente una pila di tre via.

Gli strati attraversati possono essere visualizzati all'interno dei via. Passa il cursore sull'immagine per visualizzare i via in 3D.Gli strati attraversati possono essere visualizzati all'interno dei via. Passa il cursore sull'immagine per visualizzare i via in 3D.

Altre impostazioni di visualizzazione dei via

Per visualizzare il nome della net del via e i numeri degli strati attraversati dal via, abilita rispettivamente le opzioni Via Nets e Via Span nell'area Additional Options della scheda View Options del pannello View Configuration.

Esplorazione dei fori di pad e via

Nella modalità del pannello PCB Hole Size Editor, le tre aree principali cambiano per mostrare, dall'alto verso il basso:

  • I filtri generali per i tipi di foro e il relativo stato, con una sottosezione dedicata alle coppie di strati di foratura attualmente definite per la scheda.
  • Unique Holes organizzati in gruppi in base a dimensioni e forma.
  • I singoli Pads/Vias che costituiscono ciascun gruppo di oggetti foro.

Le sezioni del pannello mostrano i filtri cumulativi applicati ai tipi, agli stili e allo stato dei fori.
Le sezioni del pannello mostrano i filtri cumulativi applicati ai tipi, agli stili e allo stato dei fori.

I gruppi di fori possono essere modificati collettivamente nell'area Unique Holes del pannello inserendo i valori nella cella della colonna appropriata. Puoi inserire un valore numerico per modificare le dimensioni correnti dei fori di pad e via nella colonna Hole Size .

Modifica delle dimensioni del foro per il gruppo selezionato di sei stili di foro corrispondenti.
Modifica delle dimensioni del foro per il gruppo selezionato di sei stili di foro corrispondenti.

Puoi anche modificare le voci corrispondenti Hole Length, Hole Type e Plated per i fori, ove applicabile.

Modifica del tipo di foro per il gruppo selezionato di sei stili di foro corrispondenti.
Modifica del tipo di foro per il gruppo selezionato di sei stili di foro corrispondenti.

I singoli oggetti pad/via appartenenti al gruppo di fori selezionato sono elencati nella sezione inferiore Pad/Via del pannello PCB. Fai clic con il pulsante destro del mouse su un oggetto nell'elenco, quindi seleziona Properties (oppure fai doppio clic direttamente sulla voce) per aprire la modalità associata del pannello Properties per quella primitiva, dove puoi visualizzarne e modificarne le proprietà.

Per aggiornare il pannello PCB nella modalità Hole Size Editor con i dati correnti dei simboli di foratura del PCB, fai clic con il pulsante destro del mouse all'interno di un'area del pannello in questa modalità e seleziona il comando Refresh.

I dati dei simboli di foratura vengono aggiornati automaticamente al salvataggio del documento PCB e per tutti gli output che contengono questi dati.

Per migliorare le prestazioni, i dati dei simboli di foratura non vengono aggiornati automaticamente nel pannello PCB. È possibile aggiornare manualmente i dati dei simboli di foratura quando l'opzione PCB.LiveDrillSymbols è disabilitata nella finestra di dialogo Advanced Settings.

Supporto per il back drilling

La modalità Hole Size Editor del pannello PCB può essere utilizzata anche per esaminare pad e via destinati al back drilling. Le coppie di strati per il back drilling vengono visualizzate nell'elenco Layer Pairs contrassegnate dall'aggiunta del testo [BD].

Quando viene selezionata una dimensione del foro di back drilling, il valore Kind degli oggetti viene visualizzato come Backdrill. Usa questa funzionalità per individuare ed esaminare rapidamente i fori sottoposti a back drilling. Nota che le impostazioni del back drilling non possono essere modificate nel pannello.

Report di back drilling

Per generare un report di tutte le operazioni di back drilling, fai clic con il pulsante destro del mouse nell'elenco Unique Holes, quindi seleziona Backdrill Report dal menu contestuale.

Il report descrive in dettaglio ogni operazione di back drilling, inclusi posizione, diametro e profondità di foratura.

Per ulteriori informazioni sul back drilling, consulta Foratura a profondità controllata, o back drilling.

Supporto per lamature e svasature

La modalità Hole Size Editor del pannello PCB può essere utilizzata anche per esaminare i pad con funzionalità di lamatura o svasatura abilitate. Quando il progetto PCB contiene oggetti pad con funzionalità di lamatura o svasatura abilitate su uno o entrambi i lati, i gruppi Counterholes Top e/o Counterholes Bottom associati vengono visualizzati nell'elenco Layer Pairs. Le colonne Counterhole Depth e Counterhole Angle possono essere visualizzate in Unique Holes area del pannello. Si noti che le impostazioni delle svasature e delle lamature non possono essere modificate nel pannello.

Le informazioni sulle svasature e sulle lamature presenti nel progetto sono visualizzate nella modalità Hole Size Editor del pannello PCB.
Le informazioni sulle svasature e sulle lamature presenti nel progetto sono visualizzate nella modalità Hole Size Editor del pannello PCB.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents