設計では、プロジェクトまたは特定のプロジェクトドキュメントに関連する各種レポートを準備、生成できます。これには次のものがあります。
-
部品表 – 製品の製造に必要なすべての部品を一覧で確認できるレポート形式のドキュメントです。これには、他のすべての部品を実装するための基礎となる「部品」であるベアボードも含まれます。BOMは、設計どおりに製品を製造するために調達すべきものを示す指針となります。また、対象の製造ロットで必要となる実装済み基板の枚数に基づいて、コストを計算する手段にもなります。
部品表レポートの設定に使用するReport Managerダイアログに表示されるデータは、2種類のソースのいずれかから取得されます。設計プロジェクトに関連付けられたActiveBOMドキュメント(*.BomDoc)がある場合は、それがデータソースとして使用されます。それ以外の場合は、プロジェクトのソース回路図ドキュメントからデータが抽出されます。
-
BOM比較 – Workspaceプロジェクトのリリース時に変更された部品(追加、削除、置換など)に関する情報を提供するレポートです。
-
Manufacturing Data – ハーネスメーカーが使用するデータをまとめた、単一のExcelブックです。生成されるブックには、次の4種類のシートが含まれます。
-
Bill of Materials – 見積もりの迅速な作成に役立ちます。
-
Wiring List – 電線加工機で使用します。
-
Labels – ハーネス束用に印刷する物理ラベルをまとめたもので、Zebraなどのプリンターで使用します。
-
Coverings – ハーネス束に取り付ける被覆材をまとめたものです。
製造データ出力のソースには、ハーネス設計プロジェクトのActiveBOMドキュメントを使用することをお勧めします。
ハーネス設計の詳細については、ハーネス設計のページを参照してください。
-
部品相互参照レポート – 設計内で部品が配置されている回路図シートに基づいて、部品の一覧を作成します。
部品表レポートと部品相互参照レポートは、専用の強力なレポート生成エンジンを使用して、柔軟に設定できます。このエンジンのインターフェースはReport Managerダイアログです。必要なレポートの内容を定義し、要件に合わせて整理したら、レポートを生成して印刷するか、CSV(カンマ区切り)(*.csv)、Microsoft Excelワークシート(*.xls;*.xlsx;*.xlt;*.xltx)、PDF(*.pdf)、タブ区切りテキスト(*.txt)、Webページ(*.htm;*.html)、XMLスプレッドシート(*.xml)のいずれかのファイル形式にエクスポートできます。エクスポートしたファイルは任意の場所に保存できます。また、作成後に対応するソフトウェアアプリケーションで開いたり、プロジェクトに追加したりすることもできます。Report ManagerダイアログのメニューからReport コマンドを使用すると、レポートが読み込まれた状態でReport Previewダイアログが開きます。ウィンドウ内の各種コントロールを使用して、レポートの表示を調整します。Print ボタンをクリックするとPrint ダイアログが開き、印刷する内容と印刷ジョブの送信先となるプリンターを指定できます。レポートのプレビューも、さまざまなファイル形式にエクスポートできます。
-
コメントのエクスポート – プロジェクトドキュメントのコメントをエクスポートしたPDFファイルを作成します。
-
プロジェクト履歴 – プロジェクト履歴をエクスポートしたPDFファイルを作成します。出力はProject History Report Configurationダイアログで設定します。このダイアログでは、レポートをエクスポートする対象のPeriodを、プロジェクト履歴全体、または特定の(もしくは最新の)プロジェクトリリースを開始点/終了点とする範囲から指定できます。
-
プロジェクト階層レポート – プロジェクトで使用されているソースドキュメントの一覧を作成します。この出力には設定オプションはなく、ASCIIレポートが指定の出力フォルダーに書き込まれます。
-
単一ピンネットレポート – 接続が1つしかないネットを一覧にしたレポートを作成します。この出力には設定オプションはなく、ASCIIレポートが指定の出力フォルダーに書き込まれます。設計のすべてのソース回路図ドキュメントを、プロジェクト内の階層に従って一覧にしたレポートです。ファイルは直接生成され、形式は<ActiveDocumentName>.REPです。
レポート出力は、アクティブなOutput Jobファイル内のReport Outputs領域にある[Add New Report Output]コントロールのメニュー、またはメインメニューのEdit » Add Report Outputsサブメニューから、そのファイルに追加できます。
OutputJobファイルを使用すると、設計の出力準備を効率化し、整合性の高いプロジェクトリリースプロセスを通じて出力を生成できますが、アクティブな設計のレポート出力は、回路図エディターのメインのReports メニュー、またはPCBエディターのReports » Project Reportsサブメニューにあるコマンドを使用して直接生成することもできます。
-
Report Managerダイアログは非常に柔軟に設定できるため、特定の実装機に合わせてデータを特定の構造にする必要があるピックアンドプレースファイルなど、必要に応じた任意の形式のレポートを生成することもできます。
-
すべての出力ファイルは、Options for ProjectダイアログのOptionsタブにあるOutput Pathフィールドで指定した出力フォルダーに書き込まれます。デフォルトでは、出力パスはプロジェクトファイルを含むフォルダーのサブフォルダーに設定され、その名前はProject Outputs for <ProjectName>です。出力パスは必要に応じて変更できます。Projectsパネルでは、生成されたファイルはGenerated\Text Documents(.csv、.txt、.rep)またはGenerated\Documents(.xls、.pdf、.htm、.xml)サブフォルダーの下に表示されます。同じアクティブドキュメントから別の形式のレポートを生成すると、以前に生成したレポートファイルとファイル名が同じ場合、そのファイルが上書きされることに注意してください。
-
Use separate folder for each output typeオプション(同じくOptions タブにあります)が有効な場合、出力はさらに下位のReportsという名前のサブフォルダー(例:Project Outputs for <ProjectName>\Reports)に書き込まれます。Projects パネルでは、出力はGenerated (Reports)\Text Documents(.csv、.txt、.rep)またはGenerated (Reports)\Documents(.xls、.pdf、.htm、.xml)サブフォルダーの下に表示されます。これにより、ファイルを上書きすることなく、同じアクティブドキュメントから複数のレポートを生成できます。

AI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。