3D PDF ファイルの作成

概略

Altium DesignerのPDF3Dエクスポート機能を使えば、PCB設計のインタラクティブな3Dビューを、基板メーカー、実装業者、顧客と共有できます。この記事では、3D PDFの生成方法、含める設計内容や外観の設定方法、書き出した基板をAdobe Acrobat Readerで確認する方法を解説します。共有相手が確認したい内容に合わせた3D PDFを作成するために、ぜひ読み進めてください。

- PDF3Dエクスポートへのアクセス方法と、ジオメトリ、配色、初期ビュー、および必要に応じて保存するキーフレームビューの設定方法を学びます。
- 含める設計内容が、ファイルサイズや表示パフォーマンスにどう影響するかを理解します。
- Acrobat Readerの3Dツールバーとモデルツリーを使って、ビューの操作、コンポーネントやネットのハイライト表示、表示/非表示の切り替えを行う方法を確認します。
AIでさらに深掘り:

Altium Designerのユーザーは、完全にレンダリングされた3DでPCB設計をインタラクティブに表示する機能を長年にわたって活用してきました。この機能により、基板設計、コンポーネント、および関連する機構部品の実際の構造を独自の視点から把握できます。

この3D機能を、製造業者や実装業者、そして何よりも顧客など、設計チーム以外の関係者も利用できるようにすることには、大きなメリットがあります。これを実現するのが、Altium Designerの3D PDFエクスポート機能です。このインタラクティブな3D形式は、広く普及しているAdobe® Acrobat® Readerの比較的新しいバージョンがあれば、誰でも利用できます。

エクスポートした3D設計をAdobe Readerでインタラクティブに表示し、ズームや回転を行ったり、表示する設計要素を選択したりできます。
エクスポートした3D設計をAdobe Readerでインタラクティブに表示し、ズームや回転を行ったり、表示する設計要素を選択したりできます。

特定の角度からの視点に固定された基板の3D表示とは異なり、エクスポートされた3D PDF形式は、概念的にはAltium Designerのインタラクティブな 3D Layout Modeと同等です。そのため、エクスポートされた3D PDFでは、同様の回転、ズーム、パン操作が可能で、 すべてのコンポーネントとネットへのブックマークも用意されており、複数の定義済み配色から1つを適用できます。

Altium Designerで3D PDFエクスポート機能を利用するには、 PDF3D Exporter ソフトウェア拡張機能がインストールされている必要があります。 この拡張機能は、デフォルトでAltium Designerとともにインストールされます。 手動でインストールまたは削除することもできます。

拡張機能の管理について詳しくは、 Extending Your Installation ページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

Acrobat Readerでの3D表示

Acrobat Readerのバージョン7から高度な3D表示機能が導入され、PDFファイルでインタラクティブな3D表示が可能になりました。その後のAcrobat Readerでも機能強化が重ねられており、Altium Designerの3D PDFエクスポートによって生成される詳細な表現と設定オプションは、バージョン9以降に対応しています。

この新しい3D機能の基盤となるのは、業界で開発されたコンピューターグラフィックスファイル用のUniversal 3D(U3D)形式です。この形式は、欧州電子計算機工業会(ECMA)によってStandard ECMA-363 - Universal 3D File Formatとして標準化されています。U3DはPDF形式でネイティブにサポートされており、PDFファイルに簡単に埋め込んで圧縮し、Acrobat Readerでインタラクティブに3D表示できます。

その結果、専用の3D表示ソフトウェアを必要としない、比較的小容量でクロスプラットフォーム対応の3Dファイル形式を利用できます。Altium Designerからエクスポートした3D PDFファイルの場合、埋め込まれるコンテンツには、Altium Designer自体の3Dビューで表示できるデータの大部分が含まれます。これには、すべてのトラック、パッド、ビア、ポリゴンなど、すべてのコンポーネント、および基板の全レイヤーが含まれます。

PDFの生成

3D PDFファイルをエクスポートするには、目的のPCB設計ドキュメントをデザインスペースで開き、メインメニューからFile » Export » PDF3Dコマンドを選択します(PCBエディターの現在の表示モードが2Dか3Dかにかかわらず、3D PDFファイルは3D形式で作成されます)。

特定の角度からの視点に固定された基板の3D表示とは異なり、新しい3D PDFエクスポートは、概念的にはAltium Designer自体のインタラクティブな3Dビューと同等です。

そのため、エクスポートされた3D PDFでは、同様の回転、ズーム、パン操作が可能で、アクティブな表示設定で定義された任意の配色を適用できます。現在の設定、つまりエクスポートするPDFで使用可能なレンダリング色を確認または編集するには、基板の表示を3Dに切り替え(キーボードショートカット:3)、View Configurationパネルを開きます。レンダリング色は、パネルのView Optionsタブにある3D Settingsセクションで確認できます。

Ctrl+Dキーボードショートカットを使用すると、View ConfigurationパネルのView Optionsタブにすばやくアクセスできます。

PCBエディターの現在の表示モードが2Dか3Dかにかかわらず、3D PDFファイルは3D形式で作成されます。

エクスポートオプション

3D PDFのエクスポートを開始し(File » Export » PDF3D)、標準のWindowsベースのExport Fileダイアログで出力先のファイル名と保存場所を指定すると、Export 3Dダイアログが開き、PDFのレンダリング、動作、および含める設計コンテンツを定義できます。

Export 3Dダイアログでは、エクスポートするPDFの外観と動作を設定できます。
Export 3Dダイアログでは、エクスポートするPDFの外観と動作を設定できます。

Export 3Dダイアログで必要に応じてエクスポートオプションを設定し、Exportボタンをクリックして3D PDFファイルを生成します。

3Dファイルは、この形式に備わっているデータ圧縮を使用してもサイズが大きくなる場合があるため、対象ユーザーにとってどの程度の設計内容が重要かを検討してください。たとえば、基板設計の機構面を確認する人にとって、銅箔レイヤーの内容(配線、パッドなど)は必要ない場合があります。

  • Acrobat Readerでは、ユーザーが必要に応じてモデル要素の表示をグループ単位または個別に切り替えられます。以下を参照してください。

  • PCBドキュメントで定義されたキーフレームは、Export 3D ダイアログの Use 3D Movie views オプションをオンにすることで、3D PDFエクスポートに含めることができます。3D PDFドキュメントにエクスポートされたキーフレームは、Acrobat Readerで選択可能なビューとして利用できます。

含める3Dコンテンツを選択する際は、閲覧者のPCの3Dレンダリング性能も考慮することをお勧めします。生成される3D PDFファイルのサイズが適切であっても、閲覧先のPCのCPUやグラフィックスシステムでは、複雑な多層設計を滑らかにレンダリングできない場合があります。

上記のオプションは、Acrobat ReaderでPDFを開いたときの初期設定を定義するもので、Readerの3Dツールバーから好みに合わせて簡単に変更できます。ただし、3D PDFのエクスポートオプションでツールバーを無効にした場合、ユーザーはビューを変更できません。

3D PDFの表示

Acrobat Readerでの3D PDFの表示は、ご想像のとおり非常に簡単です。コマンドやメニューは、使い慣れた2D機能を自然に拡張したものになっています。

フローティングの3Dツールバーから機能を選択し、マウスのドラッグやスクロールホイールの簡単な操作で、3Dオブジェクトのパン、ズーム、回転を行えます。

Acrobatの3Dツールバーには、3Dナビゲーションや照明/ビュー設定のコントロールが用意されています。
Acrobatの3Dツールバーには、3Dナビゲーションや照明/ビュー設定のコントロールが用意されています。

Readerで特に便利な機能が、Model Treeナビゲーションペインです。まだ開いていない場合は、ボタンで開くことができます。このペインを使うと、3D PDF内のすべてのオブジェクトをたどり、表示を切り替えながら、目的のオブジェクトを選択してハイライト表示できます。


モデルツリーのナビゲーションペインは、
特定の部品やネットの表示を制御する際に特に便利です。

Model Treeナビゲーションペインは、3D設計のあらゆる側面を細部まで調べるための強力な手段です。部品の配置やレイアウトを詳しく確認する場合も、基板の内部構造を詳細に検査する場合も、ナビゲーションツリーを使用して該当するオブジェクトを見つけ、表示できます。

部品と基板のオーバーレイの選択を解除して表示した設計。Acrobat Readerで行える3D表示制御の柔軟性を示しています。
部品と基板のオーバーレイの選択を解除して表示した設計。Acrobat Readerで行える3D表示制御の柔軟性を示しています。

Model Treeペインで個々のオブジェクトを選択すると、ペイン上部で定義された色(この例では赤)でビューウィンドウ内にハイライト表示されます。これにより、特定の部品やネットを簡単に見つけることができ、位置を確認するためにオブジェクトの表示を切り替える必要がなくなります。同様に、3Dビューウィンドウでオブジェクトを選択すると、Model Treeペイン内の該当項目がハイライト表示されます。

Acrobat Readerの各種コントロール、機能、設定の使用方法について詳しくは、Adobeの該当ヘルプコンテンツを参照してください。 PDFでの3Dモデルの表示。

エクスポートされた3D PDFドキュメントには、Altium Designerの基本的な設計メタデータも含まれます。このデータには、設計のソースファイル、作成者、Altium Designerのバージョン、作成日/更新日などが含まれます。これらの情報は、Adobe Readerの Document PropertiesダイアログのDescriptionタブで確認できます – File » Properties。

OutJobによる3D PDFのエクスポート

プロジェクトのOutJobに3D PDFファイルのエクスポートを含めるには、Documentation Outputs項目の下にあるAdd New Documentation Outputをクリックし、PDF3D を選択してから、目的のドキュメントソースを選択します。エクスポートする特定のPCBドキュメントを選択するか、OutJobを汎用的に再利用できるようにするには[PCB Document]を選択します。

出力ジョブ設定ファイルへのPDF3D出力ジェネレーターの追加。出力ジョブ設定ファイルへのPDF3D出力ジェネレーターの追加。

3D PDFの生成設定は、出力ジェネレーターの項目を選択して右クリックし、コンテキストメニューからConfigureを選択することで、事前に設定できます。これにより、前述のExport 3D設定ダイアログが開きます。

出力ジョブを実行するか、手動で生成を開始すると、OutJobのOutput Containersセクションで定義されたとおりに3D PDFファイルがエクスポートされます。出力先は、設定されたWorkspaceとパス、またはPreferencesダイアログのデータ管理 – パブリッシュ先ページで定義されたローカル/リモートのパブリッシュ先です。

設定済みのOutJobから、指定したPDF出力コンテナに3D PDFファイルを生成。
設定済みのOutJobから、指定したPDF出力コンテナに3D PDFファイルを生成。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents