出力ドキュメントとプロジェクトリリース

概略

Altium Designerの手順を追ったチュートリアルで、完成したPCB設計の製造準備を進めましょう。出力ジョブファイルの作成方法、基板製造・実装ドキュメントの設定方法、リリースプロセスにデザインルールチェックを組み込む方法を学べます。出力の設定が完了すれば、プロジェクトはリリース可能な状態になります。引き続き、PCB設計の最終準備の手順をご確認ください。

- GerberおよびNCドリル出力の単位、精度、出力先などを設定します。
- 実装ドキュメント用に、BOM、Draftsman、ピック&プレースの出力を設定します。
- DRC検証レポートを追加し、ほかのリリース用出力を生成する前にデザインルールをチェックします。
AIでさらに深掘り:

Main page: 製造に向けた設計の準備

PCBの設計とレイアウトが完了したので、基板のレビュー、製造、実装に必要な出力ドキュメントを作成する準備が整いました。

PCBの製造にはさまざまな技術や手法があるため、Altium Designerでは、ガーバーファイル、ODB++ファイル、ピックアンドプレースファイル、部品表レポートなど、用途に応じた多様な形式の出力を生成できます。

プロジェクトへのOutput Jobファイルの追加

Main page: Output Jobによる製造データの準備

必要な出力は、各エディターから個別に生成できます(たとえば、PCBエディターのFileメインメニューにあるFabrication Outputs および Assembly Outputs サブメニューのコマンドを使用)。また、Altium DesignerはOutput Jobファイルにも対応しています。Output Jobファイル(略して「OutJob」)には、出力タイプごとの設定が保存されます。OutJobでは、各出力タイプの設定に加え、出力の命名規則、形式、出力先を設定できます。出力はOutJobから直接生成することも、統合されたプロジェクトリリースプロセスの一部として生成することもできます。

  1. Projects パネルでプロジェクトの項目を右クリックし、コンテキストメニューから Add New to Project » Output Job File コマンドを選択します。新しいOutput Jobファイルが開き、ProjectsパネルのSettings\Output Job Files項目の下に、プロジェクトに関連付けられた項目として表示されます。

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Projects パネルでOutJobの項目を右クリックし、Save As コマンドを選択します。Save As ダイアログが開き、プロジェクトファイルと同じ場所にドキュメントを保存できる状態になります。File name フィールドに Fabrication という名前を入力し、Save ボタンをクリックします。

  3. OutJobの追加によってプロジェクトが変更されたため、Projects パネルでプロジェクトの項目を右クリックし、Saveを選択して、プロジェクトをローカルに保存します。

基板製造用出力の追加と設定

Main page: 基板製造データの準備

このチュートリアルでは、基板の製造に必要な出力であるガーバーファイルとNCドリルファイルを設定します。 

  1. 新しいガーバー出力を追加するには、OutJobのOutputs領域にあるFabrication OutputsセクションのAdd New Fabrication Output リンクをクリックし、Gerber Files » [PCB Document]を選択します。

    [PCB Document]オプションを選択すると、プロジェクトのPCBドキュメントが自動的に出力元として使用されます。この設定を選択しておけば、設定を更新する必要がないため、OutJobを別のプロジェクトに簡単にコピーできます。プロジェクトに複数のPCBドキュメントがある場合は、対象の基板を選択する必要があります。

  2. 追加した Gerber Files出力項目をダブルクリックします。Gerber Setupダイアログが開きます。ダイアログのオプションを次のように設定します。

    1. この基板はメートル単位で設計されているため、Units オプションがMillimetersに設定されていることを確認します。

    2. この基板で使用されている最小単位は、配線とクリアランスの0.25mmです。ただし、ほとんどの部品は幾何学的中心を基準点としており、1mmグリッド上に配置されているため、一部のパッドは実際には0.01のグリッド上に位置します。Decimal オプションを0.001 mmに設定します。これにより、出力データの解像度が、これらのグリッド位置を表現するのに十分な精度になります。

    3. Layer to plotタブの下部にある  ボタンをクリックし、Select Usedを選択します。設計で使用されているレイヤーが、上のグリッドのPlot列で有効になります。

  3. Apply をクリックして、その他のデフォルト設定を適用し、Gerber Setupダイアログを閉じます。

  4. 基板には穴があるため、NCドリルファイルも生成する必要があります。同様に、OutJobファイルにNCドリル出力を追加します。OutJobのOutputs領域にあるFabrication OutputsセクションのAdd New Fabrication Output リンクをクリックし、NC Drill Files » [PCB Document]を選択します。

  5. 追加したNC Drill Files出力項目をダブルクリックして、NC Drill Setupダイアログを開きます。NCドリルファイルがガーバーファイルと同じ形式で作成されるように、UnitsをMillimetersに、Formatを4:3に設定します。Coordinate PositionオプションがReference to relative originに設定されていることを確認します。

  6. OK をクリックして、その他のデフォルト設定を適用し、NC Drill Setupダイアログを閉じます。

  7. ガーバーとNCドリルの設定が完了したので、次に命名規則と出力先を設定します。これには、OutJobの右側にある出力コンテナーに各出力を割り当てます。固有のファイル形式を持つ個別のファイルには、Folder Structureコンテナーを使用します。新しいOutJobには、デフォルトでいくつかのコンテナーが含まれています。出力コンテナーの一覧で Folder Structure 項目を選択し、下図のように、Outputs領域のEnabled列でガーバーファイルとNCドリルファイルのラジオボタンをクリックして、これらの出力を選択したコンテナーに割り当てます。

  8. 最後にコンテナーを設定します。コンテナーの項目を選択した状態で、その項目内のChangeリンクをクリックし、Folder Structure settingsダイアログを開きます。ダイアログの上部には、出力先を設定するためのコントロールがあります。最初のコントロールがRelease Managedに設定されていることを確認します。ダイアログの下部には、選択したオプションに応じて名前とフォルダー構造がどのように変わるかが表示されます。

  9. OKをクリックして、Folder Structure settingsダイアログを閉じます。

DRC検証レポートの追加と設定

Main page: 検証レポートの準備

Altium Designerには複数の検証チェックが用意されており、出力生成時に出力の一部として含めることができます。それぞれのチェックでHTMLレポートファイルが生成されます。プロジェクトのリリースプロセスでは、他の出力が生成される前にこれらのチェックが実行され、いずれかの検証チェックに合格しなかった場合、リリースは失敗します。

  1. 新しいDRC検証出力を追加するには、OutJobのOutputs領域にあるValidation OutputsセクションのAdd Validation Output リンクをクリックし、Design Rules Check » [PCB Document]を選択します。

  2. 追加したレポートを既存の Folder Structure コンテナーに割り当てます。OutJobの右側の一覧でFolder Structure 項目を選択し、Outputs領域のEnabled列でDesign Rules Check出力のラジオボタンをクリックします。

  3. Projects パネルでOutput Jobファイルの項目を右クリックし、コンテキストメニューから Save を選択して、ファイルをローカルに保存します。

  4. デザインスペース上部にあるOutput Jobファイルのタブを右クリックし、コンテキストメニューから Close Fabrication.OutJob コマンドを選択して、ファイルを閉じます。 

実装用出力の追加と設定

Main page: Report ManagerでのBOM設定

実際のBOM出力ファイルは、Report Managerダイアログを使用して生成します。このダイアログは柔軟に設定できるレポート生成エンジンで、テキスト、CSV、PDF、HTML、Excelなど、さまざまな形式で出力できます。Excel形式のBOMには、あらかじめ用意されたテンプレートや独自のテンプレートを適用することもできます。

  1. Projects パネルでプロジェクトのエントリを右クリックし、コンテキストメニューから Add New to Project » Output Job File コマンドを選択して、新しいOutJobファイルをプロジェクトに追加します。

  2. Projects パネルでOutJobのエントリを右クリックし、Save As コマンドを選択します。Save As ダイアログが開き、プロジェクトファイルと同じ場所にドキュメントを保存できる状態になります。File name フィールドに Assembly という名前を入力し、Save ボタンをクリックします。

  3. Projects パネルでプロジェクトのエントリを右クリックし、Saveを選択して、プロジェクトをローカルに保存します。

  4. 新しいBOM出力を追加するには、OutJobのReport OutputsセクションにあるAdd New Report Output リンクをクリックし、Bill of Materials » [ActiveBOM Document]を選択します。

  5. 追加したBill of Materials出力をダブルクリックして、Report Managerダイアログを開きます。

  6. ダイアログ右側のPropertiesペインにあるExport Options 領域で、File Format ドロップダウンから Generic XLS (*.xls, *.xlsx, *.xlsm) を選択し、次に Template ドロップダウンから、Workspace内にある BOM Template Single Supplier テンプレートを選択します。

  7. OKをクリックして変更を保存し、Report Managerダイアログを閉じます。

  8. OutJobのDocumentation OutputsセクションにあるAdd New Documentation Output リンクをクリックし、Draftsman » All Draftsman Documentsを選択して、新しいDraftsman出力を追加します。

  9. 追加したBOM出力とDraftsman出力を、既存の PDF出力コンテナに割り当てます。これを行うには、OutJob右側の出力コンテナのリストでPDFエントリを選択し、Outputs領域のEnabled列で、Bill of Materials 出力とDraftsman出力のラジオボタンをクリックします。

  10. PDFコンテナのエントリを選択した状態で、エントリ内のChangeリンクをクリックし、PDF settingsダイアログを開きます。

  11. PDF settingsダイアログの上部にあるAssembly.PDFエントリをクリックし、Separate file for each output using output nameを選択して、ボタンをクリックします。 出力されるBOMと図面には、OutJobの各出力に設定された名前(それぞれBill of Materials.pdf とDraftsman.pdf)が割り当てられます。これらの名前は、ダイアログのPreview領域で確認できます。

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. OKをクリックしてダイアログを閉じます。

  13. OutJobのDocumentation OutputsセクションにあるAdd New Documentation Output リンクをクリックし、Generates pick and place files » [PCB Document]を選択して、新しいピック&プレース出力を追加します。

  14. 追加したGenerates pick and place files出力をダブルクリックして、Pick and Place Setupダイアログを開きます。

  15. ダイアログの左下にあるOutput Setting領域で、UnitsをMetricに設定します。

  16. OKをクリックして、その他の設定はデフォルトのまま確定し、Pick and Place Setupダイアログを閉じます。

  17. 追加したピック&プレース出力を、既存の Folder Structure出力コンテナに割り当てます。これを行うには、OutJob右側の出力コンテナのリストでFolder Structureエントリを選択し、Outputs領域のEnabled列で、Generates pick and place files出力のラジオボタンをクリックします。

  18. Projects パネルでOutput Jobファイルのエントリを右クリックし、コンテキストメニューから Save を選択して、ファイルをローカルに保存します。

  19. デザインスペース上部にあるOutput Jobファイルのタブを右クリックし、コンテキストメニューから Close Assembly.OutJob コマンドを選択して、ファイルを閉じます。

プロジェクトのリリース

Main page: 設計プロジェクトのリリース

Output Jobファイルで出力ドキュメントを設定したら、接続先のWorkspaceにプロジェクトをリリースする準備が整います。基板設計のリリースプロセスは自動化されているため、手動のリリース手順に伴うリスクなしに、基板設計プロジェクトをリリースできます。プロジェクトをリリースすると、設計ソースのスナップショットが作成され、生成されたすべての出力とともにアーカイブされます。これらは、その設計プロジェクトを基に製造され、会社が販売する実際の製品を表すものです。

リリースプロセス自体は、Altium DesignerのProject Releaserを使用して実行します。そのユーザーインターフェースは、専用のReleaseビューとして提供されます。リリースプロセスは段階的に進み、ビューの左側にあるエントリで、現在どの段階にいるかをひと目で確認できます。

  1. Projects パネルでプロジェクトのエントリを右クリックし、コンテキストメニューから Project Releaserコマンドを選択します。Releaseビューが独立したドキュメントタブとして開きます。

  2. 最初の段階である1. Configure Server Releaseでは、生成するデータの種類を指定します。各データセットのヘッダーの右端にあるDetailsコントロールをクリックすると、そのデータセットで生成される内容の詳細を確認できます。

  3. ビューの左下にある ボタンをクリックして、Project Release Optionsダイアログを開きます。ダイアログのRelease Optionsタブで、Release TargetとしてManaged - <WorkspaceName>が選択され、Fabrication Dataセットに Fabricationが、Assembly DataセットにAssemblyが割り当てられていることを確認します。

  4. OKをクリックしてダイアログを閉じ、Releaseビューに戻ります。

  5. Include Fabrication DataとInclude Assembly Data for No Variantの両方のオプションが有効になっていることを確認します。

  6. ビューの右下にある ボタンをクリックして次に進みます。

  7. Item Creationダイアログが開き、Workspace内に作成されるリリース対象アイテムのリストが表示されます。Create itemsオプションを選択して、アイテムの作成を確定します。

  8. 表示されるProject Modifiedダイアログで、Save and Commit changesオプションを選択して変更をローカルに保存し、Workspaceへの変更の保存に進みます。

  9. 開いたCommit to Version Controlダイアログで、Commentフィールドに わかりやすいコメント(例:The project is ready for release)を入力し、ボタンをクリックします。

  10. リリースプロセスの次の段階である2. Validate Projectは、Fabrication出力ジョブファイルにデザインルールチェックレポートが含まれているため、自動的に実行されます。

    いずれかの検証チェックに合格しなかった場合、リリースは失敗します。このチュートリアルのプロジェクトリリースでは、PCBドキュメントに少なくとも1つのDRC違反が含まれていることを意味します。この場合、ビューの右下にあるボタンでリリースプロセスを停止し、PCBドキュメントを開いてDRC違反を解消してから、リリースプロセスを再度開始します。

  11. 検証に合格すると、リリースプロセスの次の段階である3. Generate Dataが自動的に実行されます。この段階では、対象のデータアイテムに割り当てられたOutJobファイルで定義されているその他すべての出力が実行され、Workspace内の対応するターゲットアイテムにリリースするデータが生成されます。

  12. すべての検証チェックに合格し、出力データが生成されると、リリースプロセスの次の段階である4. Review Dataで、生成されたデータを確認できます。ビューの右下にあるボタンをクリックして、リリースを続行します。

  13. Confirm Releaseダイアログが開き、Workspaceにリリースされるプロジェクト構成の概要が表示されます。Release Note(例:Initial Release)を入力し、OKをクリックします。

  14. 前の段階でリリースを確認すると、次の段階である5. Upload Dataに自動的に進みます。この段階では、Workspace内の対応するデータアイテムのリビジョンへのデータアップロードの進行状況が表示されます。

  15. プロセスの最終段階である6. Execution Reportでは、リリースの概要が表示されます。ビューの右下にあるボタンをクリックして、リリースビューを閉じます。

Workspaceを使用した共同設計

電子製品の設計と開発には、多くの場合、複数の人が携わります。これを効率的に進めるには、設計チームのメンバーが共同で作業できる必要があります。Altium Designerは、接続されたWorkspaceと連携して、さまざまな共同設計機能を提供します。以下に、その一部を紹介します。

  • Project history – 専用の履歴ビューは、グラフィカルな表示を重視した高度なプロジェクト履歴タイムラインです。プロジェクトの作成、コミット、リリース、クローン、MCADとのデータ交換など、プロジェクトに関する主要なイベントを時系列で表示し、必要に応じてさまざまな操作を行えます()。Workspaceプロジェクトの履歴ビューには、Altium DesignerのProjectsパネルでプロジェクトのエントリを右クリックし、コンテキストメニューからHistory & Version Control » Show Project Historyコマンドを選択してアクセスできます。

    詳細: プロジェクト履歴、Project History(Altium 365 Workspace、Enterprise Server Workspace)

  • Web Viewer – WorkspaceのWeb Viewerインターフェースを使用すると、標準のブラウザーからプロジェクトドキュメントにアクセスできます。単なるブラウザーベースのビューアーにとどまらず、高度なブラウザー技術により、プロジェクト構造内の移動、設計ドキュメントの操作、コメントを付ける領域やオブジェクトのハイライト表示に加え、設計全体のコンポーネントやネットの検索、クロスプローブ、選択、詳細確認を行えます。WorkspaceプロジェクトのWeb Viewerには、Altium DesignerのProjectsパネルでプロジェクトのエントリを右クリックし、コンテキストメニューからShow in Web Browserコマンドを選択してアクセスできます。

    詳細: Web Viewer(Altium 365プラットフォーム、Enterprise Server Workspace)

  • Document commenting – コメントは、対応するデータビューの特定の位置、オブジェクト、または領域にユーザーが追加するメモであり、他のユーザーが返信できます。コメントは、そのデータとは別にWorkspaceに保存されるため、共有データ自体を変更することなく、ユーザー間の共同作業を促進できます。以下の場所にあるWeb Viewerインターフェースで追加したコメントはAltium Designerでも表示され、その逆も同様です。Altium Designerでは、コメント機能はComments and Tasksパネル()で管理します。

    詳細: ドキュメントへのコメント追加、Web Viewer(Altium 365プラットフォーム、Enterprise Server Workspace)

  • Sharing a project – プロジェクトをWorkspaceに保存すると、共同設計やレビューのために、そのプロジェクトにアクセスできるユーザーを指定できます。これは、プロジェクトの共有、より具体的にはアクセス権限の設定によって行います。Altium Designerでは、プロジェクトの共有はShareダイアログ()で管理します。このダイアログには、Projectsパネルでプロジェクトのエントリを右クリックし、コンテキストメニューからShareコマンドを選択してアクセスします。

    詳細: 設計の共有、 Workspace Projects (Altium 365 Workspace、Enterprise Server Workspace)

おめでとうございます! 白紙の回路図シートから始めてPCBを完成させ、その出力をWorkspaceにリリースするまで、Altium Designerの設計プロセス全体を完了しました!

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents