部品の配置と基板配線

概略

Altium Designerでコンポーネントを配置し、PCBをインタラクティブに配線する方法を学びます。このチュートリアルでは、コンポーネントとデジグネータの配置、配線設定、トラックによるパッドの接続、配線済み基板の3D表示までを順を追って説明します。手順に沿ってコンポーネントを配置した基板の配線を完成させ、設計検証の準備を整えましょう。

- スナップグリッドと接続線を目安に、コンポーネントの位置と向きを調整します。
- インタラクティブ配線を設定し、ショートカットを使ってトラックを配置し、障害物を回避しながら接続を完成させます。
- 3Dレイアウトモードに切り替え、ズーム、パン、回転操作で基板をさまざまな角度から確認します。
AIでさらに深掘り:

コンポーネントを基板上の適切な位置に配置し、配線を行いましょう。

PCB上へのコンポーネントの配置

Main page: コンポーネントの配置

PCB設計は配置が90%、配線が10%といわれています。それぞれの割合には議論の余地があるものの、良好な基板設計には適切なコンポーネント配置が不可欠であることは広く認められています。配線中にも配置の調整が必要になる場合があることを覚えておいてください。

コンポーネントを移動するには、 Click, Hold&Dragで目的の位置に移動し、Spacebarで回転させて(反時計回りに90º刻み)、マウスボタンを放して配置します。コンポーネントを移動すると、接続線が自動的に最適化されます。接続線を参考にコンポーネントの向きと位置を調整し、接続線の交差を減らしてください。

コンポーネントを配置すると、PCBは下の画像のようになります。

基板上にコンポーネントが配置され、配線の準備が整いました。
基板上にコンポーネントが配置され、配線の準備が整いました。

  1. ズームして基板とコンポーネントを表示します。

  2. コンポーネントは現在のスナップグリッドに合わせて配置されます。このような単純な設計では、配置グリッドを指定する特別な設計要件はありません。設計者が適切な配置グリッドを判断します。コンポーネントの配置作業を簡単にするため、大きめの配置グリッドを使用できます。ステータスバーで、Snap Gridが1 mmに設定されていることを確認します。必要に応じて、メインメニューのView » Grids » Set Global Snap Grid コマンドを使用してください。

  3. コネクタP1を配置するには:

    1. コネクタの外形の中央にカーソルを合わせ、Click, Hold&Dragを使用します。カーソルが十字に変わり、コンポーネントの最も近いパッドの中心に移動します。

    2. マウスボタンを押したままマウスを動かし、コンポーネントをドラッグします。接続線もコンポーネントと一緒に移動することを確認してください。

    3. 必要に応じてSpacebarを押してコンポーネントを回転させ、上の画像のように基板の左側に配置します。

    4. コネクタが目的の位置に来たら、マウスボタンを放して配置を確定します。

  4. 上の画像を参考に、残りのコンポーネントを再配置します。ドラッグ中にSpacebarでコンポーネントを回転させ、接続線が画像のようになるようにします。

  5. コンポーネントのデジグネータを再配置します。これも同様の方法で行えます。Click, Hold&Dragでテキストを移動し、Spacebarを押して回転させます。または、設計スペースでデジグネータを選択した状態()で、PropertiesパネルのAutopositionオプションを使用します。

  6. ProjectsパネルでPCBドキュメントの項目を右クリックし、コンテキストメニューからSaveを選択して、ローカルに保存します。

コンポーネントの配置ができたら、配線を始めましょう!

基板のインタラクティブ配線

Main page: インタラクティブ配線

このチュートリアルのこのパートでは、基板の配線を行います。

配線とは、基板上にトラックとビアを配置してコンポーネントのピンを接続する作業です。PCBエディタには高度なインタラクティブ配線ツールが用意されており、この作業を簡単に行えます。これらのツールは、トラック配置時のカーソルガイド、ワンクリックでの接続の配線、障害物の押しのけ、既存の接続への自動追従などを通じて、直感的な操作で配線の効率と柔軟性を最大限に高めます。これらはすべて、適用される設計制約に従って行われます。

基板の配線作業を示す動画です。一部の接続は、Ctrl+Clickによる自動完了で仕上げています。

  1. 配線を開始する前に、PreferencesダイアログのPCB Editor – Interactive Routingページでインタラクティブ配線のオプションを設定します。

    1. をクリックします。デザインスペース上部のボタンをクリックしてPreferencesダイアログを開き、左側のツリーでPCB Editorカテゴリを展開し、このカテゴリのInteractive Routing項目を選択してページを開きます。

    2. ページのRouting Conflict Resolution領域で、Current ModeをWalkaround Obstaclesに設定します。

    3. ページのInteractive Routing Width Sources領域で、Track Width Mode とVia Size Modeの両方のオプションがRule Preferredに設定されていることを確認します。

    4. OKをクリックして変更を保存し、ダイアログを閉じます。

     
     
     
     
     

  2. Snap Gridダイアログ(View » Grids » Set Global Snap Grid)を使用して、スナップグリッドを0.25 mmに設定します。

  3. デザインスペース下部のTop Layerタブをクリックしてアクティブレイヤーにし、配線できる状態にします。

  4. メインメニューから Route » Interactive Routing コマンドを選択します(ショートカット: Ctrl+W)。カーソルが十字に変わり、インタラクティブ配線モードになったことを示します。

  5. コネクタP1の下側のパッドにカーソルを合わせます。

  6. クリックして配線の始点を固定します。

  7. カーソルをパッドの下に移動し、クリックして垂直セグメントを配置します。

  8. クリックして配線セグメントを確定しながら配線を進め、R2の下側のパッドで終了します。

  9. 引き続き、基板上のすべての接続を配線します。上の動画では、基板をインタラクティブに配線する様子を紹介しています。

  10. 配線が完了したら、 Projects パネルでPCBドキュメントの項目を右クリックし、コンテキストメニューから Save を選択して、PCBドキュメントをローカルに保存します。

Altium Designerの強力な機能の1つは、基板を3Dオブジェクトとして表示できることです。3D表示に切り替えるには、メインメニューからView » 3D Layout Modeコマンドを実行します(ショートカット: 3)。基板が3Dオブジェクトとして表示されます。以下にチュートリアル用の基板を示します。

3D表示で基板を操作するには、次の操作方法を使用します。

  • ズーム – Ctrl+Mouse Wheel

  • パン – Right-Click, Hold&Drag。

  • 回転 – Shift+Right-Click, Hold&Drag。モデルは、Shiftを押したときに現在のカーソル位置に表示される方向球の中心を軸に回転します。

詳細については、 3Dビューの操作ページを参照してください。

PCB設計が完了しました。次に、基板設計を検証して、PCBが定義された制約に準拠していることを確認します。 

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents