Altium Designer Documentation

ODB Setup

Created: November 17, 2020 | Updated: August 6, 2021

The ODB++ Setup dialog
The ODB++ Setup dialog

Summary

This dialog provides controls to completely configure ODB++ file output options. ODB++ is a CAD-to-CAM data exchange format used in the design and manufacture of printed circuit boards. The format was originally developed by Valor Computerized Systems, Ltd., as an open database that could provide a more information-rich data exchange between PCB design software and Valor CAD-CAM software used by PCB fabricators.

Access

The ODB++ Setup dialog is accessed in one of the following ways:

  • Using an ODB output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » ODB++ Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the ODB++ Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Layers to Plot

Check the box next to each specific layer(s) you want to plot as part of the generated output.

Click the  associated with a layer group to open the Select Layer dialog in which you can select the mechanical layers that are added to all plot layers in the selected layer group.

Units

Select either inches or millimeters to be used as your preferred unit of measurement.

File Options

Check the box next to the file type you wish to utilize for output file generation. Options include uncompressed, .zip, and, .tar/.tgz files.

A TGZ file is GZIP compressed TAR Archive file. The TAR Archive is used to bundle files together and then the GZIP compression is used to reduce the size of the files; TGZ files are smaller than regular Zip files. Because TGZ files are favored by many CAM software options, such as Frontline Genesis, a TGZ file can make it easier to facilitate the fabrication process.

Others

  • ​Include unconnected mid-layer pads - check to allow unconnected pads in the mid-layer on ODB++ plots.
  • Generate DRC Rules export file (.RUL) - check to generate a .RUL file that contains all design rules defined for the source document from which the ODB++ data is being generated.
  • Export only the objects inside the board outline - check to specify the source that is to be used to create the ODB++ profile layer. The profile layer contains the enclosing boundary of the board. By default, this field is set to Board Outline (also referred to as the board shape, it is a closed polygonal shape that defines the boundary, or extents, of the PCB). Created with each new PCB, this is perhaps the best source for the creation of the Profile layer. If your design has no associated board shape, you can choose which source PCB layer has been used to define the closed polygon representing the boundary of the board (e.g., the KeepOut layer or a specific Mechanical layer). This option is only available when the source document contains an embedded board array object and it provides control over the extent of objects exported. Note that if an object (e.g., text) is outside of, but touching the board outline and this option is enabled, that object will still be exported.
  • Merge Net-Tie Nets - when enabled, if a design contains nets connected by Net-Tie components, these nets will report as distinguished single nets in the netlist.

Plot Layers

Use the drop-down, or right-click in the Layers to Plot section, to easily select a group of layers to plot:

  • All On - click to check all boxes in the Plot column (ODB++ data will be created for all checked layers).
  • All Off - click to clear all checked boxes in the Plot column (no ODB++ data will be created).
  • Used On - click to check all boxes in the Plot column of the layers that are used in the project.
  • Edit Group - click to open the Select Layer dialog in which you can select the mechanical layers that are added to all plot layers in the selected layer group. You can also click the  associated with a layer group or right-click on a layer group then select Edit Group to access the Select Layer dialog.

Additional Options

Right-clicking in the Custom Layers section will display:

  • Add Layer - click to add a layer.
  • Edit Layer - click to edit the layer.
  • Delete Layer - click to delete the layer.

Tips

Generating from an Embedded Board Array

When generating an ODB++ output from a PCB design that contains an embedded board array, the following statements apply:

  • The design is analyzed automatically for layer stack violations.
  • Embedded boards that are flipped will display their layer stacks as flipped.
  • Mid-signal layers and internal planes that are different can still appear on the same mid-layer panel.
  • Mid-signal layers and internal planes can be flipped against each other.

When generating ODB++ output from the PCB design, all objects on all layers enabled for plotting will be exported. If you only want to export design objects residing within the board outline, ensure that all additional layers containing objects outside of this boundary are disabled for plotting.

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the ODB++ output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the ODB++ files will be written to a further sub-folder named ODB++ Output.

Automatically Opening the Generated Output

When generating ODB++ output, you can specify that the output is opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the ODB++ Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: