PCB上のテストポイントの割り当て

概略

この記事では、PCB製造においてテストポイントが重要な理由と、Altium Designerを使ってベアボードの製造検査と実装基板の検査の両方に対応するテストポイントを割り当てる方法を解説します。基板製造時と実装後の検査戦略の実務上の違い、テストポイントの配置場所を左右する制約、パッドやビアを手動またはTestpoint Managerでテストポイントに指定する方法を紹介します。検査しやすい基板を設計し、そのプロセスをAltium Designerがどのように支援するかを理解したい方に、基礎をわかりやすく説明します。ぜひ読み進めて、より効果的なテストポイント計画にお役立てください。

- 基板製造時の検査と実装後の検査の違い、およびそれぞれがテストポイントの配置に与える影響を理解します。
- 基板のどちらの面からアクセスできるか、クリアランス、グリッド要件、プローブのアクセス性など、適切なテストポイント戦略を立てるうえで重要な考慮事項と制約を学びます。
- Altium Designerのパッド、ビア、Testpoint Managerの各機能を使い、テストポイントを手動または自動で割り当てる方法を確認します。
AIでさらに深掘り:

テストは、基板製造工程の重要な一部です。基板の製造後には通常、短絡や断線がないことを確認するためのテストを行います。すべての部品を実装した後も、信号の完全性とデバイスの動作を確認するために、再度テストを行うことがよくあります。このプロセスを支援するには、テスト装置がプローブを接触させて必要なテストを実施できるよう、基板上に測定ポイントを計画的に設けることが基本的に有効です。Testpoints

基板上のテストポイントの位置は、テストの種類(ベアボードの製造テスト、実装後のインサーキットテストなど)やテスト方法(フライングプローブやベッドオブネイル治具を使用する自動テスト、手動テストなど)といった要因によって決まります。たとえば、ベアボードの製造テストでは部品が実装されていないため、すべてのパッドとビアをテストポイントの割り当て対象にできます。一方、実装後のインサーキットテストで使用するテストポイントの位置は、ほとんどの場合、これとは異なります。部品を実装すると、部品パッドにプローブを接触させられなくなることがあり、部品の下にあるパッドやビアには確実にアクセスできなくなるためです。

Altium Designerは、テストポイントに関するニーズに対応し、基板のテスト容易性を高める強力なシステムを備えています。必要に応じて、ベアボードの製造テスト用と実装後のインサーキットテスト用に、テストポイントを個別に割り当てることができます。テストポイントは手動で割り当てることも、Testpoint Managerダイアログを使用して、より効率的かつ自動的に割り当てることもできます。

テストポイントの方針を検討する

テストポイントの位置として使用するパッドやビアを割り当てる前に、一度立ち止まって要件を検討することをお勧めします。設計にテストポイントを組み込む方針を定める際には、次のような点を考慮してください。

  • テストポイントの配置を許可する基板面を選ぶ際は、使用するテスト工程と関連する治具を考慮する必要があります。たとえば、基板の下面のみ、上面のみ、または両面からプローブを接触させるのかを検討します。
  • 部品の下(部品と同じ基板面)にあるテストポイントは、通常、ベアボードのテスト段階で使用します。実装済み基板のテストポイントの位置を計画する際は、この点を考慮する必要があります。
  • 必要に応じてビアを使用し、すべてのテストポイントを基板の片面だけに配置することをお勧めします。これは、両面用のテスト治具が片面用のテスト治具より高価になるためです。
  • テストポイントの配置パターンが非標準的で複雑になるほど、基板をテストする治具の構成コストは高くなります。汎用的なテスト容易性を確保できる手法を確立することが、最善の考え方です。十分に練られた柔軟性のあるテストポイント方針によって、さまざまな設計を効率的かつ低コストでテストできるようになります。
  • 設計上のビアのテンティング要件については、慎重に検討する必要があります。テストポイントに指定されたビアをテンティングすると、事実上、テストプローブが接触できなくなります。液状感光性(LPI)ソルダーマスクを使用した部分的なテンティングでも、マスク液がビア穴を通って流れ出やすいため、接触不良が生じます。このようなビアを一時的にテンティングするために剥離可能なソルダーマスクを使用することもできますが、多くの場合、かなりのコストがかかります。
  • 基板製造業者や実装業者と十分に相談し、テストポイントを指定する際に、個別の設計条件が考慮されるようにしてください。たとえば、テストポイント間やテストポイントと部品間のクリアランスには、通常の配置・配線クリアランスよりも厳しい条件が求められる場合があります。

以降のセクションでは、製造テストと実装テストについて、それぞれに固有のテストポイントの制約や考慮事項を含めて詳しく説明します。

製造テスト

製造テストとは、製造工程の実装前の段階、つまり基板に部品を配置する前に行うプリント基板のテストです。そのため、ベアボードテストとも呼ばれます。このテストでは通常、フライングプローブ装置を使用して、ネットごとにテストを行います。基本的には、2本のプローブが連携して動作するようにプログラムされ、一方がネットにパルス信号を送り、もう一方がその信号の有無を検出します。

ベアボードの製造テストでは、一般的に次の2種類のテストを行います。

  1. 設計どおりに端から端まで連続している銅箔が、断線することなく、最大許容インピーダンス以下で正常な信号を伝送できることを確認するテスト。
  2. ネット同士が短絡していないことを確認するテスト。

実装テスト

実装テストとは、製造工程の実装後の段階、つまり対応する部品表(BOM)で指定されたすべての部品が基板に実装された後に行うプリント基板のテストです。そのため、インサーキットテストまたは電気テストとも呼ばれます。このテスト方法では通常、手動で構成したベッドオブネイル治具を使用しますが、方法はそれだけに限定されるわけではありません。治具を使用して行うテストの種類に応じて、基板に電源を投入する場合としない場合があります。

実装後のインサーキットテストでは、一般的に次の2種類のテストを行います。

  1. 各ネット(または対象のネット)に設けた専用のテストポイント1か所ずつに、プローブを同時に接触させます。そのうえで、各プローブから個別にパルス信号を送り、ほかのすべてのプローブで信号の受信結果を検出します。
  2. 特定の部品やバスをテストし、デバイス自体が正常に動作していることを確認します。これらは、さまざまなテスト方法で実施できる専門的なテストです。最も単純な場合は、ベッドオブネイル治具を使用して部品のパッド間をテストできます。

パッドとビアのテストポイント対応

Altium Designerはテストポイントを全面的にサポートしており、製造テストや実装テストのテストポイントとして使用するパッド(スルーホールまたはSMD)やビアを指定できます。パッドまたはビアをテストポイントとして指定するには、関連するテストポイントプロパティを設定し、次の2つの重要な事項を決定します。

  • パッドやビアを製造テスト用、実装テスト用、またはその両方のテストポイントとして使用するか。
  • 基板のどちらの面でパッドやビアをテストポイントとして使用するか(上面、下面、または両面)。

これらのプロパティは、デザインスペースでパッド(パッドのプロパティを参照)またはビア(ビアのプロパティを参照)オブジェクトを選択すると、Propertiesパネルに表示されます。

選択したパッドまたはビアは、Propertiesパネルにある関連オプションを使用して、テストポイントとして指定します。選択したパッドまたはビアは、Propertiesパネルにある関連オプションを使用して、テストポイントとして指定します。

作業を効率化し、パッドやビアのテストポイントプロパティを手動で設定する手間を軽減するため、Altium Designerには、定義済みのデザインルールに基づき、テストポイントマネージャーを使用してテストポイントを自動的に割り当てる方法が用意されています。この自動割り当てでは、各パッドやビアに対して関連するテストポイントプロパティが 設定されます。テストポイントを手動で指定することもできます。つまり、個々のパッドやビア単位で細かく設定し、基板に採用するテストポイント構成を完全に制御できます。
Summer 09より前のリリースで作成されたPCB設計を開くと、有効なテストポイントオプションは、有効なFabrication テストポイントオプションに変換されます。

テストポイントのデザインルール

PCB設計の制約は、十分に検討し、最適化された一連のデザインルールとして実装する必要があります。定義したすべてのテストポイントにアクセスでき、ベアボードテストやインサーキットテストで使用できる適切なテストポイント構成を実現するには、それを管理する制約を設ける必要があります。このため、PCBエディターのデザインルールシステムでは、次のルールタイプを定義できます。

これらのタイプのルールには、PCBルールと制約エディターダイアログ(Design » Rules)からアクセスして定義できます。

個別のデザインルールを定義し、設計内のどのパッドやビアを製造テストポイントおよび実装テストポイントとして使用できるか、また、どのネットにテストポイントが必要かを制約します。個別のデザインルールを定義し、設計内のどのパッドやビアを製造テストポイントおよび実装テストポイントとして使用できるか、また、どのネットにテストポイントが必要かを制約します。

テストポイントスタイルルールと使用条件ルールの制約は、2つのテストモード(製造と実装)で同じです。スタイルルールは、基本的に、パッドやビアがテストポイントの候補となるために満たすべき制約を指定します。使用条件ルールは、どのネットにテストポイントが必要かを 指定します。

テストポイント使用条件ルール(上)とテストポイントスタイルルール(下)のデフォルト制約。テストポイント使用条件ルール(上)とテストポイントスタイルルール(下)のデフォルト制約。

スタイルルールを定義する際は、Rule Scope Helper領域のオプションを使用して、テストポイントの候補となるパッドやビアオブジェクトを的確に対象とするルールの適用範囲をすばやく作成できます。

テストポイントのデザインルールは、テストポイントマネージャー、オートルーター、オンラインDRCおよびバッチDRCの各処理、さらに出力生成時にも使用されます。

製造および実装のテストポイントスタイルルールとテストポイント使用条件ルールは、デフォルトで用意されています。これらのルールが基板の要件を満たしているか確認し、必要に応じて変更してください。同じタイプのルールが複数必要な場合は、デザインルールの優先順位を使用して、適用範囲がより限定されたルールが先に適用されるようにしてください(DRCの実行時など)。

Testpoint Managerでテストポイントを正しく割り当てるには、適用範囲がAllの、対応するテストポイントスタイルルールが少なくとも1つalways 存在する必要があります。
Summer 09より前のリリースで作成されたPCB設計を開くか、デザインルールをインポートすると、テストポイントスタイルルールは製造テストポイントスタイルルールに、テストポイント使用条件ルールは製造テストポイント使用条件ルールに変換されます。

テストポイントの管理

テストポイントを手動で割り当てる作業は、手間と時間がかかります。数百個の部品が基板の両面に実装された複雑な基板では、なおさらです。基板設計でのテストポイント管理を効率化するため、Altium DesignerのPCBエディターにはTestpoint Managerが用意されています。Testpoint Managerを使用すると、定義済みのデザインルールに基づき、ベアボードの製造テストや実装後のインサーキットテスト用のテストポイントを自動的に割り当てることができます。この自動割り当てでは、それぞれのパッドやビアに適切なテストポイントプロパティが設定されます。

メインメニューからTools » Testpoint Managerコマンドを選択してアクセスします。

Testpoint Managerを使用して、製造および実装テストポイントの要件を迅速かつ効率的に管理できます。Testpoint Managerを使用して、製造および実装テストポイントの要件を迅速かつ効率的に管理できます。

このダイアログでは、テストポイントの自動割り当てと解除を1か所で簡単に行えます。Testpoint Net Status 領域には、設計内のすべてのネットが一覧表示され、ベアボードの製造テストと実装後のインサーキットテストの両方について、テストポイントのカバレッジを示すステータス(CompleteまたはIncomplete)が表示されます。Fabrication TestpointsまたはAssembly Testpointsボタンをクリックするか、グリッド内で右クリックすると、該当する種類のテストポイントを割り当てたり解除したりするコマンドにアクセスできます。ダイアログの上部領域でネットを手動選択し、テストポイントを選択的に割り当てたり解除したりすることもできます。

設計内の一部のネットに割り当てる場合も、すべてのネットに割り当てる場合も、Testpoint Managerは製造および実装テストポイントに定義されたスタイルルールと使用ルールに従います。有効なオブジェクトの検索順序を確認するには、Search Orderボタンをクリックします。

順序を変更するには、検索順序リスト内の項目を右クリックし、ポップアップメニューのコマンド、またはShift+Up ArrowとShift+Down Arrowのショートカットを使用して、リスト内で上下に移動します。
ネットに割り当てられたテストポイントが、適用されるテストポイントのデザインルールに違反している場合、Testpoint ManagerダイアログのTestpoint Net Status領域に Illegalと表示されます。PCBエディターのデザインルールチェック機能を使用して、割り当てられたテストポイントの妥当性を確認してください。

Status Summaries領域には、両方のテストモードについて、基板のテストポイントの状態をまとめた情報が表示されます。この領域は、割り当てや解除を行うたびに更新されます。さらに詳細な情報を確認するには、Assignment Results領域を使用します。たとえば、割り当てや解除の対象となった上面/下面のパッドやビアの数、失敗の有無などを確認できます。

テストポイントの妥当性の確認

定義済みの製造および実装テストポイントのルールは、PCBエディターのデザインルールチェック(DRC)機能の一部として適用されます。各種ルールのオンラインDRCチェックやバッチDRCチェックは、Design Rule Checkerダイアログ(Tools » Design Rule Check)で有効にできます。

オンラインDRCまたはバッチDRCの処理に、テストポイントのデザインルールを含めます。オンラインDRCまたはバッチDRCの処理に、テストポイントのデザインルールを含めます。

テストポイント関連のクエリフィールド

設計内に割り当てられる各種の製造および実装テストポイントに対応するため、論理クエリ式でテストポイントを対象にする際に、以下のキーワードを使用できます。いずれも、Query HelperのPCB Functions - Fieldsカテゴリにあります。

  • IsAssyTestpoint - 実装テストポイントである。
  • IsFabTestpoint - 製造テストポイントである。
  • IsTestpoint - 上面または下面のテストポイントである。
  • Testpoint - 上面または下面のテストポイントか?
  • TestpointAssy - 実装テストポイントか?
  • TestpointAssyBottom - 下面の実装テストポイントか?
  • TestpointAssyTop - 上面の実装テストポイントか?
  • TestpointBottom - 下面のテストポイントか?
  • TestpointFab - 製造テストポイントか?
  • TestpointFabBottom - 下面の製造テストポイントか?
  • TestpointFabTop - 上面の製造テストポイントか?
  • TestpointTop - 上面のテストポイントか?

必要に応じて、設計内のテストポイントを対象として抽出する論理クエリ式を作成します。製造および実装テストポイントを対象とする論理クエリ式の例を以下に示します。

  1. (ObjectKind = 'Pad') And (TestpointAssy = 'True')
    実装テストポイントであるすべてのパッドを対象にします。
  2. IsPad And (TestpointAssyTop = 'True')
    上面の実装テストポイントであるすべてのパッドを対象にします。
  3. (ObjectKind = 'Pad') And (TestpointFab = 'True')
    製造テストポイントであるすべてのパッドを対象にします。
  4. ((IsPad Or IsVia)) And (TestpointAssy = 'True')
    実装テストポイントであるすべてのパッドとビアを対象にします。
  5. ((IsPad Or IsVia)) And IsFabTestpoint
    製造テストポイントであるすべてのパッドとビアを対象にします。

テストポイントレポートの生成

Altium Designerには、製造テストポイントレポートと実装テストポイントレポートを生成するための専用のレポートジェネレーターがそれぞれ用意されています。これら2つのレポートジェネレーターは、設計内のパッドおよびビアのプリミティブに設定された、対応するテストポイントプロパティを使用します。

製造テストポイントレポートでは、パッドとビアのFabrication テストポイント設定のみが使用されます。実装テストポイントレポートでは、Assembly テストポイント設定のみが使用されます。

レポートは次の2つの方法で生成できます。

  • File » Fabrication Outputs » Test Point ReportおよびFile » Assembly Outputs » Test Point Reportコマンドを使用して、PCBドキュメントから直接生成します。
  • 出力ジョブ設定ファイル(*.OutJob)内に定義された、適切に設定済みの出力を使用します。
出力ジョブ設定ファイルの詳細については、出力ジョブを使用した製造データの準備を参照してください。

単独で使用できる汎用性の高い出力ジョブ設定ファイルに、製造および実装テストポイントレポートの出力を追加して設定します。一度定義すれば、ボタンを押すだけでレポートを取得できます。単独で使用できる汎用性の高い出力ジョブ設定ファイルに、製造および実装テストポイントレポートの出力を追加して設定します。一度定義すれば、ボタンを押すだけでレポートを取得できます。

レポートの生成方法にかかわらず、レポートのオプションは同じダイアログで定義します。製造テストポイントレポートには、Fabrication Testpoint Setupダイアログを使用します。実装テストポイントレポートには、Assembly Testpoint Setupダイアログを使用します。これらのダイアログのレポートオプションは同じです。

対応するレポート設定ダイアログで、生成するファイル形式などのレポートオプションを定義します。 
対応するレポート設定ダイアログで、生成するファイル形式などのレポートオプションを定義します。

PCBから直接出力を生成する際にTestpoint Setupダイアログで定義する設定は、出力ジョブ設定ファイルで同じ出力形式に対して定義する設定とは別のものです。前者の設定はプロジェクトファイルに保存され、後者の設定は出力ジョブファイルに保存されます。
ダイアログのCoordinate Positions領域にあるオプションを使用すると、すべてのレポート形式で、基板の絶対原点または現在の基板原点を基準としてテストポイントの位置をエクスポートできます。
すべてのテストポイントレポート形式は、埋め込み基板アレイに対応しています。複数の埋め込み基板アレイを含むPCBドキュメントからエクスポートすると、複数のIPC-D-356Aネットリストファイルが生成されます。

IPC-D-356Aネットリストファイルの役割

テストポイントレポートの3種類の出力形式の1つが、IPC-D-356Aネットリストファイルです。このファイルは通常、ベアボードの製造テストモードを対象として使用されます。IPCファイルは後処理によって、フライングプローブテスターを駆動するコマンドに変換されます。

IPC-D-356Aファイル内でどの部分がテストポイントの位置として明示されているかにかかわらず、基板メーカーは一般に、このファイルのデータを使用して必要な種類のテストを実施できます。ただし、状況やファイルの内容によっては、手作業による調整が必要になる場合があります。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents