출력물 준비 및 프로젝트 릴리스

개요

Altium Designer의 단계별 튜토리얼을 따라 완성된 PCB 설계를 제조에 맞게 준비하세요. Output Job 파일을 생성하고, 제작 및 조립 문서를 구성하고, 릴리스 프로세스에 Design Rule 검사를 포함하는 방법을 알아보세요. Output 구성을 마치면 프로젝트를 릴리스할 준비가 완료됩니다. 계속 읽고 PCB 설계의 최종 준비 단계를 진행해 보세요.

- 단위, 정밀도, 저장 위치를 포함하여 Gerber 및 NC Drill Output을 구성합니다.
- 조립 문서에 필요한 BOM, Draftsman 및 Pick & Place Output을 설정합니다.
- 다른 릴리스 Output이 생성되기 전에 Design Rule을 검사하도록 DRC 검증 보고서를 추가합니다.
AI로 더 깊이 알아보기:

Main page: 제조를 위한 설계 준비

PCB 설계와 레이아웃을 완료했으므로, 이제 보드 검토, 제작 및 조립에 필요한 출력 문서를 생성할 준비가 되었습니다.

PCB 제조에는 다양한 기술과 방식이 사용되므로, Altium Designer는 Gerber 파일, ODB++ 파일, 픽 앤 플레이스 파일, 자재 명세서 보고서 등 다양한 용도의 출력 유형을 생성할 수 있습니다.

프로젝트에 Output Job 파일 추가하기

Main page: Output Job으로 제조 데이터 준비하기

특정 편집기에서 필요한 출력을 선택적으로 생성할 수도 있지만(예: PCB 편집기의 File 기본 메뉴에 있는 Fabrication Outputs 및 Assembly Outputs 하위 메뉴의 명령 사용), Altium Designer는 Output Job 파일도 지원합니다. Output Job 파일(줄여서 'OutJob')에는 각 출력 유형의 설정이 저장됩니다. OutJob을 사용하면 각 출력 유형과 출력 이름, 형식, 출력 위치를 구성할 수 있습니다. 출력은 OutJob에서 직접 생성하거나 통합 프로젝트 릴리스 프로세스의 일부로 생성할 수 있습니다.

  1. Projects 패널에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Add New to Project » Output Job File 명령을 선택합니다. 새 Output Job 파일이 열리고, Projects 패널의 Settings\Output Job Files 항목 아래에 프로젝트와 연결된 해당 파일 항목이 나타납니다.

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Projects 패널에서 OutJob 항목을 마우스 오른쪽 버튼으로 클릭하고 Save As 명령을 선택합니다. Save As 대화 상자가 열리고, 프로젝트 파일과 동일한 위치에 문서를 저장할 수 있는 상태가 됩니다. File name 필드에 Fabrication 이름을 입력하고 Save 버튼을 클릭합니다.

  3. OutJob을 추가하면 프로젝트가 변경되므로, Projects 패널에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭하고 Save을 선택하여 프로젝트를 로컬에 저장합니다.

제작 출력 추가 및 구성하기

Main page: 제작 데이터 준비하기

이 튜토리얼에서는 보드 제작에 필요한 Gerber 및 NC Drill 파일 출력을 구성합니다. 

  1. 새 Gerber 출력을 추가하려면 OutJob의 Outputs 영역에 있는 Fabrication Outputs 섹션에서 Add New Fabrication Output 링크를 클릭하고 Gerber Files » [PCB Document]을 선택합니다.

    [PCB Document] 옵션을 선택하면 프로젝트의 PCB 문서가 자동으로 출력 소스로 사용됩니다. 또한 이 설정을 업데이트할 필요가 없으므로 프로젝트 간에 OutJob을 쉽게 복사할 수 있습니다. 프로젝트에 PCB 문서가 여러 개 있는 경우 특정 보드를 선택해야 합니다.

  2. 추가된 Gerber Files 출력 항목을 두 번 클릭합니다. Gerber Setup 대화 상자가 열립니다. 대화 상자의 옵션을 다음과 같이 구성합니다.

    1. 보드가 미터법 단위로 설계되었으므로 Units 옵션이 Millimeters로 설정되어 있는지 확인합니다.

    2. 보드에 사용된 최소 단위는 라우팅과 클리어런스의 경우 0.25mm입니다. 그러나 대부분의 부품은 기하학적 중심에 기준점이 있고 1mm 그리드에 배치되었으므로, 일부 패드는 실제로 0.01 그리드에 놓이게 됩니다. Decimal 옵션을 0.001 mm로 설정합니다. 이렇게 하면 출력 데이터의 해상도가 이러한 그리드 위치를 표현하기에 충분해집니다.

    3. Layer to plot 탭 하단의  버튼을 클릭하고 Select Used을 선택합니다. 설계에 사용된 레이어가 위쪽 그리드의 Plot 열에서 활성화됩니다.

  3. Apply을 클릭하여 나머지 기본 설정을 적용하고 Gerber Setup 대화 상자를 닫습니다.

  4. 보드에 홀이 있으므로 NC Drill 파일도 생성해야 합니다. 같은 방법으로 OutJob 파일에 NC Drill 출력을 추가합니다. OutJob의 Outputs 영역에 있는 Fabrication Outputs 섹션에서 Add New Fabrication Output 링크를 클릭하고 NC Drill Files » [PCB Document]을 선택합니다.

  5. 추가된 NC Drill Files 출력 항목을 두 번 클릭하여 NC Drill Setup 대화 상자를 엽니다. NC Drill 파일이 Gerber 파일과 동일한 형식으로 생성되도록 Units을 Millimeters로, Format을 4:3로 설정합니다. Coordinate Position 옵션이 Reference to relative origin로 설정되어 있는지 확인합니다.

  6. 확인을 클릭하여 나머지 기본 설정을 적용하고 NC Drill Setup 대화 상자를 닫습니다.

  7. Gerber 및 NC Drill 설정을 구성했으므로, 다음 단계는 파일 이름과 출력 위치를 구성하는 것입니다. 이를 위해 OutJob 오른쪽의 출력 컨테이너에 해당 출력을 매핑합니다. 각각 고유한 파일 형식을 가진 개별 파일에는 Folder Structure 컨테이너를 사용합니다. 새 OutJob에는 기본적으로 몇 가지 컨테이너가 포함되어 있습니다. 출력 컨테이너 목록에서 Folder Structure 항목을 선택한 다음, 아래 그림과 같이 Outputs 영역의 Enabled 열에서 Gerber 및 NC Drill 파일에 해당하는 라디오 버튼을 클릭하여 이 출력을 선택한 컨테이너에 매핑합니다.

  8. 마지막 단계는 컨테이너를 구성하는 것입니다. 컨테이너 항목이 선택된 상태에서 해당 항목의 Change 링크를 클릭하여 Folder Structure settings 대화 상자를 엽니다. 대화 상자 상단에는 출력 위치를 구성하는 데 사용되는 컨트롤이 있습니다. 첫 번째 컨트롤이 Release Managed로 설정되어 있는지 확인합니다. 대화 상자 하단에는 선택한 옵션에 따라 이름과 폴더 구조가 어떻게 변경되는지 표시됩니다.

  9. OK을 클릭하여 Folder Structure settings 대화 상자를 닫습니다.

DRC 검증 보고서 추가 및 구성하기

Main page: 검증 보고서 준비하기

Altium Designer에는 출력 생성 시 출력 항목으로 포함할 수 있는 여러 검증 검사가 있습니다. 각 검사는 HTML 보고서 파일을 생성합니다. 프로젝트 릴리스 프로세스에서는 다른 출력을 생성하기 전에 이러한 검사가 수행되며, 하나라도 통과하지 못하면 릴리스가 실패합니다.

  1. 새 DRC 검증 출력을 추가하려면 OutJob의 Outputs 영역에 있는 Validation Outputs 섹션에서 Add Validation Output 링크를 클릭하고 Design Rules Check » [PCB Document]을 선택합니다.

  2. 추가된 보고서를 기존 Folder Structure 컨테이너에 매핑합니다. OutJob 오른쪽 목록에서 Folder Structure 항목을 선택한 다음, Outputs 영역의 Enabled 열에서 Design Rules Check 출력에 해당하는 라디오 버튼을 클릭합니다.

  3. Projects 패널에서 Output Job 파일 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Save을 선택하여 파일을 로컬에 저장합니다.

  4. 설계 공간 상단의 탭을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Close Fabrication.OutJob 명령을 선택하여 Output Job 파일을 닫습니다. 

조립 출력 추가 및 구성

Main page: Report Manager에서 BOM Configuration 설정

실제 BOM 출력 파일은 Report Manager 대화 상자를 사용하여 생성합니다. 이 대화 상자는 다양한 설정이 가능한 보고서 생성 엔진으로, 텍스트, CSV, PDF, HTML, Excel 등 여러 형식으로 출력할 수 있습니다. Excel 형식의 BOM에는 미리 정의된 템플릿이나 직접 만든 템플릿을 적용할 수도 있습니다.

  1. Projects 패널에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Add New to Project » Output Job File 명령을 선택하여 프로젝트에 새 OutJob 파일을 추가합니다.

  2. Projects 패널에서 OutJob 항목을 마우스 오른쪽 버튼으로 클릭하고 Save As 명령을 선택합니다. Save As 대화 상자가 열리며, 프로젝트 파일과 같은 위치에 문서를 저장할 수 있는 상태가 됩니다. File name 필드에 Assembly 이름을 입력하고 Save 버튼을 클릭합니다.

  3. Projects 패널에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭하고 Save을 선택하여 프로젝트를 로컬에 저장합니다.

  4. 새 BOM 출력을 추가하려면 OutJob의 Report Outputs 섹션에서 Add New Report Output 링크를 클릭하고 Bill of Materials » [ActiveBOM Document]을 선택합니다.

  5. 추가된 Bill of Materials 출력을 두 번 클릭하여 Report Manager 대화 상자를 엽니다.

  6. 대화 상자 오른쪽에 있는 Properties 창의 Export Options 영역에서 File Format 드롭다운을 사용하여 Generic XLS (*.xls, *.xlsx, *.xlsm)을 선택한 다음, Template 드롭다운을 사용하여 워크스페이스에 있는 템플릿 중 BOM Template Single Supplier 템플릿을 선택합니다.

  7. OK을 클릭하여 변경 사항을 저장하고 Report Manager 대화 상자를 닫습니다.

  8. OutJob의 Documentation Outputs 섹션에서 Add New Documentation Output 링크를 클릭하고 Draftsman » All Draftsman Documents을 선택하여 새 Draftsman 출력을 추가합니다.

  9. 추가된 BOM 및 Draftsman 출력을 기존 PDF 출력 컨테이너에 매핑합니다. 이렇게 하려면 OutJob 오른쪽의 출력 컨테이너 목록에서 PDF 항목을 선택한 다음, Outputs 영역의 Enabled 열에서 Bill of Materials 및 Draftsman 출력의 라디오 버튼을 클릭합니다.

  10. PDF 컨테이너 항목을 선택한 상태에서 해당 항목의 Change 링크를 클릭하여 PDF settings 대화 상자를 엽니다.

  11. PDF settings 대화 상자 상단의 Assembly.PDF 항목을 클릭하고 Separate file for each output using output name을 선택한 다음  버튼을 클릭합니다. 출력 BOM과 도면에는 OutJob에서 각 출력에 설정된 이름(각각 Bill of Materials.pdf 및 Draftsman.pdf)이 지정되며, 이 이름은 대화 상자의 Preview 영역에서 확인할 수 있습니다.

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. OK을 클릭하여 대화 상자를 닫습니다.

  13. OutJob의 Documentation Outputs 섹션에서 Add New Documentation Output 링크를 클릭하고 Generates pick and place files » [PCB Document]을 선택하여 새 픽 앤 플레이스 출력을 추가합니다.

  14. 추가된 Generates pick and place files 출력을 두 번 클릭하여 Pick and Place Setup 대화 상자를 엽니다.

  15. 대화 상자 왼쪽 하단의 Output Setting 영역에서 Units을 Metric으로 설정합니다.

  16. OK을 클릭하여 나머지 기본 설정을 적용하고 Pick and Place Setup 대화 상자를 닫습니다.

  17. 추가된 픽 앤 플레이스 출력을 기존 Folder Structure 출력 컨테이너에 매핑합니다. 이렇게 하려면 OutJob 오른쪽의 출력 컨테이너 목록에서 Folder Structure 항목을 선택한 다음, Outputs 영역의 Enabled 열에서 Generates pick and place files 출력의 라디오 버튼을 클릭합니다.

  18. Projects 패널에서 Output Job 파일 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Save을 선택하여 파일을 로컬에 저장합니다.

  19. 설계 공간 상단의 탭을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Close Assembly.OutJob 명령을 선택하여 Output Job 파일을 닫습니다.

프로젝트 릴리스

Main page: 설계 프로젝트 릴리스

Output Job 파일에서 출력 문서 구성을 완료하면 프로젝트를 연결된 워크스페이스에 릴리스할 준비가 됩니다. 보드 설계 릴리스 프로세스는 자동화되어 있으므로 수동 릴리스 절차에 따르는 위험 없이 보드 설계 프로젝트를 릴리스할 수 있습니다. 특정 프로젝트를 릴리스하면 설계 소스의 스냅샷이 생성되고 모든 생성된 출력과 함께 보관됩니다. 이 출력은 해당 설계 프로젝트를 기반으로 제작되어 회사에서 판매하는 실제 제품을 나타냅니다.

릴리스 프로세스 자체는 Altium Designer의 Project Releaser을 사용하여 수행하며, 전용 뷰인 Release 뷰를 통해 사용자 인터페이스가 제공됩니다. 릴리스 프로세스는 단계별로 진행되며, 뷰 왼쪽의 항목을 통해 현재 어느 단계에 있는지 한눈에 확인할 수 있습니다.

  1. Projects 패널에서 프로젝트 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Project Releaser 명령을 선택합니다. Release 뷰가 별도의 문서 탭으로 열립니다.

  2. 첫 번째 단계인 1. Configure Server Release에서는 생성할 데이터 유형을 지정합니다. 각 데이터 세트 헤더의 맨 오른쪽에 있는 Details 컨트롤을 클릭하면 해당 데이터 세트에서 정확히 무엇이 생성되는지 자세히 확인할 수 있습니다.

  3. 뷰 왼쪽 하단의  버튼을 클릭하여 Project Release Options 대화 상자를 엽니다. 대화 상자의 Release Options 탭에서 Release Target으로 Managed - <WorkspaceName>이 선택되어 있는지, Fabrication이 Fabrication Data 세트에 할당되어 있는지, Assembly이 Assembly Data 세트에 할당되어 있는지 확인합니다.

  4. OK을 클릭하여 대화 상자를 닫고 Release 뷰로 돌아갑니다.

  5. Include Fabrication Data 및 Include Assembly Data for No Variant 옵션이 모두 활성화되어 있는지 확인합니다.

  6. 뷰 오른쪽 하단의  버튼을 클릭하여 계속 진행합니다.

  7. Item Creation 대화 상자가 열리고 워크스페이스에 생성할 릴리스 대상 항목 목록이 표시됩니다. Create items 옵션을 선택하여 항목 생성을 확인합니다.

  8. 열리는 Project Modified 대화 상자에서 Save and Commit changes 옵션을 선택하여 변경 사항을 로컬에 저장하고 워크스페이스에 변경 사항을 저장하는 단계로 진행합니다.

  9. 열리는 Commit to Version Control 대화 상자에서 Comment 필드에 의미 있는 Comment를 입력한 다음(예: The project is ready for release),  버튼을 클릭합니다.

  10. 릴리스 프로세스의 다음 단계인 2. Validate Project은 Fabrication Output Job 파일에 설계 규칙 검사 보고서가 포함되어 있으므로 자동으로 실행됩니다.

    유효성 검사 중 하나라도 통과하지 못하면 릴리스가 실패합니다. 이 튜토리얼의 프로젝트 릴리스에서는 PCB 문서에 DRC 위반이 하나 이상 있다는 의미입니다. 이 경우 뷰 오른쪽 하단의  버튼으로 릴리스 프로세스를 중지하고, PCB 문서를 열어 DRC 위반을 해결한 후 릴리스 프로세스를 다시 시작합니다.

  11. 유효성 검사가 성공적으로 완료되면 릴리스 프로세스의 다음 단계인 3. Generate Data이 자동으로 실행됩니다. 이 단계에서는 포함된 데이터 항목에 할당된 OutJob 파일에 정의된 다른 모든 출력을 실행하여, 워크스페이스의 해당 타겟 항목으로 릴리스할 데이터를 생성합니다.

  12. 모든 유효성 검사를 통과하고 출력 데이터가 생성되면 릴리스 프로세스의 다음 단계인 4. Review Data에서 생성된 데이터를 검토할 수 있습니다. 뷰 오른쪽 하단의  버튼을 클릭하여 릴리스를 진행합니다.

  13. Confirm Release 대화 상자가 열리고 워크스페이스로 릴리스할 프로젝트의 구성이 요약되어 표시됩니다. Release Note을 입력하고(예: Initial Release), OK을 클릭합니다.

  14. 이전 단계에서 릴리스를 확인하면 다음 단계인 5. Upload Data으로 자동으로 넘어갑니다. 이 단계에서는 워크스페이스의 해당 데이터 항목 리비전으로 데이터를 업로드하는 진행 상황이 표시됩니다.

  15. 프로세스의 마지막 단계인 6. Execution Report에서는 릴리스 요약이 제공됩니다. 뷰 오른쪽 하단의  버튼을 클릭하여 릴리스 뷰를 닫습니다.

워크스페이스를 활용한 협업 설계

전자 제품의 설계 및 개발에는 대개 여러 사람이 참여합니다. 이를 효과적으로 수행하려면 설계 팀 구성원들이 협업할 수 있어야 합니다. Altium Designer는 연결된 워크스페이스와 함께 다양한 협업 설계 기능을 지원합니다. 그중 일부는 다음과 같습니다.

  • Project history – 전용 History 뷰는 프로젝트 생성, 커밋, 릴리스, 복제, MCAD 데이터 교환 등 프로젝트와 관련된 주요 이벤트를 시간순으로 보여 주는 고급 그래픽 기반 프로젝트 이력 타임라인이며, 해당하는 경우 다양한 작업을 지원합니다(). Altium Designer에서 워크스페이스 프로젝트의 History 뷰에 액세스하려면 Projects Panel에서 프로젝트 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 History & Version Control » Show Project History 명령을 선택합니다.

    자세히 알아보기: 프로젝트 이력, Project History (Altium 365 워크스페이스, Enterprise Server 워크스페이스)

  • Web Viewer – 워크스페이스의 Web Viewer 인터페이스를 사용하면 표준 브라우저를 통해 어디서나 프로젝트 문서에 액세스할 수 있습니다. 단순한 브라우저 기반 뷰어를 넘어, 고급 브라우저 기술을 통해 프로젝트 구조를 탐색하고, 설계 문서와 상호 작용하고, Comment를 달 영역이나 객체를 강조 표시하고, 설계 전반의 부품과 네트를 검색, 교차 탐색, 선택 및 검사할 수 있습니다. Altium Designer에서 워크스페이스 프로젝트의 Web Viewer에 액세스하려면 Projects Panel에서 프로젝트 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Show in Web Browser 명령을 선택합니다.

    자세히 알아보기: Web Viewer (Altium 365 플랫폼, Enterprise Server 워크스페이스)

  • Document commenting – Comment는 지원되는 데이터 뷰의 특정 지점, 객체 또는 영역(해당하는 경우)에 사용자가 추가하는 메모로, 다른 사용자가 답글을 달 수 있습니다. Comment는 워크스페이스에 해당 데이터와 별도로 저장되므로 공유 데이터 자체를 변경하지 않고도 사용자 간 협업을 촉진합니다. 다음 위치의 Web Viewer 인터페이스에서 추가한 Comment는 Altium Designer에서도 사용할 수 있으며, 그 반대도 마찬가지입니다. Altium Designer에서는 Comments and Tasks Panel()을 통해 Comment 기능을 관리합니다.

    자세히 알아보기: 문서에 Comment 추가하기, Web Viewer (Altium 365 플랫폼, Enterprise Server 워크스페이스)

  • Sharing a project – 프로젝트를 워크스페이스에 저장하면 협업 설계 및/또는 프로젝트 검토를 위해 실제로 해당 프로젝트에 액세스할 수 있는 사용자를 지정할 수 있습니다. 이는 프로젝트를 공유하는 방식으로, 더 정확히는 액세스 권한을 설정하여 수행합니다. Altium Designer에서는 Share 대화 상자()를 통해 프로젝트 공유를 관리합니다. 이 대화 상자에 액세스하려면 Projects Panel에서 프로젝트 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Share 명령을 선택합니다.

    자세히 알아보기: 설계 공유하기, Workspace Projects (Altium 365 워크스페이스, Enterprise Server 워크스페이스)

축하합니다! 빈 Schematic 시트에서 시작하여 완성된 PCB를 만들고 출력물을 워크스페이스로 릴리스하는 데까지, Altium Designer의 전체 설계 과정을 완료했습니다!

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents