부품 배치 및 보드 라우팅

개요

Altium Designer에서 컴포넌트를 배치하고 PCB를 인터랙티브 방식으로 라우팅하는 방법을 알아보세요. 이 튜토리얼에서는 컴포넌트와 지정자 배치, 라우팅 설정 구성, 트랙을 통한 패드 연결, 라우팅된 보드의 3D 확인 과정을 안내합니다. 단계별로 따라 하며 컴포넌트 배치를 연결이 완료된 보드로 완성하고 설계 검증을 준비하세요.

- Snap 그리드와 연결선을 배치 가이드로 활용하여 컴포넌트의 위치와 회전을 조정합니다.
- 인터랙티브 라우팅을 설정하고 단축키를 사용하여 트랙을 배치하고, 장애물을 피하고, 연결을 완료합니다.
- 3D 레이아웃 모드로 전환하고 확대/축소, 화면 이동, 회전 기능을 사용하여 보드를 살펴봅니다.
AI로 더 깊이 알아보기:

이제 컴포넌트를 보드의 적절한 위치에 배치한 다음 라우팅할 차례입니다.

PCB에 컴포넌트 배치하기

Main page: 컴포넌트 배치

PCB 설계는 배치가 90%, 라우팅이 10%라는 말이 있습니다. 각 비율에 대해서는 이견이 있을 수 있지만, 좋은 컴포넌트 배치가 좋은 보드 설계에 매우 중요하다는 점은 널리 인정됩니다. 라우팅하면서 배치를 조정해야 할 수도 있다는 점을 기억하세요.

컴포넌트를 이동하려면, Click, Hold&Drag 컴포넌트를 원하는 위치로 이동하고 Spacebar 키로 회전한 다음(시계 반대 방향으로 90º씩), 마우스 버튼을 놓아 배치합니다. 컴포넌트를 이동하면 Connection 선이 자동으로 다시 최적화됩니다. 이 선을 참고하여 컴포넌트의 방향과 위치를 조정하면 Connection 선이 서로 교차하는 횟수를 줄일 수 있습니다.

컴포넌트를 배치하고 나면 PCB가 아래 이미지와 같은 모습이 됩니다.

컴포넌트가 보드에 배치되어 라우팅할 준비가 되었습니다.
컴포넌트가 보드에 배치되어 라우팅할 준비가 되었습니다.

  1. 보드와 컴포넌트가 보이도록 확대/축소합니다.

  2. 컴포넌트는 현재 Snap Grid에 맞춰 배치됩니다. 이와 같이 간단한 설계에는 사용할 배치 Grid를 지정하는 특별한 설계 요구사항이 없습니다. 설계자가 적절한 배치 Grid를 결정하면 됩니다. 컴포넌트 배치 과정을 간소화하려면 큰 배치 Grid를 사용할 수 있습니다. 상태 표시줄에서 Snap Grid 값이 1 mm로 설정되어 있는지 확인합니다. 필요한 경우 메인 메뉴에서 View » Grids » Set Global Snap Grid 명령을 사용합니다.

  3. 커넥터 P1을 배치하려면:

    1. 커넥터 Outline의 중앙에 커서를 놓고 Click, Hold&Drag 동작을 수행합니다. 커서가 십자 모양으로 바뀌고 컴포넌트에서 가장 가까운 Pad의 중앙으로 이동합니다.

    2. 마우스 버튼을 계속 누른 상태에서 마우스를 움직여 컴포넌트를 드래그합니다. Connection 선도 컴포넌트와 함께 드래그되는 것을 확인할 수 있습니다.

    3. 필요한 경우 Spacebar 키를 눌러 컴포넌트를 회전하고, 위 이미지와 같이 보드의 왼쪽에 배치합니다.

    4. 커넥터 컴포넌트가 원하는 위치에 오면 마우스 버튼을 놓아 배치합니다.

  4. 위 이미지를 참고하여 나머지 컴포넌트의 위치를 조정합니다. 컴포넌트를 드래그하면서 Spacebar 키로 회전하여 Connection 선이 이미지와 같은 모습이 되도록 합니다.

  5. 컴포넌트 Designator의 위치를 조정합니다. 이 작업도 비슷한 방식으로 수행할 수 있습니다. Click, Hold&Drag 동작으로 텍스트를 이동하고 Spacebar 키를 눌러 회전합니다. 또는 설계 공간에서 Designator를 선택한 상태에서() Properties Panel의 Autoposition 옵션을 사용합니다.

  6. Projects Panel에서 PCB 문서의 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Save 항목을 선택하여 PCB 문서를 로컬에 저장합니다.

컴포넌트 배치가 완료되었으니 이제 라우팅할 차례입니다!

보드 인터랙티브 라우팅하기

Main page: 인터랙티브 라우팅

이 튜토리얼 부분에서는 보드를 라우팅합니다.

라우팅은 컴포넌트 핀을 연결하기 위해 보드에 Track과 비아를 배치하는 과정입니다. PCB Editor는 정교한 인터랙티브 라우팅 도구를 제공하여 이 작업을 쉽게 수행할 수 있도록 합니다. 이 도구는 Track 배치를 위한 커서 안내, 싱글 클릭으로 Connection 라우팅, 장애물 밀어내기, 기존 Connection 자동 추종 등의 기능을 통해 직관적인 방식으로 라우팅 효율성과 유연성을 극대화하며, 모든 작업은 적용되는 설계 제약 조건을 준수합니다.

보드 라우팅 과정을 보여주는 동영상입니다. 일부 Connection은 Ctrl+Click 동작으로 자동 완성하여 마무리합니다.

  1. 라우팅을 시작하기 전에 Preferences 대화 상자의 PCB Editor – Interactive Routing 페이지에서 인터랙티브 라우팅 옵션을 구성합니다.

    1. 다음을 클릭합니다:  설계 공간 상단의 버튼을 클릭하여 Preferences 대화 상자를 연 다음, 왼쪽 트리에서 PCB Editor 범주를 확장하고 이 범주의 Interactive Routing Entry를 선택하여 페이지를 엽니다.

    2. 페이지의 Routing Conflict Resolution Region에서 Current Mode을(를) Walkaround Obstacles(으)로 설정합니다.

    3. 페이지의 Interactive Routing Width Sources Region에서 Track Width Mode 및 Via Size Mode 옵션이 모두 Rule Preferred(으)로 설정되어 있는지 확인합니다.

    4. OK을(를) 클릭하여 변경 사항을 저장하고 대화 상자를 닫습니다.

     
     
     
     
     

  2. Snap Grid 대화 상자(View » Grids » Set Global Snap Grid)를 사용하여 Snap Grid를 0.25 mm로 설정합니다.

  3. 설계 공간 하단의 Top Layer 탭을 클릭하여 활성 레이어로 설정하고 라우팅할 준비를 합니다.

  4. 주 메뉴에서 Route » Interactive Routing 명령을 선택합니다(단축키: Ctrl+W). 커서가 십자 모양으로 바뀌어 인터랙티브 라우팅 모드임을 나타냅니다.

  5. 커넥터 P1의 아래쪽 Pad 위에 커서를 놓습니다.

  6. 클릭하여 Track의 첫 번째 점을 고정합니다.

  7. 커서를 Pad 아래로 이동하고 클릭하여 수직 세그먼트를 배치합니다.

  8. 클릭하여 Track 세그먼트를 Commit하면서 라우팅하고, R2의 아래쪽 Pad에서 마무리합니다.

  9. 계속해서 보드의 모든 연결을 라우팅합니다. 위 동영상은 보드를 인터랙티브 방식으로 라우팅하는 과정을 보여 줍니다.

  10. 라우팅을 마치면 Projects Panel에서 PCB 문서의 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Save 을(를) 선택하여 PCB 문서를 로컬에 저장합니다.

Altium Designer의 강력한 기능 중 하나는 보드를 3차원 객체로 볼 수 있다는 점입니다. 3D로 전환하려면 주 메뉴에서 View » 3D Layout Mode 명령을 실행합니다(단축키: 3). 보드가 3차원 객체로 표시됩니다. 아래는 튜토리얼 보드의 모습입니다.

3D에서 보드를 탐색하려면 다음 조작 방법을 사용할 수 있습니다.

  • 확대/축소 – Ctrl+Mouse Wheel

  • 화면 이동 – Right-Click, Hold&Drag.

  • 회전 – Shift+Right-Click, Hold&Drag. Shift을(를) 누르면 현재 커서 위치에 방향 구체가 나타나며, 이 구체의 중심을 기준으로 모델이 회전합니다.

자세한 내용은 3D 뷰 제어 페이지를 참조하세요.

PCB 설계가 완료되었습니다. 이제 보드 설계를 검증하여 PCB가 정의된 제약 조건을 준수하는지 확인합니다. 

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents