Searching for Components in Database & File-based Libraries
Altium Essentials: Schematic Capture
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Poznaj różnice między bibliotekami projektu, bibliotekami zainstalowanymi i bibliotekami ze ścieżek wyszukiwania oraz ich wpływ na dostępność komponentów w Altium Designer.
- Dowiedz się, gdzie zarządzać dostępnymi bibliotekami, jak działa kolejność wyszukiwania i dlaczego niektóre ustawienia bibliotek mogą wpływać na szybkość i niezawodność.
- Sprawdź, jak działa wyszukiwanie komponentów w bibliotekach plikowych i bazodanowych oraz czego można się spodziewać podczas korzystania ze źródeł DbLib i SVNDbLib.
Zarządzanie dostępnymi bibliotekami bazodanowymi i plikowymi
W Altium Designer komponenty z bibliotek bazodanowych i plikowych można umieszczać tylko z bibliotek, które są aktualnie dostępne. Należą do nich:
-
Libraries in the current project – jeśli biblioteka jest częścią projektu, jej komponenty są automatycznie dostępne do umieszczania w tym projekcie.
-
Installed libraries – biblioteki te zostały zainstalowane w Altium Designer; ich komponenty są dostępne do użycia w każdym otwartym projekcie.
-
Libraries on a defined search path – można również zdefiniować ścieżkę wyszukiwania do folderu zawierającego wiele bibliotek. Ponieważ wszystkie pliki w ścieżce wyszukiwania są przeszukiwane przy każdym wyborze nowego komponentu w panelu, to podejście jest zalecane tylko w przypadku małych bibliotek z prostymi definicjami modeli, takich jak modele symulacyjne. Ścieżki wyszukiwania nie są zalecane w przypadku złożonych modeli, takich jak footprinty zawierające modele 3D.
Aby zarządzać dostępnymi bibliotekami bazodanowymi i plikowymi, można użyć okna dialogowego Libraries Preferences, które otwiera się po kliknięciu przycisku
u góry panelu Components i wybraniu z menu opcji Libraries Preferences.
Okno dialogowe Libraries Preferences zawiera trzy karty. Wszystkie biblioteki i lokalizacje modeli zdefiniowane na tych kartach są łączone w listę dostępnych bibliotek. Gdy wykonywana jest operacja wymagająca wyszukania modelu, na przykład przeniesienie projektu ze schematu do projektu PCB, biblioteki są przeszukiwane w kolejności kart, a następnie w obrębie każdej karty w kolejności, w jakiej wymieniono biblioteki i modele. Po znalezieniu właściwego modelu wyszukiwanie zostaje zakończone.
Biblioteki projektu
Biblioteki należące do aktywnego projektu są wymienione na karcie Project okna dialogowego Libraries Preferences, gdy dany projekt jest aktywny w oprogramowaniu. Zaletą bibliotek projektu jest to, że modele i biblioteki stają się automatycznie dostępne po każdym otwarciu projektu. Wadą jest to, że jeśli modele i biblioteki nie są przechowywane w tej samej strukturze folderów projektu co pliki projektowe, można o nich łatwo zapomnieć podczas przenoszenia plików projektu.

Karta Project zawiera listę dostępnych bibliotek w bieżącym projekcie.
Zainstalowane biblioteki
Biblioteki i modele udostępnione w danej instalacji oprogramowania są określane jako zainstalowane biblioteki. Są one wymienione na karcie Installed okna dialogowego Libraries Preferences.
Zainstalowane biblioteki mogą być wskazywane za pomocą ścieżki bezwzględnej lub ścieżki względnej wobec ustawienia Library Path Relative To. Zaletą ścieżki względnej jest możliwość utworzenia wspólnego podśrodowiska na wielu komputerach, co ułatwia przenoszenie między nimi plików projektowych. Ponadto zainstalowane biblioteki można tymczasowo dezaktywować, usuwając zaznaczenie pola wyboru Activated, zamiast je usuwać.

Karta Installed zawiera listę bibliotek udostępnionych w tej instalacji Altium Designer.
Ścieżka wyszukiwania
Karta Search Path przedstawia listę bibliotek znalezionych zgodnie z ustawieniami ścieżek zdefiniowanymi na karcie Ścieżki wyszukiwania w oknie dialogowym Opcje projektu, które można otworzyć, klikając przycisk Paths. Każda ścieżka wyszukiwania określa folder i może obejmować podfoldery, jeśli włączona jest opcja Recursive (dostępna na karcie Search Paths okna dialogowego Project Options po dodaniu ścieżki). Wszystkie pliki modeli i bibliotek znalezione w ścieżce wyszukiwania będą dostępne. Ścieżki wyszukiwania są zapisywane wraz z projektem.

Karta Search Path zawiera listę bibliotek znalezionych w zdefiniowanych ścieżkach wyszukiwania.
Wyszukiwanie modeli przy użyciu ścieżek wyszukiwania może być powolne, jeśli foldery objęte wyszukiwaniem zawierają dużą liczbę plików. Z tego powodu nie zaleca się stosowania tego podejścia do bibliotek PCB, ponieważ mogą to być duże pliki zawierające wiele footprintów. Funkcję tę opracowano w celu umożliwienia odwoływania się do dostępnych modeli symulacyjnych i modeli integralności sygnałów.
Przeglądanie komponentów bazy danych
Po dodaniu biblioteki DbLib/SVNDbLib do listy dostępnych bibliotek plikowych komponenty w bazie danych będzie można przeglądać w panelu Components. Mimo że dodawany jest tylko jeden plik DbLib/SVNDbLib, każda tabela w połączonej bazie danych będzie wyświetlana jako osobna biblioteka.
Górna lista rozwijana w panelu zostanie wypełniona wpisami w postaci:
- <LibraryName>.DbLib - <TableName> lub <LibraryName>.SVNDbLib - <TableName> ----gdy baza danych zawiera tabele
- <LibraryName>.DbLib - <SheetName>$ lub <LibraryName>.SVNDbLib - <SheetName>$ ----gdy baza danych składa się z arkuszy w skoroszycie programu Excel.
Przykład załadowanej biblioteki DbLib z trzema tabelami, innej z jedną tabelą oraz biblioteki SVNDbLib z jedną tabelą.
Każda pozycja komponentu w panelu odpowiada rekordowi w danej tabeli bazy danych. Podczas przeglądania załadowanych bibliotek bazodanowych panel Components działa w istocie jak bezpośrednia przeglądarka bazy danych. Informacje o symbolach i modelach są pobierane z bibliotek symboli i modeli wskazanych w odpowiednich polach bazy danych (z uwzględnieniem zdefiniowanych ścieżek/lokalizacji wyszukiwania).
Przeglądanie komponentów w zewnętrznej bazie danych połączonej za pośrednictwem biblioteki bazodanowej.
Domyślnie w obszarze listy komponentów w panelu wyświetlane są tylko pola Part Number i Library Ref. Aby wyświetlić inne pola tabeli bazy danych, kliknij ten obszar prawym przyciskiem myszy i wybierz Select Columns z menu kontekstowego. Otworzy się okno dialogowe Select Columns, w którym można włączyć wyświetlanie dowolnych dodatkowych pól tej tabeli.
Lokalne buforowanie symboli i modeli używanych przez biblioteki bazodanowe SVN
Po dodaniu pliku SVNDbLib do listy dostępnych bibliotek biblioteki symboli i modeli z repozytorium są zapisywane w pamięci podręcznej w folderze tymczasowym na komputerze projektanta. Gdy działanie w programie wymaga użycia symbolu schematowego lub modelu, dany symbol lub model jest pobierany z lokalnej pamięci podręcznej.
Automatyczna aktualizacja pamięci podręcznej
Biblioteki w pamięci podręcznej będą automatycznie aktualizowane do najnowszych wersji z repozytorium kontroli wersji podczas wykonywania w programie dowolnej z następujących czynności:
-
Umieszczanie komponentu z zainstalowanego pliku SVNDbLib (z panelu Components).
-
Przenoszenie projektu (tj. aktualizacja PCB).
-
Użycie polecenia Tools » Update From Libraries w edytorze schematów.
-
Użycie polecenia Tools » Update From PCB Libraries w edytorze PCB.
Chociaż aktualizacja jest automatyczna, można nią sterować za pomocą opcji Do not check files more often than xx minutes na stronie Data Management - SVN Libraries w Preferences oknie dialogowym. Opcja ta zasadniczo określa odstęp między aktualizacjami lokalnej pamięci podręcznej. Jeśli od ostatniej aktualizacji pamięci podręcznej upłynął określony czas, zostanie ona automatycznie zaktualizowana po wykonaniu jednej z wymienionych czynności. Jeśli czynność zostanie wykonana przed upływem tego czasu, użyta zostanie bieżąca zawartość pamięci podręcznej, która może być nieaktualna w porównaniu z zawartością repozytorium.
Ręczne wymuszanie aktualizacji pamięci podręcznej
Czasami może być konieczne wymuszenie aktualizacji lokalnej pamięci podręcznej, aby mieć pewność, że zawiera ona najnowsze biblioteki przechowywane obecnie w repozytorium kontroli wersji. Na przykład podczas przygotowywania się do przeniesienia projektu ze schematu na PCB.
Aktualizację pamięci podręcznej można wymusić ręcznie jedną z następujących metod:
- Używając jednego z poleceń Refresh dostępnych w menu otwieranym prawym przyciskiem myszy w panelu Components.
- Usuwając plik SVNDbLib z listy Available Libraries i ponownie go do niej dodając.
Wyszukiwanie komponentów w bibliotekach bazodanowych i plikowych
Aby ułatwić znajdowanie komponentów w bibliotekach plikowych (zarówno zainstalowanych, jak i aktualnie niezainstalowanych) oraz bazodanowych, Altium Designer udostępnia funkcję przeszukiwania bibliotek.
Wyszukiwanie komponentów w bibliotekach bazodanowych i plikowych jest możliwe za pomocą pola Search w panelu Components. Wprowadź ciąg znaków i naciśnij Enter, aby wyszukać go w bieżącej bibliotece, w dowolnym miejscu widocznych parametrów komponentów.
Wyszukiwanie można przeprowadzić bezpośrednio w panelu Components.
Okno dialogowe File-based Libraries Search umożliwia bardziej szczegółowe wyszukiwanie. Aby je otworzyć, kliknij przycisk
w panelu Components i wybierz File-based Libraries Search z menu. Górna połowa okna dialogowego służy do określenia what szukasz, a dolna — do określenia where szukać.
Przeszukuj zainstalowane biblioteki (Available libraries) lub biblioteki na dysku twardym (Libraries on path).Proces wyszukiwania można podsumować następująco:
-
Wyszukiwanie odbywa się przez zdefiniowanie Filters stosowanych do wszystkich bibliotek, które można przeszukać zgodnie z bieżącymi ustawieniami Scope wyszukiwania.
-
Ustawienie Scope obejmuje typ bibliotek do przeszukania. Jednocześnie można przeszukiwać tylko jeden typ.
-
Aby włączyć wyszukiwanie komponentów w bazie danych, ustaw pole Search in na Database Components i wybierz wymagane Table. Pamiętaj, że dostępne Fields na powyższej liście rozwijanej zmienią się, aby odpowiadać nagłówkom kolumn dostępnym w wybranej tabeli. Pozostałe opcje w oknie dialogowym zostaną wyszarzone, ponieważ nie mają zastosowania podczas przeszukiwania bibliotek bazodanowych.
-
Ustawienie Scope określa, które biblioteki zostaną przeszukane: biblioteki, do których program ma obecnie dostęp (Available libraries), lub wszystkie biblioteki w folderze (Libraries on path).
-
Podczas przeszukiwania bibliotek we wskazanej ścieżce celem jest określony folder; można także Include Subdirectories.
-
Można również przeszukiwać wyniki wyszukiwania, ustawiając Scope na Refine last search.
-
Kliknij Clear, aby wyczyścić wprowadzone parametry wyszukiwania.
Ustawianie filtra wyszukiwania
Obszar Filters służy do definiowania ciągów tekstowych używanych podczas wyszukiwania. Należy skonfigurować trzy obszary:
-
Field – atrybut komponentu, który ma zostać przeszukany. Może to być dowolny atrybut komponentu lub obudowy, w tym nazwa, opis, komentarz, obudowa lub dowolny parametr dodany do komponentu. Wybierz dostępne pole z listy rozwijanej lub wpisz je w polu tekstowym.
-
Operator – określa sposób ustalania dopasowania. Dopasowanie może wystąpić, gdy wartość equals, contains, starts with lub ends with. Pamiętaj, że equals wymaga dokładnego dopasowania ciągu znaków, dlatego należy używać tej opcji tylko wtedy, gdy masz pewność, że wyszukiwany ciąg jest poprawny i kompletny.
-
Value – znaki, które mają zostać wyszukane w wybranym Field, dopasowywane zgodnie z wybranym Operator. Wybierz dostępną wartość z listy rozwijanej lub wpisz wartość w polu tekstowym.
Domyślnie dostępne są trzy warunki filtrowania; za pomocą elementu sterującego Add Row można dodać maksymalnie siedem dodatkowych wierszy, uzyskując łącznie 10 wierszy. Ostatnio dodany wiersz warunku filtrowania można usunąć za pomocą Remove Row. Nieużywane wiersze można usuwać.
Ustawianie zakresu
Zasadniczo istnieją dwa sposoby wyszukiwania:
-
Aktualnie dostępne biblioteki – jest to lista bibliotek wyświetlana na liście rozwijanej u góry panelu Components .
-
Biblioteki zapisane w określonym folderze, a także w podfolderach, jeśli ta opcja jest włączona.
Wyszukiwanie zwróci wszystkie elementy typu wybranego na liście rozwijanej Search in (Components/Footprints/3D Models/Database Components), znalezione we wszystkich bibliotekach objętych zdefiniowanym zakresem Scope:
- Available libraries — włącz, aby wyszukiwać modele określonych typów wyłącznie w dostępnych bibliotekach.
-
Libraries on path — włącz, aby wyszukiwać modele określonych typów w dostępnych bibliotekach w określonych folderach. W obszarze Path okna dialogowego, który staje się dostępny po wybraniu opcji zakresu Libraries on path, można zdefiniować ścieżkę, uwzględnić podfoldery oraz określić maskę plików bibliotek w celu sprecyzowania i zawężenia kryteriów wyszukiwania:
- Path — edytuj, aby określić folder, w którym mają być wyszukiwane biblioteki, lub kliknij ikonę przeglądania na końcu pola, aby wskazać folder.
- Include Subdirectories — włącz, jeśli chcesz wyszukiwać biblioteki w określonej ścieżce i jej podfolderach.
-
File Mask — wprowadź maskę plików lub wybierz jedną z istniejących masek z listy rozwijanej. Wyniki wyszukiwania są filtrowane zgodnie z wprowadzonym ciągiem. W ciągu można używać symbolu wieloznacznego * (dowolny znak). Na przykład wpisz *, aby wyszukać wszystkie pliki, lub wpisz M, aby wyszukać wszystkie pliki, których nazwy zaczynają się na literę M.
Na przykład, jeśli chcesz znaleźć komponent, który według Ciebie znajduje się w bibliotece w określonych folderach na dysku twardym, a biblioteka ta nie jest obecnie wymieniona w Available File-based Libraries, zdefiniuj wyszukiwanie następująco:
- W obszarze Scope ustaw Search in na Components i wybierz Libraries on path.
- W obszarze Path ustaw Path tak, aby wskazywał folder zawierający dokument biblioteki, który chcesz przeszukać.
- Kliknij Search. Wyniki są wyświetlane w panelu Components w trakcie wyszukiwania.
Zaawansowany tryb wyszukiwania
Wyszukiwanie w bibliotekach jest w rzeczywistości wykonywane za pomocą zapytań. W oknie dialogowym File-based Libraries Search przełącz się do trybu Advanced, aby przeanalizować zapytanie.
W trybie Advanced tego okna dialogowego można również tworzyć własne zapytania, używając słów kluczowych języka zapytań do wyszukiwania opartego na zapytaniach. Więcej informacji o dostępnych słowach kluczowych języka zapytań znajdziesz w sekcji poniżej.
Po wybraniu trybu Advanced użyj następujących dodatkowych elementów sterujących:
-
Helper — kliknij, aby otworzyć okno dialogowe Pomocnik zapytań, które ułatwia tworzenie zapytań do wyszukiwania w bibliotekach przy użyciu predefiniowanych funkcji bibliotecznych i systemowych. Możesz również użyć przycisków History i Favorites, aby wybrać ostatnio używane lub predefiniowane zapytanie biblioteczne.
-
History — kliknij, aby otworzyć okno dialogowe Menedżer wyrażeń i wybrać jedno z wcześniej używanych wyrażeń zapytań do wyszukiwania w bibliotekach. Możesz również użyć przycisku Favorites, aby zastosować predefiniowane zapytanie do określonego wyszukiwania w bibliotekach.
-
Favorites — kliknij, aby otworzyć okno dialogowe Menedżer wyrażeń i wybrać jedno z ulubionych wyrażeń zapytań do wyszukiwania w bibliotekach. Możesz również zmodyfikować listę Favorites, usuwając wyrażenia, zmieniając ich nazwy lub kopiując je z listy History.
Podczas wyszukiwania wśród Database Components tryb Advanced umożliwia wyszukiwanie za pomocą zapytań SQL. Ten poziom wyszukiwania oferuje precyzyjne wyszukiwanie na podstawie określonego wyrażenia zapytania — zapytanie SQL można wprowadzić bezpośrednio w sekcji edytora zapytań w oknie dialogowym.
Kliknij Advanced , aby uzyskać dostęp do zaawansowanego wyszukiwania opartego na zapytaniach SQL. Kliknij Advanced ponownie, aby wrócić do wyszukiwania prostego.
Funkcje zapytań dotyczących komponentów i bibliotek

Funkcje zapytań dotyczących komponentów i bibliotek w oknie dialogowym Query Helper
Podstawą działania edytorów schematów i PCB w Altium Designer jest zaawansowany silnik zapytań. Wprowadzając do niego zapytania, można za pomocą warunków logicznych precyzyjnie określić zbiór potrzebnych obiektów.
Zapytanie to wprowadzany ciąg znaków, który przy użyciu określonych słów kluczowych i składni zwraca wskazane obiekty. Dostępnych jest wiele słów kluczowych, które pozwalają wybierać obiekty według ich typu, właściwości lub obu tych kryteriów.
Poniższe sekcje szczegółowo opisują słowa kluczowe języka zapytań dostępne podczas wyszukiwania komponentów z baz danych i bibliotek plikowych w Altium Designer. Aby uzyskać pomoc dotyczącą określonego słowa kluczowego zapytania, skorzystaj z poniższych rozwijanych sekcji lub zaznacz dane słowo kluczowe (albo kliknij w jego obrębie) w Query Helper.
Komponenty
Komentarz
Podsumowanie
Zwraca wszystkie komponenty, których Comment spełnia warunki zapytania.
Składnia
Comment : String
Przykłady użycia
Comment = 'Res1'
Zwraca wszystkie komponenty, których Comment ma wartość Res1.
Comment = '100nF'
Zwraca wszystkie komponenty, których Comment ma wartość 100nF.
Comment Like '*33*'
Zwraca wszystkie komponenty, których Comment zawiera 33.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Typ komponentu
Podsumowanie
Zwraca wszystkie komponenty, których właściwość Component Type spełnia warunki zapytania.
Składnia
ComponentType = ComponentType_String
ComponentType_String musi być jednym z ciągów z poniższej listy:
- 'Graphical'
- 'Jumper'
- 'Mechanical'
- 'Net Tie'
- 'Net Tie (In BOM)'
- 'Standard'
- 'Standard (No BOM)'
Przykłady użycia
ComponentType = 'Graphical'
Zwraca wszystkie komponenty, których Component Type ma wartość Graphical.
ComponentType = 'Standard'
Zwraca wszystkie komponenty, których Component Type ma wartość Standard.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym File Libraries Search.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
-
Znaki pojedynczego cudzysłowu (') na początku i końcu
ComponentType_Stringsą obowiązkowe.
Oznaczenie
Podsumowanie
Zwraca wszystkie komponenty, których właściwość Designator spełnia warunki zapytania.
Składnia
Designator : String
Przykłady użycia
Designator = 'U2'
Zwraca wszystkie komponenty, których właściwość Designator ma wartość U2.
Designator Like '*Channel*'
Zwraca wszystkie komponenty, których właściwość Designator zawiera Channel.
Designator <> 'C*'
Zwraca wszystkie komponenty except te, których właściwość Designator zaczyna się od C.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym File Libraries Search.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Ma model
Podsumowanie
Zwraca każdy komponent powiązany z modelem dziedzinowym (lub odwołujący się do niego), którego właściwości spełniają warunki zapytania.
Składnia
HasModel(ModelType : String,ModelName : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
Ciąg ModelType określa właściwość Type powiązanego modelu i musi być jednym z ciągów z poniższej listy:
- 'PCB3DLIB' — użyj tego ciągu, aby wskazać powiązany model, którego właściwość Type ma wartość PCB3D.
- 'PCBLIB' — użyj tego ciągu, aby wskazać powiązany model, którego właściwość Type ma wartość Footprint.
- 'IBIS' — użyj tego ciągu, aby wskazać powiązany model, którego właściwość Type ma wartość Ibis Model.
- 'SI' — użyj tego ciągu, aby wskazać powiązany model, którego właściwość Type ma wartość Signal Integrity.
- 'SIM' — użyj tego ciągu, aby wskazać powiązany model, którego właściwość Type ma wartość Simulation.
Ciąg ModelName określa właściwość Name powiązanego modelu.
Parametr CurrentModelOnly określa, czy powiązany model musi być bieżącym modelem każdego komponentu. Gdy ma wartość False, powiązany model nie musi być bieżącym modelem (ale może nim być); gdy ma wartość True, powiązany model musi być bieżącym modelem.
Przykłady użycia
HasModel('PCBLIB','SOIC14',False)
HasModel('PCBLIB','SOIC14',False) = True
HasModel('PCBLIB','SOIC14',False) = 'True'
Zwraca wszystkie komponenty powiązane z modelem obudowy, którego właściwość Name ma wartość SOIC14; model ten nie musi być bieżącym modelem obudowy każdego komponentu (ale może nim być).
HasModel('PCBLIB','DIP14',True)
HasModel('PCBLIB','DIP14',True) = True
HasModel('PCBLIB','DIP14',True) = 'True'
Zwraca wszystkie komponenty powiązane z modelem obudowy, którego właściwość Name ma wartość DIP14; model ten musi być bieżącym modelem obudowy komponentu.
HasModel('SI','RES1',False)
HasModel('SI','RES1',False) = True
HasModel('SI','RES1',False) = 'True'
Zwraca wszystkie komponenty powiązane z modelem integralności sygnałów, którego właściwość Name ma wartość RES1; model ten nie musi być bieżącym modelem integralności sygnałów każdego komponentu (ale może nim być).
HasModel('SIM','RESISTOR',True)
HasModel('SIM','RESISTOR',True) = True
HasModel('SIM','RESISTOR',True) = 'True'
Zwraca wszystkie komponenty powiązane z modelem symulacyjnym, którego właściwość Name ma wartość RESISTOR; model ten musi być bieżącym modelem symulacyjnym komponentu.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym File Libraries Search.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Ma parametr modelu
Podsumowanie
Zwraca każdy komponent powiązany z modelem dziedzinowym (lub odwołujący się do niego), który zawiera obiekt parametru, którego właściwości Parameter Name i Value spełniają warunki zapytania.
Składnia
HasModelParameter(Parameter Name : String,Value : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
Parametr CurrentModelOnly określa, czy powiązany model (zawierający parametr spełniający warunki zapytania) musi być bieżącym modelem każdego komponentu. Gdy ma wartość False, powiązany model nie musi być bieżącym modelem (ale może nim być); gdy ma wartość True, powiązany model musi być bieżącym modelem.
Przykłady użycia
HasModelParameter('Inductance A','1mH',False)
HasModelParameter('Inductance A','1mH',False) = True
HasModelParameter('Inductance A','1mH',False) = 'True'
Zwraca wszystkie komponenty powiązane z modelem zawierającym obiekt parametru, którego właściwość Parameter Name ma wartość Inductance A, a właściwość Value ma wartość 1mH. Model ten nie musi być bieżącym modelem każdego komponentu (ale może nim być).
HasModelParameter('Coupling Factor','0.999',True)
HasModelParameter('Coupling Factor','0.999',True) = True
HasModelParameter('Coupling Factor','0.999',True) = 'True'
Zwraca wszystkie komponenty powiązane z modelem zawierającym obiekt parametru, którego właściwość Parameter Name ma wartość Coupling Factor, a właściwość Value ma wartość 0.999. Model ten musi być bieżącym modelem komponentu.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym File Libraries Search.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Odwołanie do biblioteki
Podsumowanie
Zwraca wszystkie komponenty, których właściwość Library Reference spełnia warunki zapytania.
Składnia
LibReference : String
Przykłady użycia
LibReference = 'LM833'
Zwraca wszystkie komponenty, których właściwość Library Reference ma wartość LM833.
LibReference Like 'C*'
Zwraca wszystkie komponenty, których właściwość Library Reference zaczyna się od C.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym File Libraries Search.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Liczba części
Podsumowanie
Zwraca wszystkie komponenty, których właściwość Part Count spełnia warunki zapytania.
Składnia
PartCount : Number
Przykłady użycia
PartCount = 2
Zwraca wszystkie komponenty, których Part Count ma wartość 2.
PartCount > 4
Zwraca wszystkie komponenty, których Part Count jest większe niż 4 (tj. wszystkie komponenty wieloczęściowe zawierające więcej niż cztery części).
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Liczba pinów
Podsumowanie
Zwraca wszystkie komponenty, których właściwość Pin Count spełnia warunki zapytania.
Składnia
PinCount : Number
Przykłady użycia
PinCount = 2
Zwraca wszystkie komponenty, których Pin Count ma wartość 2.
PinCount > 14
Zwraca wszystkie komponenty, których Pin Count jest większe niż 14.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Wszystkie
Opis
Podsumowanie
Zwraca wszystkie komponenty lub footprinty, których właściwość Description spełnia warunki zapytania.
Składnia
Description : String
Przykłady użycia
Description = 'TTL-RS232 DRIVER'
Zwraca wszystkie komponenty lub footprinty, których właściwość Description ma wartość TTL-RS232 DRIVER.
Description Like '*RS485*'
Zwraca wszystkie komponenty lub footprinty, których właściwość Description zawiera RS485.
Uwagi
-
Zwracane obiekty, komponenty lub footprinty, zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Ma parametr
Podsumowanie
Zwraca wszystkie komponenty zawierające obiekt parametru, którego właściwości Parameter Name i Value spełniają warunki zapytania.
Składnia
HasParameter(Parameter Name : String,Value : String) : Boolean/Boolean_String
Przykłady użycia
HasParameter('Comment','1K')
HasParameter('Comment','1K') = True
HasParameter('Comment','1K') = 'True'
Zwraca wszystkie komponenty zawierające obiekt parametru, którego właściwość Parameter Name ma wartość Comment, a właściwość Value ma wartość 1K.
Uwagi
-
Zwracane obiekty, komponenty lub footprinty, zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Nazwa biblioteki
Podsumowanie
Zwraca wszystkie komponenty lub footprinty, których nazwa biblioteki macierzystej spełnia warunki zapytania.
Składnia
LibraryName : String
Przykłady użycia
LibraryName = 'Miscellaneous Devices.SchLib'
Zwraca wszystkie komponenty, których biblioteką macierzystą jest Miscellaneous Devices.SchLib.
LibraryName Like 'Miscellaneous*.IntLib'
Zwraca wszystkie komponenty lub footprinty, których nazwa biblioteki macierzystej zaczyna się od Miscellaneous i kończy na .IntLib.
LibraryName Like '*Vishay*'
Zwraca wszystkie komponenty, których nazwa biblioteki macierzystej zawiera Vishay.
Uwagi
-
Zwracane obiekty, komponenty lub footprinty, zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib, IntLib i DbLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania. Podczas wyszukiwania footprintów przeszukiwane są wszystkie biblioteki PcbLib i IntLib.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Ścieżka biblioteki
Podsumowanie
Zwraca wszystkie komponenty lub footprinty znajdujące się w bibliotece określonej w zapytaniu.
Składnia
LibraryPath : String
Przykłady użycia
LibraryPath = 'C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Zwraca wszystkie komponenty, których biblioteką macierzystą jest MyExampleLibrary.SchLib, a biblioteka ta znajduje się w folderze C:\Documents\Altium\Library.
LibraryPath Like ' C:\Documents\Altium\Library\Miscellaneous*.IntLib'
Zwraca wszystkie komponenty lub footprinty, których nazwa biblioteki macierzystej zaczyna się od Miscellaneous i kończy na .IntLib, a biblioteka ta znajduje się w folderze C:\Documents\Altium\Library.
LibraryPath = 'C:\Test Projects\Example DBLib\VishayCapacitor.DBLib'
Zwraca wszystkie komponenty, których biblioteką macierzystą jest VishayCapacitor.DBLib, a biblioteka ta znajduje się w folderze C:\Test Projects\Example DBLib.
Uwagi
-
Zwracane obiekty, komponenty lub footprinty, zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib, IntLib i DbLib dostępne w zdefiniowanej ścieżce bibliotek. Podczas wyszukiwania footprintów przeszukiwane są wszystkie biblioteki PcbLib i IntLib.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
Nazwa
Podsumowanie
Zwraca wszystkie komponenty lub footprinty, których nazwa spełnia warunki zapytania.
Składnia
Name : String
Przykłady użycia
Name = 'Res1'
Zwraca wszystkie komponenty lub footprinty, których nazwa to Res1.
Name Like 'DIP*'
Zwraca wszystkie komponenty lub footprinty, których nazwa zaczyna się od DIP.
Name Like '*33*'
Zwraca wszystkie komponenty lub footprinty, których nazwa zawiera 33.
Uwagi
-
Zwracane obiekty, komponenty lub footprinty, zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym Wyszukiwanie w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są wszystkie biblioteki SchLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania. Podczas wyszukiwania footprintów przeszukiwane są wszystkie biblioteki PcbLib i IntLib.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Komponenty.
-
Nazwa komponentu schematowego jest sprawdzana na podstawie jego właściwości Design Item ID, a nazwa footprintu PCB — na podstawie jego właściwości Footprint .
Nazwa biblioteki źródłowej
Podsumowanie
Zwraca wszystkie komponenty lub footprinty, których nazwa macierzystej biblioteki źródłowej spełnia warunki zapytania.
Składnia
SourceLibraryName : String
Przykłady użycia
SourceLibraryName = 'Miscellaneous Devices.SchLib'
Zwraca wszystkie komponenty, których macierzystą biblioteką źródłową jest Miscellaneous Devices.SchLib.
SourceLibraryName = 'Miscellaneous Devices.PcbLib '
Zwraca wszystkie footprinty, których nadrzędną biblioteką źródłową jest Miscellaneous Devices.PcbLib.
Uwagi
-
Zwracane obiekty — komponenty lub footprinty — zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym wyszukiwania w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są tylko źródłowe biblioteki schematów — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania. Podczas wyszukiwania footprintów przeszukiwane są tylko biblioteki PCB.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Ścieżka biblioteki źródłowej
Podsumowanie
Zwraca wszystkie komponenty lub footprinty znajdujące się w bibliotece źródłowej wskazanej w zapytaniu.
Składnia
SourceLibraryPath : String
Przykłady użycia
SourceLibraryPath = ' C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Zwraca wszystkie komponenty, których nadrzędną biblioteką źródłową jest MyExampleLibrary.SchLib i których biblioteka znajduje się w folderze C:\Documents\Altium\Library.
SourceLibraryPath = ' C:\Documents\Altium\Library\Miscellaneous Devices.PcbLib'
Zwraca wszystkie footprinty, których nadrzędną biblioteką źródłową jest Miscellaneous Devices.PcbLib i których biblioteka znajduje się w folderze C:\Documents\Altium\Library.
SourceLibraryPath Like ' C:\Documents\Altium\Library\*'
Zwraca wszystkie komponenty lub footprinty, których nadrzędna biblioteka źródłowa znajduje się w folderze C:\Documents\Altium\Library.
Uwagi
-
Zwracane obiekty — komponenty lub footprinty — zależą od wybranego zakresu, określonego za pomocą pola Search in w oknie dialogowym wyszukiwania w bibliotekach plikowych.
-
Podczas wyszukiwania komponentów przeszukiwane są tylko biblioteki schematów dostępne w zdefiniowanej ścieżce bibliotek. Podczas wyszukiwania footprintów przeszukiwane są tylko biblioteki PCB.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Footprinty
Wysokość
Podsumowanie
Zwraca wszystkie footprinty, których właściwość Height spełnia warunki zapytania.
Składnia
Height : Number
Number będzie wyrażona w jednostkach miary aktualnie używanych w bibliotece — imperialnych (mil; 1 mil = 0,001 cala) lub metrycznych (mm; 1 mm = 0,001 metra).
Przykłady użycia
Height = 300
Zwraca wszystkie footprinty, których właściwość Height jest równa 300 w aktualnie używanych jednostkach miary.
Height >= 5.08
Zwraca wszystkie footprinty, których właściwość Height jest większa lub równa 5.08 w aktualnie używanych jednostkach miary.
Height <> 550
Zwraca wszystkie footprinty, których właściwość Height jest not równa 550 w aktualnie używanych jednostkach miary.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym wyszukiwania w bibliotekach plikowych.
-
Podczas wyszukiwania footprintów przeszukiwane są wszystkie biblioteki PcbLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.
Liczba padów
Podsumowanie
Zwraca wszystkie footprinty, których właściwość Pad Count spełnia warunki zapytania.
Składnia
PadCount : Number
Przykłady użycia
PadCount = 2
Zwraca wszystkie footprinty, których Pad Count wynosi 2.
PadCount > 14
Zwraca wszystkie footprinty, których Pad Count jest większa niż 14.
Uwagi
-
Upewnij się, że zakres wyszukiwania jest ustawiony na Components za pomocą pola Search in w oknie dialogowym wyszukiwania w bibliotekach plikowych.
-
Podczas wyszukiwania footprintów przeszukiwane są wszystkie biblioteki PcbLib i IntLib — dostępne lub znajdujące się w zdefiniowanej ścieżce wyszukiwania.
-
Wszystkie wyniki są wyświetlane na liście Query Results w panelu Components.