Working with Pads & Vias
Podsumowanie padów i przelotek
Pady służą zarówno do mechanicznego mocowania, jak i do połączeń elektrycznych z wyprowadzeniami komponentu
Pad jest prymitywnym obiektem projektowym. Pady są używane do mocowania komponentu do płytki oraz do tworzenia punktów połączeń między wyprowadzeniami komponentu a trasowaniem na płytce. Pady mogą występować na pojedynczej warstwie, na przykład jako pad elementu montowanego powierzchniowo, albo mogą być trójwymiarowymi padami przelotowymi, posiadającymi cylindryczny korpus w płaszczyźnie Z (pionowej) oraz płaski obszar na każdej (poziomej) warstwie miedzi. Cylindryczny korpus padu powstaje podczas wiercenia i metalizacji przelotowej płytki w trakcie produkcji. W płaszczyznach X i Y pady mogą mieć kształt okrągły, prostokątny, ośmiokątny, zaokrąglonego prostokąta, prostokąta ze ściętymi narożnikami lub kształt niestandardowy. Pady mogą być używane pojedynczo jako wolne pady w projekcie, albo — co bardziej typowe — są używane w edytorze biblioteki PCB, gdzie są łączone z innymi prymitywami w footprinty komponentów.

Przelotka rozciągająca się i łącząca warstwę górną (czerwoną) z warstwą dolną (niebieską), a także łącząca jedną wewnętrzną płaszczyznę zasilania (zieloną).
Przelotka jest prymitywnym obiektem projektowym. Przelotki są używane do tworzenia pionowego połączenia elektrycznego między dwiema lub większą liczbą warstw elektrycznych PCB. Przelotki są obiektami trójwymiarowymi i mają cylindryczny korpus w płaszczyźnie Z (pionowej) z płaskim pierścieniem na każdej (poziomej) warstwie miedzi. Cylindryczny korpus przelotki powstaje podczas wiercenia i metalizacji przelotowej płytki w trakcie produkcji. W płaszczyznach X i Y przelotki są okrągłe, podobnie jak okrągłe pady. Kluczowa różnica między przelotką a padem polega na tym, że oprócz możliwości przechodzenia przez wszystkie warstwy płytki (od góry do dołu), przelotka może także łączyć warstwę powierzchniową z warstwą wewnętrzną lub dwie warstwy wewnętrzne.
Bezpośrednie umieszczanie padów i przelotek
Pady i przelotki są dostępne do umieszczania zarówno w edytorze PCB, jak i PCB Footprint. Przelotki są zwykle umieszczane automatycznie podczas interaktywnego lub automatycznego trasowania, ale w razie potrzeby można je umieszczać ręcznie. Ręcznie umieszczane przelotki są określane jako „wolne” przelotki. Po uruchomieniu polecenia umieszczania padu (Place » Pad) lub przelotki (Place » Via) kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania.
- Ustaw kursor, a następnie kliknij lub naciśnij Enter, aby umieścić pad/przelotkę.
- Kontynuuj umieszczanie kolejnych padów/przelotek albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby wyjść z trybu umieszczania.
Podczas umieszczania naciśnij klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, w zależności od początkowego kierunku ruchu.
Edycja graficzna
Właściwości padów i przelotek nie mogą być modyfikowane graficznie inaczej niż przez zmianę ich położenia.
- Aby przesunąć wolny pad i jednocześnie przesunąć połączone ścieżki, kliknij pad, przytrzymaj i przesuń go. Połączone trasowanie pozostanie dołączone do padu podczas jego przesuwania. Pamiętaj, że pad nie zostanie przesunięty, jeśli należy do komponentu.
- Aby przesunąć wolny pad bez przesuwania połączonych ścieżek w edytorze PCB lub PCB Library Editor, wybierz polecenie Edit » Move » Move, a następnie kliknij pad, przytrzymaj i przesuń go.
Edycja niegraficzna za pomocą panelu Properties
Ta metoda edycji wykorzystuje powiązany tryb panelu Properties do modyfikowania właściwości obiektu Pad/Via.
Pad Properties

Tryb Pad panelu PropertiesProperties panel
Informacje o sieci
Ten obszar zawiera informacje o sieci, do której należy pad, a także o parze różnicowej i/lub xSignal, jeśli ta sieć jest jej członkiem. W stosownych przypadkach wyświetlane są informacje o klasie. Podawane są również wartości Delay i Length.
Więcej informacji znajduje się na stronie PCB Placement & Editing Techniques.
Właściwości
-
Component – to pole jest wyświetlane tylko w edytorze PCB, gdy wybrany pad jest częścią składową komponentu PCB, i pokazuje oznaczenie nadrzędnego komponentu PCB. Wybierz klikalny link Component, aby otworzyć Component mode of the Properties panel dla komponentu nadrzędnego.
-
Designator – to pole wyświetla bieżące oznaczenie padu. Jeśli pad jest częścią komponentu, oznaczenie jest zwykle ustawione na odpowiadający numer wyprowadzenia komponentu. Wolne pady mogą zawierać oznaczenie lub pole może pozostać puste. Jeśli oznaczenie zaczyna się lub kończy cyfrą, liczba będzie automatycznie zwiększana podczas sekwencyjnego umieszczania serii padów. Edytuj wartość w tym polu, aby zmienić oznaczenie padu.
-
Layer – wybierz warstwę, do której przypisany jest pad. Wybierz Multi-Layer, aby zdefiniować pad przelotowy.
-
Net – służy do wyboru sieci dla padu. Na liście rozwijanej zostaną wyświetlone wszystkie sieci aktywnego projektu płytki. Wybierz No Net, aby określić, że pad nie jest połączony z żadną siecią. Właściwość Net prymitywu jest używana przez Design Rule Checker do określenia, czy obiekt PCB został umieszczony prawidłowo. Alternatywnie możesz kliknąć ikonę Assign Net , aby wybrać obiekt w obszarze projektu — sieć tego obiektu zostanie przypisana do wybranych padów.
-
Electrical Type – to pole wyświetla bieżący stan elektryczny padu. Ten stan ma znaczenie tylko dla padów komponentów i określa charakterystykę linii transmisyjnej dla tych padów. Pady mogą być oznaczone jako Load, Source lub Terminator. Ustawienia Source i Terminator są używane, gdy sieć wymaga jednej z topologii trasowania typu Daisy chain. Kliknij pole, aby zmienić typ elektryczny z listy rozwijanej.
-
Propagation Delay – to pole podaje opóźnienie propagacji, czyli czas potrzebny, aby czoło sygnału przemieściło się od nadawcy do odbiorcy.
-
Pin Package Length – długość pakietu pinu jest automatycznie uwzględniana w obliczeniach Signal Length, które są wyświetlane w panelu PCB. Ustaw panel PCB na tryb Nets, aby sprawdzić (lub edytować) wartość Pin/Pkg Length dla pinów w wybranej sieci.
-
Jumper – to pole nadaje padowi numer identyfikacyjny połączenia zworą (zakres 1–1000), gdy używasz połączenia zworą na PCB. Połączenie zworą wykorzystuje przewód do fizycznego połączenia padów na PCB i nie używa ścieżek ani obiektów elektrycznych na płytce. Wartość Jumper informuje oprogramowanie, które pady należy traktować jako „połączone”. Połączenie zworą można utworzyć tylko między padami w obrębie footprintu komponentu. Użyte pady muszą mieć tę samą wartość Jumper i muszą również należeć do tej samej sieci. Połączenie zworą jest wyświetlane jako zakrzywiona linia połączenia w edytorze PCB. Użyj strzałek przewijania lub wpisz bezpośrednio żądany numer identyfikacyjny połączenia zworą.
-
Template – wyświetla bieżący szablon dla padu. Użyj listy rozwijanej, aby wybrać inny szablon. Jeśli istnieje powiązana biblioteka Library, zostanie ona wyświetlona. Kliknij przycisk
, aby odłączyć szablon od powiązanej biblioteki szablonów Pad/Via.
-
(X/Y)
-
X (pierwsze pole) – to pole pokazuje bieżącą pozycję X środka padu względem bieżącego punktu odniesienia. Edytuj wartość w polu, aby zmienić pozycję padu względem bieżącego punktu odniesienia. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostki podczas wprowadzania wartości, której jednostki nie są aktualnie domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty), i są używane, jeśli jednostka nie została określona.
-
Y (drugie pole) – to pole pokazuje bieżącą pozycję Y środka padu względem bieżącego punktu odniesienia. Edytuj wartość w polu, aby zmienić pozycję padu względem bieżącego punktu odniesienia. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostki podczas wprowadzania wartości, której jednostki nie są aktualnie domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty), i są używane, jeśli jednostka nie została określona.
-
-
Rotation – kąt obrotu padu (w stopniach), mierzony przeciwnie do ruchu wskazówek zegara od zera (poziomej osi 3 o'clock). Edytuj to pole, aby zmienić obrót padu. Minimalna rozdzielczość kątowa wynosi 0,001°.
Stos padów
-
Simple / Top-Middle-Bottom / Full Stack – wybierz żądany tryb stosu padów dla padu przelotowego (tj. gdy Multi-Layer jest wybrane jako Layer padu). Dla innych warstw obowiązują opcje trybu Simple.
-
Simple – wybierz, aby ustawić prosty pad warstwowy. Możesz zdefiniować atrybuty kształtu padu, które są wspólne dla wszystkich sygnałowych warstw miedzi tego padu.
-
Top-Middle-Bottom – wybierz, aby ustawić pad warstwowy Top-Middle-Bottom. Możesz zdefiniować rozmiary X i Y oraz atrybuty kształtu dla górnej, środkowej i dolnej sygnałowej warstwy miedzi tego padu.
-
Full Stack – wybierz, aby ustawić pad warstwowy Full Stack. Możesz zdefiniować rozmiary X i Y oraz atrybuty kształtu dla wszystkich sygnałowych warstw miedzi tego padu.
-
-
Copper – rozwiń zwijane obszary lub użyj siatki, aby zdefiniować atrybuty padu na sygnałowych warstwach miedzi. Zestaw dostępnych warstw miedzi zależy od warstwy, na której umieszczono pad, oraz od wybranego trybu stosu padów.
- Shape – wybierz kształt padu. Standardowe kształty padów (Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle i Donut) można modyfikować przez zmianę ustawień X i Y, aby uzyskać asymetryczne kształty padów. Wybierz Custom Shape, aby zdefiniować pad o niestandardowym kształcie (dowiedz się więcej).
-
Edit Shape – kliknij, aby interaktywnie edytować region padu o niestandardowym kształcie w obszarze projektu. Ten przycisk jest dostępny tylko wtedy, gdy Custom Shape jest wybrane jako Shape.
-
(X/Y) – określ rozmiar X (poziomy) i Y (pionowy) padu. Rozmiary X i Y można ustawiać niezależnie, aby definiować asymetryczne kształty padów. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostki podczas wprowadzania wartości, której jednostki nie są aktualnie domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano Rounded Rectangle lub Chamfered Rectangle .
-
Corner Radius – wprowadź bezwzględną wartość promienia/ścięcia narożnika padu. Wartość musi być mniejsza lub równa połowie krótszego boku padu. Obliczona wartość procentowa (procent połowy krótszego boku padu) zostanie pokazana po prawej stronie pola. Wprowadź wartość, po której następuje symbol
%, aby zdefiniować promień/ścięcie jako procent połowy krótszego boku padu, gdzie100%całkowicie zaokrągla krótszy bok (obliczona wartość bezwzględna zostanie w tym przypadku pokazana po prawej stronie pola). Ta opcja jest dostępna tylko wtedy, gdy dla padu wybrano Rounded Rectangle lub Chamfered Rectangle jako Shape na odpowiedniej warstwie miedzi. -
Upper Left, Upper Right, Lower Left, Lower Right – włącz zaokrąglanie/ścięcie narożników kształtu padu. Te opcje są dostępne tylko wtedy, gdy dla padu wybrano Rounded Rectangle lub Chamfered Rectangle jako Shape na odpowiedniej warstwie miedzi.
-
Outer Diameter – wprowadź zewnętrzną średnicę padu. Ta opcja jest dostępna tylko wtedy, gdy jako Donut dla padu Shape na odpowiedniej warstwie miedzi wybrano.
-
Width – wprowadź szerokość padu. Ta opcja jest dostępna tylko wtedy, gdy jako Donut dla padu Shape na odpowiedniej warstwie miedzi wybrano. na odpowiadającej warstwie miedzi.
-
Thermal Relief – włącz tę opcję, aby dostosować odciążenie termiczne dla pada, zastępując obowiązującą regułę Polygon Connect Style. Po zaznaczeniu kliknij łącze, aby otworzyć okno dialogowe Polygon Connect Style, w którym możesz zmienić opcje odciążenia termicznego zgodnie z potrzebami. Kliknij przycisk Edit Points, aby ręcznie zdefiniować punkty połączeń wypustek odciążenia termicznego. Dowiedz się więcej o Definiowaniu niestandardowych odciążeń termicznych.
-
Center Offset (X/Y) (tylko dla pada SMD, tj. gdy jako Layer pada wybrano warstwę inną niż Multi-Layer) – wprowadź wartość, aby przesunąć obszar lądowania pada względem jego środka.
-
Hole – rozwiń sekcję zwijaną lub użyj siatki, aby zdefiniować atrybuty otworu pada. Opcje otworu są dostępne tylko dla pada przewlekanego (tj. gdy jako Layer pada wybrano Multi-Layer).
-
Shape – wybierz żądany kształt otworu.
- Round – określa okrągły kształt otworu dla rozmiaru otworu pada. Dla każdego rodzaju otworu, a także dla otworów metalizowanych i niemetalizowanych, generowane są oddzielne pliki wierceń (format NC Drill Excellon 2). Dla tych typów może istnieć maksymalnie sześć różnych plików wierceń.
- Rectangular – określa prostokątny (wybijany) otwór dla tego pada. Otwory prostokątne mogą być metalizowane lub niemetalizowane. Dla każdego rodzaju otworu, a także dla otworów metalizowanych i niemetalizowanych, generowane są oddzielne pliki wierceń (format NC Drill Excellon 2). Dla tych typów może istnieć maksymalnie sześć różnych plików wierceń.
- Slot – określa podłużny otwór z zaokrąglonymi końcami dla tego pada. Otwory podłużne mogą być metalizowane lub niemetalizowane. Dla każdego rodzaju otworu, a także dla otworów metalizowanych i niemetalizowanych, generowane są oddzielne pliki wierceń (format NC Drill Excellon 2). Dla tych typów może istnieć maksymalnie sześć różnych plików wierceń.
- Size – to pole wyświetla bieżący rozmiar otworu dla pada. Wartość określa średnicę okrągłego otworu (lub szerokość otworu prostokątnego albo podłużnego) w milach lub mm, który ma zostać wykonany w padzie podczas produkcji. Dla padów SMD lub złączy krawędziowych wartość ta powinna wynosić zero. Rozmiar otworu można ustawić od 0 do 1000 mil; może on być większy niż pad, aby zdefiniować mechaniczne otwory (bez miedzi), ale nie może być większy niż Length otworu Rectangular lub Slot. Edytuj wartość w tym polu, aby zmienić rozmiar otworu pada. Wartość można wprowadzać w jednostkach metrycznych lub imperialnych; dołącz jednostki, jeśli wprowadzasz wartość w jednostkach innych niż bieżące domyślne. Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w sekcji Other panelu Properties w trybie Board (dostępnym, gdy w obszarze roboczym nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie zostanie określona.
-
Tolerance – ustawienie atrybutów tolerancji otworu może pomóc w określeniu pasowań i granic dla płytki. Określ minimalną (-) i maksymalną (+) tolerancję dla otworu.
-
Length – wyświetla długość otworu w padzie, gdy Shape otworu jest ustawiony na Rectangular lub Slot. Wartość określa długość w mm lub mil, która ma zostać wyfrezowana NC w padzie podczas produkcji. Rozmiar otworu można ustawić od 0 do 1000 mil; może on być większy niż pad, aby zdefiniować mechaniczne otwory (bez miedzi), ale nie może być mniejszy niż Size otworu Rectangular lub Slot (użyj ustawienia Rotation, aby uzyskać wymagany format X-Y). Edytuj wartość w tym polu, aby zmienić długość. Wartość można wprowadzać w jednostkach metrycznych lub imperialnych; dołącz jednostki, jeśli wprowadzasz wartość w jednostkach innych niż bieżące domyślne. Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w sekcji Other panelu Properties w trybie Board (dostępnym, gdy w obszarze roboczym nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie zostanie określona. Ta opcja nie jest dostępna, jeśli Shape otworu jest ustawiony na Round.
- Rotation – wyświetla bieżący obrót otworu przeciwnie do ruchu wskazówek zegara względem pada w stopniach. Edytuj to pole, aby zmienić obrót. Minimalna rozdzielczość kątowa wynosi 0,001°. Ta opcja jest dostępna tylko wtedy, gdy jako Shape otworu wybrano Rectangular lub Slot.
- Copper Offset (X/Y) – wprowadź wartość, aby przesunąć obszar lądowania pada względem środka otworu pada.
- Plated – ta opcja określa, czy pad ma metalizowany otwór. Znacznik wyboru w tym polu ustawia pad jako pad z metalizowanym otworem. Jeśli w projekcie występują zarówno pady metalizowane, jak i niemetalizowane, otwory niemetalizowane będą przypisane do innych narzędzi niż otwory metalizowane w plikach wierceń NC.
-
Shape – wybierz żądany kształt otworu.
-
Paste – rozwiń sekcje zwijane lub użyj siatki, aby zdefiniować atrybuty pada na warstwach maski pasty. Zestaw dostępnych warstw maski pasty zależy od warstwy, na której umieszczono pad.
-
Shape – wybierz kształt na warstwie maski pasty.
-
Rule Expansion – wybierz tę opcję, aby rozszerzenie maski pasty dla pada było zgodne z wartością zdefiniowaną w odpowiedniej regule projektowej Paste Mask Expansion.
-
Manual Expansion – wybierz tę opcję, aby określić wartość rozszerzenia maski pasty dla pada.
-
Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle, i Donut – wybierz, aby zdefiniować standardowy kształt maski pasty. Kształtami tymi można manipulować, zmieniając ustawienia X i Y, aby uzyskać kształty asymetryczne.
- Dla kształtu Donut D oznacza średnicę zewnętrzną pierścienia, a W oznacza szerokość.
-
Custom Shape – wybierz, aby zdefiniować niestandardowy kształt maski pasty.
-
-
Edit – kliknij, aby interaktywnie edytować niestandardowy kształt na warstwie maski pasty w obszarze roboczym. Ten przycisk jest dostępny tylko wtedy, gdy jako Shape wybrano Custom Shape.
-
Paste Expansion – wprowadź żądaną wartość rozszerzenia maski pasty. Wartość może być określona jako wartość bezwzględna (mil/mm) albo procent powierzchni pada. Przy wprowadzaniu wartości bezwzględnej dołącz jednostki, jeśli wprowadzasz wartość w jednostkach innych niż bieżące domyślne. Jednostki domyślne są określane przez ustawienie Units w sekcji Other panelu Properties w trybie Board (dostępnym, gdy w obszarze roboczym nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie zostanie określona. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano Manual Expansion, a użycie maski pasty to Enabled.
-
(X/Y) – zdefiniuj rozmiar X (poziomy) i Y (pionowy) kształtu maski pasty. Rozmiar X i Y można ustawiać niezależnie, aby zdefiniować kształty asymetryczne. Wartość można wprowadzać w jednostkach metrycznych lub imperialnych; dołącz jednostki, jeśli wprowadzasz wartość w jednostkach innych niż bieżące domyślne. Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w sekcji Other panelu Properties w trybie Board (dostępnym, gdy w obszarze roboczym nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie zostanie określona. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano Round, Rectangular, Octagonal, Rounded Rectangle lub Chamfered Rectangle.
-
Corner Radius – wprowadź bezwzględną wartość promienia narożnika/fazowania kształtu maski pasty. Wartość musi być mniejsza lub równa połowie krótszego boku kształtu maski pasty. Obliczona wartość procentowa (procent połowy krótszego boku kształtu maski pasty) zostanie wyświetlona po prawej stronie pola. Wprowadź wartość, po której następuje symbol
%, aby zdefiniować promień/fazowanie jako procent połowy krótszego boku kształtu maski pasty, gdzie100%całkowicie zaokrągla krótszy bok (w tym przypadku po prawej stronie pola zostanie wyświetlona obliczona wartość bezwzględna). Ta opcja jest dostępna tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski pasty wybrano Rounded Rectangle lub Chamfered Rectangle. -
Upper Left, Upper Right, Lower Left, Lower Right – włącz zaokrąglenie/fazowanie narożników kształtu maski pasty. Te opcje są dostępne tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski pasty wybrano Rounded Rectangle lub Chamfered Rectangle.
-
Offset (X/Y) – wprowadź wartość, aby przesunąć kształt maski pasty względem środka pada.
-
Outer Diameter – wprowadź średnicę zewnętrzną pada. Ta opcja jest dostępna tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski pasty wybrano Donut.
-
Width – wprowadź szerokość pada. Ta opcja jest dostępna tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski pasty wybrano Donut.
-
Enabled – użyj tej opcji, aby włączyć/wyłączyć użycie kształtu maski pasty dla pada. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano opcję inną niż Rule Expansion.
-
-
Solder – rozwiń sekcje zwijane lub użyj siatki, aby zdefiniować atrybuty pada na warstwach maski lutowniczej. Zestaw dostępnych warstw maski lutowniczej zależy od warstwy, na której umieszczono pad.
-
Shape – wybierz kształt na warstwie maski lutowniczej.
-
Rule Expansion – wybierz tę opcję, aby rozszerzenie maski lutowniczej dla pada było zgodne z wartością zdefiniowaną w odpowiedniej regule projektowej Solder Mask Expansion.
-
Manual Expansion – wybierz tę opcję, aby określić wartość rozszerzenia maski lutowniczej dla pada.
- Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle, i Donut – wybierz, aby zdefiniować standardowy kształt maski lutowniczej. Kształtami tymi można manipulować, zmieniając ustawienia X i Y, aby uzyskać kształty asymetryczne.
-
Custom Shape – wybierz, aby zdefiniować niestandardowy kształt maski lutowniczej.
-
-
Edit – kliknij, aby interaktywnie edytować niestandardowy kształt na warstwie maski lutowniczej w obszarze roboczym. Ten przycisk jest dostępny tylko wtedy, gdy jako Shape wybrano Custom Shape.
-
Solder Expansion – wprowadź żądaną wartość rozszerzenia maski pasty. Wartość może być określona jako wartość bezwzględna (mil/mm) albo procent powierzchni pada. Przy wprowadzaniu wartości bezwzględnej dołącz jednostki, jeśli wprowadzasz wartość w jednostkach innych niż bieżące domyślne. Jednostki domyślne są określane przez ustawienie Units w sekcji Other panelu Properties w trybie Board (dostępnym, gdy w obszarze roboczym nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie zostanie określona. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano Manual Expansion, a opcja Tented jest wyłączona.
-
From Hole Edge – po włączeniu otwarcie maski lutowniczej będzie zgodne z kształtem otworu. Maska jest zatem niezależna od kształtu i rozmiaru pada i jest skalowana zarówno na podstawie rozmiaru, jak i kształtu otworu. Na przykład pad z kwadratowym otworem utworzy kwadratowe otwarcie maski odpowiadające wymiarom otworu oraz przypisanej wartości rozszerzenia. Należy również pamiętać, że rozmiar otwarcia maski wynikający z rozszerzenia pada będzie śledził wszelkie zmiany rozmiaru otworu. Ta opcja jest dostępna tylko dla padów przewlekanych (tj. gdy jako Layer pada wybrano Multi-Layer) jeśli jako Shape wybrano Manual Expansion, a opcja Tented jest wyłączona.
-
(X/Y) – zdefiniuj rozmiar X (poziomy) i Y (pionowy) kształtu maski lutowniczej. Rozmiar X i Y można ustawiać niezależnie, aby zdefiniować kształty asymetryczne. Wartość można wprowadzać w jednostkach metrycznych lub imperialnych; dołącz jednostki, jeśli wprowadzasz wartość w jednostkach innych niż bieżące domyślne. Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w sekcji Other panelu Properties w trybie Board (dostępnym, gdy w obszarze roboczym nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie zostanie określona. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano Round, Rectangular, Octagonal, Rounded Rectangle lub Chamfered Rectangle.
-
Corner Radius – wprowadź bezwzględną wartość promienia narożnika/fazowania kształtu maski lutowniczej. Wartość musi być mniejsza lub równa połowie krótszego boku kształtu maski lutowniczej. Obliczona wartość procentowa (procent połowy krótszego boku kształtu maski lutowniczej) zostanie wyświetlona po prawej stronie pola. Wprowadź wartość, po której następuje symbol
%, aby zdefiniować promień/fazowanie jako procent połowy krótszego boku kształtu maski lutowniczej, gdzie100%całkowicie zaokrągla krótszy bok (w tym przypadku po prawej stronie pola zostanie wyświetlona obliczona wartość bezwzględna). Ta opcja jest dostępna tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski lutowniczej wybrano Rounded Rectangle lub Chamfered Rectangle. -
Upper Left, Upper Right, Lower Left, Lower Right – włącz zaokrąglenie/fazowanie narożników kształtu maski lutowniczej. Te opcje są dostępne tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski lutowniczej wybrano Rounded Rectangle lub Chamfered Rectangle.
-
Offset (X/Y) – wprowadź wartość, aby przesunąć kształt maski lutowniczej względem środka pada.
-
Outer Diameter – wprowadź średnicę zewnętrzną pada. Ta opcja jest dostępna tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski lutowniczej wybrano Donut.
-
Width – wprowadź szerokość pada. Ta opcja jest dostępna tylko wtedy, gdy dla pada jako Shape na odpowiadającej warstwie maski lutowniczej wybrano Donut.
-
Tented – zaznacz, jeśli chcesz zastąpić wszelkie ustawienia maski lutowniczej z reguł projektowych rozszerzenia maski lutowniczej, co spowoduje brak otwarcia w masce lutowniczej na górnej/dolnej warstwie tego pada, a tym samym jego zakrycie maską (tented). Wyłącz tę opcję, a ten pad będzie podlegał regule rozszerzenia maski lutowniczej lub określonej wartości rozszerzenia. Ta opcja jest dostępna tylko wtedy, gdy jako Shape wybrano opcję inną niż Rule Expansion.
-
/
– gdy jako Shape wybrano Manual Expansion, sekcja Bottom Solder Mask (a więc także jej opcja Solder Expansion) jest dostępna, jeśli przycisk jest ustawiony na
. Gdy przycisk ma stan
, wartość rozszerzenia maski lutowniczej dolnej warstwy będzie taka sama jak dla warstwy górnej.
-
Pad Features
Top Side / Bottom Side – wybierz żądaną opcję dla przeciwpogłębienia pada po górnej/dolnej stronie płytki. Dostępne opcje: None, Counterbore, Countersink. Te opcje są dostępne tylko dla okrągłego pada przewlekanego (tj. gdy jako Layer pada wybrano Multi-Layer, a jako kształt otworu pada wybrano Round).
Pogłębienia w laminacie zapewniają miejsce na łby śrub. Otwory countersink i counterbore to dwa typy pogłębień, które umożliwiają stosowanie różnych typów śrub. W tej wersji wprowadzono możliwość wyboru otworów typu counterbore lub countersink. Kluczowa różnica między śrubami do otworów countersink i counterbore dotyczy rozmiaru i kształtu otworów; otwory counterbore są szersze i bardziej cylindryczne, aby umożliwić dodanie podkładek. Otwory countersink tworzą stożkowy otwór odpowiadający skośnemu kształtowi spodniej części śruby z łbem stożkowym. Otwór countersink to stożkowe zagłębienie wykonane w laminacie. Zwykle stosuje się je, aby zwężający się łeb śruby licował z górną powierzchnią laminatu. Dla porównania, otwór counterbore ma płaskie dno, a jego ścianki są wiercone pionowo. Zwykle używa się go do osadzenia śruby lub nasadki z łbem sześciokątnym. Dozwolony jest tylko jeden otwór countersink lub counterbore na pad.
W widoku 2D wokół pada pojawia się linia przerywana, która definiuje obrys pogłębienia na aktywnej warstwie. Pogłębienia są obsługiwane w 2D, 3D oraz w Draftsman.
Punkt testowy
Fabrication/Assembly – te opcje umożliwiają określenie padów (przelotowych lub SMD), które mają być używane jako lokalizacje punktów testowych podczas testów produkcyjnych i/lub montażowych. Włącz Top, aby ten pad został zdefiniowany jako punkt testowy górnej warstwy. Włącz Bottom, aby ten pad został zdefiniowany jako punkt testowy dolnej warstwy.
Właściwości przelotki

Tryb Via panelu Propertieswłaściwości
Informacje o sieci
Ten obszar zawiera informacje o sieci, do której należy przelotka, a także o parze różnicowej i/lub xSignal, jeśli ta sieć jest jej członkiem. Informacje o klasie są wyświetlane tam, gdzie ma to zastosowanie. Podawane są również wartości Delay, Length, Max Current i Resistance.
Aby dowiedzieć się więcej o informacjach o sieci, zobacz stronę Techniki rozmieszczania i edycji PCB.
Definicja
-
Component – to pole jest wyświetlane w edytorze PCB tylko wtedy, gdy wybrana przelotka jest częścią składową komponentu PCB, i pokazuje oznaczenie nadrzędnego komponentu PCB. Wybierz klikalny link Component, aby otworzyć tryb Component panelu Properties dla komponentu nadrzędnego.
-
Net – służy do wyboru sieci dla przelotki. Wszystkie sieci aktywnego projektu płytki będą widoczne na liście rozwijanej. Wybierz No Net , aby określić, że przelotka nie jest połączona z żadną siecią. Właściwość Net elementu pierwotnego jest używana przez Design Rule Checker do określenia, czy obiekt PCB został umieszczony zgodnie z regułami. Alternatywnie możesz kliknąć ikonę Assign Net , aby wybrać obiekt w obszarze projektu — sieć tego obiektu zostanie przypisana do wybranych przelotek.
-
Name – gdy wybrana jest jedna lub więcej przelotek, po kliknięciu listy rozwijanej wyświetlane są nazwy przelotek; lista zawiera wszystkie zakresy przelotek zdefiniowane w Layer Stack. Wszystkie przelotki użyte na płytce muszą należeć do jednego z zakresów przelotek zdefiniowanych w Layer Stack.
-
Propagational Delay – to pole podaje opóźnienie propagacji, czyli czas potrzebny, aby czoło sygnału przemieściło się od nadawcy do odbiorcy.
-
Template – wyświetla bieżący szablon przelotki. Użyj listy rozwijanej, aby wybrać inny szablon. Jeśli istnieje powiązana Library, ta biblioteka zostanie wyświetlona.
-
Library – wyświetla szablon przelotki zawarty w bieżącej bibliotece. Jeśli przelotka została umieszczona z biblioteki Pad Via Library (*.PvLib), nazwa tej biblioteki zostanie uwzględniona w tym polu. Po umieszczeniu ikona
staje się aktywna, co oznacza, że właściwości umieszczonej przelotki są zdefiniowane w bibliotece i nie można ich już edytować. Jeśli ikona
nie jest aktywna, zawartość nadal można edytować.
-
(X/Y)
- X (pierwsze pole) – to pole pokazuje bieżącą pozycję X środka przelotki względem bieżącego początku układu współrzędnych. Edytuj wartość w polu, aby zmienić pozycję przelotki względem bieżącego początku układu. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; dołącz jednostki podczas wprowadzania wartości, jeśli są inne niż bieżące domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona.
- Y (drugie pole) – to pole pokazuje bieżącą pozycję Y środka przelotki względem bieżącego początku układu współrzędnych. Edytuj wartość w polu, aby zmienić pozycję przelotki względem bieżącego początku układu. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; dołącz jednostki podczas wprowadzania wartości, jeśli są inne niż bieżące domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona.
Stos przelotki
-
Simple – wybierz, aby użyć prostej przelotki.
- Diameter – wprowadź wymagą średnicę przelotki. Średnica przelotki jest taka sama na wszystkich warstwach.
- Relief – włącz, aby dostosować odciążenie termiczne dla przelotki, zastępując odpowiednią regułę Polygon Connect Style.
-
Thermal Relief – po włączeniu opcji Relief kliknij link, aby otworzyć okno dialogowe Polygon Connect Style, w którym możesz zmienić opcje odciążenia termicznego zgodnie z wymaganiami. Kliknij przycisk Edit Points, aby ręcznie zdefiniować punkty połączeń ramion odciążenia termicznego.
-
Top-Middle-Bottom – wybierz, aby ustawić różne średnice dla warstwy górnej, wszystkich wewnętrznych warstw sygnałowych i warstwy dolnej.
- Displayed Layer(s) – kliknij wyświetloną warstwę, aby skonfigurować przelotki dla tej warstwy. Wybrana warstwa zostanie podświetlona.
- Diameter – kliknij listę rozwijaną, a następnie wprowadź wymaganą średnicę przelotki dla wybranej warstwy.
- Relief – włącz, aby dostosować odciążenie termiczne dla przelotki, zastępując odpowiednią regułę Polygon Connect Style.
-
Thermal Relief – po włączeniu opcji Relief kliknij link, aby otworzyć okno dialogowe Polygon Connect Style, w którym możesz zmienić opcje odciążenia termicznego zgodnie z wymaganiami. Kliknij przycisk Edit Points, aby ręcznie zdefiniować punkty połączeń ramion odciążenia termicznego.
-
Full Stack – wybierz, aby użyć obiektu przelotki Full Stack.
- Displayed Layer(s) – kliknij wyświetloną warstwę, aby skonfigurować przelotki dla tej warstwy. Wybrana warstwa zostanie podświetlona.
- Diameter – kliknij listę rozwijaną, a następnie wprowadź wymaganą średnicę przelotki dla wybranej warstwy.
- Relief – włącz, aby dostosować odciążenie termiczne dla przelotki, zastępując odpowiednią regułę Polygon Connect Style.
-
Thermal Relief – po włączeniu opcji Relief kliknij link, aby otworzyć okno dialogowe Polygon Connect Style, w którym możesz zmienić opcje odciążenia termicznego zgodnie z wymaganiami. Kliknij przycisk Edit Points, aby ręcznie zdefiniować punkty połączeń ramion odciążenia termicznego.
-
Hole Size – to pole wyświetla bieżący rozmiar otworu dla przelotki. Wartość określa średnicę otworu (o kształcie okrągłym, kwadratowym lub fasolkowym) w milach lub mm, który ma zostać wywiercony w przelotce podczas produkcji. Rozmiar otworu można ustawić od 0 do 1000 mil, a także większy niż sama przelotka, aby zdefiniować mechaniczne otwory (bez miedzi). Edytuj wartość w tym polu, aby zmienić rozmiar otworu przelotki. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; dołącz jednostki podczas wprowadzania wartości, jeśli są inne niż bieżące domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona.
-
Tolerance – ustawienie atrybutów tolerancji otworu może pomóc określić pasowania i granice dla płytki. Określ minimalną (-) i maksymalną (+) tolerancję dla otworu. W Altium Designer nie ma domyślnej wartości tolerancji otworu.
Rozszerzenie maski lutowniczej
-
Rule – wybierz, aby rozszerzenie maski lutowniczej dla przelotki było zgodne z wartością zdefiniowaną w odpowiedniej regule projektowej Solder Mask Expansion.
-
Top
- Tented – zaznacz, jeśli ustawienia maski lutowniczej z reguł rozszerzenia maski mają zostać nadpisane, co spowoduje brak otwarcia w masce lutowniczej na górnej warstwie tej przelotki, a więc jej zatentowanie. Wyłącz tę opcję, a ta przelotka będzie objęta regułą rozszerzenia maski lutowniczej lub określoną wartością rozszerzenia.
-
Bottom
- Tented – zaznacz, jeśli ustawienia maski lutowniczej z reguł rozszerzenia maski mają zostać nadpisane, co spowoduje brak otwarcia w masce lutowniczej na dolnej warstwie tej przelotki, a więc jej zatentowanie. Wyłącz tę opcję, a ta przelotka będzie objęta regułą rozszerzenia maski lutowniczej lub określoną wartością rozszerzenia.
-
Top
-
Manual – wybierz, aby nadpisać odpowiednią regułę projektową i określić wartość rozszerzenia maski lutowniczej dla przelotki.
-
Top – wprowadź wartość rozszerzenia maski lutowniczej dla warstwy górnej. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; dołącz jednostki podczas wprowadzania wartości, jeśli są inne niż bieżące domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona. To pole jest dostępne tylko wtedy, gdy Tented nie jest włączone.
- Tented – zaznacz, jeśli ustawienia maski lutowniczej z reguł rozszerzenia maski mają zostać nadpisane, co spowoduje brak otwarcia w masce lutowniczej na górnej warstwie tej przelotki, a więc jej zatentowanie. Wyłącz tę opcję, a ta przelotka będzie objęta regułą rozszerzenia maski lutowniczej lub określoną wartością rozszerzenia.
-
Bottom – wprowadź wartość rozszerzenia maski lutowniczej dla warstwy dolnej. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; dołącz jednostki podczas wprowadzania wartości, jeśli są inne niż bieżące domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona. To pole jest dostępne tylko wtedy, gdy ikona
po prawej stronie tego obszaru jest ustawiona na
i opcja Tented nie jest włączona. Gdy ikona jest w stanie
, a opcja Tented nie jest włączona, wartość rozszerzenia maski lutowniczej dla warstwy dolnej będzie taka sama jak dla warstwy górnej.
- Tented – zaznacz, jeśli ustawienia maski lutowniczej z reguł rozszerzenia maski mają zostać nadpisane, co spowoduje brak otwarcia w masce lutowniczej na dolnej warstwie tej przelotki, a więc jej zatentowanie. Wyłącz tę opcję, a ta przelotka będzie objęta regułą rozszerzenia maski lutowniczej lub określoną wartością rozszerzenia.
- From Hole Edge – po włączeniu otwarcie maski lutowniczej będzie zgodne z rozmiarem otworu. Maska jest zatem niezależna od rozmiaru przelotki i skalowana od rozmiaru otworu. Zwróć też uwagę, że rozmiar otwarcia maski rozszerzenia przelotki będzie śledził wszelkie zmiany rozmiaru otworu.
-
Top – wprowadź wartość rozszerzenia maski lutowniczej dla warstwy górnej. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; dołącz jednostki podczas wprowadzania wartości, jeśli są inne niż bieżące domyślne. Domyślne jednostki (metryczne lub imperialne) są określane przez ustawienie Units w obszarze Other panelu Properties w trybie Board (dostępnym, gdy w obszarze projektu nie są zaznaczone żadne obiekty) i są używane, jeśli jednostka nie została określona. To pole jest dostępne tylko wtedy, gdy Tented nie jest włączone.
Typy i cechy przelotek
- IPC 4761 Via Type – użyj listy rozwijanej, aby wybrać typ przelotki zgodnie ze standardem IPC 4761, Design Guide for Protection of Printed Board Via Structures.
-
Grid – pojawia się, gdy w liście rozwijanej IPC 4761 Via Type wybrano typ przelotki inny niż
None. Wybierz płytkę Side i wpisz Material dla funkcji dostępnych zgodnie z wybranym typem przelotki.
Punkt testowy
Fabrication/Assembly – te opcje umożliwiają określenie przelotek, które mają być używane jako lokalizacje punktów testowych podczas testów produkcyjnych i/lub montażowych. Włącz Top, aby ta przelotka została zdefiniowana jako punkt testowy górnej warstwy. Włącz Bottom, aby ta przelotka została zdefiniowana jako punkt testowy dolnej warstwy.
Odciążenia termiczne padów i przelotek
Pole Thermal Relief w obszarze Pad Stack / Via Stack panelu Properties podsumowuje aktualnie zastosowaną konfigurację odciążenia termicznego. Na przykład Relief, 15mil, 10mil, 4, 90 oznacza, że:
- połączenie odciążenia termicznego jest zastosowane;
- szczelina izolacyjna ma szerokość 15 mil;
- przewodniki odciążenia termicznego mają szerokość 10 mil;
- przewodniki odciążenia termicznego mają obrót o 90 stopni.
Gdy pole wyboru w polu Thermal Relief jest wyłączone, odciążenia termiczne polygonów dla padów i przelotek są rules-driven, tzn. te odciążenia są definiowane przez odpowiednie reguły projektowe Polygon Connect Style. Dla poszczególnych padów konfigurację odciążenia termicznego można dostosować, włączając powiązaną opcję Thermal Relief dla wymaganej warstwy. W takim przypadku odciążenia termiczne są traktowane jako custom. Dowiedz się więcej o Definiowaniu niestandardowych odciążeń termicznych.
Rozszerzenia maski lutowniczej i pasty
Maska lutownicza jest tworzona automatycznie w miejscu każdego pada/przelotki na warstwie Solder Mask. Maska lutownicza jest definiowana negatywowo, co oznacza, że umieszczone obiekty definiują otwory w warstwie Solder Mask. Maska pasty jest tworzona automatycznie w miejscu każdego pada na warstwie Paste Mask. Kształt tworzony na warstwie maski jest kształtem pada/przelotki, rozszerzonym lub zmniejszonym o wartość określoną przez reguły projektowe Solder Mask Expansion i Paste Mask Expansion ustawione w edytorze PCB lub zgodnie z ustawieniami określonymi w panelu Properties.

Pady z wyświetloną maską lutowniczą.
Podczas edycji pada lub przelotki ustawienia rozszerzeń maski lutowniczej i maski pasty są widoczne odpowiednio w obszarach Pad Stack i Solder Mask Expansion panelu Properties. Choć ustawienia te zapewniają lokalną kontrolę nad wymaganiami rozszerzenia dla pada/przelotki, zwykle nie będą potrzebne. Zazwyczaj łatwiej jest kontrolować wymagania maski pasty i maski lutowniczej poprzez zdefiniowanie odpowiednich reguł projektowych w edytorze PCB. Korzystając z reguł projektowych, można utworzyć jedną regułę ustawiającą rozszerzenie dla wszystkich komponentów na płytce, a następnie, jeśli to konieczne, dodać inne reguły ukierunkowane na konkretne sytuacje, takie jak wszystkie wystąpienia określonego typu footprintu użytego na płytce albo konkretny pad w konkretnym komponencie itd.
Aby ustawić rozszerzenia masek w regułach projektowych:
-
Potwierdź, że opcja Rule Expansion jest wybrana jako Shape w obszarze Pad Stack panelu Properties (dla padów) i/lub że opcja Rule jest wybrana w obszarze Solder Mask Expansion panelu Properties (dla przelotek).
-
W edytorze PCB wybierz Design » Rules z menu głównego i sprawdź reguły projektowe kategorii Mask w oknie dialogowym PCB Rules and Constraints Editor. Reguły te będą stosowane po umieszczeniu footprintu na PCB.
Aby zastąpić reguły projektowe rozszerzenia i określić rozszerzenie maski jako atrybut pada/przelotki, wybierz Manual Expansion jako Shape w obszarze Pad Stack panelu Properties (dla padów) i/lub Manual w obszarze Solder Mask Expansion panelu Properties (dla przelotek) i wpisz wymaganą wartość (wartości).
Zatentowanie padów i przelotek
Częściowe i pełne zatentowanie padów oraz przelotek można uzyskać przez zdefiniowanie odpowiedniej wartości dla Solder Mask Expansion. Ograniczenie rozszerzenia można zdefiniować indywidualnie dla każdego obiektu w panelu Properties lub przez zdefiniowanie odpowiednich reguł projektowych Solder Mask Expansion. Ustawiając wartość rozszerzenia na odpowiednią wartość, można uzyskać następujące efekty:
- Aby częściowo zatentować pad/przelotkę – zakrywając tylko obszar lądowania – ustaw wartość Expansion na wartość ujemną, która zamknie maskę aż do otworu pada/przelotki.
- Aby całkowicie zamaskować pad/przelotkę (pokrywając pole i otwór), ustaw wartość Expansion na wartość ujemną równą promieniowi pada/przelotki lub większą od niego.
- Aby zamaskować wszystkie pady/przelotki na pojedynczej warstwie, ustaw odpowiednią wartość Expansion i upewnij się, że zakres (Full Query) reguły Solder Mask Expansion obejmuje wszystkie pady/przelotki na wymaganej warstwie.
- Aby całkowicie zamaskować wszystkie pady/przelotki w projekcie, w którym zdefiniowano przelotki o różnych rozmiarach, ustaw Expansion na wartość ujemną równą największemu promieniowi pada/przelotki lub większą od niego. Podczas maskowania pojedynczego pada/przelotki dostępne są opcje pozwalające użyć rozszerzenia zdefiniowanego w odpowiedniej regule projektowej albo zastąpić tę regułę i bezpośrednio zastosować określone rozszerzenie do danego pada/przelotki.
Punkty testowe
Related page: Przypisywanie punktów testowych na płytce
Oprogramowanie zapewnia pełną obsługę punktów testowych, umożliwiając wskazanie padów (przelotowych lub SMD) oraz przelotek do użycia jako lokalizacji punktów testowych podczas testów produkcyjnych i/lub montażowych. Pad/przelotka jest wyznaczany do użycia jako punkt testowy przez ustawienie odpowiednich właściwości punktu testowego — czy ma to być punkt testowy do produkcji czy montażu oraz po której stronie płytki ma być używany jako punkt testowy. Właściwości te można znaleźć w obszarze Testpoint panelu Properties .
Aby usprawnić ten proces i wyeliminować konieczność ręcznego ustawiania właściwości punktów testowych, oprogramowanie udostępnia metodę automatycznego przypisywania punktów testowych na podstawie zdefiniowanych reguł projektowych oraz przy użyciu Testpoint Manager (Tools » Testpoint Manager). W każdym przypadku takie automatyczne przypisanie ustawia odpowiednie właściwości punktu testowego dla pada/przelotki.
Szczegóły padów
Oznaczenia padów
Każdy pad powinien być oznaczony designatorem (zwykle odpowiadającym numerowi wyprowadzenia komponentu) o długości do 20 znaków alfanumerycznych. Oznaczenia padów będą automatycznie zwiększane o jeden podczas rozmieszczania, jeśli początkowy pad ma designator kończący się znakiem numerycznym. Zmień designator pierwszego pada przed rozmieszczeniem w panelu Properties .
Aby uzyskać przyrosty alfabetyczne, np. 1A, 1B, lub przyrosty numeryczne inne niż 1, użyj okna dialogowego Setup Paste Array dialog otwieranego przez naciśnięcie przycisku Paste Array w oknie dialogowym Paste Special dialog (Edit » Paste Special).
Funkcja Paste Array
Ustawiając designator pada przed skopiowaniem go do schowka, możesz użyć okna dialogowego Setup Paste Array, aby automatycznie zastosować sekwencję oznaczeń podczas rozmieszczania padów. Korzystając z pola Text Increment w oknie dialogowym Setup Paste Array, można umieszczać następujące sekwencje oznaczeń padów:
- Numeryczne (1, 3, 5)
- Alfabetyczne (A, B, C)
- Kombinacje alfanumeryczne (A1 A2, 1A 1B, A1 B1 lub 1A 2A itd.)
Aby zwiększać numerację liczbowo, ustaw pole Text Increment na wartość, o jaką chcesz zwiększać. Aby zwiększać alfabetycznie, ustaw pole Text Increment na literę alfabetu odpowiadającą liczbie liter, które chcesz pominąć. Na przykład, jeśli początkowy pad ma designator 1A, ustaw pole na A, (pierwsza litera alfabetu) aby zwiększać oznaczenia o 1. Jeśli ustawisz pole na C (trzecia litera alfabetu), oznaczenia będą miały postać 1A, 1D (trzy litery po A), 1G itd.
Połączenia zworek
Połączenia zworek definiują połączenia elektryczne między padami komponentów, które nie są fizycznie prowadzone za pomocą obiektów na PCB. Jest to szczególnie przydatne na płytkach jednowarstwowych, gdzie przewód jest używany do przeskoczenia nad ścieżkami na jednej fizycznej warstwie.
Pady w obrębie komponentu mogą mieć przypisaną Jumper wartość w panelu Properties. Pady, które mają tę samą zworkę i tę samą sieć elektryczną, informują system, że istnieje między nimi prawidłowe, chociaż fizycznie niepołączone, połączenie.
Połączenia zworek są pokazywane w Edytorze PCB jako zakrzywione linie połączeń. Kontrola reguł projektowych nie będzie zgłaszać połączeń zworek jako niepoprowadzonych sieci.
Szczegóły przelotek
Definiowanie właściwości przelotki
Podczas gdy wymagania dotyczące rozpiętości warstw (płaszczyzna Z) dla każdego typu przelotki są definiowane na karcie the Via Types tab of the Layer Stack Manager, właściwości rozmiaru przelotki są definiowane przez:
-
ręczną edycję umieszczonej przelotki w panelu Properties panel, lub
-
domyślne obiekty PCB, gdy przelotka jest umieszczana ręcznie (Place » Via), lub
-
regułę projektową Routing Via Style design rule, jeśli przelotka jest umieszczana podczas routingu interaktywnego, ActiveRouting lub autoroutingu.
Konfigurowanie reguły projektowej Routing Via Style
Main page: Definiowanie, określanie zakresu i zarządzanie regułami projektowymi PCB
Przelotki umieszczane podczas routingu interaktywnego, ActiveRouting lub autoroutingu mają swoje właściwości rozmiaru kontrolowane przez odpowiednią regułę projektową Routing Via Style. Aby ułatwić kierowanie przelotek w regule projektowej, dostępny jest zestaw słów kluczowych zapytań związanych z przelotkami, których można użyć w zakresie reguły (Where the Object Matches); są one szczegółowo opisane poniżej.
Gdy podczas routingu wykonujesz zmianę warstwy, oprogramowanie sprawdza warstwy początkową i końcową dla tej zmiany warstwy i wybiera dozwolony typ przelotki z Layer Stack Manager. Następnie identyfikuje odpowiednią regułę projektową Routing Via Style o najwyższym priorytecie i stosuje ustawienia rozmiaru przelotki z sekcji Constraints tej reguły do przelotki, która ma zostać umieszczona.
Na przykład możesz mieć zestaw sieci DRAM_DATA, które wymagają µVias dla przejścia warstw TopLayer - do - S2 oraz S2 - do - S3, a wierconej przelotki przelotowej dla wszystkich pozostałych przejść międzywarstwowych (która również różni się od przelotki wymaganej przez inne sieci). Można to obsłużyć, tworząc dwie reguły projektowe Routing Via Style ukierunkowane na te sieci DRAM_DATA. Przykład odpowiedniej reguły projektowej µVia pokazano poniżej; najedź kursorem na obraz, aby wyświetlić regułę dla przelotki przelotowej.

Zakres reguł projektowych można określić tak, aby dotyczyły określonych typów przelotek.
Aby uprościć proces określania zakresu reguł projektowych Routing Via Style, dostępne są następujące słowa kluczowe zapytań związane z przelotkami:
| Via Type Query | Returns |
|---|---|
| IsVia | Wszystkie obiekty przelotek, niezależnie od typu przelotki. |
| IsThruVia | Wszystkie przelotki rozciągające się od warstwy górnej do warstwy dolnej. |
| IsBlindVia | Wszystkie przelotki rozpoczynające się na warstwie zewnętrznej i kończące na warstwie wewnętrznej, które nie są µVia. |
| IsBuriedVia | Wszystkie przelotki rozpoczynające się na warstwie wewnętrznej i kończące na innej warstwie wewnętrznej, które nie są µVia. |
| IsMicroVia | Wszystkie przelotki z włączoną opcją µVia, łączące sąsiednie warstwy. |
| IsSkipVia | Wszystkie przelotki z włączoną opcją µVia, obejmujące 2 warstwy. |
Umieszczanie przelotek podczas routingu interaktywnego
Gdy zmieniasz warstwy podczas routingu interaktywnego, oprogramowanie automatycznie wstawi przelotkę. Wybrana przelotka zależy od:
- Dostępnych typów przelotek dla warstw obejmowanych zmianą warstwy.
- Odpowiedniej reguły projektowej Routing Via Style dla typu przelotki wybranego dla tej zmiany warstwy.
Skumulowane µVias umieszczane podczas zmiany warstwy z L1 do L4. Tryb Interactive Routing panelu Properties wyświetla typ(y) przelotek, które zostaną umieszczone; naciśnij 6, aby przełączać się między możliwymi stosami przelotek; naciśnij 8, aby wyświetlić listę możliwych stosów przelotek.
Sterowanie przelotką umieszczaną podczas routingu interaktywnego
-
Podczas zmiany warstw routingu oprogramowanie automatycznie wybiera najbardziej odpowiedni typ przelotki dla danego zakresu warstw.
-
Jeśli istnieje wiele typów/kombinacji przelotek (stosów przelotek), których można użyć, naciśnij klawisz skrótu 6, aby interaktywnie przełączać wszystkie stosy przelotek dostępne dla tej zmiany warstwy, a skrót 8, aby wyświetlić listę. Stosy przelotek są prezentowane w kolejności: użyj µVia, użyj Skip µVia, użyj ślepej przelotki, użyj przelotki przelotowej. Skumulowane przelotki mogą być umieszczane, jeśli zmiana warstwy obejmuje więcej niż jedną warstwę i zdefiniowano odpowiednie typy przelotek. Proponowany typ(y) przelotek są opisane na pasku stanu oraz w Heads Up display, na przykład [µVia 1:2, µVia 2:3, µVia 3:4], jak pokazano na powyższym obrazie.
-
Ostatnio użyty stos przelotek jest zachowywany jako domyślny dla następnej prowadzonej sieci. Domyślny stos przelotek jest zachowywany tylko dla bieżącej sesji edycji.
-
Właściwości rozmiaru przelotki są określane przez odpowiednią regułę projektową Routing Via Style, a strategie definiowania odpowiedniej reguły projektowej Routing Via Style zostały omówione powyżej.
-
Aby interaktywnie zmienić rozmiar przelotki podczas wykonywania zmiany warstwy, naciśnij skrót 4. Spowoduje to przełączanie trybów Via Size:
Rule Minimum;Rule Preferred;Rule Maximum;User Choice; przy czym bieżący tryb Via-Size będzie wyświetlany w Heads Up display i na pasku stanu (jak pokazano na obrazie powyżej). Jeśli wybrano User Choice, naciśnij Shift+V, aby otworzyć okno dialogowe Choose Via Sizes dialog i wybrać preferowany rozmiar przelotki. Lista dostępnych rozmiarów przelotek wyświetlana w oknie dialogowym jest pobierana z listy przelotek już użytych w projekcie; można je sprawdzić w trybie Pad and Via Templates mode panelu PCB.Jeśli tryb Template preferred jest używany w odpowiedniej regule projektowej Routing Via Style, użycie skrótu 4 będzie przełączać włączone szablony przelotek.
-
Widok z boku proponowanych typów przelotek jest pokazywany w panelu Properties, jak pokazano powyżej.
-
Aby umieścić przelotkę i kontynuować routing na tej samej warstwie, naciśnij skrót 2.
-
Aby umieścić przelotkę i zawiesić routing tego połączenia, naciśnij skrót / na klawiaturze numerycznej.
-
Jeśli prowadzona sieć ma być połączona z wewnętrzną płaszczyzną zasilania, naciśnij klawisz / (na klawiaturze numerycznej), aby umieścić przelotkę łączącą z odpowiednią płaszczyzną zasilania. To będzie działać we wszystkich trybach rozmieszczania ścieżek z wyjątkiem trybu Any Angle mode.
-
Podczas routingu naciśnij Shift+F1, aby wyświetlić menu wszystkich skrótów dostępnych w bieżącym poleceniu.
Praca ze skumulowanymi przelotkami
-
Skumulowane przelotki, które tworzą ciągłe połączenie, mogą być obsługiwane tak, jakby były pojedynczą przelotką, click and drag na stosie, aby przesunąć je wszystkie wraz z dołączonym routingiem.
-
Kliknij raz, aby zaznaczyć najwyżej położoną przelotkę w stosie. Jeśli mysz nie zostanie poruszona, kolejne pojedyncze kliknięcia będą po kolei zaznaczać każdą z pozostałych przelotek w stosie.
-
Ctrl+Click and drag aby przesunąć tylko wybraną przelotkę wraz z dołączonym routingiem.
-
Aby zaznaczyć wszystkie przelotki w stosie, kliknij raz, aby zaznaczyć jedną, a następnie naciśnij Tab, aby rozszerzyć zaznaczenie na wszystkie przelotki w tym stosie.
Konfigurowanie wyświetlania przelotek
Dostępnych jest wiele funkcji wyświetlania, które pomagają w pracy z przelotkami.
Kolory przelotek
Kolory przelotek są konfigurowane w panelu View Configuration panel. Miedziany pierścień przelotki jest pokazywany zgodnie z bieżącym ustawieniem Multi-Layer w sekcji Layers . Kolor otworu przelotki jest pokazywany zgodnie z ustawieniem Via Holes w sekcji System Colors . Możesz także wyłączyć wyświetlanie otworów, przełączając
dla żądanych ustawień.

Na pierwszym obrazie pokazano przelotkę przelotową. Przelotka na drugim obrazie to przelotka ślepa; otwór jest pokazany w kolorach warstwy początkowej i końcowej.
Przelotki i maska lutownicza
Domyślny sposób prezentacji warstw w edytorze PCB polega na tym, że Multi-Layer jest zawsze pokazywana jako warstwa najwyższa. Może to utrudniać dokładne wyświetlanie zawartości warstw maski lutowniczej, szczególnie gdy pad lub przelotka używa ujemnego rozszerzenia maski, ponieważ zawartość warstwy maski lutowniczej zniknie pod obiektem multi-layer. Można to zmienić, modyfikując kolejność rysowania warstw na stronie PCB Editor – Display okna dialogowego Preferences. Ustaw bieżącą warstwę tak, aby była rysowana jako warstwa najwyższa.
Po zmianie kolejności rysowania warstw tak, aby bieżąca warstwa była pokazywana na wierzchu, gdy ustawisz Top Solder jako bieżącą warstwę, otwory maski będą prezentowane dokładnie, jak pokazano na poniższym obrazie. Zielone strzałki pokazują rozmiar otwarcia maski lutowniczej dla przelotki po lewej, pada ze zmniejszonym otwarciem maski pośrodku oraz pada z powiększonym otwarciem po prawej.

Skonfiguruj ustawienia wyświetlania, aby móc sprawdzać otwory maski lutowniczej.
Wyświetlanie skumulowanych przelotek
Jeśli występują skumulowane przelotki, wyświetlane liczby oznaczają warstwy początkowe i końcowe wszystkich przelotek w stosie. Najedź kursorem na obraz poniżej, aby pokazać przelotki w 3D; po prawej stronie obrazu znajduje się stos trzech przelotek.
Warstwy objęte przelotką mogą być wyświetlane wewnątrz przelotek. Najedź kursorem, aby pokazać przelotki w 3D.
Inne ustawienia wyświetlania przelotek
Aby wyświetlić nazwę sieci przelotki oraz numery warstw w zakresie przelotki, włącz odpowiednio opcje Via Nets i Via Span w obszarze Additional Options na karcie View Options panelu View Configuration .
Przeglądanie otworów padów i przelotek
W trybie PCB panel’s Hole Size Editor jego trzy główne obszary zmieniają się tak, aby odzwierciedlać (w kolejności od góry):
- Ogólne filtrowanie typów otworów i ich statusu, z podsekcją dla par warstw wiercenia aktualnie zdefiniowanych dla płytki.
- Unique Holes ułożone w grupy określane według rozmiaru i kształtu.
- Pojedyncze Pads/Vias tworzące każdą grupę obiektów otworów.

Sekcje panelu pokazują skumulowane filtrowanie zastosowane do typów, stylów i statusu otworów.
Grupy otworów można zbiorczo edytować w obszarze Unique Holes panelu, wprowadzając wartości w odpowiedniej komórce kolumny. Możesz wprowadzić wartość liczbową, aby zmienić bieżący rozmiar otworu dla padów i przelotek w kolumnie Hole Size .

Edycja rozmiaru otworu dla wybranej grupy sześciu pasujących stylów otworów.
Możesz również zmienić odpowiednie wpisy Hole Length, Hole Type i Plated dla otworów tam, gdzie ma to zastosowanie.

Zmiana typu otworu dla wybranej grupy sześciu pasujących stylów otworów.
Poszczególne obiekty padów/przelotek należące do wybranej grupy otworów są wyświetlane w dolnej sekcji Pad/Via panelu PCB. Kliknij prawym przyciskiem obiekt na liście, a następnie wybierz Properties (lub kliknij dwukrotnie bezpośrednio wpis), aby otworzyć odpowiedni tryb panelu Properties dla tego obiektu, gdzie można przeglądać i edytować jego właściwości.
Aby zaktualizować panel PCB w trybie Hole Size Editor o bieżące dane symboli wierceń z PCB, kliknij prawym przyciskiem w obszarze panelu w tym trybie i wybierz polecenie Refresh.
Obsługa back drillingu
Tryb Hole Size Editor panelu PCB może być również używany do badania padów i przelotek przeznaczonych do back drillingu. Pary warstw back drillu są wyświetlane na liście Layer Pairs z dopiskiem [BD].
Po wybraniu rozmiaru otworu back drillu obiekty mają wyświetlane Kind jako Backdrill. Użyj tej możliwości, aby szybko zlokalizować i sprawdzić otwory po back drillingu. Zwróć uwagę, że ustawień back drillu nie można edytować w panelu.
Raport back drillingu
Aby wygenerować raport wszystkich zdarzeń back drillu, kliknij prawym przyciskiem na liście Unique Holes, a następnie wybierz Backdrill Report z menu kontekstowego.
Raport zawiera szczegóły każdego zdarzenia back drillu, w tym lokalizację, rozmiar wiercenia i głębokość wiercenia.
Obsługa otworów pogłębianych
Tryb Hole Size Editor panelu PCB może być również używany do badania padów z włączonymi funkcjami counterhole. Gdy projekt PCB zawiera obiekty padów z włączonymi funkcjami counterhole (counterbore/countersink) po jednej lub obu stronach, odpowiednie grupy Counterholes Top i/lub Counterholes Bottom są wyświetlane na liście Layer Pairs. Kolumny Counterhole Depth i Counterhole Angle mogą być wyświetlane w obszarze Unique Holes panelu. Zwróć uwagę, że ustawień counterhole nie można edytować w panelu.

Informacje o otworach pogłębianych w projekcie są wyświetlane w trybie Hole Size Editor panelu PCB.





