Defining the Wiring Diagram
W skrócie
- Jak dodać i skonfigurować dokument schematu połączeń wiązki przewodów, w tym jednostki, siatki, opcje strony i ustawienia domyślne.
- Jak synchronizacja z projektem wielopłytkowym importuje do schematu połączeń komponenty złączy i połączenia logiczne.
- Jak umieszczać komponenty w schemacie połączeń i zarządzać nimi — zarówno tymi zaimportowanymi z projektu wielopłytkowego, jak i dodanymi ręcznie.
Poszczególne połączenia przewodowe w wiązce są określone na schemacie połączeń wiązki (*.WirDoc). Dodaj ten dokument do projektu wiązki z panelu Projects, klikając prawym przyciskiem myszy pozycję projektu, a następnie wybierając Add New to Project » Harness Wiring Diagram z menu kontekstowego (lub użyj polecenia File » New » Harness Wiring Diagram z menu głównego).
Konfigurowanie dokumentu schematu połączeń wiązki
Opcje dokumentu schematu połączeń wiązki można skonfigurować w panelu Properties, gdy w obszarze projektowym dokumentu nie jest zaznaczony żaden obiekt. Główne ustawienia to:
-
W sekcji General na karcie General panelu – wybierz jednostki miary obowiązujące w dokumencie i jego elementach graficznych oraz ustaw siatki, aby ułatwić rozmieszczanie obiektów. Altium Designer oferuje trzy typy siatek: siatkę widoczną do nawigacji, siatkę przyciągania do rozmieszczania obiektów oraz odległość przyciągania ułatwiającą tworzenie połączeń.
-
W sekcji Page Options na karcie General panelu – skonfiguruj rozmiar arkusza dokumentu i tabelkę rysunkową lub wybierz jeden z dostępnych szablonów schematów połączeń wiązki.

Karty General i Parameters panelu Properties, gdy w dokumencie schematu połączeń wiązki nie jest zaznaczony żaden obiekt
Synchronizacja projektów wielopłytkowych i projektów wiązek
Gdy projekt wiązki jest częścią projektu wielopłytkowego, schemat połączeń wiązki można zsynchronizować na podstawie danych z dokumentu schematu wielopłytkowego (*.MbsDoc). W tym celu wybierz polecenie Design » Import Changes From <Multi-board Project> z menu głównego.
Więcej informacji o dodawaniu projektu wiązki do projektu wielopłytkowego znajdziesz na stronie Projektowanie wiązek.
Jeśli dokument schematu wielopłytkowego zawiera więcej niż jedną definicję połączenia wiązki, otworzy się okno dialogowe Select Harness Definition. Wskaż definicję odpowiadającą bieżącemu projektowi wiązki.

Okno dialogowe Select Harness Definition
Następnie otworzy się okno dialogowe Engineering Change Order, przedstawiające komponenty złączy wiązki oraz sieci wiązki zdefiniowane na schemacie wielopłytkowym, które będą stanowić podstawę schematu połączeń wiązki.

Użyj okna dialogowego Engineering Change Order, aby zaimportować dane z projektu wielopłytkowego.
Po wykonaniu zmian dane z dokumentu schematu wielopłytkowego zostaną zaimportowane do schematu połączeń wiązki. Komponenty złączy, z których każdy jest reprezentowany przez swój symbol schematowy, pojawią się w dokumencie schematu połączeń wiązki, początkowo w przypadkowych położeniach.

Przykład schematu połączeń wiązki bezpośrednio po imporcie.
Między pinami będą widoczne linie sieci reprezentujące połączenia logiczne zdefiniowane na schemacie wielopłytkowym. Pamiętaj, że na tym etapie w projekcie nie ma jeszcze fizycznych przewodów.
Praca z komponentami
Oprócz synchronizacji z dokumentem schematu wielopłytkowego komponenty można również umieszczać ręcznie na schemacie połączeń wiązki. Umożliwia to umieszczanie komponentów w samodzielnym projekcie wiązki (który nie jest częścią projektu wielopłytkowego), a także dodawanie kolejnych komponentów do schematu połączeń wiązki będącego częścią projektu wielopłytkowego.
Użyj panelu Components, aby umieścić symbole wymaganych komponentów. Proces umieszczania komponentów jest podobny do stosowanego w edytorze schematów — więcej informacji znajdziesz na stronie Wyszukiwanie i umieszczanie komponentów. Należy pamiętać, że dla komponentów dodanych ręcznie nie będą wyświetlane linie sieci, ponieważ nie istnieje projekt logiczny wyższego poziomu, który by je definiował.
Aby przesunąć umieszczony komponent (lub komponent umieszczany z panelu Components) w żądane położenie, kliknij go i przytrzymaj lewy przycisk myszy, a następnie przesuń mysz. Podczas przeciągania użyj Spacebar, aby obrócić komponenty o 90 stopni, oraz klawiszy X i Y, aby odbić je odpowiednio w poziomie i w pionie.

Schemat połączeń wiązki po przesunięciu komponentów
Właściwości umieszczonego komponentu można skonfigurować w panelu Properties po zaznaczeniu komponentu w obszarze projektowym. Panel Properties dla komponentu zawiera następujące karty:
-
General – ogólne właściwości komponentu, takie jak oznaczenie i komentarz, położenie, parametry itp.
-
Pins – lista pinów komponentu.
-
Cavities – umożliwia przypisywanie komór stykowych do komponentu (dowiedz się więcej).
-
Associated Parts – umożliwia przypisywanie do komponentu dodatkowych części, takich jak koszulki termokurczliwe.
Przypisywanie komór stykowych
Do komponentu wiązki można przypisać elementy komór stykowych oraz ich typy. Aby dodać element komory i jego typ, zaznacz komponent w obszarze projektowym. Wybierz pin na karcie Cavities panelu Properties , a następnie kliknij przycisk
. Wybierz żądany typ z listy rozwijanej. Obsługiwane są następujące typy elementów komór:
-
Crimp – służy do utworzenia połączenia elektrycznego przez zaciśnięcie tulei styku na żyle przewodu.
-
Seal – służy do zapewnienia ochrony przed wpływem otoczenia przez uszczelnienie miejsca wprowadzenia przewodu.
-
Plug – służy do wypełnienia otwartej (nieużywanej) komory złącza w celu zachowania szczelności i ochrony przed wpływem otoczenia.
-
Other – służy do określenia innych/dodatkowych części lub materiałów, np. lutowia.
W otwartym oknie dialogowym Select Connector odszukaj i wybierz żądany komponent. Odpowiedni typ i powiązane informacje zostaną dodane do pinu na karcie, jak pokazano na poniższych ilustracjach przedstawiających dodawanie styku zaciskanego do pinu 1.
W przypadku styku zaciskanego, uszczelki lub zaślepki do pinu można dodać tylko jeden element komory danego typu. Po dodaniu elementu komory danego typu odpowiednia pozycja na liście rozwijanej staje się niedostępna (wyszarzona). Do pinu można dodać dowolną liczbę elementów komór typu Other.
Piny z przypisanymi stykami zaciskanymi są oznaczone symbolem
w obszarze projektowym, jak pokazano na poniższej ilustracji.
Obszar tabeli na karcie Cavities obsługuje zaznaczanie wielu pozycji oraz operacje kopiowania, wklejania i usuwania zaznaczonych wpisów.
-
Wiele wpisów pinów można zaznaczyć za pomocą skrótów
Click, Hold&Drag,Ctrl+Click,Shift+ClickiCtrl+A. -
Po zaznaczeniu wielu wpisów pinów kliknij
, aby dodać element komory do wszystkich zaznaczonych pinów, lub kliknij
albo naciśnij Delete, aby usunąć dodane elementy komór z zaznaczonych pinów. -
Aby zmienić element komory pinu, zaznacz jego wpis, a następnie kliknij
, aby otworzyć okno dialogowe Select Connector i wybrać nowy element komory.
-
Zaznacz jeden lub więcej wpisów pinów i użyj skrótów
Ctrl+X/Ctrl+C, aby wyciąć/skopiować zaznaczone wpisy, a następnie użyj skrótuCtrl+V, aby wkleić wyciętą/skopiowaną zawartość w aktualnie zaznaczonym wpisie.
Tworzenie połączeń na schemacie połączeń wiązki
Przewody fizyczne umieszcza się w dokumencie schematu połączeń wiązki, wybierając polecenie Place » Harness Wire z menu głównego (skrót: Shift+W).
Po wybraniu polecenia kliknij pin złącza (gdy kursor znajduje się nad punktem przyłączeniowym pinu, pojawia się przy nim czerwony krzyżyk), aby umieścić punkt początkowy przewodu wiązki. Ustawiaj kursor i klikaj, aby wstawić kolejne wierzchołki określające kształt przewodu wiązki. Po umieszczeniu ostatniego wierzchołka w punkcie przyłączeniowym innego pinu kliknij prawym przyciskiem myszy, aby zakończyć umieszczanie.
Podczas umieszczania przewodu wiązki naciskaj Shift+Spacebar, aby przełączać tryby umieszczania. Tryb określa sposób tworzenia narożników podczas umieszczania przewodów oraz kąty, pod jakimi można je prowadzić. W trybie 90 Degree lub 45 Degree (tryby ściśle ortogonalne) naciskaj Spacebar, aby przełączać między podtrybem początkowym a końcowym. Bieżący tryb i podtryb są wyświetlane na pasku stanu.
Podczas umieszczania przewodu wiązki linie połączeń są śledzone i odświeżane na bieżąco, wskazując w czasie rzeczywistym, gdzie należy poprowadzić przewód, jak pokazano na poniższym filmie. Po wykonaniu połączenia odpowiadająca mu linia znika z dokumentu.
Demonstracja funkcji śledzenia na żywo
Po umieszczeniu i zaznaczeniu przewodu wiązki można przeciągać jego wierzchołki, aby zmienić kąt między dwoma sąsiednimi odcinkami
Zaznacz przewód wiązki w obszarze projektowym, aby zmienić go w panelu Properties. W panelu można zmienić nazwę zaznaczonego przewodu wiązki, jego szerokość i kolor oraz dodać parametry, które można wyświetlać lub ukrywać w obszarze projektowym.

Panel Properties po zaznaczeniu przewodu wiązki
Dodawanie połączeń łączących i odgałęzień
W sytuacjach projektowych, w których nowy przewód trzeba połączyć z już umieszczonym przewodem, należy najpierw umieścić obiekt połączenia łączącego (Place » Splice) lub odgałęzienia (Place » Tap).
-
Splice – połączenie łączące dzieli pierwotny przewód na dwa oddzielne przewody.
Do zaznaczonego przewodu (W4) trzeba podłączyć kolejny przewód.
Połączenie łączące umieszczone na przewodzie. Zwróć uwagę, że dzieli ono pierwotny przewód na dwa w miejscu połączenia.
Do połączenia łączącego podłączono kolejny przewód.
-
Tap – pierwotny przewód pozostaje nieprzerwany.
Do wybranego przewodu (W4) należy podłączyć kolejny przewód.
Odczep umieszczony na przewodzie. Zwróć uwagę, że odczep nie dzieli pierwotnego przewodu.
Do odczepu podłączono kolejny przewód.
Właściwości umieszczonego połączenia lub odczepu (jego położenie i wygląd) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektowym.

Panel Properties po zaznaczeniu połączenia/odczepu
Sekcja Associated Parts panelu Properties umożliwia przypisanie komponentów do wybranego połączenia/odczepu. Przypisany komponent zostanie uwzględniony w zestawieniu materiałowym (BOM) projektu.
Dodawanie kabli
Aby określić, że jeden lub więcej przewodów należy do kabla, umieść obiekt kabla na schemacie połączeń wiązki (Place » Harness Cable).

Umieść kabel, aby określić, które przewody do niego należą.
Po zaznaczeniu obiektu kabla przewody należące do tego kabla zostaną podświetlone w obszarze projektowym na jaskrawozielono
Właściwości umieszczonego obiektu kabla (jego położenie, wygląd i parametry) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektowym.

Panel Properties po zaznaczeniu kabla
Użyj przycisku blokowania/odblokowywania w polach Width/Height panelu, aby przełączać między zablokowanymi a odblokowanymi wymiarami. Podczas przeciągania uchwytów edycji obiektu proporcje są zachowywane zgodnie z tym ustawieniem. Domyślnie wymiary są zablokowane, a stosunek wysokości do szerokości wynosi 2:1. Po odblokowaniu można niezależnie zmieniać wymiary według potrzeb.
Ekranowanie i skręcanie przewodów
Ekran (z połączeniem lub bez niego, na przykład z połączeniem przewodu odprowadzającego) można przypisać do grupy przewodów, umieszczając obiekt ekranu (Place » Shield) lub ekranu z połączeniem (Place » Shield with Connection).
W poniższym przykładzie przewody W1, W2 i W3 są ekranowane ekranem bez połączenia (SH1), a przewody W4, W8 i W9 — ekranem z połączeniem (SH2). Przewód W10 służy do połączenia SH2 z wyprowadzeniem komponentu.

Umieść obiekt ekranu lub ekranu z połączeniem, aby oznaczyć przewody jako ekranowane.
Po zaznaczeniu obiektu ekranu lub ekranu z połączeniem objęte nim przewody zostaną podświetlone w obszarze projektowym na jaskrawozielono
Właściwości umieszczonego obiektu ekranu lub ekranu z połączeniem (położenie i wygląd) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektowym. Sekcja Shield Objects panelu zawiera listę przewodów objętych zaznaczonym obiektem.

Panel Properties po zaznaczeniu ekranu
Przewody można oznaczyć jako skręcone ze sobą, umieszczając obiekt skręcenia (Place » Twist). Obiekt skręcenia może obejmować dwa lub więcej przewodów.
W poniższym przykładzie przewody W1 i W2 są oznaczone jako skręcone ze sobą za pomocą obiektu skręcenia Tw1.

Umieść obiekt skręcenia, aby oznaczyć przewody jako skręcone ze sobą.
Po zaznaczeniu obiektu skręcenia objęte nim przewody zostaną podświetlone w obszarze projektowym na jaskrawozielono
Właściwości umieszczonego obiektu skręcenia (jego położenie i wygląd) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektowym. Sekcja Twist Objects panelu zawiera listę przewodów objętych zaznaczonym obiektem skręcenia.

Panel Properties po zaznaczeniu obiektu skręcenia
Niepodłączone przewody
Niepodłączone końce przewodów są oznaczone wypełnionym kwadratem.

Oznaczenie niepodłączonego przewodu
Końca przewodu nie należy pozostawiać niepodłączonego. Jeśli projekt wymaga pozostawienia niepodłączonego końca przewodu, należy umieścić na nim obiekt „brak połączenia” (Place » No Connect).

Umieść obiekt „brak połączenia” na końcu przewodu, który ma pozostać niepodłączony.
Właściwości umieszczonego obiektu „brak połączenia” (jego położenie i wygląd) można skonfigurować w panelu Properties, gdy obiekt jest zaznaczony w obszarze projektowym.

Panel Properties po zaznaczeniu obiektu „brak połączenia”
Praca z wieloma arkuszami
Pełny schemat połączeń wiązki można zdefiniować na wielu arkuszach (w strukturze „płaskiej”, w której wszystkie arkusze znajdują się na tym samym poziomie), z których każdy jest reprezentowany przez osobny dokument *.WirDoc. Połączenia są tworzone bezpośrednio między dowolnymi arkuszami za pomocą obiektów przerwania przewodu (Place » Wire Break) o tym samym oznaczeniu przewodu.
Po wybraniu polecenia wstawiania przerwania przewodu ustaw obiekt tak, aby jego punkt połączenia elektrycznego (koniec przytrzymywany kursorem) dotykał przewodu, z którym chcesz go połączyć, a następnie kliknij lub naciśnij Enter, aby go wstawić. Wstawione przerwanie przewodu dziedziczy właściwości (oznaczenie i kolor) przewodu, z którym jest połączone.
Zaznacz przerwanie przewodu w obszarze projektowym, aby zmodyfikować je w panelu Properties. W panelu możesz zdefiniować oznaczenie przewodu, z którym jest połączone, oraz jego styl: kierunek (Left lub Right) i kolor.
Synchronizacja przewodów
Przewody wiązki połączone za pomocą przerwania przewodu są rozpoznawane nawet wtedy, gdy mają różne identyfikatory elementu projektu (Design Item ID). Ponadto wszystkie segmenty przewodów o tym samym oznaczeniu, połączone za pomocą tego samego przerwania przewodu, są porównywane pod kątem numeru części, komentarza, koloru i wszystkich parametrów. Jeśli zostaną wykryte jakiekolwiek różnice, zgłaszane jest naruszenie Mismatched parameters in connected wire segments. Ostrzeżenie pojawia się również w panelu Properties przewodu i przerwania przewodu, informując o wykryciu konfliktu parametrów. Kliknij Synchronize w ostrzeżeniu, aby otworzyć okno dialogowe Conflict Wire Parameters, w którym możesz wybrać parametry do zastosowania dla segmentu przewodu.
Wstawianie komponentu połączeń wiązki
Po połączeniu z Workspace możesz tworzyć w nim komponenty o wstępnie zdefiniowanej strukturze i właściwościach zgodnych z wymaganiami, a następnie ponownie wykorzystywać je w projektach wiązek, wstawiając je bezpośrednio do dokumentów schematu połączeń wiązki.
Więcej informacji znajdziesz na stronie Tworzenie komponentu połączeń wiązki.
Te komponenty (każdy z przypisanym zdefiniowanym modelem połączeń wiązki) są dostępne w panelu Components. Gdy odpowiedni dokument schematu połączeń wiązki jest aktywny w obszarze projektowym, wstaw komponent, klikając prawym przyciskiem myszy jego pozycję w panelu i wybierając polecenie Place <ComponentName> z menu kontekstowego. Sposób wstawiania komponentu różni się w zależności od tego, czy zawiera on pojedynczy obiekt przewodu, czy strukturę kabla (wiele przewodów i/lub dodatkowe obiekty: kable, ekrany itp.).
-
Single wire – podczas wstawiania komponentu zawierającego pojedynczy obiekt przewodu zostanie uruchomiony tryb wstawiania przewodu wiązki. Wstawiany przewód odziedziczy właściwości zdefiniowane podczas tworzenia komponentu. Więcej informacji na temat wstawiania przewodów wiązki znajdziesz w sekcji Tworzenie połączeń na schemacie połączeń wiązki powyżej.
-
Cable structure – po wybraniu polecenia wstawiania komponentu zawierającego strukturę kabla struktura ta zostanie dołączona do kursora dokładnie w takiej postaci, w jakiej została zdefiniowana podczas tworzenia komponentu. Kliknij w wybranym miejscu dokumentu schematu połączeń wiązki, aby wstawić komponent. Następnie możesz edytować poszczególne obiekty komponentu, na przykład podłączyć przewody tworzące kabel do styków złączy wiązki.
Aktualizowanie schematu połączeń na podstawie bibliotek
Następujące obiekty można aktualizować na podstawie ich biblioteki źródłowej w Workspace:
-
Komponenty wiązki
-
Gniazda styków komponentów wiązki
-
Części powiązane z komponentami wiązki
-
Przewody
Po zaznaczeniu obiektu informacje o powiązanym komponencie Workspace można znaleźć w panelu Properties (np. na karcie Associated Parts w przypadku części powiązanych z komponentem wiązki).
Jeśli dostępna jest nowsza rewizja komponentu Workspace, pozycja stanu rewizji będzie o tym informować tekstem Out of date. Na poziomie pojedynczego obiektu można zaktualizować powiązanie do najnowszej rewizji komponentu Workspace, klikając przycisk
.
Przykład oznaczenia nieaktualnej rewizji komponentu wiązki
Funkcji Update from Libraries (Tools » Update from Libraries) można również używać do aktualizowania nieaktualnych komponentów powiązanych z obiektami wymienionymi powyżej. Pamiętaj, że aby obiekt został uwzględniony w aktualizacji za pomocą funkcji Update from Libraries, przypisany do niego komponent musi zawierać powiązanie z symbolem schematowym.
Nadawanie oznaczeń obiektom schematu połączeń wiązki
Użyj poleceń w menu Tools » Annotation, aby nadać oznaczenia następującym obiektom w dokumencie schematu połączeń wiązki:
-
Komponenty wiązki
-
Przewody
-
Połączenia splatane i odgałęzienia
-
Kable
-
Ekrany i ekrany z połączeniem
-
Skrętki
-
Obiekty „Brak połączenia”
Nadawanie oznaczeń obiektom w dokumencie schematu połączeń wiązki przebiega podobnie jak nadawanie oznaczeń komponentom w dokumencie schematu (*.SchDoc) projektu PCB. Skorzystaj z poniższych łączy, aby dowiedzieć się więcej o poleceniach nadawania oznaczeń dostępnych dla dokumentu schematu połączeń wiązki:
).

).







).

).
).
).
).
).
).





).