Pesquisar Componentes em Bibliotecas Baseadas em Banco de Dados e em Arquivos
Altium Essentials: Schematic Capture
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Num relance
- Entenda as diferenças entre bibliotecas do projeto, bibliotecas instaladas e bibliotecas de caminhos de pesquisa, e como cada uma afeta a disponibilidade de componentes no Altium Designer.
- Saiba onde gerenciar as bibliotecas disponíveis, como funciona a ordem de pesquisa e por que algumas escolhas de configuração das bibliotecas podem afetar a velocidade e a confiabilidade.
- Veja como funciona a pesquisa de componentes em bibliotecas baseadas em arquivos e bancos de dados, incluindo o que esperar ao usar fontes DbLib e SVNDbLib.
Gerenciamento de bibliotecas disponíveis baseadas em banco de dados e em arquivos
No Altium Designer, os componentes de bibliotecas baseadas em banco de dados e em arquivos só podem ser posicionados a partir de bibliotecas que estejam disponíveis no momento. Elas incluem:
-
Libraries in the current project – se uma biblioteca fizer parte do projeto, seus componentes estarão automaticamente disponíveis para posicionamento nesse projeto.
-
Installed libraries – essas bibliotecas foram instaladas no Altium Designer; seus componentes estão disponíveis para uso em qualquer projeto aberto.
-
Libraries on a defined search path – também é possível definir um caminho de pesquisa para uma pasta com várias bibliotecas. Como todos os arquivos no caminho de pesquisa são pesquisados sempre que um novo componente é escolhido em um painel, essa abordagem só é recomendada para bibliotecas pequenas com definições de modelos simples, como modelos de simulação. Caminhos de pesquisa não são recomendados para modelos complexos, como footprints que incluem modelos 3D.
Para gerenciar as bibliotecas disponíveis baseadas em banco de dados e em arquivos, você pode usar a caixa de diálogo Libraries Preferences, que pode ser acessada clicando no botão
na parte superior do painel Components e selecionando Libraries Preferences no menu.
A caixa de diálogo Libraries Preferences tem três abas. Todas as bibliotecas e localizações de modelos definidas nessas abas são reunidas para compor sua lista de bibliotecas disponíveis. Quando é executada uma ação que exige a busca de um modelo, como transferir o projeto do esquemático para o layout da PCB, as bibliotecas são pesquisadas na ordem das abas e, dentro de cada aba, na ordem em que as bibliotecas/modelos estão listados. Assim que o modelo correto é localizado, o processo de pesquisa é encerrado.
Bibliotecas do projeto
As bibliotecas que fazem parte do projeto ativo são listadas na aba Project da caixa de diálogo Libraries Preferences quando esse projeto é o projeto ativo no software. A vantagem das bibliotecas do projeto é que os modelos/bibliotecas ficam automaticamente disponíveis sempre que o projeto é aberto. A desvantagem é que, se os modelos/bibliotecas não forem armazenados na mesma estrutura de pastas do projeto que os arquivos de projeto, eles poderão ser facilmente esquecidos se os arquivos do projeto forem movidos.

A aba Project fornece uma lista das bibliotecas disponíveis no projeto atual.
Bibliotecas instaladas
As bibliotecas e os modelos disponibilizados na sua instalação do software são chamados de bibliotecas instaladas. Eles são listados na aba Installed da caixa de diálogo Libraries Preferences.
As bibliotecas instaladas podem ser listadas usando um caminho absoluto ou um caminho relativo à configuração Library Path Relative To. A vantagem de usar um caminho relativo é que isso permite criar um subambiente comum em vários PCs, facilitando a movimentação dos arquivos de projeto entre eles. Além disso, as bibliotecas instaladas podem ser desativadas temporariamente desmarcando a caixa de seleção Activated, em vez de removê-las.

A aba Installed lista as bibliotecas disponibilizadas nesta instalação do Altium Designer.
Caminho de pesquisa
A aba Search Path apresenta uma lista de bibliotecas localizadas de acordo com as configurações de caminho definidas na aba Search Paths da caixa de diálogo Project Options, que é acessada clicando no botão Paths. Cada caminho de pesquisa define uma pasta e pode incluir subpastas se a opção Recursive estiver habilitada (disponível na aba Search Paths da caixa de diálogo Project Options após a adição de um caminho). Todos os arquivos de modelos e bibliotecas encontrados no caminho de pesquisa estarão disponíveis. Os caminhos de pesquisa são salvos com o projeto.

A aba Search Path lista as bibliotecas encontradas nos caminhos de pesquisa definidos.
A recuperação de modelos usando caminhos de pesquisa pode ser lenta se houver um grande número de arquivos nas pastas do caminho de pesquisa. Por esse motivo, não é recomendável usar essa abordagem para bibliotecas de PCB, pois elas podem ser arquivos grandes que contêm muitos footprints. O recurso foi desenvolvido para fornecer uma maneira de referenciar modelos de simulação e de integridade de sinal disponíveis.
Exploração dos componentes do banco de dados
Depois que o DbLib/SVNDbLib for adicionado à lista de bibliotecas disponíveis baseadas em arquivos, os componentes do banco de dados ficarão disponíveis para consulta no painel Components. Embora apenas um único arquivo DbLib/SVNDbLib seja adicionado, cada tabela do banco de dados vinculado será apresentada como se fosse uma biblioteca distinta.
A lista suspensa na parte superior do painel será preenchida com entradas no formato:
- <LibraryName>.DbLib - <TableName> ou <LibraryName>.SVNDbLib - <TableName> ----quando seu banco de dados contém tabelas
- <LibraryName>.DbLib - <SheetName>$ ou <LibraryName>.SVNDbLib - <SheetName>$ ----onde seu banco de dados é composto por planilhas em um arquivo do Excel.
Exemplo de uma DbLib carregada com três tabelas, outra com uma tabela e uma SVNDbLib com uma tabela.
Cada entrada de componente no painel corresponde a um registro nessa tabela específica do banco de dados. Na verdade, ao navegar pelas bibliotecas de banco de dados carregadas, o painel Components funciona como um navegador direto do banco de dados. As informações de símbolos e modelos são preenchidas a partir das bibliotecas de símbolos e modelos subjacentes indicadas pelos campos correspondentes do banco de dados (e em conjunto com os caminhos/locais de pesquisa definidos).
Navegação por componentes em um banco de dados externo vinculado por meio de uma biblioteca de banco de dados.
Por padrão, apenas os campos Part Number e Library Ref são exibidos na região de listagem de componentes do painel. Para exibir outros campos da tabela do banco de dados, clique com o botão direito na região e escolha Select Columns no menu de contexto. Isso dará acesso à caixa de diálogo Selecionar colunas, na qual você pode habilitar a exibição de qualquer um dos campos adicionais dessa tabela.
Cache local de símbolos e modelos usados por bibliotecas de banco de dados SVN
Quando um arquivo SVNDbLib é adicionado à lista de bibliotecas disponíveis, as bibliotecas de símbolos e modelos do repositório são armazenadas em cache em uma pasta temporária no computador do projetista. Quando uma ação no software exige o uso de um símbolo de esquemático ou modelo, esse símbolo/modelo é recuperado do cache local.
Atualização automática do cache
As bibliotecas no cache serão atualizadas automaticamente com as versões mais recentes do repositório de controle de versão ao executar qualquer uma das seguintes ações no software:
-
Inserir um componente de um arquivo SVNDbLib instalado (a partir do painel Componentes).
-
Executar uma transferência do projeto (ou seja, atualizar a PCB).
-
Usar o comando Tools » Update From Libraries no Editor de Esquemáticos.
-
Usar o comando Tools » Update From PCB Libraries no Editor de PCB.
Embora a atualização seja automática, ela pode ser controlada usando a opção Do not check files more often than xx minutes na página Gerenciamento de dados - Bibliotecas SVN da Preferences caixa de diálogo. Essa opção fornece, essencialmente, um “temporizador de atualização” para o cache local. Se o tempo especificado tiver decorrido desde a última atualização do cache, ele será atualizado automaticamente quando uma das ações listadas for executada. Se uma ação for executada dentro desse intervalo, o conteúdo atual do cache será usado, podendo estar desatualizado em relação ao conteúdo do repositório.
Como forçar manualmente uma atualização do cache
Em alguns momentos, pode ser necessário forçar uma atualização do cache local para garantir que você tenha as bibliotecas mais recentes armazenadas no repositório de controle de versão. Por exemplo, ao se preparar para transferir o projeto do esquemático para a PCB.
Você pode forçar uma atualização do cache manualmente usando um dos seguintes métodos:
- Usar um dos Refresh comandos disponíveis no menu do botão direito do mouse no painel Componentes.
- Desinstalar e reinstalar o arquivo SVNDbLib na lista de Bibliotecas disponíveis.
Pesquisa de componentes em bibliotecas de banco de dados e baseadas em arquivos
Para ajudar a encontrar um componente em bibliotecas baseadas em arquivos (tanto as instaladas quanto as que não estão instaladas no momento) e de banco de dados, o Altium Designer inclui um recurso de pesquisa em bibliotecas.
É possível pesquisar um componente em bibliotecas de banco de dados e baseadas em arquivos usando o campo Search do painel Components. Insira uma sequência de caracteres e pressione Enter para procurá-la na biblioteca atual, em qualquer parte dos parâmetros visíveis dos componentes.
Você pode realizar uma pesquisa diretamente no painel Components.
A caixa de diálogo File-based Libraries Search permite pesquisas mais detalhadas. Para acessá-la, clique no botão
do painel Components e selecione File-based Libraries Search no menu. A metade superior da caixa de diálogo é usada para definir what você está procurando; a metade inferior é usada para definir where pesquisar.
Pesquise nas bibliotecas instaladas (Available libraries) ou nas bibliotecas do disco rígido (Libraries on path).O processo de pesquisa pode ser resumido da seguinte forma:
-
A pesquisa é realizada definindo Filters que são aplicados a todas as bibliotecas que podem ser pesquisadas de acordo com as configurações atuais de Scope da pesquisa.
-
O Scope inclui o tipo de biblioteca a pesquisar. Só é possível pesquisar um tipo por vez.
-
Para habilitar a pesquisa de componentes de banco de dados, defina o campo Search in como Database Components e selecione o Table desejado. Observe que os Fields disponíveis na lista suspensa acima mudarão para refletir os cabeçalhos de coluna disponíveis na tabela escolhida. As demais opções da caixa de diálogo ficam desabilitadas, pois não são relevantes para a pesquisa em bibliotecas de banco de dados.
-
O Scope define quais bibliotecas serão pesquisadas: as bibliotecas às quais o software tem acesso no momento (Available libraries) ou todas as bibliotecas de uma pasta (Libraries on path).
-
Ao pesquisar bibliotecas em um caminho, o destino é uma pasta específica, e também é possível Include Subdirectories.
-
Você também pode pesquisar nos resultados da pesquisa definindo o Scope como Refine last search.
-
Clique em Clear para limpar os parâmetros de pesquisa inseridos.
Configuração do filtro de pesquisa
A região Filters é usada para definir as sequências de caracteres a serem aplicadas à pesquisa. Há três regiões a configurar:
-
Field – este é o atributo do componente que será pesquisado. Pode ser qualquer atributo de componente ou de footprint, incluindo Nome, Descrição, Comentário, Footprint ou qualquer parâmetro que tenha sido adicionado a um componente. Selecione um campo disponível na lista suspensa ou insira um campo na caixa de texto.
-
Operator – define como uma correspondência é determinada. Isso pode ocorrer quando o valor equals, contains, starts with ou ends with. Observe que equals exige uma correspondência exata da sequência de caracteres, portanto só deve ser usado quando você tiver certeza de que a sequência de pesquisa está correta e completa.
-
Value – os caracteres a serem pesquisados no Field escolhido, com a correspondência determinada de acordo com o Operator escolhido. Selecione um valor disponível na lista suspensa ou insira um valor no campo de texto.
Por padrão, há três condições de filtro; você pode adicionar até sete linhas adicionais, totalizando 10 linhas, usando o Add Row controle. A última linha de condição de filtro adicionada pode ser removida usando o Remove Row. Você pode remover as linhas que não são usadas.
Configuração do escopo
Há essencialmente duas abordagens de pesquisa:
-
Bibliotecas disponíveis no momento – esta é a lista de bibliotecas exibida na lista suspensa na parte superior do painel Components .
-
Bibliotecas armazenadas em uma pasta específica, incluindo subdiretórios se a opção estiver habilitada.
A pesquisa retornará todos os itens do tipo de pesquisa escolhido na lista suspensa Search in (Components/Footprints/3D Models/Database Components) encontrados em todas as bibliotecas abrangidas pelo Scope definido:
- Available libraries - habilite para pesquisar os tipos de modelo especificados apenas nas bibliotecas disponíveis.
-
Libraries on path - habilite para pesquisar os tipos de modelo especificados nas bibliotecas disponíveis em uma ou mais pastas específicas. Na região Path da caixa de diálogo, que fica disponível com a opção de escopo Libraries on path selecionada, você pode definir o caminho, incluir subdiretórios e incluir a máscara de arquivos de biblioteca para especificar e restringir os critérios de pesquisa:
- Path - edite para definir a pasta na qual as bibliotecas podem ser pesquisadas ou clique no ícone de navegação no final do campo para procurar uma pasta.
- Include Subdirectories - habilite se quiser pesquisar bibliotecas no caminho especificado e em seus subdiretórios.
-
File Mask - insira a string da máscara de arquivos ou escolha uma das máscaras de arquivos existentes na lista suspensa. A pesquisa é filtrada para incluir os arquivos que correspondem à string. Você pode usar o caractere curinga * (qualquer caractere) na string. Por exemplo, digite * para pesquisar todos os arquivos e digite M para pesquisar todos os arquivos que começam com a letra M.
Por exemplo, se quiser encontrar um componente que você acredita estar em uma biblioteca dentro de pastas específicas no disco rígido, e essa biblioteca não estiver listada no momento em Available File-based Libraries, defina a pesquisa da seguinte forma:
- Na região Scope, defina Search in como Components e selecione Libraries on path.
- Na região Path, defina Path para apontar para a pasta que contém o documento de biblioteca que você deseja pesquisar.
- Clique em Search. Os resultados são exibidos no painel Components à medida que a pesquisa é realizada.
Modo de pesquisa avançada
A pesquisa em bibliotecas é, na verdade, realizada por meio de consultas. Na caixa de diálogo File-based Libraries Search, alterne para o modo Advanced para examinar a consulta.
No modo Advanced da caixa de diálogo, você também pode criar suas próprias consultas usando as palavras-chave da linguagem de consulta para realizar uma pesquisa baseada em consultas. Consulte a seção abaixo para saber mais sobre as palavras-chave disponíveis na linguagem de consulta.
Use os seguintes controles adicionais quando o modo Advanced estiver selecionado:
-
Helper - clique para abrir a caixa de diálogo Assistente de consultas e criar facilmente uma consulta de pesquisa em bibliotecas com funções de biblioteca e funções de sistema predefinidas. Você também pode usar os botões History e Favorites para escolher uma consulta de biblioteca aplicada recentemente ou predefinida.
-
History - clique para abrir a caixa de diálogo Gerenciador de expressões e escolher uma das expressões de consulta aplicadas anteriormente para usar na pesquisa em bibliotecas. Você também pode usar o botão Favorites para usar uma consulta predefinida para uma pesquisa específica em bibliotecas.
-
Favorites - clique para abrir a caixa de diálogo Gerenciador de expressões e escolher uma de suas expressões de consulta favoritas para usar em uma pesquisa em bibliotecas. Você também pode alterar a lista Favorites removendo, renomeando ou copiando expressões da lista History.
Ao pesquisar entre Database Components, o modo Advanced permitirá realizar uma pesquisa por consulta SQL. Esse nível de pesquisa oferece uma busca refinada com base em uma expressão de consulta especificada, na qual você pode inserir uma consulta SQL diretamente na seção do editor de consultas da caixa de diálogo.
Clique em Advanced para acessar uma poderosa pesquisa baseada em consultas SQL. Clique em Advanced novamente para retornar à pesquisa simples.
Funções de consulta de componentes e bibliotecas

Funções de consulta de componentes e bibliotecas na caixa de diálogo Query Helper
Os editores de esquemáticos e de PCB do Altium Designer contam com um poderoso mecanismo de consulta. Ao inserir consultas nesse mecanismo, você pode delimitar logicamente e com precisão os objetos de que precisa.
Uma consulta é uma string que você insere usando palavras-chave e sintaxe específicas e que retorna os objetos desejados. Há muitas palavras-chave disponíveis, permitindo selecionar objetos por tipo, por propriedades ou por ambos.
As seções abaixo detalham as palavras-chave da linguagem de consulta disponíveis ao pesquisar componentes baseados em bancos de dados e em arquivos no Altium Designer. Para obter ajuda sobre uma palavra-chave de consulta específica, use as seções expansíveis a seguir ou selecione (ou clique dentro de) uma palavra-chave no Query Helper.
Componentes
Comentário
Resumo
Retorna todos os componentes cujo Comment atende à consulta.
Sintaxe
Comment : String
Exemplo de uso
Comment = 'Res1'
Retorna todos os componentes cujo Comment é Res1.
Comment = '100nF'
Retorna todos os componentes cujo Comment é 100nF.
Comment Like '*33*'
Retorna todos os componentes cujo Comment contém 33.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou localizadas em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Tipo de componente
Resumo
Retorna todos os componentes cuja propriedade Component Type atende à consulta.
Sintaxe
ComponentType = ComponentType_String
ComponentType_String deve ser uma das strings da lista a seguir:
- 'Graphical'
- 'Jumper'
- 'Mechanical'
- 'Net Tie'
- 'Net Tie (In BOM)'
- 'Standard'
- 'Standard (No BOM)'
Exemplo de uso
ComponentType = 'Graphical'
Retorna todos os componentes cujo Component Type é Graphical.
ComponentType = 'Standard'
Retorna todos os componentes cujo Component Type é Standard.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou presentes em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results, de volta ao painel Componentes.
-
Os caracteres de aspas simples (') no início e no final de
ComponentType_Stringsão obrigatórios.
Designador
Resumo
Retorna todos os componentes cuja propriedade Designator atende à consulta.
Sintaxe
Designator : String
Exemplos de uso
Designator = 'U2'
Retorna todos os componentes cuja propriedade Designator é U2.
Designator Like '*Channel*'
Retorna todos os componentes cuja propriedade Designator inclui Channel.
Designator <> 'C*'
Retorna todos os componentes except aqueles cuja propriedade Designator começa com C.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou presentes em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
HasModel
Resumo
Retorna cada componente vinculado a (ou que referencia) um modelo de domínio cujas propriedades atendem à consulta.
Sintaxe
HasModel(ModelType : String,ModelName : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
A string ModelType especifica a propriedade Type de um modelo vinculado e deve ser uma das strings da seguinte lista:
- 'PCB3DLIB' - use esta string para selecionar um modelo vinculado cuja propriedade Type seja PCB3D.
- 'PCBLIB' - use esta string para selecionar um modelo vinculado cuja propriedade Type seja Footprint.
- 'IBIS' - use esta string para selecionar um modelo vinculado cuja propriedade Type seja Ibis Model.
- 'SI' - use esta string para selecionar um modelo vinculado cuja propriedade Type seja Signal Integrity.
- 'SIM' - use esta string para selecionar um modelo vinculado cuja propriedade Type seja Simulation.
A string ModelName especifica a propriedade Name de um modelo vinculado.
O parâmetro CurrentModelOnly especifica se o modelo vinculado deve ou não ser um modelo atual de cada componente. Quando ele é False, o modelo vinculado não precisa ser um modelo atual (mas pode ser); quando ele é True, o modelo vinculado deve ser um modelo atual.
Exemplos de uso
HasModel('PCBLIB','SOIC14',False)
HasModel('PCBLIB','SOIC14',False) = True
HasModel('PCBLIB','SOIC14',False) = 'True'
Retorna todos os componentes vinculados a um modelo de footprint cuja propriedade Name é SOIC14; esse modelo não precisa ser o modelo de footprint atual de cada componente (mas pode ser).
HasModel('PCBLIB','DIP14',True)
HasModel('PCBLIB','DIP14',True) = True
HasModel('PCBLIB','DIP14',True) = 'True'
Retorna todos os componentes vinculados a um modelo de footprint cuja propriedade Name é DIP14; esse modelo deve ser o modelo de footprint atual do componente.
HasModel('SI','RES1',False)
HasModel('SI','RES1',False) = True
HasModel('SI','RES1',False) = 'True'
Retorna todos os componentes vinculados a um modelo de integridade de sinal cuja propriedade Name é RES1; esse modelo não precisa ser o modelo de integridade de sinal atual de cada componente (mas pode ser).
HasModel('SIM','RESISTOR',True)
HasModel('SIM','RESISTOR',True) = True
HasModel('SIM','RESISTOR',True) = 'True'
Retorna todos os componentes vinculados a um modelo de simulação cuja propriedade Name é RESISTOR; esse modelo deve ser o modelo de simulação atual do componente.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou presentes em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
HasModelParameter
Resumo
Retorna cada componente vinculado a (ou que referencia) um modelo de domínio que contém um objeto de parâmetro cujas propriedades Parameter Name e Value atendem à consulta.
Sintaxe
HasModelParameter(Parameter Name : String,Value : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
O parâmetro CurrentModelOnly especifica se o modelo vinculado (que contém um parâmetro que atende à consulta) deve ou não ser um modelo atual de cada componente. Quando ele é False, o modelo vinculado não precisa ser um modelo atual (mas pode ser); quando ele é True, o modelo vinculado deve ser um modelo atual.
Exemplos de uso
HasModelParameter('Inductance A','1mH',False)
HasModelParameter('Inductance A','1mH',False) = True
HasModelParameter('Inductance A','1mH',False) = 'True'
Retorna todos os componentes vinculados a um modelo que contém um objeto de parâmetro cuja propriedade Parameter Name é Inductance A e cuja propriedade Value é 1mH. Esse modelo não precisa ser um modelo atual de cada componente (mas pode ser).
HasModelParameter('Coupling Factor','0.999',True)
HasModelParameter('Coupling Factor','0.999',True) = True
HasModelParameter('Coupling Factor','0.999',True) = 'True'
Retorna todos os componentes vinculados a um modelo que contém um objeto de parâmetro cuja propriedade Parameter Name é Coupling Factor e cuja propriedade Value é 0.999. Esse modelo deve ser um modelo atual do componente.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou presentes em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
LibReference
Resumo
Retorna todos os componentes cuja propriedade Library Reference atende à consulta.
Sintaxe
LibReference : String
Exemplos de uso
LibReference = 'LM833'
Retorna todos os componentes cuja propriedade Library Reference é LM833.
LibReference Like 'C*'
Retorna todos os componentes cuja propriedade Library Reference começa com C.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou presentes em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Contagem de partes
Resumo
Retorna todos os componentes cuja propriedade Part Count atende à consulta.
Sintaxe
PartCount : Number
Exemplo de uso
PartCount = 2
Retorna todos os componentes cujo Part Count é 2.
PartCount > 4
Retorna todos os componentes cujo Part Count é maior que 4 (ou seja, todos os componentes com múltiplas partes que contêm mais de quatro subpartes).
Observações
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Contagem de pinos
Resumo
Retorna todos os componentes cuja propriedade Pin Count atende à consulta.
Sintaxe
PinCount : Number
Exemplo de uso
PinCount = 2
Retorna todos os componentes cujo Pin Count é 2.
PinCount > 14
Retorna todos os componentes cujo Pin Count é maior que 14.
Observações
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Todos
Descrição
Resumo
Retorna todos os componentes ou footprints cuja propriedade Description atende à consulta.
Sintaxe
Description : String
Exemplo de uso
Description = 'TTL-RS232 DRIVER'
Retorna todos os componentes ou footprints cuja propriedade Description é TTL-RS232 DRIVER.
Description Like '*RS485*'
Retorna todos os componentes ou footprints cuja propriedade Description inclui RS485.
Observações
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Possui parâmetro
Resumo
Retorna todos os componentes que contêm um objeto de parâmetro cujas propriedades Parameter Name e Value atendem à consulta.
Sintaxe
HasParameter(Parameter Name : String,Value : String) : Boolean/Boolean_String
Exemplo de uso
HasParameter('Comment','1K')
HasParameter('Comment','1K') = True
HasParameter('Comment','1K') = 'True'
Retorna todos os componentes que contêm um objeto de parâmetro cuja propriedade Parameter Name é Comment e cuja propriedade Value é 1K.
Observações
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Nome da biblioteca
Resumo
Retorna todos os componentes ou footprints cujo nome da biblioteca à qual pertencem atende à consulta.
Sintaxe
LibraryName : String
Exemplo de uso
LibraryName = 'Miscellaneous Devices.SchLib'
Retorna todos os componentes cuja biblioteca à qual pertencem é Miscellaneous Devices.SchLib.
LibraryName Like 'Miscellaneous*.IntLib'
Retorna todos os componentes ou footprints cujo nome da biblioteca à qual pertencem começa com Miscellaneous e termina com .IntLib.
LibraryName Like '*Vishay*'
Retorna todos os componentes cujo nome da biblioteca à qual pertencem contém Vishay.
Observações
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib, IntLib e DbLib — disponíveis ou em um caminho de pesquisa definido — serão consultadas. Ao pesquisar footprints, todas as bibliotecas PcbLib e IntLib serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Caminho da biblioteca
Resumo
Retorna todos os componentes ou footprints que estão na biblioteca especificada como parte da consulta.
Sintaxe
LibraryPath : String
Exemplo de uso
LibraryPath = 'C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Retorna todos os componentes que pertencem à biblioteca MyExampleLibrary.SchLib, sendo que essa biblioteca está localizada na pasta C:\Documents\Altium\Library.
LibraryPath Like ' C:\Documents\Altium\Library\Miscellaneous*.IntLib'
Retorna todos os componentes ou footprints cujo nome da biblioteca à qual pertencem começa com Miscellaneous e termina com .IntLib, sendo que essa biblioteca está localizada na pasta C:\Documents\Altium\Library.
LibraryPath = 'C:\Test Projects\Example DBLib\VishayCapacitor.DBLib'
Retorna todos os componentes que pertencem à biblioteca VishayCapacitor.DBLib, sendo que essa biblioteca está localizada na pasta C:\Test Projects\Example DBLib.
Observações
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib, IntLib e DbLib — disponíveis no caminho de biblioteca definido — serão consultadas. Ao pesquisar footprints, todas as bibliotecas PcbLib e IntLib serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Componentes.
Nome
Resumo
Retorna todos os componentes ou footprints cujo nome atende à consulta.
Sintaxe
Name : String
Exemplo de uso
Name = 'Res1'
Retorna todos os componentes ou footprints cujo nome é Res1.
Name Like 'DIP*'
Retorna todos os componentes ou footprints cujo nome começa com DIP.
Name Like '*33*'
Retorna todos os componentes ou footprints cujo nome contém 33.
Observações
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo Pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, todas as bibliotecas SchLib e IntLib — disponíveis ou em um caminho de pesquisa definido — serão consultadas. Ao pesquisar footprints, todas as bibliotecas PcbLib e IntLib serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results, de volta no painel Componentes.
-
O nome de um componente esquemático é verificado em relação à sua propriedade Design Item ID , e o nome de um footprint de PCB é verificado em relação à sua propriedade Footprint .
Nome da biblioteca de origem
Resumo
Retorna todos os componentes ou footprints cujo nome da biblioteca de origem à qual pertencem atende à consulta.
Sintaxe
SourceLibraryName : String
Exemplo de uso
SourceLibraryName = 'Miscellaneous Devices.SchLib'
Retorna todos os componentes cuja biblioteca de origem à qual pertencem é Miscellaneous Devices.SchLib.
SourceLibraryName = 'Miscellaneous Devices.PcbLib '
Retorna todos os footprints cuja biblioteca de origem é Miscellaneous Devices.PcbLib.
Notas
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo de pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, somente as bibliotecas de esquemáticos de origem — disponíveis ou em um caminho de pesquisa definido — serão consultadas. Somente as bibliotecas de PCB serão consultadas ao pesquisar footprints.
-
Todos os resultados são exibidos na listagem Query Results no painel Components.
Caminho da biblioteca de origem
Resumo
Retorna todos os componentes ou footprints presentes na biblioteca de origem especificada como parte da consulta.
Sintaxe
SourceLibraryPath : String
Exemplo de uso
SourceLibraryPath = ' C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Retorna todos os componentes cuja biblioteca de origem é MyExampleLibrary.SchLib e está localizada na pasta C:\Documents\Altium\Library.
SourceLibraryPath = ' C:\Documents\Altium\Library\Miscellaneous Devices.PcbLib'
Retorna todos os footprints cuja biblioteca de origem é Miscellaneous Devices.PcbLib e está localizada na pasta C:\Documents\Altium\Library.
SourceLibraryPath Like ' C:\Documents\Altium\Library\*'
Retorna todos os componentes ou footprints cuja biblioteca de origem está localizada na pasta C:\Documents\Altium\Library.
Notas
-
As entidades retornadas, componentes ou footprints, dependem do escopo escolhido, definido usando o campo Search in na caixa de diálogo de pesquisa em bibliotecas de arquivos.
-
Ao pesquisar componentes, somente as bibliotecas de esquemáticos — disponíveis no caminho de bibliotecas definido — serão consultadas. Somente as bibliotecas de PCB serão consultadas ao pesquisar footprints.
-
Todos os resultados são exibidos na listagem Query Results no painel Components.
Footprints
Altura
Resumo
Retorna todos os footprints cuja propriedade Height atende à consulta.
Sintaxe
Height : Number
Number seguirá as unidades de medida atualmente utilizadas na biblioteca — imperiais (mil; 1 mil = 0,001 polegada) ou métricas (mm; 1 mm = 0,001 metro).
Exemplo de uso
Height = 300
Retorna todos os footprints cuja propriedade Height é igual a 300 nas unidades de medida atuais.
Height >= 5.08
Retorna todos os footprints cuja propriedade Height é maior ou igual a 5.08 nas unidades de medida atuais.
Height <> 550
Retorna todos os footprints cuja propriedade Height é not igual a 550 nas unidades de medida atuais.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo de pesquisa em bibliotecas de arquivos.
-
Ao pesquisar footprints, todas as bibliotecas PcbLib e IntLib — disponíveis ou em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Components.
Contagem de pads
Resumo
Retorna todos os footprints cuja propriedade Pad Count atende à consulta.
Sintaxe
PadCount : Number
Exemplo de uso
PadCount = 2
Retorna todos os footprints cujo Pad Count é 2.
PadCount > 14
Retorna todos os footprints cujo Pad Count é maior que 14.
Notas
-
Certifique-se de que o escopo da pesquisa esteja definido como Components usando o campo Search in na caixa de diálogo de pesquisa em bibliotecas de arquivos.
-
Ao pesquisar footprints, todas as bibliotecas PcbLib e IntLib — disponíveis ou em um caminho de pesquisa definido — serão consultadas.
-
Todos os resultados são exibidos na listagem Query Results no painel Components.