Trabalhando com Modelos de Pad Via

Num relance

Este artigo explica como o Altium Designer utiliza modelos de pads e vias para melhorar a reutilização, a consistência e o gerenciamento em projetos de PCB. Você verá como os modelos locais são criados automaticamente em uma placa, como as bibliotecas externas de modelos de pads e vias são disponibilizadas e como o painel PCB Pad Via Templates funciona como o local central para visualizar, inserir, filtrar e gerenciar as definições desses modelos. O artigo também descreve como os modelos permanecem vinculados às bibliotecas de origem, como isso afeta a edição e em quais etapas do fluxo de trabalho de projeto eles podem ser aplicados. Continue lendo para entender como essas ferramentas podem ajudar você a trabalhar com mais eficiência e maior controle.

- Conheça a diferença entre os modelos locais de pads e vias e os modelos armazenados em bibliotecas externas de pads e vias, e saiba como cada um é utilizado em um projeto de PCB.
- Veja como usar o painel PCB Pad Via Templates para inserir modelos, consultar as bibliotecas disponíveis, filtrar listas de modelos e verificar quais já estão sendo utilizados na placa atual.
- Entenda como os nomes dos modelos são gerados, como os modelos vinculados a bibliotecas afetam as possibilidades de edição e onde os modelos podem ser aplicados nas regras de projeto e nos fluxos de trabalho de PCB.
Aprofunde-se com a IA:
 

Juntamente com os objetos de trilha, os pads e as vias são elementos fundamentais de todos os projetos de placas de circuito. Cada pad e via pode ser configurado como um objeto personalizado durante ou após o posicionamento.

Pad e via em 3D 
Pad e via em 3D

Para ampliar os recursos de reutilização e gerenciamento de pads e vias em projetos de PCB, o Altium Designer também oferece suporte à criação automatizada de modelos de pads e vias, bibliotecas de modelos de pads e vias e diversos painéis associados ao gerenciamento de pads e vias.

O conceito de modelos de pads e vias que podem ser reunidos em uma biblioteca é semelhante ao das bibliotecas de footprints de PCB, embora seja um pouco mais básico. A biblioteca de modelos de pads e vias não armazena pads e vias propriamente ditos, mas sim definições pré-configuradas que são aplicadas a uma instância de pad ou via durante seu posicionamento. As bibliotecas de modelos de pads e vias salvas podem ser carregadas e utilizadas para posicionar instâncias de pads e vias predefinidos em qualquer projeto de PCB ou footprint de PCB.

Para saber mais sobre a criação de bibliotecas de pads e vias, consulte a página Criação de modelos e bibliotecas de pads e vias.

Como mencionado, os modelos existentes podem ser salvos em bibliotecas de modelos de pads e vias, e novos modelos podem ser criados. Os modelos dessas bibliotecas são disponibilizados para uso por meio do painel PCB Pad Via Templates. Os modelos locais também são listados no painel, tornando-o o recurso central para trabalhar com bibliotecas de modelos de pads e vias.

O painel de modelos de pads e vias de PCB

O painel PCB Pad Via Templates é um painel especializado que lista tanto os modelos de pads/vias armazenados no documento de PCB atual (locais) quanto aqueles disponíveis em bibliotecas de pads e vias que foram instaladas ou incluídas no projeto atual (bibliotecas disponíveis).

Clique no botão no canto inferior direito da área de projeto e escolha PCB Pad Via Templates para abrir o painel.

O painel tem a dupla função de acessar modelos locais e modelos de bibliotecas.
O painel tem a dupla função de acessar modelos locais e modelos de bibliotecas.

Os dois conceitos de biblioteca apresentados no painel podem ser resumidos da seguinte forma:

  • Available Pad/Via Template Libraries – bibliotecas de pads e vias carregadas ou instaladas (coleções de modelos de pads/vias baseadas em arquivos). Esta região do painel lista os modelos contidos na biblioteca de pads e vias selecionada.
  • Local Pad & Via Library – o termo coletivo para os modelos de pads/vias utilizados no projeto atual da placa, incluindo os que foram obtidos ou adicionados a partir de uma biblioteca de pads e vias. Esta região do painel lista os modelos que se aplicam aos pads/vias do projeto atual da placa.

A biblioteca local de pads e vias

As entradas listadas na região inferior Local Pad & Via Library do painel representam as configurações de pads/vias (modelos) utilizadas e salvas no projeto atual da placa. Uma prévia do modelo selecionado é exibida na parte inferior da região.

Os modelos listados aqui são modelos de pads e vias salvos no arquivo de PCB e não estão contidos em uma “biblioteca” definida separadamente. Um modelo selecionado pode ser reutilizado na placa atual como uma nova instância de pad ou via, arrastando-o para o layout ou selecionando Place no menu de contexto do painel, acessado com o botão direito do mouse.

Posicionamento de uma instância de modelo local de pad.
Posicionamento de uma instância de modelo local de pad.

Bibliotecas de arquivos de modelos de pads e vias disponíveis

A região superior do painel, Available Pad/Via template Libraries, é utilizada para trabalhar com bibliotecas de arquivos de modelos de pads e vias.

Um modelo da biblioteca selecionada pode ser posicionado na PCB arrastando-o do painel ou utilizando o menu de contexto acessado com o botão direito do mouse. Como o pad/via está sendo posicionado a partir de uma biblioteca externa de arquivos de modelos, suas propriedades não ficam disponíveis para edição na PCB, como pode ser visto na imagem do painel Properties exibida abaixo, à direita. Para editar as propriedades de um pad/via baseado em biblioteca, é necessário desvincular seu modelo. Saiba mais na seção Desvinculação de um modelo de uma biblioteca.

Os modelos da biblioteca de pads e vias ativa, Preferred.PvLib neste exemplo. As propriedades de uma instância posicionada do pad selecionado são mostradas na segunda imagem. Observe que as propriedades físicas, como o formato do pad e o tamanho do furo, não podem ser editadas. 
Os modelos da biblioteca de pads e vias ativa, Preferred.PvLib neste exemplo. As propriedades de uma instância posicionada do pad selecionado são mostradas na segunda imagem. Observe que as propriedades físicas, como o formato do pad e o tamanho do furo, não podem ser editadas.

Quando um modelo de pad ou via baseado em arquivo é posicionado em um projeto de placa, ele permanece vinculado ao modelo da biblioteca de origem e ao nome dessa biblioteca. Como essa origem é um arquivo externo, as propriedades físicas do pad ou da via que utiliza esse modelo não podem ser editadas, protegendo a integridade do modelo de origem no arquivo de biblioteca externo. Para editar um modelo de pad ou via baseado em arquivo, ele pode ser desvinculado. Saiba mais na seção Desvinculação de um modelo de uma biblioteca.

A lista suspensa na parte superior do painel é utilizada para selecionar qual biblioteca disponível está ativa; na imagem abaixo, é a ExampleViaLib.PvLib. O botão  é utilizado para abrir a caixa de diálogo Available Libraries, na qual arquivos de bibliotecas de modelos podem ser adicionados e removidos. As bibliotecas disponíveis são abordadas abaixo. Utilize o campo Filter para exibir apenas os modelos cujo Name começa com essa sequência de caracteres.

Utilize o campo Filter para filtrar rapidamente a lista de modelos.
Utilize o campo Filter para filtrar rapidamente a lista de modelos.

Disponibilização de bibliotecas de modelos de pads e vias

O termo Available Libraries refere-se às bibliotecas de modelos de pads e vias cujos modelos estão disponíveis para uso no projeto atual da placa. Isso inclui as bibliotecas de modelos adicionadas ao projeto atual e também as bibliotecas de modelos instaladas no Altium Designer. Ambos os tipos podem ser consultados e gerenciados na caixa de diálogo Available Libraries; clique no botão  na parte superior do painel PCB Pad Via Templates para abrir a caixa de diálogo.

Instale uma biblioteca externa de pads e vias ou utilize a aba Project para adicionar uma biblioteca existente ao projeto atual.
Instale uma biblioteca externa de pads e vias ou utilize a aba Project para adicionar uma biblioteca existente ao projeto atual.

  • A aba Project da caixa de diálogo lista todos os arquivos PvLib incluídos no projeto e também possui botões para adicionar ou remover bibliotecas do projeto.
  • A aba Installed lista todas as bibliotecas de modelos de pads e vias atualmente disponíveis nesta instalação do Altium Designer e, portanto, disponíveis para todos os projetos de PCB. Observe que, com uma biblioteca instalada, você pode controlar se ela está disponível para uso habilitando ou desabilitando a opção Activated associada. Isso evita ter que remover e adicionar novamente as bibliotecas.

Utilização de um modelo no projeto

Os modelos listados no painel PCB Pad Via Templates podem ser utilizados no projeto atual da placa das seguintes maneiras:

  • Por posicionamento – posicione um pad ou uma via local ou de uma biblioteca de modelos diretamente a partir do painel.
  • Por seleção na lista suspensa Template – no painel Properties, quando pads ou vias estão selecionados. Utilize essa abordagem para alterar os pads ou vias selecionados para que utilizem um modelo diferente.
  • Como restrição de regra – um modelo de pad ou via pode ser selecionado como restrição na regra de projeto de estilo de via de roteamento (mostrada abaixo).
  • Como escopo de regra – as seguintes palavras-chave de consulta podem ser utilizadas ao definir o escopo de uma regra de projeto (por exemplo, a regra de projeto de estilo de ponto de teste):
  • Para costura/blindagem com vias – selecione o Via Template necessário na caixa de diálogo Adicionar costura à rede ou na caixa de diálogo Adicionar blindagem à rede.

Use modelos de vias na regra de projeto de estilo de via de roteamento ou ao adicionar costura com vias a uma rede.
Use modelos de vias na regra de projeto de estilo de via de roteamento ou ao adicionar costura com vias a uma rede.

O modelo de pad/via e como ele é nomeado

Para cada pad ou via exclusivo inserido em um projeto de placa, um modelo de pad/via é automaticamente criado, nomeado e armazenado no arquivo da placa. O modelo armazena a configuração básica do pad/via, incluindo tamanho, formato, tipo de padstack, informações de máscara de pasta/solda e furo, entre outras. A configuração é nomeada automaticamente de acordo com os padrões IPC (especificamente, as convenções de nomenclatura de padstacks IPC-7251/7351). Cada pad e via usado no projeto faz referência ao seu modelo, o que pode ser visto no painel Properties, conforme mostrado abaixo.

O sistema de nomenclatura IPC é baseado no sistema métrico, no qual uma unidade equivale a um centésimo de milímetro (10-5 metros, 10µm). Assim, por exemplo, o modelo de um pad circular de 1,5mm com um furo de 0,8mm é nomeado c150h80 – em que c indica circular (redondo) e h precede o tamanho do furo. Um pad chamado r155_125 é um pad retangular de montagem em superfície, com dimensões de 1,55mm x 1,25mm; e um pad chamado s160h100 é um pad quadrado com furo passante, de 1,6mm, com um furo de 1,0mm. Os nomes dos modelos de pads com formato personalizado recebem o prefixo u. Outras combinações de letras e números inteiros são adicionadas para as propriedades especificadas de máscara de pasta/solda.

Para observar esse comportamento, inspecione as propriedades de um pad ou via existente no painel Properties associado, clicando duas vezes no objeto ou selecionando-o e escolhendo Properties no menu de contexto exibido ao clicar com o botão direito.

O nome do modelo de pad ou via gerado automaticamente, mostrado no painel Properties.
O nome do modelo de pad ou via gerado automaticamente, mostrado no painel Properties.

Observe o nome Template atribuído na região Pad/Via Template do painel. De acordo com as diretrizes IPC, o nome é derivado das propriedades básicas do pad/via, como dimensões, formato, furo e configuração de máscara de pasta/solda. Se essas propriedades forem alteradas, o nome do modelo mudará para refletir a nova configuração. Como seria de esperar, a relação entre as propriedades de um pad ou via e o nome de seu modelo é menos evidente ao trabalhar com unidades imperiais em vez de métricas.

Localizando um pad ou via no espaço de projeto da PCB

Sempre que um pad ou via com dimensões exclusivas é inserido em um projeto de PCB usando o menu Place ou o Active Bar, um novo modelo de pad/via é criado automaticamente no arquivo da placa. Esses modelos são chamados de modelos <Local>. Para a PCB atual, a lista de todos os modelos de pads e vias usados pode ser examinada no painel PCB quando ele está definido para o modo Modelos de pads e vias.

O painel PCB no modo Pad &amp; Via Templates
O painel PCB no modo Pad & Via Templates

O modo Pad & Via Templates oferece controle avançado dos modelos de pads e vias usados no documento de PCB atual. Esse modo do painel é dividido em três seções:

  • Library Name
  • Templates
  • Pads/Vias

Nome da biblioteca

Esta lista mostra as instâncias dos modelos de pads e vias no projeto como uma coleção de bibliotecas virtuais e físicas. Elas filtram os modelos incluídos na lista da seção inferior do painel e são organizadas da seguinte forma:

  • All – mostra todos os modelos de pads e vias, incluindo os usados a partir de bibliotecas de pads e vias.
  • Pads – mostra todos os pads, tanto locais quanto provenientes de bibliotecas.
  • Vias – mostra todas as vias, tanto locais quanto provenientes de bibliotecas.
  • Local – mostra todos os modelos de pads e vias aplicados à placa, mas não aqueles adicionados a partir de bibliotecas de pads e vias.
  • Pad & Via Libraries – mostra apenas os modelos de pads e vias que foram aplicados a partir da biblioteca de pads e vias selecionada.

Modelos

Esta região fornece uma lista de todos os modelos de pads/vias usados no projeto de PCB atual. Suas colunas incluem a origem Library Name do modelo (local ou nome da biblioteca de pads e vias) e o número de instâncias de pads/vias para cada modelo (Count).

Quando a seção Library Name do painel está definida para uma biblioteca de pads e vias específica, a seção Template pode mostrar entradas com um Count de zero instâncias. Isso indica que o modelo não está sendo usado por nenhum pad/via no layout da placa, mas é usado no projeto – por exemplo, ele pode ser usado como uma configuração padrão de pad/via ou para definir a restrição de uma regra de projeto, como a de estilo de via de roteamento.

Qualquer quantidade dos modelos listados pode ser salva em uma biblioteca de pads e vias separada. Para isso, selecione vários modelos usando as técnicas padrão de Shift+Click e Ctrl+Click e clique no botão Save as Library. A biblioteca será adicionada automaticamente ao projeto e poderá ser salva com o nome de arquivo *.PvLib desejado usando File » Save As no painel Projetos. Para saber mais sobre como criar uma biblioteca de modelos de pads e vias, consulte a página Criando e editando uma biblioteca de modelos de pads e vias.

A seção Templates também permite inserir no projeto de PCB um modelo proveniente de uma biblioteca de pads e vias usando o botão Place. Selecione a biblioteca de pads e vias desejada na seção superior Library Name do painel para habilitar esse recurso.

O botão Place pode ser usado para inserir o modelo de pad/via selecionado se esse modelo estiver em uma biblioteca de modelos de pads e vias. Para inserir um pad/via local, use o painel PCB Pad Via Templates, conforme descrito abaixo.

Pads/Vias

Esta região do painel é preenchida com as instâncias individuais de pads/vias do modelo selecionado na seção Templates acima.

À medida que cada instância de pad/via é selecionada, o objeto é destacado graficamente no espaço de projeto, conforme definido pelas opções padrão de destaque, zoom e seleção do painel, localizadas na parte superior do painel PCB. Os pads ou vias selecionados podem então ser editados para usar um modelo diferente no painel Properties; escolha o modelo desejado na lista suspensa Template.

Cada instância listada nesta região é acompanhada por uma caixa indicadora Changed que é marcada quando um modelo vinculado à biblioteca de origem difere daquele usado no pad ou via local, ou seja, quando a biblioteca de pads e vias de origem foi atualizada. O indicador Changed também será marcado se o tipo de padstack do pad/via local for alterado; por exemplo, se uma instância de pad for alterada localmente de multicamada para camada única.

Em todos os casos, a versão local do pad ou via pode ser atualizada (ou revertida) para o modelo atual na biblioteca de pads e vias de origem usando o botão do painel Modelos de pads e vias da PCB Update.

Tarefas de edição e gerenciamento de modelos de pads e vias

Esta seção aborda os diversos cenários em que é necessário editar modelos de pads ou vias.

Aplicar um modelo diferente a pads/vias existentes

Em algumas situações, você pode querer aplicar um modelo diferente a pads ou vias existentes (por exemplo, para reduzir o número de vias diferentes usadas em um projeto). Nesse caso, use o modo Pad & Via Templates do painel PCB para localizar e selecionar os pads/vias que deseja alterar. Os pads ou vias selecionados podem então ser editados para usar um modelo diferente no painel Properties, selecionando o modelo desejado na lista suspensa Template.

Aplicação de um modelo diferente.
Aplicação de um modelo diferente.

Desvincular um modelo de uma biblioteca

Não é possível editar as propriedades de pads/vias que usam um modelo de uma biblioteca de modelos baseada em arquivos, pois isso faria com que a instância local deixasse de corresponder ao modelo da biblioteca referenciada. Para editar um pad ou via que referencia um modelo de biblioteca, é necessário desvincular o modelo.

Clique no botão Linked button, click to copy the template from the file library to the local library and reference the local template para desvincular um modelo. Ao clicar nesse botão, uma cópia do modelo é criada na biblioteca local, e as instâncias selecionadas do pad/via passam a referenciar o modelo local. Observe que, se o botão Linked button, click to copy the template from the file library to the local library and reference the local template estiver desativado, isso indica que o modelo já é local.

Clique para desvincular o modelo da biblioteca baseada em arquivos. O modelo é copiado para a biblioteca local, e essa cópia passa a ser utilizada.
Clique para desvincular o modelo da biblioteca baseada em arquivos. O modelo é copiado para a biblioteca local, e essa cópia passa a ser utilizada.

Se o pad/via desvinculado tiver um nome personalizado definido na biblioteca de modelos de pads e vias, esse nome será removido e a convenção de nomenclatura padrão IPC será aplicada ao modelo local.

Adicionar um modelo de biblioteca à biblioteca local

Se necessário, um modelo de biblioteca pode ser adicionado à biblioteca local. Isso pode ser feito clicando com o botão direito no nome do modelo e selecionando Add to Internal Library no menu de contexto, ou arrastando o modelo da região Pad/Via Library do painel e soltando-o em uma área vazia da região Local Pad & Via Library.

Adicione um modelo de pad/via à biblioteca local usando o menu do botão direito ou a ação de arrastar e soltar.
Adicione um modelo de pad/via à biblioteca local usando o menu do botão direito ou a ação de arrastar e soltar.

Modelos de biblioteca de pads/vias não utilizados podem ser removidos da biblioteca local clicando no botão Removed Unused Pad/Via.

Isso equivale a inserir um pad/via proveniente de um modelo da biblioteca de pads e vias e depois excluí-lo da placa, registrando esse modelo como disponível localmente. Para replace um modelo local, em vez de adicionar um à lista local, consulte Substituir um modelo local abaixo.

Atualizar a partir da biblioteca de pads e vias

Se um modelo de pad/via tiver sido atualizado na biblioteca e já tiver sido usado em um projeto de placa, clique no botão Update no painel PCB Pad Via Templates para atualizar o modelo de pad/via no projeto. A atualização será refletida automaticamente em todas as instâncias de pads/vias que usam esse modelo na placa.

Um pad/via que usa um modelo atualizado na biblioteca pode ser atualizado no projeto de PCB usando o botão Update no painel PCB Pad Via Templates.
Um pad/via que usa um modelo atualizado na biblioteca pode ser atualizado no projeto de PCB usando o botão Update no painel PCB Pad Via Templates.

Quando uma atualização é iniciada, a caixa de diálogo Update Pads/Vias on Board é aberta, listando os detalhes das alterações detectadas que serão aplicadas.

Modelos de pads/vias que apresentem diferenças em relação à versão da biblioteca de origem podem ser atualizados da biblioteca para o projeto de PCB.
Modelos de pads/vias que apresentem diferenças em relação à versão da biblioteca de origem podem ser atualizados da biblioteca para o projeto de PCB.

A caixa de diálogo oferece três opções para controlar o processo de atualização:

  • Update locked objects – força a atualização do modelo de um objeto pad/via, independentemente de seu estado de bloqueio.
  • Update free objects – atualiza apenas os modelos de pads/vias aplicáveis a pads e vias livres.
  • Update component objects – atualiza apenas os modelos de pads/vias aplicáveis aos pads e vias usados em componentes.

Esse comportamento de sincronização é definido pela propriedade Library dos pads e vias, exibida no painel Properties ao visualizar as propriedades de um pad ou via selecionado, respectivamente. A existência de diferenças entre a versão local do modelo e o modelo de origem é indicada na coluna Changed da região Pads/Vias no modo Pad & Via Templates do painel PCB.

Mesmo que o nome do modelo tenha sido alterado na biblioteca de pads e vias de origem, o vínculo com o pad/via ao qual ele foi aplicado no projeto de PCB é mantido pela referência GUID do modelo, armazenada nos dados do projeto da placa.

A região inferior da caixa de diálogo lista os pads/vias a serem atualizados. As informações de cada um incluem Type, Description, Library, Template e Action. Além disso, você pode optar por marcar cada pad/via como Locked e/ou In Component. Quando ativadas, essas opções sujeitam o objeto aos controles da região superior da caixa de diálogo.

Substituir um modelo local

Um modelo de pad/via baseado em biblioteca também pode replace um modelo local, atualizando os pads ou vias da placa que usam esse modelo local.

Para isso, arraste o modelo de biblioteca desejado da região Pad/Via Library do painel para a região Local Pad & Via Library do painel, mas, nesse caso, solte o modelo de biblioteca on top of a entrada do modelo local existente. Todas as instâncias de pads/vias livres ou de componentes que usam o modelo serão atualizadas para o estilo do novo modelo de biblioteca.

Na animação abaixo, observe que os pads dos componentes C1 e C2 mudam fisicamente para o tipo definido pelo modelo de biblioteca que foi “solto” — de r110_100 para s120.

Solte um modelo de biblioteca sobre uma entrada de modelo local para substituí-lo em todas as instâncias do projeto.
Solte um modelo de biblioteca sobre uma entrada de modelo local para substituí-lo em todas as instâncias do projeto.

Remover pads/vias não utilizados

Como os nomes dos modelos listados na biblioteca local são derivados dos pads e vias no layout de PCB atual, se todas as instâncias de uma determinada configuração local de pad/via forem excluídas da placa, o modelo correspondente será removido da lista local.

No entanto, se um pad ou via inserido tiver sido obtido de uma biblioteca de pads e vias, seu modelo será mantido na lista local quando todas as instâncias desse pad/via forem removidas da placa. Instâncias de modelos da biblioteca de pads e vias que não sejam mais necessárias podem ser removidas do registro da “base de dados” local com o botão Remove Unused Pad/Via. A caixa de diálogo Update Templates from Library será aberta, permitindo escolher quais modelos de pads e vias serão removidos da biblioteca local de pads e vias. Use o botão Templates  ou o menu do botão direito para selecionar/desmarcar todos os modelos da lista ou inverter a seleção.

A caixa de diálogo Update Templates from Library
A caixa de diálogo Update Templates from Library

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents