Definindo o Diagrama de Fiação

As conexões individuais com fios dentro do chicote são especificadas no diagrama de fiação do chicote (*.WirDoc). Adicione este documento ao projeto do chicote no painel Projects, clicando com o botão direito na entrada do projeto e, em seguida, selecionando Add New to Project » Harness Wiring Diagram no menu de contexto (ou use o comando File » New » Harness Wiring Diagram nos menus principais).

Configurando um Documento de Diagrama de Fiação de Chicote

As opções de um documento de diagrama de fiação de chicote podem ser configuradas no painel Properties quando nenhum objeto estiver selecionado na área de projeto do documento. As principais configurações são:

  • Na região General da guia General do painel – selecione as unidades de medida aplicáveis ao documento e aos seus elementos gráficos e defina as grades para facilitar o posicionamento. O Altium Designer oferece três tipos de grade: grade visível para navegação, grade de snap para posicionamento e distância de snap para auxiliar na criação de conexões.

  • Na região Page Options da guia General do painel – configure o tamanho da folha do documento e o bloco de título ou selecione entre os modelos disponíveis de diagrama de fiação de chicote.

As guias General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de diagrama de fiação de chicote 
As guias General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de diagrama de fiação de chicote

  • Configurar um documento de diagrama de fiação de chicote é semelhante a configurar um documento esquemático (*.SchDoc) de um projeto de design de PCB. Consulte a página Setting Up a Schematic Document para saber mais.

  • Use a lista suspensa Length Units para escolher as unidades de comprimento do documento. Os valores Strip Length e Pull Off Length das cavidades do soquete serão exibidos usando as unidades selecionadas. As unidades compatíveis são mm, cm, m, in e ft. As unidades de comprimento padrão de documentos de diagrama de fiação recém-criados podem ser definidas na página Harness Design – General page da caixa de diálogo Preferences.

  • Para saber mais sobre a criação de modelos de documentos de fiação de chicote, consulte a página Creating Harness Template Documents.

  • As propriedades padrão dos objetos de diagrama de fiação de chicote podem ser configuradas na página Harness Design – Defaults page da caixa de diálogo Preferences. Essas propriedades serão aplicadas ao posicionar objetos subsequentes.

  • Ao criar um documento de diagrama de fiação de chicote, você também pode usar objetos de texto e desenho. Trabalhar com esses objetos em um documento de diagrama de fiação de chicote é semelhante a trabalhar com eles em um documento esquemático (*.SchDoc) de um projeto de design de PCB. Consulte Working with Text Objects on a SchematicWorking with Drawing Objects on a Schematic para saber mais sobre esses objetos.

    • Observe que links ativos para objetos do diagrama de fiação de chicote (por exemplo, fios e componentes) e objetos do desenho de layout do chicote (por exemplo, feixes e pontos de conexão) também são compatíveis em quadros de texto e notas. Clique em um link no quadro de texto ou nota colocados para fazer cross-probe até esse objeto no documento associado.

  • Para verificar seu diagrama de fiação de chicote quanto a violações lógicas, elétricas e de desenho, há suporte para várias verificações de violação. Consulte a página Validating the Harness Design para saber mais.

  • Um documento de diagrama de fiação de chicote pode ser salvo em formato ASCII, o que pode ser vantajoso para compartilhamento. Use o comando File » Save As e selecione Harness Wiring ascii (*.WirDoc) na lista suspensa Save as type na caixa de diálogo Save As que se abre. Ao salvar um diagrama de fiação ASCII usando o comando File » Save, a caixa de diálogo File Format será aberta, alertando que o formato ASCII está sendo usado. Escolha a versão ASCII na caixa de diálogo para continuar usando esse formato.

Sincronizando Projetos Multi-board e de Chicote

 
 
 
 
 

Quando o projeto de chicote faz parte de um projeto de design multi-board, o diagrama de fiação do chicote pode ser sincronizado a partir dos dados do documento esquemático multi-board (*.MbsDoc). Para fazer isso, selecione o comando Design » Import Changes From <Multi-board Project> nos menus principais.

Para saber mais sobre como adicionar um projeto de design de chicote a um projeto multi-board, consulte a página Harness Design.

Se o documento esquemático multi-board contiver mais de uma definição de conexão de chicote, a caixa de diálogo Select Harness Definition será aberta. Especifique a definição que se relaciona ao projeto de chicote atual.

A caixa de diálogo Select Harness Definition
A caixa de diálogo Select Harness Definition

A caixa de diálogo Engineering Change Order será então aberta mostrando os componentes de conectores do chicote e as redes do chicote que foram definidos no esquemático multi-board, que formarão a base para o diagrama de fiação do chicote.

Use a caixa de diálogo Engineering Change Order para importar dados do projeto multi-board. 
Use a caixa de diálogo Engineering Change Order para importar dados do projeto multi-board. 

Após executar as alterações (), os dados do documento esquemático multi-board são importados para o diagrama de fiação do chicote. Os componentes de conectores, cada um representado por seu símbolo esquemático, aparecerão no documento de diagrama de fiação do chicote, inicialmente em posições arbitrárias.

Um exemplo de um diagrama de fiação de chicote logo após a importação.
Um exemplo de um diagrama de fiação de chicote logo após a importação.

Linhas de rede serão mostradas entre os pinos para representar as conexões lógicas definidas no esquemático multi-board. Observe que, neste estágio, não há fios físicos no design.

Observe que os dados de conectividade importados do projeto multi-board para o projeto de chicote dependem dos nomes dos pinos dos componentes de conectores, portanto, certifique-se de que nomes exclusivos e corretos sejam atribuídos aos pinos dos componentes na biblioteca de origem antes da importação dos dados.

Trabalhando com Componentes

Além de sincronizar a partir do documento esquemático multi-board, os componentes também podem ser colocados manualmente no diagrama de fiação do chicote. Isso permite que componentes sejam colocados em um projeto de chicote independente (isto é, que não faz parte de um projeto multi-board), mas também permite que componentes adicionais sejam colocados em um diagrama de fiação de chicote que faz parte de um projeto multi-board.

Use o painel Components para posicionar os símbolos dos componentes necessários. O processo de posicionamento de componentes é semelhante ao do editor Schematic – consulte a página Searching for & Placing Components para saber mais. Observe que não haverá linhas de rede para componentes adicionados manualmente, pois não há um design lógico de nível superior para guiá-los.

  • Os componentes são posicionados a partir das bibliotecas disponíveis e representados por seus modelos de símbolos esquemáticos em um diagrama de fiação de chicote. Consulte Building & Maintaining Your Components and Libraries para saber mais sobre a criação de componentes.

  • Componentes com múltiplas partes também podem ser posicionados em um diagrama de fiação de chicote. Quando os dados do design são importados para o desenho de layout do chicote, os designadores são atribuídos corretamente aos componentes no desenho de layout do chicote. Se várias partes do mesmo componente forem posicionadas no diagrama de fiação do chicote, apenas uma instância do componente será posicionada no desenho de layout do chicote ().

  • Conectores de chicote podem ser usados para fazer conexões entre vários projetos multi-board que estão em uma configuração aninhada.

  • Ao colar componentes de chicote recortados/copied em um diagrama de fiação de chicote, os designadores dos componentes colados respeitam a opção Reset Parts Designators On Paste da página Schematic – Graphical Editing page da caixa de diálogo Preferences. Quando os componentes são colados, a parte numérica de seus designadores será redefinida para ? quando a opção estiver habilitada.

Para mover um componente posicionado (ou um componente sendo posicionado a partir do painel Components) para a posição desejada, clique e mantenha pressionado o botão esquerdo do mouse sobre ele e mova o mouse. Durante o arraste, use Spacebar para rotacionar os componentes em 90 graus e as teclas X e Y para espelhá-los horizontal e verticalmente, respectivamente.

O diagrama de fiação do chicote após mover os componentes
O diagrama de fiação do chicote após mover os componentes

As propriedades de um componente posicionado podem ser configuradas no painel Properties quando o componente estiver selecionado na área de projeto. O painel Properties de um componente inclui as seguintes guias:

 
 
 
 
 
  • General – propriedades gerais do componente, como designador e comentário, localização, parâmetros etc.

  • Pins – a lista de pinos do componente.

  • Cavities – permite atribuir cavidades de soquete ao componente (saiba mais).

  • Associated Parts – permite atribuir peças adicionais, como tubo termoencolhível, ao componente.

Guias do painel Properties quando um componente está selecionado
Guias do painel Properties quando um componente está selecionado

Atribuindo Cavidades de Soquete

 
 
 
 
 

Cavidades de soquete e seus tipos podem ser atribuídos a um componente de chicote. Selecione um componente na área de projeto para adicionar uma cavidade e um tipo. Selecione um pino na guia Cavities do painel Properties , depois clique no botão . Selecione o tipo desejado na lista suspensa. Os seguintes tipos de cavidade são compatíveis:

  • Crimp – usado para fornecer uma conexão elétrica comprimindo um barril de contato ao redor de um condutor.

  • Seal – usado para fornecer proteção ambiental vedando o ponto de entrada do fio.

  • Plug – usado para preencher uma cavidade aberta (não usada) do conector para manter a integridade da vedação ambiental.

  • Other – usado para especificar outras/peças adicionais ou materiais, por exemplo, solda.

Para o tipo de cavidade Crimp ou linhas sem tipo de cavidade adicionado, você pode especificar os seguintes valores:

  • Strip Length – o comprimento no qual a isolação é cortada do condutor.

  • Pull Off Length – o comprimento no qual a isolação cortada é puxada do condutor. Isso pode ser usado em casos em que a extremidade do fio não está completamente decapada e o pedaço de isolação removido é mantido no fio para evitar danos ao filamento.

As unidades nas quais esses valores são mostrados no painel Properties quando um componente está selecionado são especificadas usando a lista suspensa Length Units na guia General do painel Properties quando nenhum objeto está selecionado no documento.

Na caixa de diálogo Select Connector que se abre, procure e selecione o componente desejado. O tipo específico e as informações pertinentes serão adicionados ao pino na guia, como mostrado nas imagens abaixo, para adicionar um crimp ao pino 1.

Observe que os pinos são apresentados na tabela da guia Cavities por seus nomes (a coluna Pins) e a atribuição de cavidade depende dos nomes dos pinos, portanto, certifique-se de que nomes exclusivos e corretos sejam atribuídos aos pinos do componente.

Para um crimp, vedação ou plugue, apenas uma cavidade de um tipo específico pode ser adicionada a um pino. Depois que uma cavidade de um tipo específico for adicionada, a entrada ficará indisponível (acinzentada) na lista suspensa. Qualquer número de cavidades do tipo Other pode ser adicionado a um pino.

Pinos com crimps atribuídos são indicados pelo símbolo  no espaço de projeto, como mostrado na imagem abaixo.

A região de grade da guia Cavities oferece suporte a multisseleção e operações de copiar/colar/excluir para entradas selecionadas.

  • Várias entradas de pino podem ser selecionadas usando os atalhos Click, Hold&DragCtrl+ClickShift+ClickCtrl+A.

  • Quando várias entradas de pino estão selecionadas, clique em   para adicionar uma cavidade a todos os pinos selecionados ou clique em  ou pressione Delete para remover cavidades adicionadas dos pinos selecionados. 

  • Para alterar a cavidade de um pino, selecione sua entrada e clique em  para abrir a caixa de diálogo Select Connector para selecionar a nova cavidade.

  • Selecione uma ou mais entradas de pino e use os atalhos Ctrl+X/Ctrl+C para recortar/copiar as entradas selecionadas, depois use o atalho Ctrl+V para colar o conteúdo recortado/copiado na entrada atualmente selecionada.

Criando conectividade no diagrama de fiação do chicote

Os fios físicos são colocados no documento do diagrama de fiação do chicote selecionando o comando Place » Harness Wire nos menus principais (atalho: Shift+W).

Após selecionar o comando, clique em um pino de um conector (uma cruz vermelha aparece no cursor quando ele está sobre o hotspot de um pino) para posicionar o ponto inicial do fio do chicote. Posicione o cursor e clique para ancorar uma série de pontos de vértice que definem a forma do fio do chicote. Após posicionar o ponto de vértice final no hotspot de outro pino, clique com o botão direito para concluir o posicionamento.

Ao posicionar um fio do chicote, pressione Shift+Spacebar para alternar entre os modos de posicionamento. O modo especifica como os cantos são criados ao posicionar fios e os ângulos em que os fios podem ser colocados. Enquanto estiver no modo 90 Degree ou 45 Degree (modos verdadeiramente ortogonais), pressione Spacebar para alternar entre os submodos inicial e final. O modo e o submodo atuais são mostrados na Barra de Status.

Ao posicionar um fio do chicote, as netlines acompanham/atualizam-se “ao vivo”, mostrando onde fazer a fiação em tempo real, como demonstrado no vídeo abaixo. Quando uma conexão é concluída, sua netline desaparece do documento.

Demonstração do recurso de rastreamento ao vivo

Quando colocado e selecionado, os vértices de um fio do chicote podem ser arrastados para alterar o ângulo entre duas seções adjacentes (Mostrar exemplo).

Selecione um fio do chicote no espaço de projeto para alterá-lo no painel Properties. No painel, você pode renomear o fio do chicote selecionado, alterar sua largura e cor, e adicionar parâmetros que podem ser mostrados ou ocultados no espaço de projeto.

O painel Properties quando um fio do chicote está selecionado
O painel Properties quando um fio do chicote está selecionado

  • Um fio do chicote já colocado pode ser substituído por um componente de fiação de chicote que inclua um único fio. Para fazer isso, selecione o fio do chicote a ser substituído e clique no botão  à direita do campo Design Item ID no painel Properties. Na caixa de diálogo Replace Component que será aberta, procure e selecione o componente necessário. O fio colocado será atualizado com as propriedades e os parâmetros do componente escolhido, mantendo sua geometria inalterada. Consulte a seção Placing a Harness Wiring Component para saber mais.

  • A cor primária de um fio é definida pelo parâmetro Color, que é apresentado em um fio de chicote inserido por padrão. Para editar a cor, insira seu nome (por exemplo, Red) ou código hexadecimal (digitando o caractere # seguido pelo número hexadecimal, por exemplo, #9900FF) como valor do parâmetro. Como alternativa, clique no botão de cor à esquerda do valor do parâmetro e use o seletor de cores que será aberto, no qual a cor do fio pode ser especificada por valor RGB ou HEX, por seleção livre ou a partir de uma variedade de predefinições.

  • Fios de chicote multicoloridos são suportados no diagrama de fiação do chicote por meio da escolha das cores secundária e terciária de um fio. No painel Properties, clique na lista suspensa   na parte inferior da região Parameters e então escolha Secondary e Tertiary para definir as cores desejadas; o parâmetro da cor escolhida aparecerá na região Parameters . Você também pode definir a cor da borda do fio do chicote usando a mesma lista suspensa e selecionando Border. Observe que o parâmetro Color controla a visibilidade do valor combinado dos parâmetros definidos do fio Color, Secondary Color e Tertiary Color. Clique na apresentação de slides abaixo para ver exemplos.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Um fio com apenas a cor primária definida

    Um fio com a cor secundária definida

    Um fio com a cor terciária definida

    Um fio com a cor da borda definida

    Um fio com todas as opções de cor definidas

    Fios multicoloridos são suportados por tabelas em documentos de desenho de fabricação de projetos de chicote (*.HarDwf) – saiba mais.

  • Se um fio do chicote tiver o valor No para seu parâmetro Include Cut, esse fio não será apresentado em uma lista de fiação e na tabela de conexões no desenho de fabricação.

  • Os parâmetros Color, Min. Bending Radius, Thickness e Units de um fio do chicote são usados ao sincronizar um projeto de chicote com uma ferramenta MCAD usando MCAD CoDesigner. Consulte a página Synchronizing a Harness Design Project para saber mais.

Adicionando emendas e derivações

Em situações de projeto em que um novo fio precisa ser conectado a um fio já colocado, um objeto de emenda (Place » Splice) ou derivação (Place » Tap) deve ser colocado primeiro.

  • Splice – o fio original é dividido em dois fios separados pela emenda.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Outro fio precisa ser conectado ao fio selecionado (W4).

    Uma emenda colocada no fio. Observe que a emenda divide o fio original em dois no local da emenda.

    Outro fio foi conectado à emenda.

    Quando dois fios são conectados em forma de T, uma emenda é colocada automaticamente no local da junção em T (Mostrar exemplo).

  • Tap – o fio original permanece intacto.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Outro fio precisa ser conectado ao fio selecionado (W4).

    Uma derivação colocada no fio. Observe que a derivação não divide o fio original.

    Outro fio foi conectado à derivação.

As propriedades de uma emenda ou derivação já colocada (sua localização e representação visual) podem ser configuradas no painel Properties quando o objeto estiver selecionado no espaço de projeto.

O painel Properties quando uma emenda/derivação está selecionada
O painel Properties quando uma emenda/derivação está selecionada

A região Associated Parts do painel Properties permite que componentes sejam atribuídos à emenda/derivação selecionada, e esse componente será refletido na BOM do projeto.

Adicionando cabos

Para definir um ou mais fios como adicionados a um cabo, você pode colocar um objeto de cabo no diagrama de fiação do chicote (Place » Harness Cable).

Coloque um cabo para definir um ou mais fios como adicionados a um cabo.
Coloque um cabo para definir um ou mais fios como adicionados a um cabo.

Quando um objeto de cabo é selecionado, os fios cobertos por esse cabo são destacados em verde neon no espaço de projeto ().

As propriedades de um objeto de cabo já colocado (sua localização, representação visual e parâmetros) podem ser configuradas no painel Properties quando o objeto estiver selecionado no espaço de projeto.

 
 
 
 
 

O painel Properties quando um cabo está selecionado
O painel Properties quando um cabo está selecionado

Um cabo tem uma proporção fixa de 2:1 durante o posicionamento ou a edição gráfica, sendo o tamanho final de posicionamento determinado pelo valor atual da grade de snap do documento.

  • Se um cabo estiver associado a fios em vários locais no diagrama de fiação do chicote (ou seja, quando vários objetos de cabo com o mesmo designador forem colocados em diferentes fios), selecionar um objeto destacará todos os fios associados no grupo, e todos esses fios serão listados na região Cable Objects do painel Properties ().

  • Os parâmetros Color, Min. Bending Radius, Thickness e Units de um cabo são usados ao sincronizar um projeto de chicote com uma ferramenta MCAD usando MCAD CoDesigner. Consulte a página Synchronizing a Harness Design Project para saber mais.

Blindagem e torção de fios

Uma blindagem (com ou sem uma conexão, como uma conexão de fio dreno) pode ser anexada a um grupo de fios colocando um objeto de blindagem (Place » Shield) ou um objeto de blindagem com conexão (Place » Shield with Connection).

No exemplo mostrado abaixo, os fios W1, W2 e W3 são blindados por uma blindagem sem conexão (SH1), e os fios W4, W8 e W9 são blindados por uma blindagem com conexão (SH2). O fio W10 é colocado para conectar SH2 a um pino de componente.

Coloque um objeto de blindagem ou blindagem com conexão para indicar fios como blindados.
Coloque um objeto de blindagem ou blindagem com conexão para indicar fios como blindados.

Quando um objeto de blindagem ou blindagem com conexão é selecionado, os fios cobertos são destacados em verde neon no espaço de projeto ().

As propriedades de um objeto de blindagem ou blindagem com conexão já colocado (localização e representação visual) podem ser configuradas no painel Properties quando o objeto estiver selecionado no espaço de projeto. A região Shield Objects do painel lista os fios cobertos pelo objeto selecionado.

 
 
 
 
 

O painel Properties quando uma blindagem está selecionada
O painel Properties quando uma blindagem está selecionada

  • Uma blindagem tem uma proporção fixa de 2:1 durante o posicionamento ou a edição gráfica, sendo o tamanho final de posicionamento determinado pelo valor atual da grade de snap do documento. 

  • Se uma blindagem estiver associada a fios em vários locais no diagrama de fiação do chicote (ou seja, quando vários objetos de blindagem com o mesmo designador forem colocados em diferentes fios), selecionar um objeto destacará todos os fios associados no grupo, e todos esses fios serão listados na região Shield Objects do painel Properties ().

Os fios podem ser indicados como torcidos entre si colocando uma torção (Place » Twist). Uma torção pode ser colocada em dois ou mais fios.

No exemplo abaixo, os fios W1 e W2 são indicados como torcidos entre si com a torção Tw1.

Coloque um objeto de torção para indicar fios como torcidos entre si.
Coloque um objeto de torção para indicar fios como torcidos entre si.

Quando uma torção é selecionada, os fios cobertos são destacados em verde neon no espaço de projeto ().

As propriedades de uma torção já colocada (sua localização e representação visual) podem ser configuradas no painel Properties quando o objeto estiver selecionado no espaço de projeto. A região Twist Objects do painel lista os fios cobertos pela torção selecionada.

 
 
 
 
 

O painel Properties quando uma torção está selecionada
O painel Properties quando uma torção está selecionada

  • Uma torção tem uma proporção fixa de 1:1 durante o posicionamento ou a edição gráfica, sendo o tamanho final de posicionamento determinado pelo valor atual da grade de snap do documento. 

  • Se uma torção estiver associada a fios em vários locais no diagrama de fiação do chicote (ou seja, quando vários objetos de torção com o mesmo designador forem colocados em diferentes fios), selecionar um objeto destacará todos os fios associados no grupo, e todos esses fios serão listados na região Twist Objects do painel Properties ().

  • O parâmetro Twists per Unit Length e os parâmetros Thickness de uma torção são usados ao sincronizar um projeto de chicote com uma ferramenta MCAD usando MCAD CoDesigner. Consulte a página Synchronizing a Harness Design Project para saber mais.

Fios desconectados

As extremidades de fios desconectados são indicadas com um quadrado sólido.

Um fio desconectado indicado
Um fio desconectado indicado

A extremidade de um fio não deve ser deixada desconectada. Se o projeto exigir uma extremidade de fio desconectada, um objeto “no connect” deve ser colocado na extremidade (Place » No Connect).

Coloque um objeto “no connect” na extremidade de um fio que deve permanecer desconectado.
Coloque um objeto “no connect” na extremidade de um fio que deve permanecer desconectado.

As propriedades de um objeto “no connect” já colocado (sua localização e representação visual) podem ser configuradas no painel Properties quando o objeto estiver selecionado no espaço de projeto.

O painel Properties quando um objeto “no connect” está selecionado
O painel Properties quando um objeto “no connect” está selecionado

Trabalhando com várias folhas

Um diagrama completo de fiação de chicote pode ser definido em várias folhas (em um estilo de projeto “flat”, em que todas as folhas existem no mesmo nível), cada uma representada por seu próprio documento *.WirDoc. A conectividade é criada diretamente de qualquer folha para qualquer outra usando objetos de interrupção de fio (Place » Wire Break) com o mesmo designador de fio.

Após selecionar o comando de posicionamento de interrupção de fio, posicione o objeto de modo que seu ponto ativo elétrico (a extremidade mantida pelo cursor) toque o fio ao qual você deseja se conectar e, em seguida, clique ou pressione Enter para efetuar o posicionamento. Uma interrupção de fio posicionada herda as propriedades (designador e cor) do fio ao qual está conectada.

Selecione uma interrupção de fio no espaço de projeto para alterá-la no painel Properties. No painel, você pode definir o designador do fio ao qual ela está conectada e seu estilo: direção (Left ou Right) e cor.

Sincronização de Fios

Os fios do chicote conectados com uma interrupção de fio são reconhecidos mesmo que tenham IDs de item de projeto diferentes. Além disso, todos os segmentos de fio com o mesmo designador conectados pela mesma interrupção de fio são comparados (quanto a número da peça, comentário, cor e todos os parâmetros). Se alguma diferença for encontrada, a violação Mismatched parameters in connected wire segments será reportada. Um aviso também aparece no painel Properties do fio e da interrupção de fio, indicando que foi detectado um conflito entre os parâmetros. Clique em Synchronize no aviso para abrir a caixa de diálogo Conflict Wire Parameters, que permite escolher quais parâmetros usar para o segmento de fio.

Propriedades e parâmetros do fio antes da sincronização

Um aviso aparece no painel , indicando que há um conflito entre parâmetros. Após clicar em Synchronize no aviso, a caixa de diálogo Confirm Wire Parameters é aberta. Selecione a opção desejada e clique em OK para realizar a sincronização.

A violação Mismatched parameters in connected wire segments na caixa de diálogo Project Options

Após a sincronização, as propriedades dos segmentos de fio foram sincronizadas. 

 
  • Observe que, ao alterar a cor e o designador de uma interrupção de fio, a cor e o designador do fio ao qual a interrupção está conectada são alterados de forma correspondente e, vice-versa, ao alterar a cor e o designador de um fio, a cor e o designador da interrupção de fio conectada a ele também são alterados de forma correspondente.

  • Você também pode alterar as propriedades de uma interrupção de fio durante o posicionamento pressionando Tab após selecionar o comando de posicionamento. Observe que, se um designador for definido para a interrupção de fio antes do seu posicionamento, o fio ao qual ela está conectada herdará o designador e a cor da interrupção de fio.

  • Se uma cor de borda for definida para um fio ao qual uma interrupção de fio está conectada, essa interrupção de fio também será exibida com uma borda dessa cor. Além disso, o designador da interrupção de fio será mostrado na cor da borda do fio conectado.

  • As interrupções de fio não têm propriedades de fonte independentes; elas usam as propriedades Document Font do documento de diagrama de fiação de chicote no qual estão posicionadas.

  • As interrupções de fio também podem ser usadas para criar conectividade dentro da mesma folha do diagrama de fiação de chicote – por exemplo, em vez de posicionar um fio de um pino de conector a outro, você pode posicionar um fio curto de chicote e uma interrupção de fio em cada um desses pinos ().

Posicionando um Componente de Fiação de Chicote

Quando conectado ao seu Workspace, você pode criar componentes com estrutura e propriedades predefinidas conforme necessário no Workspace conectado e depois reutilizar esses componentes em seus projetos de chicote, posicionando-os diretamente em documentos de diagrama de fiação de chicote.

Consulte a página Criando um Componente de Fiação de Chicote para saber mais.

Esses componentes (cada um com um modelo de fiação de chicote atribuído) são acessados pelo painel Components panel. Quando o documento de diagrama de fiação de chicote necessário for o documento ativo no espaço de projeto, posicione um componente clicando com o botão direito em sua entrada no painel e selecionando o comando Place <ComponentName> no menu de contexto. O comportamento ao posicionar um componente difere dependendo de o componente incluir um único objeto de fio ou uma estrutura de cabo (múltiplos fios e/ou objetos adicionais: cabos, blindagens etc.).

  • Single wire – ao posicionar um componente que inclui um único objeto de fio, você entrará no modo de posicionamento de fio de chicote. O fio que está sendo posicionado herdará as propriedades definidas durante a criação do componente. Consulte a seção Creating Connectivity in the Harness Wiring Diagram acima para saber mais sobre o posicionamento de fios de chicote.

  • Cable structure – ao selecionar o comando de posicionamento para um componente que inclui uma estrutura de cabo, essa estrutura de cabo aparecerá anexada ao cursor exatamente como foi definida durante a criação do componente. Clique no local desejado do documento de diagrama de fiação de chicote para posicionar o componente. Em seguida, você poderá editar individualmente os objetos do componente, por exemplo, para conectar os fios que compõem o cabo aos pinos dos conectores do chicote.

Atualizando o Diagrama de Fiação a partir de Bibliotecas

Os seguintes objetos podem ser atualizados a partir de sua biblioteca de origem no Workspace:

  • Componentes de chicote

  • Cavidades de componentes de chicote

  • Peças associadas a componentes de chicote

  • Fios

Quando um objeto é selecionado, as informações sobre o componente vinculado do Workspace podem ser encontradas no painel Properties (por exemplo, a guia Associated Parts para as peças associadas de um componente de chicote).

Se houver uma revisão mais recente do componente do Workspace disponível, a entrada do status da revisão refletirá isso usando o texto Out of date. No nível de objeto individual, o vínculo pode ser atualizado para a revisão mais recente do componente do Workspace clicando no botão .

Um exemplo de indicação de uma revisão desatualizada de componente de chicote
Um exemplo de indicação de uma revisão desatualizada de componente de chicote

O recurso Update from Libraries (Tools » Update from Libraries) também pode ser usado para atualizar componentes desatualizados vinculados aos objetos listados acima. Observe que, para que um objeto seja incluído na atualização usando o recurso Update from Libraries, um componente atribuído ao objeto deve incluir um vínculo para um símbolo esquemático.

Anotando Objetos do Diagrama de Fiação de Chicote

Use os comandos no menu Tools » Annotation para anotar os seguintes objetos no documento de diagrama de fiação de chicote:

  • Componentes de chicote

  • Fios

  • Emendas e derivações

  • Cabos

  • Blindagens e blindagens com conexão

  • Torções

  • Objetos “sem conexão”

Anotar objetos em um documento de diagrama de fiação de chicote é semelhante a anotar componentes em um documento esquemático (*.SchDoc) de um projeto de PCB. Use os links a seguir para saber mais sobre os comandos de anotação disponíveis para um documento de diagrama de fiação de chicote:

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Conteúdo