Preparando Saídas e Liberando o Projeto
Main page: Preparando seu projeto para fabricação
Agora que você concluiu o projeto e o layout da PCB, está pronto para gerar a documentação de saída necessária para que a placa seja revisada, fabricada e montada.
Como existem diversas tecnologias e métodos de fabricação de PCBs, o Altium Designer permite gerar vários tipos de saída para diferentes finalidades, incluindo arquivos Gerber, arquivos ODB++, arquivos Pick and Place, relatórios de lista de materiais etc.
Adicionando um arquivo Output Job ao projeto
Main page: Preparando dados de fabricação com Output Jobs
Embora você possa gerar seletivamente as saídas necessárias a partir de editores específicos (por exemplo, usando comandos nos submenus Fabrication Outputs e Assembly Outputs do menu principal File no editor de PCB), o Altium Designer oferece suporte a arquivos Output Job. Um arquivo Output Job (ou 'OutJob', para abreviar) armazena as configurações de cada tipo de saída. Um OutJob permite configurar cada tipo de saída, bem como o nome, o formato e o local dos arquivos gerados. As saídas podem ser geradas diretamente de um OutJob ou como parte do processo integrado de liberação do projeto.
-
Clique com o botão direito na entrada do projeto no painel Projects e selecione o comando Add New to Project » Output Job File no menu de contexto. Um novo arquivo Output Job será aberto, e uma entrada correspondente aparecerá vinculada ao projeto no painel Projects, sob a entrada Settings\Output Job Files.
-
Clique com o botão direito na entrada do OutJob no painel Projects e selecione o comando Save As. A caixa de diálogo Save As será aberta, pronta para salvar o documento no mesmo local do arquivo do projeto. Digite o nome
Fabricationno campo File name e clique no botão Save. -
A adição do OutJob alterou o projeto. Portanto, salve o projeto localmente clicando com o botão direito na entrada do projeto no painel Projects e selecionando Save.
Adicionando e configurando saídas de fabricação
Main page: Preparando dados de fabricação
Nesta parte do tutorial, você configurará as saídas necessárias para fabricar a placa: arquivos Gerber e NC Drill.
-
Para adicionar uma nova saída Gerber, clique no link Add New Fabrication Output na seção Fabrication Outputs da região Outputs do OutJob e selecione Gerber Files » [PCB Document].
-
Clique duas vezes na entrada de saída Gerber Files adicionada. A caixa de diálogo Gerber Setup será aberta. Configure as opções da seguinte forma:
-
Como a placa foi projetada no sistema métrico, verifique se a opção Units está definida como Millimeters.
-
A menor unidade usada na placa é de 0,25 mm para o roteamento e o espaçamento. Porém, como a maioria dos componentes tem seu ponto de referência no centro geométrico (e foi posicionada em uma grade de 1 mm), algumas de suas ilhas estarão, na verdade, em uma grade de 0,01 mm. Defina a opção Decimal como 0.001 mm. Isso garante que a resolução dos dados de saída seja mais do que suficiente para representar essas posições na grade.
-
Clique no botão
na parte inferior da aba Layer to plot e escolha Select Used. As camadas usadas no projeto serão habilitadas na coluna Plot da tabela acima.
-
-
Clique em Apply para aceitar as demais configurações padrão e fechar a caixa de diálogo Gerber Setup.
-
Como a placa tem furos, também é necessário gerar um arquivo NC Drill. Da mesma forma, adicione a saída NC Drill ao arquivo OutJob: clique no link Add New Fabrication Output na seção Fabrication Outputs da região Outputs do OutJob e selecione NC Drill Files » [PCB Document].
-
Clique duas vezes na entrada de saída NC Drill Files adicionada para acessar a caixa de diálogo NC Drill Setup. Para garantir que os arquivos NC Drill sejam criados no mesmo formato dos arquivos Gerber, defina Units como Millimeters e Format como 4:3. Verifique se a opção Coordinate Position está definida como Reference to relative origin.
-
Clique em OK para aceitar as demais configurações padrão e fechar a caixa de diálogo NC Drill Setup.
-
Agora que as configurações de Gerber e NC Drill estão definidas, a próxima etapa é configurar os nomes e o local dos arquivos de saída. Isso é feito associando essas saídas a um contêiner de saída no lado direito do OutJob. Para arquivos individuais com formato próprio, use um contêiner de estrutura de pastas. Um novo OutJob inclui alguns contêineres por padrão. Selecione a entrada Folder Structure na lista de contêineres de saída e clique nos botões de opção dos arquivos Gerber e NC Drill na coluna Enabled da região Outputs para associar essas saídas ao contêiner selecionado, conforme mostrado abaixo.
-
A última etapa é configurar o contêiner. Para isso, clique no link Change na entrada do contêiner selecionado para abrir a caixa de diálogo Folder Structure settings. Na parte superior da caixa de diálogo, há um conjunto de controles usados para configurar o local dos arquivos de saída. Verifique se o primeiro controle está definido como Release Managed. A parte inferior da caixa de diálogo mostrará como os nomes e a estrutura de pastas mudam à medida que você seleciona diferentes opções.
-
Clique em OK para fechar a caixa de diálogo Folder Structure settings.
Adicionando e configurando um relatório de validação DRC
Main page: Preparando relatórios de validação
O Altium Designer inclui diversas verificações de validação que podem ser incluídas como saídas durante a geração dos arquivos de saída. Cada uma produz um arquivo de relatório HTML. Durante o processo de liberação do projeto, essas verificações serão executadas antes da geração das demais saídas. Se alguma verificação de validação não for aprovada, a liberação falhará.
-
Para adicionar uma nova saída de validação DRC, clique no link Add Validation Output na seção Validation Outputs da região Outputs do OutJob e selecione Design Rules Check » [PCB Document].
-
Associe o relatório adicionado ao contêiner Folder Structure existente. Selecione a entrada Folder Structure na lista do lado direito do OutJob e clique no botão de opção da saída Design Rules Check na coluna Enabled da região Outputs.
-
Salve o arquivo Output Job localmente clicando com o botão direito em sua entrada no painel Projects e selecionando Save no menu de contexto.
-
Feche o arquivo Output Job clicando com o botão direito do mouse em sua aba na parte superior da área de projeto e selecionando o comando Close Fabrication.OutJob no menu de contexto.
Adição e configuração de saídas de montagem
Main page: Configuração da BOM no Gerenciador de Relatórios
O arquivo de saída da BOM é gerado usando a caixa de diálogo Report Manager – um mecanismo de geração de relatórios altamente configurável que pode gerar saídas em diversos formatos, incluindo texto, CSV, PDF, HTML e Excel. Às BOMs em formato Excel também pode ser aplicado um modelo, usando um dos modelos predefinidos ou um modelo próprio.
-
Adicione um novo arquivo OutJob ao projeto clicando com o botão direito do mouse na entrada do projeto no painel Projects e selecionando o comando Add New to Project » Output Job File no menu de contexto.
-
Clique com o botão direito do mouse na entrada do OutJob no painel Projects e selecione o comando Save As . A caixa de diálogo Save As será aberta, pronta para salvar o documento no mesmo local do arquivo do projeto. Digite o nome
Assemblyno campo File name e clique no botão Save . -
Salve o projeto localmente clicando com o botão direito do mouse na entrada do projeto no painel Projects e selecionando Save.
-
Para adicionar uma nova saída de BOM, clique no link Add New Report Output na seção Report Outputs do OutJob e selecione Bill of Materials » [ActiveBOM Document].
-
Clique duas vezes na saída Bill of Materials adicionada para abrir a caixa de diálogo Report Manager.
-
Na região Export Options do painel Properties à direita da caixa de diálogo, use a lista suspensa File Format para selecionar Generic XLS (*.xls, *.xlsx, *.xlsm) e, em seguida, use a lista suspensa Template para selecionar o modelo BOM Template Single Supplier entre os disponíveis em seu Workspace.
-
Clique em OK para salvar as alterações e fechar a caixa de diálogo Report Manager.
-
Adicione uma nova saída do Draftsman clicando no link Add New Documentation Output na seção Documentation Outputs do OutJob e selecionando Draftsman » All Draftsman Documents.
-
Associe as saídas de BOM e Draftsman adicionadas ao contêiner de saída PDF existente. Para isso, selecione a entrada PDF na lista de contêineres de saída à direita do OutJob e clique nos botões de opção das saídas Bill of Materials e Draftsman na coluna Enabled da região Outputs.
-
Com a entrada do contêiner PDF selecionada, clique no link Change dessa entrada para abrir a caixa de diálogo PDF settings.
-
Clique na entrada Assembly.PDF na parte superior da caixa de diálogo PDF settings, selecione Separate file for each output using output name e clique no botão
. A BOM e o desenho de saída receberão os nomes definidos para as saídas no OutJob (Bill of Materials.pdf e Draftsman.pdf, respectivamente), que podem ser vistos na região Preview da caixa de diálogo.
-
Clique em OK para fechar a caixa de diálogo.
-
Adicione uma nova saída de Pick & Place clicando no link Add New Documentation Output na seção Documentation Outputs do OutJob e selecionando Generates pick and place files » [PCB Document].
-
Clique duas vezes na saída Generates pick and place files adicionada para acessar a caixa de diálogo Pick and Place Setup.
-
Na região Output Setting, na parte inferior esquerda da caixa de diálogo, defina Units como Metric.
-
Clique em OK para aceitar as demais configurações padrão e fechar a caixa de diálogo Pick and Place Setup.
-
Associe a saída de Pick & Place adicionada ao contêiner de saída Folder Structure existente. Para isso, selecione a entrada Folder Structure na lista de contêineres de saída à direita do OutJob e clique no botão de opção da saída Generates pick and place files na coluna Enabled da região Outputs.
-
Salve o arquivo Output Job localmente clicando com o botão direito do mouse em sua entrada no painel Projects e selecionando Save no menu de contexto.
-
Feche o arquivo Output Job clicando com o botão direito do mouse em sua aba na parte superior da área de projeto e selecionando o comando Close Assembly.OutJob no menu de contexto.
Liberação do projeto
Main page: Liberação do projeto de design
Com a documentação de saída configurada nos arquivos Output Job, o projeto está pronto para ser liberado para o Workspace conectado. O processo de liberação do projeto da placa é automatizado, permitindo liberar seus projetos de placas sem os riscos associados aos procedimentos manuais de liberação. Quando um projeto específico é liberado, uma cópia instantânea dos arquivos-fonte do projeto é criada e arquivada junto com todas as saídas geradas – que representam um produto tangível produzido a partir desse projeto e vendido pela empresa.
O processo de liberação em si é realizado usando o Project Releaser do Altium Designer, cuja interface de usuário é disponibilizada em uma visualização dedicada – a visualização de liberação. O processo de liberação é um fluxo dividido em etapas, com as entradas à esquerda da visualização indicando rapidamente em qual etapa você está.
-
Clique com o botão direito do mouse na entrada do projeto no painel Projects e selecione o comando Project Releaser no menu de contexto. A visualização de liberação será aberta em uma aba de documento separada.
-
Na primeira etapa – 1. Configure Server Release – você especifica os tipos de dados que deseja gerar. Clique nos controles Details na extremidade direita do cabeçalho de cada conjunto de dados para acessar os detalhes do que exatamente será gerado por esse conjunto.
-
Clique no botão
na parte inferior esquerda da visualização para acessar a caixa de diálogo Project Release Options. Na aba Release Options da caixa de diálogo, certifique-se de que Managed - <WorkspaceName> esteja selecionado como Release Target, Fabrication esteja atribuído ao conjunto Fabrication Data e Assembly esteja atribuído ao conjunto Assembly Data.
-
Clique em OK para fechar a caixa de diálogo e retornar à visualização de liberação.
-
Certifique-se de que as opções Include Fabrication Data e Include Assembly Data for No Variant estejam habilitadas.
-
Clique no botão
na parte inferior direita da visualização para prosseguir.
-
A caixa de diálogo Item Creation será aberta, com a lista dos itens de destino da liberação a serem criados no Workspace. Selecione a opção Create items para confirmar a criação dos itens.
-
Na caixa de diálogo Project Modified que será aberta, selecione a opção Save and Commit changes para salvar as alterações localmente e prosseguir com o salvamento das alterações no Workspace.
-
Na caixa de diálogo Commit to Version Control que se abre, insira um comentário significativo no campo Comment (por exemplo,
The project is ready for release) e clique no botão
.
-
A próxima etapa do processo de liberação – 2. Validate Project – é executada automaticamente porque o arquivo de tarefas de saída
Fabricationinclui o relatório de verificação das regras de projeto. -
Após a validação bem-sucedida, a próxima etapa do processo de liberação – 3. Generate Data – é executada automaticamente. É nessa etapa que todas as outras saídas – definidas nos arquivos OutJob atribuídos aos itens de dados incluídos – são executadas para gerar os dados que serão liberados nos respectivos itens de destino no Workspace.
-
Com todas as verificações de validação aprovadas e os dados de saída gerados, a próxima etapa do processo de liberação – 4. Review Data – permite revisar os dados gerados. Prossiga com a liberação clicando no botão
no canto inferior direito da visualização.
-
A caixa de diálogo Confirm Release será aberta, apresentando um resumo das configurações do projeto que serão liberadas no Workspace. Insira um Release Note (por exemplo,
Initial Release) e clique em OK.
-
Após confirmar a liberação na etapa anterior, a próxima etapa – 5. Upload Data – é iniciada automaticamente. Ela apenas apresenta o andamento do upload dos dados para as revisões dos respectivos itens de dados no Workspace.
-
A etapa final do processo – 6. Execution Report – apresenta um resumo da liberação. Feche a visualização de liberação clicando no botão
no canto inferior direito da visualização.
Projeto colaborativo com um Workspace
Na maioria das vezes, várias pessoas estão envolvidas no projeto e no desenvolvimento de um produto eletrônico. Para fazer isso de maneira eficaz, os membros da equipe de projeto precisam ser capazes de trabalhar de forma colaborativa. O Altium Designer, em conjunto com um Workspace conectado, oferece diversos recursos de projeto colaborativo. Alguns deles estão listados abaixo.
-
Project history – uma visualização dedicada de histórico oferece uma linha do tempo avançada e gráfica do histórico do projeto, apresentando uma sequência dos principais eventos relacionados ao projeto – sua criação, commits, liberações, clones e trocas de dados com MCAD – com suporte a várias ações, quando aplicável A visualização de histórico de um projeto do Workspace pode ser acessada no Altium Designer clicando com o botão direito do mouse na entrada do projeto no painel Projects e selecionando o comando History & Version Control » Show Project History no menu de contexto.
Saiba mais: Histórico do projeto, Project History (Workspace do Altium 365, Workspace do Enterprise Server)
-
Web Viewer – a interface Web Viewer do Workspace oferece acesso universal aos documentos do projeto por meio de um navegador padrão. Muito mais do que apenas um visualizador baseado em navegador, sua tecnologia avançada permite que os usuários naveguem pela estrutura do projeto, interajam com os documentos de projeto, destaquem áreas ou objetos para adicionar comentários e pesquisem, façam sondagem cruzada, selecionem e inspecionem componentes e redes em todo o projeto. O Web Viewer de um projeto do Workspace pode ser acessado no Altium Designer clicando com o botão direito do mouse na entrada do projeto no painel Projects e selecionando o comando Show in Web Browser no menu de contexto.
Saiba mais: Web Viewer (Plataforma Altium 365, Workspace do Enterprise Server)
-
Document commenting – um comentário é uma nota adicionada pelo usuário e atribuída a um ponto, objeto ou área específica (conforme aplicável) em uma visualização de dados compatível, à qual outros usuários podem responder. Os comentários promovem a colaboração entre os usuários sem alterar os próprios dados compartilhados, pois são armazenados pelo Workspace independentemente desses dados. Os comentários adicionados na interface Web Viewer nos locais a seguir ficam disponíveis no Altium Designer e vice-versa. No Altium Designer, o recurso de comentários é gerenciado pelo painel Comments and Tasks
Saiba mais: Comentários em documentos, Web Viewer (Plataforma Altium 365, Workspace do Enterprise Server)
-
Sharing a project – depois que um projeto é salvo no Workspace, você pode determinar quais usuários podem efetivamente acessá-lo para colaborar no projeto e/ou revisá-lo. Isso é feito compartilhando o projeto ou, mais precisamente, configurando suas permissões de acesso. No Altium Designer, o compartilhamento de projetos é gerenciado pela caixa de diálogo Share , acessada clicando com o botão direito do mouse na entrada do projeto no painel Projects e selecionando o comando Share no menu de contexto.
Saiba mais: Compartilhamento de um projeto, Workspace Projects (Workspace do Altium 365, Workspace do Enterprise Server)



















).
).
)