Навигация по документу

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

При работе с графическим документом, например листом схемы, документом печатной платы или документом Draftsman, можно изменять масштаб и перемещать документ, чтобы сосредоточиться на определенной области. Для этого можно использовать следующие основные сочетания клавиш:

  • Ctrl+Mouse Wheel для увеличения и уменьшения масштаба
  • Right-Click, Hold&Drag для перемещения документа

Главное меню View содержит ряд команд для управления отображением текущего документа.

Используйте команды главного меню View для управления отображением документа. На верхнем изображении показано меню View редактора схем. На нижнем изображении показано меню View редактора печатных плат.

Используйте команды главного меню View для управления отображением документа. На верхнем изображении показано меню View редактора схем. На нижнем изображении показано меню View редактора печатных плат.

К этим командам относятся:

  • Fit Document — отобразить всю область текущего документа.

  • Fit All Objects — отобразить все объекты проекта в текущем документе.

  • Area — увеличить масштаб выбранной пользователем области текущего документа.

  • Around Point — задать область отображения вокруг указанной точки текущего документа.

  • Selected Objects — изменить вид рабочей области так, чтобы были видны все выделенные объекты.

  • Zoom In — увеличить масштаб проекта относительно положения курсора в текущем документе.

  • Zoom Out — уменьшить масштаб проекта относительно положения курсора в текущем документе.

  • Zoom Last — вернуться к предыдущему виду текущего документа.

Для доступа к всплывающему меню с командами масштабирования также можно использовать сочетание клавиш Z.

В редакторах печатных плат и посадочных мест это меню позволяет вызвать команду Select, которая открывает диалоговое окно Zoom Value (0.001x..4x). В нем можно изменить масштаб отображения текущего документа на заданный коэффициент. Значения больше 1 используются для увеличения масштаба. Значения меньше 1 используются для уменьшения масштаба.

Диалоговое окно Zoom Value
Диалоговое окно Zoom Value

При просмотре документа печатной платы или посадочного места в 3D доступны дополнительные команды, сочетания клавиш и элементы управления для удобной навигации. Подробнее см. на странице Управление 3D-видом.

Переход к определенной точке документа

С помощью команд подменю Edit » Jump главного меню редактора схем, символов схем, печатных плат или посадочных мест можно перейти к определенной точке активного документа. Всплывающее меню Jump также можно открыть, нажав клавишу J в рабочей области. Например, можно перейти к:

  • началу координат документа:
    • началу координат листа схемы (соответствует левому нижнему углу) — Origin;

    • абсолютному началу координат документа печатной платы — Absolute Origin;

    • относительному началу координат текущего документа печатной платы — Current Origin;

    • опорной точке компонента в документе посадочного места — Reference;

  • любой точке текущего документа по заданным пользователем координатам XY — выберите команду New Location и в появившемся диалоговом окне Jump To Location введите координаты X и Y точки рабочей области, к которой должен перейти курсор. В редакторе печатных плат также можно использовать поля Delta X и Delta Y, чтобы задать смещения по X и Y для требуемой точки перехода.

    Диалоговое окно Jump To Location — в редакторе схем (первое изображение) и в редакторе печатных плат (второе изображение)
    Диалоговое окно Jump To Location — в редакторе схем (первое изображение) и в редакторе печатных плат (второе изображение)

  • объекту в документе. Для перехода к нужному объекту используйте следующие команды:
    • компонент на листе схемы — Jump Component. После запуска команды появится диалоговое окно Component Designator. Введите позиционное обозначение компонента, к которому нужно перейти. Если обозначение корректно и компонент существует в исходном документе схемы активного проекта, соответствующий документ схемы станет активным, а нужный компонент будет показан в увеличенном масштабе и по возможности расположен в центре рабочей области. Найденный компонент (или все секции многосекционного компонента) также отображается в панели Messages . Дважды щелкните запись сообщения, чтобы перейти к этому компоненту (или его секции) в рабочей области.

      Диалоговое окно Component Designator
      Диалоговое окно Component Designator

      При поиске многосекционного компонента вводите только основное позиционное обозначение. Не добавляйте суффикс секции. Например, чтобы перейти к микросхеме из двух секций с обозначениями IC1_CPA и IC1_CPB, введите IC1_CP в диалоговом окне Component Designator. Для многосекционного компонента будет выделена первая секция и открыто диалоговое окно Find Text - Jump. Используйте это окно для перехода между секциями компонента.
      Включите параметр Physical в диалоговом окне Component Designator, чтобы функция перехода учитывала только физические позиционные обозначения компонентов — те, которые отображаются на вкладках Compiled Document исходных документов схем. Если этот параметр отключен, функция перехода будет учитывать только логические позиционные обозначения — те, которые отображаются на вкладках Editor исходных документов схем.
    • определенный компонент в документе печатной платы — Component. После запуска команды появится диалоговое окно Component Designator. Введите позиционное обозначение компонента, чтобы перейти к нему. Если вы не уверены в обозначении, введите ? и нажмите OK , чтобы открыть диалоговое окно Components Placed со списком всех компонентов проекта. Введите текст в поле Mask для поиска нужного компонента. По мере ввода список фильтруется: в нем остаются только строки, соответствующие маске. В строке можно использовать подстановочные знаки ? (любой один символ) и * (любые символы). Курсор перейдет к опорной точке выбранного компонента.

      Введите ? в диалоговом окне Component Designator, чтобы открыть диалоговое окно Components Placed со списком всех компонентов печатной платы.
      Введите ? в диалоговом окне Component Designator, чтобы открыть диалоговое окно Components Placed со списком всех компонентов печатной платы.

    • определенная цепь в документе печатной платы — Net. После запуска команды появится диалоговое окно Net Name. Введите имя цепи, к которой нужно перейти, либо введите ? и нажмите OK , чтобы открыть диалоговое окно Nets Loaded со списком всех загруженных цепей проекта. Введите текст в поле Mask для поиска нужной цепи. По мере ввода список фильтруется: в нем остаются только строки, соответствующие маске. В строке маски можно использовать подстановочные знаки ? (любой один символ) и * (любые символы). Если нужная цепь уже отображается в основном окне проектирования, курсор перейдет к ближайшему объекту проекта, принадлежащему этой цепи. Если цепь находится за пределами видимой области, курсор будет установлен на ближайшем объекте проекта, принадлежащем этой цепи, а этот объект по возможности будет расположен в центре рабочей области.

      Введите ? в диалоговом окне Net Name, чтобы открыть диалоговое окно Nets Loaded со списком всех цепей печатной платы.Введите ? в диалоговом окне Net Name, чтобы открыть диалоговое окно Nets Loaded со списком всех цепей печатной платы.

    • конкретной контактной площадке компонента в документе печатной платы — Pad. После запуска команды появится диалоговое окно Jump To Pad Number. Укажите нужную контактную площадку требуемого компонента в формате ComponentDesignator-PadDesignator (например, U1-6) и нажмите OK. Если искомая контактная площадка уже отображается в рабочей области, курсор просто переместится в ее центр. Если контактная площадка находится за пределами видимой области, курсор будет установлен в ее центре, а сама площадка по возможности будет расположена в центре рабочей области.

      Диалоговое окно Jump To Pad Number
      Диалоговое окно Jump To Pad Number

    • конкретной строке в документе печатной платы — String. После запуска команды появится диалоговое окно Jump To String. Введите строку, к которой нужно перейти, либо введите ? и нажмите OK , чтобы открыть диалоговое окно Strings со списком всех строк, найденных в активном документе платы (как отдельных, так и входящих в состав других групповых объектов). Используйте это диалоговое окно для быстрого поиска строки, к которой нужно перейти. Если искомая строка уже отображается в рабочей области, курсор просто переместится в точку привязки строки — точку, за которую она удерживается при перемещении или вокруг которой вращается. Если строка находится за пределами видимой области, курсор будет установлен в ее точке привязки, а сама точка по возможности будет расположена в центре рабочей области.

      Введите ? в диалоговом окне Jump To String, чтобы открыть диалоговое окно Strings со списком всех цепей печатной платы.
      Введите ? в диалоговом окне Jump To String, чтобы открыть диалоговое окно Strings со списком всех цепей печатной платы.

      Система выполнит три поиска: сначала будет найдена строка, совпадающая с указанной по регистру, символам и длине; затем — строка с теми же символами, но, возможно, содержащая дополнительные символы; и наконец — строка с теми же символами без учета регистра.

    • переходу ко всем маркерам ошибок в текущем документе проекта с их последовательным перебором — Error Marker. После запуска команды курсор переместится к первому маркеру ошибки проверки правил проектирования (DRC), который будет расположен в центре главного окна проектирования. Повторное выполнение команды приведет к переходу ко второму маркеру ошибки и так далее. Эта команда позволяет перейти к маркеру ошибки независимо от того, было ли нарушение исключено из проверки.

      Чтобы просмотреть сведения о нарушениях, связанных с объектом под курсором, щелкните правой кнопкой мыши и выберите соответствующую команду в подменю Violations .

  • переходу ко всем выделенным объектам проекта в текущем документе с их последовательным перебором — Selection. После запуска команды курсор переместится к первому выделенному объекту, который будет показан в увеличенном масштабе и расположен в центре главного окна проектирования. Повторное выполнение команды приведет к переходу ко второму выделенному объекту и так далее, с последовательным перебором всех выделенных объектов текущего документа. Команда перебирает выделенные объекты в том порядке, в котором они были добавлены в выделение.

  • позиции в текущем документе схемы или печатной платы, координаты которой были ранее сохранены в указанном маркере положения, — выберите команду Location Marks » n, чтобы перейти к позиции, сохраненной в указанном маркере положения с помощью команды Set Location Marks » n.

    В документе схемы сохраненная позиция доступна только до тех пор, пока документ остается открытым (независимо от того, активен он или нет). Если закрыть документ и открыть его снова, маркер положения будет пустым. В документе печатной платы маркеры положения сохраняются вместе с проектом, поэтому заданные пользователем позиции остаются доступными между сеансами работы над проектом.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.