Altium Designer Documentation

Среда Altium Designer

Последнее изменение: Pavel Demidov; 03.06.2020

Altium Designer предлагает унифицированную среду для всех аспектов процесса разработки электронных изделий, в том числе:

  • Ввод электрических схем
  • Конструирование печатных узлов
  • Имитация цепей смешанных сигналов
  • Анализ целостности сигналов
  • Производство плат

Altium Designer включает в себя редакторы и программные модули, необходимые для всех аспектов процесса проектирования электронных изделий. Всё редактирование и обработка документов осуществляется в среде Altium Designer. Altium Designer также бесшовно взаимодействует со вспомогательными средствами, такими как ПО для трассировки и стороннее ПО для анализа. В основе Altium Designer лежит интеграционная платформа X2, которая объединяет различные редакторы и программные модули Altium Designer и обеспечивает преемственный интерфейс пользователя между всеми средствами и редакторами. Набор доступных функциональных возможностей зависит от конкретной лицензии, которая была приобретена. Среда Altium Designer полностью доступна для настройки, что позволяет настроить рабочее пространство в соответствии с вашим стилем работы. Преемственная парадигма выделения и редактирования объектов в различных редакторах позволяет легко и беспрепятственно переключаться между проектными задачами в среде Altium Designer.

Получение справки

Altium Designer предлагает различные способы получения справки и дополнительной информации.

  • Нажмите F1 при наведении курсора на любой объект, редактор, панель, пункт меню или кнопку, чтобы открыть документацию по этой сущности.
  • Нажмите Shift+F1 при активной команде для отображения списка сочетаний клавиш, которые можно использовать в этой команде.
  • Используйте дерево навигации в левой части сайта документации, чтобы прочитать статью по этой теме.

    Документацию по ресурсам (настройки, объекты, панели, команды, диалоговые окна и т.д.) можно найти под заголовком Preferences & References (Настройки и справочники) в дереве навигации.

Элементы среды

Altium Designer является уникальной с точки зрения поддержки всех аспектов проектирования электроники, от ввода схем до формирования выходной документации для производства. Это осуществляется в едином программном приложении, благодаря поддержке лежащей в основе интеграционной платформы X2. Платформа поддерживает все стандартные элементы интерфейса пользователя, такие как меню и панели инструментов (также называемых ресурсами), где каждый редактор использует определенный набор ресурсов и команд. Смотрите раздел ниже для получения информации по элементам среды Altium Designer: их описания, доступ к ним и т.д.


Элементы

В разделах ниже приведено описание некоторых главных элементов проектного пространства Altium Designer, выделенных на изображении выше.

Открытые и активные документы

В Altium Designer у вас может быть открыто сколь угодно много документов, но только один документ может быть активным. Активный документ открыт в проектном пространстве, чтобы вы могли вносить необходимые изменения. Все открытые документы отображаются в виде вкладок над проектным пространством. Вкладка активного на текущий момент документа отображается на умеренно сером фоне. Открытые, но не активные документы отображаются на темно-сером/черном фоне.

Щелкните ПКМ по вкладке документа, чтобы открыть список команд на закрытие документа, по которому вы щелкнули ПКМ, закрытие всех документов того же редактора (например, все документы PcbDoc, все документы SchLib или все документы PcbLib), закрытие всех открытых документов, разделение, мозаичное размещение и объединение документов.

Перейдите на страницу Настройка и кастомизация Altium Designer для получения более подробной информации.

Настройки

Диалоговое окно Preferences является центральным расположением, где вы можете задать глобальные системные настройки для различных функциональных областей программного обеспечения. Эти настройки применяются к различным проектам и соответствующим документам. Доступ к диалоговому окну осуществляется щелчком мыши по элементу управления вверху справа от проектного пространства. Используйте в левой части диалогового окна, чтобы открыть раздел нужной области, и выберите заголовок, чтобы открыть определенную страницу настроек.

Лицензии

Altium Designer предлагает лицензии различных типов для ваших индивидуальных требований. Система лицензирования позволяет вам быстро и эффективно начать работу в Altium Designer. Чтобы открыть страницу License Management, щелкните мышью по элементу управления  возле своих учетных данных вверху справа от рабочего пространства и выберите Licenses из открывшегося меню.

Для получения полной информации о лицензировании перейдите на страницу Установка, лицензирование и управление системой.

Дополнительные программные модули и обновления

Дополнительные программные модули

Дополнительные программные модули (Extensions) являются расширениями программного обеспечения, которые добавляют дополнительные функциональные возможности. Вы можете устанавливать, обновлять и удалять дополнительные возможности, в том числе новые модули импорта и экспорта, средство формирования схемных символов, поддержку взаимодействия с механическими САПР.

Чтобы открыть страницу Extensions & Updates, щелкните мышью по элементу управления  возле своих учетных данных вверху справа от рабочего пространства и выберите Extensions and Updates из открывшегося меню.

Для получения полной информации о лицензировании перейдите на страницу Расширение функциональных возможностей Altium Designer.

Обновления

Обновление Altium Designer позволяет вам получить самый новый выпуск платформы программного обеспечения и всех установленных дополнительных программных модулей.

Чтобы открыть раздел обновлений, щелкните мышью по элементу управления  возле своих учетных данных вверху справа от рабочего пространства и выберите Extensions and Updates из открывшегося меню. На странице Extensions & Updates выберите вкладку Updates, как показано на изображении ниже.

Число (n) отображает общее количество доступных обновлений. Если (n) не отображается, обновлений нет.

Страница Updates отображает доступные обновления платформы, а также список дополнительных программных модулей (System Extensions и Software Extensions), для которых доступны обновления.

Для получения полной информации о лицензировании перейдите на страницу Расширение функциональных возможностей Altium Designer.

Панели

Панели являются ключевыми элементами среды Altium Designer. Панели могут быть специфичными для определенного редактора документов либо общими, глобальными для всей среды. В них присутствует информация и элементы управления, которые повышают эффективность работы. Например, панель PCB можно использовать для обзора компонентов и цепей. При первом запуске Altium Designer уже открыта панель Projects, которая закреплена слава от проектного пространства. Чтобы открыть другие панели, нажмите кнопку Panels слева внизу от проектного пространства и выберите нужную панель. У каждого редактора есть специфичный для него набор панелей.

Панели используются для работы в среде в целом – например, панель Projects используется для открытия какого-либо документа в проекте, а также для отображения иерархии проекта. Специфичные для документа панели можно отобразить только когда документ этого типа является активным.

Слева – панели редактора плат; справа – панели редактора схем

Для получения более подробной информации о доступе к панелям, режимам отображения панелей (закрепленный, всплывающий, плавающий режимы), о перемещении и закрытии панелей и т.д. перейдите на страницу Работа с панелями в Altium Designer.

Active Bar

Active Bar позволяет быстро получить доступ к часто используемым командам, которые также можно найти в главном меню. Вы можете навести курсор мыши на иконку, чтобы отобразить всплывающую подсказку с ее описанием. Чтобы использовать иконку, щелкните по ней мышью. При использовании иконки для размещения объекта, этот объект появится под курсором для его размещения в нужном месте. Если в правом нижнем углу иконки отображается белый треугольник, то здесь доступен набор иконок. Зажмите левую кнопку мыши, когда курсор наведен на такую иконку, чтобы отобразить список дополнительных иконок, затем выберите нужную команду/иконку. Для набора отображается иконка, которая использовалась последний раз.

Вверху – Active Bar редактора плат; внизу – Active Bar редактора схем

Active Bar можно отключить при необходимости. Чтобы сделать это, в диалоговом окне Advanced Settings (которое открывается нажатием кнопки Advanced на странице System - General диалогового окна Preferences), снимите флажок поля Value для настройки UI.UseActiveBar. Как сказано в диалоговом окне Advanced Settings, Altium Designer будет необходимо перезапустить, чтобы новая настройка вступила в силу.

Главное меню

Главное меню позволяет получить доступ к командам и функциям активного документа. Меню отображается в верхней левой части редактора. У каждого редактора есть собственное меню.

Вверху – главное меню редактора плат; внизу – главное меню редактора схем

Чтобы использовать команду, щелкните мышью по заголовку пункта меню (например, Design), затем выберите нужную команду.

У некоторых команд есть подменю, которые обозначены символом . При наведении курсора мыши на такую команду будет открыто подменю.

Панель быстрого доступа

Панель быстрого доступа (Quick Access Bar) расположена вверху слева от проектного пространства. Она используется для быстрого выполнения часто используемых функций.

  • – выйти и закрыть Altium Designer.
  • – сохранить активный в данный момент документ.
  • – сохранить все измененные документы.
  • – открыть диалоговое окно Open Project, в котором вы можете выбрать документ на открытие.
  • – отменить последнее действие. Иконка активна, только если было произведено какое-либо действие.
  • – повторить последнее действие. Иконка активна, только если была произведена отмена действия.

Строка состояния

Строка состояния (Status Bar) отображает сводную информацию, такую как координаты курсора, подсказки по командам, слой. Вы можете управлять отображением строки состояния с помощью команды View » Status Bar главного меню.

Информационное окно Heads Up Display

Информационное окно Heads Up Display предоставляет динамический отклик об объекте, который в данный момент находится под курсором в рабочей области редактора плат. Чтобы управлять отображением информационного окна Heads Up Display, выберите команду View » Board Insight » Toggle Heads Up Display из главного меню или используйте сочетание клавиш Shift+H.

Вы можете настроить, что отображается в информационном окне Heads Up Display, а также цвет фона, шрифт и цвет шрифта, на странице PCB Editor - Board Insight Modes диалогового окна Preferences.

Проекты и документы

Все относящиеся к проекту данные хранятся в документах, которые также называют файлами. Документы, проекты и группы проектов можно открыть с помощью соответствующих команд, доступных в главном меню File. Либо вы можете перетащить документ, файл проекта или файл группы проектов непосредственно в Altium Designer, чтобы открыть его. Файл проекта хранит в себе ссылки на документы этого проекта, а также относящиеся к проекту настройки, такие как настройки проверки ошибок, настройки компиляции и т.п.

При открытии документа он становится активным документом в главном проектном окне Altium Designer. Может быть открыто одновременно множество документов. Для каждого открытого документа отображается вкладка над окном проектирования. Документы могут занимать всё проектное пространство, либо можно разделить проектное пространство для множества документов с помощью команд Split в меню Window. Затем документы можно перетаскивать между разделенными областями.

Для получения более подробной информации, касающейся документов, мониторов и команд Split и Tile, перейдите на страницу Настройка и кастомизация Altium Designer.

Дополнительные ссылки

Настройка и кастомизация Altium Designer

Вводный урок по Altium Designer

Управление проектами в Altium Designer

Навигация по проекту

Сочетания клавиш

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.