Xác định đường uốn - Chế độ tiêu chuẩn

Sơ lược

Bài viết này giải thích cách xác định, đặt, di chuyển, xóa và cấu hình Đường uốn cho các vùng mạch mềm khi làm việc ở chế độ Rigid-Flex Tiêu chuẩn trong Altium Designer. Bài viết cũng làm rõ sự khác biệt giữa chế độ Rigid-Flex Tiêu chuẩn và Rigid-Flex Nâng cao, cách kiểm tra bo mạch đang sử dụng chế độ nào, cũng như các chế độ xem và bảng điều khiển trong trình biên tập được dùng để quản lý chính xác các nếp uốn. Nếu bạn cần hướng dẫn thực hành về cách thiết lập vị trí uốn, góc uốn, bán kính uốn, chiều rộng vùng chịu ảnh hưởng và thứ tự gập trong đúng chế độ, hướng dẫn này sẽ giúp bạn thao tác tự tin hơn. Hãy đọc tiếp và áp dụng các bước này vào thiết kế tiếp theo của bạn.

- Tìm hiểu khi nào có thể sử dụng Đường uốn trong chế độ Rigid-Flex Tiêu chuẩn và chế độ này khác với Rigid-Flex Nâng cao như thế nào về cách xác định vùng bo mạch.
- Xem các bước cụ thể để đặt, thay đổi vị trí, xóa và căn chỉnh chính xác các Đường uốn trong Chế độ Quy hoạch Bo mạch.
- Nắm rõ những thuộc tính của Đường uốn có thể cấu hình, bao gồm góc uốn, bán kính uốn, chiều rộng vùng chịu ảnh hưởng và thứ tự gập để kiểm tra việc gập trong 3D.
Tìm hiểu sâu hơn với AI:

Có hai chế độ thiết kế cứng-dẻo trong phần mềm thiết kế PCB của Altium. Chế độ ban đầu, hay chế độ tiêu chuẩn, được gọi là Rigid-Flex, hỗ trợ các thiết kế cứng-dẻo đơn giản. Nếu thiết kế của bạn có các yêu cầu cứng-dẻo phức tạp hơn, chẳng hạn như các vùng dẻo chồng lấn, bạn cần sử dụng chế độ Advanced Rigid-Flex (còn được gọi là rigid-flex 2.0). Chế độ được chọn trong menu Tools của Trình quản lý xếp chồng lớp.

Điểm khác biệt cơ bản giữa hai chế độ là ở chế độ ban đầu, hình dạng bo mạch được chia thành các vùng bo mạch riêng biệt bằng cách đặt Đường phân chia, và Đường phân chia này vẫn tồn tại dưới dạng một đối tượng xác định nơi một vùng bo mạch kết thúc và vùng khác bắt đầu. Ở chế độ nâng cao, mỗi vùng bo mạch được đặt riêng biệt, hoặc nếu một vùng lớn hơn được cắt thì vùng đó sẽ trở thành hai đối tượng vùng riêng biệt. Trong chế độ nâng cao, các cạnh của những vùng bo mạch liền kề xác định nơi hai vùng tiếp giáp nhau, chứ không phải sự hiện diện của Đường phân chia. Do sự khác biệt này, không có đối tượng Đường phân chia khi bo mạch ở chế độ Advanced Rigid-Flex.

► Tìm hiểu thêm về Thiết kế PCB cứng-dẻo

Menu View có ba chế độ làm việc của trình biên tập PCB với các phím tắt dễ nhớ, cho phép bạn nhanh chóng chuyển đổi giữa:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Theo mặc định, khi chuyển đổi giữa chế độ xem 2D và 3D, các thiết lập thu phóng và hướng nhìn riêng của từng chế độ xem sẽ được giữ nguyên. Nếu bạn muốn xem cùng một vị trí và hướng của bo mạch khi chuyển đổi, hãy nhấn Ctrl+Alt+2 hoặc Ctrl+Alt+3, thay vì 2 hoặc 3.

Bạn vừa mở một PCB và đang băn khoăn liệu bo mạch đang sử dụng chế độ cứng-dẻo tiêu chuẩn hay chế độ cứng-dẻo nâng cao?

Bạn có thể mở Trình quản lý xếp chồng lớp để kiểm tra. Ngoài ra, hãy chuyển sang Chế độ quy hoạch bo mạch (phím tắt 1) và quan sát Thanh công cụ chủ động:

Chế độ cứng-dẻo tiêu chuẩn
Chế độ cứng-dẻo nâng cao

Để xác định cách uốn một bo mạch dẻo, bạn đặt một hoặc nhiều Đường uốn. Đường uốn xác định vị trí uốn trên bề mặt vùng dẻo. Đường uốn cũng xác định góc và bán kính uốn cũng như chiều rộng của dải bề mặt bo mạch được uốn. Các Đường uốn được đặt và chỉnh sửa bằng trình biên tập PCB trong Board Planning Mode (View » Board Planning Mode, hoặc nhấn phím tắt 1).

Chỉ có thể đặt Đường uốn trên vùng được cấu hình là vùng Flex trong Layer Stack Manager.


Một Đường uốn được đặt trên vùng dẻo và được cấu hình để bo mạch có thể gập 180 độ. Video này minh họa cách đặt Đường uốn trong chế độ cứng-dẻo tiêu chuẩn.

Đặt Đường uốn

Để đặt Đường uốn:

  1. Chọn View » Board Planning Mode hoặc nhấn phím tắt 1 để vào Board Planning Mode.

  2. Các Đường uốn được đặt trên Multi-Layer. Nếu tab Mutli-Layer không hiển thị ở cuối không gian chỉnh sửa, hãy bật lớp này trong bảng View Configuration (phím tắt L để hiển thị bảng).

  3. Chọn lệnh Design » Define Bending Line.

  4. Nhấp vào bên trong vùng bo mạch cần đặt Đường uốn; một đầu của đường sẽ gắn vào cạnh của vùng gần vị trí nhấp nhất, đầu còn lại sẽ gắn vào con trỏ.

  5. Đưa đầu thứ hai đến vị trí mong muốn, rồi nhấp một lần để đặt.

  6. Bạn vẫn ở chế độ đặt Đường uốn, sẵn sàng đặt thêm Đường uốn khác nếu cần. Nếu không, hãy nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt Đường uốn.

Bảng PCB ở chế độ Layer Stack Regions hiển thị dữ liệu Bending Lines. Nhấp đúp vào một mục để mở hộp thoại Đường uốn. 

Ba Đường uốn đã được đặt trên vùng bo mạch dẻo này. Chiều rộng của dải màu cam là Chiều rộng vùng chịu ảnh hưởng.
Ba Đường uốn đã được đặt trên vùng bo mạch dẻo này. Chiều rộng của dải màu cam là Chiều rộng vùng chịu ảnh hưởng.

Khi một vùng bo mạch được thiết lập để sử dụng cấu trúc xếp chồng lớp dẻo, một Đường uốn sẽ tự động được thêm theo chiều dọc qua tâm hình học của vùng. Hãy xóa hoặc định vị lại và cấu hình Đường uốn này theo yêu cầu.

Di chuyển Đường uốn

Để thay đổi vị trí của một Đường uốn hiện có:

  1. Chọn View » Board Planning Mode (hoặc nhấn phím tắt  1) để vào Board Planning Mode.
  2. Nhấp một lần để chọn Vùng bo mạch chứa Đường uốn. Các điểm điều khiển của tất cả Đường uốn trong vùng đó sẽ hiển thị.
  3. Để di chuyển đầu của một đường, hãy nhấp, giữ và kéo nút đến vị trí mong muốn trên đường bao của vùng bo mạch. Con trỏ sẽ bị ràng buộc theo lưới bắt điểm hiện tại và/hoặc các đối tượng thiết kế hiện có.
  4. Vị trí uốn sẽ được xác định lại theo vị trí mới của Đường uốn.

Chọn và kéo nút đầu mút của Đường uốn để thay đổi vị trí uốn trên bo mạch.
Chọn và kéo nút đầu mút của Đường uốn để thay đổi vị trí uốn trên bo mạch.

Định vị chính xác Đường uốn

Khi di chuyển Đường uốn, điểm điều khiển sẽ bắt vào các vị trí trên Lưới bắt điểm hiện tại. Trong khi di chuyển, điểm này cũng có thể bắt vào các đối tượng thiết kế hiện có, chẳng hạn như các đường trên lớp cơ khí. Hình bên dưới cho thấy một điểm điều khiển của Đường uốn đang được đặt tại đầu mút của một đường trên lớp Mechanical 2 (được đánh dấu bằng số 1). Lưu ý rằng lớp cơ khí phải là lớp thiết kế đang hoạt động thì tính năng bắt điểm mới có tác dụng.

Số 1 chỉ điểm điều khiển của Đường uốn đang bắt vào một đường trên Mechanical 2; lưu ý rằng lớp này là lớp đang hoạt động.
Số 1 chỉ điểm điều khiển của Đường uốn đang bắt vào một đường trên Mechanical 2; lưu ý rằng lớp này là lớp đang hoạt động.

Để minh họa chi tiết hơn quy trình trên, các hình bên dưới cho thấy những đường dựng đã được đặt trên Mechanical 2 trong 2D Layout Mode, xác định chính xác các điểm tham chiếu phía trên và phía dưới có thể dùng để đặt Đường uốn 45 độ.

Bo mạch trong Chế độ bố trí 2D hiển thị các đường dựng giúp đặt chính xác các Đường uốn chéo.Bo mạch trong Chế độ bố trí 2D hiển thị các đường dựng giúp đặt chính xác các Đường uốn chéo.

Bo mạch trong Chế độ quy hoạch bo mạch hiển thị các Đường uốn chéo đã được bắt vào các đường dựng trên Mechanical 2.Bo mạch trong Chế độ quy hoạch bo mạch hiển thị các Đường uốn chéo đã được bắt vào các đường dựng trên Mechanical 2.

Xóa Đường uốn

Để xóa Đường uốn:

  1. Chọn View » Board Planning Mode (hoặc nhấn phím tắt 1) để vào Board Planning Mode.
  2. Nhấp và giữ một trong các đầu mút của đường rồi nhấn phím Delete. Ngoài ra, hãy chọn và xóa một mục Đường uốn trong vùng bảng PCB Bending Lines.

Khi một vùng bo mạch được thiết lập để sử dụng cấu trúc xếp chồng lớp dẻo, một Đường uốn sẽ tự động được thêm theo chiều dọc qua tâm hình học của vùng. Hãy xóa hoặc định vị lại và cấu hình Đường uốn này theo yêu cầu.

Cấu hình thuộc tính Đường uốn

Các vùng bo mạch, Đường phân chia và Đường uốn được kiểm tra và chỉnh sửa trong Board Planning Mode (nhấn 1). Có thể chỉnh sửa Đường uốn theo cách tương tác trong không gian thiết kế hoặc thông qua PCB bảng điều khiển khi được đặt ở chế độ Layer Stack Regions. Để hiển thị bảng điều khiển, nhấp vào nút Panels ở góc dưới bên phải của Altium Designer, sau đó chọn PCB từ menu. Trong bảng điều khiển, chọn Layer Stack Regions từ danh sách thả xuống ở đầu bảng. Ở chế độ này, bảng điều khiển hiển thị:

  • Các cấu trúc xếp chồng lớp bo mạch có sẵn trong vùng Layer Stacks.
  • Các vùng được gán cho những cấu trúc xếp chồng đó trong vùng Stackup Regions.
  • Các đường uốn được xác định trong vùng đã chọn tại vùng Bending Lines.

Khi chuyển sang Board Planning Mode, bảng điều khiển PCB sẽ tự động được cấu hình sang chế độ Layer Stack Regions.

Để chỉnh sửa thuộc tính của một đường uốn trong bảng điều khiển PCB:

  1. Có thể chỉnh sửa các đường uốn trong 2D Layout Mode (nhấn 2) hoặc Board Planning Mode (nhấn 1).
  2. Đánh dấu ô Select ở đầu bảng điều khiển.
  3. Chọn vùng bo mạch chứa đường uốn trong khu vực Stackup Regions của bảng điều khiển PCB .
  4. Chọn đường uốn từ danh sách trong vùng Bending Lines của bảng điều khiển. Đường uốn sẽ được tô sáng (được chọn) trên bo mạch nếu tùy chọn Select của bảng điều khiển PCB được bật. Bạn cũng có thể xóa một mục đường uốn khỏi vùng Bending Lines.
  5. Nhấp đúp vào mục đường uốn trong vùng Bending Lines để mở hộp thoại Bending Line như minh họa trong hình bên dưới.

  6. Trong hộp thoại Bending Line, chỉnh sửa hai trong ba thuộc tính đầu tiên, ví dụ như Radius (khoảng cách từ bề mặt uốn đến tâm uốn) và Bending Angle (góc mà bề mặt của vùng mạch mềm sẽ uốn theo). Thuộc tính thứ ba - Affected area width (chiều rộng của phần bề mặt sẽ được uốn với Radius và Bending Angle đã cho) - sẽ được tính toán tự động (xem thêm bên dưới). Lưu ý rằng Affected area width của mỗi đường uốn được hiển thị dưới dạng một vùng tô màu cam.
  7. Trong hộp thoại Bending Line, đặt Fold Index theo yêu cầu để xác định trình tự gập các nếp uốn khi sử dụng thanh trượt Fold State trong bảng điều khiển PCB hoặc lệnh View » Fold/Unfold để gập bo mạch ở chế độ 3D. Nếp uốn có giá trị thấp nhất sẽ được áp dụng trước, lần lượt đến giá trị cao nhất.

Một vùng bo mạch phải được đánh dấu ô 3D Locked trong hộp thoại Board Region để xác định mặt phẳng tham chiếu vật lý cho chế độ hiển thị 3D (tại Z = 0). Nếu không thực hiện thao tác này, Affected area width của từng đường uốn đã xác định sẽ không được hiển thị.

Bạn cũng có thể truy cập hộp thoại Bending Line bằng cách nhấn Tab trong khi đặt hoặc di chuyển điểm điều khiển của đường uốn, hoặc bằng cách nhấp đúp vào điểm điều khiển của đường uốn.

Tóm tắt cách xác định nếp uốn

Đường uốn là một đối tượng dạng đường thẳng được đặt ngang qua một vùng để xác định vị trí, bán kính và góc uốn sẽ áp dụng cho vùng mạch mềm đó của bo mạch.

Xác định đường uốn:

  • Các đường uốn được đặt trong chế độ lập kế hoạch bo mạch (phím tắt 1).
  • Để đặt đường uốn, chạy lệnh Design » Define Bending Line.
  • Đặt đường uốn ngang qua vùng mạch mềm của bo mạch. Điểm đầu và điểm cuối của đường uốn không nhất thiết phải chạm chính xác vào từng mép của vùng; phần mềm sẽ tự động kéo dài (nếu quá ngắn) hoặc thu ngắn (nếu quá dài) đường uốn. Ít nhất một đầu của đường uốn phải chạm hoặc vượt qua mép của vùng.
  • Để chỉnh sửa thuộc tính của đường uốn, nhấp vào vị trí bất kỳ trong vùng để hiển thị các đỉnh của tất cả đường uốn trong vùng đó, sau đó:
    • Nhấp đúp vào đỉnh của một đường uốn để mở hộp thoại Đường uốn, hoặc
    • Hiển thị bảng điều khiển PCB và đặt bảng ở chế độ Layer Stack Regions, tại đây bạn có thể xem và chỉnh sửa các vùng cũng như đường uốn.
    • Đặt Bending Angle và Radius của nếp uốn theo yêu cầu.
    • Các nếp uốn được gập theo thứ tự Fold Index của chúng; hãy sử dụng tính năng này khi cần kiểm tra thứ tự gập.
  • Để di chuyển đường uốn, nhấp và kéo từng đỉnh.
  • Có thể xóa đường uốn bằng cách nhấp và giữ một trong các đỉnh, sau đó nhấn Delete trên bàn phím.
  • Không thể áp dụng đường uốn cho mép của phần khoét bo mạch. Nếu bo mạch của bạn yêu cầu điều này, hãy chuyển sang chế độ mạch cứng-mềm nâng cao.
AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents