Xác định các yêu cầu thiết kế bằng Constraint Manager
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Bạn sẽ học cách kiểm tra xem Constraint Manager có khả dụng cho dự án của mình hay không, cũng như hiểu ý nghĩa của việc dự án vẫn đang sử dụng phương thức quản lý quy tắc trước đây.
- Bạn sẽ tìm hiểu cách tổ chức của Constraint Manager, các loại ràng buộc có thể định nghĩa trong từng chế độ xem và cách truy cập công cụ này từ trình biên tập sơ đồ nguyên lý hoặc PCB.
- Bạn sẽ nắm được những thao tác quan trọng trong công việc hằng ngày, bao gồm lưu và làm mới các thay đổi, xem giá trị mặc định và giá trị tùy chỉnh, cũng như định nghĩa khoảng cách cách điện trong ma trận.
Constraint Manager là giao diện người dùng dạng tài liệu, tương tự bảng tính, cho phép bạn xem, tạo và quản lý các ràng buộc thiết kế được sử dụng cho thiết kế PCB của mình.
Một số ưu điểm của việc sử dụng Constraint Manager, đặc biệt đối với các thiết kế phức tạp có nhiều net, lớp đối tượng, v.v., bao gồm:
-
Khả dụng ở cấp dự án, giúp việc truy cập chức năng quản lý ràng buộc thiết kế tương tự nhau trong cả môi trường vẽ sơ đồ nguyên lý và thiết kế PCB.
-
Chuyển từ việc xác định phạm vi áp dụng quy tắc dựa trên truy vấn sang đối chiếu loại đối tượng được áp dụng, giúp đơn giản hóa việc tạo quy tắc ràng buộc.
-
Sử dụng các bộ ràng buộc để đẩy nhanh quá trình xác định các ràng buộc.
-
Độ ưu tiên của quy tắc được tự động xác định dựa trên hệ thống phân cấp tự nhiên của các đối tượng thiết kế.
-
Sử dụng giao diện trình bày dạng tài liệu thay vì hộp thoại giúp trình biên tập sơ đồ nguyên lý và PCB cùng các chức năng liên quan vẫn hoạt động và có thể truy cập.
Truy cập Constraint Manager
Để truy cập Constraint Manager, chọn lệnh Design » Constraint Manager từ các menu chính của trình biên tập sơ đồ nguyên lý hoặc PCB.

Truy cập Constraint Manager từ trình biên tập sơ đồ nguyên lý

Truy cập Constraint Manager từ trình biên tập PCB
Các loại ràng buộc
Sử dụng các nút ở góc trên bên trái của Constraint Manager để chuyển đổi giữa các chế độ xem nhằm xác định các loại ràng buộc khác nhau.
Lưu ý khi làm việc với Constraint Manager:
-
Sử dụng tùy chọn Units trong bảng Properties (hoặc các tùy chọn tương ứng trong menu con Tools » Measurement Units thuộc các menu chính; phím tắt:
Ctrl+Q) để chuyển đổi giữa các đơn vị đo (mm hoặc mils) của các giá trị hiển thị trong vùng lưới của Constraint Manager. -
Sử dụng tùy chọn Show Default Values trong bảng Properties (hoặc tùy chọn tương ứng trong menu chính View hoặc menu con View Options thuộc menu chuột phải của vùng lưới) để bật/tắt hiển thị các giá trị mặc định (ví dụ: các giá trị kế thừa từ lớp net hoặc cặp vi sai) trong Constraint Manager. Khi được hiển thị, các giá trị mặc định này xuất hiện trong vùng lưới của Constraint Manager bằng màu xám. Các giá trị tùy chỉnh được hiển thị trong vùng lưới của Constraint Manager bằng màu trắng.
-
Khi ở chế độ xem Physical hoặc Electrical, sử dụng tùy chọn Show Only Object Custom Values trong bảng Properties (hoặc tùy chọn tương ứng trong menu chính View hoặc menu con View Options thuộc menu chuột phải của vùng lưới) để bật/tắt hiển thị các mục đối tượng có giá trị mặc định (tức là lọc bỏ các mục có giá trị mặc định khi tùy chọn này được bật).
-
Hỗ trợ sao chép và dán giá trị từ/vào các ô – sử dụng các lệnh trong menu con Copy/Paste Values của menu ngữ cảnh hoặc các phím tắt
Ctrl+CvàCtrl+V. -
Sử dụng trường Search ở góc trên bên phải của Constraint Manager để lọc danh sách đối tượng bằng cách nhập chuỗi tìm kiếm. Nhấp vào biểu tượng
ở bên phải thanh Search để xóa chuỗi tìm kiếm hiện tại.
-
Sử dụng trường Comment ở cuối Constraint Manager khi một ô của ràng buộc/quy tắc được chọn để thêm chú thích cho ràng buộc/quy tắc đó, ví dụ như mô tả rõ mục đích sử dụng của nó Khi phần dưới của Constraint Manager cho phép xác định ràng buộc cho nhiều quy tắc khác nhau, bạn có thể thêm chú thích riêng cho từng quy tắc bằng cách chuyển quy tắc hiện tại qua danh sách thả xuống Rule
-
Bạn phải thực hiện thao tác lưu trong Constraint Manager trước khi các thay đổi được áp dụng vào thiết kế. Để thực hiện việc này, hãy dùng lệnh File » Save (khi truy cập Constraint Manager từ sơ đồ nguyên lý) hoặc File » Save to PCB (khi truy cập Constraint Manager từ PCB) trong các menu chính của Constraint Manager hoặc phím tắt
Ctrl+S. -
Khi lưu lần đầu trong Constraint Manager được truy cập từ phía sơ đồ nguyên lý, tài liệu ràng buộc sơ đồ nguyên lý (
Constraints.xml) sẽ được thêm vào dự án và có thể truy cập qua bảng Projects (trong thư mục con Settings/Constraints – Ngoài ra, dữ liệu ràng buộc trong tài liệu sẽ được tải lại/làm mới sau khi cập nhật dự án từ Workspace được kết nối. -
Nếu có bất kỳ thay đổi nào trong thiết kế sơ đồ nguyên lý hoặc cấu trúc lớp PCB (thay đổi ảnh hưởng đến các lớp và/hoặc cấu hình trở kháng), hãy nhấp vào nút
ở đầu Constraint Manager (được truy cập từ trình biên tập tương ứng) để cập nhật các thay đổi này trong Constraint Manager. Nhấp vào nút này cũng cho phép bạn nhập các chỉ thị từ sơ đồ nguyên lý vào Constraint Manager – tìm hiểu thêm. Nếu bạn có các thay đổi trong Constraint Manager chưa được lưu, một hộp thoại sẽ xuất hiện để xác nhận, cảnh báo rằng các thay đổi này sẽ bị mất.
-
Các tùy chọn toàn cục sau đây có sẵn trong vùng Clearances Settings của bảng Properties từ các chế độ xem Clearances và Physical khi Constraint Manager được truy cập từ sơ đồ nguyên lý hoặc PCB:
-
Ignore Pad to Pad clearances within a footprint – sử dụng tùy chọn này để áp dụng thiết lập cho tất cả các quy tắc khoảng cách đã xác định. Tùy chọn này cho phép bạn chỉ định có bỏ qua khoảng cách giữa các pad trong cùng footprint linh kiện hay không.
-
Apply zero Keepout clearance – khi tùy chọn này được bật, một quy tắc khoảng cách mặc định với khoảng cách bằng ‘0’ được áp dụng giữa vùng cấm và tất cả các đối tượng nguyên thủy khác trong thiết kế. Lưu ý rằng quy tắc này không hiển thị trong bất kỳ chế độ xem nào của Constraint Manager, do đó không thể chỉnh sửa. Nếu bị tắt, các giá trị thông thường trong ma trận khoảng cách sẽ được áp dụng.
-
-
Bạn có thể nhanh chóng hoàn tác hoặc làm lại các thay đổi trong Constraint Manager bằng cách sử dụng
ở góc trên bên trái của không gian thiết kế hoặc sử dụng Edit » Undo/Redo từ các menu chính. Chức năng này có sẵn trong hầu hết các khu vực, bao gồm quy tắc, phạm vi áp dụng và bộ ràng buộc. Như trong các khu vực khác của phần mềm, các biểu tượng/lệnh chỉ khả dụng khi đã thực hiện một thao tác (để hoàn tác) hoặc thao tác hoàn tác (để làm lại).
Làm việc với ma trận khoảng cách
Theo mặc định, ma trận khoảng cách trong chế độ xem Clearances của Constraint Manager có một mục từ All Net Classes đến All Net Classes, cho phép bạn xác định giá trị khoảng cách mặc định giữa bất kỳ net nào trong thiết kế. Sử dụng điều khiển Add ở góc trên bên trái của ma trận (hoặc nhấp chuột phải vào một ô bất kỳ trong ma trận khoảng cách và sử dụng lệnh Add từ menu ngữ cảnh) để hiển thị cửa sổ bật lên chứa danh sách các lớp net và lớp cặp vi sai hiện đã được xác định. Chọn một hoặc nhiều lớp cần thiết (có thể chọn nhiều mục lớp bằng thao tác Shift+Click hoặc Ctrl+Click) rồi nhấp vào nút Add. Một hàng và một cột cho mỗi lớp đã chọn sẽ được thêm vào ma trận.
Nhấp vào ô tại giao điểm giữa hàng và cột của hai lớp để chọn ô đó và hiển thị các thiết lập khoảng cách chi tiết ở phần dưới của Constraint Manager, nơi bạn có thể xác định các giá trị khoảng cách cụ thể giữa các đối tượng khác nhau và trên các lớp khác nhau.
Sử dụng trường Clearance ở phần dưới để nhập giá trị cần thiết; giá trị này sẽ được áp dụng cho tất cả các cặp đối tượng và tất cả các lớp của cặp lớp này. Ngoài ra, bạn có thể nhấp đúp vào một ô trong ma trận ở phần trên để nhập trực tiếp giá trị cần thiết.
Nhập các giá trị khoảng cách cần thiết cho từng cặp đối tượng cụ thể trong bảng. Lưu ý rằng ô trong ma trận khoảng cách hiển thị khoảng giá trị nhỏ nhất đến lớn nhất được xác định trong bảng.
Lưu ý khi làm việc với chế độ xem Clearances:
-
Khi một ô trong ma trận khoảng cách được chọn, việc nhập giá trị vào ô đó hoặc vào trường Clearance sẽ tự động áp dụng giá trị này cho tất cả các trường trong vùng bảng ở phần dưới của Constraint Manager. Bạn chỉ cần chỉnh sửa trong vùng bảng khi muốn xác định khoảng cách dựa trên loại đối tượng.
-
Trong các thiết lập khoảng cách chi tiết ở phần dưới của Constraint Manager, bạn cũng có thể bật ràng buộc Creepage cho các lớp đã chọn và xác định giá trị khoảng cách đường rò Ràng buộc này kiểm tra khoảng cách đường rò giữa các tín hiệu được chỉ định trên bề mặt bo mạch, qua các lỗ không mạ, phần khoét và quanh mép bo mạch.
-
Trong các thiết lập khoảng cách chi tiết ở phần dưới của Constraint Manager, bạn cũng có thể bật ràng buộc Z-Axis Clearance cho các lớp đã chọn và xác định giá trị khoảng cách theo trục Z Ràng buộc này được dùng để kiểm tra khoảng cách tối thiểu giữa các đối tượng nguyên thủy trên các lớp đồng khác nhau.
-
Để đặt lại giá trị khoảng hở cho một cặp đối tượng cụ thể (ví dụ: cặp Track với Track) về giá trị mặc định (tức là giá trị được xác định cho mục All Net Classes với All Net Classes), hãy chọn ô tương ứng trong bảng phía dưới rồi nhấn phím
Delete, hoặc nhấp chuột phải vào ô và chọn lệnh Reset to Default từ menu ngữ cảnh. -
Để đặt lại giá trị khoảng hở cho tất cả các cặp đối tượng thuộc một mục cụ thể trong ma trận khoảng hở (ví dụ: mục giữa một lớp net và một lớp net khác) về giá trị mặc định, hãy nhấp chuột phải vào ô tương ứng trong ma trận khoảng hở và chọn lệnh Remove Rule từ menu ngữ cảnh.
-
Để xóa một lớp khỏi ma trận khoảng hở, hãy nhấp chuột phải vào ô bất kỳ trong hàng của lớp đó trong ma trận khoảng hở và chọn lệnh Remove Scope từ menu ngữ cảnh.
Cấu hình khoảng hở theo lớp
Sử dụng các tab bên dưới bảng, bạn cũng có thể xác định giá trị khoảng hở theo lớp. Sử dụng điều khiển Add để thêm tab cho một lớp cụ thể.
Lọc lớp
Để làm việc hiệu quả với số lượng lớn các lớp trong chế độ xem Clearances, bạn có thể sử dụng tính năng lọc/nhóm. Tính năng này cho phép tạo các bộ lọc (hoặc nhóm) lớp để chuyển đổi giữa các tập con cụ thể của ma trận khoảng hở và làm việc với chúng.
Sử dụng nút
ở góc trên bên phải của chế độ xem Clearances để mở cửa sổ bật lên, nơi bạn có thể tạo, chỉnh sửa, xóa và bật/tắt các bộ lọc.
Làm việc với các ràng buộc vật lý và điện
Trong chế độ xem Physical hoặc Electrical của Constraint Manager, hãy nhấp vào một ô trong vùng lưới để hiển thị các thiết lập của quy tắc tương ứng ở phần dưới của Constraint Manager, nơi bạn có thể xác định các giá trị ràng buộc.
Có thể cấu hình các ràng buộc sau trong chế độ xem Physical:
-
Width – ràng buộc này xác định độ rộng của các đường mạch được đặt trên các lớp tín hiệu.
-
Diff Pair Gap – ràng buộc này xác định khoảng hở (hoặc khe hở) giữa các net trong các cặp vi sai thuộc phạm vi áp dụng.
-
Clearance – ràng buộc này xác định khoảng hở tối thiểu được phép giữa các đối tượng của các net thuộc phạm vi áp dụng và các đối tượng của các net khác trong thiết kế.
-
Via Style – ràng buộc này xác định kiểu via có thể sử dụng khi đi dây. Bạn có thể xác định các giá trị Tối thiểu/Tối đa/Ưu tiên cụ thể cho đường kính và kích thước lỗ của via (Min/Max Preferred), hoặc sử dụng các mẫu có sẵn cho thiết kế bo mạch (Templates) khi truy cập Constraint Manager từ PCB hoặc khi cấu hình ràng buộc cho một bộ xếp chồng lớp cụ thể (tìm hiểu thêm).
-
Polygon Connect – ràng buộc này xác định kiểu kết nối từ pad linh kiện hoặc via trên đường mạch đến vùng đổ đồng polygon.
Để biết thêm thông tin về các giá trị ràng buộc, hãy tham khảo trang Các loại quy tắc mặt phẳng.
-
Same Net Clearance – ràng buộc này xác định khoảng hở tối thiểu được phép giữa hai đối tượng cơ bản bất kỳ thuộc cùng một net (ví dụ: giữa via và pad trên cùng một net, hoặc giữa hai đoạn đường mạch trong cùng một net).
-
Routing Neck Down – ràng buộc này xác định chiều dài tối đa được phép của các đường đi dây liên tục có độ rộng nằm giữa Min Width và Preferred Width được xác định bởi ràng buộc Độ rộng áp dụng.
Có thể cấu hình các ràng buộc sau trong chế độ xem Electrical:
-
Tab Nets:
-
Topology – ràng buộc này xác định cấu trúc liên kết được sử dụng khi đi dây các net trên bo mạch. Cấu trúc liên kết của một net là cách sắp xếp hoặc mô hình các kết nối từ chân đến chân.
Để biết thêm thông tin về các giá trị ràng buộc, hãy tham khảo trang Các loại quy tắc đi dây.
-
Impedance – ràng buộc này quy định trở kháng tối thiểu và tối đa cho phép của net.
-
All Layer Sets – ràng buộc này quy định những lớp được phép sử dụng để đi dây.
-
Maximum Via Count – ràng buộc này quy định số lượng via tối đa cho phép.
-
Min / Max Total Length – ràng buộc này quy định chiều dài tối thiểu và tối đa của net.
-
Max Stub Length – ràng buộc này quy định chiều dài đoạn cụt tối đa cho phép đối với net có cấu trúc liên kết chuỗi.
-
Max Via Stub Length – đoạn cụt là phần chiều dài của thân via hoặc pad nhô ra ngoài lớp tín hiệu cuối cùng được sử dụng mà via/pad kết nối tới. Khoan ngược sẽ được áp dụng cho các via/pad phù hợp trong những net được nhắm tới, theo các hộp kiểm Layer chỉ định mặt bo mạch đã bật và các cặp khoan ngược được định nghĩa trên tab Back Drills của Layer Stack Manager.
Để biết thêm thông tin về các giá trị ràng buộc, hãy tham khảo trang Các loại quy tắc tốc độ cao.
Để biết thêm thông tin về khoan ngược, hãy tham khảo trang Khoan có kiểm soát độ sâu (Khoan ngược).
-
-
Tab Diff Pairs :
-
Impedance – ràng buộc này quy định trở kháng tối thiểu và tối đa cho phép của net.
-
Gap – ràng buộc này quy định khoảng cách (hoặc khe hở) giữa các net trong những cặp vi sai thuộc phạm vi áp dụng.
-
Width – ràng buộc này quy định chiều rộng cho phép của đường mạch khi đi dây cặp vi sai.
-
Max Uncoupled Length – ràng buộc này quy định chiều dài không ghép cặp tối đa cho phép giữa net dương và net âm trong cặp vi sai.
-
Tolerance – ràng buộc này quy định dung sai chiều dài khi so sánh với net dài nhất trong cặp vi sai.
-
Dynamic Phase Tolerance – ràng buộc này quy định độ lệch pha cho phép giữa các đường mạch trong cặp vi sai; khi vượt quá giá trị này, cần thực hiện bù.
-
Matching Distance – ràng buộc này quy định khoảng cách sau khi vượt quá dung sai mà trong đó phải thực hiện bù.
-
-
Tab xSignals:
-
Tolerance – ràng buộc này quy định dung sai chiều dài khi so sánh từng xSignal trong lớp xSignal với xSignal được chọn làm Matching Target cho lớp đó.
-
Lưu ý khi làm việc với chế độ xem Physical hoặc Electrical:
-
Constraint Manager tự động xác định mức ưu tiên của các quy tắc trong những chế độ xem này: mức ưu tiên được sắp xếp từ All (thấp nhất), đến lớp đối tượng, rồi đến đối tượng (cao nhất).
-
Để xóa các giá trị ràng buộc tùy chỉnh được định nghĩa bởi một quy tắc cụ thể (tức là đặt lại các giá trị của quy tắc này về mặc định), hãy nhấp chuột phải vào ô tương ứng trong bảng và chọn lệnh Remove rule từ menu ngữ cảnh.
-
Để xóa các giá trị ràng buộc tùy chỉnh của tất cả quy tắc cho một đối tượng, hãy nhấp chuột phải vào ô bất kỳ trong hàng của đối tượng đó trong bảng và chọn lệnh Remove rules from scope từ menu ngữ cảnh.
-
Tất cả các nút, ngoại trừ những nút được định nghĩa sẵn (ví dụ: All Nets), đều được thu gọn theo mặc định trong các chế độ xem Physical và Electrical . Bạn có thể sử dụng các lệnh Expand All và Collapse All trong menu chuột phải để điều khiển các nút trong bảng.
-
Khi nhập một giá trị trong bảng phía trên của chế độ xem Physical cho một net hoặc xNet đơn lẻ (Min Width hoặc Preferred Width), một cặp vi sai (Min Width, Preferred Width hoặc Preferred Diff Pair Gap) hoặc một lớp net/xNet/cặp vi sai, giá trị này sẽ được truyền đến các trường chiều rộng (Min Width/Preferred Width/Max Width) hoặc khe hở (Min Gap/Preferred Gap/Max Gap) tương ứng trong các vùng ràng buộc bên dưới. Lưu ý rằng giá trị đã nhập chỉ được truyền đến các trường khác nếu đối tượng chưa có quy tắc cụ thể được định nghĩa.
-
Khi định nghĩa các giá trị tối thiểu, tối đa và ưu tiên cho chiều rộng đi dây và khe hở cặp vi sai trong chế độ xem Physical, bảng Values by Layer ở phía dưới chế độ xem sẽ tô đỏ các mục nhập không hợp lệ. Điều này có thể xảy ra, chẳng hạn, khi bạn chỉ định giá trị ràng buộc tối thiểu lớn hơn giá trị ràng buộc tối đa. Định nghĩa ràng buộc không chính xác cũng được làm nổi bật bằng cách hiển thị các giá trị chiều rộng/khe hở bằng màu đỏ trong bảng phía trên của chế độ xem.
Cấu hình giá trị ràng buộc theo từng lớp
Khi truy cập Constraint Manager từ sơ đồ nguyên lý, bạn có thể cấu hình các ràng buộc Chiều rộng và Đi dây cặp vi sai cho các lớp trong một cấu trúc lớp đã chọn.
Sử dụng danh sách thả xuống ở phía trên Constraint Manager để chọn mục tương ứng với một tài liệu PCB cụ thể trong dự án thiết kế. Nếu PCB đã chọn chứa nhiều cấu trúc lớp, bạn có thể chọn cấu trúc cần cấu hình ràng buộc bằng các tab ở phần dưới của Constraint Manager khi quy tắc tương ứng được chọn. Ngoài ra, bạn có thể sử dụng một Hồ sơ trở kháng đã chọn (nếu được định nghĩa trong cấu trúc lớp của PCB đã chọn).
Định nghĩa cặp vi sai
Cặp vi sai được tạo từ chế độ xem Physical hoặc từ tab Diff Pairs của chế độ xem Electrical trong Constraint Manager. Để Constraint Manager tạo cặp vi sai từ các net, các net cần ghép cặp phải có quy tắc đặt tên nhất quán (tức là có chung phần tên gốc, theo sau là hậu tố dương/âm nhất quán, ví dụ: TX0_P và TX0_N).
Nhấp chuột phải vào vị trí bất kỳ trong vùng bảng của chế độ xem Physical hoặc tab Diff Pairs của chế độ xem Electrical, rồi chọn lệnh Differential Pairs » Create Differential Pairs From Nets từ menu ngữ cảnh để mở hộp thoại Create Differential Pairs From Nets và định nghĩa các tùy chọn tạo cặp vi sai. Các bộ lọc ở phía trên hộp thoại cho phép bạn nhanh chóng xác định các net này theo lớp net mà chúng thuộc về và dấu hiệu phân biệt cụ thể được dùng để phân biệt net dương và net âm trong cặp dự kiến, ví dụ: _P và _N. Bạn cũng có thể định nghĩa tiền tố để thêm vào các đối tượng cặp vi sai được tạo và xác định lớp cặp vi sai mà chúng sẽ được thêm vào.
Đối với mỗi đối tượng cặp vi sai, hộp thoại liệt kê các net dương và âm cấu thành cặp đó. Theo mặc định, tất cả các đối tượng cặp vi sai dự kiến đều được chọn để tạo; bạn có thể loại trừ từng đối tượng bằng cách bỏ chọn hộp kiểm Create tương ứng.
Khi tất cả tùy chọn đã được thiết lập theo yêu cầu, hãy nhấp vào nút
– các đối tượng cặp vi sai sẽ được tạo và hiển thị trong chế độ xem Physical của Constraint Manager, với các net cấu thành được liệt kê bên dưới từng mục.
Cặp vi sai cũng có thể được tạo từ xNets. Sử dụng danh sách thả xuống ở phía trên hộp thoại Create Differential Pairs From Nets để chọn All xNets hoặc một lớp xNet cụ thể. Khi các tùy chọn khác trong hộp thoại đã được cấu hình theo yêu cầu, hãy nhấp vào nút
để tạo các cặp vi sai tương ứng.
Để xóa một cặp vi sai, nhấp chuột phải vào mục tương ứng và chọn lệnh Differential Pairs » Remove Differential Pair từ menu ngữ cảnh. Bạn cũng có thể xóa nhiều cặp vi sai bằng cách chọn các mục tương ứng bằng kỹ thuật Ctrl+Click, Shift+Click hoặc Click, Hold&Drag, nhấp chuột phải vào vùng chọn rồi chọn lệnh Differential Pairs » Remove Differential Pair từ menu ngữ cảnh.
Tab Diff Pairs của chế độ xem Electrical cũng có thể được dùng để quản lý trực tiếp các cặp vi sai. Tab này hiển thị danh sách phân cấp các cặp vi sai trong thiết kế. Chọn một ô của cặp vi sai hoặc lớp cặp vi sai để hiển thị các ràng buộc tương ứng ở phần dưới của Constraint Manager.
Định nghĩa xNet
Một đường dẫn từ linh kiện nguồn đến linh kiện đích đi qua một hoặc nhiều linh kiện mắc nối tiếp có thể được định nghĩa là một xNet.
Các danh sách tiền tố ký hiệu linh kiện, phân cách bằng dấu phẩy, dùng để xác định linh kiện nguồn hoặc đích (Sources/Destinations) và linh kiện mắc nối tiếp (Discretes) có thể được thiết lập trong vùng xNets Creation của tab Options trong hộp thoại Project Options.

Vùng xNets Creation của tab Options trong hộp thoại Project Options

Ví dụ về một đường dẫn có thể được định nghĩa là xNet trong Constraint Manager (theo các thiết lập tạo xNet hiển thị ở trên)
Trong chế độ xem Physical hoặc Electrical của Constraint Manager (khi truy cập từ sơ đồ nguyên lý hoặc PCB), nhấp chuột phải vào net cần đưa vào xNet mới rồi chọn lệnh xNets » Create xNets From Selected Nets từ menu ngữ cảnh. Một xNet mới sẽ được tạo và hiển thị trong chế độ xem Physical hoặc Electrical của Constraint Manager, với các net thành phần được liệt kê bên dưới mục tương ứng.
Việc tạo xNet cũng hỗ trợ các linh kiện mắc nối tiếp có nhiều hơn hai chân. Các loại linh kiện mắc nối tiếp sau được hỗ trợ:
-
Dual-inline component with an even number of pins – có thể tạo xNet từ các net nối với chân đầu tiên và chân cuối cùng của linh kiện, tiếp theo là chân thứ hai và chân áp chót, v.v.
-
Single-inline component with an even number of pins – có thể tạo xNet từ các net nối với chân thứ nhất và chân thứ hai của linh kiện, tiếp theo là chân thứ ba và chân thứ tư, v.v. Lưu ý rằng linh kiện phải có tham số tên là
PinPairsConfigurationvới giá trịSIP; nếu không, xNet sẽ được tạo như đối với linh kiện hai hàng chân. -
Component with an odd number of pins – một xNet được tạo từ các net nối với tất cả các chân của linh kiện.
Để xóa một xNet, nhấp chuột phải vào mục tương ứng và chọn lệnh xNets » Remove xNet từ menu ngữ cảnh. Bạn cũng có thể xóa nhiều xNet bằng cách chọn các mục tương ứng bằng kỹ thuật Ctrl+Click, Shift+Click hoặc Click, Hold&Drag, nhấp chuột phải vào vùng chọn rồi chọn lệnh xNets » Remove xNet từ menu ngữ cảnh.
Định nghĩa xSignal
Từ Constraint Manager, bạn cũng có thể định nghĩa xSignal – các đường dẫn tín hiệu do người dùng xác định giữa hai nút trên PCB. Trong chế độ xem Electrical của Constraint Manager, chọn ô trong cột Topology của một net hoặc xNet, chọn Custom từ danh sách thả xuống ở phần dưới của Constraint Manager, rồi sử dụng các điều khiển được cung cấp để định nghĩa cấu trúc liên kết tùy chỉnh và chọn các xSignal tương ứng.
Ví dụ về cách định nghĩa xSignal cho một xNet hiển thị bên dưới sẽ được mô tả và minh họa tiếp sau.

Ví dụ về xNet cần tạo xSignal.
Có thể định nghĩa cấu trúc liên kết tùy chỉnh bằng đồ thị cấu trúc liên kết ở phần dưới của Constraint Manager. Sử dụng menu chuột phải trong vùng đồ thị để thêm và xóa các nút, đổi loại nút từ Source sang Destination và ngược lại, đồng thời Click, Hold&Drag các nút để định nghĩa cấu trúc liên kết.
Danh sách các xSignal được đề xuất (được đặt tên theo quy tắc <SourceNetName> (<SourcePinDesignator> → <DestinationPinDesignator>)) xuất hiện ở bên phải vùng lưới. Danh sách được chia thành hai nhóm: xSignal đi từ nguồn đến đích (S-T) và xSignal đi từ một đích đến một đích khác (T-T). Sử dụng các hộp kiểm cho từng nhóm hoặc từng xSignal để chọn/bỏ chọn các xSignal cần tạo. Các xSignal được chọn sẽ xuất hiện trên tab xSignals của chế độ xem Electrical.
Ví dụ về tạo xSignal bằng đồ thị cấu trúc liên kết
Đối với một lớp xSignal đã tạo (tham khảo phần Định nghĩa lớp bên dưới để biết chi tiết), có thể định nghĩa ràng buộc Tolerance và chọn một xSignal trong lớp này làm Matching Length. Khi truy cập Constraint Manager từ phía PCB, các cột Actual Value và Margin cũng khả dụng.
Trong tài liệu PCB, có thể duyệt các xSignal đã định nghĩa từ bảng PCB ở chế độ xSignals. Các From-To tương ứng cũng sẽ được tạo và có thể được duyệt từ bảng PCB ở chế độ From-To Editor.
Định nghĩa lớp
Constraint Manager cho phép bạn định nghĩa các lớp net, cặp vi sai, xNet và xSignal.
-
Để thêm các đối tượng trong chế độ xem Physical hoặc Electrical của Constraint Manager vào một lớp hiện có, hãy chọn nhiều mục đối tượng bằng kỹ thuật
Ctrl+Click,Shift+ClickhoặcClick, Hold&Drag, sau đó nhấp chuột phải vào vùng chọn và chọn lớp cần thiết từ menu con Classes » Add Selected to Class của menu ngữ cảnh.Khi có hơn 30 lớp, lệnh Classes » Add Selected to Class » Existing Class sẽ được hiển thị thay cho danh sách các lớp. Sử dụng lệnh này để mở hộp thoại nơi bạn có thể chọn một lớp hiện có để thêm các đối tượng đã chọn vào.
-
Để thêm một lớp mới gồm các đối tượng được liệt kê trong chế độ xem Physical hoặc Electrical của Constraint Manager, hãy chọn các đối tượng đó, sau đó nhấp chuột phải vào vùng chọn và chọn lệnh Classes » Add Selected to Class » New Class từ menu ngữ cảnh để mở hộp thoại Add Class. Xác định Name của lớp (phải duy nhất và không được để trống) cùng tập hợp các thành viên của lớp. Các đối tượng được chọn trước khi mở hộp thoại sẽ có sẵn trong danh sách Member. Nếu cần, hãy cấu hình thêm tập hợp thành viên của lớp bằng cách di chuyển các mục đối tượng giữa danh sách Non-Members và Member bằng các nút mũi tên.
-
Ngoài ra, hãy nhấp chuột phải trong vùng lưới và chọn lệnh Classes » Add Class trong chế độ xem Clearances hoặc Electrical hoặc một lệnh từ (để thêm một lớp net) hoặc menu con Classes » Add Class để mở hộp thoại Add Class. Khi mở hộp thoại theo cách này, các danh sách Member ban đầu sẽ trống.
-
Để loại bỏ các đối tượng khỏi lớp mà chúng hiện đang thuộc về, hãy chọn các đối tượng đó, sau đó nhấp chuột phải vào vùng chọn và chọn lệnh Classes » Remove Selected from Class từ menu ngữ cảnh.
-
Để chỉnh sửa một lớp, hãy nhấp chuột phải vào mục của lớp đó và chọn lệnh Classes » Edit Class từ menu ngữ cảnh để mở hộp thoại Edit Class, nơi bạn có thể chỉnh sửa tên và các thành viên của lớp.
-
Để xóa một lớp hiện có, hãy nhấp chuột phải vào mục của lớp đó và chọn lệnh Classes » Remove Class từ menu ngữ cảnh. Bạn cũng có thể xóa nhiều lớp bằng cách chọn các mục của chúng bằng kỹ thuật
Ctrl+Click,Shift+ClickhoặcClick, Hold&Drag, nhấp chuột phải vào vùng chọn rồi chọn lệnh Classes » Remove Class từ menu ngữ cảnh.
Ngoài ra, bạn có thể sử dụng hộp thoại Object Class Explorer để thêm, chỉnh sửa và xóa các lớp. Nhấp chuột phải trong vùng lưới và chọn lệnh Classes » Class Explorer từ menu ngữ cảnh để mở hộp thoại.
Ngăn cây thư mục ở bên trái hộp thoại liệt kê các loại lớp đối tượng được hỗ trợ và các lớp đối tượng hiện có của từng loại.
- Nhấp vào thư mục gốc Object Classes để xem danh sách tổng hợp trong vùng chỉnh sửa chính của hộp thoại, bao gồm tất cả các lớp cụ thể đã được định nghĩa trên mọi loại lớp đối tượng.
- Nhấp vào một thư mục con tương ứng với loại lớp đối tượng để xem danh sách tổng hợp tất cả các lớp cụ thể đã được định nghĩa cho loại đó.
- Nhấp vào mục của một lớp cụ thể (hoặc nhấp đúp vào mục của lớp đó trong danh sách tổng hợp) để truy cập các điều khiển dùng để quản lý các đối tượng thành viên của lớp.
Để thêm một lớp mới do người dùng định nghĩa từ hộp thoại Object Class Explorer, hãy nhấp chuột phải trong danh mục lớp bạn muốn tạo và chọn Add Class từ menu ngữ cảnh. Để đổi tên hoặc xóa một lớp do người dùng định nghĩa, hãy nhấp chuột phải vào tên lớp và chọn lần lượt Rename Class hoặc Delete Class.
Bộ ràng buộc
Để đẩy nhanh quá trình định nghĩa các ràng buộc cho đối tượng, Constraint Manager cho phép lưu một tập hợp ràng buộc thành một Bộ ràng buộc, rồi áp dụng Bộ ràng buộc này cho các đối tượng.
Để lưu tập hợp ràng buộc hiện được định nghĩa cho một đối tượng thành một Bộ ràng buộc, hãy nhấp chuột phải vào một ô của đối tượng này và chọn lệnh Save as Constraint Set từ menu ngữ cảnh. Trong cửa sổ bật lên New Constraint Set, nhập tên mong muốn cho Bộ ràng buộc (phải duy nhất và không được để trống), rồi nhấp vào Create.
Bộ ràng buộc mới tạo sẽ được áp dụng cho đối tượng dùng để tạo Bộ ràng buộc đó. Để áp dụng Bộ ràng buộc cho một đối tượng khác, hãy nhấp chuột phải vào ô của đối tượng đó và chọn Bộ ràng buộc cần thiết từ menu con Select Constraint Set của menu ngữ cảnh. Các ô được áp dụng Bộ ràng buộc sẽ được đánh dấu bằng một biểu tượng ở góc trên bên trái (ví dụ: , và trong các chế độ xem Physical hoặc Electrical, tên của Bộ ràng buộc được áp dụng sẽ hiển thị trong cột Constraint Set.
Để chỉnh sửa các giá trị của một Bộ ràng buộc hiện có, hãy chọn một đối tượng được áp dụng Bộ ràng buộc này và nhấp vào
nút. Thay đổi các giá trị ràng buộc theo yêu cầu, rồi nhấp vào nút Save trong cửa sổ bật lên để lưu các thay đổi. Các thay đổi sẽ được áp dụng cho tất cả các đối tượng hiện đang được gán Bộ ràng buộc đó.
Các Bộ ràng buộc hiện được định nghĩa được liệt kê trong vùng Constraint Sets của bảng Properties. Nhấp vào mục của một Bộ ràng buộc để hiển thị các giá trị ràng buộc của bộ đó. Có thể xóa một Bộ ràng buộc được chọn trong bảng Properties bằng cách nhấp vào nút
ở cuối vùng Constraint Sets. Các đối tượng đã được gán Bộ ràng buộc bị xóa sẽ giữ nguyên các giá trị ràng buộc mà bộ này đã áp dụng trước khi bị xóa.
Nhập chỉ thị từ sơ đồ nguyên lý
Bạn có thể nhập các lớp net và lớp cặp vi sai, các cặp vi sai và các ràng buộc từ những chỉ thị thiết kế bộ tham số và cặp vi sai, được đặt và định nghĩa trên các tài liệu nguồn sơ đồ nguyên lý, vào Constraint Manager. Để thực hiện, nhấp vào nút
khi truy cập Constraint Manager từ phía sơ đồ nguyên lý. Hộp thoại Refresh Constraint Manager sẽ hiển thị bản tóm tắt quá trình nhập từ sơ đồ nguyên lý vào Constraint Manager; quá trình này sẽ được hoàn tất khi nhấp vào nút
trong hộp thoại.
Có chỉ báo trạng thái đồng bộ giữa một ràng buộc trong Constraint Manager và ràng buộc tương ứng được định nghĩa trong một chỉ thị đặt trên sơ đồ nguyên lý.
-
Khi một đối tượng trong sơ đồ nguyên lý có chỉ thị bộ tham số hoặc cặp vi sai được đặt trên đó, và chỉ thị này có các giá trị ràng buộc khác với giá trị được định nghĩa cho cùng đối tượng trong Constraint Manager, các giá trị này sẽ được đánh dấu bằng một thanh màu cam ở bên trái ô tương ứng trong chế độ xem Physical hoặc Electrical của Constraint Manager khi Constraint Manager được truy cập từ sơ đồ nguyên lý (ví dụ:
-
Khi các giá trị ràng buộc được đồng bộ giữa Constraint Manager và chỉ thị, chỉ báo sẽ chuyển thành thanh màu xanh lá (ví dụ:
Cũng có chỉ báo trạng thái đồng bộ cho các lớp net, cặp vi sai và lớp cặp vi sai được nhập từ các chỉ thị. Các thay đổi (phần tử mới/bị xóa) được phát hiện, và những điểm không nhất quán cần đồng bộ được chỉ báo bằng thanh màu cam ở bên trái tên đối tượng tương ứng (ví dụ: Trạng thái đã đồng bộ được chỉ báo bằng thanh màu xanh lá (ví dụ:
Lưu ý khi nhập chỉ thị vào Constraint Manager:
-
Mọi ràng buộc hiện có đã được định nghĩa cho net/lớp net/cặp vi sai/lớp cặp vi sai thông qua Constraint Manager sẽ được ưu tiên và giữ lại khi xử lý thao tác nhập. Do đó, nếu một giá trị ràng buộc đã được đồng bộ với một chỉ thị được chỉnh sửa trong Constraint Manager sau khi nhập, giá trị đó sẽ không được đồng bộ khi nhập lại sau đó.
-
Sau khi đồng bộ dữ liệu bằng cách nhập dữ liệu từ các chỉ thị vào Constraint Manager và lưu các thay đổi trong Constraint Manager:
-
Các chỉ thị đã nhập được phân biệt trong không gian thiết kế bằng màu xanh lam và một ký hiệu hơi khác
-
Có thể lọc bỏ các mục lớp và quy tắc đã nhập vào Constraint Manager bằng nút Constraint Manager ở đầu vùng Parameters của bảng Properties.
-
Với một chỉ thị bộ tham số gắn vào một dây đơn, dữ liệu liên quan từ Constraint Manager (tên lớp net/cặp vi sai và các thiết lập quy tắc) có thể được hiển thị gần chỉ thị đó trên trang sơ đồ nguyên lý. Với một chỉ thị bộ tham số có định nghĩa các lớp net và được gắn vào một vùng bao (blanket), sau khi đồng bộ/nhập với/vào Constraint Manager, cũng có thể bật/tắt hiển thị thông tin chỉ thị lớp net trong không gian thiết kế. Với một chỉ thị cặp vi sai được gắn vào một vùng bao, có thể bật/tắt hiển thị thông tin lớp cặp vi sai và các quy tắc liên quan trong không gian thiết kế sau khi đồng bộ/nhập các chỉ thị vào Constraint Manager. Sử dụng điều khiển hiển thị ở bên trái mục dữ liệu tương ứng trong bảng Properties khi chỉ thị được chọn.
-
Các điều khiển để thêm lớp net, lớp cặp vi sai hoặc lớp linh kiện mới hay xóa lớp hiện có sẽ bị vô hiệu hóa trong bảng Properties đối với các chỉ thị tương ứng.
-
Các điều khiển để thêm quy tắc mới hoặc chỉnh sửa/xóa quy tắc hiện có vẫn khả dụng trong bảng Properties đối với các chỉ thị tương ứng. Bạn cũng có thể chỉnh sửa tên của một lớp net. Để áp dụng các thay đổi về quy tắc và/hoặc tên lớp net của một chỉ thị đã nhập vào dữ liệu trong Constraint Manager, nhấp vào nút
khi truy cập Constraint Manager từ phía sơ đồ nguyên lý.
-
-
Đối với các quy tắc được thêm vào chỉ thị bộ tham số nhưng không xuất hiện trong các chế độ xem Physical và Electrical, những quy tắc đó sẽ tự động được tạo dưới dạng quy tắc nâng cao, hiển thị trong chế độ xem All Rules khi truy cập Constraint Manager từ PCB. Các quy tắc nâng cao được tạo sau khi hoàn tất nhập chỉ thị và thực hiện ECO tiếp theo từ sơ đồ nguyên lý sang PCB.
-
Để cho phép nhập các lớp net được định nghĩa bằng chỉ thị vào Constraint Manager, phải bật tùy chọn Generate Net Classes trong tab Class Generation của hộp thoại Project Options. Lưu ý rằng nếu các lớp net đã được nhập vào Constraint Manager rồi tùy chọn Generate Net Classes bị tắt, lần nhập tiếp theo vào Constraint Manager sẽ đề xuất xóa các lớp net đã nhập.
Chỉnh sửa các chỉ thị được nhập từ tài liệu chỉ đọc
Không thể chỉnh sửa các chỉ thị đã được nhập từ tài liệu chỉ đọc (ví dụ: trang thiết bị và trang được quản lý) nếu tùy chọn Make Device Sheets In Projects Read-Only được bật (đánh dấu chọn) trên trang Quản lý dữ liệu - Trang thiết bị của hộp thoại Preferences.
Khi tùy chọn này bị tắt (bỏ chọn), bạn có thể chỉnh sửa các chỉ thị. Sau khi các chỉ thị được nhập (khi tùy chọn này được bật), quy tắc sẽ được tô màu xanh dương trong Constraint Manager.
Nhập và xuất các ràng buộc và bộ ràng buộc
Bạn có thể nhập và xuất các ràng buộc và bộ ràng buộc giữa các thiết kế. Để truy cập chức năng này, nhấp chuột phải trong chế độ xem Clearances, Physical, hoặc Electrical của Constraint Manager, rồi chọn Import hoặc Export.
Sau khi chọn Import, hộp thoại File Explorer tiêu chuẩn sẽ mở ra, cho phép bạn chọn ràng buộc/bộ ràng buộc mong muốn (*.CstrDot ) để nhập vào thiết kế. Hộp thoại Constraints to Import sẽ mở ra, cho phép bạn chọn các ràng buộc/bộ ràng buộc để nhập vào thiết kế hiện tại. Các ràng buộc/bộ ràng buộc được chọn sẽ được áp dụng cho các đối tượng tương ứng trong thiết kế đích.
Exporting Constraints and Constraint Sets
Sau khi chọn một hoặc nhiều ô trong chế độ xem Clearances hoặc một hoặc nhiều dòng trong chế độ xem Physical hoặc Electrical, rồi chọn Export, hộp thoại Constraints to Export sẽ mở ra. Bảng trong hộp thoại liệt kê các ràng buộc và bộ ràng buộc của tất cả đối tượng đã được chọn trước khi thực hiện lệnh. Dùng các ô đánh dấu để chọn các ràng buộc/bộ ràng buộc bạn muốn xuất (theo mặc định, các ràng buộc liên quan đến chế độ xem hiện tại sẽ được chọn trong hộp thoại). Sau khi nhấp vào nút Export items, hộp thoại File Explorer tiêu chuẩn sẽ mở ra, cho phép bạn đặt tên và lưu các ràng buộc/bộ ràng buộc. Tệp sẽ được xuất với phần mở rộng *.CstrDot và sau đó có thể được nhập vào một thiết kế khác.
Làm việc với tất cả quy tắc ở phía PCB
Khi truy cập Constraint Manager từ trình biên tập PCB, bạn có thể sử dụng chế độ xem All Rules, trong đó hiển thị danh sách tất cả quy tắc trong thiết kế PCB. Từ đây, bạn có thể tạo các quy tắc nâng cao có biểu thức truy vấn phức tạp hơn để xác định phạm vi áp dụng.
Tạo quy tắc nâng cao mới
Để tạo một quy tắc nâng cao mới trong chế độ xem All Rules của Constraint Manager, chọn Add Advanced Rule từ menu ngữ cảnh khi nhấp chuột phải (hoặc sử dụng nút
ở phần dưới của Constraint Manager khi không có quy tắc nào được chọn trong vùng bảng), sau đó nhập phạm vi áp dụng dựa trên truy vấn và các tham số ràng buộc trong bảng hoặc phần biểu diễn đồ họa bên dưới.
Quản lý thư viện phạm vi
Để đơn giản hóa quá trình tạo các quy tắc nâng cao lặp đi lặp lại, Constraints Manager cho phép bạn lưu các phạm vi khớp đối tượng dựa trên truy vấn trong Thư viện phạm vi. Thư viện được quản lý bằng Scopes Library hộp thoại được truy cập bằng cách nhấp vào nút Edit Library trong vùng Scopes Library của bảng Properties . Thư viện được hiển thị trong bảng Properties, nơi có thể nhập và xuất các phạm vi tùy chỉnh dưới dạng tệp XML, sau đó dùng tệp này để bổ sung nội dung cho Thư viện phạm vi của một bản cài đặt Altium Designer khác.
Để xuất một phạm vi vào thư viện hoặc nhập một phạm vi từ thư viện, hãy dùng các lệnh trong menu của nút
bên cạnh trường Object Match / Second Object Match ở phần dưới của Constraint Manager. Sau khi một phạm vi từ thư viện được áp dụng cho quy tắc, tên phạm vi sẽ hiển thị trong cột Object Match / Second Object Match ở vùng lưới và phía trên trường Object Match / Second Object Match. Bạn có thể dùng menu
của trường để chuyển phạm vi trở lại định dạng dựa trên truy vấn (Detach Scope).
Bật/Tắt quy tắc
Bạn có thể bật/tắt các quy tắc cơ bản và nâng cao được liệt kê trong chế độ xem All Rules. Cột Enabled phản ánh trạng thái của quy tắc: True (bật) hoặc False (tắt). Nhấp đúp vào một ô trong cột để chuyển đổi trạng thái của quy tắc cụ thể. Các ô tương ứng với quy tắc cơ bản đã tắt được gắn nhãn (Disabled) và hiển thị mờ trong các chế độ xem Physical và Electrical.
Bạn cũng có thể chuyển đổi trạng thái bật của các quy tắc nâng cao thuộc một loại, một nhóm cụ thể hoặc tất cả quy tắc nâng cao bằng các lệnh trong menu ngữ cảnh khi nhấp chuột phải vào mục tương ứng trong cây Rule Class.
|
Nhấp chuột phải vào một mục loại quy tắc trong cây Rule Class để bật/tắt các quy tắc nâng cao thuộc loại này. Nhấp chuột phải vào một mục nhóm quy tắc trong cây Rule Class để bật/tắt các quy tắc nâng cao thuộc nhóm này. Nhấp chuột phải vào tiêu đề Rule Class để bật/tắt tất cả quy tắc nâng cao. |
Nhập và xuất quy tắc
Từ chế độ xem All Rules, bạn có thể nhập và xuất các quy tắc (nâng cao và/hoặc cơ bản).
Để xuất, hãy chọn nhiều quy tắc trong danh sách bằng Ctrl+Click, Shift+Click hoặc Click, Hold&Drag, sau đó nhấp chuột phải và chọn lệnh Export Selected Rules (x) (x biểu thị số quy tắc đã chọn). Bạn cũng có thể xuất quy tắc bằng các lệnh trong menu ngữ cảnh khi nhấp chuột phải vào mục tương ứng trong cây Rule Class:
-
Nhấp chuột phải vào một mục loại quy tắc trong cây và chọn lệnh Export <RuleType> Rules để xuất các quy tắc thuộc loại này.
-
Nhấp chuột phải vào một mục nhóm quy tắc trong cây và chọn lệnh Export <RuleCategory> Rules để xuất các quy tắc thuộc nhóm này.
-
Nhấp chuột phải vào tiêu đề Rule Class của cây và chọn lệnh Export All Rules để xuất tất cả quy tắc.
Sau khi chọn một lệnh Export, hộp thoại Constraints to Export mở ra, cho phép bạn chọn quy tắc cần xuất vào một tệp *.CstrDot để sau này nhập vào dự án khác. Sau khi nhấp vào nút Export x Items (x biểu thị số mục đã chọn trong hộp thoại), hộp thoại tiêu chuẩn File Explorer mở ra, cho phép bạn xác định tên và vị trí của tệp. Các quy tắc sẽ được xuất vào một tệp *.CstrDot để sau này nhập vào thiết kế khác.
|
Nhấp chuột phải vào một hoặc nhiều quy tắc đã chọn để xuất chúng. Nhấp chuột phải vào một mục loại quy tắc trong cây Rule Class để xuất các quy tắc thuộc loại này. Nhấp chuột phải vào một mục nhóm quy tắc trong cây Rule Class để xuất các quy tắc thuộc nhóm này. Nhấp chuột phải vào tiêu đề Rule Class để xuất tất cả quy tắc. |
Để nhập, hãy nhấp chuột phải trong vùng danh sách hoặc cây Rule Class của chế độ xem All Rules và chọn lệnh Import Rules. Cửa sổ tiêu chuẩn File Explorer mở ra, cho phép bạn chọn tệp *.CstrDot mong muốn; sau đó nhấp vào Open. Hộp thoại Constraints to Import mở ra, cho phép bạn chọn các quy tắc cần nhập vào thiết kế hiện tại. Khi nhập, các phạm vi tùy chỉnh liên quan sẽ được áp dụng tự động.
Xóa quy tắc nâng cao
Để xóa quy tắc nâng cao đang được chọn, hãy nhấp chuột phải vào quy tắc đó và chọn Remove Advanced Rule. Để xóa nhiều quy tắc nâng cao cùng lúc, hãy chọn nhiều quy tắc bằng Ctrl+Click, Shift+Click hoặc Click, Hold&Drag, sau đó nhấp chuột phải và chọn Remove Advance Rules (x). 'x' biểu thị số quy tắc sẽ bị xóa. Bạn cũng có thể xóa tất cả quy tắc nâng cao thuộc một loại, một nhóm cụ thể hoặc toàn bộ quy tắc nâng cao bằng các lệnh trong menu ngữ cảnh khi nhấp chuột phải vào mục tương ứng trong cây Rule Class.
|
Nhấp chuột phải vào nhiều quy tắc đã chọn để xóa chúng. Nhấp chuột phải vào một mục loại quy tắc trong cây Rule Class để xóa các quy tắc nâng cao thuộc loại này. Nhấp chuột phải vào một mục nhóm quy tắc trong cây Rule Class để xóa các quy tắc nâng cao thuộc nhóm này. Nhấp chuột phải vào tiêu đề Rule Class để xóa tất cả quy tắc nâng cao. |
Trong mỗi trường hợp, các quy tắc sẽ bị xóa ngay lập tức mà không yêu cầu xác nhận.
Truy tìm chéo
Constraint Manager có tính năng truy tìm chéo, giúp hiển thị các đối tượng liên quan bằng cách tô sáng chúng trong tài liệu tương ứng. Để truy tìm chéo đến một đối tượng bất kỳ, hãy nhấp chuột phải vào mục của đối tượng đó, rồi chọn tùy chọn Cross Probe từ menu ngữ cảnh hoặc chọn Cross Probe từ menu
của một quy tắc nâng cao.
Thiết lập Cross Probe View Settings trong bảng Properties để cấu hình các cài đặt truy tìm chéo.
Sử dụng tùy chọn Clear Filter của trình biên tập sơ đồ nguyên lý/PCB (nhấp chuột phải trong không gian thiết kế và chọn Clear Filter, phím tắt: Shift+C) để đặt lại trạng thái tô sáng khi truy tìm chéo.
Tham khảo trang Truy tìm chéo & Chọn để tìm hiểu thêm về truy tìm chéo trong Altium Designer.
Chọn chéo
Tính năng chọn chéo hỗ trợ lựa chọn đối tượng linh hoạt theo hai chiều. Khi chế độ chọn chéo được bật (bằng Cross Select Mode lệnh từ Tools menu chính của Constraint Manager, trình biên tập sơ đồ nguyên lý hoặc PCB), các đối tượng được chọn trong Constraint Manager cũng được chọn trong các tài liệu sơ đồ nguyên lý và PCB, và ngược lại.
Tham khảo trang Dò chéo & chọn để tìm hiểu thêm về việc chọn chéo trong Altium Designer.
Chuyển các ràng buộc giữa sơ đồ nguyên lý và PCB
Các thay đổi được áp dụng trong Constraint Manager được chuyển giữa thiết kế sơ đồ nguyên lý và PCB bằng quy trình Lệnh thay đổi kỹ thuật (ECO). Chọn một lệnh để cập nhật các ràng buộc ở phía còn lại.
-
Để chuyển các thay đổi từ sơ đồ nguyên lý sang PCB – chọn lệnh Design » Update PCB Document <PCBDocumentName> từ các menu chính của trình biên tập sơ đồ nguyên lý.
-
Để chuyển các thay đổi (được thực hiện trong các chế độ xem Clearances, Physical và/hoặc Electrical của Constraint Manager) từ PCB sang sơ đồ nguyên lý – chọn lệnh Design » Update Schematics in <PCBProjectName> từ các menu chính của trình biên tập PCB.
Sử dụng hộp thoại Engineering Change Order xuất hiện sau đó để xem xét, xác thực và thực hiện các thay đổi.
Tham khảo trang Duy trì đồng bộ giữa sơ đồ nguyên lý & PCB để tìm hiểu thêm.
Chuyển đổi từ Quy tắc thiết kế sang Constraint Manager
Nếu một dự án PCB sử dụng hệ thống quản lý quy tắc cũ (tức là hộp thoại PCB Rules and Constraints Editor), bạn có thể thực hiện chuyển đổi một lần, một chiều sang Constraint Manager.
Sử dụng lệnh Design » Migrate Project to Constraint Manager Flow từ các menu chính trong trình biên tập PCB và sơ đồ nguyên lý. Hộp thoại Migration Required sẽ mở để cảnh báo rằng quá trình chuyển đổi sẽ diễn ra và không thể hoàn tác sau khi nhấp vào nút
.
Cả quy tắc thiết kế PCB và chỉ thị trên sơ đồ nguyên lý sẽ được chuyển thành các ràng buộc tương ứng phù hợp trong Constraint Manager. Khi quá trình chuyển đổi hoàn tất thành công, Constraint Manager sẽ được mở (trong ngữ cảnh của trình biên tập đang hoạt động khi bạn thực hiện chuyển đổi).
).



).
).
).

).
).
).






)
)
)








).
).





).

).










).
).
).