Làm việc với Rooms trên PCB
Sơ lược
- Bạn sẽ tìm hiểu room trên PCB là gì và cách sử dụng room để kiểm soát việc bố trí đối tượng cũng như các yêu cầu thiết kế trong một khu vực đã xác định trên bo mạch.
- Bạn sẽ biết các phương pháp chính để tạo room trong trình biên tập PCB, bao gồm đặt tương tác, tạo từ các linh kiện đã chọn và tạo thông qua các ràng buộc thiết kế.
- Bạn sẽ hiểu cách các đối tượng room và ràng buộc Room Definition phối hợp với nhau trong Altium Designer, bao gồm cách áp dụng trong PCB Rules and Constraints Editor và Constraint Manager.
Tóm tắt
Room là một vùng được xác định trên một trong các lớp bề mặt của PCB. Room được dùng để xác định các yêu cầu thiết kế trong vùng đó của bo mạch, chẳng hạn như: these components must be in this area, hoặc route these nets this width, hoặc use routing vias of this size.
Room được đặt giống như các đối tượng đa giác khác, dưới dạng hình chữ nhật hoặc hình đa giác.
Ngoài việc tồn tại dưới dạng một hình có tên trong mặt phẳng X-Y trên bo mạch, mỗi room còn tự động trở thành một ràng buộc thiết kế Room Definition có tên Các thiết lập trong ràng buộc Room Definition xác định: objects mà room áp dụng, liệu các đối tượng đó có phải được giữ inside or outside room hay không, và layer mà room được áp dụng.
Ngoài yêu cầu đơn giản về keep these objects in (or out) được quy định trực tiếp bởi ràng buộc Room Definition, room cũng có thể được dùng để xác định một vùng trên bo mạch nơi áp dụng các ràng buộc thiết kế khác. Ví dụ: đường mạch bên dưới BGA có thể cần có độ rộng cụ thể , hoặc việc đi dây cặp vi sai bên dưới BGA có thể yêu cầu áp dụng một cấu hình trở kháng cụ thể
Khả năng sử dụng
Chỉ có thể đặt/tạo room trong trình biên tập PCB. Sử dụng các phương pháp sau để tạo room:
-
Chọn lệnh cần dùng từ menu con Design » Rooms , sau đó xác định hình dạng room theo cách tương tác (nếu bạn chọn lệnh Place), hoặc tự động tạo room (nếu bạn chọn lệnh Create).
-
Thêm một ràng buộc thiết kế Room Definition mới, sau đó chỉnh sửa ràng buộc room mới rồi nhấp vào nút Define để xác định hình dạng của room đa giác theo cách tương tác.
-
Tạo room dựa trên một đường bao kín (đã chọn) được tạo thành từ một tập hợp các đoạn mạch/cung tròn, bằng lệnh Tools » Convert » Create Room from Selected Primitives.
-
Tự động tạo room trong quá trình đồng bộ thiết kế từ sơ đồ nguyên lý sang PCB. Tìm hiểu thêm về các room được tạo tự động (bao gồm cách tắt tính năng này).
Tạo room
Quy trình tạo room trên tài liệu PCB phụ thuộc vào việc bạn đang đặt hay tạo room theo cách tương tác, cũng như phương pháp đặt/tạo cụ thể mà bạn đã chọn.
Có nhiều kỹ thuật khác nhau để đặt hoặc tạo room.
Đặt room theo cách tương tác
Có thể đặt room hình chữ nhật hoặc hình đa giác trên lớp trên cùng hoặc dưới cùng của thiết kế. Lưu ý rằng mặc dù có thể đặt room khi bất kỳ lớp nào đang hoạt động, lớp mà room áp dụng sẽ được chỉ định trong ràng buộc thiết kế Room Definition.
Room hình chữ nhật
Sau khi khởi chạy lệnh Design » Rooms » Place Rectangular Room, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt room. Thực hiện việc đặt theo trình tự sau:
-
Nhấp chuột hoặc nhấn Enter để cố định góc đầu tiên của room.
-
Để chỉnh sửa ngay các thuộc tính của ràng buộc Room Definition liên quan, hãy nhấn phím Tab trong khi đặt.
-
Di chuyển con trỏ để điều chỉnh kích thước room, sau đó nhấp chuột hoặc nhấn Enter để cố định góc đối diện theo đường chéo và hoàn tất việc đặt room.
-
Tiếp tục đặt các room khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Room đa giác
Sau khi khởi chạy lệnh Design » Rooms » Place Polygonal Room, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt room. Thực hiện việc đặt theo trình tự sau:
-
Định vị con trỏ rồi nhấp chuột để cố định điểm bắt đầu của room.
-
Định vị con trỏ rồi nhấp chuột để cố định một chuỗi các đỉnh xác định hình dạng đa giác của room.
-
Sau khi đặt đỉnh cuối cùng, nhấp chuột phải hoặc nhấn Esc để hoàn tất việc đặt room. Không cần khép kín đa giác vì phần mềm sẽ tự động hoàn thiện hình dạng bằng cách nối điểm bắt đầu với điểm cuối cùng đã đặt.
-
Tiếp tục đặt các room đa giác khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Dựa trên các linh kiện đã chọn
Nếu các linh kiện đã được bố trí trên bo mạch và bạn muốn tạo một room mới phù hợp với vị trí của chúng, hãy sử dụng một trong ba lệnh Create xxx Room from selected components. Có thể tự động tạo room có dạng không trực giao, trực giao và hình chữ nhật bằng một trong các lệnh này, dựa trên các linh kiện hiện được chọn trong không gian thiết kế. Trong mỗi trường hợp, phương pháp tạo đều giống nhau:
-
Chọn tất cả các linh kiện mà bạn muốn tạo room cho chúng. Để chọn các linh kiện PCB từ sơ đồ nguyên lý, hãy chạy lệnh Tools » Cross Select Mode rồi chọn các linh kiện trên sơ đồ nguyên lý.
-
Trong trình biên tập PCB, khởi chạy lệnh tạo tương ứng (Design » Rooms » Create xxx Room from selected components). Một lớp linh kiện bao gồm các linh kiện đã chọn sẽ được tạo tự động (trừ khi đã có sẵn).
-
Loại vùng được chọn sau đó sẽ được tạo, với quy tắc thiết kế Room Definition của vùng đó tự động được liên kết với lớp linh kiện vừa tạo.
-
Vùng sẽ được điều chỉnh kích thước để chứa tất cả các linh kiện đã chọn, dựa trên các hình chữ nhật bao quanh vùng chọn của linh kiện.
-
Nếu bạn nhấp và kéo để di chuyển vùng đó, tất cả các linh kiện trong lớp linh kiện liên kết cũng sẽ di chuyển theo.
Một vùng trực giao được tạo từ các linh kiện PCB đã chọn, vốn được chọn từ sơ đồ nguyên lý.
Bằng cách thêm ràng buộc thiết kế định nghĩa vùng
Bạn cũng có thể tạo vùng mới bằng cách xác định một ràng buộc mới trong PCB Rule and Constraints Editor hoặc Constraint Manager.
Phương pháp nào đang được sử dụng để xác định các ràng buộc thiết kế?
Altium Designer hỗ trợ hai phương pháp riêng biệt để xác định các ràng buộc thiết kế: Trình quản lý ràng buộc và Trình chỉnh sửa quy tắc và ràng buộc PCB.
PCB Rule and Constraints Editor là giao diện ban đầu được phát triển để xác định các ràng buộc trong trình chỉnh sửa PCB. Nếu sử dụng PCB Rule and Constraints Editor, nhà thiết kế sẽ xác định: what objects the constraint (rule) applies to, và how those objects are to be constrained. Điểm mạnh của phương pháp này là cho phép nhà thiết kế nhắm chính xác đến các đối tượng cần ràng buộc; ràng buộc có thể áp dụng cho mọi đối tượng (ví dụ: tất cả các net), hoặc tập trung vào một đối tượng cụ thể trên bo mạch (một pad nhất định). Phương pháp linh hoạt này để xác định các đối tượng thiết kế đích được thực hiện thông qua một bộ máy quy tắc vận hành bằng ngôn ngữ truy vấn.
Constraint Manager mang đến cách tiếp cận lấy đối tượng làm trung tâm khi xác định các ràng buộc. Nhà thiết kế làm việc từ góc nhìn của các đối tượng, áp dụng các ràng buộc điện và vật lý khác nhau theo yêu cầu của thiết kế trong một giao diện dạng bảng tính; các đối tượng sẽ được tô sáng trong trình chỉnh sửa đồ họa khi được chọn trong Constraint Manager. Điều này giúp nhà thiết kế dễ dàng cấu hình và kiểm tra tất cả các yêu cầu đối với một đối tượng, ví dụ: lớp net này phải được đi dây với độ rộng này, khoảng hở này, sử dụng via đi dây này và kiểu kết nối polygon này. Bạn cũng có thể yêu cầu lớp net đó phải được đi dây trên các lớp này, với các giá trị trở kháng này. Cách nhìn lấy đối tượng làm trung tâm này không có trong PCB Rule and Constraints Editor. Cuối cùng, phần mềm chuyển đổi các ràng buộc lấy đối tượng làm trung tâm sang cùng định dạng quy tắc được xác định trong PCB Rule and Constraints Editor; hãy chuyển sang chế độ xem All Rules sau khi mở các ràng buộc từ trình chỉnh sửa PCB để xem chúng.
Trang tài liệu này hiển thị hình ảnh các ràng buộc được xác định trong cả hộp thoại PCB Rule and Constraints Editor và Constraint Manager. Lưu ý rằng các thuật ngữ constraint và rule được sử dụng thay thế cho nhau.
Thêm ràng buộc thiết kế định nghĩa vùng mới
Trong Trình chỉnh sửa quy tắc và ràng buộc PCB
Với mỗi vùng được đặt hoặc tạo, một ràng buộc thiết kế Room Definition tương ứng sẽ tự động được tạo. Điều ngược lại cũng đúng: nếu bạn thêm một quy tắc mới thuộc loại này, đối tượng vùng tương ứng sẽ xuất hiện trong không gian thiết kế. Lưu ý rằng điều này cũng áp dụng khi xóa: nếu bạn xóa một vùng trong trình chỉnh sửa đồ họa, ràng buộc sẽ tự động bị xóa; hoặc nếu bạn xóa ràng buộc thiết kế, đối tượng đồ họa cũng sẽ bị xóa.
Nếu ràng buộc vùng được xác định từ PCB Rules and Constraint Editor, một đối tượng vùng mặc định có kích thước 5 inch x 5 inch sẽ được tạo, cách Gốc tọa độ tuyệt đối 1 inch (ở góc dưới bên trái của không gian chỉnh sửa). Lưu ý rằng dấu gốc tọa độ hiển thị Gốc tọa độ tương đối do người dùng xác định, có thể được đặt ở bất kỳ đâu trong không gian chỉnh sửa.
Khi thêm một ràng buộc vùng mới, một vùng mặc định sẽ được xác định trong không gian chỉnh sửa.
Sau khi thêm ràng buộc, bạn có thể quay lại không gian chỉnh sửa và chỉnh sửa vùng bằng thao tác đồ họa. Ngoài ra, khi đang ở trong PCB Rules and Constraints Editor, bạn có thể chỉnh sửa ràng buộc vùng, rồi nhấp vào nút Define để xác định hình dạng bằng thao tác tương tác. Vì vùng xác định một khu vực trên bo mạch, cách phổ biến hơn là đặt vùng bằng thao tác tương tác và để ràng buộc thiết kế được tạo tự động.
Tìm hiểu thêm về cách thêm ràng buộc mới trong Trình chỉnh sửa quy tắc và ràng buộc PCB.
Trong Trình quản lý ràng buộc
Để tạo một ràng buộc giới hạn (vùng) mới trong Constraint Manager:, hãy chuyển sang chế độ xem All Rules, chọn Room Definition trong danh mục Placement, sau đó nhấp chuột phải trong danh sách Advanced Rules và chọn Add Advanced Rule từ menu ngữ cảnh, như minh họa bên dưới.
Có thể thêm ràng buộc vùng mới trong Trình quản lý ràng buộc.
Ở giai đoạn này, đối tượng vùng chưa tồn tại trong không gian chỉnh sửa đồ họa; bạn phải nhấp vào nút Define (để chuyển sang trình chỉnh sửa PCB) và xác định hình dạng của vùng. Sau khi hoàn tất, cả ràng buộc vùng và đối tượng vùng đều tồn tại, và bạn có thể lưu các ràng buộc.
-
Nếu ràng buộc vùng được dùng để buộc các đối tượng nằm bên trong (hoặc bên ngoài) khu vực đó của bo mạch, bước tiếp theo là cấu hình Object Match và các thiết lập ràng buộc khác ở cuối Constraint Manager. Hãy đọc tiếp để tìm hiểu thêm.
-
Nếu ràng buộc vùng được dùng để xác định khu vực trong một loại ràng buộc khác, chẳng hạn như độ rộng đường đi dây, hãy tham khảo phần Xác định các ràng buộc bên trong một vùng để tìm hiểu thêm.
Tìm hiểu thêm về cách thêm ràng buộc mới trong Trình quản lý ràng buộc.
Ràng buộc vùng là gì?
Như đã nêu trước đó, vùng là một khu vực được xác định trên một trong các lớp bề mặt PCB, dùng để xác định các yêu cầu thiết kế trong khu vực đó của bo mạch.
Tất cả các ràng buộc thiết kế đều có hai yếu tố chính:
-
what objects this constraint applies to , và
-
how those objects are to be constrained
Nếu ràng buộc vùng được xác định trong một khu vực trên bo mạch không có linh kiện nào, tiêu chí Object Match (the objects this constraint applies to) mặc định là False, nghĩa là ràng buộc này không áp dụng cho đối tượng nào. Hãy chỉnh sửa tiêu chí này theo yêu cầu.
Định nghĩa vùng vừa được tạo. Lưu ý rằng phạm vi áp dụng của quy tắc là False, nghĩa là quy tắc không áp dụng cho đối tượng nào.
Ràng buộc một lớp linh kiện
Một cách phổ biến để sử dụng ràng buộc vùng là xác định vị trí của một lớp linh kiện, cố định lớp linh kiện đó trong một khu vực cụ thể trên bo mạch.
Lớp linh kiện Encoder được giới hạn trong vùng có tên Room-Encoder, trên lớp trên cùng của bo mạch.
Hình trên minh họa cách lớp linh kiện Encoder được ràng buộc within vùng Room-Encoder, trên Top side của bo mạch trong PCB Rules and Constraints Editor (về cơ bản giống như trong Constraint Manager Sau khi được gán vào một vùng, các linh kiện sẽ di chuyển theo vùng đó. Để di chuyển vùng mà không di chuyển các linh kiện, hãy tạm thời vô hiệu hóa quy tắc Room Definition tương ứng.
Tìm hiểu thêm về ràng buộc thiết kế Room Definition.
Trình biên tập PCB có nhiều công cụ mạnh mẽ để làm việc với các vùng; xem thêm trong phần Làm việc với các vùng trên trang này.
Ngoài việc bản thân là một ràng buộc thiết kế (Room Definition), vùng còn có thể được dùng làm đối tượng để giới hạn phạm vi áp dụng của một ràng buộc thiết kế khác vào một khu vực trên bo mạch, chẳng hạn như độ rộng, khoảng hở hoặc kiểu via. Chủ đề này được trình bày trong phần Xác định ràng buộc trong một vùng trên trang này.
Được tạo trong quá trình đồng bộ hóa thiết kế từ sơ đồ nguyên lý sang PCB
Khi chuyển thiết kế từ sơ đồ nguyên lý sang PCB, bạn có thể chọn tạo một vùng chứa các linh kiện trên mỗi trang sơ đồ nguyên lý. Trong thiết kế phân cấp nhiều mức, điều này có thể không mang lại nhiều giá trị, nhưng trong một thiết kế phẳng lớn, việc có một vùng cho mỗi trang có thể hữu ích khi bố trí các linh kiện trên bo mạch.
Thẻ Class Generation trong hộp thoại Project Options có các tùy chọn để tạo vùng cho từng trang trong thiết kế Nếu tùy chọn Generate Rooms được chọn, một vùng sẽ được tạo cho trang đó và một lớp gồm tất cả các linh kiện trong trang sẽ được gán vào vùng này khi chạy lệnh Design » Update. Lưu ý rằng các linh kiện trên mỗi trang được thêm vào một lớp linh kiện, vì vậy tùy chọn Generate Rooms yêu cầu tùy chọn Component Class tương ứng cũng phải được bật.
Trong PCB, mỗi ràng buộc vùng được tạo với phạm vi InComponentClass('<SheetSymbolDesignator>'). Vùng sẽ không được tạo nếu trang không chứa linh kiện nào. Khi sơ đồ nguyên lý được chuyển sang PCB lần đầu, các linh kiện trong mỗi lớp linh kiện được xếp thành một hàng, sau đó một vùng được tạo bao quanh lớp linh kiện đó, như minh họa trong hình bên dưới.
Bỏ chọn các ô Generate Rooms trong hộp thoại Project Options nếu không cần tạo vùng tự động.
PCB sau lần đồng bộ hóa thiết kế đầu tiên – mỗi trang đã được tạo một vùng, với lớp linh kiện của trang đó được gán vào vùng tương ứng.
Tìm hiểu thêm về việc tự động tạo vùng, lớp linh kiện và lớp net từ dự án sơ đồ nguyên lý.
Để tìm hiểu thêm về đồng bộ hóa thiết kế, tham khảo trang Giữ đồng bộ sơ đồ nguyên lý & PCB .
Từ các đường mạch và cung tròn đã chọn
Có thể xác định một đối tượng vùng bằng đường bao kín tạo thành từ các đối tượng đường mạch và/hoặc cung tròn đã chọn. Để thực hiện, hãy chọn tất cả các đối tượng đường mạch và cung tròn cấu thành đường bao kín trong không gian thiết kế rồi chọn lệnh Tools » Convert » Create Room from Selected Primitives từ các menu chính. Trình chiếu bên dưới minh họa các bước thực hiện.
|
Các đường mạch đã được đặt trên một lớp cơ khí để xác định phần diện tích bo mạch dành cho các linh kiện Encoder. Chạy lệnh Tools » Convert » Create Room from Selected Primitives để tạo một Room Definition có cùng hình dạng. Hộp thoại Edit Room Definition xuất hiện để bạn xác định các tham số của ràng buộc. Lớp linh kiện Để điều chỉnh hình dạng của vùng, nhấp để chọn vùng đó, sau đó chạy lệnh Design » Rooms » Edit Polygonal Verticies, rồi nhấp vào một đỉnh hoặc một cạnh để thay đổi hình dạng vùng. |
Chỉnh sửa vùng
Có thể thay đổi hình dạng X-Y của vùng và vị trí của nó trên bo mạch bằng thao tác tương tác. Lưu ý rằng có hai cách khác nhau để chỉnh sửa vùng theo kiểu tương tác: dựa trên hình chữ nhật chọn của vùng (được mô tả trong phần Thay đổi kích thước và vị trí), hoặc dựa trên các đỉnh chỉnh sửa hình dạng của vùng (được mô tả trong phần Thay đổi hình dạng).
Ngoài việc truy cập các lệnh qua menu con Design » Rooms, bạn cũng có thể truy cập các lệnh vùng phù hợp với ngữ cảnh bằng cách nhấp chuột phải vào một vùng đã đặt và chọn menu con Room Actions.
Nhấp chuột phải vào một vùng để truy cập các lệnh dành riêng cho vùng.
Thay đổi kích thước và vị trí
Khi bạn nhấp một lần vào vùng để chọn, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện – bất kể ban đầu vùng được đặt dưới dạng hình chữ nhật hay đa giác:
Các tay nắm chỉnh sửa xuất hiện khi bạn nhấp để chọn một room.
Thay đổi kích thước room
-
Kéo các tay nắm ở góc (A) sẽ thay đổi kích thước room đồng thời theo cả chiều ngang và chiều dọc.
-
Kéo một tay nắm ở cạnh (B) sẽ thay đổi kích thước đối tượng theo hướng đó (chiều ngang hoặc chiều dọc).
-
Trong khi kéo, có thể xoay hoặc lật room bằng cách nhấn:
-
Spacebar để xoay đối tượng ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Góc xoay tuân theo giá trị Rotation Step được xác định trên trang PCB Editor - General của hộp thoại Preferences.
-
X hoặc Y để lật đối tượng theo trục X hoặc trục Y.
-
L để lật đối tượng sang mặt bên kia của bo mạch. Nếu room có các linh kiện liên kết, các linh kiện đó cũng sẽ được lật cùng room.
-
Di chuyển room
Nhấp và kéo room để di chuyển nó đến vị trí mới. Bạn cũng có thể di chuyển đối tượng room bằng lệnh Design » Rooms » Move Room từ các menu chính hoặc lệnh Room Actions » Move Room từ menu ngữ cảnh của room. Sau khi kích hoạt lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ di chuyển room – nhấp vào room để di chuyển.
Khi bạn nhấp vào một room để di chuyển:
-
Room sẽ bám theo con trỏ. Điểm giữ room phụ thuộc vào Object Snap Options hiện tại, trong đó con trỏ sẽ bắt vào điểm bắt dính được bật gần nhất (pad linh kiện, điểm tham chiếu linh kiện hoặc đỉnh của room).
-
Di chuyển room đến vị trí mong muốn, sau đó nhấp hoặc nhấn Enter để đặt room.
-
Tiếp tục di chuyển các room khác hoặc nhấp chuột phải hay nhấn Esc để thoát.
-
Nếu có linh kiện trong room đang di chuyển, bạn có thể hiển thị các đường dẫn căn chỉnh động màu xanh lá trong khi di chuyển bằng cách nhấn phím Shift hoặc Ctrl. Dùng Shift để tiếp tục bắt dính vào lưới hiện hành; dùng Ctrl để tạm thời bỏ qua lưới và căn chỉnh theo một đối tượng có sẵn nằm ngoài lưới.
-
Nếu room chứa bất kỳ đối tượng nào không có net và/hoặc bị khóa, hộp thoại Room containing No Net/Locked Objects sẽ mở ra. Dùng hộp thoại này để xác định có di chuyển các đối tượng đó cùng room hay không, rồi nhấp OK. Để hộp thoại này xuất hiện, tùy chọn Ask when moving rooms containing No Net/Locked Objects phải được bật trên trang PCB Editor - General của hộp thoại Preferences

Hộp thoại Room containing No Net / Locked Objects
Hộp thoại Room chứa đối tượng không có net / bị khóa |
|
| No Net Objects | Bật để di chuyển các đối tượng không có net cùng room. |
| Locked Objects | Bật để di chuyển các đối tượng bị khóa cùng room. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | Bật tùy chọn này để lưu các thiết lập đã chọn và tiếp tục sử dụng chúng trong phần còn lại của phiên làm việc PCB. Hộp thoại sẽ không mở lại cho đến khi bắt đầu phiên mới. |
Thay đổi hình dạng
Hình dạng đường bao của room được thay đổi bằng cách chạy lệnh Edit Polygonal Room Vertices. Bạn có thể truy cập lệnh qua menu con Design » Rooms hoặc menu con ngữ cảnh Room Actions khi nhấp chuột phải.
Khi chạy lệnh, các tay nắm chỉnh sửa đường bao cho hình đa giác của room sẽ xuất hiện. Khi đó, bạn có thể:
-
Nhấp vào một tay nắm A, rồi di chuyển con trỏ để di chuyển đỉnh đó. Nhấp lần nữa tại vị trí mới để đặt đỉnh.
-
Trong khi di chuyển tay nắm A, nhấn phím Delete trên bàn phím để xóa đỉnh đó khỏi room.
-
Nhấp vào B hoặc nhấp dọc theo một cạnh (giữa các tay nắm), rồi di chuyển con trỏ để trượt cạnh đó. Nhấn Shift+Spacebar trong khi di chuyển cạnh để chuyển lần lượt qua các chế độ xử lý cạnh khả dụng (trượt cạnh, bẻ cạnh, uốn cong cạnh).
-
Ctrl+Click B hoặc Ctrl+Click dọc theo một cạnh, rồi di chuyển con trỏ để thêm một đỉnh vào cạnh đó đồng thời di chuyển đỉnh. Nhấp lần nữa tại vị trí mới để đặt đỉnh. Khi đó, đỉnh mới trở thành đỉnh A và các đỉnh B mới được thêm vào giữa đỉnh này và các đỉnh A ban đầu.
-
Để thao tác với tay nắm nằm ngoài lưới, hãy giữ phím Ctrl để tạm thời tắt bắt dính lưới.
-
Tiếp tục chỉnh sửa hình dạng room theo yêu cầu, hoặc nhấp chuột phải hay nhấn Esc để dừng. Room sẽ được hiển thị cập nhật theo hình dạng đường bao mới.
Lệnh này có thể được sử dụng bất kể room đích có bị khóa hay không.
Cắt room
Có các lệnh cho phép slice một đối tượng room đã đặt thành hai hoặc nhiều room riêng biệt bằng thao tác đồ họa. Quy trình cắt tương tự như đặt một đường và bao gồm các chế độ góc giống nhau (trên thực tế, độ rộng của đối tượng cắt chính là độ rộng đường mặc định hiện tại). Lưu ý rằng các đối tượng dùng để hiển thị đường cắt không phải là các đối tượng đang được đặt; chúng chỉ xuất hiện để biểu diễn đường cắt và sẽ bị xóa khi quá trình cắt hoàn tất. Ngoài ra, không cần bắt đầu cắt chính xác tại cạnh của room; sẽ dễ thao tác hơn nếu bắt đầu hơi lệch ra ngoài room và cũng kết thúc hơi lệch ra ngoài room.
Có hai lệnh chia vùng. Quy trình xác định đường chia giống nhau ở cả hai lệnh; chúng khác nhau ở cách xử lý các linh kiện có trong vùng được chia. Sự khác biệt giữa hai lệnh sẽ được giải thích sau phần mô tả quy trình chia vùng.
|
Nhấp chuột phải vào một vùng để truy cập các lệnh Slice trong menu Room Actions. Hai đường chia đã được xác định bằng quy trình mô tả bên dưới. Ba vùng đã được tạo. |
Quy trình chia vùng
Sau khi khởi chạy một lệnh Slice:
-
Con trỏ chuyển thành hình chữ thập và bạn được nhắc chọn điểm bắt đầu cho đường chia.
-
Đặt con trỏ ngay bên ngoài vùng bạn muốn chia, rồi nhấp chuột hoặc nhấn Enter. Lúc này bạn đang ở chế độ chia vùng (về cơ bản là chế độ đặt đường).
-
Di chuyển con trỏ vào trong vùng để xác định cạnh đầu tiên của đường chia, rồi nhấp chuột hoặc nhấn Enter để cố định điểm cuối của cạnh đó.
-
Tiếp tục di chuyển con trỏ và nhấp chuột để xác định một chuỗi các đỉnh tạo nên hình dạng của đường chia.
-
Sau khi đặt đỉnh cuối cùng (ngay bên ngoài vùng), nhấp chuột phải hoặc nhấn Esc để hoàn tất việc đặt đường chia đó.
-
Bây giờ, bạn có thể bắt đầu một đường chia khác cho vùng, hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ chia vùng.
-
Một hộp thoại xác nhận sẽ mở ra, cho biết vùng ban đầu sẽ được chia thành bao nhiêu vùng. Nhấp vào Yes để áp dụng các đường chia bạn đã tạo, hoặc No để hủy bỏ. Các đối tượng vùng mới tạo sẽ được cập nhật tương ứng, đồng thời các quy tắc Room Definition liên quan sẽ được tạo và liên kết.
-
Trong khi chia vùng, nhấn:
-
Shift+Spacebar để chuyển lần lượt qua các chế độ góc.
-
Spacebar để đảo hướng của góc.
-
Mỗi cạnh của đường chia cần có điểm bắt đầu và điểm kết thúc.
-
Nếu chế độ đặt đường chia có bao gồm góc, nhấn phím tắt 1 để chuyển đổi giữa việc đặt một cạnh mỗi lần nhấp và hai cạnh mỗi lần nhấp.
-
Backspace để xóa cạnh đường chia vừa đặt gần nhất.
-
Bao lại một vùng hiện có
Một cách khác để thay đổi hình dạng của vùng hiện có là yêu cầu phần mềm bao lại vùng quanh lớp linh kiện được gán cho vùng đó. Menu con Room Actions khi nhấp chuột phải và menu con Design » Rooms đều có ba lệnh Wrap Room, như minh họa trong phần trình chiếu.
|
Nếu bạn thay đổi vị trí đặt linh kiện trong một vùng, hãy sử dụng một trong ba lệnh Wrap để cập nhật hình dạng vùng. Lệnh Wrap Non-Orthogonal đặt các cạnh của vùng nối các điểm ngoài cùng trên đường bao linh kiện. Lệnh Wrap Orthogonal đặt các cạnh dọc và ngang của vùng xung quanh đường bao linh kiện. Lệnh Wrap Rectangular đặt vùng hình chữ nhật nhỏ nhất bao quanh các đường bao linh kiện. |
Chỉnh sửa trong bảng Properties
Đối tượng vùng có điểm đặc biệt là vừa là một đối tượng, vừa là một ràng buộc thiết kế.
Chỉnh sửa qua bảng Properties
Các thuộc tính của đối tượng vùng, bao gồm vị trí và hình dạng trong không gian chỉnh sửa, có thể được chỉnh sửa trong bảng Properties khi vùng được chọn. Có thể mở bảng qua nút Panels Panels ở góc dưới bên phải không gian thiết kế, hoặc bằng lệnh View » Panels » Properties.
Bảng Properties có thể được dùng để chỉnh sửa các thuộc tính đồ họa của vùng.
| Name | Tên hiện tại của vùng (và quy tắc Room Definition liên quan). Có thể thay đổi tên này theo yêu cầu. Ngoài việc giúp nhận diện từng vùng, tên còn có thể được dùng để chỉ định một vùng cụ thể trong quy tắc thiết kế. |
| (X/Y) (hai trường) | Tọa độ X và Y hiện tại của đỉnh đầu tiên của room, so với gốc tọa độ hiện tại. Chỉnh sửa giá trị trong trường để thay đổi vị trí của room so với gốc tọa độ hiện tại. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại. Đơn vị mặc định (hệ mét hoặc hệ Anh) được hiển thị trên thanh Trạng thái và được thiết lập trong vùng Other của bảng Properties (khi không có đối tượng nào được chọn trong không gian thiết kế). Chỉ có thể chỉnh sửa các giá trị này khi tùy chọn X/Y được mở khóa ( biểu tượng |
Các đỉnh đường bao |
|
| Vertices Grid | Liệt kê tất cả các đỉnh hiện được xác định cho room, theo thứ tự chúng được xác định khi đặt room. Các cạnh thẳng được dùng để nối từng đỉnh với đỉnh kế tiếp. Nếu muốn nối bằng cung tròn, hãy nhập giá trị cho Arc Angle theo yêu cầu. Nhập giá trị vào trường tương ứng với đỉnh bắt đầu; cung tròn sẽ đi từ đỉnh này đến đỉnh kế tiếp bên dưới trong danh sách. Nhấp chuột phải để Copy / Paste hoặc Import / Export to CSV. |
| Index | Chỉ số được gán cho đỉnh (không thể chỉnh sửa, dựa trên thứ tự đặt các đỉnh khi xác định room). |
| X | Tọa độ X (ngang) của đỉnh. Nhấp để chỉnh sửa. |
| Y | Tọa độ Y (dọc) của đỉnh. Nhấp để chỉnh sửa. |
| Arc Angle (Neg = CW) | Góc của cung tròn được vẽ để nối đỉnh này với đỉnh kế tiếp. Theo mặc định, các đỉnh được nối bằng cạnh thẳng và trường này để trống. Nhấp để chỉnh sửa, sau đó nhập góc cung tròn theo yêu cầu. Nhập giá trị dương sẽ tạo cung tròn ngược chiều kim đồng hồ. Để vẽ cung tròn theo chiều kim đồng hồ, hãy nhập giá trị âm. |
Làm việc với room
Phần mềm cung cấp nhiều tính năng giúp bạn làm việc với các room và các đối tượng bên trong chúng. Các tính năng này bao gồm những lệnh để: sắp xếp các room theo dạng lưới; di chuyển các room về lưới bắt điểm hiện tại; và đối với thiết kế có các khối mạch lặp lại, sao chép cách bố trí linh kiện và đi dây từ room này sang room khác.
Bạn cũng có thể dùng room để giới hạn phạm vi áp dụng các ràng buộc thiết kế khác trong một khu vực của bo mạch, chẳng hạn yêu cầu các net trong room này phải được đi dây với chiều rộng và khoảng cách cụ thể, hoặc các cặp vi sai phải được đi dây theo một cấu hình trở kháng cụ thể.
Bộ trộn 8 kênh: kênh đầu vào đầu tiên đã được bố trí và đi dây, sau đó được nhân bản sang bảy kênh đầu vào còn lại bằng lệnh Copy Room Format.
Xác định ràng buộc trong room
Ngoài việc ràng buộc các đối tượng phải nằm bên trong hoặc bên ngoài room (như đã trình bày trong phần Ràng buộc thiết kế định nghĩa room), room còn có thể được dùng để giới hạn khu vực áp dụng cho các ràng buộc thiết kế khác. Ví dụ, ràng buộc chiều rộng đường mạch có thể yêu cầu các đường mạch bên dưới BGA có chiều rộng khác nhau, hoặc ràng buộc khoảng cách điện có thể yêu cầu các khoảng cách khác nhau tại một khu vực cụ thể của bo mạch.
Chiều rộng đường mạch và khoảng cách được tự động điều chỉnh trong room theo các thiết lập trong định nghĩa room.
Điều này được thực hiện bằng cách thêm ràng buộc Chiều rộng đường mạch và ràng buộc Khoảng cách điện như minh họa trong trình chiếu bên dưới.
Trong Constraint Manager
Khi một ràng buộc room được thêm vào chế độ xem All Rules trong Constraint Manager, đối tượng room đó cũng sẽ xuất hiện trong chế độ xem Physical. Với chế độ xem này, bạn có thể nhanh chóng xác định các ràng buộc theo khu vực phải áp dụng trong room, bao gồm: chiều rộng đường mạch, khoảng cách điện, kiểu via đi dây, thuộc tính cặp vi sai, đoạn thu hẹp đường mạch và kiểu kết nối polygon. Trình chiếu bên dưới thể hiện các ràng buộc cho bo mạch trong video phía trên.
|
Trong room này, mọi đối tượng đi dây phải có chiều rộng nằm trong phạm vi được chỉ định. Trong room này, mọi đối tượng đi dây phải cách các đối tượng thuộc net khác ít nhất một khoảng bằng giá trị này. Trong room này, mọi đối tượng đi dây phải có khoảng cách điện tối thiểu bằng giá trị này. Trong room này, mọi cặp vi sai phải được đi dây bằng cấu hình trở kháng |
Trong PCB Rules and Constraint Editor
Để đạt được kết quả tương tự trong PCB Rules and Constraint Editor, bạn tạo một truy vấn xác định khu vực của room. Có hai cách nhận diện các đối tượng trong room: nhắm đến các đối tượng nằm hoàn toàn trong room (sử dụng từ khóa WithinRoom), hoặc nhắm đến các đối tượng chạm vào room (sử dụng từ khóa TouchesRoom). Trình chiếu bên dưới minh họa các thuộc tính chiều rộng đường mạch, khoảng cách điện, kiểu via đi dây và cặp vi sai giống như trong Constraint Manager trình chiếu trước.
Sắp xếp các room đã chọn
Để sắp xếp các room đã chọn trong không gian thiết kế, bạn có thể dùng lệnh Design » Rooms » Arrange Rooms. Chọn các room cần thiết, sau đó chạy lệnh để mở hộp thoại Arrange Rooms.
Hộp thoại Arrange Rooms.
Chỉ định cách sắp xếp các room và thứ tự đặt chúng. Bạn cũng có thể chỉ định vị trí bắt đầu – bằng cách nhập tọa độ X-Y trong hộp thoại hoặc nhấp trong không gian làm việc – cũng như khoảng cách giữa các room liền kề. Sau khi nhấp OK, các room đã chọn sẽ được di chuyển vào vị trí.
Cột/Hàng |
|
| Columns | Số cột dùng để bố trí các room. Chỉnh sửa trường này theo yêu cầu. |
| Rows | Số hàng dùng để bố trí các room. Chỉnh sửa trường này theo yêu cầu. Nếu số room vượt quá sức chứa của cách bố trí hàng và cột tùy chỉnh, các hàng bổ sung sẽ được thêm ở phía trên. |
Sắp xếp theo |
|
| SortBy | Hiển thị thứ tự sắp xếp đã chọn, tức là tiêu chí dùng để phân biệt room đầu tiên với room tiếp theo. Các tùy chọn khả dụng được trình bày chi tiết bên dưới. |
| Channel Name | Sắp xếp các room theo thứ tự chữ và số, dựa trên tên kênh của chúng. Tìm hiểu thêm về thiết kế đa kênh. |
| Room Area | Sắp xếp các room theo diện tích. |
| Room Component Count | Sắp xếp các room theo số lượng linh kiện bên trong. |
| Room Width | Sắp xếp các room theo kích thước X (chiều ngang). |
| Room Height | Sắp xếp các room theo kích thước Y (chiều dọc). |
| Sort in Ascending order | Bật để sắp xếp các room theo thứ tự tăng dần (từ nhỏ nhất đến lớn nhất), theo tiêu chí SortBy hiện tại. Nếu tắt tùy chọn này, thứ tự sắp xếp sẽ là giảm dần (từ lớn nhất đến nhỏ nhất). |
Vị trí |
|
| Origin X | Xác định vị trí X (chiều ngang) nơi bắt đầu bố trí room. Chỉnh sửa trường này để thay đổi tọa độ X, có thể được xác định bằng đơn vị mm hoặc mil. Để chỉ định đơn vị khi nhập số, hãy thêm hậu tố mm hoặc mil vào giá trị. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong bảng Thuộc tính và được sử dụng nếu không chỉ định đơn vị. |
| Origin Y | Xác định vị trí Y (chiều dọc) nơi bắt đầu bố trí room. Chỉnh sửa trường này để thay đổi tọa độ Y, có thể được xác định bằng đơn vị mm hoặc mil. Để chỉ định đơn vị khi nhập số, hãy thêm hậu tố mm hoặc mil vào giá trị. Đơn vị mặc định (hệ mét hoặc hệ Anh) được xác định bởi thiết lập Units trong bảng Thuộc tính và được sử dụng nếu không chỉ định đơn vị. |
| Select Origin Using Mouse | Nếu bật, bạn sẽ được nhắc đặt thủ công điểm gốc cho việc sắp xếp room. Phải tắt tùy chọn để chỉnh sửa Origin X và Origin Y. |
| X-Spacing | Xác định khoảng cách X (chiều ngang) cần chừa giữa các room liền kề. |
| Y-Spacing | Xác định khoảng cách Y (chiều dọc) cần chừa giữa các room liền kề. |
| Auto Spacing | Nếu bật, các room sẽ được sắp xếp với khoảng cách X (chiều ngang) và Y (chiều dọc) bằng nhau. Phải tắt tùy chọn để chỉnh sửa X-Spacing và Y-Spacing. |
| Place On Grid | Bật để buộc các room được sắp xếp thẳng hàng với lưới bắt điểm PCB hiện tại. |
Di chuyển room đến lưới
Để di chuyển từng room đã chọn đến điểm gần nhất trên lưới bắt điểm hiện tại, hãy sử dụng lệnh Design » Rooms » Move Rooms to Grid. Sau khi chạy lệnh, một hộp thoại xác nhận sẽ mở ra, hỏi bạn có muốn di chuyển các đối tượng cùng với các room đã chọn hay không. Nhấp vào Yes để di chuyển room và các đối tượng bên trong đến điểm gần nhất trên lưới bắt điểm, hoặc nhấp vào No để chỉ di chuyển room.
Sao chép định dạng room
Một trong những tính năng mạnh mẽ nhất của room là khả năng sao chép hình dạng room, cách bố trí linh kiện và đi dây từ một room sang các room khác chứa cùng một tập hợp linh kiện. Lệnh này đặc biệt hữu ích khi bố trí thiết kế đa kênh, cho phép áp dụng cách bố trí linh kiện và đi dây của một kênh cho tất cả các kênh khác.
Để sao chép định dạng của một room sang các room khác:
-
Nhấp vào Design » Rooms » Copy Room Formats từ các menu chính.
-
Thanh trạng thái sẽ nhắc bạn chọn room nguồn. Đặt con trỏ lên room nguồn rồi nhấp chuột hoặc nhấn Enter.
-
Thanh trạng thái sẽ nhắc bạn chọn room đích. Đặt con trỏ lên room mà bạn muốn sao chép định dạng sang, rồi nhấp chuột hoặc nhấn Enter. Nếu bạn muốn áp dụng định dạng cho nhiều room, lần nhấp thứ hai này có thể thực hiện trên bất kỳ room nào trong số đó.
-
Hộp thoại Confirm Channel Format Copy mở ra. Sử dụng các tùy chọn để xác định nội dung định dạng cần sao chép. Theo mặc định, định dạng sẽ được sao chép từ Source Room đã chọn sang Destination Room đã chọn. Để sao chép từ room nguồn sang từng room trong lớp kênh được phát hiện, hãy bật tùy chọn Apply to Specified Channels và xác nhận rằng các ô kiểm Copy cần thiết đã được chọn cho các room đích.
-
Nhấp vào OK trong hộp thoại để cập nhật các room đích.
-
Bạn có thể tiếp tục chọn thêm các room đích, hoặc nhấp chuột phải để kết thúc.
Room |
|
| Source Room | Tên của room nguồn (đại diện cho kênh trong sơ đồ nguyên lý), có cách bố trí linh kiện và đi dây sẽ được sao chép. |
| Destination Room | Trường này chứa tên của room đích (đại diện cho kênh trong sơ đồ nguyên lý), nơi sẽ áp dụng cách bố trí linh kiện và đi dây đã sao chép. Nếu dự án là thiết kế đa kênh và kênh nguồn cùng kênh đích thuộc cùng một lớp kênh, việc sao chép định dạng sẽ được áp dụng cho các kênh được bật trong vùng Channel Class của hộp thoại Lưu ý rằng kênh nguồn (room nguồn) và kênh đích (room đích) phải thuộc cùng một lớp kênh nếu bạn muốn sao chép định dạng của kênh nguồn (room nguồn) sang các kênh (room) khác. |
Tùy chọn |
|
| Copy Component Placement | Sao chép cách bố trí linh kiện của room nguồn sang các room đích. |
| Copy Designator and Comment Formatting | Sao chép định dạng ký hiệu định danh và chú thích của room nguồn sang room đích. |
| Copy Routed Nets | Sao chép bố cục đi dây (các đoạn mạch/cung tròn & via dùng để đi dây cho các net) của room nguồn sang room đích. |
| Copy Room Size/Shape | Sao chép hình dạng room nguồn và áp dụng hình dạng này cho room đích. Nếu Copy Room Orientation được bật trong hộp thoại, hình dạng room đích sẽ thay đổi so với điểm bắt đầu (góc dưới bên trái), tức là điểm góc dưới bên trái của room đích sẽ không thay đổi. |
| Copy Room Orientation | Sao chép hướng của room. Altium Designer phát hiện hướng của các room (dựa trên góc xoay của linh kiện có số chân nhiều nhất hoặc, nếu có nhiều linh kiện có cùng số chân nhiều nhất, dựa trên linh kiện có diện tích lớn nhất) và sử dụng thông tin đó để xoay room đích. |
| Copy Selected Objects Only | Sao chép định dạng của các đối tượng đã chọn trong room nguồn sang room đích. |
Tùy chọn cho các đối tượng tiếp xúc |
|
| Copy All Objects Touching the Room | Bao gồm các đối tượng (ngoài linh kiện và các đoạn mạch/đường cung đi dây & via) nằm hoàn toàn hoặc một phần trong room. Phải bật tùy chọn này để sao chép cả đối tượng có net và không có net, chẳng hạn như vùng, polygon và vùng cấm, từ room này sang room khác. |
| Exclude NoNet Objects | Loại trừ các đối tượng chưa được gán net. |
Chỉ nằm hoàn toàn bên trong / Nằm bên trong và tiếp xúc |
|
| Fully Enclosed Objects Only | Nếu tùy chọn Copy All Objects Touching the Room được bật, hãy bật tùy chọn này để chỉ sao chép các đối tượng nằm hoàn toàn bên trong. |
| Enclosed & Touching Objects | Nếu tùy chọn Copy All Objects Touching the Room được bật, hãy bật tùy chọn này để sao chép cả các đối tượng nằm bên trong và các đối tượng tiếp xúc với room. |
Đối sánh linh kiện giữa các kênh |
|
| Match Components by Channel Offsets | Mỗi linh kiện trong một kênh lặp được gán một giá trị độ lệch kênh khi chuyển thiết kế từ sơ đồ nguyên lý sang PCB. Sử dụng giá trị độ lệch kênh để xác định cùng một linh kiện trong từng kênh. |
| Match Components by Source Designator | Hoặc sử dụng ký hiệu định danh nguồn (trên sơ đồ nguyên lý) để xác định các linh kiện tương ứng trong từng kênh. |
Xóa các kết nối bị ảnh hưởng |
|
| Whole connections | Sau khi xử lý việc sao chép định dạng kênh, phần mềm cần biết cách xóa các kết nối bị ảnh hưởng. Nếu chọn tùy chọn này, các kết nối bị ảnh hưởng cả bên trong và bên ngoài room sẽ bị xóa. |
| Touching parts of connections only | Nếu chọn tùy chọn này, chỉ các kết nối bị ảnh hưởng tiếp xúc với room mới bị xóa. |
| Contained parts of connections only | Nếu chọn tùy chọn này, chỉ các kết nối bị ảnh hưởng bên trong room mới bị xóa. |
Lớp kênh |
|
| Channel Class | Khi một thiết kế đa kênh được chuyển từ sơ đồ nguyên lý sang PCB, các mạch lặp (kênh) được xác định dưới dạng một Lớp kênh trong hộp thoại Object Class Explorer của trình biên tập PCB Chính Lớp kênh này được dùng để xác định những kênh sẽ được áp dụng thao tác sao chép định dạng. Nếu vùng Channel Class của hộp thoại trống, hãy kiểm tra xem Lớp kênh đã được xác định đúng trong hộp thoại Object Class Explorer (Design » Classes) hay chưa. Nếu không xác định được Lớp kênh nào, lệnh sao chép chỉ được áp dụng từ Room nguồn sang Room đích. |
| Channel Members | Danh sách này chứa các kênh, mỗi kênh được nhận diện bằng tên room tương ứng. Nếu room nguồn thuộc một lớp kênh đã xác định, lớp đó và tất cả các thành viên của lớp sẽ được liệt kê. Lớp (mặt bo mạch nơi đặt room) và số lượng linh kiện trong mỗi kênh cũng được hiển thị. Mỗi kênh có một hộp kiểm để kiểm soát việc áp dụng sao chép định dạng cho kênh đó; hộp kiểm này có thể được sử dụng khi tùy chọn Apply To Specified Channel được bật. |
| Apply To Specified Channel | Theo mặc định, định dạng được sao chép từ Source Room sang tất cả các kênh trong Lớp kênh mà room nguồn (kênh nguồn) là thành viên. Khi bật tùy chọn này, hộp kiểm Copy của từng kênh sẽ khả dụng, cho phép lựa chọn cụ thể những kênh trong lớp sẽ được áp dụng thao tác sao chép định dạng. |
Ẩn room
Có thể hiển thị, ẩn hoặc hiển thị ở chế độ phác thảo đồng loạt các room trong một tài liệu bằng các tùy chọn trên thẻ View Options của bảng Cấu hình chế độ xem.
Điều chỉnh thanh trượt Mức độ hiển thị đối tượng cho Room để làm mờ hoặc ẩn chúng trong không gian chỉnh sửa.
).

).
)
).
).
).




)
).








).