Làm việc với các linh kiện đã được đặt
Sơ lược
- Tìm hiểu nguồn cung cấp linh kiện, cách xử lý phần tử và linh kiện nhiều phần tử, cũng như các cách chính để đặt chúng lên sơ đồ nguyên lý.
- Khám phá cách tìm kiếm linh kiện hiệu quả hơn và thực hiện nhanh các thao tác chỉnh sửa đồ họa trong hoặc sau khi đặt.
- Hiểu mối liên hệ giữa linh kiện trên sơ đồ nguyên lý và linh kiện trên PCB, cũng như các thuộc tính cốt lõi mà bạn có thể xem hoặc chỉnh sửa sau khi đặt.
Một linh kiện trong thư viện đại diện cho thiết bị vật lý được đặt trên bảng mạch in thực tế. Trên trang sơ đồ nguyên lý, linh kiện được biểu diễn bằng mô hình ký hiệu sơ đồ nguyên lý của nó. Mỗi linh kiện có thể chứa một hoặc nhiều phần.
Phần

Phần đại diện cho linh kiện điện tử vật lý thực tế.
Tổng quan
Phần là một đối tượng cơ bản trong thiết kế điện. Đây là ký hiệu sơ đồ nguyên lý đại diện cho một thiết bị điện tử, chẳng hạn như điện trở, công tắc, bộ khuếch đại thuật toán, bộ ổn áp, v.v. Các phần được lưu trong các linh kiện thuộc thư viện linh kiện sơ đồ nguyên lý. Lưu ý rằng mỗi linh kiện có thể chứa một hoặc nhiều phần. Ngoài biểu diễn bằng ký hiệu của linh kiện, phần còn bao gồm các liên kết đến mô hình, chẳng hạn như footprint PCB, và các tham số dùng để ghi lại những chi tiết như tham số linh kiện và thông tin nhà cung cấp. Cách thêm liên kết mô hình và tham số vào phần phụ thuộc vào loại hình lưu trữ thư viện đang được sử dụng.
Khả năng sử dụng
Có thể đặt các phần trong cả trình biên tập sơ đồ nguyên lý và trình biên tập thư viện sơ đồ nguyên lý.
- Trong trình biên tập sơ đồ nguyên lý, nhấp vào Place » Part.
- Nhấp chuột phải trong không gian thiết kế, sau đó chọn Place » Part từ menu ngữ cảnh.
- Từ bảng Components, nhấp chuột phải vào một linh kiện và chọn Place <ComponentName>.
- Từ bảng Components, chọn một linh kiện chung làm đối tượng giữ chỗ.
- Kéo và thả một linh kiện từ bảng Components.
- Chọn nút Place trong ngăn Details của bảng Components, hoặc sử dụng phím tắt Enter.
- Từ bảng SCH Library khi đang ở trình biên tập thư viện sơ đồ nguyên lý, chọn một linh kiện, sau đó nhấp vào Place.
Đặt linh kiện từ bảng Components
Trong trình biên tập sơ đồ nguyên lý, có thể chọn và đặt phần từ bảng Components.
- Bảng hiển thị nội dung của thư viện hiện được chọn. Sử dụng danh sách thả xuống bên cạnh tên thư viện để chọn thư viện khác.
- Sử dụng trường bộ lọc bên dưới trường thư viện hiện được chọn để lọc danh sách và tăng tốc quá trình tìm kiếm, hoặc cuộn và chọn phần cần thiết.
- Nhấp vào Place, nhấp đúp, hoặc nhấp và kéo để đặt linh kiện đã chọn lên trang sơ đồ nguyên lý đang hoạt động. Khi phần đang gắn với con trỏ, bạn có thể xoay (nhấn Spacebar), lật đối xứng theo một trục (nhấn X hoặc Y), hoặc chỉnh sửa (nhấn Tab) trước khi đặt.
- Có thể sắp xếp lại (nhấp và kéo) hoặc cấu hình lại (nhấp chuột phải, sau đó chọn Select Columns) các cột hiển thị trong danh sách linh kiện của thư viện hiện được chọn.
-
Nhấp vào nút
trong ô Linh kiện chung để gắn linh kiện với con trỏ và đặt vào tài liệu sơ đồ nguyên lý đang hoạt động. Chọn chính ô đó sẽ mở danh mục loại linh kiện tương ứng trong bảng Components.
Tìm kiếm linh kiện
Các tùy chọn trong menu thư viện không thuộc Workspace cho phép bạn thiết lập tùy chọn, thực hiện tìm kiếm và di chuyển nội dung thư viện dựa trên cơ sở dữ liệu và tệp. Để truy cập các tùy chọn này, chọn nút menu thư viện
ở góc trên bên phải của bảng Components.
Chọn File-based Libraries Preferences để mở hộp thoại Thư viện dựa trên tệp khả dụng, nơi bạn có thể xem các tùy chọn điều khiển để thêm hoặc xóa thư viện, cài đặt thư viện và chỉ định đường dẫn tìm kiếm thư viện.
Có thể lọc danh sách hiện tại của các linh kiện trong thư viện dựa trên cơ sở dữ liệu và tệp bằng cách nhập cụm từ tìm kiếm vào trường Search của bảng Components. Để truy cập các chức năng tìm kiếm nâng cao hơn cho thư viện linh kiện, chọn tùy chọn File-based Libraries Search từ menu
của bảng (ở góc trên bên phải) để mở hộp thoại Tìm kiếm thư viện dựa trên tệp. Hộp thoại cung cấp các tùy chọn tìm kiếm linh hoạt, bao gồm các điều kiện lọc dựa trên truy vấn và khả năng tìm kiếm trong tất cả các thư viện dựa trên cơ sở dữ liệu và tệp khả dụng, hoặc trong các thư viện nằm trong một đường dẫn được chỉ định.
- Scope tìm kiếm mặc định là tìm Components trong Available File-based Libraries.
- Ngoài ra, hộp thoại cũng hỗ trợ tìm kiếm trong Libraries on path được lưu trong các thư mục trên ổ đĩa. Để thực hiện, bật tùy chọn Libraries on path rồi cấu hình các tùy chọn Path theo yêu cầu.
- Filters sử dụng toán tử "AND" và do đó, tốt nhất nên bắt đầu bằng một bộ lọc đơn giản. Nếu có nhiều kết quả, hãy sử dụng chế độ Refine last search để tìm kiếm trong các kết quả đó.
- Kết quả tìm kiếm bằng truy vấn được hiển thị trong hộp thoại File-based Libraries Search khi chọn Helper.
Đặt linh kiện từ trình biên tập thư viện sơ đồ nguyên lý
Cũng có thể đặt một phần trực tiếp từ thư viện đang mở trong trình biên tập thư viện sơ đồ nguyên lý thông qua bảng SCH Library. Lưu ý rằng:
- Nhấp vào nút Place trong bảng sẽ đặt phần (linh kiện) đã chọn vào trang sơ đồ nguyên lý hoạt động gần nhất.
- Khi phần đang gắn với con trỏ, bạn có thể xoay (nhấn Spacebar), lật đối xứng theo một trục (nhấn X hoặc Y), hoặc chỉnh sửa (nhấn Tab) trước khi đặt. Cũng có thể thực hiện thao tác này trong khi kéo đối tượng. Mỗi lần xoay một góc 90°.
-
Nếu đặt một phần trực tiếp từ thư viện, bạn không cần thêm thư viện đó vào hộp thoại Thư viện dựa trên tệp khả dụng trước.
Chỉnh sửa đồ họa
Việc chỉnh sửa đồ họa đối với một phần chỉ giới hạn ở các thao tác di chuyển, xoay và lật đối xứng. Khi chọn một phần trong không gian thiết kế, một khung chọn nét đứt sẽ xuất hiện xung quanh phần đó. Để thao tác đồ họa với linh kiện đã chọn:
- Nhấn Delete để xóa phần đã chọn khỏi thiết kế.
- Nhấp và giữ để di chuyển phần đã chọn. Con trỏ sẽ chuyển đến điểm kết nối điện gần nhất (đầu nối dây của chân gần nhất).
- Nhấn Spacebar để xoay cung ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Cũng có thể thực hiện thao tác này trong khi kéo đối tượng. Mỗi lần xoay một góc 90°.
- Khi một phần đang di chuyển cùng con trỏ, nhấn phím X hoặc Y để lật đối xứng phần đó theo trục tương ứng.
Làm việc giữa linh kiện trên sơ đồ nguyên lý và linh kiện trên PCB
Phần mềm cung cấp các công cụ hỗ trợ làm việc giữa linh kiện trên sơ đồ nguyên lý và chính linh kiện đó trên PCB. Các công cụ này bao gồm Định vị chéo, Chọn chéo và Chọn linh kiện PCB từ sơ đồ nguyên lý.
Định vị chéo
Đúng như tên gọi, Định vị chéo cho phép bạn nhấp vào một linh kiện trong một trình chỉnh sửa và chuyển đến linh kiện đó trong trình chỉnh sửa còn lại. Để định vị chéo:
- Nhấp vào Cross Probe trong menu Tools của trình chỉnh sửa sơ đồ nguyên lý hoặc PCB.
- Khi bạn nhấp vào linh kiện trong trình chỉnh sửa sơ đồ nguyên lý, linh kiện đó sẽ được đưa vào giữa màn hình và phóng to trong trình chỉnh sửa PCB. Mức thu phóng được thiết lập trên trang Hệ thống – Điều hướng của hộp thoại Preferences.
- Theo mặc định, bạn vẫn ở trong cùng trình chỉnh sửa, sẵn sàng định vị chéo một linh kiện khác. Để chuyển sang trình chỉnh sửa còn lại khi định vị chéo, hãy giữ phím Ctrl.
Chế độ chọn chéo
Chế độ chọn chéo chọn cùng một linh kiện trong trình chỉnh sửa còn lại. Lưu ý rằng chế độ này không phóng to hay đưa linh kiện vào giữa màn hình. Chọn chéo chỉ có hai trạng thái bật hoặc tắt. Nhấp vào Tools » Cross Select Mode để bật/tắt chế độ này. Chọn nhiều linh kiện bằng cách giữ phím Shift khi nhấp để chọn.
Chọn linh kiện PCB
Tính năng này cho phép bạn chọn nhiều linh kiện trên sơ đồ nguyên lý theo một thứ tự cụ thể, sau đó đặt chính các linh kiện đó trong trình chỉnh sửa PCB theo cùng thứ tự. Để sử dụng tính năng này:
- Chọn lần lượt từng linh kiện trên sơ đồ nguyên lý (giữ Shift khi nhấp để chọn nhiều linh kiện).
- Chuyển sang trình chỉnh sửa PCB rồi nhấn phím tắt I, C để khởi chạy lệnh Reposition Selected Components. Lệnh Reposition Selected Components cũng có trong menu chuột phải sau khi nhấn phím tắt I.
Thuộc tính phần linh kiện
Thẻ Tổng quát
Tổng quát
-
Reuse Block – khi linh kiện thuộc một khối tái sử dụng, trường này hiển thị tên của khối tái sử dụng chứa linh kiện. Nhấp vào siêu liên kết Reuse Block để xem thuộc tính của khối tái sử dụng này.
-
Designator – nhập ký hiệu định danh. Nhấp vào biểu tượng con mắt để hiện/ẩn ký hiệu định danh. Sử dụng biểu tượng khóa để khóa/mở khóa ký hiệu định danh. Tìm hiểu thêm về Ký hiệu định danh.
-
Comment – nhập tên hoặc chú thích. Nhấp vào biểu tượng con mắt để hiện/ẩn tên. Sử dụng biểu tượng khóa để khóa/mở khóa tên. Trường Chú thích cũng có thể được dùng để hiển thị giá trị của một tham số do người dùng xác định hoặc tham số hệ thống. Tìm hiểu thêm về Chú thích.
-
Part <x> of Parts – hiển thị số thứ tự của phần linh kiện được chọn và tổng số phần. Nhấp vào
để khóa/mở khóa các trường, sau đó sử dụng danh sách thả xuống để chọn số thứ tự của phần linh kiện tương ứng.
-
Description – mô tả linh kiện/phần linh kiện.
-
Type – chọn một trong các loại linh kiện sau cho footprint của linh kiện tại đây. Các loại có sẵn gồm:
-
Standard– các linh kiện có đặc tính điện tiêu chuẩn, luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và việc gán net đều phải khớp), và được đưa vào BOM. Ví dụ là một linh kiện điện tiêu chuẩn như điện trở. -
Mechanical– các linh kiện không có đặc tính điện, không được đồng bộ (bạn phải đặt chúng thủ công trong cả hai trình chỉnh sửa) và được đưa vào BOM. Ví dụ là bộ tản nhiệt. -
Graphical– các linh kiện không có đặc tính điện, không được đồng bộ (bạn phải đặt chúng thủ công trong cả hai trình chỉnh sửa) và not được đưa vào BOM. Ví dụ là logo công ty. -
Net Tie (In BOM)– các linh kiện được dùng để nối tắt hai hoặc nhiều net khác nhau với nhau, luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và việc gán net đều phải khớp) và được đưa vào BOM. Chúng khác với linh kiện Tiêu chuẩn ở chỗ kết nối được tạo bởi phần đồng bên trong footprint không được kiểm tra; chính phần đồng này cho phép nối tắt các net. Lưu ý: bật tùy chọn Verify Shorting Copper trong hộp thoại Kiểm tra quy tắc thiết kế để xác minh rằng không có phần đồng nào chưa được kết nối bên trong linh kiện. -
Net Tie (No BOM)– các linh kiện được dùng để nối tắt hai hoặc nhiều net khác nhau với nhau, luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và việc gán net đều phải khớp) và not được đưa vào BOM. Chúng khác với linh kiện Tiêu chuẩn ở chỗ kết nối được tạo bởi phần đồng bên trong footprint không được kiểm tra; chính phần đồng này cho phép nối tắt các net. Lưu ý: bật tùy chọn Verify Shorting Copper trong hộp thoại Kiểm tra quy tắc thiết kế để xác minh rằng không có phần đồng nào chưa được kết nối trong linh kiện. -
Standard (No BOM)– các linh kiện có đặc tính điện tiêu chuẩn, luôn được đồng bộ giữa sơ đồ nguyên lý và PCB (footprint, chân/pad và việc gán net đều phải khớp) và not được đưa vào BOM. Ví dụ là một linh kiện điểm kiểm tra mà bạn muốn loại khỏi BOM. -
Jumper– các linh kiện được dùng để bổ sung dây nối tắt vào thiết kế PCB, chẳng hạn trên PCB một mặt không thể đi dây hoàn toàn trên một lớp. Với loại linh kiện này, footprint và chân linh kiện được đồng bộ giữa sơ đồ nguyên lý và PCB nhưng việc gán net thì không, và linh kiện được đưa vào BOM. Ngoài việc chọn tùy chọn này ở cấp linh kiện, cả hai pad trong linh kiện phải có JumperID được đặt thành cùng một giá trị khác không. Linh kiện loại Jumper không cần được nối dây trên sơ đồ nguyên lý; chúng chỉ cần xuất hiện trên sơ đồ nguyên lý nếu phải có trong BOM. Nếu không cần có trong BOM, chúng có thể được đặt trực tiếp trên PCB, tại đó Component Type được thiết lập, JumperIDs được thiết lập và Nets được gán thủ công cho các pad.
-
-
Design Item ID – trường này liệt kê tên của linh kiện được chọn (đối với linh kiện trong Workspace), trường khóa được chọn đã được xác định trong Field Settings vùng của tệp DbLib/SVNDbLib (đối với linh kiện trong thư viện cơ sở dữ liệu), hoặc tham số Design Item ID được xác định cho ký hiệu linh kiện (đối với linh kiện trong thư viện dạng tệp). Nhấp vào
để mở hộp thoại Replace Component. Hộp thoại này cho phép truy cập đầy đủ thông tin chi tiết của linh kiện đã chọn (Tham số, Mô hình, Lựa chọn linh kiện, Dữ liệu nhà cung cấp, v.v.), so sánh linh kiện và thay thế linh kiện hiện tại bằng linh kiện khác, cùng nhiều tính năng khác. Nếu chọn một linh kiện khác để thay thế, trường này sẽ hiển thị đầy đủ Design Item ID của linh kiện mới được chọn. Nhấp vào nút Validate để hiển thị thông tin về vị trí lưu trữ linh kiện. Nếu linh kiện không thuộc Workspace, đường dẫn đến tệp lưu linh kiện trên máy tính của bạn sẽ xuất hiện. Nếu linh kiện thuộc Workspace, thông tin sẽ chỉ cho biết đã tìm thấy linh kiện.
-
Source – hiển thị tên thư viện nguồn của linh kiện. Nhấp vào
để tìm kiếm và chọn thư viện mong muốn.
-
Revision state – trường này hiển thị trạng thái vòng đời hiện tại của bản sửa đổi linh kiện đã chọn, kèm theo biểu tượng màu và tên trạng thái của bản sửa đổi.
-
Revision status – nếu bản sửa đổi linh kiện đã chọn ở trạng thái hợp lệ (được phép sử dụng trong thiết kế), mục này sẽ cho biết bản sửa đổi đó là mới nhất (
Up to date) hay không (Out of date). Nếu bản sửa đổi ở trạng thái không hợp lệ (không được phép sử dụng trong thiết kế), mục này sẽ hiển thịNot applicable. Nhấp vào nút
để cập nhật linh kiện lên bản sửa đổi mới nhất.
-
Component issues (chỉ trong bảng Properties) – nếu linh kiện đã chọn có nguồn từ Altium 365 Workspace đang kết nối gặp bất kỳ vấn đề nào về tình trạng, biểu tượng
(đối với lỗi) hoặc
(đối với lỗi nghiêm trọng) sẽ xuất hiện để thông báo. Số ở bên phải biểu tượng cho biết số vấn đề được tìm thấy. Nhấp vào mũi tên xuống ở bên phải con số để xem mô tả ngắn gọn về các vấn đề.

Ví dụ về các vấn đề được phát hiện liên quan đến tình trạng thư viện. -
Supply Chain Data (chỉ trong bảng Properties) – hiển thị thông tin chuỗi cung ứng từ Lựa chọn linh kiện liên quan:
- Đơn giá trung vị. Mục này sẽ hiển thị màu đỏ nếu không có giá hoặc giá = 0.
- Tồn kho. Mục này hiển thị tổng lượng hàng tồn kho có sẵn từ các nhà cung cấp được bật trong nguồn Altium Parts Provider cho Workspace của bạn.
-
Thanh vòng đời của nhà sản xuất. Di chuột lên thanh để xem chú giải thông tin. Thanh này có thể xuất hiện ở một trong bốn trạng thái:
- Trắng/Xám = Mặc định, không xác định hoặc không có thông tin
- Xanh lá = Trạng thái Mới hoặc Sản xuất hàng loạt
- Cam = Không khuyến nghị cho thiết kế mới
- Đỏ = Đã ngừng sản xuất hoặc Hết vòng đời (EOL)
Vị trí
-
(X/Y)
- X (trường thứ nhất) – tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, tính theo gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) – tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, tính theo gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy ghi kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
-
Rotation – sử dụng danh sách thả xuống để chọn góc xoay. Các lựa chọn gồm
0 Degrees,90 Degrees,180 Degreesvà270 Degrees.
Tham số
-
Grid – liệt kê Name và Value của các tham số liên quan đến linh kiện hiện được chọn. Sử dụng
để khóa/mở khóa một tham số trong danh sách và ngăn tham số đó được cập nhật. Giá trị tham số có thể được nhập thủ công hoặc chọn từ danh sách thả xuống chứa các giá trị lấy từ tất cả linh kiện hiện có thuộc loại đó. Bạn có thể bật/tắt biểu tượng con mắt để hiển thị/ẩn tham số.
-
Favorites – các tham số được đánh dấu là Yêu thích sẽ hiển thị trong danh sách Tham số, còn các tham số không được đánh dấu sẽ bị ẩn. Di chuột sang bên phải tên bộ lọc tham số và nhấp vào biểu tượng
để đặt bộ lọc làm Yêu thích. Để bỏ đánh dấu Yêu thích cho một tham số, hãy nhấp lại vào biểu tượng.
Để xem tất cả tham số bị ẩn, hãy nhấp vào điều khiển Show More ở cuối danh sách. Nhấp vào điều khiển Show Less để chỉ xem các tham số Yêu thích.
-
Font – nhấp vào phông chữ đang hiển thị để thay đổi kiểu phông chữ.
-
Other – nhấp để mở danh sách thả xuống và thay đổi các tùy chọn bổ sung:
- Show Parameter Name – bật để hiển thị tên tham số.
- Allow Synchronization with Database – bật để đồng bộ với cơ sở dữ liệu. Tùy chọn này được dùng để kiểm soát việc có cho phép cập nhật chú thích hay không. Theo mặc định, các tùy chọn này được bật để luôn cho phép đồng bộ với thư viện/cơ sở dữ liệu nguồn. Bạn có thể tắt tùy chọn này để loại chú thích đó khỏi quá trình cập nhật.
- (X/Y) – nhập tọa độ X và Y.
-
Rotation – sử dụng danh sách thả xuống để chọn góc xoay. Các lựa chọn gồm:
0°,90°,180°và270°. - Autoposition – chọn để bật tính năng tự động định vị, nghĩa là tham số được tự động định vị mỗi khi linh kiện liên kết được xoay. Tắt tùy chọn này để giữ nguyên vị trí tương đối của tham số so với linh kiện liên kết khi linh kiện được xoay.
-
Add – nhấp để thêm một tham số, chẳng hạn như footprint, mô hình hoặc quy tắc, cùng các loại khác. Nhấp vào
để xóa mục đã chọn khỏi bảng. Nhấp vào
để chỉnh sửa tham số thông qua hộp thoại tương ứng của tham số đó.
Đồ họa
-
Mode – sử dụng danh sách thả xuống để chọn chế độ mong muốn. Nếu không có chế độ nào khác ngoài Normal, danh sách thả xuống này sẽ bị làm mờ.
- Mirrored – bật để lật đối xứng phần linh kiện.
- Local Colors – bật tùy chọn màu cục bộ để ghi đè màu tô, đường nét và chân của linh kiện trên sơ đồ nguyên lý bằng các màu tương ứng trong các ô màu Fill, Lines và Pins. Tắt tùy chọn này để sử dụng các màu được xác định sẵn trong thư viện.
Lựa chọn linh kiện
Vùng này cung cấp thông tin về các lựa chọn linh kiện và liên kết nhà cung cấp được gán cho linh kiện đã chọn. Tham khảo trang Thêm thông tin chuỗi cung ứng vào linh kiện để tìm hiểu thêm về thông tin do các mục trong phần này cung cấp.
Thẻ Chân
-
Grid – vùng này liệt kê Pins và Names của tất cả các chân thuộc linh kiện đã chọn. Sử dụng biểu tượng con mắt để hiển thị/ẩn chân. Sử dụng biểu tượng khóa để khóa/mở khóa các chân.
Đối với chân đa chức năng (chân có các chức năng được chỉ định trong trường Functions ở chế độ Chân của bảng Thuộc tính), hãy nhấp vào ô của chân trong cột Name và chọn chức năng chân trong danh sách thả xuống xuất hiện. Chức năng đã chọn sẽ được hiển thị làm tên chân trên trang sơ đồ nguyên lý.
- Show Full/Show Short - trong Show Full tên chân mở rộng đầy đủ của tất cả các chân trong danh sách được hiển thị; ở chế độ Show Short, tên chân hiện tại được hiển thị.
-
– khi nút này được bật (biểu tượng khóa đóng), không thể chỉnh sửa các chân linh kiện trong trình biên tập sơ đồ nguyên lý (nhưng có thể chỉnh sửa trong trình biên tập thư viện sơ đồ nguyên lý). Tắt tùy chọn này để chỉnh sửa chân linh kiện trên trang sơ đồ nguyên lý.
-
– nhấp để hiển thị tất cả các chân ẩn và thuộc tính chân (tên và số), bao gồm cả những chân có thuộc tính Show bị tắt trong Trình chỉnh sửa chân linh kiện. Lưu ý rằng nếu bạn đang làm việc trong trình biên tập thư viện sơ đồ nguyên lý, tùy chọn View » Show Hidden Pins cũng phải được bật để hiển thị các chân ẩn trong trình biên tập thư viện.
-
– nhấp để thêm chân vào linh kiện. Cấu hình chân trong bảng Properties, sau đó nhấp và kéo để định vị chân.
-
– nhấp để xóa các chân đã chọn khỏi linh kiện.
-
– nhấp để mở hộp thoại Trình chỉnh sửa chân linh kiện. Hộp thoại này cung cấp một cách thuận tiện để xem/chỉnh sửa tất cả các chân của linh kiện hiện đang mở trong trình biên tập thư viện sơ đồ nguyên lý, hoặc của linh kiện đã chọn (hay một phần của linh kiện đó) trong trình biên tập sơ đồ nguyên lý.
Thuộc tính linh kiện tổng quát
Linh kiện tổng quát

Đặt linh kiện tổng quát từ bảng Components
Khi Altium Designer được kết nối với một Workspace, bạn có thể truy cập các linh kiện tổng quát có sẵn từ bảng Components. Các linh kiện này xuất hiện khi tùy chọn All được chọn trong ngăn Categories – hoặc từ menu thả xuống phía trên khi bảng ở chế độ thu gọn. Nhấp vào nút
trong ô linh kiện tổng quát để gắn linh kiện vào con trỏ và đặt vào sơ đồ nguyên lý đang hoạt động. Chọn chính ô đó sẽ mở danh mục loại linh kiện tương ứng trong bảng Components.
Thuộc tính linh kiện tổng quát
Thông tin chung
- Designator – nhập ký hiệu định danh. Bật/tắt biểu tượng con mắt để hiển thị/ẩn ký hiệu định danh. Nhấp vào biểu tượng khóa để khóa/mở khóa ký hiệu định danh.
- Comment – nhập tên. Bật/tắt biểu tượng con mắt để hiển thị/ẩn tên.
-
Description – mô tả linh kiện/phần linh kiện tổng quát.
- Replace – chọn nút Replace khi thiết kế đã tiến triển đến giai đoạn có thể thay thế linh kiện tổng quát bằng một linh kiện vật lý cụ thể thông qua hộp thoại Thay thế linh kiện.
Vị trí
-
(X/Y)
- X (trường thứ nhất) – tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, so với gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) – tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation – sử dụng danh sách thả xuống để chọn góc xoay.
Tham số
- Grid – liệt kê Name và Value của các tham số liên kết với linh kiện hiện được chọn. Sử dụng biểu tượng khóa để khóa/mở khóa một tham số trong danh sách. Giá trị tham số có thể được nhập thủ công hoặc chọn từ danh sách thả xuống cung cấp các giá trị lấy từ tất cả các linh kiện có sẵn thuộc loại đó. Bạn có thể sử dụng biểu tượng con mắt để hiển thị/ẩn tham số.
- Font – nhấp vào phông chữ đang hiển thị để thay đổi kiểu phông chữ.
-
Other – nhấp để mở danh sách thả xuống nhằm thay đổi các tùy chọn bổ sung:
- Show Parameter Name – bật để hiển thị tên tham số.
- Allow Synchronization with Database – bật để đồng bộ hóa với cơ sở dữ liệu. Tùy chọn này dùng để kiểm soát việc có cho phép cập nhật chú thích hay không. Theo mặc định, các tùy chọn này được bật để luôn cho phép đồng bộ hóa với thư viện/cơ sở dữ liệu nguồn. Bạn có thể tắt tùy chọn này để loại chú thích đó khỏi quá trình cập nhật.
- (X/Y) – nhập tọa độ X và Y.
- Rotation – sử dụng danh sách thả xuống để chọn góc xoay.
- Autoposition – chọn để bật tính năng tự động định vị, nghĩa là tham số được định vị tự động mỗi khi linh kiện liên kết được xoay. Tắt tùy chọn này để giữ nguyên vị trí tương đối của tham số so với linh kiện liên kết khi linh kiện được xoay.
Ký hiệu định danh
Ký hiệu định danh xác định duy nhất từng linh kiện trong thiết kế.
Tóm tắt
Trường ký hiệu định danh là một đối tượng tham số con của linh kiện (phần linh kiện) trên sơ đồ nguyên lý. Trường này được dùng để xác định duy nhất từng phần linh kiện đã đặt, giúp phân biệt nó với tất cả các phần linh kiện khác được đặt trên mọi trang sơ đồ nguyên lý trong dự án.
Khả năng sử dụng và cách đặt
Ký hiệu định danh được đặt tự động khi đối tượng phần linh kiện cha được đặt. Đây không phải là đối tượng thiết kế mà bạn có thể đặt trực tiếp.
Chỉnh sửa bằng đồ họa
Chuỗi ký hiệu định danh có thể được chỉnh sửa bằng đồ họa thông qua phương thức chỉnh sửa in-place. Để chỉnh sửa trực tiếp chuỗi ký hiệu định danh tại chỗ, hãy kéo con trỏ bao quanh ký hiệu định danh để chọn, sau đó nhấn Enter.

Ví dụ về chỉnh sửa tại chỗ
Sau khi chỉnh sửa xong, nhấn Enter hoặc nhấp ra ngoài chuỗi để thoát chế độ chỉnh sửa tại chỗ.
Chỉnh sửa phi đồ họa
Có hai khía cạnh cần xem xét khi chỉnh sửa ký hiệu định danh: chỉnh sửa giá trị của ký hiệu định danh và chỉnh sửa các thuộc tính hiển thị của ký hiệu định danh.
Các chuỗi ký hiệu định danh (và chú thích) có thể được hiển thị trong trình biên tập thư viện sơ đồ nguyên lý, sau đó nhấp đúp vào chúng để chỉnh sửa thuộc tính. Biểu tượng
gắn với trường này trong bảng Properties được dùng để hiển thị hoặc ẩn ký hiệu định danh.
Chỉnh sửa giá trị ký hiệu định danh trong trình biên tập sơ đồ nguyên lý
Ký hiệu định danh có thể được xác định trong trình biên tập sơ đồ nguyên lý khi đang đặt linh kiện hoặc sau khi linh kiện đã được đặt trên trang sơ đồ nguyên lý trong Properties panel.
- Để chỉnh sửa ký hiệu định danh trong khi đặt linh kiện, nhấn phím Tab khi linh kiện đang gắn với con trỏ. Bảng Properties sẽ mở ra; nhập chuỗi ký hiệu định danh cần dùng. Nhấp vào nút tạm dừng nổi trên không gian thiết kế để tiếp tục đặt.
- Tiếp tục đặt linh kiện hoặc nhấn Esc để kết thúc việc đặt.
- Nhấn Spacebar để xoay cung ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Thao tác này cũng có thể được thực hiện trong khi kéo đối tượng. Mỗi lần xoay là 90°.
- Để chỉnh sửa ký hiệu định danh sau khi đặt, nhấp đúp vào linh kiện đã đặt để mở bảng Thuộc tính , nơi bạn có thể chỉnh sửa ký hiệu định danh.
Chỉnh sửa thuộc tính hiển thị của ký hiệu định danh
Hình thức của chuỗi ký hiệu định danh, bao gồm loại phông chữ, kích thước và màu sắc, có thể được cấu hình trên trang Sơ đồ nguyên lý - Mặc định của hộp thoại Preferences. Các thiết lập này sẽ được áp dụng trừ khi bị ghi đè bởi các thiết lập được xác định trong ký hiệu linh kiện ở trình biên tập thư viện sơ đồ nguyên lý.
Cố định vị trí chuỗi ký hiệu định danh
Theo mặc định, ký hiệu định danh sẽ tự động được định vị khi linh kiện được xoay trong quá trình đặt. Nếu không cần hành vi này, hãy tắt tùy chọn Autoposition trong hộp thoại Preferences (tham khảo hình trước đó) trong khi tạo ký hiệu hoặc sau khi linh kiện đã được đặt trên trang sơ đồ nguyên lý. Lưu ý rằng thao tác này khiến tham số được phân loại là manual parameter (nghĩa là tham số được định vị thủ công). Các tham số thủ công được nhận biết bằng một dấu chấm ở góc dưới bên trái của khung chọn.
Lưu ý
-
Trình biên tập sơ đồ nguyên lý có tính năng tự động tăng ký hiệu định danh đơn giản, có thể sử dụng khi đặt nhiều bản thể của cùng một linh kiện. Để sử dụng tính năng này, nhấn Tab khi linh kiện đầu tiên đang gắn với con trỏ và nhập ký hiệu định danh phù hợp, ví dụ
R1. Các linh kiện tiếp theo sẽ được gán ký hiệuR2,R3, v.v. Lưu ý rằng khi chuyển sang đặt một loại linh kiện khác, bạn phải nhấn lại Tab và nhập tiền tố ký hiệu định danh phù hợp. -
Khi đặt linh kiện gồm nhiều phần và ký hiệu định danh ban đầu được gán như mô tả ở trên, hậu tố phần sẽ tự động được gán, ví dụ
U3A,U3B, v.v. Nếu không gán ký hiệu định danh ban đầu, tất cả các phần sẽ có cùng hậu tố. Điều này được giải quyết bằng lệnh Annotation của trình biên tập sơ đồ nguyên lý. Hậu tố phần có thể là chữ cái hoặc số. Sử dụng tùy chọn Alpha Numeric Suffix trên trang Sơ đồ nguyên lý - Chung của hộp thoại Preferences để cấu hình.
Thuộc tính ký hiệu định danh
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, so với gốc tọa độ hiện tại của không gian làm việc. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - Tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation - sử dụng danh sách thả xuống để chọn góc xoay.
Thuộc tính
- Object - hiển thị đối tượng liên quan.
- Tên - bật trường này bằng cách nhấp vào biểu tượng hiển thị để thêm tiền tố "Designator:" vào chính giá trị ký hiệu định danh. Thao tác này giúp phân biệt trực quan và xác nhận rằng giá trị văn bản là ký hiệu định danh trong tài liệu sơ đồ nguyên lý.
-
Value - hiển thị chính tên ký hiệu định danh. Bật/tắt biểu tượng con mắt
để hiển thị/ẩn giá trị.
- Tự động định vị - chọn để bật tính năng tự động định vị, nghĩa là văn bản sẽ giữ nguyên vị trí đã chọn khi linh kiện được di chuyển và xoay.
- Khóa tham số - chọn để khóa tham số, ngăn không cho chỉnh sửa giá trị từ bảng Properties hoặc tài liệu sơ đồ nguyên lý.
- Cho phép đồng bộ với cơ sở dữ liệu - bật để đồng bộ với cơ sở dữ liệu. Tùy chọn này được dùng để kiểm soát việc có cho phép cập nhật chú thích hay không. Theo mặc định, các tùy chọn này được bật để luôn cho phép đồng bộ với thư viện/cơ sở dữ liệu nguồn. Bạn có thể tắt tùy chọn này để ngăn chú thích đó được đưa vào quá trình cập nhật.
- Phông chữ - sử dụng các điều khiển để chọn phông chữ, cỡ chữ, màu chữ và thêm các đặc tính mong muốn cho phông chữ, chẳng hạn như đậm, nghiêng và gạch chân.
- Căn chỉnh - nhấp vào các mũi tên để cấu hình căn chỉnh văn bản hoặc nhấp vào hình tròn để căn giữa.
- Override Library Primitive (chỉ trong hộp thoại Preferences ) - chọn hộp kiểm này để ghi đè các thiết lập đối tượng cơ bản được xác định cho đối tượng ký hiệu định danh trong thư viện. Do đó, khi được đặt, linh kiện sẽ sử dụng các thiết lập đối tượng cơ bản mà bạn đã xác định trong hộp thoại Tùy chọn, thay vì các thiết lập đã được xác định cho linh kiện trong thư viện.
Chú thích
Chú thích cho phép hiển thị thông tin bổ sung về một linh kiện.
Tóm tắt
Trường Chú thích là đối tượng tham số con của một linh kiện (phần) trong sơ đồ nguyên lý. Trường này hiển thị thông tin bổ sung về linh kiện.
Khả năng sử dụng và cách đặt
Chú thích được cấu hình khi đối tượng phần linh kiện cha được đặt. Đây không phải là đối tượng thiết kế mà bạn có thể đặt trực tiếp.
Chỉnh sửa đồ họa
Có thể chỉnh sửa Comment bằng phương thức đồ họa được gọi là chỉnh sửa in-place. Để chỉnh sửa Comment tại chỗ, nhấp một lần để chọn, chờ một giây, rồi nhấp lần thứ hai để vào chế độ chỉnh sửa.
Sau khi chỉnh sửa xong, nhấn Enter hoặc nhấp ra ngoài chuỗi để thoát chế độ chỉnh sửa tại chỗ.
Chỉnh sửa phi đồ họa
Có hai khía cạnh cần xem xét khi chỉnh sửa Comment: chỉnh sửa giá trị của Comment và chỉnh sửa các thuộc tính hiển thị của Comment.
Chỉnh sửa Comment trong trình biên tập sơ đồ nguyên lý
Có thể xác định Comment trong trình biên tập sơ đồ nguyên lý khi đang đặt linh kiện hoặc sau khi linh kiện đã được đặt trên trang sơ đồ nguyên lý, trong trường Comment của bảng Properties.
- Để chỉnh sửa Comment trong khi đặt linh kiện, nhấn phím Tab khi linh kiện đang di chuyển theo con trỏ. Bảng Properties sẽ mở ra; nhập Comment mong muốn. Nhấp vào nút tạm dừng phủ trên không gian thiết kế để tiếp tục đặt linh kiện.
- Tiếp tục đặt linh kiện hoặc nhấn Esc để kết thúc việc đặt.
- Để chỉnh sửa Comment sau khi đặt, nhấp đúp vào linh kiện đã đặt để mở bảng Thuộc tính , nơi bạn có thể chỉnh sửa Comment.
Chỉnh sửa thuộc tính hiển thị của Comment
Hình thức hiển thị của các chú thích, bao gồm kiểu phông chữ, kích thước và màu sắc, có thể được cấu hình trên trang Sơ đồ nguyên lý - Mặc định của hộp thoại Preferences .
Cố định vị trí của Comment
Theo mặc định, Comment sẽ tự động được định vị khi linh kiện được xoay trong quá trình đặt. Nếu không cần hành vi này, hãy tắt tùy chọn Autoposition trong hộp thoại Preferences (tham khảo hình trước đó), trong khi tạo ký hiệu hoặc sau khi linh kiện đã được đặt trên trang sơ đồ nguyên lý. Lưu ý rằng thao tác này sẽ phân loại tham số này thành manual parameter (nghĩa là tham số được định vị thủ công). Các tham số thủ công được nhận biết bằng một dấu chấm ở góc dưới bên trái của khung chọn.
Thuộc tính Comment
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, tính từ gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ đo lường Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - Tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, tính từ gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ đo lường Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation - sử dụng danh sách thả xuống để chọn góc xoay. Các lựa chọn gồm: 0 Degrees, 90 Degrees, 180 Degrees và 270 Degrees.
Thuộc tính
- Linh kiện - hiển thị tên của linh kiện liên quan. Nhấp vào liên kết Component để mở bảng Thuộc tính linh kiện, nơi bạn có thể chỉnh sửa các tùy chọn của linh kiện cũng như chính Comment, được xác định trong trường Comment của bảng đó.
- Tên - bật trường này bằng cách nhấp vào biểu tượng hiển thị để thêm tiền tố "Comment:" vào giá trị chú thích. Thao tác này giúp phân biệt trực quan và xác nhận rằng giá trị văn bản là một chú thích trong tài liệu sơ đồ nguyên lý.
-
Giá trị - hiển thị chính tên chú thích. Chuyển đổi để hiện/ẩn giá trị.
- Tự động định vị - chọn để bật tính năng tự động định vị, nghĩa là văn bản sẽ giữ nguyên vị trí đã chọn khi linh kiện được di chuyển và xoay.
- Khóa tham số - chọn để khóa tham số, ngăn việc chỉnh sửa giá trị từ bảng Properties hoặc tài liệu sơ đồ nguyên lý.
- Cho phép đồng bộ hóa với cơ sở dữ liệu - bật để đồng bộ hóa với cơ sở dữ liệu. Tùy chọn này được dùng để kiểm soát liệu chú thích có thể được cập nhật hay không. Theo mặc định, tùy chọn này được bật để luôn cho phép đồng bộ hóa với thư viện/cơ sở dữ liệu nguồn. Bạn có thể tắt tùy chọn này để ngăn chú thích được đưa vào quá trình cập nhật.
- Phông chữ - sử dụng các điều khiển để chọn phông chữ, cỡ chữ, màu chữ và thêm các đặc tính mong muốn cho phông chữ, chẳng hạn như đậm, nghiêng và gạch chân.
- Căn chỉnh - nhấp vào các mũi tên để cấu hình cách căn chỉnh văn bản hoặc nhấp vào hình tròn để căn giữa.
- Override Library Primitive (chỉ trong hộp thoại Preferences ) - chọn ô này để ghi đè các thiết lập đối tượng cơ bản được xác định cho đối tượng chú thích trong thư viện. Do đó, khi đặt linh kiện, linh kiện sẽ sử dụng các thiết lập đối tượng cơ bản mà bạn đã xác định trong hộp thoại Preferences, thay vì các thiết lập đã được xác định cho linh kiện trong thư viện.
Cập nhật và thay thế linh kiện từ thư viện
Sau khi đặt các linh kiện ban đầu lên các trang sơ đồ nguyên lý của một thiết kế bo mạch, cần có cách cập nhật các phiên bản linh kiện đã đặt này theo mọi thay đổi của các linh kiện nguồn được liên kết trong Workspace tương ứng. Nói cách khác, cần có phương thức để giữ cho thiết kế đồng bộ với các đối tượng trong Workspace mà thiết kế sử dụng.
Ví dụ, một linh kiện có thể đã được lưu lại vào Workspace, có thể để phản ánh thay đổi đối với một mô hình con. Việc này tạo ra một bản sửa đổi mới của linh kiện đó. Phiên bản linh kiện đã đặt hiện đang sử dụng một bản sửa đổi cũ hơn và bạn có thể muốn cập nhật để sử dụng bản sửa đổi mới nhất. Hoặc bạn có thể đã quyết định sử dụng một linh kiện hoàn toàn khác và chỉ cần thay linh kiện hiện có trong thiết kế bằng một linh kiện thay thế.
Có nhiều phương pháp để quản lý linh kiện sau khi đặt chúng vào thiết kế lần đầu.
Thay đổi từng bản thể linh kiện
Mỗi linh kiện đã đặt đều có liên kết về phiên bản linh kiện trong Workspace. Bạn có thể tìm thấy thông tin này trên bảng Properties khi xem các thuộc tính của linh kiện được chọn.
Mỗi bản thể linh kiện đã đặt đều có liên kết về phiên bản cụ thể của linh kiện đó trong Workspace.
Ở cấp độ riêng lẻ này, bản thể linh kiện đã đặt có thể được:
-
Cập nhật lên phiên bản mới nhất của linh kiện hiện tại bằng cách nhấp vào nút
.
Ví dụ về việc cập nhật cùng một linh kiện lên phiên bản mới nhất – di chuột lên hình ảnh để xem kết quả.
-
Thay bằng phiên bản mới nhất của một linh kiện khác (linh kiện thay thế) trong Workspace hoặc một linh kiện từ thư viện dựa trên tệp bằng cách nhấp vào nút
ở bên phải trường Design Item ID. Hộp thoại Replace Component sẽ mở ra, hiển thị các linh kiện trong Workspace đang kết nối và các thư viện dựa trên tệp hiện có. Linh kiện hiện tại được hiển thị ở đầu danh sách. Tìm linh kiện thay thế cần dùng, chọn linh kiện đó, rồi nhấp vào OK.
Ví dụ về việc thay linh kiện hiện tại bằng một linh kiện khác (linh kiện thay thế)
Hộp thoại Replace Component cho phép truy cập trực tiếp vào tất cả linh kiện thư viện Workspace và linh kiện thư viện dựa trên tệp hiện có. Hộp thoại cung cấp thông tin đầy đủ về linh kiện được chọn (tham số, mô hình, các lựa chọn mã linh kiện, dữ liệu nhà cung cấp, v.v.), chức năng so sánh linh kiện và, đối với linh kiện thư viện Workspace, khả năng tìm kiếm theo tham số dựa trên bộ lọc để chỉ định các tham số linh kiện mong muốn.
Các tùy chọn và điều khiển của hộp thoại Replace Component
- Search - sử dụng ô tìm kiếm văn bản để tìm thủ công một linh kiện cụ thể.
-
- nhấp để mở rộng hoặc thu gọn ngăn Categories – để hiển thị một số loại linh kiện nhất định hoặc hiển thị tất cả linh kiện hiện có. Sử dụng thanh tìm kiếm bên dưới ngăn Categories để tìm thủ công một danh mục linh kiện cụ thể hoặc thư viện linh kiện dựa trên tệp hiện có.
-
- nhấp để truy cập menu và chọn một trong các mục sau:
- File-based Libraries Preferences - nhấp để mở hộp thoại Available File-based Libraries nhằm thêm hoặc xóa thư viện.
- File-based Libraries Search - nhấp để mở hộp thoại File-based Libraries Search nhằm tìm kiếm thư viện.
- Refresh - nhấp để làm mới hộp thoại.
-
- nhấp để mở/đóng Details vùng của hộp thoại (được mô tả bên dưới).
Bộ lọc
Khi một danh mục linh kiện Workspace được chọn, nhấp vào biểu tượng Filters để mở vùng Filters, nơi bạn có thể lọc thêm các danh mục được chọn trong danh sách Components . Bạn có thể tùy chỉnh các tùy chọn Filters của bảng theo nhu cầu bằng cách chọn các loại tham số cụ thể làm Favorites; khi đó, chúng sẽ được chuyển lên đầu danh sách cho danh mục linh kiện hiện tại. Di chuột sang bên phải tên bộ lọc tham số rồi nhấp vào biểu tượng để đặt bộ lọc làm mục Yêu thích. Thiết lập bộ lọc Yêu thích được áp dụng và lưu riêng cho từng Categorieslinh kiện.
Linh kiện
- Name - tên của linh kiện.
- Description - mô tả của từng linh kiện.
- Footprint - footprint của linh kiện.
- Results - liệt kê tổng số linh kiện được tìm thấy/liệt kê trong kết quả tìm kiếm.
Chi tiết
- Component Revision ID - liệt kê ID phiên bản và giá của một linh kiện nhất định. Nhấp vào ID phiên bản để mở bảng Explorer và xem thêm thông tin về linh kiện.
- References - nhấp để mở thông tin tham khảo về linh kiện trong trình duyệt web. Sử dụng danh sách thả xuống để truy cập Manufacturer URL hoặc Datasheet.
- Place - nhấp để đặt linh kiện được chọn vào tài liệu sơ đồ nguyên lý.
- Component information - liệt kê các thông tin liên quan về linh kiện, bao gồm nhà sản xuất, ngày phát hành và thông tin mô tả. Nhấp vào liên kết Show More để xem toàn bộ thông tin; nhấp vào Show Less để thu gọn thông tin.
- Models - mở rộng để xem các mô hình được cung cấp. Sử dụng các liên kết hiện có để hiển thị các phần khác nhau của một mô hình.
- References - mở rộng để truy cập Manufacturer URL, Datasheet và Package Specification.
- Part Choices - mở rộng để xem các lựa chọn mã linh kiện. Tên, giá và mô tả sẽ được cung cấp. Bảng dữ liệu của linh kiện cũng sẽ được liệt kê.
- Where Used - mở rộng để xem các dự án sử dụng linh kiện.
Menu chuột phải
- Find Similar Components - nhấp để mở hộp thoại Find Similar Components, nơi bạn có thể tìm kiếm các linh kiện khác có đặc tính tương tự.
- Place <component> - nhấp để đặt linh kiện vào tài liệu phù hợp.
- Edit - nhấp để mở các tài liệu thư viện linh kiện của linh kiện được chọn.
- Navigate to <revision> - nhấp để mở linh kiện được chọn trong bảng Explorer.
- Operations - di chuột để truy cập các chức năng Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL và Full Item History.
- Refresh- nhấp để làm mới nhằm xem các cập nhật hoặc chỉnh sửa gần đây. Bạn cũng có thể làm mới bằng phím tắt F5.
- Library Report - khi một thư viện dựa trên tệp được chọn trong ngăn Categories, nhấp để truy cập hộp thoại Library Report Settings, trong đó bạn có thể sử dụng các điều khiển được cung cấp để cấu hình báo cáo thư viện.
Thực hiện thay đổi linh kiện hàng loạt – Item Manager
Related page: Quản lý nội dung bằng Item Manager
Việc thay đổi từng linh kiện rất hữu ích, tuy nhiên sẽ nhanh chóng trở nên tốn công khi phải xử lý số lượng linh kiện lớn hơn. Khi đó, bạn cần một nơi tập trung duy nhất để thực hiện nhiều thay đổi theo lô. Đó chính là Item Manager (Tools » Item Manager).
Item Manager là “trung tâm điều phối” để đồng bộ các đối tượng thiết kế trong Workspace – được đặt trên các trang sơ đồ nguyên lý – với nội dung nguồn mà chúng liên kết đến trong Workspace. Công cụ này tự động phát hiện và liệt kê tất cả các linh kiện, đánh dấu xem chúng có phải là đối tượng Workspace hay không, sau đó so sánh phiên bản Item của từng linh kiện Workspace trên sơ đồ nguyên lý với các phiên bản hiện có của linh kiện đó trong Workspace. Với mỗi đối tượng, thông tin về Item đang được liên kết được cung cấp, bao gồm phiên bản, trạng thái vòng đời và Workspace nguồn chứa Item đó.
Bạn có toàn quyền kiểm soát việc cập nhật đối tượng Workspace nào và cập nhật như thế nào. Ví dụ:
- Chọn một mục riêng lẻ và cập nhật để sử dụng phiên bản mới nhất của Item được liên kết, hoặc chọn sử dụng phiên bản mới nhất của một Item hoàn toàn khác.
- Chọn một nhóm mục sử dụng cùng một Item được liên kết và cập nhật chúng lên phiên bản mới nhất của Item đó, hoặc chọn sử dụng phiên bản mới nhất của một Item hoàn toàn khác.
Tất cả các thay đổi được đề xuất đều được thể hiện trong trình quản lý.
Sau khi thiết lập các thay đổi theo yêu cầu, hãy tạo Lệnh thay đổi kỹ thuật (ECO) và xem các thao tác sẽ được thực hiện để áp dụng những thay đổi đó. Vô hiệu hóa bất kỳ thao tác nào nếu cần – bạn luôn nắm quyền kiểm soát! Khi đã sẵn sàng, hãy thực thi ECO để áp dụng các thay đổi. Nhanh chóng và hiệu quả, nội dung Workspace đã đặt trong thiết kế của bạn được quản lý một cách đơn giản, dễ dàng.
Các ví dụ sau minh họa cách sử dụng Item Manager:
- Cập nhật nhiều linh kiện để sử dụng phiên bản mới nhất của linh kiện Workspace hiện tại.

Cập nhật một nhóm linh kiện đã lỗi thời lên phiên bản mới nhất.
- Thay một vài linh kiện bằng phiên bản mới nhất của một linh kiện Workspace khác – được chọn thông qua hộp thoại Thay thế linh kiện.

Thay thế một hoặc nhiều linh kiện bằng một linh kiện Workspace khác.
Item Manager không chỉ giúp duy trì sự đồng bộ giữa các linh kiện trong thiết kế và những thay đổi của nội dung nguồn trong các Workspace được kết nối, mà còn là công cụ mạnh mẽ hỗ trợ chuyển đổi các thiết kế bo mạch hiện có – từ sử dụng các mục thiết kế cục bộ sang sử dụng nội dung thiết kế Workspace. Sau khi chuyển các linh kiện thiết kế và mọi trang sơ đồ nguyên lý (trang thiết bị) sang Workspace, bạn sử dụng Item Manager để “thay thế” các linh kiện và ký hiệu trang hiện có bằng các đối tượng Workspace tương ứng vừa được chuyển đổi. Nói cách khác, xét về mặt thiết kế, các linh kiện vẫn giữ nguyên, nhưng nguồn của chúng thay đổi.
Thay đổi linh kiện từ BomDoc
Việc phát hiện vấn đề với một linh kiện trong quá trình kiểm tra BomDoc và chuẩn bị đặt mua linh kiện là khá phổ biến. Ví dụ, người thiết kế có thể đã quên chốt lựa chọn linh kiện, hoặc một linh kiện đã ngừng sản xuất (EOL) và người thiết kế muốn tìm hiểu giá cả cũng như khả năng cung ứng của các linh kiện thay thế tiềm năng. Bạn có thể giải quyết vấn đề này bằng cách quay lại sơ đồ nguyên lý để chỉnh sửa linh kiện, chọn một linh kiện phù hợp rồi làm mới BomDoc. Tuy nhiên, ActiveBOM hỗ trợ thực hiện việc này trực tiếp trong BomDoc – sau đó chuyển thay đổi đó trở lại sơ đồ nguyên lý thông qua Lệnh thay đổi kỹ thuật.
Trong BomDoc, nhấp chuột phải vào các linh kiện đã chọn và chọn lệnh Operations » Change <ComponentName>. Hộp thoại Thay thế linh kiện sẽ mở ra, cho phép bạn tìm kiếm linh kiện thay thế. Sau khi tìm được linh kiện thay thế mong muốn, hãy chọn linh kiện đó rồi nhấp vào OK. Hộp thoại Engineering Change Order sẽ mở ra, trình bày chi tiết các thay đổi cần thiết để đồng bộ sơ đồ nguyên lý với BomDoc.

Ví dụ về thay thế linh kiện trực tiếp trong BomDoc.
Thay thế linh kiện tổng quát
Khi thiết kế đã tiến triển đến giai đoạn có thể thay một linh kiện tổng quát bằng một linh kiện vật lý cụ thể, hãy mở hộp thoại Thay thế linh kiện bằng cách chọn nút
trong bảng Properties. Lưu ý rằng bạn cũng có thể thực hiện việc này từ Trình quản lý Item hoặc thông qua tài liệu ActiveBOM của dự án.
Các giá trị tham số đã áp dụng cho linh kiện tổng quát (ở đây là công suất và điện trở) được tự động sử dụng làm từ khóa tìm kiếm trong hộp thoại Replace Generic Component, cho phép bạn chọn linh kiện thay thế phù hợp từ các kết quả đã lọc – trong ví dụ này, có hai mục linh kiện đáp ứng tiêu chí tìm kiếm.
|
Thay thế linh kiện tổng quát thông qua bảng Properties. Thay thế linh kiện tổng quát thông qua bảng Properties. |
Quản lý footprint trên toàn bộ thiết kế
Trình biên tập sơ đồ nguyên lý của Altium Designer tích hợp Footprint Manager mạnh mẽ. Được mở từ menu Công cụ của Trình biên tập sơ đồ nguyên lý (Tools » Footprint Manager), Footprint Manager cho phép bạn xem xét tất cả footprint liên kết với từng linh kiện trong toàn bộ dự án. Khả năng chọn nhiều mục giúp bạn dễ dàng chỉnh sửa việc gán footprint cho nhiều linh kiện, thay đổi cách liên kết footprint hoặc thay đổi footprint hiện đang được gán cho các linh kiện có nhiều footprint. Footprint Manager giúp xem xét và phát hiện các vấn đề về việc gán footprint trên toàn bộ thiết kế, đặc biệt hữu ích khi bạn đang làm việc với một thiết kế cũ hoặc thiết kế từ một tổ chức khác. Các thay đổi thiết kế được áp dụng thông qua hệ thống ECO, cập nhật cả sơ đồ nguyên lý và PCB nếu cần.
Hộp thoại Footprint Manager hiển thị danh sách tất cả linh kiện trên mọi sơ đồ nguyên lý nguồn của dự án đang hoạt động. Sử dụng các điều khiển ở phía bên phải hộp thoại để quản lý các footprint có sẵn cho linh kiện trong thiết kế và các footprint hiện đang được sử dụng. Các tính năng bao gồm:
- Khả năng thêm, chỉnh sửa và xóa mô hình footprint cho một hoặc nhiều linh kiện đã chọn.
- Sao chép footprint giữa các linh kiện.
- Thay đổi footprint hiện được gán (footprint hiện sẽ được sử dụng để biểu diễn linh kiện trên PCB, trong số nhiều footprint có thể có sẵn cho linh kiện đó).
- Xác thực footprint – để đảm bảo các mô hình footprint thực sự có sẵn, đặc biệt là những mô hình được đặt làm mô hình hiện tại.
Sau khi hoàn tất tất cả các thay đổi cần thiết đối với việc gán mô hình footprint, các thay đổi đó sẽ được áp dụng thông qua một Lệnh thay đổi kỹ thuật (ECO) tiêu chuẩn. Để thực hiện, chỉ cần nhấp vào nút Accept Changes (Create ECO) ở góc dưới bên phải của hộp thoại Footprint Manager.
Các tùy chọn và điều khiển của hộp thoại Footprint Manager
Danh sách linh kiện
Đây là danh sách tất cả các linh kiện trên các trang sơ đồ nguyên lý của dự án thiết kế PCB đang được chọn. Thông tin bao gồm:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Xem và chỉnh sửa footprint
Đây là danh sách các footprint liên kết với linh kiện được chọn trong Component List. Sử dụng các điều khiển ở cuối khu vực này hoặc các lệnh trong menu chuột phải để thao tác với footprint trong danh sách.
Menu chuột phải
-
Add - nhấp để mở hộp thoại PCB Model nhằm chọn một mô hình footprint mới để thêm cho linh kiện sơ đồ nguyên lý đang được tô sáng. Không khả dụng khi chọn một linh kiện được quản lý.
-
Remove - nhấp để xóa footprint đã chọn. Không khả dụng khi chọn một linh kiện được quản lý.
-
Edit Footprint - nhấp để mở hộp thoại PCB Model. Hộp thoại PCB Model xác định mô hình footprint nào được liên kết với linh kiện sơ đồ nguyên lý và những thư viện mà trình chỉnh sửa sơ đồ nguyên lý có thể tìm kiếm footprint. Không khả dụng khi chọn một linh kiện được quản lý.
-
Validate Footprint Paths - nhấp để xác nhận rằng có thể tìm thấy footprint đang được tô sáng tại vị trí được phép. Nếu không tìm thấy footprint, Not Validated sẽ xuất hiện trong trường Found In. Nếu footprint được xác thực, đường dẫn đầy đủ đến footprint này sẽ được hiển thị.
-
Change PCB Library - nhấp để mở hộp thoại Edit PCB Library nhằm thay đổi thư viện PCB của footprint đã chọn. Hộp thoại này là phiên bản đơn giản hơn của hộp thoại PCB Model, cung cấp các tùy chọn PCB Library để xác định nơi phần mềm có thể tìm kiếm mô hình footprint.

Hộp thoại Edit PCB Library- Any - tìm kiếm mô hình phù hợp trong tất cả các thư viện hiện có.
- Library name - chỉ tìm kiếm mô hình phù hợp trong các thư viện hiện có mang tên này.
- Library path - chỉ tìm kiếm mô hình phù hợp trong thư viện mang tên này tại vị trí này. Nhập thủ công đường dẫn và tên thư viện, hoặc nhấp vào nút Choose để mở hộp thoại Windows Open, cho phép bạn duyệt đến thư viện cần dùng.
- Use footprint from source integrated library, database library, or server - chỉ tìm kiếm mô hình trong thư viện tích hợp/thư viện cơ sở dữ liệu/máy chủ mà linh kiện đã được lấy từ đó để đặt vào thiết kế. Thư viện tích hợp hoặc thư viện cơ sở dữ liệu phải khả dụng; nếu là máy chủ, bạn phải kết nối với máy chủ đó.
-
Copy - nhấp để sao chép thông tin chi tiết của footprint đang được chọn.
-
Paste - nhấp để dán (thêm) thông tin footprint đã sao chép vào linh kiện sơ đồ nguyên lý đang được chọn.
-
Select All - nhấp để chọn tất cả các footprint hiện hiển thị trong danh sách View and Edit Footprints.
-
Set As Current - nhấp để đặt footprint đã chọn làm footprint hiện hành (được biểu thị bằng
trong cột Current ).
-
Add to All Parts - nhấp để thêm footprint đã chọn vào tất cả các phần khác của cùng một linh kiện sơ đồ nguyên lý (lệnh này chỉ khả dụng nếu linh kiện đã chọn là linh kiện nhiều phần và một hoặc nhiều phần của linh kiện chưa được gán footprint này).
Các điều khiển bổ sung
-
Menu - nhấp để xem menu có các điều khiển giống với menu chuột phải ở trên.
-
Add, Remove, Edit, Validate - các nút này thực hiện những chức năng giống với các mục menu được mô tả ở trên.
-
Accept Changes (Create ECO) - nhấp để chấp nhận các thay đổi đối với linh kiện sơ đồ nguyên lý và các mô hình footprint liên kết, đồng thời mở hộp thoại Engineering Change Order. Với hộp thoại ECO, bạn có thể xác thực và áp dụng các thay đổi sau khi rà soát những chỉnh sửa đối với giá trị footprint của các linh kiện sơ đồ nguyên lý tương ứng.













