Altium Designer Documentation

Device Sheets

Modified by Susan Riege on Jul 9, 2020

Parent page: Design Reuse

There is a strong incentive to re-use sections of circuitry from existing designs; the design is proven so the engineering is complete, it saves time, it can help reduce component inventory, and it frees up your design team to focus on the development of new concepts and products.

Designers are clever people - they already reuse existing designs all the time. It might be a proven circuit that they re-capture, or perhaps they copy and paste from an existing design, or they link an existing schematic sheet into a new design.

Device Sheets simplify the design process by providing modularized and consistent building blocks that can be reused between projects. Device Sheet Symbols are placed and referenced similarly to components. They are connected to and function in the same way as a sheet symbol that is referencing a standard schematic document, but are not explicitly added to a project.

Device Sheets

Device Sheets are building blocks developed with the intent of being reused in different designs. They usually contain predefined circuits that are useful in multiple projects, for example, a power supply.


One Device Sheet can be used across multiple projects.

A Device Sheet is created and stored as a normal schematic document, in a declared Device Sheet Folder. Rather than being added as a document, they are placed and referenced in a project in a similar way as a component. Device Sheets are included in the project hierarchy and can be distinguished from standard schematic documents by a different document icon in the Projects Panel.

By default, Device Sheets are usually configured to be read-only. This gives all designers in the team confidence that they are complete and ready-for-use, and also ensures that no one in the design team can inadvertently modify them. Because they are configured to be read-only, the component designators cannot be changed, nor can the schematic sheet number.

The fundamental difference between a device sheet and a regular schematic sheet is that the software has additional features to handle component annotation and the schematic sheet numbering when the project includes Device Sheets.

Device Sheets Versus Managed Sheets

While learning about design re-use, you might have come across the terms Device Sheets and Managed Sheets. In terms of what they deliver to the designer, they are very similar. Both provide a straightforward mechanism to re-use existing design content, and both have support for project-level component re-annotation and schematic sheet numbering.

Where they differ is that Device Sheets must be managed by the designer, including document access control, revision control, history, lifecycle management, and so on.

A Managed Sheet is essentially a Device Sheet stored in a managed content server. As managed content, all of the document management tasks are handled by the server, including document access control, revision control, history, and lifecycle management.

Learn more about Managed Projects

Learn more about Working with a Managed Content Server

Enabling Device Sheet Support

  1. Using Windows File Explorer, create a folder in a suitable location to hold your Device Sheets. If required, you can create a parent folder called Device Sheets with sub-folders to suit your company's requirements, such as Data Conversion, Power, and so on.

  1. The Device Sheet parent folder is declared in the Data Management - Device Sheets page of the Preferences dialog as shown below. Enable the Include Sub-folders option if required.

Creating a Device Sheet

A Device Sheet can be any normal schematic sheet, including a schematic that contains Sheet Symbols that reference other schematic sheets. It is the fact that they are placed as a Device Sheet from the Device Sheet folder that flags to the software that this schematic sheet is a Device Sheet, that the Device Sheet control options defined in the Preferences dialog must be applied, and the special annotation and sheet numbering commands obeyed.

By default, Device Sheets are usually configured to be read-only. The challenge of working with Device Sheets is not protecting that chunk of design from modification, it is dealing with the design finalization tasks that are carried out when the design is complete, namely schematic sheet numbering and component annotation.

There are some preparatory steps that should be taken before a schematic is copied or moved into the Device Sheet storage folder:

  • Think of the Device Sheet as a completed piece of work, make sure it has the correct template applied, with the required company annotations and special strings defined.
  • Using a systematic naming scheme for Device Sheets can help order the Device Sheets in the Select Device Sheet dialog.
  • Annotate the Device Sheet schematic (Tools » Annotation » Annotate Schematics) before putting it into the Device Sheets folder. Some designers use a simple, flat component numbering scheme, others include a suffix to reflect the function of that circuitry. When the design is complete, all of the sheets and components can be renumbered across the project.

Using a Device Sheet in your Project

A Device Sheet is used in a project by placing the Sheet Symbol that represents it. To do this:

  1. Run the command Place » Device Sheet Symbol.
  2. The Select Device Sheet dialog will open. The tree on the left displays the folder structure below the folder chosen in the Data Management - Device Sheets page of the Preferences dialog. Any schematic sheets detected in the selected folder will be listed on the right side of the dialog as shown below.

Select the correct Device Sheet folder on the left, then the required Device Sheet on the right.

  1. Select the required Device Sheet then click OK. You will be returned to the schematic editor with the Sheet Symbol for that Device Sheet floating on the cursor.
  2. Single-click to place the Sheet Symbol. Note that the Device Sheet Symbol is different from a Sheet Symbol that references a regular schematic sheet and has rounded corners and a recycled symbol. You are free to resize the placed symbol and relocate the Sheet Entries. 


A placed Device Sheet Symbol.

  1. Note that a different document icon is used to represent a Device Sheet when compared to a regular schematic sheet.

The Device Sheet will appear in the project hierarchy with a special Device Sheet icon.

The Device Sheet Symbol will be assigned the designator U_<DeviceSheetFileName>; edit this as required.

The Device Sheet can now be wired in the same way as a standard Sheet Symbol. All of the standard wiring features are supported, such as Net Labels, Ports and Sheet Entries, Power Ports, and Wiring Harnesses.

Learn more about Creating Connectivity.

Device Sheet Properties


A Read-Only Device Sheet. Note the Editor tab at the bottom of the design window has the suffix (ReadOnly) to indicate that you are viewing a Device Sheet
that cannot be edited. There is also an option to display a Read Only watermark and a Device Sheet (recycle) watermark.

Once you have placed a Device Sheet Symbol, open the Device Sheet itself to view its graphical properties. The default setting in the software is for Device Sheets to be read-only as configured in the Options section of the Data Management - Device Sheets page of the Preferences dialog. Note that the Read-Only option is independent of the display of the Read Only Watermark across the sheet; check the Editor tab at the bottom of the editing window to see if a sheet is ReadOnly (as shown above).

Editing a Device Sheet

You can edit Device Sheets in one of two ways: either directly in your project or from the source schematic documents in the Device Sheet folders.

Edit Device Sheets Directly in Your Project

To edit Device Sheets directly in your project:

  • Click the  at the top right to open the Preferences dialog.
  • Navigate to the Data Management - Device Sheets page.
  • Disable the Make Device Sheets in Projects Read-Only checkbox then click OK.

Configure the Device Sheet options as required. Note that these are environment settings, which means they apply to all Device Sheets in all designs edited in this installation of the software.

You will notice that once your Device Sheets are editable, the Read Only watermark is removed and the Editor tab no longer has the (ReadOnly) suffix.

This approach to Device Sheet editing is not recommended, as it means all Device Sheets can be edited in this installation of the software.

Edit a Device Sheet From the Device Sheet Folder

To edit Device Sheets from your Device Sheet folders:

  • Close all open projects that reference the Device Sheet. You will not be able to open a Device Sheet as a source schematic if there is a project currently open that references that Device Sheet.
  • Use the File » Open command to open the Device Sheet from its source in the Device Sheet folder. The sheet will present as a standard schematic, without any watermarks.
  • Make the modifications as required, save the changes then close the Device Sheet.

Note that once you have modified a Device Sheet, all projects referencing this Device Sheet will also be updated.

This is the recommended approach to modifying a Device Sheet.

Hierarchical Design with Device Sheets

A Device Sheet may contain Device Sheet Symbols, although a Device Sheet cannot be the top sheet in a project due to hierarchical implications. There are no limitations to the depth of the hierarchical structure when using Device Sheets.

To prepare hierarchical Device Sheets:

  • Prepare and save all of the relevant child schematic documents as Device Sheets in the Device Sheet folder.
  • Place the Device Sheet Symbol(s) in the parent schematic and save this in the Device Sheet folder.


This schematic is a Device Sheet and it also has a Device Sheet Symbol placed on it referencing a child Device Sheet.

Device Sheets can also be used in multi-channel design, a feature that allows a section of circuitry to be repeated, without copying/pasting that section.

Learn more about Multi-Sheet and Multi-Channel Design.

Refactoring your Design with Device Sheets

Main article: Design Refactoring

The process of design is often unstructured and organic; the designer could be formulating ideas for multiple parts of the design at the same time, capturing sections as their ideas evolve. That means that what started out as a well organized, neatly laid out set of schematics can become crowded and poorly organized. While you can cut, copy and paste to reorganize the schematic design, this is not always the best approach.

Why not cut and copy? Because as each component is placed, it is assigned a unique identifier, and this identifier is automatically reset whenever a component is cut, copied and pasted. This UID management is done to ensure that there is only one instance of each UID used in the design, as it is the key field that links the schematic component to the PCB component. The cut/copy/paste approach is fine if the design has not been transferred to the PCB editor, but if it has, then it is better to use the refactor tools.

Moving a Sub-circuit to Another Sheet

The easiest way to move a section of circuitry from one sheet to another is to select it then run the Edit » Refactor » Move Selected Subcircuit to Different Sheet command (also available via the right-click menu when there is a selection). The Choose Destination Document dialog will open. When you select the target sheet then click OK, that sheet will appear with the sub-circuit floating on the cursor, ready to position.


A selected section of circuitry can easily be moved to a different sheet in the project using the Move Selected Subcircuit to Different Sheet command.

The refactoring commands support:

  • Converting an existing schematic into a Device Sheet.
  • Converting a Device Sheet into a regular schematic sheet.
  • Moving a section of circuitry to another sheet.
  • Converting a part to a Sheet Symbol.

Learn more about Design Refactoring.

Annotating the Components and the Sheets

To guarantee the integrity of the circuitry used in a Device Sheet, that sheet should not be edited during normal design use. That means the sheet number and designator assignments should not be modified on the sheet. So just how do you number all the sheets in the project and annotate all of the components?

These tasks are managed by two commands: sheets are numbered using the Annotate Compiled Sheets command and components are annotated using the Board Level Annotation command. Sheet number and designator assignments are stored in a separate file, <ProjectName>*.annotation

The component annotation tools need to know the order that the schematic sheets are to be processed. For this reason, it is better to number the sheets before numbering the components.

Annotating Compiled Device Sheets

Main article: Numbering the Sheets

Complimenting the Board Level Annotation feature, the Tools » Annotation » Annotate Compiled Sheets command is used to uniquely number Device Sheets without modifying the source schematics. As with component annotations, the sheet numbers are stored in the <ProjectName>*.annotation file.

Notes about sheet numbering:

  • Sheets can be numbered according to the order they appear in the Projects panel. This order can be changed in the Projects panel using drag and drop. Save the project after changing the order so that the project file reflects the latest order when an annotation dialog is used. Note that drag and drop order changing is not supported for Device Sheets.
  • Number the non-Device Sheets using the Tools » Annotation » Number Schematic Sheets. Press F1 over the dialog to learn more about the options and controls.
  • Then number all sheets including Device Sheets using the Tools » Annotation » Annotate Compiled Sheets.
  • Numbering dialogs support entering values directly; this approach can sometimes be more efficient.
  • Many of the dialogs have dual-purpose buttons, such as the Annotate Sheet button (shown above):
    • Click the down arrow on the button to reveal the numbering options; configure these as required,
    • Then click the main part of the button to number in accordance with the options just selected.

Learn more about Annotating Compiled Sheets.

Component Annotation

Main article: Annotating the Components

To allow the component designators to be uniquely assigned across the entire project, the software includes a feature called Board Level Annotation. This command does not edit the source schematic sheets. Instead, it stores mapping information, mapping each logical schematic designator to a physical PCB designator as they will appear on the PCB. These designator mappings are stored in a project file called <ProjectName>*.annotation. There is a broad range of annotation options available in the Board Level Annotate dialog.


Board Level Annotation allows the completed design to be re-annotated, assigning a unique physical designator to each component.

Notes about working with Board Level Annotation, referring to the image above:

  • All schematic components must be assigned a designator before running the Board Level Annotate command using the Tools » Annotation » Annotate Schematics command. This ensures that the schematic source data, including packaged options for multi-part components, is available as input for the Board Level Annotation process. Note that components on Device Sheets should have already been annotated when the Device Sheet was opened for editing as a source file. 
  • Board Level Annotation is performed by running the Tools » Annotation » Board Level Annotate command.
  • In the image above, the schematic Editor tab is active. This tab always shows the logical designators at the standard size with the assigned physical (PCB) designators shown in superscript. The Compiled tab of the schematic (U_CVE in this example) is the opposite; it shows the physical designators at the standard size, with the logical designators shown in superscript. This behavior is configured on the Schematic - Compiler page of the Preferences dialog as shown below.

  • The default behavior in the PCB editor is to display the physical designators. This can be changed in the Properties panel in Board mode as shown below (displayed when nothing is selected in the PCB workspace).

Learn more about Board Level Annotation.

Troubleshooting

If you open a project containing Device Sheets and the location of these Device Sheets has not been declared, you will see the following dialog with a list of the Device Sheets that cannot be found.

If you click Yes, the Device Sheet Folders section of the Data Management - Device Sheets page of the Preferences dialog will open. It might be that the Include Sub-Folders option has not been enabled, otherwise, add in the new path if the Device Sheets used in the project are stored in a different location.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。