原理图编辑器和原理图库编辑器快捷键

以下各节介绍了原理图编辑器和/或原理图符号编辑器专用的快捷键。有关快捷键的一般信息(包括访问与编辑、通用 Altium 环境快捷键以及加速键),请参阅 Altium Designer Shortcut Keys。

查看快捷键列表时,请注意以下事项:

  • 在提到快捷键时,使用加号(+)表示按所示顺序同时按住多个键。例如,Shift+F1 表示按住 Shift 键,然后按下 F1 键。同样,Shift+Ctrl+PgUp 表示按住 Shift 键,同时按住 Ctrl 键,并按下 PgUp 键。
  • 当使用标准鼠标按键时,Click 表示单击鼠标左键一次,Double-Click表示双击鼠标左键,Right-Click表示单击鼠标右键一次。

标准快捷键

以下快捷键为原理图编辑器和/或原理图符号编辑器的标准快捷键。它们在一般情况下均可用,不要求你正在执行交互式操作才能访问。

General Editing

Double-Click 修改当前光标下对象的属性。
Right-Click 打开当前光标下设计空间或对象的上下文菜单。如果当前处于交互式命令中,将退出当前操作。
F2 就地编辑所选文本对象(直接编辑)。
Ctrl+C 复制所选内容
Ctrl+X 剪切所选内容
Ctrl+V 粘贴所选内容
Ctrl+R 复制所选对象并在设计空间中按需反复粘贴(橡皮图章)。
Shift+Ctrl+V 打开 Smart Paste dialog。
Delete 删除所选内容
Ctrl+Z 撤销
Ctrl+Y 重做

Selecting

Shift+F 访问“查找相似对象”功能(单击一个对象作为基准模板)。
Click 选择/取消选择当前光标下的对象。
Shift+Click 在不影响其他对象状态的情况下,更改当前光标下对象的选择状态。
Shift+Ctrl+X 切换交叉选择模式开/关。
Shift+Ctrl+Y 切换交叉选择模式的 Reposition selected component in PCB 选项开/关。
Ctrl+A 选择当前文档上的所有对象。
Alt+Click 在网络对象上:选择该对象,并在活动设计工程的所有图纸中高亮与该网络相关联的所有对象。
Click(远离对象), Hold&Drag (从左到右) 选择完全落在选择区域边界内的所有对象。
Click(远离对象), Hold&Drag (从右到左) 选择完全位于选择区域内或被其边界触及的所有对象。
Ctrl+n(n = 1 到 8) 将当前选择存储到内存位置 n。
Alt+n(n = 1 到 8) 从内存位置 n 召回选择。
Shift+n(n = 1 到 8) 将当前选择添加到已存储在内存位置 n 的选择中。
Alt+Shift+n(n = 1 到 8) 从内存位置 n 召回选择,并将其添加到设计空间中的当前选择。
Shift+Ctrl+n(n = 1 到 8) 基于内存位置 n 中的选择集应用过滤。

Moving

Click(在对象上), Hold&Drag

移动当前光标下的单个对象(如果该对象属于所选对象组,则移动所选对象组)。如果启用了 Always Drag 选项(位于 Schematic - Graphical Editing 对话框的 Preferences 页面),则使用此快捷键移动电气对象时将保持与其他电气对象的连通性。

Ctrl+Click, Hold&Drag 移动当前光标下的单个对象(如果该对象属于所选对象组,则移动所选对象组)。如果禁用了 Always Drag 选项(位于 Schematic - Graphical Editing 对话框的 Preferences 页面),则使用此快捷键移动电气对象时将保持与其他电气对象的连通性。
Left Arrow 在当前文档设计空间中,将光标向左移动一个捕捉栅格单位。
Shift+Left Arrow 在当前文档设计空间中,将光标向左移动 10 个捕捉栅格单位。
Right Arrow 在当前文档设计空间中,将光标向右移动一个捕捉栅格单位。
Shift+Right Arrow 在当前文档设计空间中,将光标向右移动 10 个捕捉栅格单位。
Up Arrow 在当前文档设计空间中,将光标向上移动一个捕捉栅格单位。
Shift+Up Arrow 在当前文档设计空间中,将光标向上移动 10 个捕捉栅格单位。
Down Arrow 在当前文档设计空间中,将光标向下移动一个捕捉栅格单位。
Shift+Down Arrow 在当前文档设计空间中,将光标向下移动 10 个捕捉栅格单位。
Ctrl+Left Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向左移动一个捕捉栅格单位。
Shift+Ctrl+Left Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向左移动 10 个捕捉栅格单位。
Ctrl+Right Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向右移动一个捕捉栅格单位。
Shift+Ctrl+Right Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向右移动 10 个捕捉栅格单位。
Ctrl+Up Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向上移动一个捕捉栅格单位。
Shift+Ctrl+Up Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向上移动 10 个捕捉栅格单位。
Ctrl+Down Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向下移动一个捕捉栅格单位。
Shift+Ctrl+Down Arrow 在当前文档设计空间中,将当前选择(一个或多个已选设计对象)向下移动 10 个捕捉栅格单位。

Aligning

Shift+Ctrl+L 按左边缘对齐所选对象。
Shift+Ctrl+R 按右边缘对齐所选对象。
Shift+Ctrl+H 使所选对象的水平间距相等。
Shift+Ctrl+T 按上边缘对齐所选对象。
Shift+Ctrl+B 按下边缘对齐所选对象。
Shift+Ctrl+V 使所选对象的垂直间距相等。
Shift+Ctrl+D 将所选对象移动到当前捕捉栅格上的最近点。
Spacebar 将所选内容逆时针旋转 90°。
Shift+Spacebar 将所选内容顺时针旋转 90°。

Viewing the Schematic

Ctrl+PgDn 显示当前文档上的所有设计对象。
PgUp 相对于当前光标位置放大。

你也可以使用鼠标通过以下方法之一放大文档的某个区域(在适用情况下,并取决于鼠标按键的分配方式):

  • 按住 Ctrl 键并向上滚动鼠标滚轮。使用 Ctrl 键是默认设置,可在 Preferences 对话框的 System - Mouse Wheel Configuration page 中更改。
  • 同时按住 Ctrl 键和鼠标右键,然后向前移动鼠标。
  • 按住鼠标右键(第一键)和左键(第二键),然后向前移动鼠标。
  • 单击并按住鼠标滚轮,然后向前移动鼠标。
PgDn 相对于当前光标位置缩小。

你可以使用鼠标通过以下方法之一从文档的某个区域缩小(在适用情况下,并取决于鼠标按键的分配方式):

  • 按住 Ctrl 键并向下滚动鼠标滚轮。使用 Ctrl 键是默认设置,可在 Preferences 对话框的 System - Mouse Wheel Configuration page 中更改。
  • 同时按住 Ctrl 键和鼠标右键,然后向后移动鼠标。
  • 按住鼠标右键(第一键)和左键(第二键),然后向后移动鼠标。
  • 单击并按住鼠标滚轮,然后向后移动鼠标。
Mouse Wheel 在设计空间内垂直滚动。这是默认设置,可在 Preferences 对话框的 System - Mouse Wheel Configuration page 中更改。
Shift+Mouse Wheel 在设计空间内水平滚动。这是默认设置,可在 Preferences 对话框的 System - Mouse Wheel Configuration page 中更改。
Shift+Ctrl+Mouse Wheel 在多通道设计中循环切换通道。 当你向上/向下滚动鼠标滚轮时,下一个/上一个已编译通道选项卡(位于主设计窗口底部)将成为活动选项卡。这是默认设置,可在 Preferences 对话框的 System - Mouse Wheel Configuration page 中更改。
Home 重绘主设计窗口中的视图,并将启动命令之前由光标标记的位置置于窗口中心。
End 刷新屏幕,实质上是重绘当前文档,以消除任何不理想的绘图更新效果。
Alt+End 重绘当前文档的当前层,以消除任何不理想的绘图更新效果。
Alt+F5 在最大化与非最大化之间切换当前文档编辑器的显示。
F5 在视觉上切换 Net Color Override 功能开/关。
Shift+C 清除当前应用于活动文档的过滤器。
Right-Click, Hold&Drag 显示滑块(平移)手形光标,然后拖动以移动你对设计空间的视图。

Grids

G 在你预定义的捕捉栅格设置之间向前循环切换。
Shift+G 在你预定义的捕捉栅格设置之间向后循环切换。
Shift+Ctrl+G 在当前文档中打开或关闭可见栅格。
Ctrl+Shift 临时禁用栅格。
Shift+E 打开或关闭光标电气栅格。

Finding Text

Ctrl+F 查找文本。
Ctrl+H 查找并替换文本。
F3 查找下一处匹配的文本。

Quick Panel Access

F11 切换显示 Properties 面板。
F12 相应地切换显示 SCH Filter panel 或 SCHLIB Filter panel。
Shift+F12 相应地切换显示 List panel(SCH List 或 SCHLIB List 面板)。

Commenting

Alt+Ctrl+C 在活动原理图文档上的某个点、对象或区域添加新的评论线程。在开始使用评论功能之前,请确保你已打开(检出)一个 Managed Project,并正在处理其某个源原理图文档。

Miscellaneous

Ctrl+Double-Click
  • 在 Sheet Entry 上,跳转到该条目父级 Sheet Symbol 所引用子页中的对应端口。
  • 在 Port 上,跳转到父级页符号中对应的 Sheet Entry,该页符号引用了端口所在的子页。
  • 在端口上,跳转到所指示目标原理图文档中同名的另一个端口(仅当 Net Identifier Scope(在 Project Options dialog 的 Options tab 上设置)被设为 Flat 或 Global 时可用)。
  • 在页符号上,沿设计层次向下进入并打开该符号引用的子页。
Ctrl+L 通过使用 Board Level Annotate dialog 执行 Board Level Annotation 。
Ctrl+W 进入导线放置模式。
Ctrl+Home 将光标移动到当前文档的绝对原点坐标 (0,0)。
Ctrl+Q
  • 在主设计空间中访问 Selection Memory dialog,你可以在其中控制选择记忆功能的各个方面。
  • 在对话框或面板中切换度量单位(仅在该对话框或面板内),在公制(mm)与英制(mil)之间切换。
Ctrl+M 测量并显示当前文档中任意两点之间的距离。
F9

使用当前通过 Simulation Dashboard 面板定义的分析及相关设置,对活动设计运行仿真。如果这是首次对该设计执行仿真,则将以默认设置运行默认分析——Operating Point、DC Sweep、Transient Analysis 和 AC Analysis。在后一种情况下,强烈建议先通过 Simulation Dashboard 面板完成仿真设置。请注意,与此快捷键关联的 Run Simulation 命令仅在你已安装 Mixed Simulation 系统扩展时才可用。该扩展会将 Simulate menu 添加到原理图编辑器中。更多信息请参见 Extending Your Installation (Altium Designer Develop、Altium Designer Agile、Altium Designer)。

 ,Click 从当前原理图文档中选定对象交叉探测到 PCB 文档中对应对象,并保持源文档为活动文档(Continuous Mode)。
,Ctrl+Click 从当前原理图文档中选定对象交叉探测到 PCB 文档中对应对象,并将目标文档设为活动文档(Jump To Mode)。

交互式快捷键

当启动交互式过程时(例如放置新的设计对象或移动现有对象),以下快捷键将可用。请注意,可用的快捷键取决于交互命令以及该命令所聚焦的具体设计对象。

F1 访问 Graphical Editing Hot key List 对话框,该对话框提供可用(但无法在此处启动的)快捷键列表,并可访问当前正在运行命令的文档。
Shift+F1 访问一个菜单,其中列出当前正在运行的交互命令在现阶段所有有效的快捷键。
Enter 在放置/移动对象时,其作用类似于鼠标的 Click 。
PgUp 放大。
PgDn 缩小。
End 刷新屏幕。
Home 更改显示方式,使光标(以及所附着的正在放置/移动的对象)位于设计窗口中心。
Left Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向左移动,每次移动 1 个捕捉栅格单位。
Shift+Left Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向左移动,每次移动 10 个捕捉栅格单位。
Right Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向右移动,每次移动 1 个捕捉栅格单位。
Shift+Right Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向右移动,每次移动 10 个捕捉栅格单位。
Up Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向上移动,每次移动 1 个捕捉栅格单位。
Shift+Up Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向上移动,每次移动 10 个捕捉栅格单位。
Down Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向下移动,每次移动 1 个捕捉栅格单位。
Shift+Down Arrow 在当前文档工作区中,将光标(以及所附着的正在放置/移动的对象)向下移动,每次移动 10 个捕捉栅格单位。
Tab 暂停交互任务并访问 Properties panel 的相关模式,在该模式下可即时更改正在放置/移动对象的属性。在 Properties 面板(或任何对话框)中继续使用 Tab 将在面板字段之间循环切换。
X 沿 X 轴镜像正在放置/移动的对象。
Y 沿 Y 轴镜像正在放置/移动的对象。
Alt 根据初始移动方向,将移动方向约束为水平或垂直轴。
Shift 在放置/移动对象时进行自动平移时,使用该快捷键以更高速度平移。
Esc
(或 Right-Click)
退出当前过程——可以是当前正在运行的交互命令的某个阶段,或该命令本身。
Spacebar
  • 将正在放置/移动的对象逆时针旋转。旋转步进为 90°。
  • 在 90 Degree 或 45 Degree 放置模式下放置 Wire/Bus/Signal Harness 时,切换起点与终点子模式。
  • 放置 Line 时在放置模式之间循环切换。
Shift+Spacebar
  • 将正在放置/移动的对象顺时针旋转。旋转步进为 90°。
  • 放置 Wire/Bus/Signal Harness 时在放置模式之间循环切换。
Ctrl+Spacebar 拖动电气对象时,更改任何已连接导线、总线或信号线束的布线模式。
Insert
Click&Hold+Insert 在已放置的 Wire、Line、Bus 或 Signal Harness 的选定线段上,或在已放置的 Polygon 的边上,在该点添加一个顶点。
Click&Hold+Delete 在已放置的 Wire、Line、Bus、Signal Harness 或 Polygon 的顶点上,移除该顶点。
Backspace 或 Delete 在放置 Wire、Line、Bus、Signal Harness 或 Polygon 时,移除最后放置的顶点。
+(在数字小键盘上) 增大当前正在放置/移动的 IEEE Symbol 的尺寸。
-(在数字小键盘上) 减小当前正在放置/移动的 IEEE Symbol 的尺寸。
S 将当前正在移动的已选 Sheet Entry(或多个条目)重新定位到父级 Sheet Symbol 的正对侧。
V 在移动两个或更多已选 Sheet Entries 时反转顺序。
T
  • 在移动一个或多个已选 Sheet Entries 时切换 IO 类型。
  • 在以图形方式调整父级 Sheet Symbol 大小时,切换所有 Sheet Entries 的 IO 类型。

弹出菜单快捷键

以下快捷键可在设计空间内直接访问特定命令的弹出菜单。其中一些你可能很熟悉,因为它们是编辑器主菜单中的子菜单。每个主菜单也都定义了一个弹出键,便于在设计空间内快速访问;更多信息请参见 Accelerator Keys。

A 该 Align 子菜单(来自主 Edit 菜单)。
B 该 Toolbars 子菜单(来自主 View 菜单)。
J 该 Jump 子菜单(来自主 Edit 菜单)。
K 该 Panels 子菜单(来自主 View 菜单)。
M 该 Move 子菜单(来自主 Edit 菜单)。
O 一个弹出菜单,提供对选项和首选项的快速访问。
S 该 Select 子菜单(来自主 Edit 菜单)。
X 该 DeSelect 子菜单(来自主 Edit 菜单)。
Y 一个带有过滤命令的弹出菜单。
Z 一个带有缩放命令的弹出菜单。

 

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Content
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Content