Altium Designer Documentation

DocumentPreferences

Modified by Susan Riege on Nov 29, 2018

Parent page: PCB Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: VisibleGridKind=Toggle

Summary

This command is used to toggle the markers used for the fine-level display of the default Global Board Snap Grid between lines and dots.

Access

This command can be accessed from both PCB and PCB Library Editors:

  • PCB Editor - the following methods of access are available:
    • Choose the View » Grids » Toggle Visible Grid Kind command from the main menus.
    • Choose the Toggle Visible Grid Kind entry on the Grids drop-down () of the Utilities toolbar.
    • Use the V keyboard shortcut then choose the Grids » Toggle Visible Grid Kind entry on the subsequent pop-up menu.
  • PCB Library Editor - the following method of access is available:
    • Choose the View » Grids » Toggle Visible Grid Kind command from the main menus.
    • Choose the Toggle Visible Grid Kind entry on the Grids drop-down () of the PCB Lib Standard toolbar.
    • Use the V keyboard shortcut then choose the Grids » Toggle Visible Grid Kind entry on the subsequent pop-up menu.

Use

After launching the command, the marker type used for the Global Board Snap Grid's fine-level grid display will change to either dots or lines depending on the type that was previously in use.

Tips

  1. This command only toggles the marker type used for the fine-level display and not the coarse-level display.
  2. The marker type can also be changed through the Cartesian Grid Editor dialog when editing the default Global Board Snap Grid. Grid management is performed through the Grid Manager section of the Properties panel when no objects are currently selected in the design workspace.


Applied Parameters: ElectricalGridEnabled = Toggle

Summary

This command is used to cycle to the next mode of object Hotspot Snapping. Often referred to as an Electrical Grid, object hotspot snapping provides an aid to routing electrical objects, especially those that may not fall on the default Global Board Snap Grid or a defined custom grid. It gives you a distance, or tolerance, in which the cursor can be away from an object but still snap to the object's hot-spot (e.g., the center of a pad). Object hotspot snapping overrides a snap grid allowing you to easily connect to an off-grid object.

Access

This command can be accessed from both PCB and PCB Library Editors by:

  • Choosing the View » Grids » Toggle Object Hotspot Snapping command from the main menus.
  • Using the Shift+E keyboard shortcut.
  • Using the V keyboard shortcut then choose the Grids » Toggle Object Hotspot Snapping entry on the subsequent pop-up menu.
In addition, from the PCB Editor, you can choose the Toggle Object Hotspot Snapping entry on the Grids drop-down () of the Utilities toolbar.

Use

After launching the command, object hotspot snapping will cycle to the next mode within the following modes depending on its previous state:

  • ON (Current Layer) - hotspot snap is enabled for the current layer. That is, the cursor will snap to object hotspots on the current layer only.
  • ON (All Layers) - hotspot snap is enabled for all visible layers. That is, the cursor will snap to object hotspots on any layer, not just the current layer.
  • OFF - hotspot snap is disabled.
The current mode is reflected on the Status Bar - (Hotspot Snap) ----> (Hotspot Snap (All Layers)) ----> no display.

Tips

  1. Hotspot snapping can also be enabled/disabled and its range (Snap Distance) defined in the Snap Options section of the Properties panel (when no objects are currently selected in the design workspace).
  2. Hold the Ctrl shortcut key to temporarily disable object hotspot snapping during interactive routing.


Applied Parameters: MeasurementUnit=Toggle

Summary

This command is used to toggle the measurement units for the current document, between metric (mm) and imperial (mil).

Access

This command can be accessed from the PCB Editor, and PCB Library Editor, by:

  • Choosing the View » Toggle Units command from the main menus.
  • Using the Q keyboard shortcut.
  • Using the V keyboard shortcut then choosing the Toggle Units entry on the subsequent pop-up menu.

Use

After launching the command, the measurement units for the current document will become either metric or imperial depending on the measurement units previously in force.

Tips

  1. The current measurement units for the document can be checked/changed in the Other section of the Properties panel (when no objects are currently selected in the design workspace).


Applied Parameters: MaskLevel=Increase

Summary

This command is used to increase the masking level, and therefore, decrease the extent of dimming in the workspace for all objects not falling under the scope of a currently applied filter.

This command is only effective when the highlighting method for objects not passing the applied filter is set to Dim. Unlike the Mask highlighting method, such objects can still be selected and edited.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the View » Increase Mask Level command from the main menus.
  • Using the ] keyboard shortcut.

Use

After launching the command, the level or intensity of masking applied in the workspace will be decreased. Design objects that do not fall under the scope of the currently applied filter will become less faded. Continue using this command to further increase the display intensity of objects not belonging to the filtered set.

Tips

  1. Use of this command corresponds to sliding the Dimmed Objects slider to the right (increasing its value). This slider can be found in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.


Applied Parameters: MaskLevel=Decrease

Summary

This command is used to decrease the masking level, and therefore, increase the extent of dimming in the workspace for all objects not falling under the scope of a currently applied filter.

This command is only effective when the highlighting method for objects not passing the applied filter is set to Dim. Unlike the Mask highlighting method, such objects can still be selected and edited.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the View » Decrease Mask Level command from the main menus.
  • Using the [ keyboard shortcut.

Use

After launching the command, the level or intensity of masking applied in the workspace will be increased. Design objects that do not fall under the scope of the currently applied filter will become more faded. Continue using this command to further decrease the display intensity of objects not belonging to the filtered set.

Tips

  1. Use of this command corresponds to sliding the Dimmed Objects slider to the left (decreasing its value). This slider can be found in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。