了解 PCB 上的连接性
概览
- 您将了解什么是飞线、连接线如何表示网络连接关系,以及网络拓扑如何影响这些连接线的排列方式。
- 您将了解如何在复杂的 PCB 布局中快速定位、高亮显示、过滤和检查单个网络或一组网络。
- 您将了解如何在 PCB 面板中浏览网络和网络类,以及其中提供的各类连接关系和长度信息。
在 PCB 编辑器中,网络中各节点之间的连接关系通过一系列点对点连接线表示,这些连接线统称为飞线。 当设计从原理图传输过来时(Design » Update PCB),元件会放置在 PCB 设计空间中,并显示连接线(以细实线表示)。
在单个网络中,连接线将该网络的所有节点连接起来。它们的连接模式或顺序称为 Net Topology,下文将对此进行讨论。

网络中的节点按照适用的布线拓扑规则通过连接线相连(默认为最短拓扑)。

在此设计中,GND 和 5V 网络的连接线使用了不同的颜色。
连接线不仅有助于指导元件布局,还能为交互式布线和自动布线提供重要参考。
PCB 编辑器内置网络分析器,可持续监控设计空间中所有对象的位置 ,并在任何网络对象被编辑(包括移动)时更新连接线。例如,移动元件时,从该元件引出的每条连接线的远端都可能从一个目标焊盘跳转到另一个目标焊盘,以便在更新后保持适用设计规则所定义的拓扑。下方视频中的 GND 网络展示了这一过程; 该网络采用最短拓扑。

请注意,随着电阻移动,GND 连接线会不断跳转并自动重新排列,以保持最短的总连接长度。
在电路板上查找网络
尚未布线的电路板可能令人望而生畏——大量连接线在整块电路板上纵横交错。一种有效的布线方法是从原理图入手,因为在原理图中可以轻松找到重要元件和关键网络。您可以直接对原理图中的元件和网络进行交叉选择和交叉探查,从而高亮显示 PCB 上的对应对象。有关详细信息,请参阅在原理图与电路板之间协同工作。
PCB 编辑器的一项实用功能是能够遮蔽或调暗设计空间中的对象。此过滤功能会淡化显示除通过过滤条件的对象之外的所有内容。下图显示了选中单个网络的情形,其中过滤系统设置为对所有未通过过滤条件的对象执行 Dim。
要尝试此功能,请将 PCB 面板设置为 Nets 模式,面板中将显示电路板上的网络列表。使用下拉菜单将过滤模式设置为 Dim 或 Mask,然后启用 Select 和 Zoom 选项,如下图所示。
当您在面板中单击某个网络名称时,设计空间的显示会随之变化:视图缩放至显示该网络中的节点,并淡化显示该网络的焊盘和连接线之外的所有内容,相当于将该网络从电路板的其余部分中单独提取出来。请注意,即使在工作区中单击,过滤效果仍会保留,所选网络依然清晰可见,便于检查或布线。

使用过滤功能可以更轻松地查找网络或网络类。
单击 PCB 面板顶部的 Clear 按钮可清除过滤器,并将整个设计空间恢复为正常亮度(或按 Shift+C 快捷键)。
请注意,除了单个网络,您还可以在面板的 Net Classes 区域中过滤显示某个网络类(如果已定义网络类),也可以交互式选择多个网络(在 PCB 面板中单击选择网络名称时,按住 Ctrl )。
浏览网络
在 PCB 面板的 Nets 模式下,其三个主要区域会随当前 PCB 设计的网络层次结构而变化(从上到下依次为):
- Net Classes,由电路板定义。
- 类中的各个成员 Nets 。
- 网络中的各个 Primitives (焊盘、过孔、走线和填充)。
网络类
在面板顶部区域 (Net Classes)中,右键单击网络或网络条目,然后从弹出的菜单中选择 Properties (或直接双击该条目),即可打开 编辑网络类对话框 。在此对话框中,您可以查看或编辑该类的网络成员、重命名该类,或添加其他类。
您还可以使用主菜单中 Design » Netlist 子菜单下的以下命令,或使用所选网络对象右键菜单中 Net Actions 子菜单下的以下命令来管理网络类:
- Create NetClass from Selected Nets — 此命令用于根据设计空间中选中的两个或更多网络创建新的网络类。 执行该命令后,将打开 Object Class Name 对话框。使用此对话框为新网络类指定所需的名称。单击 OK 后,将创建该网络类 ,并将所选网络添加为其成员。
- Add Selected Net(s) to NetClass — 此命令用于将一个或多个选定网络添加到现有网络类中。 执行该命令后,将打开 Choose Net Class 对话框。此对话框列出了所有现有网络类。选择目标类,然后单击 OK。所选网络将添加为该类的成员。
- Remove Selected Net(s) From NetClass — 此命令用于从现有网络类中移除一个或多个选定网络。 执行该命令后,将打开 Choose Net Class 对话框。此对话框列出了所有现有网络类。选择目标类,然后单击 OK。所选网络将从该类的成员中移除。

Choose Net Class 对话框
网络
面板中间区域显示上方区域所选网络类中的网络。
默认情况下,每个网络会列出以下信息:
-
- 此功能有两个作用:
- Color background - 分配给网络的颜色。此颜色始终应用于网络的连接线。也可以使用网络颜色显示覆盖功能,将此颜色应用于该网络的布线。双击可编辑此网络的颜色,右键单击可编辑当前所有选中网络的颜色。
-
checkbox - 勾选此项可将该颜色应用于此网络的布线(启用网络颜色显示覆盖功能)。右键单击可为当前所有选中的网络启用(或禁用)显示覆盖功能。按 F5 可在设计空间中启用/禁用网络颜色显示覆盖。
► 请参阅网络颜色覆盖 - 在已布线网络上显示网络颜色以了解更多信息。
-
Name - 网络的名称。
-
Node Count - 此网络中的焊盘总数。
-
Routed Length - 构成布线的已放置走线段和圆弧段的长度总和,加上穿过过孔的垂直距离(请参阅下方注释)。布线长度计算器不会尝试处理重叠的走线段或焊盘内部的曲折布线。
-
Signal Length - 精确计算节点到节点的总距离。通过分析已放置的对象,处理堆叠或重叠的对象以及焊盘内部的曲折路径,并计入过孔长度。如果网络尚未完成布线,还会计入连接线的曼哈顿(X + Y)长度。
以下说明适用于信号长度计算:
-
处理焊盘内部的重叠和曲折路径。
-
支持使用走线和圆弧以外的对象(例如区域或填充)创建的布线路径。
-
计入穿过过孔的垂直距离(请参阅下方注释)。
-
计入此网络的 Total Pin/Package Length。
-
计入此网络的 Unrouted (Manhattan) 长度。
-
如果不符合适用的长度/匹配长度设计规则,信号长度将以彩色背景显示来标示:信号长度过短时背景为黄色,过长时为红色。
► 请参阅长度调谐,了解有关长度和匹配长度设计规则应用方式的更多信息。
-
信号是点到点的实体,因此,在面板的 Nets 模式下,只有具有两个节点的网络才会显示信号长度(其他节点数量的网络将显示
0)。对于具有两个以上节点的网络,请定义 xSignals 来计算其信号长度。► 请参阅 PCB - xSignals。
► 请参阅使用 xSignals 定义高速信号路径,了解有关 xSignals 的更多信息。
-
-
Total Pin/Package Length - 此网络中所有焊盘的引脚封装长度值的总和。该值定义为 PCB 焊盘的属性,也可以在原理图引脚中指定。
-
Unrouted (Manhattan) - 所有未布线部分的垂直距离与水平距离(X+Y)之和。
在此区域中右键单击,然后使用 Columns 子菜单添加以下列:
-
Min/Max - 来自适用的长度和匹配长度设计规则的设置。如果未定义适用的规则,则使用内部默认值
Min=0mil和Max=99999mil。► 请参阅长度调谐,了解有关如何根据长度和匹配长度设计规则确定最小值和最大值设置的更多信息。
- Estimated Length - 此值为 Routed Length 加上所有尚未布线部分的连接线长度。对于未布线部分,它不使用 Manhattan 长度,而是使用点到点的直线距离。
- Delay - 信号沿该布线路径传播所需的时间。
双击 Nets 区域中某个网络的条目(或右键单击该网络条目,然后从上下文菜单中选择 Properties 命令),即可打开 Edit Net 对话框,在其中修改网络的属性。
编辑网络对话框的选项和控件
属性
- Net Name - 根据需要重命名网络。
- Connection Color - 单击以打开 Choose Color 对话框,为指定网络选择连接线颜色。启用网络颜色覆盖功能(按 F5)后,此网络颜色也可应用于已布线的网络。
- Hide Connections - 启用以隐藏连接线。
- Hide Jumpers - 启用以隐藏跳线或已布线段之间的短连接。
- Remove Loops - 启用以自动移除此网络中的所有冗余回路。
其他网络中的引脚
此处列出 PCB 上的所有引脚。对于当前已分配给网络的引脚,其网络名称会显示在括号中。选择要添加到正在编辑的网络中的引脚。使用 Shift 和 Ctrl 键可选择多个引脚。使用控制按钮将选定的引脚移入当前网络列表,或右键单击并通过上下文菜单从列表中移除选定的引脚。
按钮
-
- 用于将所有 Pins in Other Nets 添加到 Pins in This Net。
-
- 用于将选定的 Pins in Other Nets 添加到 Pins in This Net。 使用 Shift 和 Ctrl 键可选择多个引脚。
-
- 用于将所有 Pins in This Net 移至 Pins in Other Nets。
-
- 用于将选定的 Pins in This Net 移至 Pins in Other Nets。 使用 Shift 和 Ctrl 键可选择多个引脚。
将引脚从 Pins in Other Nets 列表移至 Pins in This Net 列表后,可以右键单击已移动的引脚,然后选择 Remove One 命令,将其移回 Pins in Other Nets 列表。
此网络中的引脚
列出此网络中的所有引脚。选择要从此网络中移除的引脚。使用 Shift 和 Ctrl 键可选择多个引脚。使用控制按钮将选定的引脚移出当前网络列表,或右键单击并通过上下文菜单移除选定的引脚。
当前交互式布线设置
表格
表格区域 列出当前的交互式布线设置。
- Track Width - 列出当前交互式布线设置的走线宽度字段,该字段可编辑,可根据个人偏好和/或设计要求进行更改。
- Name - 列出 Current Routing、Layer Stack Reference 和 Absolute Layer。
- Index - 列出索引编号。
示意图
- Via Hole Size - 表示存储在网络中的当前过孔孔径的用户自选值。此对话框可用于修改当前交互式布线设置的当前值。如果这些值为零,则用户自选值不从此对话框获取,而是使用此电路板上次使用的值。
- Via Diameter - 表示存储在此网络中的当前过孔尺寸的用户自选值。此对话框可用于修改当前交互式布线设置的当前值。如果这些值为零,则用户自选值不从此对话框获取,而是使用此电路板上次使用的值。
- All Widths - 这些是当前布线及其层参考值,表示存储在网络中的当前用户自选值。可在此修改当前交互式布线设置的当前值。如果这些值为零,则用户自选值不从此对话框获取,而是使用此电路板上次使用的值。
- Layers in Layer-Stack only - 启用后,仅将过孔参数应用于层堆栈中的层。
图元
面板底部 Primitives 区域中各类网络项的显示/包含情况,取决于是否在右键菜单中启用了对应选项。该菜单可从 Nets 或 Primitives 区域访问。

右键单击网络或网络项条目,以选择要包含的项目。
请注意,Primitives 列表的右键上下文菜单还提供了在两个选定项目之间创建 xSignal 的选项。有关更多信息,请参阅 PCB - xSignals。
管理连接线的显示
Related page: PCB 视图
连接线有助于放置元件和调整元件方向,并在布线过程中提供指引。不过,它们也可能使视图显得十分杂乱。为此,PCB 编辑器提供了下述功能,帮助设计人员管理连接线的显示。
更改连接线颜色
将设计从原理图传输到 PCB 工作区时,会应用默认的层和颜色设置。在此过程中,所有连接线都会被指定为默认的 Connection Lines 颜色,该颜色在 视图配置 面板(快捷键为 L)的 Layers & Colors 选项卡的 System Colors 部分中定义。视图配置可用于 2D 和 3D 工作区,并且可以保存和重新应用(位于 View Configuration 面板的 View Options 选项卡)。
在布线过程中,让重要网络突出显示的一种简单方法是更改其连接线颜色。为此,在 PCB 面板中双击网络名称,打开 Edit Net 对话框,即可编辑连接线颜色(需将面板设置为 Nets 模式)。
或者,要更改一个 or 多个网络的颜色,请先在 PCB 面板中选择所需的网络,然后右键单击选定的网络并选择 Change Net Color 命令。

在 PCB 面板中,右键单击选定的网络可更改其连接线颜色。
使用层颜色显示连接线
除了为各个网络指定连接线颜色外, 还可以使用连接线跨越的起始层和终止层的颜色来显示连接线。如果连接线从某一层上的对象连接到另一层上的对象,则连接线的起始部分采用第一个对象所在层的颜色,随后在接近另一层上的对象时,逐渐变为终止层的颜色(如下图所示)。
此功能在多层板布线时非常有用,因为它能指示当前所布连接必须到达的目标层。请注意,颜色渐变仅应用于跨层连接;如果连接线的起点和终点位于同一层,则保留为该网络指定的颜色。
要使用层颜色功能,请在 View Configurations 面板的 View Options 选项卡中启用 Use Layer Colors for Connection Drawing 选项,如下所示。

连接线可以使用其起始层和终止层的颜色显示。右图中移除了多个网络的部分布线段,以展示连接线的显示效果。
在单层模式下显示连接线
多层板在视觉上信息密集,因此很难看清其中的情况。为此,您可以按 Shift+S 快捷键,轻松地将层显示从已启用的层切换到单层模式。
通常,切换后,起点和终点均不在当前层上的所有连接线也会隐藏,因为系统认为这些连接线与当前操作无关。若要始终显示连接线,请在 View Configurations 面板的 View Options 选项卡中启用 All Connections in Single Layer Mode 选项,如下所示。

控制单层模式下连接线的显示。
隐藏/显示连接线
除了通过 PCB 面板筛选网络,您还可以完全隐藏一条、多条或全部连接线。View » Connections 子菜单中提供了多个用于控制连接线显示的命令。您也可以在工作时按 N 快捷键访问这些命令。 使用这些命令可以:
网络拓扑
网络中各节点相互连接的模式或顺序称为网络拓扑。网络拓扑由适用的 布线拓扑设计规则控制,默认采用最短拓扑。最短拓扑是指网络中的节点按照使该网络总连接长度最短的模式相互连接。移动元件时,系统会监测这一总长度,并动态改变连接线的模式,以保持最短的总长度。在上方动画中可以看到这一点:移动元件时,从元件底部向下连接的线会发生跳变——每当某个已连接焊盘移动到更靠近其网络中的另一个焊盘的位置时,就会发生这种情况。
使用布线拓扑设计规则应用预定义拓扑
可以创建其他布线拓扑设计规则,将某个网络(或网络类)配置为使用不同的拓扑。以下图示对此进行了演示:左图显示了默认拓扑规则,右图显示了同一网络应用新的星形布线拓扑后的情况。在星形拓扑中,连接线从 Electrical Type 为 Source 的焊盘向外辐射(所有焊盘的默认类型均为负载)。

在默认拓扑中,连接线的分布使总连接长度最短。在星形拓扑中,所有连接线均从源焊盘向外辐射。
应用自定义拓扑
在单个网络中,两个节点之间的连接称为 From-To。要在单独的引脚到引脚层面控制连接线的路径,可以在网络中手动定义 From-To,从而创建自定义网络拓扑。
要定义 From-To,需将 PCB 面板 设置为 From-To Editor 模式。定义 From-To 的过程是:在面板中选择两个 Nodes on Net,然后单击 Add From To 按钮。为便于在设计空间中清晰识别 From-To,它们以虚线而非实线显示。

两个焊盘之间已定义一个 From-To,请注意 From-To 线以虚线而非实线显示。
PCB 面板的 From-To Editor 模式分为三个区域:
- Nets
- Nodes所选网络的
- From-Tos on Net
单击某个网络条目时,该网络上的所有节点都会加载到面板的中间区域。 双击某个网络条目将打开 编辑网络对话框,您可以在其中编辑网络的属性,包括节点归属。
添加 From-To
要在所选网络的两个节点之间添加用户定义的 From-To,请在面板的 Nodes on Net 区域中选择这两个节点,然后单击 Add From To 按钮。
新添加的 From-To 将列在面板的 From-To on Net 区域中,并在设计空间中显示为两个节点之间的虚线。

已在该网络上创建一个新的 From-To。

设计空间中用户定义的 From-To。
要移除 From-To,请在面板的 From-To on Net 区域中选择相应条目,然后点击 Remove 按钮。
选择预定义拓扑
网络拓扑是指引脚间连接的排列方式或模式。默认情况下,每个网络的引脚间连接均按总连接长度最短的方式排列。
为网络应用拓扑的原因有很多:对于必须尽量减少信号反射的高速设计,可将网络排列为菊花链拓扑;对于接地网络,则可应用星形拓扑,以确保所有走线都汇聚到同一个公共点。您既可以为网络中的节点对创建专用的 From-To,也可以选择根据可用的预定义布线拓扑之一为网络生成 From-To。
点击面板 From-To on Net 区域中的 Generate 按钮,即可访问以下拓扑:
- Shortest - 此拓扑连接网络中的所有节点,使总连接长度最短。
-
Daisy Simple - 此拓扑将所有节点依次串联。串联顺序经过计算,以使总长度最短。如果指定了源焊盘和终端焊盘,则所有其他焊盘都会串联在它们之间,以实现尽可能短的长度。如果指定了多个源焊盘(或终端焊盘),则它们会分别在两端串联在一起。
-
Daisy Balanced - 此拓扑将所有负载均分到各条链中,链的总数等于终端的数量。这些链随后以星形方式连接到源节点。多个源节点会串联在一起。
-
Daisy Mid-Driven - 此拓扑将源节点置于菊花链的中心,将负载均分后,分别从源节点的两侧串联出去。此拓扑需要两个终端,两端各一个。多个源节点会在中心串联在一起。如果终端数量不是恰好两个,则使用 Daisy-Simple 拓扑。
- Starburst - 此拓扑将每个节点直接连接到源节点。如果存在终端,则将其连接在每个负载节点之后。与平衡菊花链拓扑一样,多个源节点会串联在一起。
在 Properties 面板的 Pad 模式中,相应地更改 Electrical Type 字段的条目,即可将焊盘定义为源、终端或负载。在 Nodes on Net 区域中双击焊盘条目,即可访问 Properties 面板的 Pad 模式。

在 Properties 面板的 Pad 模式中,将焊盘的 Electrical Type 设置为源。
将焊盘的电气类型更改为源或终端后,设计空间中会显示“[S]”或“[T]”,以便区分。
注意事项
-
系统生成的连接线不会作为独立实体出现在设计空间中。仅显示与该 From-To 关联的引脚间连接线,用于引导交互式布线/自动布线。
-
用户定义的 From-To 在设计空间中显示为虚线,它与添加 From-To 时同时显示的引脚间连接线相互独立,且有明显区别。用户定义的 From-To 线控制关联的引脚间连接线的起点和终点。通过示例可以最清楚地说明这一点。假设在两个元件之间具有逻辑连接的引脚间添加一个用户定义的 From-To。此时也会添加并显示一条连接线(PCB 面板配置为 Nets 模式):
-
用于布线的引脚间连接线遮住了与其完全独立的用户定义 From-To 线。但是,当您开始为该连接布线时,就可以看到这两条线彼此独立:
-
如果此时暂停布线,网络分析器会添加一条连接线,以保持所需的拓扑。该连接线显示为虚线(称为断网标记),表示应在这两点之间布线,以保持用户通过添加自定义 From-To 所确定的拓扑:
-
如果仅为网络的一部分指定用户定义的 From-To,PCB 编辑器会将其余引脚间连接(系统生成的 From-To)设置为最短拓扑。
-
From-To 的类型决定了连接性分析器如何处理设计空间中的连接线,例如在移动网络对象或对网络的一部分进行手动布线时:
- 系统生成的 From-To - 在网络分析器重新优化的过程中,可以根据需要移动连接线,以保持网络的默认拓扑(即最短拓扑)。
- 用户定义的 From-To - 如果 From-To 不是通过选择预定义拓扑生成的,则网络分析器在重新优化过程中不会考虑该连接线。如果 From-To 属于预定义网络拓扑(最短拓扑除外)的一部分,则只要保持所选拓扑不变,网络分析器就可以将其纳入重新优化过程。
-
对应用于相应网络的布线拓扑设计规则执行批量设计规则检查 (DRC)时,可以检查使用 From-To 定义的自定义拓扑的实现情况。如果 From-To 的焊盘之间存在电气连接,且最短路径中包含该网络的至少一个其他焊盘,则会检测到违规。
在三个焊盘之间创建两个 From-To:从焊盘 1 到焊盘 2,以及从焊盘 2 到焊盘 3
按照 From-To 配置进行布线:焊盘 1 与焊盘 2 之间以及焊盘 2 与焊盘 3 之间均有走线。未检测到布线拓扑规则违规。
以 T 形分支方式布线。根据 From-To 配置,各路径中均无额外焊盘,因此未检测到布线拓扑规则违规。
在焊盘 1 与焊盘 3 之间以及焊盘 2 与焊盘 3 之间布线。这种布线与 From-To 配置不符,因为焊盘 1 与焊盘 2 之间的路径中多了焊盘 3,因此会检测到焊盘 1 与焊盘 2 之间的 From-To 违反了布线拓扑规则。
网络表管理器
通过主菜单中的 Design » Netlist » Edit Nets 命令打开的 Netlist Manager 对话框提供了有效管理电路板网络表的控件。您可以根据需要添加、编辑或删除网络,也可以编辑这些网络中元器件引脚(或焊盘)的属性。此对话框还提供了其他网络表管理工具,包括根据 PCB 上相连的铜箔创建网络表,以及从 PCB 导出网络表。
Netlist Manager 对话框
网络表管理器对话框的选项和控件
-
Nets In Board - 此区域按名称列出电路板中定义的所有网络。使用列表上方的掩码字段可快速筛选内容。
- Edit - 单击可打开编辑网络对话框,在其中查看和修改当前所选网络的属性(如果列表中选中了多个网络,则为焦点网络。焦点网络以虚线边框标示)。
- Add - 单击可为电路板添加新网络。随后会打开 Edit Net 对话框,您可以在其中定义网络的属性。新网络的初始默认名称为 NewNet;可根据需要更改。
-
Delete - 单击可从电路板中删除当前所选的网络。随后会出现确认对话框;单击 Yes 可继续删除。
-
Pins In Focused Net - 此区域显示与当前所选网络或焦点网络关联或属于该网络的所有引脚(元器件焊盘)。列表中每个条目的引脚标识符均以 <ComponentDesignator>-<PinDesignator> 格式显示。使用列表上方的掩码字段可快速筛选内容。
- Edit - 单击可打开焊盘对话框,在其中查看和修改当前所选引脚(焊盘)的属性。
-
Menu - 单击可打开包含以下命令的菜单:
- Add Net - 用于为电路板添加新网络。随后会打开 Edit Net 对话框,您可以在其中定义网络的属性
- Delete Net - 用于从电路板中删除当前所选的网络。随后会出现确认对话框;单击 Yes 可继续删除。
-
Update Free Primitives From Component Pads - 用于将布线图元的网络名称重新同步为其所连接焊盘的网络名称。启动此命令后,会出现确认对话框,询问是否使用元器件焊盘的网络来更新自由图元的网络。单击 Yes 后,将从每个焊盘开始选择与其相连的铜箔,并将每个图元的网络名称设置为与该焊盘一致。
- Clear All Nets - 用于清除当前设计文档中的所有网络,即清空 PCB 内部网络表。如果您已更改源原理图文档中的网络信息,并希望将 PCB 与源原理图的网络表信息完全重新同步,则可以使用此命令。启动此命令后,会出现确认对话框,提示此操作将清除 PCB 中的所有网络信息。单击 Yes 后,所有网络信息都将被移除。已布线的走线将保留,但其网络分配将变为 No Net。所有未布线的逻辑连接都将被移除。
- Export Netlist From PCB - 用于将当前文档的 PCB 内部网络表导出到文件。启动此命令后,会出现确认对话框,询问是否要从 PCB 导出网络表。单击 Yes 后,将在 PCB 设计文档所在文件夹中创建一个网络表(Exported <PCBDocumentName>.Net)。
-
Create Netlist From Connected Copper - 用于根据当前设计中布线形成的连接关系创建网络表文件。启动此命令后,会出现确认对话框,询问是否要根据 PCB 上的铜箔生成网络表。单击 Yes 后,将在 PCB 设计文档所在文件夹中创建一个网络表(Generated <PCBDocumentName>.Net),该网络表会自动在主设计窗口中作为活动文档打开。
焊盘对话框的选项和控件
焊盘模板
- Template - 从下拉列表中选择一个焊盘模板。
- Library - 显示焊盘模板所链接的库,并提供取消模板与该库链接的选项。
位置
- X - 焊盘中心相对于当前原点的当前 X 坐标。编辑此值可更改焊盘相对于原点的位置。
- Y - 焊盘中心相对于当前原点的当前 Y 坐标。编辑此值可更改焊盘相对于原点的位置。
- Rotation - 当前焊盘的旋转角度,以度为单位。编辑此值可更改焊盘的旋转角度。最小角度分辨率为 0.001°。
孔信息
- Hole Size - 焊盘当前的孔径。此值指定制造过程中在焊盘上钻孔的直径(以 mil 或 mm 为单位)。对于单层焊盘(例如 SMD 焊盘或板边连接器焊盘),此值会自动设为零。孔径可设置为 0 至 1000mil ,也可设置为大于焊盘区域,以定义无铜机械孔。编辑此字段中的值可更改焊盘孔径。输入值可使用 mm 或 mil 单位。
- Tolerance - 设置孔公差属性有助于确定电路板的配合与极限尺寸。指定设计的最小(-)和最大(+)孔公差。
选择以下选项之一以指定孔的形状:
- Round - 指定焊盘孔为圆孔(默认)。
- Square - 指定焊盘孔为方孔(冲孔)。
- Slot - 指定焊盘孔为圆端槽孔。
- Plated - 此选项决定焊盘孔是否为金属化孔。如果设计中同时存在金属化和非金属化焊盘孔,则在 NC 钻孔文件中,非金属化孔将使用与金属化孔不同的刀具。
属性
- Designator - 当前焊盘的标识。如果焊盘属于某个元件,其标识通常设置为对应的元件引脚编号。标识最长可包含 20 个字符,且不能包含空格。自由焊盘可以具有标识 ,也可以将此字段留空。如果标识以数字开头或结尾,则在连续放置一系列焊盘时,该数字会自动递增。编辑此字段中的值可更改焊盘标识。请注意,如有需要,同一元件封装内的多个焊盘可以共用同一标识。
-
Layer - 焊盘当前所属的层。焊盘可分配到任何可用层。将 Layer 设置为
Multi-Layer,可在所有信号层上定义焊盘形状。 - Net - 焊盘当前所属的网络。单击此字段并从下拉列表中选择网络,即可更改网络分配。选择 No Net 可指定焊盘不连接到任何网络。设计规则检查器使用 Net 属性来确定 PCB 对象的放置是否符合规则。
- Electrical Type - 此字段显示焊盘当前的电气类型。此类型仅与元件焊盘相关,用于设置这些焊盘的传输线特性。焊盘可指定为负载、源或终端。当网络需要采用某种菊花链布线拓扑时,会用到源和终端设置。单击此字段,可从下拉列表中更改电气类型。
- Pin/Pkg Length - 引脚封装长度会自动计入 PCB 面板中显示的 Signal Length 计算结果。将 PCB 面板设置为 Nets 模式,可查看(或编辑)所选网络中引脚的 Pin/Pkg Length 值。
- Jumper ID - 将此项设置为非零值(范围为 1–1000),以表明该焊盘属于跳线元件封装。当使用导线跨接焊盘而非通过走线建立连接时,可在单面 PCB 上使用跳线元件。跳线 ID 值用于告知软件应将哪些焊盘视为“已连接”。跳线连接只能在同一元件封装内的焊盘之间创建;这些焊盘必须具有相同的 Jumper ID 值 ,并且必须分配到同一网络。该元件的 Type 还必须设置为跳线。满足这些条件后,PCB 编辑器中将以弧形连接线显示跳线连接。
- Locked - 启用此选项可防止以图形方式编辑焊盘。对于位置或尺寸至关重要的焊盘,应将其锁定。如果尝试编辑已锁定的图元,系统会提示该图元已锁定,并询问您是否继续操作。如果未勾选此选项,则可自由编辑图元,无需确认。请注意,Locked 复选框对属于元件的焊盘不起作用。如果元件未锁定,移动元件时焊盘也会随之移动。在这种情况下,应锁定元件以防止意外移动。
测试点设置
使用此区域可将此焊盘定义为测试点,以用于生成 Fabrication 和/或 Assembly 测试点文件。测试点是测试探针可以接触 PCB 的位置,用于检查电路板是否正常工作。勾选所需的测试点类型和层复选框,即可将任何焊盘或过孔指定为测试点。完成此操作后,焊盘或过孔会自动锁定;如果焊盘属于某个元件,该元件也会被锁定。如果需要移动焊盘、过孔或元件,可暂时将其解锁。请注意,禁用测试点设置不会自动解锁焊盘、过孔或元件,必须手动解锁。
- Top - 启用此选项可将此焊盘定义为顶层测试点。
- Bottom - 启用此选项可将此焊盘定义为底层测试点。
尺寸和形状
焊盘的铜区域由 X 和 Y 尺寸 以及形状设置定义。
- Simple - 简单焊盘是指在所有层上具有相同尺寸和形状的焊盘。
-
Top-Middle-Bottom - 顶层-中间层-底层分层焊盘支持分别为顶层、所有中间信号层和底层定义不同的 X、Y 尺寸及形状。
- X-Size - 焊盘当前的 X(水平)尺寸。输入范围为 1 至 10000mil 的值。X 和 Y 尺寸可独立设置,以定义非对称焊盘形状。
- Y-Size - 焊盘当前的 Y(垂直)尺寸。输入 1 至 10000mil 之间的值。X 和 Y 尺寸可以独立设置,以定义非对称焊盘形状。
-
Shape - 焊盘的基本形状。基本焊盘形状包括
Round、Rectangular、Octagonal或Rounded Rectangle。可以通过更改 X 和 Y 尺寸设置来调整基本形状,从而生成非对称焊盘形状。 -
Corner Radius - 当 Shape 设置为
Rounded Rectangle时,此选项可用。该值是焊盘最短边长度一半的百分比,因此, 0% 对应矩形焊盘, 100% 对应圆形焊盘。 - Offset From Hole Center (X/Y) - 输入一个值,使焊盘的焊接区域相对于焊盘孔中心 偏移该距离。
-
Full Stack - 可以在各层(包括所有信号层和电源平面层)上编辑不同的孔尺寸和直径。
-
Edit Full Pad Layer Definitions - 单击以打开 Pad Layer Editor 对话框,其中提供了各层焊盘/过孔设置的相关控件,包括焊盘形状、尺寸以及 X/Y 位置。必须选中 Full Stack 才能使用此按钮。
Options and Controls of the Pad Layer Editor Dialog
- Main Grid - 焊盘堆栈是与堆栈中各层对应的焊盘形状和尺寸信息的集合。单击此表格中的某个属性,即可编辑堆栈当前层的值。焊盘堆栈的层源自 层叠管理器(Design » Layer Stack Manager)。
-
Attributes on Layer
- Shape - 从下拉列表中选择焊盘形状:Round、Rectangular、Octagonal 或 Rounded Rectangle。
- X Size - 单击以指定焊盘的 X 尺寸。
- Y Size - 单击以指定焊盘的 Y 尺寸。
- Corner Radius (%) - 单击以指定焊盘的圆角半径;此字段仅对 Rounded Rectangle 可编辑。
-
Layer Stack Reference
- Name - 焊盘层所引用的层。
- Index - 层的相对索引。
-
Absolute Layer
- Name - 层的名称,默认已定义。
- Index - 焊盘在所有层(包括隐藏层)中的绝对索引。
- Only show layers in layerstack - 启用此选项可仅显示层叠中(源自 Layer Stack Manager)的层。查看 Layer Stack Manager (Design » Layer Stack Manager)可了解使用了哪些层。 如果禁用此选项,则显示所有可用的 PCB 层。
-
锡膏掩膜扩展
软件会自动在锡膏掩膜中创建与焊盘形状相同的开窗。根据此设置,开窗可以比焊盘本身 更大(正扩展值)或更小(负扩展值)。通常,锡膏掩膜开窗比焊盘小,但也有例外。
- Expansion value from rules - 启用此选项后,此焊盘的锡膏掩膜扩展由适用的 锡膏掩膜扩展 设计规则定义。
- Specify expansion value - 启用此选项可覆盖规则,并指定此焊盘的锡膏掩膜扩展值。
阻焊层扩展
软件会自动在阻焊层中创建与焊盘形状相同的开窗。根据此设置,开窗可以比焊盘本身 更大(正扩展值)或更小(负扩展值)。通常,阻焊开窗比焊盘大,但也有例外。
- Expansion value from rules - 启用此选项后,此焊盘的阻焊层扩展由适用的 阻焊层扩展 设计规则定义。
- Specify expansion value - 启用此选项可覆盖规则,并指定此焊盘的阻焊层扩展值。
- Solder Mask From The Hole Edge - 如果在此对话框中指定扩展值,还可以启用此选项,以孔边缘 而非焊盘边缘为基准定义阻焊层扩展。
- Force complete tenting on top - 盖油是指 to close off。启用此选项后,将覆盖适用的阻焊层扩展设计规则中的设置,使此焊盘在顶层阻焊层上不产生开窗。启用此选项时,将忽略 Expansion value from rules 和 Specify expansion value 选项。
- Force complete tenting on bottom - 盖油是指 to close off。启用此选项后,将覆盖适用的阻焊层扩展设计规则中的设置,使此焊盘在底层阻焊层上不产生开窗。启用此选项时,将忽略 Expansion value from rules 和 Specify expansion value 选项。
生成网络报告
要从当前 PCB 文档生成网络表状态报告,请从主菜单中选择 Reports » Netlist Status 命令。 此报告提供已布线电路板的网络表详细信息。它列出所有网络,并针对每个网络指出布线所用的层以及实际布线的总走线长度。 运行该命令后,将生成报告 Net Status - <PCBDocumentName>.html 并将其作为活动文档打开。报告中列出了每个网络;单击网络名称可在 PCB 文档中高亮显示该网络。实际布线的走线长度数据最初以电路板设计本身指定的度量单位显示。根据需要,使用报告中的 Units 字段可在英制和公制单位之间快速切换。
),可以选择特定网络的连接线,并在 Properties 面板中显示其属性。









