组件安置
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概览
- 您将了解 PCB 元件封装包含哪些内容,从焊盘、丝印特征到可选的 3D 实体。
- 您将了解 Altium Designer 中哪些元件属性会影响元件的放置、方向、层分配和标识。
- 您将了解 PCB 编辑器如何处理不同的元件类型和面积定义。
有一种说法,PCB 设计中 90% 的工作是布局,10% 是布线。虽然这两者的比例可能存在争议,但人们普遍认为,良好的元件布局对于优秀的电路板设计至关重要。请记住,在布线过程中,您可能还需要调整布局。
元件封装定义了将实体元件安装到印制电路板上所需的空间和连接点。它是一个组合对象,由焊盘、线条和圆弧等一系列简单的图元对象以及其他设计对象组成。

元件封装定义了元件在 PCB 上的安装方式和连接点,还可以包含用于定义实际元件的 3D 实体对象。
焊盘为元件引脚提供安装和连接点。通常还会包含线条和圆弧等其他设计图元,用于在元件的丝印层上绘制元件外形轮廓。
元件封装还可以包含可选的 3D 实体对象,用于定义安装在电路板上的实际元件所占据的物理空间或包络。如果已使用 3D 实体对象或导入的 STEP 模型定义了实体元件,则可以执行三维元件间距检查。
元件封装是在 PCB 封装编辑器中通过放置合适的设计对象来创建的,这些对象构成了安装和连接元件所需的形状。元件参考点是 PCB 封装编辑器设计空间的原点,可以在编辑器中将其设置为元件的 1 号引脚、几何中心或用户自定义的位置。要了解有关封装创建的更多信息,请参阅 创建 PCB 封装 页面。
元件属性
常规选项卡
位置
-
(X/Y)
-
X (第一个字段)– 元件参考点相对于当前设计空间原点的当前 X(水平)坐标。编辑此值可更改元件的 X 位置。可以使用公制或英制输入数值;如果输入值的单位不是当前默认单位,请同时输入单位。元件封装的参考点在库编辑器中设置。
-
Y (第二个字段)– 元件参考点相对于当前原点的当前 Y(垂直)坐标。编辑此值可更改元件的 Y 位置。可以使用公制或英制输入数值;如果输入值的单位不是当前默认单位,请同时输入单位。元件封装的参考点在库编辑器中设置。
-
-
Rotation – 元件的旋转角度(以度为单位),从零度位置(3 o'clock 水平方向)起沿逆时针方向测量。编辑此值可更改元件的旋转角度。最小角度分辨率为 0.001°。
属性
-
Layer – 设置元件所在的层。元件可以放置在顶层或底层。使用下拉列表可选择其他层。更改所在层会将元件的所有图元切换到各自对应的相反层。例如,将顶层元件移到底层时,单层焊盘会从顶层切换到底层,顶层丝印层上的图元会被重新分配到底层丝印层,配对机械层上的图元会切换到该配对中的另一个机械层。元件的朝向将沿 X 轴翻转,元件丝印文字将从底面读取。
-
Reuse Block – 当元件属于某个复用块时,此字段会显示其所属复用块的名称。单击 Reuse Block 超链接可查看此复用块的属性。
-
Designator – 元件位号是一个最长为 255 个字符的字母数字字符串。每个元件都必须具有唯一的位号字符串。切换
或
可显示/隐藏位号。单击 Designator 超链接可打开元件位号的属性。
-
Comment – 元件注释是一个最长为 255 个字符的字母数字字符串。切换
或
可显示/隐藏注释。单击 Comment 超链接可打开元件注释的属性。
-
Area – 以当前电路板单位显示已放置元件的面积。该面积可由用户定义;如果未定义,则会根据元件的选择区域自动计算:
-
要定义元件面积,请在 PCB 封装编辑器中,通过封装的 Properties 面板编辑 Area。要将更新后的封装推送到已打开的 PCB,请在 PCB Library 面板中右键单击封装名称,然后从右键菜单中选择 Update PCB With <ComponentName>。
-
您也可以自定义已放置在 PCB 上的元件的面积,方法是选择该元件,然后在此字段中输入数值。
-
要将已放置在 PCB 上的元件的面积从用户定义值切换为计算值,请删除此字段中的数值;该字段将自动重新填入自动计算的数值。
-
自动计算的面积就是单击选择元件时高亮显示的区域面积。选择区域根据 Courtyard 层上的几何图形确定;如果不存在该层,则根据丝印层、3D 实体对象和铜层上的几何图形组合确定(不包括字符串)。下方上面的几张图显示了 Courtyard 层上定义有轮廓时的元件面积;下面的图显示了根据丝印层、3D 实体对象和铜层上的几何图形计算出的面积。
► 了解有关选择区域计算方式以及用于确定选择区域的其他可用模式的更多信息。
► 了解有关使用机械层的更多信息。
-
-
Description – 此元件的元件级描述。通常,描述在创建元件时定义,但也可以在原理图中编辑元件的描述或为其添加描述。此描述显示在 Components 面板中。
-
Type – 在此处为元件封装选择以下元件类型之一。可用类型包括:
-
Standard– 这些元件具有标准电气属性,始终在原理图和 PCB 之间保持同步(封装、引脚/焊盘和网络分配必须全部匹配),并包含在 BOM 中。例如,电阻等标准电气元件。 -
Mechanical– 这些元件不具有电气属性,不进行同步(必须在两个编辑器中分别手动放置),并包含在 BOM 中。例如,散热器。 -
Graphical– 这些元件不具有电气属性,不进行同步(必须在两个编辑器中分别手动放置),并且not包含在 BOM 中。例如,公司徽标。 -
Net Tie (in BOM)– 这些元件用于将两个或更多不同的网络短接在一起。它们始终在原理图和 PCB 之间保持同步(封装、引脚/焊盘和网络分配必须全部匹配),并包含在 BOM 中。它们与标准元件的不同之处在于,不检查封装内部铜所形成的连接关系,而正是这些铜实现了网络之间的短接。注意:在设计规则检查器对话框中启用 Verify Shorting Copper 选项,以验证元件内部没有未连接的铜。 -
Net Tie– 这些元件用于将两个或更多不同的网络短接在一起。它们始终在原理图和 PCB 之间保持同步(封装、引脚/焊盘和网络分配必须全部匹配),并且not包含在 BOM 中。它们与标准元件的不同之处在于,不检查封装内部铜所形成的连接关系,而正是这些铜实现了网络之间的短接。注意:在设计规则检查器对话框中启用 Verify Shorting Copper 选项,以验证元件内部没有未连接的铜。 -
Standard (No BOM)– 这些元件具有标准电气属性,始终在原理图和 PCB 之间保持同步(封装、引脚/焊盘和网络分配必须全部匹配),并且not包含在 BOM 中。例如,您希望从 BOM 中排除的测试点元件。 -
Jumper– 这些元件用于在 PCB 设计中加入跳线,例如在无法仅用一层完成全部布线的单面 PCB 上使用。对于此元件类型,元件封装和引脚在原理图与 PCB 之间保持同步,但网络分配不同步,且该元件包含在 BOM 中。除了在元件级别选择此选项外,还必须将元件中两个焊盘的 JumperID 设置为相同的非零值。跳线类型的元件无需在原理图上连接导线;只有在需要将其列入 BOM 时,才需要将其放置在原理图上。如果不需要将其列入 BOM,可以直接将其放置在 PCB 中,并在其中设置 Component Type 和 JumperIDs,再为焊盘手动分配 Nets。
-
-
Design Item ID – 显示所选元件的设计项 ID。此字段不可编辑。
-
Source – 显示元件的源文档。单击
可打开一个对话框,以浏览并选择其他源文档。
-
Revision State – 显示 Workspace 库元件修订版的生命周期状态及修订状态,即该修订版是此元件最新发布的修订版(
Up to date),还是较早的修订版(Out of date)。 -
Height – 元件的高度字段。在引入 3D 实体对象之前,此字段用于定义 PCB 元件的高度;不过,对于 3D 碰撞检测等任务,3D 模型提供了更好的元件高度定义方法。请注意,Altium MCAD CoDesigner 使用此 Height 字段中定义的值,而不是 3D 模型的高度(了解更多)。
-
3D Body Opacity – 输入所需的不透明度百分比,或使用滑块进行设置。
-
Primitives – 单击对应的锁定图标以锁定/解锁。
– 锁定 元件的所有图元,使其可作为单个对象处理。
– 解锁 以修改构成元件的各个图元。编辑完成后,应重新锁定元件图元。
-
Strings – 单击相应的锁定图标以锁定/解锁。
– 锁定 元件的所有字符串。
– 解锁 以修改元件的字符串。
封装
- Footprint Name – 显示与所选元件对应的封装名称。
- Design Item ID – 所选元件的标识。
- Source – 所选元件所在的工作区的名称。
- Description – 在 PCB 封装编辑器中定义的元件封装描述。
交换选项
- Enable Pin Swapping – 勾选以允许引脚交换功能。
- Enable Part Swapping – 勾选以允许子部件交换功能(例如,74 系列 IC 的四个子部件)。
原理图参考信息
- Designator – 与此 PCB 元件匹配的原理图元件的位号。
- Hierarchical Path – 显示此元件在原理图层次结构中的位置。
- Channel Offset – 首次将设计从原理图传输到 PCB 时,每张原理图上的每个元件都会获得一个唯一的通道偏移量。
参数选项卡
- Table – 显示每个所列参数的 Name、Value 和 Source。
元件位号和注释
位号和 注释 字段是 PCB 元件(部件)的子参数对象。位号用于唯一标识每个已放置的部件,以将其与项目中所有 PCB 文档内放置的其他部件区分开来。注释 用于为已放置的对象添加附加信息。注释和位号均在放置父元件部件对象后进行配置。它们不是可以直接放置的设计对象。

已放置的位号对象
如果初始元件的位号以数字字符结尾,则 PCB 2D/3D 元件位号在放置过程中会自动递增 1。放置前,可在 属性面板中更改第一个元件的位号。
要使位号按字母递增或按非 1 的数值步长递增,请使用 Paste Array 功能。此功能的控件位于 设置粘贴阵列对话框中,可通过按下 Paste Special 对话框(Edit » Paste Special)中的 Paste Array 按钮来访问。
使用图形化编辑方式,可以直接在设计空间中选择已放置的位号或注释对象,并更改其位置、旋转角度、方向和 大小。
选中位号或注释对象后,可使用以下编辑控制柄:

选中的位号
- 单击并拖动 B,以围绕参考点 A (由小 x 表示)旋转位号/注释。
- 单击并拖动 C,以同时沿垂直和水平方向调整位号/注释边界框的大小。
- 单击并拖动 D,以分别沿垂直和水平方向调整位号/注释边界框的大小。
-
单击位号/注释上远离编辑控制柄的任意位置并拖动,即可重新定位。拖动时,可以旋转或镜像注释:
- 按 Spacebar 可逆时针旋转位号/注释,按 Shift+Spacebar 可顺时针旋转。旋转角度遵循 Preferences 对话框的 PCB 编辑器 – 常规页面中定义的 Rotation Step 值。
- 按 X 或 Y 键,可沿 X 轴或 Y 轴镜像位号/注释。
可以在 Properties 面板的 Parameter 模式下修改位号或注释对象的属性。
参数属性

Properties 面板的 Parameter 模式。
位置
-
(X/Y)
-
X (第一个字段)- 位号参考点相对于当前工作区原点的当前 X(水平)坐标。编辑此值可更改位号的 X 位置。该值可以使用公制或英制单位输入;如果输入值的单位与当前默认单位不同,请同时输入单位。
-
Y (第二个字段)- 位号参考点相对于当前原点的当前 Y(垂直)坐标。编辑此值可更改位号的 Y 位置。该值可以使用公制或英制单位输入;如果输入值的单位与当前默认单位不同,请同时输入单位。
-
- Rotation - 从零度(3 o'clock 水平方向)开始逆时针测量的位号旋转角度(以度为单位)。编辑此值可更改位号的旋转角度。最小角度分辨率为 0.001°。
属性
-
Parameter type - 显示参数类型(元件、图纸符号等)和参数名称。
-
Name - 位号的名称。
-
Value - 使用此字段输入所需的位号值。单击眼睛图标可切换该值在设计空间中的可见性。
-
Layer - 使用下拉列表选择所需的层。根据需要启用 Mirror 。
-
Autoposition - 使用下拉列表选择相对于关联对象的所需自动定位位置。
-
Text Height - 使用此字段输入所需的文本高度。
-
Font Type
-
TrueType - 选择此项以使用 PC 上可用的字体(位于 \Windows\Fonts 文件夹中)。TrueType 字体提供完整的 Unicode 支持。 默认情况下,软件会链接到所使用的 TrueType 字体(字体不存储在 PCB 文件中),这意味着将设计移至其他 PC 时,该 PC 上必须安装相同的字体。您也可以使用 Preferences 对话框中 PCB 编辑器 - TrueType 字体 页面上的选项,将使用的 TrueType 字体嵌入 PCB 文件;在该页面中,还可以选择一个 Substitution Font ,以便在未嵌入的字体不可用时使用。
-
Justification - 用于设置位号在边框矩形内的位置。
- Left - 单击左侧按钮,使文本在水平方向上左对齐。
- Center - 单击中间按钮,使文本在水平方向上居中对齐。
- Right - 单击左侧按钮,使文本在水平方向上右对齐。
- Above - 单击上方按钮,使文本在垂直方向上顶端对齐。
- Middle - 单击中间按钮,使文本在垂直方向上居中对齐。
- Below - 单击下方按钮,使文本在垂直方向上底端对齐。
-
Font - 使用下拉列表选择所需的 TrueType 字体。根据需要使用 B (bold) 和/或 I (italic) 选项来强调文本。
-
Inverted - 使用 将文本显示为反白形式,并可控制文本周围边框的大小。您可以使用以下选项进一步配置文本:
-
Size (Width/Height) -
- Width - 边框矩形的宽度。
- Height - 边框矩形的高度。
-
Size (Width/Height) -
-
Inverted - 使用 将文本显示为反白形式,并可控制文本周围边框的大小。您可以使用以下选项进一步配置文本:
-
-
Stroke
-
Justification - 用于设置位号在边框矩形内的位置。
- Left - 单击左侧按钮,使文本在水平方向上左对齐。
- Center - 单击中间按钮,使文本在水平方向上居中对齐。
- Right - 单击左侧按钮,使文本在水平方向上右对齐。
- Above - 单击上方按钮,使文本在垂直方向上顶端对齐。
- Middle - 单击中间按钮,使文本在垂直方向上居中对齐。
- Below - 单击下方按钮,使文本在垂直方向上底端对齐。
-
Font - 使用下拉列表选择所需的笔画字体。可选项包括:
-
Default- 一种简单的矢量字体,专为笔式绘图和矢量光绘而设计。 -
Sans Serif- 一种复杂字体,会降低 Gerber 等矢量输出的生成速度。 -
Serif- 一种复杂字体,会降低 Gerber 等矢量输出的生成速度。
-
- Stroke Width - 显示笔画宽度。
-
Justification - 用于设置位号在边框矩形内的位置。
-
TrueType - 选择此项以使用 PC 上可用的字体(位于 \Windows\Fonts 文件夹中)。TrueType 字体提供完整的 Unicode 支持。 默认情况下,软件会链接到所使用的 TrueType 字体(字体不存储在 PCB 文件中),这意味着将设计移至其他 PC 时,该 PC 上必须安装相同的字体。您也可以使用 Preferences 对话框中 PCB 编辑器 - TrueType 字体 页面上的选项,将使用的 TrueType 字体嵌入 PCB 文件;在该页面中,还可以选择一个 Substitution Font ,以便在未嵌入的字体不可用时使用。
-
Border Mode
-
Margin - 单击此按钮以启用“边框边距”选项的编辑。
- Text Offset - 位号相对于其对齐的边缘/角点向内偏移的距离。选择 Center 对齐模式时,此选项不起作用。此选项不适用于 Margin。
-
Offset - 单击此按钮以启用“文本偏移”选项的编辑。
- Margin Border - 用于指定围绕位号的边框边距大小。 此选项不适用于 Offset。
-
Margin - 单击此按钮以启用“边框边距”选项的编辑。
PCB 上的元件可用性
将设计从原理图编辑器传输到 PCB 编辑器时,会自动从可用库中放置 PCB 元件封装。这称为 设计同步,是检测并解决原理图与 PCB 之间差异的过程。
Altium Designer 提供了一组工具,方便在 PCB 设计空间中放置所需的元件封装。请参阅以下页面,了解这些工具:
浏览已放置的元件
在 PCB 面板的 Components 模式下,其三个主要区域会发生变化,以反映当前 PCB 设计的元件层次结构(从上到下依次为):
- Component Classes
- Components 类中的
- Component Primitives

PCB 面板的各个区域允许逐级筛选,从元件类到单个元件,再到元件图元。
右键单击元件或元件图元条目,然后选择 Properties 命令 (或直接双击该条目),即可访问 Properties 面板,您可以在其中根据需要查看/修改元件或图元的属性。
右键单击元件类条目,然后选择 Properties (或直接双击该条目),即可打开该类的 编辑元件类对话框。在此对话框中,您可以查看/修改该类包含的元件、重命名该类或添加其他类。
面板的 Component Primitives 区域中是否显示/包含各类元件图元,取决于是否在从 Components 或 Component Primitives 区域访问的右键菜单中启用了相应选项。

右键单击元件或元件图元条目,选择要包含的项目。
浏览时,可以通过双击 Components 区域中 Footprint 列右侧的方框,轻松锁定或解锁元件。

从 PCB 面板锁定/解锁元件,无需再到 Properties 面板中操作。
元件选择边界框
单击并选择元件时,会显示选择边界框。要控制使用哪些层来定义边界框,可使用 高级设置对话框中的 PCB.ComponentSelection 选项。该选项支持三种模式(输入值 0、1 或 2;默认模式为 2):
-
0 - legacy mode- 此模式合并所有层上的几何图形,但不包括丝印层上的位号和注释字符串。 -
1 - by layer mode- 按以下优先顺序,使用下列层中第一个包含对象的层上的几何图形:-
Courtyard 层类型
-
3D 实体层(STEP 模型存储在 3D 实体对象中,该对象的尺寸为能够容纳模型的最小长方体。选择元件时,使用的是此 3D 实体,而不是 STEP 模型的形状)
-
丝印层加铜层
-
铜层
-
-
2 - by graphic mode- 此模式合并在 Courtyard 层类型、丝印层、3D 实体对象和铜层上检测到的几何图形。不包括字符串。
向元件添加图元
可通过主菜单中的 Tools » Convert » Add Selected Primitives to Component 命令,将选定的图元添加到元件中。选择命令后,选择要将选定图元添加到的元件。确认后,新图元将被识别为该单一元件对象的一部分,并可与元件的原有图元配合使用。
要执行此操作,必须先解锁目标元件的图元。使用元件属性中的 Primitives 锁定图标可解锁元件图元。
将元件打散为图元
可使用主菜单中的 Tools » Convert » Explode Component to Free Primitives 命令,将元件转换为构成它的图元对象;也可右键单击已放置的元件(无论是否选中),然后从右键菜单中选择 Component Actions » Explode Component To Free Primitives (或 Explode Selected Components To Free Primitives)命令。打散后的元件不再是元件,因此其位号和注释将被移除,并还原为构成它的各个图元。
打散操作不会影响相应源库中存储的封装模型,只会影响 PCB 文档上所放置元件的被转换实例。
通过可单击链接访问参考信息
将命名文档链接添加到元件后,即可打开选定元件或光标下元件所对应的文档/页面 URL,该 URL 通过底层定义的 URL 链接参数指定。此功能可将从原理图元件传递过来的命名文档链接,显示为指向 PDF、文本文件或 HTML 页面的命名 PCB 元件链接。当元件的命名文档链接从原理图更新到 PCB(Design » Update PCB Document)时,就会发生此转换。在此更新过程中(通过 ECO),原理图中的命名文档链接会转换为对应 PCB 元件的 ComponentLink 参数对(ComponentLinknDescription/ComponentLinknURL)。例如:
| 原理图元件参数 | PCB 元件参数 | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
元件参数中使用的链接索引号(n)决定了对应 PCB 元件链接在 References 子菜单中的排列位置。选中 PCB 上的元件后,定义的 ComponentLink 参数对会显示在 属性面板的 Parameters 部分中。
启动该命令后,将直接打开基于 Web 的 URL 目标页面或指定文档(如果可用)。




)。请注意,这仅适用于 Courtyard 层上定义的形状为闭合形状,且走线端点顶点重合(精确接触)的情况。否则,边界框将由包围 Courtyard 层上所有对象的最小矩形定义。