Altium Designer Documentation

Create Project (File Menu)

Modified by Susan Riege on Mar 3, 2020
此文档页面引用了不再受支持的产品 Altium Vault, Altium Vault 及其组件管理功能已迁移到 Altium Concord Pro


The Create Project dialog

Summary

The Create Project dialog is used to create a new project. Every design starts with a project file that stores project level settings, such as links to each of the design documents within that project. As well as creating the new project file on the hard drive, this dialog supports adding the new project to version control or creating it as a managed project in your server or workspace.

The new project can be created:

  • As a managed project in an Altium Designer workspace.
  • As a managed project in an on-site server.
  • In your version control system with a working copy in your preferred location.
  • In a folder on the local hard drive.

Access

The dialog is accessed by choosing File » New » Project from the main menus.

Options/Controls

Locations

Select the target location of the project. 

 The Create Project dialog when not signed in on the left, and when connected to a Workspace on the right.

If you are not connected to a Workspace, do so by clicking the corresponding button for the Workspace in the main area of the dialog. 
  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Description - enter a meaningful description of the project.
  • Enable Formal Version Control - allows multiple contributors to work on this project - enable this option using the checkbox, if desired. 
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a managed project are read-only and can be accessed on the Server Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when not signed in on the left and when signed in to a Managed Content Server on the right. 

If you are not currently signed in to your Server, do so by clicking the corresponding button for the Server in the main area of the dialog. All known on-site servers will be listed in which you will be prompted to sign in using your server credentials, unless Sign in Automatically has been enabled from your Sign In dialog. Alternatively, you can sign in to a different server using the Custom button. Remember that while it is possible to have connections to different servers (these are listed as Known Servers), you can only be actively signed in to one managed content server through the software at a time. You can check which servers you are connected to from the Data Management - Servers page of the Preferences dialog. 
  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Description - enter a meaningful description of the project.
  • Repository - use the drop-down to display the connected repositories defined in the Data Management - Design Repositories page of the Preferences dialog. Click  to open the Preferences dialog from where you can connect to a repository.
  • Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Item dialog in which you can can navigate to and select the desired folder within the repository.  
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a managed project are read-only and can be accessed on the Server Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when creating a project under Version Control

  • Project Name - a default name appears; enter a meaningful name for the project.
  • Repository - use the drop-down to display the connected repositories defined in the Data Management - Design Repositories page of the Preferences dialog. Click  to open the Preferences dialog from where you can connect to a repository.
  • Repository Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Item dialog in which you can can navigate to and select the desired folder within the repository.  
  • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a version-controlled project can be accessed on the  Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when creating a Local Project 

  • Project Name - a default name appears; enter a meaningful name for the project.
  • Folder - a default name appears; enter a meaningful name for the project. Use  to open a dialog in which you can browse to and select the desired local folder.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a local project can be accessed on the Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

Additional Controls

  • Create - click to create and save the project and associated files. The new project will be listed in the Projects panel.
When you click Create for a version-controlled or managed project, it will be added to the specified folder within the target repository then checked out to the local working folder defined in the Local Storage field. 
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。