Integrierte Bibliotheken

Auf einen Blick

Integrierte Bibliotheken in Altium Designer vereinen Schaltplansymbole, verknüpfte Modelle und Bauteilparameter in einer einzigen, portablen Datei. In diesem Artikel erfahren Sie, wie Sie ein integriertes Bibliothekspaket erstellen, referenzierte Modelle verfügbar machen und das Paket kompilieren. Dabei prüfen Sie auf fehlende Modelle und Fehler bei der Pin-Zuordnung. Lesen Sie weiter und machen Sie den nächsten Schritt zur Erstellung und Validierung Ihrer eigenen integrierten Bibliotheken.

- Erfahren Sie, wie integrierte Bibliotheken die Portabilität verbessern und Bauteilmodelle zusammenhalten.
- Lernen Sie, wie Sie Quellbibliotheken vorbereiten und Modelle über Projektdateien, installierte Bibliotheken oder Suchpfade verfügbar machen.
- Entdecken Sie, wie Sie die Fehlerberichterstattung konfigurieren und Ihr Bibliothekspaket zu einer IntLib-Datei kompilieren.
Mit KI tiefer einsteigen:

Integrierte Bibliotheken entsprechen dem Integrated Component-Modell von Altium Designer. In diesem Modell wird die übergeordnete Komponente innerhalb des Schaltplansymbols in einer Schaltplanbibliotheksdatei (*.SchLib) modelliert. Weitere Modelle werden mit dem Symbol verknüpft, und Komponentenparameter werden dem Symbol hinzugefügt. Alle Quellbibliotheken – Symbole und verknüpfte Modelle – werden innerhalb eines Integrated Library Package-Projekts definiert, das anschließend zu einer einzigen Datei kompiliert wird – einer Integrated Library oder IntLib.

Dieses Dokument erläutert die verschiedenen Möglichkeiten, eine integrierte Bibliothek zu erstellen, sowie das Platzieren von Komponenten aus einer solchen Bibliothek und deren Bearbeitung.

Die Vorteile integrierter Bibliotheken

Die wichtigsten Vorteile der Kompilierung zu einer integrierten Bibliothek sind:

  • Alle Komponenteninformationen sind in einer einzigen, portablen Datei verfügbar. Da alle Modelle in der integrierten Bibliothek gebündelt sind, muss nur eine Datei für das Projekt verfügbar sein oder beim Verschieben des Projekts mitgenommen werden. Diese Portabilität ist von unschätzbarem Wert, wenn Sie an verschiedenen Arbeitsstationen arbeiten oder Ihre Designs mit anderen teilen möchten.
  • Wenn eine Komponente aus einer integrierten Bibliothek in einem Schaltplan platziert wird, findet Altium Designer garantiert das richtige Modell, sofern es die integrierte Bibliothek finden kann, aus der die Komponente stammt. Es ist also kein Jonglieren mit getrennten Bibliotheks- und Modelldateien erforderlich, bei denen Modellverknüpfungen sehr „fragil“ sein können und durch alltägliche Verwaltungsaufgaben wie das Umbenennen von Ordnern auf einer Festplatte leicht unterbrochen werden.
  • Aus Sicherheitsgründen sind integrierte Bibliotheken robust. Nach ihrer Erstellung können sie nicht mehr verändert werden. Eine integrierte Bibliothek zu aktualisieren bedeutet daher, sie vollständig zu ersetzen. Sie müssen dazu gezielt das ursprüngliche Bibliothekspaket öffnen, die Quelldokumente aktualisieren und anschließend erneut kompilieren.
  • Diese Bibliotheken werden bei der Kompilierung auch auf Integrität geprüft. Das bedeutet, dass nicht nur die Verfügbarkeit, sondern auch die korrekte Pin-Zuordnung geprüft wird. Selbst wenn Sie weiterhin mit einzelnen Bibliotheksdateien arbeiten möchten, empfiehlt es sich, Ihre Schaltplanbibliotheken in einem integrierten Bibliothekspaket zu kompilieren – und sei es nur, um sicherzustellen, dass die Quellkomponenten den Zielmodellen korrekt zugeordnet werden. Sobald Sie dies überprüft haben, können Sie die erstellte integrierte Bibliothek ignorieren und weiterhin direkt aus Ihren Schaltplanbibliotheken platzieren.

Erstellen einer IntLib mithilfe eines Bibliothekspakets

Ein integriertes Bibliothekspaket (*.LibPkg) ist ein Altium Designer-Projekttyp, mit dem die zur Erstellung einer integrierten Bibliothek erforderlichen Designdokumente zusammengeführt werden. Schaltplansymbole werden im Schaltplanbibliothekseditor gezeichnet. Für jedes Symbol werden Modellreferenzen bzw. -verknüpfungen sowie Parameterinformationen definiert. Diese werden in einer oder mehreren Schaltplanbibliotheksdateien gespeichert. Zu den referenzierten Modellen können PCB-Footprints, Schaltungssimulationsmodelle und Signalintegritätsmodelle gehören.

Das einzige Dokument, das dem integrierten Bibliothekspaket hinzugefügt werden muss, ist die Schaltplanbibliothek bzw. sind die Schaltplanbibliotheken. Die Dateien mit PCB-2D/3D-Komponentenmodellen und Simulationsmodellen bzw. Teilschaltungen können sich an jedem gültigen Suchort innerhalb des Projekts, in Dateien aus der Liste der installierten Bibliotheken oder in den für das Paket angegebenen Suchpfaden befinden.

Das Bibliothekspaket wird anschließend zu einer einzigen integrierten Bibliotheksdatei (*.IntLib) kompiliert.

Ob Sie Modellbibliotheken im Projekt zusammenführen oder über Suchpfade auffinden lassen, hängt von Ihrer jeweiligen Arbeitsweise ab. Wenn Sie Modelle während der Vorbereitung des integrierten Bibliothekspakets prüfen und bearbeiten, möchten Sie möglicherweise direkt auf die Modellbibliotheken zugreifen können und sie deshalb dem Paket selbst hinzufügen. Wenn Sie fortlaufend Modellbibliotheken zu bestimmten Ordnern auf einer Festplatte oder im Netzwerk hinzufügen, bevorzugen Sie möglicherweise Suchpfade, über die der Compiler neu hinzugefügte Bibliotheken automatisch erkennt.
Beachten Sie, dass SPICE-Modelle aus *.LIB-Bibliotheken derzeit nicht zu kompilierten integrierten Bibliotheken hinzugefügt werden.

Zusammengefasst sind im Wesentlichen vier Schritte erforderlich, um eine integrierte Bibliothek zu erstellen:

  1. Ein Quellbibliothekspaket erstellen.

  2. Die erforderlichen Quell-Schaltplanbibliotheksdateien erstellen und hinzufügen.

  3. Die erforderlichen domänenspezifischen Modelldateien erstellen und hinzufügen oder auf diese verweisen.

  4. Das Bibliothekspaket kompilieren, um die integrierte Bibliotheksdatei zu erzeugen.

Erstellen des Quellbibliothekspakets

Erstellen Sie ein neues integriertes Bibliothekspaket, indem Sie den Befehl File » New » Library aus den Hauptmenüs wählen und anschließend die Option Integrated Library im Bereich File des sich öffnenden Dialogs New Library auswählen. Nachdem Sie auf Create geklickt haben, wird das neue, noch leere Bibliothekspaketprojekt dem Projects-Panel hinzugefügt und enthält zunächst keine Dokumente.

Erstellen und Hinzufügen einer Quell-Schaltplanbibliothek

Erstellen Sie die Quell-Schaltplanbibliothek (*.SchLib) mit den erforderlichen Komponenten. Fügen Sie für jede Komponente die erforderlichen Modellverknüpfungen und Parameterinformationen hinzu. Es gibt zwei Möglichkeiten, eine Quell-Schaltplanbibliothek zu erstellen:

  • Von Grund auf, indem Sie den Befehl File » New » Library aus den Hauptmenüs verwenden und die Option Schematic Library im Bereich File des Dialogs New Library auswählen. Erstellen Sie neue Komponenten mit dem Schaltplansymboleditor oder kopieren Sie Komponenten aus anderen geöffneten Schaltplanbibliotheken.
  • Indem Sie im Projects-Panel mit der rechten Maustaste auf den Eintrag des Bibliothekspakets klicken und anschließend den Befehl Add New to Project » Schematic Library aus dem Kontextmenü wählen.
  • Aus den Komponenten, die bereits auf Schaltplandokumenten eines Projekts platziert wurden, mithilfe des Befehls Design » Make Schematic Library.
Wenn Sie eine Schaltplanbibliothek aus platzierten Komponenten in einem bestehenden Designprojekt erstellen, werden alle Quell-Schaltplandokumente automatisch geöffnet. Die resultierende Bibliothek wird nach dem Projekt benannt (<ProjectName>.SchLib).

Nachdem Sie die Quell-Schaltplanbibliothek bzw. die Quell-Schaltplanbibliotheken vorbereitet haben, fügen Sie diese dem Bibliothekspaket mit einer der folgenden Methoden hinzu:

  • Mit dem Befehl Project » Add Existing to Project.
  • Indem Sie im Projects-Panel mit der rechten Maustaste auf den Eintrag des Bibliothekspakets klicken und anschließend den Befehl Add Existing to Project aus dem Kontextmenü wählen.

Dem Bibliothekspaket hinzugefügte Quell-SchLib.
Dem Bibliothekspaket hinzugefügte Quell-SchLib.

Erstellen und Hinzufügen domänenspezifischer Modelldateien

Erstellen Sie die von den Schaltplankomponenten referenzierten Modelle in den entsprechenden Dateien: PCB-2D/3D-Komponentenmodelle in einer PCB-Bibliothek (*.PcbLib), Simulationsmodelle und Teilschaltungen in Model- (*.Mdl) und Subcircuit-Dateien (*.Ckt). Das wichtigste Modell ist natürlich das PCB-2D/3D-Komponentenmodell, das wie sein Gegenstück in der Schaltplanbibliothek auf zwei Arten erstellt werden kann:

  • Indem Sie den Befehl File » New » Library aus den Hauptmenüs verwenden und die Option PCB Library im Bereich File des Dialogs New Library auswählen. Erstellen Sie neue 2D-Footprints mit dem PCB-Footprint-Editor und fügen Sie gegebenenfalls 3D-Körperinformationen hinzu, oder kopieren Sie Komponenten aus anderen geöffneten PCB-Bibliotheken.
  • Indem Sie im Projects-Panel mit der rechten Maustaste auf den Eintrag des Bibliothekspakets klicken und anschließend den Befehl Add New to Project » PCB Library aus dem Kontextmenü wählen.
  • Aus den PCB-2D/3D-Komponentenmodellen, die bereits auf dem PCB-Dokument platziert wurden, mithilfe des Befehls Design » Make PCB Library.
Wenn Sie eine PCB-Bibliothek aus einem bestehenden PCB-Dokument erstellen, stellen Sie sicher, dass das Dokument geöffnet und aktiv ist. Die resultierende Bibliothek wird nach dem Dateinamen des PCB-Dokuments benannt (<PCBDocumentName>.PcbLib).

Festlegen der Suchorte für die Modelle

Nachdem die Modelldateien definiert wurden, müssen sie nun dem Bibliothekspaket zur Verfügung gestellt werden, damit sie bei Bedarf leicht gefunden werden können. Denken Sie daran: Die Modelle werden von den Schaltplankomponenten referenziert bzw. sind mit diesen verknüpft. Altium Designer verfügt über ein Standardsystem zur Bereitstellung von Modellen, unabhängig davon, ob Sie ein integriertes Bibliothekspaket erstellen oder an einem Schaltplanentwurf arbeiten. Es gibt drei Möglichkeiten, Modelle bereitzustellen:

  • Hinzufügen der Bibliothek bzw. des Modells zum Projekt.
  • Installieren der Bibliothek bzw. des Modells in der Liste der installierten Bibliotheken. Dort steht sie bzw. es allen Designprojekten zur Verfügung.
  • Definieren eines Suchpfads zur Bibliothek bzw. zum Modell.

Jede dieser Methoden bietet Vorteile. Wählen Sie daher die Methode, die am besten zu Ihrer Arbeitsweise passt. Auch für unterschiedliche Modelle eignen sich unterschiedliche Ansätze besser. Beispielsweise möchten Sie beim Öffnen des Bibliothekspakets möglicherweise nicht eine große Anzahl von Simulationsmodellen im Bedienfeld „Projects“ sehen, wohl aber die Bibliotheken mit den 2D-/3D-Leiterplattenkomponentenmodellen. Definieren Sie in diesem Fall einen Suchpfad zum Ordner, in dem die Simulationsmodelle gespeichert sind, und fügen Sie die PCB-Bibliothek zum Bibliothekspaket hinzu.

Zusammen bilden diese drei Methoden zur Bereitstellung von Modellen die Libraries Preferences (für ein Projekt verfügbar) und können alle im Dialogfeld Libraries Preferences definiert werden. Dieses öffnen Sie, indem Sie oben rechts im Bedienfeld „Components“ auf Libraries dialogs access button klicken und anschließend den Befehl Libraries Preferences auswählen.

Definieren Sie die Modellverfügbarkeit im Dialogfeld Libraries Preferences .
Definieren Sie die Modellverfügbarkeit im Dialogfeld Libraries Preferences .

Die PCB-Bibliothek (und bei Bedarf weitere Modelldateien) kann auch direkt zum Bibliothekspaket hinzugefügt werden. Verwenden Sie dazu den Befehl Add Existing to Project, der im Hauptmenü Project oder im Kontextmenü des Bibliothekspaketeintrags im Bedienfeld Projects verfügbar ist.

Quell-PcbLib zum Bibliothekspaket hinzugefügt.
Quell-PcbLib zum Bibliothekspaket hinzugefügt.

Wenn Sie auf der Registerkarte Search Path des Dialogfelds Libraries Preferences Suchpfade zu Modelldateien definieren, wird die Registerkarte „Search Paths“ des Dialogfelds Options for Integrated Library (Project » Project Options) aufgerufen. Fügen Sie nach Bedarf einen oder mehrere Pfade hinzu. Beachten Sie dabei, dass diese Pfade von oben nach unten nach Modellen durchsucht werden. Klicken Sie auf die Schaltfläche Refresh List, um zu überprüfen, ob die benötigten Modelldateien tatsächlich gefunden werden, und passen Sie bei Bedarf einen Pfad an.

Um auf die Registerkarte Search Paths des Dialogfelds Options for Integrated Library zugreifen zu können, muss die Option UI.ProjectOptions.SearchPaths im Dialogfeld „Advanced Settings“ aktiviert sein. Dieses öffnen Sie über die Schaltfläche Advanced auf der Seite „System – General“ des Dialogfelds Preferences. Sie müssen Altium Designer neu starten, damit die Änderung dieser Einstellung wirksam wird.

Beispiel für einen definierten Suchpfad, über den die benötigte PcbLib-Modelldatei gefunden wird.
Beispiel für einen definierten Suchpfad, über den die benötigte PcbLib-Modelldatei gefunden wird.

Kompilieren und Validieren des Bibliothekspakets

Nachdem die Quellbibliotheken zum Bibliothekspaket hinzugefügt und alle erforderlichen Pfade zu Modelldateien definiert wurden, kann das Paket nun kompiliert werden, um die integrierte Bibliothek zu erzeugen. Wie bei jedem anderen Projekt erzeugt der Compiler für ein integriertes Bibliothekspaket eine Liste mit Warnungen und/oder Fehlermeldungen, beispielsweise Warnungen zu nicht gefundenen Modellen. Zusätzlich können Fehler bei der Pin-Zuordnung geprüft werden, etwa eine Zuordnung zu den Pads 1 und 2, obwohl der tatsächliche Footprint die Pads A und K enthält.

Auch wenn Sie weiterhin mit separaten Bibliotheksdateien (*.SchLib, *.PcbLib) arbeiten möchten, empfiehlt es sich, Ihre Schaltplanbibliotheken in einem integrierten Bibliothekspaket zu kompilieren – und sei es nur, um sicherzustellen, dass die Quellkomponenten den Zielmodellen korrekt zugeordnet werden.

Vor dem Kompilieren sollten Sie die Bedingungen für die Fehlerberichterstattung auf der Registerkarte „Error Reporting“ des Dialogfelds Options for Integrated Library überprüfen und entsprechend einstellen.

Es empfiehlt sich, vor dem Kompilieren des Bibliothekspakets die Optionen für die Fehlerberichterstattung und die Schweregrade nach Bedarf festzulegen.
Es empfiehlt sich, vor dem Kompilieren des Bibliothekspakets die Optionen für die Fehlerberichterstattung und die Schweregrade nach Bedarf festzulegen.

Verwenden Sie zum Kompilieren den Befehl Compile Integrated Library entweder im Hauptmenü Project oder im Kontextmenü des Bibliothekspaketeintrags im Bedienfeld „Projects“. Die Quellbibliotheken und Modelldateien werden zu einer integrierten Bibliothek kompiliert, die nach dem Quellbibliothekspaket benannt wird (<LibraryPackageName>.IntLib). Der Compiler prüft auf Verstöße. Alle gefundenen Fehler oder Warnungen werden im Bedienfeld Messages aufgeführt. Beheben Sie etwaige Probleme in den Quellbibliotheken und kompilieren Sie anschließend erneut.

Beispiele für Fehler, die der Compiler beim Kompilieren des integrierten Bibliothekspakets meldet.
Beispiele für Fehler, die der Compiler beim Kompilieren des integrierten Bibliothekspakets meldet.

Die integrierte Bibliothek wird in dem Ausgabeordner gespeichert, der auf der Registerkarte „Options“ des Dialogfelds Options for Integrated Library festgelegt ist (standardmäßig ein Unterordner des Projektverzeichnisses: \Project Outputs for <ProjectName>). Wenn die Option Open outputs after compile auf der Registerkarte Options des Dialogfelds Options for Integrated Library aktiviert ist, wird die integrierte Bibliothek automatisch zur Registerkarte Installed des Dialogfelds Libraries Preferences  und zur Seite „Data Management – File-based Libraries“ des Dialogfelds Preferences hinzugefügt.

Die kompilierte integrierte Bibliothek wird zur Registerkarte Installed des Dialogfelds Libraries Preferences hinzugefügt.
Die kompilierte integrierte Bibliothek wird zur Registerkarte Installed des Dialogfelds Libraries Preferences hinzugefügt.

Erstellen einer IntLib aus Projektdokumenten

Eine integrierte Bibliothek kann auch direkt aus den zugehörigen Projektdokumenten (Quellschaltplänen und PCB-Dokument) erstellt werden. Dies ist nützlich, wenn Sie eine einsatzfähige Bibliothek oder ein Archiv Ihres fertigen Designs erstellen und wiederverwenden möchten. Verwenden Sie den Befehl Make Integrated Library, der im Hauptmenü Design sowohl im Schaltplan- als auch im PCB-Editor verfügbar ist.

Der Vorgang umfasst im Wesentlichen:

  1. Öffnen aller Quellschaltplandokumente und Erstellen einer Schaltplanbibliothek.
  2. Erstellen einer PCB-Bibliothek aus dem PCB-Dokument.
  3. Kompilieren dieser Bibliotheken zu einer integrierten Bibliothek, die nach dem Projekt benannt wird (<ProjectName>.IntLib).

Die IntLib wird zum Projekt hinzugefügt (unter Libraries\Compiled Libraries im Bedienfeld „Projects“), in die installierten Bibliotheken aufgenommen (als Teil der Available File-based Libraries, die jedem Projekt zur Verfügung stehen) und über das Bedienfeld „Components“ bereitgestellt.

Vereinfachte Erstellung einer integrierten Bibliothek direkt aus den Schaltplan- und PCB-Dokumenten des aktiven Designprojekts.
Vereinfachte Erstellung einer integrierten Bibliothek direkt aus den Schaltplan- und PCB-Dokumenten des aktiven Designprojekts.

  • Wenn Komponenten mit derselben Bibliotheksreferenz, aber unterschiedlicher interner Struktur gefunden werden, wird das Dialogfeld Duplicated Components geöffnet. Legen Sie in diesem Dialogfeld fest, wie mit solchen Komponenten verfahren werden soll: entweder die erste Instanz verarbeiten und alle weiteren ignorieren, alle Komponenten verarbeiten und ihnen eindeutige Namen zuweisen oder die Erstellung der Bibliothek abbrechen.
  • Das Bedienfeld Messages listet alle Probleme auf, die beim Erstellen der IntLib auftreten, beispielsweise verknüpfte Modelle, die nicht gefunden werden konnten.

Erstellen einer IntLib aus einer Datenbankbibliothek

Related page: Datenbankbibliotheken

Die Datenbankbibliotheken von Altium Designer sind die ideale Wahl, wenn Sie Ihre Altium Designer-Bauteile eng mit Ihrer Unternehmensdatenbank verknüpfen möchten. Soll das Design Ihren Unternehmensstandort verlassen oder sollen Ihre Entwickler lieber mit sicheren integrierten Bibliotheken arbeiten, lässt sich dies problemlos umsetzen. Altium Designer bietet die Möglichkeit, eine integrierte Bibliothek direkt aus einer Datenbankbibliothek zu kompilieren: entweder aus einer Standard-Datenbankbibliothek (DbLib) oder aus einer versionsverwalteten SVN-Datenbankbibliothek (SVNDbLib). So können Ihre CAD-Bibliothekare weiterhin Datenbankbibliotheken verwenden, während Ihre Entwickler mit regelmäßig neu generierten integrierten Bibliotheken sozusagen „offline“ arbeiten.

Die Konvertierung erfolgt mit dem Assistenten Offline Integrated Library Maker. Der Vorgang wird für jede Datenbanktabelle einzeln durchgeführt, wobei Sie vollständig steuern können, welche Tabellen der Datenbank berücksichtigt werden. Für jede einbezogene Tabelle wird eine separate integrierte Bibliothek generiert.

Konvertieren Sie Ihre Datenbankbibliotheken (DbLibs oder SVNDbLibs) mit dem Offline Integrated Library Maker in integrierte „Offline“-Bibliotheken.
Konvertieren Sie Ihre Datenbankbibliotheken (DbLibs oder SVNDbLibs) mit dem Offline Integrated Library Maker in integrierte „Offline“-Bibliotheken.

Der Vorgang umfasst die folgenden Schritte:

  1. Öffnen Sie die zu konvertierende Datenbankbibliotheksdatei (*.DbLib) oder SVN-Datenbankbibliotheksdatei (*.SVNDbLib) als aktives Dokument und wählen Sie in den Hauptmenüs den Befehl Tools » Offline Integrated Library Maker, um den Offline Integrated Library Maker aufzurufen.
  2. Geben Sie auf der Seite Library to Convert die zu verarbeitende DbLib oder SVNDbLib an. Standardmäßig wird die aktive Bibliothek, aus der der Offline Integrated Library Maker aufgerufen wurde, als zu konvertierende Bibliothek festgelegt. Bei Bedarf können Sie nach einer anderen Datenbankbibliothek suchen und diese auswählen.
  3. Legen Sie auf der Seite Options fest, welche Tabellen der verknüpften Datenbank in die Konvertierung einbezogen werden sollen. Standardmäßig werden alle Datenbanktabellen konvertiert. Um eine Tabelle auszuschließen, deaktivieren Sie die zugehörige Option Convert. Auf dieser Seite des Offline Integrated Library Maker können Sie außerdem ein Ausgabeverzeichnis festlegen, in dem die generierten integrierten Bibliotheken gespeichert werden. Geben Sie den Pfad zu diesem Basisverzeichnis direkt ein oder klicken Sie auf das Symbol Browse icon rechts neben dem Feld, um einen Dialog zu öffnen, in dem Sie zum gewünschten Verzeichnis navigieren und es auswählen können. Die generierte Ausgabe (integrierte Bibliothek) für jede einbezogene Datenbanktabelle wird in einem eigenen Unterordner innerhalb des angegebenen Ausgabeverzeichnisses gespeichert, der den Namen der Tabelle trägt.
  4. Nachdem Sie die Datenbankbibliothek ausgewählt und die zugehörigen Konvertierungsoptionen wie gewünscht eingestellt haben, klicken Sie auf Next, um die Konvertierung zu starten. Ein Fortschrittsbalken sowie Informationen zur aktuell konvertierten Datenbanktabelle werden angezeigt. Beachten Sie, dass der Konvertierungsvorgang für jede zur Konvertierung ausgewählte Datenbanktabelle durchgeführt wird. Der Vorgang gliedert sich im Wesentlichen wie folgt:
    1. Ein integriertes Bibliothekspaket (*.LibPkg) wird erstellt und im Bedienfeld Projects geöffnet. Das Paket erhält den Namen der Tabelle. Bei einer Tabelle namens Capacitor - Ceramic ergibt sich beispielsweise Capacitor - Ceramic.LibPkg.
    2. Ein Schaltplanbibliotheksdokument wird erstellt und dem LibPkg hinzugefügt. Auch dieses Dokument erhält den Namen der Tabelle (z. B. Capacitor - Ceramic.SchLib).
    3. Anschließend wird jeder Datensatz der Tabelle verarbeitet und das entsprechende Altium Designer-Bauteil erstellt. Dazu wird das referenzierte Schaltplansymbol aus der entsprechenden Quellbibliothek abgerufen und dem neuen Schaltplanbibliotheksdokument als Bauteil hinzugefügt. Anschließend werden die im Datensatz definierten Parameter- und Modellverknüpfungsinformationen zu diesem Bauteil hinzugefügt.
    4. Die im Datensatz referenzierten Footprint-Modelle werden abgerufen und einem PCB-Bibliotheksdokument hinzugefügt. Dieses Dokument erhält ebenfalls den Namen der Tabelle (z. B. Capacitor - Ceramic.PcbLib). Das PCB-Bibliotheksdokument wird anschließend dem LibPkg hinzugefügt.
    5. Wenn die Quellbibliothek eine DbLib ist und im Datenbankdatensatz Verknüpfungen zu PCB3D- und/oder Simulationsmodellen definiert wurden, werden auch die referenzierten PCB3D-Bibliotheksdateien und Simulationsmodelldateien zum LibPkg hinzugefügt. Der Speicherort dieser Modelle bleibt unverändert. Der vollständige Pfad zu einem Modell wird als Teil der entsprechenden Modellverknüpfung angegeben.
    6. Das LibPkg wird anschließend kompiliert, um die integrierte Bibliothek (z. B. Capacitor - Ceramic.IntLib) zu erzeugen. Diese wird danach den installierten Bibliotheken von Altium Designer hinzugefügt.

Die aktuell installierten Bibliotheken können auf der Seite Data Management – File-based Libraries des Dialogs Preferences sowie auf der Registerkarte Installed des Dialogs Available File-based Libraries angezeigt werden. Diesen öffnen Sie, indem Sie oben rechts im Bedienfeld Components auf Libraries dialogs access button klicken und anschließend File-based Libraries Preferences auswählen.

Ergebnisse des Konvertierungsvorgangs: Bibliothekspaketprojekte mit den zugehörigen Symbol- und Footprint-Modelldokumenten sowie die kompilierten IntLibs, die auch als installierte Bibliotheken hinzugefügt werden.
Ergebnisse des Konvertierungsvorgangs: Bibliothekspaketprojekte mit den zugehörigen Symbol- und Footprint-Modelldokumenten sowie die kompilierten IntLibs, die auch als installierte Bibliotheken hinzugefügt werden.

Erstellen einer IntLib durch Übernahme von Bauteilen

Related page: Übernehmen von Workspace-Daten mit dem Content Cart

Sie können außerdem Bauteile aus Ihrem Workspace in eine integrierte Bibliothek (*.IntLib) übernehmen. Wenn Sie Bauteile aus einer solchen integrierten Bibliothek platzieren, verweisen die tatsächlichen Verknüpfungen auf die Bauteile im Workspace. Dadurch können Sie die Workspace-Bauteile Ihres Unternehmens effektiv offline verwenden und gleichzeitig sicherstellen, dass das Design weiterhin eine echte Verbindung zu diesen Bauteilen im Quell-Workspace aufrechterhält.

Im Dialog Content Cart gehen Sie wie folgt vor, um eine IntLib zu übernehmen:

  1. Klicken Sie auf den Link Select target server und wählen Sie im Menü IntLib file.

    Legen Sie als Ziel des Content Cart eine IntLib-Datei fest.
    Legen Sie als Ziel des Content Cart eine IntLib-Datei fest.

  2. Geben Sie den Namen und den Speicherort für die generierte IntLib-Datei an. Standardmäßig erhält die Datei einen Namen im Format Integrated_Library - <Date> - <Time>.IntLib und wird unter \Users\Public\Documents\Altium\AD<Solution/Version>\Library\ExportCmpLib generiert. Passen Sie diese Angaben bei Bedarf im Dialog Save As an, den Sie durch Klicken auf den Link Change öffnen.

    Übernehmen Sie den standardmäßigen Zielordner und Dateinamen oder ändern Sie diese bei Bedarf.
    Übernehmen Sie den standardmäßigen Zielordner und Dateinamen oder ändern Sie diese bei Bedarf.

  3. Wenn Sie weitere Bauteile in dieselbe IntLib übernehmen möchten, klicken Sie auf den Link Add More Items und wählen Sie den Eintrag Select, um den Dialog Choose Item zu öffnen (eine „abgespeckte“ Version des Bedienfelds Explorer). Von hier aus können Sie den Quell-Workspace nach weiteren Elementen durchsuchen. Alternativ können Sie den Eintrag Add manually wählen, um den Dialog Add new items zu öffnen. In diesem Dialog können Sie eine externe Liste der benötigten Elemente einfügen (ein Element pro Zeile). Anschließend können Sie im Quell-Workspace anhand eines ausgewählten Suchkriteriums (GUID, Item ID, Name oder MPN) nach diesen Elementen suchen.

  4. Wenn alles bereit ist, klicken Sie auf die Schaltfläche , um die IntLib zu generieren. Ein temporäres integriertes Bibliothekspaket (*.LibPkg) wird erstellt. Die zugehörigen SchLib-Quelldateien (mit Symbolen, Parametern und Modellverknüpfungen) und PcbLib-Quelldateien (mit Footprint-Modellen) werden generiert und hinzugefügt. Das Paket wird anschließend kompiliert, um die IntLib-Datei zu erzeugen, die im angegebenen Ordner gespeichert wird. Ein Informationsdialog bestätigt die erfolgreiche Generierung der Datei.

    Übertragen Sie den Inhalt des Warenkorbs in den Zielordner, der anschließend die benötigte integrierte Bibliotheksdatei enthält.
    Übertragen Sie den Inhalt des Warenkorbs in den Zielordner, der anschließend die benötigte integrierte Bibliotheksdatei enthält.

Nach der Erstellung wird die IntLib zur Liste der installierten Bibliotheken hinzugefügt – einem Bestandteil von Available File-based Libraries der Software.

Bauteile aus einer integrierten Bibliothek platzieren

Bauteile aus einer integrierten Bibliothek werden über das Components-Panel platziert. Die Platzierung kann im aktiven Schaltplandokument oder im aktiven PCB-Dokument erfolgen. Dafür stehen folgende Möglichkeiten zur Verfügung:

  • Wählen Sie die gewünschte *.IntLib-Datei aus der Dropdown-Liste des Components-Panels aus. Klicken Sie anschließend mit der rechten Maustaste auf das zu platzierende Bauteil und wählen Sie Place <ComponentName> aus dem Kontextmenü. Positionieren Sie das Bauteil im Schaltplandokument und klicken Sie, um es zu platzieren.

  • Ziehen Sie das gewünschte Bauteil per Drag-and-drop auf die Arbeitsfläche.

Bei Verwendung der Schaltfläche Place können mehrere Instanzen eines Bauteils platziert werden, da diese Methode im Platzierungsmodus bleibt, bis Sie mit der rechten Maustaste klicken oder Esc drücken. Die Drag-and-drop-Methode wirkt direkter, erlaubt jedoch jeweils nur eine einzelne Platzierung.

Eine Schaltplanbibliothek und eine integrierte Bibliothek können zwar dasselbe Bauteil enthalten (mit genau denselben Modellverknüpfungen), die aus diesen Bibliotheken platzierten Bauteile verhalten sich beim Abrufen ihrer Modellinformationen jedoch unterschiedlich. Bauteile, die aus integrierten Bibliotheken platziert wurden, suchen ihre Modelle in der ursprünglichen integrierten Bibliothek. Bauteile, die aus Schaltplanbibliotheken platziert wurden, haben dagegen keinen Zugriff auf Modelle, die in integrierten Bibliotheken gespeichert sind.

Eine integrierte Bibliothek ändern

Integrierte Bibliotheken dienen zum Platzieren von Bauteilen und können nicht direkt bearbeitet werden. Um eine integrierte Bibliothek zu ändern, nehmen Sie die Änderungen zunächst in den Quellbibliotheken vor und kompilieren Sie anschließend das Bibliothekspaket erneut. Dadurch wird eine neue integrierte Bibliothek erstellt, die diese Änderungen enthält.

So ändern Sie eine integrierte Bibliothek:

  1. Öffnen Sie das zugehörige Bibliothekspaketprojekt mit den Quellbibliotheken der gewünschten integrierten Bibliothek.
  2. Öffnen Sie die zu ändernden Schaltplan- oder Modellquellbibliotheken.
  3. Nehmen Sie die erforderlichen Änderungen vor, speichern Sie die geänderten Bibliotheken und schließen Sie sie anschließend.
  4. Kompilieren Sie das Bibliothekspaket erneut. Die neu erstellte integrierte Bibliothek ersetzt die ältere, vorhandene Version.

Eine integrierte Bibliothek dekompilieren

Gelegentlich müssen die Quellbibliotheken einer integrierten Bibliothek zur Bearbeitung geöffnet werden, obwohl aus irgendeinem Grund kein Zugriff auf das ursprüngliche Bibliothekspaketprojekt besteht. Hier kommt ein weiterer Vorteil einer einzelnen, portablen integrierten Bibliotheksdatei zum Tragen. Obwohl integrierte Bibliotheken nicht direkt bearbeitet werden können, lassen sie sich wieder in ihre ursprünglichen Symbol- und Modellquellbibliotheken dekompilieren.

Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie die integrierte Bibliothek, die die zu ändernden Quellbibliotheken enthält. Verwenden Sie dazu eine der folgenden Möglichkeiten:
    1. Wählen Sie den Befehl File » Open, navigieren Sie im Dialogfeld Choose Document to Open zur integrierten Bibliothek und klicken Sie anschließend auf Open.
    2. Ziehen Sie die IntLib-Datei aus dem Windows-Explorer per Drag-and-drop in das Altium Designer-Fenster.
  2. Klicken Sie im daraufhin angezeigten Dialogfeld Open Integrated Library auf die Schaltfläche Extract.

Die Schaltplan- und Modellquellbibliotheken werden extrahiert und in einem neuen Ordner gespeichert, der nach dem Dateinamen der integrierten Bibliothek benannt ist und im selben Ordner wie die ursprüngliche integrierte Bibliothek angelegt wird. Anschließend wird ein Bibliothekspaket (<IntegratedLibraryFileName>.LibPkg) erstellt. Die Schaltplan- und PCB-Quellbibliotheken werden dem Projekt hinzugefügt und im Projects-Panel angezeigt. Simulationsmodell- und Teilschaltungsdateien werden dem Projekt nicht automatisch hinzugefügt.


Extrahieren der Quellbibliotheken aus einer integrierten Bibliothek – durch Dekompilieren wird ein Bibliothekspaketprojekt erstellt.

Auf der Registerkarte Search Paths des Dialogfelds Options for Integrated Library (Project » Project Options) wird automatisch ein Pfad zum Ordner mit den Quellbibliotheks- und gegebenenfalls Modelldateien hinzugefügt. Dadurch wird sichergestellt, dass alle Modelle (insbesondere .mdl- und .ckt-Dateien) gefunden werden.
Das Bibliothekspaket wird nicht automatisch gespeichert. Legen Sie fest, wo und unter welchem Namen das Projekt gespeichert werden soll. Standardmäßig wird die Datei im selben Ordner wie die extrahierten Quelldateien gespeichert.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents