Schematic Libraries
Auf einen Blick
- Entdecken Sie verschiedene Möglichkeiten zum Erstellen von Bibliotheken, darunter eine Arbeitsbibliothek oder ein Archiv mit exakt den in einem Projekt verwendeten Bauteilen.
- Lernen Sie, wie Sie Bauteile verwalten und Ports auf Schaltplanblättern in Symbolpins umwandeln.
- Erfahren Sie, wie Sie Footprint-, Simulations- und Signalintegritätsmodelle hinzufügen und organisieren – einschließlich der Zuordnungsinformationen, die für die Verknüpfung mit Symbolen erforderlich sind.
Das reale Bauteil, das auf der Leiterplatte montiert wird, wird bei der Schaltplanerstellung als Schaltplansymbol und beim Leiterplattendesign als PCB-Footprint dargestellt. Bauteile in Altium Designer können:
- in lokalen Bibliotheken erstellt und daraus platziert werden oder
- direkt aus einem verbundenen Workspace platziert werden, auf den das gesamte Entwicklungsteam zugreifen kann.
Symbole können aus dem Schaltplaneditor in eine Schaltplanbibliothek oder zwischen Schaltplanbibliotheken kopiert oder mithilfe von Schematic Symbol Generation Tool oder Zeichenwerkzeugen von Grund auf neu erstellt werden.
Erstellen einer neuen Schaltplanbibliothek
Um eine neue Schaltplanbibliothek zu erstellen, wählen Sie in den Hauptmenüs den Befehl File » New » Library und anschließend im Bereich File des Dialogfelds New Library die Option Schematic Library.
Nach einem Klick auf Create wird ein neues Schaltplanbibliotheksdokument mit dem Namen Schlib1.SchLib erstellt und im Projects-Panel angezeigt. Außerdem wird ein leeres Bauteilblatt mit dem Namen Component_1 angezeigt.
Der Inhalt der Bibliothek wird im SCH Library-Panel angezeigt.
Sie können nun mit den Befehlen des Schaltplansymboleditors Schaltplanbauteile in der neuen Schaltplanbibliothek hinzufügen, entfernen oder bearbeiten.
Erstellen einer Schaltplanbibliothek aus Schaltplandokumenten
Sie können auch eine Schaltplanbibliothek mit allen Bauteilen erstellen, die in den Schaltplan-Quelldokumenten des aktiven Projekts verwendet werden, indem Sie auf Design » Make Schematic Library klicken. Dies ist sehr nützlich, wenn Sie eine exakte Arbeitsbibliothek oder ein Archiv Ihres fertigen Designs erstellen möchten. Wenn Bauteile mit derselben Bibliotheksreferenz, aber unterschiedlicher interner Struktur vorhanden sind, wird das Dialogfeld Component Grouping geöffnet. Darin können Sie die Parameter festlegen, die zur Gruppierung verwendet werden sollen.
Alle Schaltplan-Quelldokumente des aktiven Projekts werden geöffnet, sofern sie nicht bereits geöffnet sind. Ein Bibliotheksdokument (<ProjectName>.SchLib) wird automatisch erstellt und dem Projekt hinzugefügt. Das Dokument wird als aktives Dokument im Schaltplansymboleditor geöffnet. Die Bibliothek enthält alle im Design verwendeten Bauteile. Die erstellte Datei wird im Projects-Panel als Teil des Projekts im Unterordner Libraries\Schematic Library Documents angezeigt. Die Datei wird zunächst nicht auf der Festplatte gespeichert.
Erstellen einer Schaltplanbibliothek aus einem Schaltplanblatt
Aus dem aktiven Schaltplanblatt kann ein neues Schaltplan-Bauteilsymbol erstellt werden, wobei die Ports auf diesem Blatt zu Pins des Bauteils werden. Wählen Sie dazu in den Hauptmenüs den Befehl Design » Create Component From Sheet oder klicken Sie mit der rechten Maustaste in einen freien Bereich der Hauptarbeitsfläche, in dem sich keine Designobjekte befinden, und wählen Sie im Kontextmenü den Befehl Sheet Actions » Create Component From Sheet.
Nach dem Aufrufen des Befehls wird das Dialogfeld Symbol Options angezeigt. Legen Sie in diesem Dialogfeld die Höhe und Breite des Symbols, die Länge seiner Pins sowie den Stil der Pins in Bezug auf die Ports auf dem Quellblatt fest.

Das Dialogfeld Symbol Options
Optionen und Bedienelemente des Dialogfelds Symbol Options
- Auto Width – Aktivieren Sie diese Option, um die Breite des erstellten Bauteils automatisch zu bestimmen. Wenn die Option nicht aktiviert ist, können Sie die Breite durch Eingabe eines Werts in das Textfeld anpassen.
- Auto Height – Aktivieren Sie diese Option, um die Höhe des erstellten Bauteils automatisch zu bestimmen. Wenn die Option nicht aktiviert ist, können Sie die Höhe durch Eingabe eines Werts in das Textfeld anpassen.
- Pin Length – Geben Sie einen Wert für die Pinlänge des erstellten Bauteils ein. Der Standardwert ist 10.
-
Style – Wählen Sie den Portstil aus:
- Input/Output – Eingangsports werden als Pins auf der rechten Seite des Symbols und Ausgangsports als Pins auf der linken Seite des Symbols angezeigt. Beide sind alphabetisch sortiert.
- Relative Schematic Port Layout – Die Ports auf dem Schaltplanblatt werden als Pins am Symbol in derselben Reihenfolge wie im Schaltplan angezeigt.
- Proportional Schematic Port Layout – Die Ports auf dem Schaltplanblatt werden als Pins am Symbol angezeigt. Die Größe des Symbols wird so angepasst, dass sie die Anordnung der Ports im Schaltplan widerspiegelt.
Nach einem Klick auf OK im Dialogfeld wird das neue Bauteil in einem neuen Schaltplanbibliotheksdokument (Schlib1.SchLib) erstellt und nach dem Schaltplandokument benannt. Die Bibliothek wird als aktives Dokument geöffnet und das neue Bauteil darin als aktives Bauteil angezeigt.
Erstellen eines neuen Schaltplanbauteils
In einer Schaltplanbibliothek können beliebig viele Bauteilsymbole erstellt werden. Um ein neues Schaltplanbauteil in einer vorhandenen Bibliothek zu erstellen, wählen Sie Tools » New Component in den Hauptmenüs oder im Kontextmenü der Arbeitsfläche oder klicken Sie auf die Schaltfläche Add unter dem Bereich Design Item ID im SCH Library-Panel.
Nach dem Aufrufen des Befehls wird das Dialogfeld New Component geöffnet. Geben Sie dem Bauteil im Feld Design Item ID des Dialogfelds einen geeigneten Namen.

Das Dialogfeld New Component
Nach einem Klick auf OK wird ein neues Bauteil mit diesem Namen in der Bibliothek erstellt. Ein leeres Bauteilblatt wird geöffnet und auf der Arbeitsfläche aktiviert.
Da eine neue Bibliothek immer ein leeres Bauteil enthält, können Sie auch Component_1 umbenennen, um mit der Erstellung eines Bauteils zu beginnen. Wählen Sie dazu Component_1 aus der Liste Design Item ID im SCH Library-Panel und klicken Sie anschließend auf die Schaltfläche Edit im Panel oder doppelklicken Sie auf Component_1, um das Properties -Panel im Modus Component zu öffnen. Geben Sie im Feld Design Item ID den neuen Bauteilnamen ein, der das Bauteil eindeutig identifiziert, und drücken Sie anschließend Enter.
Um das aktuelle Bauteil aus der aktiven Bibliothek zu entfernen, wählen Sie Tools » Remove Component in den Hauptmenüs oder klicken Sie mit der rechten Maustaste auf die Arbeitsfläche und wählen Sie anschließend Tools » Remove Component im Kontextmenü. Bauteile können auch direkt aus dem SCH Library-Panel gelöscht werden. Wählen Sie die gewünschten Bauteile in der Liste Design Item ID aus und klicken Sie anschließend entweder auf die Schaltfläche Delete unterhalb der Liste oder klicken Sie mit der rechten Maustaste und wählen Sie den Befehl Delete im Kontextmenü. Wenn Sie Bauteile über das Panel löschen, können Sie mehrere Bauteile gleichzeitig löschen.
Hinzufügen von Modellen zum Schaltplanbauteil
Sie können einer Schaltplankomponente beliebig viele PCB-Footprint-Modelle sowie Modelldateien für die Schaltungssimulation und die Signalintegritätsanalyse hinzufügen. Wenn eine Komponente mehrere Modelle besitzt (beispielsweise mehrere Footprints), können Sie beim Platzieren der Komponente in einem Schaltplan das passende Modell im Properties-Panel auswählen. Sie können die Modelle selbst erstellen oder die Modelldatei eines Herstellers aus dem Internet herunterladen. PCB-Bibliotheken können beliebig viele PCB-Footprints enthalten.
Sie können der aktuellen Komponente auf folgende Arten Modelle hinzufügen:
-
Über den Bereich Model unten im Designbereich (klicken Sie auf die nach unten gerichteten Pfeile bzw. das Winkelzeichen unten rechts im Designbereich, wie in der folgenden Abbildung gezeigt).

Klicken Sie auf das hervorgehobene Winkelzeichen, um auf den Bereich Model des Designbereichs zuzugreifen. -
Über das Dropdown-Menü Add im Bereich Parameters des Properties-Panels im Modus Component und anschließendes Auswählen des Modells.
-
Im Dialogfeld Model Manager des Schaltplansymbol-Editors (Tools » Model Manager, oder klicken Sie mit der rechten Maustaste auf eine Komponente im SCH Library-Panel und wählen Sie anschließend Model Manager aus dem Kontextmenü) können Sie die Komponentenmodelle aller Komponenten in der aktiven Schaltplanbibliothek anzeigen und organisieren. Beispielsweise können Sie mehreren ausgewählten Komponenten dasselbe Modell hinzufügen.
Optionen und Bedienelemente des Dialogfelds Model Manager
-
Mask – geben Sie in dieses Feld einen Komponentennamen ein, um die Inhalte zu filtern. Verwenden Sie „
*“ als Platzhalterzeichen. - Component list – listet alle vorhandenen Komponenten der aktuellen Schaltplanbibliothek und deren Beschreibungen auf.
- Model list – listet alle Modelle auf, die zur ausgewählten Komponente gehören. Das Kontextmenü dieses Bereichs enthält Befehle, mit denen Sie ein Modell Add, Copy, Paste, Remove oder Edit können.
-
Add – klicken Sie hier, um ein Dropdown-Menü mit den unten aufgeführten Modelloptionen zu öffnen. Für jede Option wird ein zugehöriges Dialogfeld geöffnet, in dem Sie das gewünschte Modell bei Bedarf anpassen und hinzufügen können.
-
Footprint– physisches Layout, das auf der Leiterplatte erforderlich ist, um eine Komponente oder ein mechanisches Anbauteil zu montieren. -
Pin Info– fügen Sie eine Pin-Info-Datei hinzu, die als FPGA/MC-Pin-Beschreibung für FPGA-Werkzeuge von Drittanbietern oder für andere Komponententypen verwendet werden kann. -
PCB3D– fügen Sie der Komponente ein 3D-Modell hinzu. -
Simulation– fügen Sie der Komponente ein SPICE-Modell hinzu, wenn Sie eine Schaltungssimulation durchführen möchten. -
Ibis Model– fügen Sie ein IBIS-Modell hinzu, um die Modellierung von IC-Pins bei Signalintegritätsanalysen zu verbessern. -
Signal Integrity– fügen Sie ein Signalintegritätsmodell hinzu, um Signalintegritätsanalysen zu konfigurieren und zu steuern.
-
- Copy – klicken Sie hier, um das gewünschte Modell aus der Liste zu kopieren.
- Paste – klicken Sie hier, um ein Modell in die Liste einzufügen. Das neue Modell erscheint am Ende der Liste.
- Remove – klicken Sie hier, um die ausgewählten Footprints zu entfernen.
- Edit – klicken Sie hier, um das entsprechende Dialogfeld zu öffnen, in dem Sie die Modellzuordnung bearbeiten können.
- Refresh Preview – klicken Sie hier, um die Modellvorschau zu aktualisieren. Klicken Sie auf 2D/3D, um zwischen der 2D- und der 3D-Vorschau umzuschalten.
-
Mask – geben Sie in dieses Feld einen Komponentennamen ein, um die Inhalte zu filtern. Verwenden Sie „
Zuordnen des Modells zum Symbol
Beim Verknüpfen des Modells müssen Informationen über die Komponente aus dem Schaltplan dem Zielmodell zugeordnet werden.
Die domänenspezifischen Informationen befinden sich in Modelldateien mit einem vordefinierten Format, beispielsweise IBIS-, MDL- und CKT-Dateien. Damit das System auf diese domänenspezifischen Informationen zugreifen kann, sind weitere Informationen erforderlich, etwa die Pin-Zuordnung und die Netzlisteninformationen zwischen dem Schaltplansymbol und dem domänenspezifischen Modell. Diese Informationen werden in einem domänenspezifischen Modelleditor definiert, der sich beim Hinzufügen oder Bearbeiten eines Modells öffnet. Neben dem Verweis auf die Modelldatei enthält er auch alle für diesen Modelltyp erforderlichen Pin-Zuordnungen und Netzlisteninformationen.
Suchorte für Modelldateien
Wenn Sie einer Komponente im Schaltplansymbol-Editor ein Modell hinzufügen, wird das Modell verknüpft; die Modelldaten werden nicht in die Schaltplankomponente kopiert oder darin gespeichert. Das bedeutet, dass die verknüpften Modelle sowohl beim Erstellen der Bibliothek als auch beim Platzieren der Komponente auf einem Schaltplanblatt verfügbar sein müssen. Wenn Sie im Bibliothekseditor arbeiten, wird die Verknüpfung von der Komponente zu den Modellinformationen anhand der folgenden gültigen Suchorte aufgelöst:
- Zuerst werden die Bibliotheken durchsucht, die im aktuellen Bibliothekspaketprojekt enthalten sind.
- Anschließend werden die PCB-Bibliotheken (keine integrierten Bibliotheken) durchsucht, die in der aktuellen Liste Installed Libraries verfügbar sind. Hinweis: Die Reihenfolge der Bibliotheken in der Liste kann geändert werden.
- Abschließend werden alle Modellbibliotheken durchsucht, die sich in den Suchpfaden des Projekts befinden. Suchpfade werden auf der Registerkarte Search Paths des Dialogfelds Project Options (Project » Project Options) definiert. Hinweis: Bibliotheken im Suchpfad können nicht manuell nach einem Modell durchsucht werden; der Compiler berücksichtigt sie jedoch bei der Modellsuche.
Weitere Informationen dazu, wie im Schaltplansymbol-Editor und im Schaltplaneditor nach Modellen gesucht wird, finden Sie im Abschnitt Verwalten verfügbarer datenbank- und dateibasierter Bibliotheken auf der Seite Suchen nach Komponenten in dateibasierten und Datenbankbibliotheken.
Hinzufügen eines Footprints zur Schaltplankomponente
Um der aktuellen Schaltplankomponente einen Footprint hinzuzufügen, wählen Sie Footprint als Option zum Hinzufügen eines Modells aus, wie oben beschrieben. Das Dialogfeld PCB Model wird geöffnet.
Optionen und Bedienelemente des Dialogfelds PCB Model
Footprint-Modell
- Name – zeigt den Namen des Footprints an.
- Browse – klicken Sie hier, um das Dialogfeld Browse Libraries zu öffnen und nach dem gewünschten Footprint zu suchen.
- Pin Map – klicken Sie hier, um das Dialogfeld Model Map zu öffnen und die Pins des Schaltplansymbols den Pins des PCB-Footprints zuzuordnen.
- Description - Geben Sie eine aussagekräftige Beschreibung für den Footprint ein.
PCB-Bibliothek
- Any – Aktivieren Sie diese Option, um in allen aktuell verfügbaren Bibliotheken nach dem gewünschten Footprint zu suchen.
- Library name – Aktivieren Sie diese Option, um in der angegebenen Bibliothek nach dem gewünschten Footprint zu suchen. Geben Sie den Bibliotheksnamen direkt in das Textfeld ein.
- Library path – Aktivieren Sie diese Option, um in der angegebenen Bibliothek am angegebenen Speicherort nach den gewünschten Footprints zu suchen. Klicken Sie auf die Schaltfläche Choose, um einen Pfad auszuwählen.
- Use footprint from component library – Diese Option wird aktiviert, wenn das Bauteil aus einer kompilierten Bibliothek, beispielsweise einer integrierten Bibliothek, oder von einem Server platziert wird. Bei Bedarf kann sie für ein platziertes Bauteil überschrieben werden, sodass eine andere PCB-Quellbibliothek ausgewählt werden kann.
Ausgewählter Footprint
Dieser Bereich zeigt eine Vorschau des gewünschten Footprints an. Klicken Sie auf das Symbol unten links in der Vorschau, um zwischen dem 2D- und dem 3D-Modus zu wechseln. Der Anzeigebereich bleibt leer, wenn der Footprint in der angegebenen PCB-Bibliothek nicht gefunden werden kann.
Oben im Dialogfeld PCB Model befindet sich das Feld Name, das den Namen des Footprints enthalten muss. Sie können den Namen direkt eingeben oder die Schaltfläche Browse verwenden, um ihn mithilfe des Dialogfelds Bibliotheken durchsuchen in den verfügbaren Footprint-Bibliotheken zu finden. Die Dropdown-Liste Libraries bietet Zugriff auf eine Liste der verfügbaren Bibliotheken. Klicken Sie auf die Schaltfläche
, um das Dialogfeld Verfügbare dateibasierte Bibliotheken zu öffnen, in dem Sie Bibliotheken hinzufügen oder entfernen können. Wenn der gewünschte Footprint in keiner der aktuellen Bibliotheken verfügbar ist, müssen Sie über die Schaltfläche Find das Dialogfeld Suche in dateibasierten Bibliotheken öffnen und dort nach ihm suchen.
Unten im Dialogfeld PCB Model wird eine Zeichenfolge angezeigt, die angibt, wo das Modell gefunden wurde.
Ob die Software das Modell finden kann, hängt von der Einstellung ab, die festlegt, wo nach Modellen gesucht werden darf. Diese Einstellung befindet sich direkt unter dem Modellnamen. Die Optionen reichen von Any, womit alle verfügbaren Bibliotheken nach diesem Modell durchsucht werden, bis zu Integrated Library oder Server, womit das Modell nur aus der angegebenen integrierten Bibliothek bzw. dem angegebenen Workspace verwendet werden kann.
Das Dialogfeld PCB Model enthält folgende Optionen:
Um die Pin-Zuordnung für einen verknüpften Footprint zu konfigurieren, klicken Sie im Dialogfeld PCB Model auf Pin Map, um das Dialogfeld Model Map zu öffnen und die erforderlichen Änderungen an den Pin-Pad-Paaren vorzunehmen. Beachten Sie, dass Sie die Eigenschaft Designator des Schaltplansymbol-Pins dem entsprechenden Pin-Bezeichner des Modells zuordnen. Bei einem PCB-Footprint ist dies die Eigenschaft Designator des Pads.
- Component Pin Designator Spalte – Listet alle Pins des Schaltplansymbols auf; dieses Feld kann nicht bearbeitet werden.
- Model Pin Designator Spalte – Listet die Pin-Nummern des Modells auf. In diesem Beispiel werden die Pads im zugewiesenen PCB-Footprint angezeigt. Bearbeiten Sie diese Felder so, dass jedes PCB-Pad dem entsprechenden Pin des Schaltplansymbols zugeordnet ist.
Hinzufügen eines Simulationsmodells zum Schaltplanbauteil
Wenn Sie ein neues Bauteil erstellen, beziehen Sie das SPICE-Modell üblicherweise von der Website des Bauteilherstellers. Um dem aktuellen Schaltplanbauteil ein Simulationsmodell hinzuzufügen, wählen Sie Simulation, wenn Sie eine Option zum Hinzufügen eines Modells auswählen, wie oben beschrieben. Das Dialogfeld Simulationsmodell wird geöffnet. In diesem Dialogfeld wählen Sie das Modell aus und ordnen die Pins des Schaltplansymbols den Modell-Pins zu.
Sie können auch SPICE Model Wizard (Tools » XSpice Model Wizard) verwenden, um bestimmte SPICE-Modelltypen zu erstellen und dem Bauteil hinzuzufügen: Weitere Informationen.
Hinzufügen eines Modells während der Schaltplanerstellung
Während der Schaltplanerstellung besteht das Design aus einer Sammlung logisch miteinander verbundener Bauteile. Um das Design zu testen oder umzusetzen, beispielsweise für die Schaltungssimulation, das PCB-Layout oder die Signalintegritätsanalyse, muss es in eine andere Designdomäne übertragen werden. Dazu muss für jedes Bauteil ein geeignetes Modell für die Zieldomäne vorhanden sein.
-
Footprints werden mit dem Schaltplanbauteil verknüpft, indem sie im Bereich Parameter des Panels Properties hinzugefügt werden. Klicken Sie auf die Dropdown-Liste Add und wählen Sie anschließend Footprint, um das Dialogfeld PCB Model zum Konfigurieren des Footprints zu öffnen.
-
Modelle werden mit dem Schaltplanbauteil verknüpft, indem sie im Bereich Parameter des Panels Properties hinzugefügt werden. Klicken Sie auf die Dropdown-Liste Add und wählen Sie anschließend Simulation oder Ibis Model , um das jeweilige Dialogfeld zu öffnen.
Ergänzen von Bauteildetails mithilfe von Parametern
Mit Bauteilparametern lassen sich zusätzliche Informationen zum Bauteil definieren. Parameter ermöglichen es Ihnen, zusätzliche Textinformationen zum Bauteil festzulegen. Dazu gehören elektrische Spezifikationen (z. B. Leistung oder Toleranz), Einkaufs- oder Lagerbestandsdaten, Hinweise für Entwickler oder Verweise auf Bauteildatenblätter – grundsätzlich alles, was Sie benötigen: Daten, die Ihr Unternehmen in der Stückliste benötigt, Herstellerdaten, ein Verweis auf das Bauteildatenblatt oder Designvorgaben wie Designregeln oder die Zuordnung zu einer PCB-Klasse usw.
Parameter können während der Bauteilerstellung im Schaltplanbibliothekseditor über das Panel Properties definiert werden.
Hinzufügen von Parametern zu einem Bauteil
Für ein einzelnes Bauteil werden Parameter im Bereich Parameters des Panels Properties im Modus Component hinzugefügt. Wie bereits erwähnt, ist dies in der Bibliothek oder nach dem Platzieren des Bauteils auf dem Schaltplanblatt möglich.
Gehen Sie wie folgt vor, um einem Schaltplanbauteil einen Parameter hinzuzufügen:
- Doppelklicken Sie im Panel SCH Library auf den Bauteilnamen, um das Panel „Properties“ im Modus „Component“ zu öffnen.
- Wählen Sie im Bereich Parameters aus der Dropdown-Liste Add die Option Parameter.
- Geben Sie den gewünschten Namen des Parameters und einen Wert ein.
- Stellen Sie sicher, dass die Sichtbarkeitsoption des Parameters aktiviert ist , wenn Name und Wert beim Platzieren des Bauteils auf einem Schaltplanblatt angezeigt werden sollen.
-
Klicken Sie auf Font Link und Other am unteren Rand des Bereichs Parameters, um auf zusätzliche Optionen zur Konfiguration von Parametern zuzugreifen.
Parameter zu mehreren Bauteilen hinzufügen
Parameter sind ein wesentlicher Bestandteil jedes Bauteils, und häufig werden viele Parameter für mehrere Bauteile verwendet. Sie können Parameter nicht nur jedem Bauteil einzeln hinzufügen, sondern mit dem Befehl Parameter Manager (Tools » Parameter Manager) auch mehreren Bauteilen gleichzeitig. Neben dem Hinzufügen und Entfernen von Parametern lassen sich auch deren Werte für mehrere Bauteile gleichzeitig bearbeiten.

Im Dialog Parameter Table Editor können sämtliche Parameter aller Bauteile bearbeitet werden.
Hinweise zur Bearbeitung mehrerer Parameter:
- Parameter lassen sich mit demselben Verfahren sowohl für die Bauteile einer Bibliothek als auch für Bauteile in einem Schaltplandesign bearbeiten. Wählen Sie Tools » Parameter Manager im Schaltplan- oder Schaltplanbibliothekseditor, um den Vorgang zu starten.
- Da Parameter zu verschiedenen Objekten hinzugefügt werden können, wählen Sie zunächst im Dialog Parameter Editor Options aus, für welche Objekttypen die Parameter bearbeitet werden sollen.
- Die Bearbeitung der Parameter erfolgt im Dialog Parameter Table Editor. Dieser Dialog lässt sich auf unterschiedliche Weise aufrufen, sodass sein Titel variieren kann. Die Arbeitsweise im Dialog ist unabhängig davon, wie er aufgerufen wurde: Wählen Sie die gewünschten Zellen mit den üblichen Windows-Tastenkombinationen aus, klicken Sie dann mit der rechten Maustaste und wählen Sie eine Bearbeitungsaktion.
- Änderungen werden nicht sofort ausgeführt; sie werden über einen Engineering Change Order (ECO) umgesetzt.
- Jede zu ändernde Zelle ist mit einem kleinen farbigen Symbol gekennzeichnet. Eine Beschreibung der einzelnen Symbole finden Sie auf der Seite zum Dialog Parameter Table Editor.
Einen Parameter dem Kommentarfeld des Bauteils zuordnen
Die standardmäßig im Schaltplan angezeigten Bauteilparameter sind Bezeichner und Kommentar. Wenn das Design vom Schaltplaneditor in den PCB-Editor übertragen wird, sind die Zeichenfolgen für Bezeichner und Kommentar ebenfalls die Standardzeichenfolgen, die sich einfach auf der Leiterplatte anzeigen lassen.
Damit Sie den Wert eines beliebigen Bauteilparameters im Schaltplan und auf der Leiterplatte anzeigen können, beispielsweise den Wert eines Parameters namens Capacitance, können Sie jeden Bauteilparameter dem Feld Comment des Bauteils zuordnen. Dazu wird eine als Zeichenfolgenindirektion bezeichnete Technik verwendet.
Geben Sie hierzu den Parameternamen in der Form =ParameterName ein. Um beispielsweise den Wert des Bauteilparameters Capacitance dem Feld Comment des Bauteils zuzuordnen, geben Sie die Zeichenfolge =Capacitance in das Feld Comment des Panels Properties ein, wie unten gezeigt. Eine mit der Syntax '=ParameterName' definierte Zeichenfolge wird als special string bezeichnet.
Spezialzeichenfolgen werden für die Bildschirmanzeige automatisch umgewandelt. Wenn ein als Spezialzeichenfolge zugeordneter Parameter keinen Wert hat, wird stattdessen der Parametername in Grau angezeigt, sofern die Option Display Names of Special Strings that have No Value Defined auf der Seite Schaltplan – Grafische Bearbeitung des Dialogs Preferences aktiviert ist. Ist diese Option deaktiviert, wird nichts angezeigt.

Verwenden Sie Spezialzeichenfolgen, um einen beliebigen Parameterwert dem Comment des Bauteils zuzuordnen.
Anklickbare Links zu Referenzinformationen definieren
Im Bereich Parameter des Panels Properties im Modus Component können Sie einen Link hinzufügen, indem Sie auf das Dropdown-Menü Add klicken und anschließend Link auswählen. Mit dieser Funktion können Sie beispielsweise Links zu einem Datenblatt oder einer Herstellerwebsite einfügen. Für ein Bauteil können beliebig viele Links definiert werden.
Ein Link sollte wie folgt konfiguriert werden:
- Name – definiert den Eintrag, der im Menü angezeigt wird:
-
Url – definiert das Zieldokument. Die folgenden Beispiele sind gültige Einträge:
-
C:\Design_Projects\Schematics\Modifications.txt -
C:\Design_Projects\Schematics\MyDataSheet.pdf -
https://www.altium.com -
www.altium.com/documentation
-
Die im Panel angezeigten Links sind aktiv. Wenn Sie auf den Linktext klicken, wird die URL daher in Ihrem bevorzugten Browser geöffnet. Um einen vorhandenen Link zu bearbeiten, klicken Sie auf eine Stelle in der Zelle außerhalb des Linktexts und anschließend auf die Schaltfläche zum Bearbeiten.
Auf Links können Sie über das Kontextmenü zugreifen, indem Sie mit der rechten Maustaste auf das platzierte Schaltplanbauteil klicken. Sie können zwar beliebig viele benannte Links definieren, im per Rechtsklick geöffneten Kontextmenü References des Schaltplaneditors stehen jedoch nur die ersten 9 zur Verfügung. Weitere benannte Links werden im Menü Reference des Schaltplaneditors nicht angezeigt, sind jedoch in einer generierten PDF-Datei enthalten. Dort stehen sie als aktive Links zur Verfügung, wenn Sie im PDF-Dokument auf das Bauteil klicken (siehe unten).
Klicken Sie mit der rechten Maustaste auf ein Bauteil auf dem Blatt, um auf die Bauteillinks zuzugreifen.
Nach dem Aufrufen des Befehls wird das angegebene Zieldokument geöffnet. Eine webbasierte URL-Zielseite wird direkt geöffnet, sofern sie verfügbar ist. Bei einem PDF- oder Textdokument wird wie folgt nach dem Dokument gesucht:
-
Wenn ein Pfad angegeben ist, wird zuerst an diesem Speicherort gesucht.
-
Wenn das Dokument an diesem Speicherort nicht gefunden wird oder kein Pfad angegeben ist, wird der Ordner
\Helpder Altium Designer-Installation durchsucht.
Bauteil prüfen und Berichte erstellen
Um zu prüfen, ob die neuen Bauteile korrekt erstellt wurden, können verschiedene Berichte generiert werden. Stellen Sie sicher, dass die Bibliotheksdatei gespeichert ist, bevor Sie die Berichte generieren.
Bibliotheksliste
Die Library List listet jedes Bauteil und die zugehörigen Details aus dem aktiven Bibliotheksdokument auf.
- Wählen Sie Reports » Library List.
-
Eine ASCII-Textdatei (<LibraryName>.rep) wird generiert und als aktives Dokument geöffnet. Die Datei enthält die Gesamtzahl der Bauteile in der Bibliothek und listet für jedes Bauteil den Bauteilnamen und, sofern vorhanden, eine Beschreibung auf.
Eine zweite Datei wird ebenfalls erstellt und geöffnet (<LibraryName>.csv), auf die in der Datei .rep verwiesen wird. Dies ist eine CSV-Datei mit kommagetrennten Werten. Sie enthält detailliertere Informationen zu jedem Bauteil in der Bibliothek, die aus den Eigenschaften des jeweiligen Bauteils extrahiert werden.
Bibliotheksbericht
Sie können aus dem aktiven Bibliotheksdokument einen Bericht mit Informationen zu den in dieser Bibliothek gespeicherten Bauteilen generieren. Der Bericht kann so konfiguriert werden, dass er Informationen zu Parametern, Pins und Modellen sowie eine Vorschau der Bauteile und Modelle enthält (in Farbe oder Schwarz-Weiß). Der Bericht kann als Microsoft Word-Dokument (*.doc) oder als Standard-HTML-Dokument (*.html) generiert werden.
-
Wählen Sie Reports » Library Report, um das Dialogfeld Library Report Settings zu öffnen. In diesem Dialogfeld konfigurieren Sie den Inhalt und den Stil des Berichts sowie den Speicherort und den Namen, unter dem er generiert werden soll. Standardmäßig erhält der Bericht den Namen der Schaltplanbibliothek und wird am selben Ort gespeichert.
Optionen und Bedienelemente des Dialogfelds Library Report Settings
Ausgabedateiname
- Output File Name – zeigt den vollständigen Namen der Ausgabedatei einschließlich Pfad an. Verwenden Sie das Ordnersymbol zum Durchsuchen, um einen anderen Speicherort und Namen zu suchen und auszuwählen.
- Document style – Die Dateierweiterung lautet .doc, und der Bibliotheksbericht wird im Word-Dokumentformat generiert.
- Browser style – Die Dateierweiterung lautet .html, und eine Webseite wird in einem Internetbrowser generiert. Sie können den vollständigen Namen der Ausgabedatei bei Bedarf bearbeiten.
- Open generated report – Aktivieren Sie diese Option, um den generierten Bericht in MS Word oder einem Internetbrowser zu öffnen.
- Add generated report to current project – Aktivieren Sie diese Option, um den generierten Bericht dem aktuellen Projekt hinzuzufügen.
In Bericht aufnehmen
- Component's Parameters – Aktivieren Sie diese Option, um die Parameter des Bauteils in den Bericht aufzunehmen.
- Component's Pins – Aktivieren Sie diese Option, um die Pins des Bauteils in den Bericht aufzunehmen.
- Component's Models – Aktivieren Sie diese Option, um die Modelle des Bauteils in den Bericht aufzunehmen.
Vorschau zeichnen für
- Components – Aktivieren Sie diese Option, um eine Vorschau der Bauteile im Bericht zu zeichnen.
- Models – Aktivieren Sie diese Option, um eine Vorschau der Modelle im Bericht zu zeichnen.
Einstellungen
- Use Color – Aktivieren Sie diese Option, damit der Bibliotheksbericht sowohl in Word- als auch in Webdokumenten farbige Elemente enthalten kann.
-
Konfigurieren Sie die Berichtseinstellungen und klicken Sie anschließend auf OK. Wenn Sie festgelegt haben, dass der Bericht nach der Generierung geöffnet werden soll, geschieht dies, sofern Microsoft Word (bei einem Bericht im DOC-Format) bzw. Ihr Standardbrowser (bei einem Bericht im HTML-Format) verfügbar ist.
Wenn Sie festgelegt haben, dass der generierte Bericht anschließend dem Projekt hinzugefügt werden soll, wird er im Panel Projects unter dem Unterordner Generated\Documents (bei einem Bericht im HTML-Format) bzw. dem Unterordner Generated\Text Documents (bei einem Bericht im DOC-Format) angezeigt.
Bauteilregelprüfung
Der Component Rule Checker prüft auf Fehler wie Duplikate und fehlende Pins.
-
Wählen Sie Reports » Component Rule Check (Tastenkürzel R, R), um das Dialogfeld Library Component Rule Check zu öffnen. Legen Sie die zu prüfenden Attribute fest und klicken Sie anschließend auf OK.
Optionen und Bedienelemente des Dialogfelds Library Component Rule Check
Duplikate
- Component Names – Aktivieren Sie diese Option, um auf doppelte Bauteilnamen zu prüfen.
- Pins – Aktivieren Sie diese Option, um auf doppelte Pins zu prüfen.
Fehlende Angaben
- Description – Aktivieren Sie diese Option, um auf fehlende Beschreibungen zu prüfen.
- Footprint – Aktivieren Sie diese Option, um auf fehlende Footprint-Namen zu prüfen.
- Default Designator – Aktivieren Sie diese Option, um auf fehlende Standard-Bauteilkennzeichnungen zu prüfen.
- Pin Name – Aktivieren Sie diese Option, um auf fehlende Pin-Namen zu prüfen.
- Pin Number – Aktivieren Sie diese Option, um auf fehlende Pin-Nummern zu prüfen.
- Missing Pins In Sequence – Aktivieren Sie diese Option, um auf fehlende Pins in einer Sequenz zu prüfen.
-
Im Arbeitsbereich wird ein Bericht mit dem Titel <
libraryname.ERR> angezeigt, der alle Bauteile auflistet, die gegen die geprüften Regeln verstoßen. - Nehmen Sie alle erforderlichen Anpassungen an der Bibliothek vor und generieren Sie den Bericht anschließend erneut.
- Speichern Sie die Schaltplanbibliothek. Schließen Sie den Bericht, um zum Arbeitsbereich des Schaltplaneditors zurückzukehren.
Bauteile aus anderen Quellen kopieren
Bauteile aus anderen Bibliotheken verschieben und kopieren
Sie können auch Bauteile aus anderen geöffneten Schaltplanbibliotheken in Ihre Schaltplanbibliothek kopieren und deren Eigenschaften anschließend nach Bedarf bearbeiten. Wenn das Bauteil Teil einer integrierten Bibliothek ist, müssen Sie die Datei .IntLib öffnen und Yes wählen, um die Quellbibliotheken zu extrahieren. Öffnen Sie anschließend die generierte Quellbibliothek (*.SchLib) über das Panel Projects .
-
Wählen Sie das Bauteil, das Sie verschieben oder kopieren möchten, in der Liste Design Item ID des Panels SCH Library aus, damit es im Entwurfsfenster angezeigt wird.
-
Wählen Sie Tools » Move Component oder Tools » Copy Component, um das Dialogfeld Destination Library zu öffnen, in dem alle derzeit geöffneten Schaltplanbibliotheksdokumente aufgelistet sind. Im Dialogfeld werden alle geöffneten Bibliotheken aufgeführt, unabhängig davon, ob es sich um freie Dokumente oder um Bestandteile des aktuellen oder eines anderen geöffneten Projekts handelt.
-
Wählen Sie das Dokument aus, in das Sie das Bauteil verschieben/kopieren möchten, und klicken Sie dann auf OK. Das Bauteil oder eine Kopie davon wird in der Zielbibliothek abgelegt, wo Sie es bei Bedarf bearbeiten können.
Kopieren von Bauteilen aus Schaltplänen
Sie können Bauteile auch aus Schaltplanblättern in Ihre Schaltplanbibliothek kopieren und anschließend deren Eigenschaften nach Bedarf bearbeiten. Wählen Sie auf dem Schaltplanblatt das Bauteil aus, das Sie kopieren möchten, und kopieren Sie es mit dem Befehl Copy aus dem Kontextmenü des ausgewählten Bauteils (Tastenkürzel: Ctrl+C). Öffnen Sie anschließend die Ziel-Schaltplanbibliothek, klicken Sie mit der rechten Maustaste in den Bauteillistenbereich des Panels SCH Library und wählen Sie Paste (Tastenkürzel: Ctrl+V).
Beachten Sie, dass eine Verknüpfung zum Quell-Workspace erhalten bleibt, wenn das Bauteil aus Ihrem verbundenen Workspace oder aus dem Panel Manufacturer Part Search auf einem Schaltplanblatt platziert wurde. Diese Bauteile sind durch das Symbol
im Panel SCH Library gekennzeichnet. Sie können die Workspace-Verknüpfungen für alle Bauteile in der geöffneten Bibliothek entfernen, indem Sie den Befehl Tools » Clear Server Links in den Hauptmenüs auswählen. Nach dem Aufrufen des Befehls wird das Dialogfeld Confirm Clear Vault Links geöffnet. Klicken Sie auf Yes , um die im Dialogfeld angegebenen Workspace-Verknüpfungen zu entfernen und die Bibliothek zu speichern. Klicken Sie auf No , um das Dialogfeld ohne Änderungen zu schließen.

Das Dialogfeld Confirm Clear Vault Links
Kopieren mehrerer Bauteile
Sie können auch das Panel SCH Library verwenden, um mehrere Bauteile zu kopieren. Wählen Sie die Bauteile im Panel mit den üblichen Funktionen Ctrl+Click oder Shift+Click aus. Klicken Sie anschließend mit der rechten Maustaste auf eines der ausgewählten Bauteile und wählen Sie Copy aus dem Kontextmenü. Danach können Sie mit der rechten Maustaste in die Liste klicken und:
- Das Bauteil bzw. die Bauteile wieder in dieselbe Bibliothek einfügen.
- Das Bauteil bzw. die Bauteile in eine andere geöffnete Bibliothek einfügen.
- Mit derselben Vorgehensweise Bauteile aus einem Schaltplan kopieren und in eine geöffnete Bibliothek einfügen.
Verschieben eines Designs an einen anderen Speicherort
Wenn ein Bauteil aus einer Bibliothek in einem Design platziert wird, wird es in der Designdatei zwischengespeichert. Dadurch kann das Dokument weiterhin an jedem beliebigen Speicherort geöffnet werden, ohne dass die Quellbibliotheken vorhanden oder geladen sein müssen. Dies ist beim Verschieben eines Designs an einen anderen Speicherort hilfreich, da die Bibliotheken nicht ebenfalls verschoben werden müssen. Beachten Sie, dass auch der Name der ursprünglichen Quellbibliothek und die Modellnamen in den Eigenschaften des platzierten Bauteils gespeichert werden.
Panel SCH Library
Im Panel SCH Library können Sie die im aktiven Schaltplanbibliotheksdokument gespeicherten Bauteile anzeigen und bearbeiten. Das Panel bietet außerdem die Möglichkeit, Änderungen an Bauteilen in der Bibliothek direkt an das Schaltplandokument zu übertragen und Modellverknüpfungen für ein Bauteil festzulegen.

Durchsuchen, betrachten und bearbeiten Sie Schaltplanbibliotheksbauteile und deren Pins interaktiv.
Inhalt und Verwendung des Panels SCH Library
Durchsuchen der Bibliothek
Wenn Sie auf einen Bauteileintrag in der Liste klicken, wird dieser zum aktiven Bauteil im Design-Editor-Fenster. Im Design-Editor-Fenster können Sie das Symbol des Bauteils ändern und nach Bedarf verknüpfte Modelle für das Bauteil hinzufügen, bearbeiten oder entfernen. Wenn Sie ein Pin Objekt im Panel auswählen, wird das entsprechende grafische Objekt im Arbeitsbereich des Editors hervorgehoben und vergrößert dargestellt. Auf diese Weise bietet das Panel SCH Library eine schnelle und einfache Möglichkeit, Schaltplanbibliotheksbauteile und Pins zu durchsuchen, anzuzeigen und darauf zuzugreifen.
Filtern von Inhalten
Der Inhalt der Liste Components kann gefiltert werden, sodass Sie ein bestimmtes Bauteil in der Bibliothek schnell finden können. Dies ist besonders hilfreich, wenn die Bibliothek viele Einträge enthält. Zum Filtern können Sie eine der in den folgenden Abschnitten beschriebenen Methoden verwenden.
Indirektes Filtern
Bei dieser Filtermethode wird das Suchfeld oben im Panel verwendet, um den Inhalt der Liste zu filtern. Die Namensmaske wird anhand der Eingabe im Feld angewendet. Es werden nur noch die Bauteile in der Liste angezeigt, die der Eingabe entsprechen.
Die Filterfunktion unterscheidet nicht zwischen Groß- und Kleinschreibung und unterstützt eine Filterung während der Eingabe. Das bedeutet, dass der Inhalt der Liste Components bereits während des Tippens gefiltert wird.
Verwenden Sie den Platzhalteroperator * für eine gezieltere Filterung. Wenn Sie beispielsweise MN* eingeben, werden nur Bauteil-Footprints angezeigt, deren Namen mit MN beginnen. Wenn Sie hingegen, wie in der folgenden Abbildung, *r34 eingeben, werden nur Bauteil-Footprints angezeigt, deren Namen R34 enthalten.
Direktes Filtern
Diese Methode ist in allen Bereichen des Panels verfügbar und ermöglicht es Ihnen, durch direkte Eingabe im Listenbereich schnell zu einem Eintrag zu springen. Es wird keine Maske angewendet, sodass der gesamte Inhalt der Liste jederzeit sichtbar bleibt.
Um mit dieser Funktion schnell einen Bauteil-Footprint zu finden, klicken Sie in den Abschnitt Components des Panels und geben Sie dann den ersten Buchstaben des Bauteil-Footprints ein, zu dem Sie springen möchten. Wenn Sie beispielsweise schnell zu Bauteileinträgen springen möchten, die mit dem Buchstaben R beginnen, drücken Sie R auf der Tastatur. Das erste Bauteil in der Liste, das mit R beginnt, wird aktiviert.
Wenn mehrere Design Item IDs mit demselben Buchstaben beginnen, insbesondere bei einer sehr großen Bibliothek, geben Sie weitere Buchstaben ein, um den gewünschten Eintrag gezielt zu finden. Geben Sie beispielsweise res ein, um den ersten Eintrag der RES Reihe in der Liste hervorzuheben.
Kombiniertes Filtern
In manchen Situationen kann es hilfreich sein, indirektes und direktes Filtern gleichzeitig zu verwenden. Wenn Sie beispielsweise wissen, dass das gesuchte Bauteil eine Untertypvariante von BRMZ und das Präfix AD74 hat, können Sie diese Informationen für die indirekte Filterung (Maske) bzw. die direkte Eingabe verwenden.
Panelbereiche
Bauteile
Wenn Sie auf einen Eintrag in der Components Liste klicken, wird dieser zum aktiven Bauteil im Editorfenster und für die vier Schaltflächen direkt unterhalb der Liste. Diese Schaltflächen bieten die folgenden Befehle für die Bauteilliste:
-
Place – Klicken Sie hier, um das aktive Bauteil in einem Schaltplandokument zu platzieren. Welches Schaltplandokument dabei verwendet wird, hängt davon ab, ob derzeit Schaltplandokumente geöffnet sind.
- Wenn keine Schaltplandokumente geöffnet sind, wird durch Klicken auf die Schaltfläche ein neues Schaltplandokument erstellt, das zum aktiven Dokument im Editorfenster wird. Das aktive Bibliotheksbauteil hängt am Cursor und ist zur Platzierung bereit.
- Wenn bereits ein oder mehrere Schaltplandokumente geöffnet sind, wird das zuletzt aktive Dokument (unabhängig davon, zu welchem Projekt es gehört) zum aktiven Dokument im Editorfenster. Das aktive Bibliotheksbauteil hängt am Cursor und ist zur Platzierung bereit.
- Add – Klicken Sie hier, um dem Bibliotheksdokument ein neues Bauteil hinzuzufügen. Der Dialog New Component wird geöffnet. Geben Sie den gewünschten Namen für das neue Bauteil ein, das der Liste hinzugefügt werden soll. Im Editorfenster wird ein leeres Blatt geöffnet, auf dem Sie das Bauteil definieren können.
- Delete – Klicken Sie hier, um die ausgewählten Bauteile dauerhaft aus dem Bibliotheksdokument zu löschen. Ein Bestätigungsdialog wird geöffnet, in dem Sie gefragt werden, ob der Löschvorgang fortgesetzt werden soll.
- Edit – Klicken Sie hier, um das Panel Properties zu öffnen, in dem Sie die Eigenschaften des aktiven Bauteils anzeigen und bearbeiten können. Über das Panel können Sie Verknüpfungen zu neuen Modellen erstellen oder bestehende bearbeiten. Durch Doppelklicken auf einen Design Item ID Eintrag wird ebenfalls das Panel Properties geöffnet.
Kontextmenü
Durch Rechtsklicken auf einen Eintrag in der Components Liste wird ein Menü mit Befehlen geöffnet.
Folgende Befehle stehen zur Verfügung:
- Select all – Wählen Sie schnell alle Bauteileinträge in der Liste aus.
- Update Schematic Sheets – Klicken Sie hier, um alle Änderungen an Bauteilen im aktiven Bibliotheksdokument auf alle geöffneten Schaltplandokumente zu übertragen. Alle Instanzen geänderter Bauteile in den Schaltplandokumenten werden aktualisiert.
-
Model Manager – Öffnen Sie den Dialog Model Manager, in dem Sie Modelle für alle Bauteile der aktiven Bibliothek hinzufügen, bearbeiten oder entfernen können.
- Copy – Kopieren Sie die ausgewählten Bauteile in die interne Zwischenablage des Schaltplanbibliothekseditors.
- Cut – Kopieren Sie die ausgewählten Bauteile in die interne Zwischenablage des Schaltplanbibliothekseditors und löschen Sie die Bauteile dauerhaft aus der Bibliothek. Ein Dialog wird angezeigt, in dem Sie bestätigen müssen, dass der Löschvorgang fortgesetzt werden soll.
- Paste – Fügen Sie ein Bauteil aus der internen Zwischenablage des Schaltplanbibliothekseditors in das aktive Bibliotheksdokument ein.
- Delete – Löschen Sie die ausgewählten Bauteile dauerhaft aus dem Bibliotheksdokument. Ein Dialog wird angezeigt, in dem Sie bestätigen müssen, ob der Löschvorgang fortgesetzt werden soll.
Hinweise
-
Die standardmäßigen Funktionen von Ctrl+Click und Shift+Click zur Auswahl mehrerer Einträge in einer Liste werden unterstützt.
-
Das aktive Bauteil ist dasjenige, dessen Symbol und zugehörige Modellinformationen derzeit im Editorfenster angezeigt werden. Ein Bauteil kann aktiv sein, ohne in der Components Liste ausgewählt zu sein.
-
Ctrl+Click auf einem ausgewählten Eintrag in einer Liste, um dessen Auswahl aufzuheben.
-
Mit den Tastenkombinationen Home, Down Arrow, Up Arrow und End sowie den Befehlen First Component, Next Component, Previous Component und Last Component im Kontext-Untermenü Tools des Arbeitsbereichs können Sie den ersten, nächsten, vorherigen bzw. letzten Eintrag in einem Listenbereich anzeigen.
-
Mehrteilige Bauteile werden in der Liste mit einem Pfeil daneben angezeigt. Jeder Teil wird darunter als Untereintrag aufgeführt.
-
In Bereichen des Panels mit mehreren Datenspalten können die Daten nach jeder beliebigen Spalte sortiert werden, indem Sie auf deren Überschrift klicken. Klicken Sie einmal, um aufsteigend zu sortieren, und erneut, um absteigend zu sortieren.
-
Sie können die Anzeigereihenfolge der Datenspalten ändern. Um eine Spalte zu verschieben, klicken Sie auf deren Überschrift und ziehen Sie sie horizontal an die gewünschte Position. Eine gültige Position wird durch zwei Positionspfeile angezeigt.
-
Das Bauteil, das Sie in das aktive Bibliotheksdokument einfügen, kann entweder aus einem Schaltplandokument oder aus einem anderen Schaltplanbibliotheksdokument stammen.
-
Wenn mehrere Bauteile aus dem Hauptentwurf im Schaltplaneditor in die Zwischenablage kopiert wurden, werden alle Bauteile der Auswahl in das Bibliotheksdokument eingefügt.
-
Wenn dasselbe Bauteil mehrmals in die Bibliothek eingefügt wird oder mehrere neue Bauteile ohne Umbenennung zur Bibliothek hinzugefügt werden, werden die Kopien durch die Suffixe _1, _2, _3 usw. unterschieden.
-
Ein Schaltplandokument muss geöffnet sein, um Änderungen an Bauteilen im Bibliotheksdokument übertragen zu können.
-
Wenn ein neues Schaltplanbibliotheksdokument erstellt wird, enthält das Panel ein einzelnes, leeres Bauteil – Component_1.













