Arbeiten mit Pads & Vias

Auf einen Blick

Dieser Artikel erläutert, wie Pads und Vias in Altium Designer funktionieren: was sie sind, worin sie sich unterscheiden, wo sie eingesetzt werden und wie sie im PCB-Editor und im PCB-Footprint-Editor platziert und bearbeitet werden. Außerdem stellt er die wichtigsten Via-Typen vor, beschreibt Arbeitsabläufe zur direkten Platzierung und Konvertierung und geht auf leistungsrelevante Funktionen für den Umgang mit Vorlagen und Vias ein. Wenn Sie die grundlegenden PCB-Objekte besser verstehen möchten, die Bauteilanschlüsse und das Routing zwischen Lagen ermöglichen, hilft Ihnen dieser Artikel, sich sicher mit diesen zentralen Konzepten vertraut zu machen. Lesen Sie weiter.

- Sie lernen die praktischen Unterschiede zwischen Pads und Vias kennen, einschließlich ihres Aufbaus, ihres Zwecks und der wichtigsten Via-Typen, die in einem PCB-Design verwendet werden.
- Sie erfahren, wie Pads und Vias in den Arbeitsabläufen von Altium Designer platziert, verschoben, konvertiert und zugewiesen werden können.
- Sie erhalten einen Überblick darüber, wie Pad- und Via-Eigenschaften verwaltet werden, einschließlich der Verwendung von Vorlagen und wichtiger Bearbeitungsoptionen im Properties-Panel.
Mit KI tiefer einsteigen:

Übersicht über Pads und Vias

Pads dienen sowohl der mechanischen Befestigung als auch der elektrischen Verbindung mit den Bauteilanschlüssen Pads dienen sowohl der mechanischen Befestigung als auch der elektrischen Verbindung mit den Bauteilanschlüssen

Ein Pad ist ein primitives Designobjekt. Pads dienen dazu, ein Bauteil auf der Leiterplatte zu befestigen und Verbindungspunkte zwischen den Bauteilanschlüssen und den Leiterbahnen auf der Leiterplatte herzustellen. Pads können auf einer einzelnen Lage liegen, beispielsweise als Pad für ein oberflächenmontiertes Bauteil, oder als dreidimensionale Durchkontaktierung ausgeführt sein. In diesem Fall besitzen sie einen hülsenförmigen Körper in Z-Richtung (vertikal) und eine flache Fläche auf jeder (horizontalen) Kupferlage. Der hülsenförmige Körper des Pads entsteht, wenn die Leiterplatte bei der Fertigung gebohrt und durchkontaktiert wird. In der XY-Ebene können Pads rund, rechteckig, achteckig, abgerundet rechteckig, rechteckig mit abgeschrägten Ecken oder benutzerdefiniert geformt sein. Pads können einzeln als freie Pads in einem Design verwendet werden. Üblicherweise werden sie jedoch im PCB-Bibliothekseditor zusammen mit anderen primitiven Objekten zu Bauteil-Footprints zusammengefügt.

Ein Via, das von der obersten Lage (rot) bis zur untersten Lage (blau) reicht und diese verbindet sowie eine interne Versorgungslage (grün) kontaktiert. 
Ein Via, das von der obersten Lage (rot) bis zur untersten Lage (blau) reicht und diese verbindet sowie eine interne Versorgungslage (grün) kontaktiert.

Ein Via ist ein primitives Designobjekt. Vias werden verwendet, um eine vertikale elektrische Verbindung zwischen zwei oder mehr elektrischen Lagen einer Leiterplatte herzustellen. Vias sind dreidimensionale Objekte und besitzen einen hülsenförmigen Körper in Z-Richtung (vertikal) mit einem flachen Ring auf jeder (horizontalen) Kupferlage. Der hülsenförmige Körper des Vias entsteht, wenn die Leiterplatte bei der Fertigung gebohrt und durchkontaktiert wird. In der XY-Ebene sind Vias kreisförmig, wie runde Pads. Der wesentliche Unterschied zwischen einem Via und einem Pad besteht darin, dass ein Via nicht nur alle Lagen der Leiterplatte (von oben nach unten) durchlaufen kann, sondern auch von einer Außenlage zu einer Innenlage oder zwischen zwei Innenlagen reichen kann.

Vias können einem der folgenden Typen entsprechen:

  • Thru-Hole – dieser Via-Typ reicht von der obersten bis zur untersten Lage und ermöglicht Verbindungen zu allen internen Signallagen.
  • Blind – dieser Via-Typ verbindet die Oberfläche der Leiterplatte mit einer internen Signallage.
  • Buried – dieser Via-Typ verbindet eine interne Signallage mit einer anderen internen Signallage.

Die im Design verwendbaren Via-Typen werden in Layer Stack Manager definiert. Weitere Informationen finden Sie auf der Seite Definition von Blind-, Buried- und Micro-Vias.

Pad- und Via-Definitionen können auch in Bibliotheken für Pad- und Via-Vorlagen gespeichert werden. Weitere Informationen finden Sie auf der Seite Arbeiten mit Pad- und Via-Vorlagen und -Bibliotheken.

Pad- und Via-Vorlagen, die nicht mit einer externen Pad- und Via-Bibliothek verknüpft sind, werden im PCB-Dokument gespeichert, wodurch sich die Ladezeiten verkürzen.

Diese Funktion ist verfügbar, wenn die Option PCB.Performance.PadViaTemplate.LoadingOptimization im Dialog Erweiterte Einstellungen aktiviert ist.

Der PCB-Editor verwendet das Konzept der „Via-Instanziierung“, bei dem die Geometrie einer Via-Instanz anstelle einer Via-Vorlage aufgebaut wird. Dies verbessert die Leistung und reduziert gleichzeitig den Speicherbedarf sowie die Zeit für den Szenenaufbau.

Diese Funktion befindet sich in der offenen Betaphase und ist verfügbar, wenn die Option PCB.ViaInstancing im Dialog Erweiterte Einstellungen aktiviert ist.

Direktes Platzieren von Pads und Vias

Pads und Vias können sowohl im PCB-Editor als auch im PCB-Footprint-Editor platziert werden. Vias werden üblicherweise beim interaktiven oder automatischen Routing automatisch platziert, können bei Bedarf jedoch auch manuell platziert werden. Manuell platzierte Vias werden als „freie“ Vias bezeichnet. Nach dem Aufrufen des Befehls zum Platzieren eines Pads (Place » Pad) oder Vias (Place » Via) wird der Cursor zu einem Fadenkreuz, und Sie wechseln in den Platzierungsmodus.

  1. Positionieren Sie den Cursor und klicken Sie anschließend oder drücken Sie Enter, um ein Pad/Via zu platzieren.
  2. Platzieren Sie weitere Pads/Vias oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Platzierungsmodus zu verlassen.
Ein Pad/Via übernimmt den Netznamen, wenn es auf einem Objekt platziert wird, das bereits mit einem Netz verbunden ist.

Drücken Sie während der Platzierung die Taste Alt, um die Bewegungsrichtung je nach ursprünglicher Bewegungsrichtung auf die horizontale oder vertikale Achse zu beschränken.

Vias werden normalerweise nicht manuell platziert, sondern automatisch im Rahmen des interaktiven Routings. Weitere Informationen finden Sie im Abschnitt Via-Platzierung beim interaktiven Routing.

Freie Pads auf der Lage Multi-layer können in Vias umgewandelt werden. Ein freies Pad ist ein Pad, das nicht zu einem übergeordneten Bauteilobjekt gehört. Die Umwandlung freier Pads in Vias kann hilfreich sein, wenn importierte Gerber-Dateien manuell wieder in das PCB-Format konvertiert werden. Wählen Sie im Designbereich alle freien Pads aus, die Sie umwandeln möchten, und wählen Sie in den Hauptmenüs den Befehl Tools » Convert » Convert Selected Free Pads to Vias. Die freien Pads werden in Vias mit demselben Bohrungsdurchmesser umgewandelt. Als Via-Durchmesser wird der größte Wert aus allen verfügbaren XY-Abmessungspaaren des Pads verwendet, die den Pad-Abmessungen auf den verschiedenen Lagen entsprechen.

Vias können auch in freie Pads umgewandelt werden. Dies kann beim Import von PADS-PCB- und PADS-2000-Dateien hilfreich sein, in denen Vias zur Verbindung mit Versorgungs- und Masselagen verwendet werden. Dadurch wird eine korrekte Verbindung mit internen Versorgungslagen mithilfe editierbarer Pads ermöglicht. Wählen Sie im Designbereich alle Vias aus, die Sie umwandeln möchten, und wählen Sie in den Hauptmenüs den Befehl Tools » Convert » Convert Selected Vias to Free Pads. Die Vias werden in freie Pads desselben Typs (Simple, Top-Middle-Bottom oder Full Stack) und mit demselben Bohrungsdurchmesser umgewandelt. Der Via-Durchmesser wird für die XY-Abmessungen des Pads auf den entsprechenden Lagen verwendet. Die Pad-Form wird auf Round festgelegt.

Grafische Bearbeitung

Mit Ausnahme ihrer Position lassen sich die Eigenschaften von Pads und Vias nicht grafisch ändern.

  • Um ein freies Pad zusammen mit den angeschlossenen Leiterbahnen zu verschieben, klicken Sie auf das Pad, halten Sie die Maustaste gedrückt und ziehen Sie es an die gewünschte Position. Die angeschlossenen Leiterbahnen bleiben beim Verschieben mit dem Pad verbunden. Beachten Sie, dass sich das Pad nicht verschieben lässt, wenn es zu einem Bauteil gehört.
  • Um ein freies Pad zu verschieben, ohne die angeschlossenen Leiterbahnen im PCB- oder PCB-Bibliothekseditor zu verschieben, wählen Sie den Befehl Edit » Move » Move. Klicken Sie anschließend auf das Pad, halten Sie die Maustaste gedrückt und verschieben Sie es.
  • Wenn Sie durch Klicken und Ziehen ein Auswahlrechteck um component Pads aufziehen, werden diese nicht ausgewählt, da sie untergeordnete Objekte des Bauteils sind. Um nur die Pads auszuwählen, halten Sie Ctrl gedrückt, während Sie das Auswahlfenster durch Klicken und Ziehen aufziehen.
  • Wenn ein Via zusammen mit den Leiterbahnen verschoben werden soll, um mehr Platz für das Routing oder für Bauteile zu schaffen, kann es effizienter sein, die Leiterbahnen neu zu routen, statt sie zu verschieben. Die Software bietet hierfür eine Funktion namens Loop Removal. Wenn diese Funktion aktiviert ist, routen Sie entlang eines neuen Pfads, dessen Anfang und Ende jeweils auf der ursprünglichen Leiterbahnführung liegen. Sobald Sie den interaktiven Routing-Modus mit einem Rechtsklick verlassen, wird die alte Leiterbahnführung (Schleife) einschließlich aller überflüssigen Vias entfernt.

Nichtgrafische Bearbeitung über das Properties-Panel

Bei dieser Bearbeitungsmethode wird der entsprechende Modus des Properties-Panels verwendet, um die Eigenschaften eines Pad-/Via-Objekts zu ändern.

Wärmefallen für Pads und Vias

Das Feld Thermal Relief im Bereich Pad Stack / Via Stack des Panels Properties fasst die aktuell angewendete Wärmefallenkonfiguration zusammen. Beispielsweise bedeutet Relief, 15mil, 10mil, 4, 90, dass:

  • eine Wärmefallenanbindung angewendet wird;
  • der Isolationsabstand 15 mil breit ist;
  • die Wärmefallenstege 10 mil breit sind;
  • die Wärmefallenstege um 90 Grad gedreht sind.

Wenn das Kontrollkästchen im Feld Thermal Relief deaktiviert ist, sind die Polygon-Wärmefallen für Pads und Vias rules-driven, d. h., diese Wärmefallen werden durch die geltenden Designregeln für den Polygon-Anbindungsstil definiert. Für einzelne Pads lässt sich die Wärmefallenkonfiguration anpassen, indem die zugehörige Option Thermal Relief für die gewünschte Lage aktiviert wird. In diesem Fall gelten die Wärmefallen als custom. Erfahren Sie mehr über das Definieren benutzerdefinierter Wärmefallen.

Lötstopp- und Pastenmaskenerweiterungen

Die Lötstoppmaske wird automatisch an jeder Pad-/Via-Position auf der Lötstoppmaskenlage erstellt. Die Lötstoppmaske wird negativ definiert, das heißt, die platzierten Objekte definieren Öffnungen in der Lötstoppmaskenlage. Die Lotpastenmaske wird automatisch an jeder Pad-Position auf der Lotpastenmaskenlage erstellt. Die auf der Maskenlage erzeugte Form entspricht der Pad-/Via-Form, erweitert oder verkleinert um den Wert, der durch die im PCB-Editor festgelegten Designregeln Lötstoppmaskenerweiterung und Lotpastenmaskenerweiterung oder im Panel Properties angegeben wird.

Pads mit eingeblendeter Lötstoppmaske.
Pads mit eingeblendeter Lötstoppmaske.

Wenn Sie ein Pad oder Via bearbeiten, sehen Sie die Einstellungen für die Lötstoppmasken- und Lotpastenmaskenerweiterung in den Bereichen Pad Stack bzw. Solder Mask Expansion des Panels Properties. Diese Einstellungen ermöglichen zwar eine lokale Steuerung der Erweiterungsanforderungen eines Pads/Vias, werden aber normalerweise nicht benötigt. Im Allgemeinen ist es einfacher, die Anforderungen an Lotpasten- und Lötstoppmasken durch entsprechende Designregeln im PCB-Editor zu steuern. Dabei wird eine Regel definiert, die die Erweiterung für alle Bauteile auf der Leiterplatte festlegt. Bei Bedarf können Sie weitere Regeln für spezifische Situationen hinzufügen, beispielsweise für alle Instanzen eines bestimmten Footprint-Typs auf der Leiterplatte oder für ein bestimmtes Pad eines bestimmten Bauteils.

  

So legen Sie die Maskenerweiterungen in den Designregeln fest:

  1. Stellen Sie sicher, dass die Option Rule Expansion als Shape im Bereich Pad Stack des Panels Properties (für Pads) ausgewählt ist und/oder dass die Option Rule im Bereich Solder Mask Expansion des Panels Properties (für Vias) ausgewählt ist.

  2. Wählen Sie im PCB-Editor über die Hauptmenüs Design » Rules aus und prüfen Sie die Designregeln der Kategorie Mask im Dialog PCB-Regel- und Constraint-Editor. Diese Regeln werden angewendet, wenn der Footprint auf der Leiterplatte platziert wird.

Um die Designregeln für die Erweiterung zu überschreiben und eine Maskenerweiterung als Pad-/Via-Attribut festzulegen, wählen Sie Manual Expansion als Shape im Bereich Pad Stack des Panels Properties (für Pads) und/oder Manual im Bereich Solder Mask Expansion des Panels Properties (für Vias) aus und geben Sie die gewünschten Werte ein.

Die Lotpastenmaskenlage für Durchsteckpads wird in Draftsman-Dokumenten sowie bei der Ausgabe in Gerber, Gerber X2, ODB++, IPC-2581 und PCB Print unterstützt.
Für Pads können Sie außerdem manuell aus einem Standardsatz vordefinierter Maskenformen auswählen oder eine eigene benutzerdefinierte Form erstellen – mehr erfahren.

Abdecken von Pads und Vias mit Lötstoppmaske

Eine teilweise oder vollständige Abdeckung von Pads und Vias mit Lötstoppmaske (Tenting) lässt sich durch Festlegen eines geeigneten Werts für die Lötstoppmaskenerweiterung erreichen. Diese Erweiterungsvorgabe kann entweder für jedes Objekt einzeln im Panel Properties oder über entsprechende Designregeln für die Lötstoppmaskenerweiterung definiert werden. Mit einem geeigneten Erweiterungswert können Sie Folgendes erreichen:

  • Um ein Pad/Via teilweise abzudecken – also nur die Kupferfläche –, setzen Sie die Erweiterung auf einen negativen Wert, der die Maske bis unmittelbar an die Pad-/Via-Bohrung heranführt.
  • Um ein Pad/Via vollständig abzudecken – also Kupferfläche und Bohrung –, setzen Sie die Erweiterung auf einen negativen Wert, dessen Betrag mindestens dem Pad-/Via-Radius entspricht.
  • Um alle Pads/Vias auf einer einzelnen Lage abzudecken, legen Sie den entsprechenden Erweiterungswert fest und stellen Sie sicher, dass der Geltungsbereich (Full Query) einer Regel für die Lötstoppmaskenerweiterung alle Pads/Vias auf der gewünschten Lage erfasst.
  • Um alle Pads/Vias in einem Design mit unterschiedlichen Via-Größen vollständig abzudecken, setzen Sie die Erweiterung auf einen negativen Wert, dessen Betrag mindestens dem größten Pad-/Via-Radius entspricht. Beim Abdecken eines einzelnen Pads/Vias können Sie entweder die Erweiterung der geltenden Designregel übernehmen oder die Regel überschreiben und eine festgelegte Erweiterung direkt auf das betreffende Pad/Via anwenden.

Testpunkte

Related page: Testpunkte auf der Leiterplatte zuweisen

Die Software bietet umfassende Unterstützung für Testpunkte. Pads (Durchsteck- oder SMD-Pads) und Vias können als Testpunktpositionen für Fertigungs- und/oder Bestückungstests festgelegt werden. Ein Pad/Via wird durch Festlegen seiner entsprechenden Testpunkteigenschaften als Testpunkt ausgewiesen: ob es als Fertigungs- oder Bestückungstestpunkt dienen soll und auf welcher Seite der Leiterplatte es als Testpunkt verwendet werden soll. Diese Eigenschaften finden Sie im Bereich Testpoint des Panels Eigenschaften .

Um den Vorgang zu vereinfachen und die manuelle Festlegung der Testpunkteigenschaften zu vermeiden, bietet die Software eine Methode zur automatischen Zuweisung von Testpunkten anhand definierter Designregeln mithilfe des Testpunkt-Managers (Tools » Testpoint Manager). Bei dieser automatischen Zuweisung werden jeweils die entsprechenden Testpunkteigenschaften des Pads/Vias festgelegt.

Pad-spezifische Angaben

Pad-Bezeichner

Jedes Pad sollte mit einem Bezeichner aus bis zu 20 alphanumerischen Zeichen versehen werden, der üblicherweise die Anschlussnummer eines Bauteils darstellt. Pad-Bezeichner werden während der Platzierung automatisch um eins erhöht, wenn der Bezeichner des ersten Pads mit einer Ziffer endet. Ändern Sie den Bezeichner des ersten Pads vor der Platzierung im Panel Eigenschaften .

Für alphabetische Inkremente, z. B. 1A, 1B, oder numerische Inkremente ungleich 1 verwenden Sie den Dialog Einfügearray einrichten, den Sie durch Klicken auf die Schaltfläche Paste Array im Dialog Inhalte einfügen (Edit » Paste Special) öffnen.

Einfügearray-Funktion

Wenn Sie den Bezeichner des Pads festlegen, bevor Sie es in die Zwischenablage kopieren, können Sie über den Dialog Setup Paste Array während der Pad-Platzierung automatisch eine Bezeichnerfolge anwenden. Über das Feld Text Increment im Dialog Setup Paste Array lassen sich folgende Pad-Bezeichnerfolgen platzieren:

  • Numerisch (1, 3, 5)
  • Alphabetisch (A, B, C)
  • Alphanumerische Kombinationen (A1 A2, 1A 1B, A1 B1 oder 1A 2A usw.)

Für eine numerische Erhöhung setzen Sie das Feld Text Increment auf den gewünschten Inkrementwert. Für eine alphabetische Erhöhung setzen Sie das Feld Text Increment auf den Buchstaben im Alphabet, dessen Position der gewünschten Schrittweite entspricht. Wenn das erste Pad beispielsweise den Bezeichner 1A hat, setzen Sie das Feld auf A (erster Buchstabe des Alphabets), um die Bezeichner jeweils um 1 zu erhöhen. Wenn Sie das Feld auf C (dritter Buchstabe des Alphabets) setzen, lauten die Bezeichner 1A, 1D (drei Buchstaben nach A), 1G usw.

Jumper-Verbindungen

Jumper-Verbindungen definieren elektrische Verbindungen zwischen Bauteilpads, die nicht physisch mit Primitiven auf der Leiterplatte geroutet werden. Sie sind besonders bei einlagigen Leiterplatten nützlich, bei denen ein Draht verwendet wird, um Leiterbahnen auf der einzigen physischen Lage zu überbrücken.

Pads innerhalb eines Bauteils können über das Panel Properties mit einem Jumper Wert gekennzeichnet werden. Pads mit demselben Jumper und demselben elektrischen Netz signalisieren dem System, dass zwischen ihnen eine gültige Verbindung besteht, obwohl sie physisch nicht verbunden sind.

Jumper-Verbindungen werden im PCB-Editor als gekrümmte Verbindungslinien dargestellt. Die Designregelprüfung meldet Jumper-Verbindungen nicht als ungeroutete Netze.

Via-spezifische Details

Via-Eigenschaften definieren

Während die Anforderungen an die von jedem Via-Typ überspannten Lagen (Z-Ebene) auf der Registerkarte „Via Types“ des Layer Stack Manager definiert werden, werden die Größenparameter des Vias wie folgt festgelegt:

Die Designregel „Routing Via Style“ konfigurieren

Main page: PCB-Designregeln definieren, ihren Geltungsbereich festlegen & verwalten

Die Größenparameter von Vias, die beim interaktiven Routing, beim ActiveRouting oder beim Autorouting platziert werden, werden durch die jeweils geltende Designregel „Routing Via Style“ festgelegt. Um Vias in der Designregel gezielt zu erfassen, steht eine Reihe von Via-bezogenen Abfrageschlüsselwörtern zur Verfügung, die Sie im Geltungsbereich der Regel (Where the Object Matches) verwenden können. Diese werden weiter unten ausführlich beschrieben.

Wenn Sie während des Routings einen Lagenwechsel vornehmen, prüft die Software die Start- und Endlage dieses Lagenwechsels und wählt einen zulässigen Via-Typ aus Layer Stack Manager. Anschließend ermittelt sie die geltende Designregel „Routing Via Style“ mit der höchsten Priorität und wendet die Via-Größeneinstellungen aus dem Abschnitt Constraints dieser Regel auf das zu platzierende Via an.

Beispielsweise könnten Sie eine Gruppe von DRAM_DATA-Netzen haben, die für den Lagenübergang von TopLayer zu S2 und von S2 zu S3 µVias und für alle anderen Lagenübergänge ein gebohrtes, durchgehendes Via benötigen (das sich zudem von dem für andere Netze benötigten Via unterscheidet). Dies lässt sich durch zwei Designregeln vom Typ „Routing Via Style“ für diese DRAM_DATA-Netze umsetzen. Ein Beispiel für eine geeignete µVia-Designregel ist unten dargestellt. Bewegen Sie den Mauszeiger über das Bild, um die Designregel für durchgehende Vias anzuzeigen.

Der Geltungsbereich von Designregeln kann auf bestimmte Via-Typen beschränkt werden.
Der Geltungsbereich von Designregeln kann auf bestimmte Via-Typen beschränkt werden.

Wenn ein Via im freien Bereich platziert wird, kann die Software während der Platzierung keine Routing-Stil-Designregel anwenden. In diesem Fall wird das Standard-Via platziert.

Query Keywords

Um die Festlegung des Geltungsbereichs von Designregeln des Typs „Routing Via Style“ zu vereinfachen, stehen die folgenden Via-bezogenen Abfrageschlüsselwörter zur Verfügung:

Via Type Query Returns
IsVia Alle Via-Objekte, unabhängig vom Via-Typ.
IsThruVia Alle Vias, die von der obersten bis zur untersten Lage reichen.
IsBlindVia Alle Vias, die auf einer Außenlage beginnen und auf einer Innenlage enden und keine µVias sind.
IsBuriedVia Alle Vias, die auf einer Innenlage beginnen und auf einer anderen Innenlage enden und keine µVias sind.
IsMicroVia Alle Vias, bei denen die Option „µVia“ aktiviert ist und die benachbarte Lagen verbinden.
IsSkipVia Alle Vias, bei denen die Option „µVia“ aktiviert ist und die zwei Lagen überspannen.

Verwenden Sie die Funktion „Mask“ im Query Helper, um verfügbare Via-bezogene Schlüsselwörter zu finden. Drücken Sie F1, während ein Abfrageschlüsselwort in der Liste ausgewählt ist, um Hilfe zu diesem Schlüsselwort aufzurufen.

Via-Platzierung beim interaktiven Routing

Wenn Sie beim interaktiven Routing die Lage wechseln, fügt die Software automatisch ein Via ein. Welches Via ausgewählt wird, hängt von folgenden Faktoren ab:

  • Den verfügbaren Via-Typen für die Lagen, die beim Lagenwechsel überspannt werden.
  • Der geltenden Designregel „Routing Via Style“ für den bei diesem Lagenwechsel ausgewählten Via-Typ.

So wechseln Sie beim interaktiven Routing die Lage:

  • Drücken Sie die Taste * auf dem Ziffernblock, um zur nächsten Signallage zu wechseln.
  • Verwenden Sie die Tastenkombination Ctrl+Shift+WheelRoll, um die Lagen nach oben oder unten zu durchlaufen.

Gestapelte µVias werden bei einem Lagenwechsel von L1 zu L4 platziert. Der Modus Interactive Routing des Panels Properties zeigt die zu platzierenden Via-Typen an; drücken Sie 6, um die möglichen Via-Stapel zu durchlaufen; drücken Sie 8, um eine Liste der möglichen Via-Stapel anzuzeigen.

Das beim interaktiven Routing platzierte Via steuern

  • Beim Wechsel der Routing-Lage wählt die Software automatisch den Via-Typ aus, der am besten zum jeweiligen Lagenbereich passt.

  • Wenn mehrere Via-Typen oder Kombinationen (Via-Stapel) verwendet werden können, drücken Sie die Tastenkombination 6, um interaktiv alle für diesen Lagenwechsel verfügbaren Via-Stapel zu durchlaufen. Drücken Sie die Tastenkombination 8, um eine Liste anzuzeigen. Via-Stapel werden in folgender Reihenfolge angeboten: µVia(s), Skip-µVia, Blind Via, durchgehendes Via. Gestapelte Vias können platziert werden, wenn der Lagenwechsel mehr als eine Lage umfasst und geeignete Via-Typen definiert sind. Die vorgeschlagenen Via-Typen werden in der Statusleiste und in der Heads-up-Anzeige aufgeführt, beispielsweise [µVia 1:2, µVia 2:3, µVia 3:4], wie im obigen Bild gezeigt.

  • Der zuletzt verwendete Via-Stapel wird als Standard für das nächste zu routende Netz beibehalten. Dieser Standard-Via-Stapel gilt nur für die aktuelle Bearbeitungssitzung.

  • Die Größenparameter des Vias werden durch die geltende Designregel „Routing Via Style“ festgelegt. Strategien zur Definition einer geeigneten Designregel „Routing Via Style“ werden weiter oben erläutert.

  • Um die Größe des Vias während eines Lagenwechsels interaktiv zu ändern, drücken Sie die Tastenkombination 4. Dadurch durchlaufen Sie die Via-Größenmodi: Rule Minimum; Rule Preferred; Rule Maximum; User Choice. Der aktuelle Via-Größenmodus wird in der Heads-up-Anzeige und in der Statusleiste angezeigt (wie im obigen Bild dargestellt). Wenn „User Choice“ ausgewählt ist, drücken Sie Shift+V, um den Dialog „Choose Via Sizes“ zu öffnen, und wählen Sie eine bevorzugte Via-Größe aus. Die im Dialog angezeigte Liste verfügbarer Via-Größen wird aus den bereits im Design verwendeten Vias zusammengestellt. Sie können diese im Modus „Pad and Via Templates“ des Panels PCB einsehen.

    Wenn in der geltenden Designregel „Routing Via Style“ der Modus Template preferred verwendet wird, können Sie mit der Tastenkombination 4 die aktivierten Via-Vorlagen durchlaufen.

  • Eine Seitenansicht der vorgeschlagenen Via-Typen wird im Panel Properties angezeigt, wie oben dargestellt.

  • Um ein Via zu platzieren und das Routing auf derselben Lage fortzusetzen, drücken Sie die Tastenkombination 2.

  • Um ein Via zu platzieren und das Routing dieser Verbindung zu unterbrechen, drücken Sie die Tastenkombination / auf dem Ziffernblock.

  • Wenn das zu routende Netz mit einer internen Versorgungslage verbunden werden soll, drücken Sie die Taste / auf dem Ziffernblock, um ein Via zu platzieren, das die Verbindung zur entsprechenden Versorgungslage herstellt. Dies funktioniert in allen Leiterbahn-Platzierungsmodi außer im Modus „Any Angle“ .

  • Drücken Sie während des Routens Shift+F1, um ein Menü mit allen innerhalb des Befehls verfügbaren Tastenkombinationen aufzurufen.

Arbeiten mit gestapelten Vias

  • Gestapelte Vias, die eine durchgehende Verbindung bilden, lassen sich wie ein einzelnes Via bearbeiten. Mit click and drag auf dem Stapel verschieben Sie alle Vias zusammen mit den angeschlossenen Leiterbahnen.

  • Klicken Sie einmal, um das oberste Via im Stapel auszuwählen. Wenn Sie die Maus nicht bewegen, wählen weitere Einzelklicks nacheinander die übrigen Vias im Stapel aus.

    Wenn die Option Display popup selection dialog auf der Seite PCB-Editor – Allgemein des Dialogs Preferences aktiviert ist, öffnet sich beim Klicken auf einen Via-Stapel ein Auswahlfenster, in dem Sie das gewünschte Via auswählen können.

  • Ctrl+Click and drag, um nur das ausgewählte Via mit seinen angeschlossenen Leiterbahnen zu verschieben.

  • Um alle Vias in einem Stapel auszuwählen, wählen Sie zunächst eines durch einen Klick aus und drücken Sie dann Tab, um die Auswahl auf alle Vias in diesem Stapel zu erweitern.

Konfigurieren der Via-Anzeige

Für die Arbeit mit Vias stehen verschiedene Anzeigefunktionen zur Verfügung.

Via-Farben

Die Via-Farben werden im Panel Ansichtskonfiguration konfiguriert. Der Kupferring des Vias wird mit der aktuellen Einstellung Multi-Layer im Bereich Layers angezeigt. Die Farbe der Via-Bohrung wird mit der Einstellung Via Holes im Bereich System Colors  angezeigt. Sie können die Anzeige der Bohrungen auch deaktivieren, indem Sie  für die gewünschte(n) Einstellung(en) umschalten.

Das erste Bild zeigt ein durchgehendes Via. Das Via im zweiten Bild ist ein Sackloch-Via; die Bohrung wird in den Farben der Start- und Endlage dargestellt.
Das erste Bild zeigt ein durchgehendes Via. Das Via im zweiten Bild ist ein Sackloch-Via; die Bohrung wird in den Farben der Start- und Endlage dargestellt.

Vias und die Lötstoppmaske

Standardmäßig wird im PCB-Editor die Multilayer-Lage immer als oberste Lage angezeigt. Dies kann die genaue Betrachtung der Inhalte der Lötstoppmaskenlagen erschweren, insbesondere wenn ein Pad oder Via eine negative Maskenerweiterung verwendet, da die Inhalte der Lötstoppmaskenlage unter dem Multilayer-Objekt verschwinden. Sie können dies ändern, indem Sie die Zeichenreihenfolge der Lagen auf der Seite PCB-Editor – Anzeige des Dialogs Preferences anpassen. Legen Sie fest, dass die aktuelle Lage als oberste Lage gezeichnet wird.

Wenn Sie die Zeichenreihenfolge so ändern, dass die aktuelle Lage oben angezeigt wird, und anschließend Top Solder als aktuelle Lage auswählen, werden die Maskenöffnungen korrekt dargestellt, wie im folgenden Bild gezeigt. Die grünen Pfeile zeigen die Größe der Lötstoppmaskenöffnung für ein Via links, ein Pad mit verkleinerter Maskenöffnung in der Mitte und ein Pad mit vergrößerter Öffnung rechts.

Konfigurieren Sie die Anzeigeeinstellungen so, dass Sie die Lötstoppmaskenöffnungen prüfen können.
Konfigurieren Sie die Anzeigeeinstellungen so, dass Sie die Lötstoppmaskenöffnungen prüfen können.

Anzeige gestapelter Vias

Bei gestapelten Vias geben die angezeigten Zahlen die Start- und Endlagen aller Vias im Stapel an. Bewegen Sie den Mauszeiger über das folgende Bild, um die Vias in 3D anzuzeigen. Auf der rechten Seite des Bildes befindet sich ein Stapel aus drei Vias.

Die überspannten Lagen können in den Vias angezeigt werden. Bewegen Sie den Mauszeiger über das Bild, um die Vias in 3D anzuzeigen.Die überspannten Lagen können in den Vias angezeigt werden. Bewegen Sie den Mauszeiger über das Bild, um die Vias in 3D anzuzeigen.

Weitere Anzeigeeinstellungen für Vias

Um den Netznamen des Vias und die Lagennummern innerhalb der Via-Spanne anzuzeigen, aktivieren Sie die Optionen Via Nets bzw. Via Span im Bereich Additional Options auf der Registerkarte View Options des Panels View Configuration.

Durchsuchen von Pad- und Via-Bohrungen

Im Modus des PCB-Panels Hole Size Editor ändern sich die drei Hauptbereiche und zeigen Folgendes an (von oben nach unten):

  • Die allgemeine Filterung nach Bohrungstypen und deren Status, mit einem Unterbereich für die aktuell für die Leiterplatte definierten Bohrlagenpaare.
  • Unique Holes, in Gruppen nach Größe und Form angeordnet.
  • Einzelne Pads/Vias, aus denen die jeweilige Gruppe von Bohrungsobjekten besteht.

Die Bereiche des Panels zeigen die kumulativ angewendete Filterung nach Bohrungstypen, -formen und -status.
Die Bereiche des Panels zeigen die kumulativ angewendete Filterung nach Bohrungstypen, -formen und -status.

Die Bohrungsgruppen können im Bereich Unique Holes des Panels gemeinsam bearbeitet werden, indem Sie Werte in die entsprechenden Spaltenzellen eingeben. In der Spalte Hole Size  können Sie einen numerischen Wert eingeben, um die aktuelle Bohrungsgröße für Pads und Vias zu ändern.

Bearbeiten der Bohrungsgröße für die ausgewählte Gruppe von sechs übereinstimmenden Bohrungsformen.
Bearbeiten der Bohrungsgröße für die ausgewählte Gruppe von sechs übereinstimmenden Bohrungsformen.

Sie können gegebenenfalls auch die zugehörigen Einträge Hole Length, Hole Type und Plated für die Bohrungen ändern.

Ändern des Bohrungstyps für die ausgewählte Gruppe von sechs übereinstimmenden Bohrungsformen.
Ändern des Bohrungstyps für die ausgewählte Gruppe von sechs übereinstimmenden Bohrungsformen.

Einzelne Pad-/Via-Objekte, die zur ausgewählten Bohrungsgruppe gehören, werden im unteren Bereich Pad/Via des Panels PCB aufgelistet. Klicken Sie mit der rechten Maustaste auf ein Objekt in der Liste und wählen Sie Properties (oder doppelklicken Sie direkt auf den Eintrag), um den zugehörigen Modus des Panels Properties für dieses Grundobjekt zu öffnen. Dort können Sie dessen Eigenschaften anzeigen und bearbeiten.

Um das Panel PCB im Modus Hole Size Editor mit den aktuellen Bohrsymboldaten der Leiterplatte zu aktualisieren, klicken Sie in diesem Modus mit der rechten Maustaste in einen Bereich des Panels und wählen Sie den Befehl Refresh.

Die Bohrsymboldaten werden beim Speichern des PCB-Dokuments sowie für alle Ausgaben, die diese Daten enthalten, automatisch aktualisiert.

Aus Leistungsgründen werden die Bohrsymboldaten im Panel PCB nicht automatisch aktualisiert. Die manuelle Aktualisierung der Bohrsymboldaten ist verfügbar, wenn die Option PCB.LiveDrillSymbols im Dialog Erweiterte Einstellungen deaktiviert ist.

Unterstützung für Backdrilling

Der Modus Hole Size Editor des Panels PCB kann auch verwendet werden, um Pads und Vias zu untersuchen, die für Backdrilling vorgesehen sind. Backdrill-Lagenpaare werden in der Liste Layer Pairs angezeigt und durch den Zusatz [BD] gekennzeichnet.

Wenn eine Backdrill-Bohrungsgröße ausgewählt wird, wird Kind der Objekte als Backdrill angezeigt. Mit dieser Funktion können Sie Backdrill-Bohrungen schnell finden und prüfen. Beachten Sie, dass die Backdrill-Einstellungen im Panel nicht bearbeitet werden können.

Backdrill-Bericht

Um einen Bericht über alle Backdrill-Vorgänge zu erstellen, klicken Sie mit der rechten Maustaste in die Liste der eindeutigen Bohrungen und wählen Sie im Kontextmenü Backdrill Report.

Der Bericht enthält Details zu jedem Backdrill-Vorgang, einschließlich Position, Bohrungsgröße und Bohrtiefe.

Weitere Informationen zum Backdrilling finden Sie unter Bohren mit kontrollierter Tiefe oder Backdrilling.

Unterstützung für Senkbohrungen

Der Modus Hole Size Editor des Panels PCB kann auch verwendet werden, um Pads mit aktivierten Senkbohrungsfunktionen zu untersuchen. Wenn das PCB-Design Pad-Objekte enthält, bei denen Senkbohrungsfunktionen (Zylinder- oder Kegelsenkung) für eine oder beide Seiten aktiviert sind, werden die zugehörigen Gruppen Counterholes Top und/oder Counterholes Bottom in der Liste Layer Pairs angezeigt. Die Spalten Counterhole Depth und Counterhole Angle können in Unique Holes angezeigt werden. Bereich des Panels. Beachten Sie, dass die Einstellungen für Senkbohrungen im Panel nicht bearbeitet werden können.

Informationen zu Senkbohrungen im Design werden im Modus Hole Size Editor des PCB Panels angezeigt.
Informationen zu Senkbohrungen im Design werden im Modus Hole Size Editor des PCB Panels angezeigt.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents