Altium Designer Documentation

Managed Projects in an Altium 365 Workspace

Modified by Jason Howie on Jul 9, 2021

Parent page: Altium 365 Workspace

Altium Designer, in conjunction with the Altium 365 Workspace, brings support for Managed Projects. Managed projects target the development stage of the project lifecycle, simplifying the creation and ongoing workflow for version controlled projects. Centralized storage under the control of the Workspace also enables this feature to be a foundation for other collaborative services.

Some key benefits to using fully-managed projects are:

  • Simplified storage. No need to make decisions about storage locations. Backup and other basic services are taken care of.
  • Foundation for collaborative features.
  • Enforced version control.
  • Advantages of a dedicated commenting system.
  • Notifications and status. Document status including local modifications is visible to entire design teams.
  • Concurrent PCB design works without any complex setup.
  • Ability to share the project with multiple people for editing, or for viewing and commenting only.
  • Full functionality when using the Project History feature, including VCS-related commit events.

Technically a managed project is the combination of meta information stored in the Workspace, along with tight integration with the Workspace's inherent GIT-based version control. The typical work flow is as follows:

  1. A user creates a new managed project (via the Create Project dialog in Altium Designer, from the Workspace's browser interface, or by making an existing unmanaged project available in the Workspace (from within Altium Designer)). During creation, that user defines the project's name and description.
  2. In the Workspace's browser interface, or directly within Altium Designer, access to the project is defined and managed.
  3. All collaborators select the project for opening (from within Altium Designer) after which it is automatically checked out.
The beauty of managed projects is that they are version controlled by default and can be collaboratively worked upon without having to worry about shared drives, servers, agreements etc. Version control is handled courtesy of the Workspace's built-in GIT version control service. All managed projects are stored in a single Design Repository within a Workspace, named Versioned Storage (a Git repository). If your project is under external version control, you can migrate it to be a fully-managed project in the Workspace that hosts the design files in the server's own Git repository (effectively switching to the Workspace's native VCS). For detailed information on how to do this, see Moving from External VCS to Workspace Native VCS.
You can also keep your project unmanaged (a regular, or VCS-based project), but make a synchronized copy of it available online - sending it to your Workspace. Referred to as Simple Sync, this enables you to take advantage of the collaborative benefits offered through Altium 365.

This document takes a look at working with managed projects through the Workspace's browser interface. For information on working with managed projects in your design software, see Management of Projects from within Altium Designer.

Creating a New Managed Project

A managed project can be created directly from the Projects page of the Workspace's browser interface. The page lists all projects that have been made available to the Workspace, and which are shared with the currently signed-in user. To create a new project, click the  button above the project list, then choose the Create Project entry to open the Create Project window.

Creating a new managed project through the Workspace's browser interface.

The Create Project window will initially present in simplified view, with the following fields:

  • Project Name - enter the required name for the project
The project name should start with, and can contain A-Z, a-z, or 0-9. Underscores, dashes, and spaces are allowed, but the latter can only be used within the middle of the name (leading and trailing spaces will be ignored). You can not use the following words: AUX, COM1-COM9, LPT1-LPT9, CON, NUL, and PRN. In addition, the name cannot contain the following characters: \ . / ? % * : | " < >.
  • Template - choose a project template if available - the associated drop-down field will list all Managed Project Templates that exist in the Workspace (in the format <Comment> (<ItemID>)). Choosing a template will inherently define the project type. If you do not want to base the new project on an existing project template, simply specify the type of project to be created (using the PCB Project or Multiboard entries available from the list).
  • Description - enter an optional description for the project.

To access more controls click the  button. The following field will present:

  • Parent Folder - use this field to specify where the project is to be created within the Workspace's folder structure. By default, this will be Projects. The default folder path for new projects is specified on the Admin - Settings - Projects page of the Workspace's browser interface. Click the Change link at the right of the field to access the server folder structure for the Workspace, from which to select an alternate folder in which to store the project. You can organize projects into a hierarchy of sub-folders should you wish. For more information, see the section Creating a Hierarchy of Project Folders.

After defining the new project as required, click . You will come back to the summary-level project list, where you will now see an entry for the newly-created project.

The newly-created project, evident back on the Projects page of the Workspace's browser interface.

The project will initially be shared for editing access with the designer who created it (Owner), Administrators for the Workspace, and all members of the Workspace team. For more information on configuring project access permissions, see Sharing a Project.

Uploading an Existing Unmanaged Project

You can also upload an existing design project to the Workspace. To do so:

  1. Click the  button above the project list, then choose the Upload Project entry. In the Select Folder to Upload dialog browse to, and select, the folder containing the project to be uploaded, then click Upload.

  1. A pop-up window will advise how many files are involved in the upload (contained in the chosen folder) and asking for confirmation to proceed - click .
  2. The Upload Project window now appears. By default, the Project Name will be that of the existing project - change if required and add a suitable description. The Parent Folder will be set to the folder that was currently active when the upload process was started. Click the Change link at the right of the field to access the server folder structure for the Workspace, from which to select an alternate folder in which to store the project. You can organize projects into a hierarchy of sub-folders should you wish. For more information, see the section Creating a Hierarchy of Project Folders. With settings defined as required, click the  button.

  1. The upload will proceed, after which time an entry for the project will be added to the summary-level project list.

Any existing version control links in the local project are ignored, and the uploaded project becomes a fully managed, version-controlled, server-based project. The local source project is not altered in any way.

Creating a Hierarchy of Project Folders

The Workspace also provides the ability to create and manage project folders within the server's structure. Projects may then be created in, or moved to, any folder in the resulting folder hierarchy.

To create a new folder under the (default) top-level Project folder, click the  button above the project list, then choose the Create Folder entry. In the Create Folder window that appears specify the name of the new folder, its parent folder, and an optional description. A new folder is always created under the currently selected folder, which becomes its parent folder.

If you already have a defined hierarchy of project folders, click the Change link at the right of the Parent Folder field to access the server folder structure for the Workspace, from which to select an alternate parent folder in which to create the new folder.

With attributes defined as required, click . The new folder (sub-folder) will be created and you will be taken to it.

Example creation of a new folder (sub-folder) in which to store projects.

Continue creating further folders as required, effectively building a hierarchy of folders in which to store and categorize your managed design projects. Those folders will then be available to choose from as the parent folder when creating a subsequent folder, as illustrated in the following image.

Example of a defined hierarchy of project folders.

On entering the Projects page in its default graphical view, you will be presented with the project content of the top-level Projects folder. All child project folders one level below will also be shown, across the top of the page. Depending on the length of folder naming, you may need to hover the cursor over a folder entry to pop the full name as a hover tip. In this respect, it may be easier to switch to the list view (click ) to see the secondary level of folders available. Selecting a folder will present information for it in the right-hand pane.

To select a folder in graphical view click on its tile, away from its name.

Example secondary level project folders seen from the default graphical view for the Projects page. Hover the mouse over the image to see the folders presented in the list view.

Access a folder by clicking on its name (graphical view) or double-clicking on its entry (list view). Use the breadcrumbs at the top of the view to quickly jump back up the folder hierarchy.

Traversing an example project folder hierarchy, using the breadcrumbs to quickly ascend.

You can also quickly jump back to the top-level Projects folder by clicking the Projects entry within the left-hand navigation tree.

Editing a Folder

To edit the properties of an existing project folder select its entry on the Projects page, click the  control above the listing of projects/folders, and choose the Edit entry on the associated menu. In the following Edit Folder window you can change the folder's Name and Description.

The root Projects folder cannot be modified.
Also available in the graphical view of the Projects page by selecting the tile for the required folder, then clicking the  control and choosing the Edit command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required folder and choose the Edit command from the associated menu.

You can edit the Name and Description for a project folder at any stage.

Click the  button to confirm any changes you have made.

Moving a Folder within the Hierarchy

To move (relocate) a folder under a different parent folder within the hierarchy select its entry on the Projects page, click the  control above the listing of projects/folders, and choose the Move entry on the associated menu.

The root Projects folder cannot be moved.
Also available in the graphical view of the Projects page by selecting the tile for the required folder, then clicking the  control and choosing the Move command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required folder and choose the Move command from the associated menu.

The Move folder window will appear, in which to choose the new parent folder.

You can move a folder within the folder hierarchy at any stage.

Click the  button to effect the move. The folder will be moved to be a sub-folder of the chosen new parent, along with its constituent projects, and you will be taken to that new parent folder.

Deleting a Folder

To delete (remove) an existing project folder from the Workspace, select its entry on the Projects page, click the  control above the listing of projects/folders, and choose the Delete entry on the associated menu.

The root Projects folder cannot be deleted.
Also available in the graphical view of the Projects page by selecting the tile for the required folder, then clicking the  control and choosing the Delete command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required folder and choose the Delete command from the associated menu.

The Delete window will appear, in which to confirm the deletion. The action is actually a 'soft delete', whereby the folder and any projects stored within will be moved into the Trash area of the Workspace.

Deleting a project folder - sending it to the isolated Trash area for the Workspace.

To proceed with the deletion, click the  button. The folder will be removed from the folder hierarchy, along with its constituent projects, and you will be taken to the deleted folder's parent. A project folder can be restored, or permanently deleted from the Trash page. A project deleted along with the folder can be restored, or permanently deleted from the Trash page, only by the owner of that project or a Workspace Administrator.

Browsing Managed Projects

The projects listing on the Projects page of the Workspace's browser interface includes all projects that are shared with you, and offers a range of controls to access project management features. Use the  button to switch the page to its list view and the  button to switch the page to its graphical view (the default view).

The Projects page of the Workspace's browser interface - command central for working with your managed projects. Here, the graphical view for the page is shown. Hover the mouse over the image to see the list view.

The list of managed projects is automatically sorted by the last modified date, with the most recently modified project appearing at the top-left of the list (in the graphical view) or at the top of the list (in the list view). In the graphical view, the  button can be used to quickly sort the projects by project name, author, or last modified date. In the list view, the project listing can be sorted by Name, Author, or Last Modified, using the column header in each case. Click once to sort in ascending order, click again to sort in descending order. The arrows to the right of the column name will indicate the currently active sort direction. The chosen sorting method in one view is applied to both views.

Sorting applies to the projects in the active project folder. If you need to quickly see and sort all projects - across all folders - enter * in the search field at the top of the page. You can then sort accordingly.

In the graphical view, the tile for a managed project includes the name of the project and the last modified date. The tile also auto-populates with the 3D view of the project's PCB, where a PCB is available.

Example tile for a selected managed project when
the Projects page is set in its graphical view.

In the list view, each project entry includes the following information:

  • Name - the name of the project.
  • Description - the description entered for the project.
  • Author - the user who created the project.
  • Last Modified - the date and time when the project was last modified.

For both project views (graphical and list) the following controls are provided at the top-right of the list (and detailed in the linked sections that follow). They act on the currently selected project in the list :

(Share) - click to access the Share window, with all the controls necessary to share the project with other users.

(More) - click to access further options:

  • Open - click to open the detailed management page for the project. This will open on a separate tab of the browser.
  • Move - click to access the Move project window. From here, you can choose an alternate parent folder in which to move the project, from all folders available in the folder hierarchy.
  • Edit - click to access the Edit Project window. From here, you can change the project's Name, Description and server Parameters. The Parent Folder field is non-editable, providing information only. To change the parent folder, you need to use the Move command.
  • Clone - choose this command to access the Clone Project window, providing the controls to make an identical copy of the project.
  • Watch - choose this command to follow the project. You will receive applicable notifications related to the project (e.g. updated, released, permission changes) through an email sent out from the Workspace (provided email notifications have been enabled for the Workspace by an Administrator). The creator of the project will automatically be set to watch that project.
  • UnWatch - choose this command to stop following the project and cease reception of notifications for events relating to that project.
  • Delete - choose this command to delete the project. The Delete window will appear in which to confirm the deletion. The action is actually a 'soft delete', whereby the project repository will be moved into the Trash area of the Workspace. This does not affect the local working copy.
In the graphical view all commands can be accessed directly from the project tile - click the  control to access the corresponding menu. In addition, double-clicking the tile for a project in this view (or clicking on its name) will access the detailed management page for the project. In the list view all commands can be accessed from the menu associated to the  control, located at the far right of a project's entry.

Also included is a project Search feature which allows you to search for projects across all project folders. You can search by:

  • Name
  • Description
  • Author
  • Project Parameter - while all parameters are searchable, this enables you to craft custom project parameters for optimal searching (e.g. customer name, project number).

Type any part of a search string in the field at the top of the browser interface. The list will update to include only those project entries whose attributes include the search string. To quickly present a full listing of projects - across all project folders - enter * into the search field.

When searching by project parameter, you can either search by parameter name, or a specific value (of a parameter that exists). In the case of parameter name, if the name has no spaces, enter the string <ParameterName> = into the search field. If the name includes spaces, enter the string as "<ParameterName>" =. Typically it will be a parameter value that is used, such as the name of a customer (in a parameter such as Customer, Customer Name, etc). However a parameter could be used as a 'tag', and hence the ability to search for any project that has that particular parameter.

Example use of the search feature, in this case finding a project based on the value of a project parameter (Customer Name).

To clear search filtering either click on the main Projects page entry in the left-hand navigation pane, or clear the search field.

Properties Pane

If not already showing, click Properties at the top of the right-hand pane to access the Properties pane. This pane shows detailed property information for the currently selected project.

Access more detailed information for the currently selected project on the Properties pane.

The property data that is available in the Properties pane has been extracted or generated by the Workspace from the currently selected project. The uppermost region of the pane presents the 3D view of the board (where a PCB is available for the project), along with general high-level information, including the project's name, description, author, when it was created and last modified and also a link to the project's parent folder.

Additional properties are arranged under the following expandable headings (with example imagery to illustrate):

  • Shared With - the users and/or roles who have access to the project. Hover over an entry to see the full name of the user/role.

  • Parameters - a comprehensive collection of detailed data extracted or computed from the project design itself. Click the Show control to expand the full list, click Hide to contract again.

  • Releases - a list of the releases for the project. Multiple releases are shown in sequential order, with the most recent at the top. Click on an entry to open that release, which will be presented on a separate tab through a Manufacturing Portal. From this portal you can view and navigate the released file data, inspect the BOM, and view and comment on the snapshot of the design itself; the source for that released data. You'll also have access to controls for downloading manufacturing data at various levels of granularity (from full data set(s) to individual generated output file(s)). A chosen release can also be sent - as a Manufacturing Package - directly to your manufacturer.

Activity Pane

If not already showing, click Activity at the top of the right-hand pane to access the Activity pane. This pane shows activity information for the currently selected project. Each message highlights an event which took place in relation to the project (property change, new commit, release, etc). The most recent event appears at the top of the list.

Access a history of events that have taken place for the currently selected project on the Activity pane.

Click on the entry for the project in any of the event messages to access the detailed management page for the project.

Sharing a Managed Project

Once a project is managed (available in the Workspace), you'll want to determine which users can actually access that project. This is done by sharing the project or rather by configuring its access permissions.

Default Sharing Permissions

A managed project - newly created or made available in the Workspace - is shared, by default, with the following:

  • The Owner of the project, which is usually the designer who created it (or made it available in the Workspace): with full editing access.
  • The Administrators role: with full editing access.
  • Anyone in the Workspace team: with full editing access.

Default permissions for new projects can be defined/changed on the Admin - Settings - Projects page of the Workspace's browser interface. Note that the Owner of the project is inherently assigned permission to access it and therefore is not present in the list.

Manage the default permissions for new projects from the Admin area of the Workspace's browser interface.

Note also that the root Projects folder is shared, by default, with all members of the Workspace team for editing, and this permission is set to apply to all children - meaning all sub-folders created. Modify folder sharing permissions to further control access to projects therein.

Bear in mind that the Projects folder is shared with all members of the Workspace team with full editing rights. Modify this access, and to any created sub-folders thereof, as required.

Sharing Overview

To configure access permissions for a project from the Workspace's browser interface, select the project entry on the Projects page of the interface and click the  button.

Also available in the graphical view of the Projects page by selecting the tile for the required project, then clicking the  control and choosing the Share command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required project and choose the Share command from the associated menu.

The Share window will appear, with all the controls necessary to share the project with other users.

With your design projects centrally managed in a Workspace, sharing with others is simply a case of managing each project's permissions.

Things to be aware of:

  • In terms of permissions, a user/role has full editing access to the project when the Can Edit option is selected. Otherwise, they have View-only access.
  • The Owner and the Administrators role always have full editing access (Can Edit).
  • With the exception of the Owner and the Administrators role, permissions for all included users/roles may be individually set as Can View or Can Edit, or access rights completely removed.
  • A project may be explicitly shared with particular Users and/or Roles, or simply shared with anyone in the Workspace team.
  • You can share a project with users outside of your Workspace team for editing, or for viewing and commenting only. You can share with other AltiumLive users from within your own organization, AltiumLive users from different organizations, and non-AltiumLive users (who will need to then register for AltiumLive accounts). For a user outside of your team, the Sharing Outside of the Workspace window will appear, offering the following options:
    • Share for Viewing - click this option to proceed with sharing the project, but with view-only permissions.
    • Share for Editing - click this option to proceed with sharing the project, with editing rights.

You can share the project with anyone outside of the team, for editing or viewing.

Sharing with a user outside of the Workspace team for editing is perfect for contractors - where you want them to actively work on the design, but without bringing them in to your team.
Support for sharing a project outside of the Workspace from within Altium Designer - for viewing and commenting only - was made available in Altium Designer 20.1. To be able to share a project outside of the Workspace for editing from within Altium Designer, and indeed to open such a shared project for editing, requires Altium Designer 20.2 or later.

Sharing with a Specific User or Role

The procedure for sharing a managed project in the Workspace with specified users and/or roles is as follows:

  1. Add the required user/role name(s) to the Share Project With field in the Share window. To add an entry, begin typing the desired name/email/role in the field so the matching user/role can be selected from the dynamic list - which will only contain filtered users in your team or within your organization, and existing roles defined for the Workspace. Multiple users/roles can be chosen. To remove an entered user/role, click the  control associated with the entry.
To share with a user outside of your organization - irrespective of whether they have an AltiumLive account or not - you must enter their full email address and press Enter.

  1. Set the sharing access permissions for the added users/roles from the associated drop-down menu by selecting Can View or Can Edit, where the latter option inherently includes viewing capability. The setting initially applies to all entries (user/roles) included in the Share Project With field.

  1. Click the  control to access a textual area if you wish to include information that relates to the sharing arrangement for this project.

  1. Click the Shared With control to present the users/roles with whom the project is currently (and specifically) shared, which by default includes the Owner and the Administrators role.

With the exception of the Owner and the Administrators role, permissions for all included users/roles may be individually set as Can View or Can Edit, or access rights completely removed. Click on the current permission state to access controls.

  1. To open access to all users in the Workspace team, choose the Anyone in the Workspace option from the drop-down listing at the bottom of the window and then set access rights to the required level - either Can View (Read-only access), or Can Edit (full Read/Write access). This option is chosen by default with full access rights (Can Edit).

  1. Click the Advanced Settings control to access a window with which to determine advanced share settings. For people with editing rights, you can control whether a person can share with others. This allows you to restrict further sharing by external contractors, for example. For people with view-only access, you can control whether they can also download native data (project itself) and derived data (e.g. generated Gerbers or PDFs). They can still view data in the Web UI and provide comments, as before. In each case, separate permissions are provided for people inside and outside of the Workspace.

If a person with view-only access rights is not permitted to download, then they can only view the project through the Web UI. They can not view the project through Altium Designer, since the project would otherwise need to be downloaded first to do so.
Access to advanced settings when sharing a project from within your design software requires Altium Designer 21.3 or later.
  1. Click the  button to confirm the updated sharing permissions for the project. What happens next depends on the type of user being invited:
  • A user that is already part of your Workspace Team will be added to the access list for the project directly. They will receive an email notifying them that the project has been shared with them (and what access rights they have to it). They can open the project in Altium Designer (if permitted to do so) and access it through the Altium 365 Platform Interface (from the Projects page).
  • An existing role for the Workspace will be added to the access list for the project directly. All members of the role will receive an email notifying them that the project has been shared with them (and what access rights they have to it). They can open the project in Altium Designer (if permitted to do so) and access it through the Altium 365 Platform Interface (from the Projects page).
  • For a person outside of your Workspace team, the project will be shared with them and they will receive a notification email. They can open the project in Altium Designer (if permitted to do so) and access it through the Altium 365 Platform Interface (from the Shared with Me page). The email provides direct access to the design through Altium 365. Once they click the  button in the email they will be taken to the Altium 365 Sign In page (unless already signed in to the platform, or their AltiumLive account). Upon signing in, they will be taken to the Viewer, with the shared design loaded.
If the person does not have an AltiumLive account, they will need to sign up for one first - a link is provided on the Altium 365 Sign In page.
Within Altium Designer access the project using the File » Open Project command and the associated Open Project dialog.  If you are a Workspace team member, you can choose which managed project to open from your connected Workspace (when connected to a Workspace, that Workspace will appear in the Locations region of the dialog, distinguished by the  icon, and appearing with the name given to the Workspace). Only those managed projects that have been shared with you (you have permission to access) will be listed. If you are a non-Workspace team member with whom the project has been shared, you can choose which managed project to open from the Shared With Me location of the dialog (requires Altium Designer 20.2 or later).

You can also share a direct link to the project. The link is obtained by clicking the  control, at the bottom of the Sharing window. The link works in concert with the current setting to the left:

  • Only people added can access - only those people specifically added or part of an added role (in the Shared With region) will be able to access the project using the link, with access rights that have been set for them (or the role).
  • Anyone in the Workspace - anyone in the Workspace team will be able to access the project using the link, with access rights determined by the field to the right.

Obtain a direct link to the project, the use of which is governed by the setting at the bottom-left of the Sharing window.

The link is copied to the clipboard. When used, it provides the applicable user - where permitted - access to the detailed management page for the project, an overview for which is presented in the next section.

Accessing the Detailed Management Page for the Project

Main page: Management of a Specific Project

The Workspace provides an advanced, manufacturing-oriented CAD-centric view of the project, opened by selecting the required project, clicking the  control above the listing of projects, and choosing the Open entry on the associated menu. Alternatively, double-click directly on the required project entry in the list.

Also available in the graphical view of the Projects page by selecting the tile for the required project, then clicking the  control and choosing the Open command from the context menu. Alternatively, click on the project's name within the tile. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required project and choose the Open command from the associated menu.

The detailed management page for that project opens in a new browser tab incorporating the CAD-centric interface, which offers Design, Supply, Releases, and History view options:

  • Design - display and navigate source project design documents, view design object properties and place review comments. This view uses the Web Viewer interface to present your design across four distinct data sub-views, to show the source schematic(s), board in 2D, board in 3D and Bill of Materials respectively. This view is for the latest version of the source project data, rather than a specified release from that project, and so could be considered to be a work-in-progress (WIP) view. You can review both the base design and any defined variant thereof.
You'll be able to search, select, cross-probe, and inspect components and nets throughout the design and across the various sub-views as applicable. And when viewing the board in 2D, you can even take measurements.

  • Supply - allows you to interactively examine work-in-progress (WIP) BOM data extracted from the design documents, including entries for Manufacturer and Supplier parts data derived from a project's populated ActiveBOM document.

  • Releases - view the releases for the project. Access is provided for opening the full release data, or a specific assembly package, which will be presented on a separate tab through a Manufacturing Portal. From this portal you can view and navigate the released file data, inspect the BOM, and view and comment on the snapshot of the design itself; the source for that released data. From either the Releases view, or through the Manufacturing Portal for a specific release, you'll have access to controls for downloading manufacturing data at various levels of granularity (from full data set(s) to individual generated output files). A chosen release can also be sent - as a Manufacturing Package - directly to your manufacturer. You even have the ability to compare Gerber data between releases or against a locally-generated file set.
The Altium 365 platform provides a dedicated Manufacturing Package Viewer - an element of the platform's Global Sharing support - which allows others to view a manufacturing package from any web browser - anywhere in the world - but outside of your Workspace, so that your designs themselves and other valuable IP are kept off limits. For more information, see Global Sharing and Manufacturing Package Viewer.

  • History - browse a progressive timeline of major events relating to the project, including its creation, commits, releases, clones and MCAD exchanges. Each time a supported event happens in association with the project, that event is added to the timeline as a dedicated tile with various actions supported where applicable. For release events, you even have the ability to compare Gerber data between releases or against a locally-generated file set.

The detailed management page for the project can also be accessed from within Altium Designer. For the active managed project, use the Project » Show in Web Browser command, from the main menus. Alternatively, right-click on the entry for the project in the Projects panel and choose the Show in Web Browser command from the context menu. When browsing the project through Altium Designer's Explorer panel - configured in its default Project View rather than Classic View - access to the detailed management page is made by clicking the  button.

Moving a Managed Project

To move (relocate) a project under a different parent folder within the folder hierarchy select its entry on the Projects page, click the  control above the listing of projects/folders, and choose the Move entry on the associated menu.

Also available in the graphical view of the Projects page by selecting the tile for the required project, then clicking the  control and choosing the Move command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required project and choose the Move command from the associated menu.

The Move project window will appear, in which to choose the new parent folder. Click the  button to effect the move. The project will be moved to the chosen folder and you will be taken to that folder.

You can move a project to any folder - within the project folder hierarchy - at any stage.

Editing a Managed Project

To edit the properties of an existing managed project in the Workspace, select its entry on the Projects page, click the  control above the listing of projects, and choose the Edit entry on the associated menu. In the following Edit Project window - which opens in simplified view - you can change the project's Name and Description.

Also available in the graphical view of the Projects page by selecting the tile for the required project, then clicking the  control and choosing the Edit command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required project and choose the Edit command from the associated menu.

You can edit the Name and Description for a managed project at any stage.

Click the  button to access additional fields.

Additional fields accessed by clicking the Advanced button.

  • Parent Folder - this field displays the name of the folder in which the project can be found, within the project folder hiearchy for the Workspace. This field is non-editable, providing information only. To change the parent folder, you need to use the Move command.
  • Parameters - click this control to expand an area in which you can manage server-side parameters for the project. Parameter Name/Value pairs my be added (), edited (in-line editing), or removed ().

Edit server-side parameters for the project.

Server-side project parameters are saved in the Workspace with the project, and can only be edited within the Workspace. By contrast, design-side project parameters are saved in the project file (*.PrjPcb), and can be edited in Altium Designer. Both parameter types may be used as Special Strings in Altium Designer - accessed from the Properties panel with a placed Text String selected in the design workspace. All parameters defined for the project - design-side and server-side - can be viewed on the Parameters tab of the Project Options dialog (Project » Project Options).

Click the  button to confirm any changes you have made.

Cloning a Managed Project

To clone an existing managed project, select its entry on the Projects page, click the  control above the listing of projects, and choose the Clone entry on the associated menu. The Clone Project window will appear.

Also available in the graphical view of the Projects page by selecting the tile for the required project, then clicking the  control and choosing the Clone command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required project and choose the Clone command from the associated menu.

You can clone a managed project to create an identical copy of it, along with its working files.

Use the Clone Project window to specify a name for the project and an optional description. By default the original project name will be used with the suffix ' - Copy', and a default description will be pre-filled.

Note that the cloned project name should start with, and can contain A-Z, a-z, or 0-9. Underscores, dashes, and spaces are allowed, but the latter can only be used within the middle of the name (leading and trailing spaces will be ignored). You can not use the following words: AUX, COM1-COM9, LPT1-LPT9, CON, NUL, and PRN. In addition, the name cannot contain the following characters: \ . / ? % * : | " < >. You cannot use the same name as the source project.

Click the  button to access the Parent Folder field. By default this will be set to the folder in which the source project is located. Click the Change link at the right of the field to access the server folder structure for the Workspace, from which to select an alternate folder in which to store the cloned project. You can organize projects into a hierarchy of sub-folders should you wish. For more information, see the section Creating a Hierarchy of Project Folders.

After setting the fields as required, click the  button. The original project will be cloned (duplicated) along with its constituent files and data and be added as a new project entry to the Projects page listing (under the chosen parent folder).

Deleting a Managed Project

Related page: Trash

To delete (remove) an existing managed project from the Workspace, select its entry on the Projects page, click the  control above the listing of projects, and choose the Delete entry on the associated menu.

Deletion is only possible provided you are the owner of the project, or a Workspace Administrator.
Also available in the graphical view of the Projects page by selecting the tile for the required project, then clicking the  control and choosing the Delete command from the context menu. When the Projects page is presented in its list view, click the  control at the far right of the entry for the required project and choose the Delete command from the associated menu.

The Delete window will appear, in which to confirm the deletion. The action is actually a 'soft delete', whereby the project repository will be moved into the Trash area of the Workspace. The Delete window will appear differently, depending on whether the project has been released or not:

  • Project never released - in this case, the Delete window simply conveys that the project repository will be moved to the Trash.

  • Project released - in this case, the Delete window conveys that the project repository will be moved to the Trash and also summarizes the number of Releases and Packages (Manufacturing Packages) that will be deleted also.
Should you wish to soft delete a specific manufacturing package associated with a particular project, this can be performed from the Manufacture view of the detailed management page for the project. Access this view quickly by clicking on the Show details link in the Delete window.

To proceed with the deletion, click the  button. The project will be removed from the main listing of projects. Your local working copy is not affected by this action, but you will no longer be able to commit changes to the server. In Altium Designer, you can simply close and reopen the local working copy to access a range of suggested actions, since the local project now references a VCS repository that no longer exists.

All projects deleted in this manner can be found on the Trash page of the interface. Note that you can only view projects (and any other items for that matter) that you have personally soft deleted. Administrators will be able to see the full content of the Trash page - so all items that have been soft deleted.

Things to consider in relation to a soft deleted project:

  • The project will not be available to open and browse from your design software, or from within the Web interface.
  • If the project had been shared externally outside of the Workspace team, the related tile for it will be removed from the Shared with Me page of the Altium 365 Platform Interface, for all external people involved.
  • Any shared Manufacturing Packages that have been deleted with the project will also be removed from the Shared with Me page of the Altium 365 Platform Interface, for all people involved.
  • When browsing any items that have been used in a project, the Where Used entry for the project will reflect that the project has been deleted.
  • A project can be restored or permanently deleted from the Trash page, only by the owner of that project or a Workspace Administrator.
Note that if you have soft deleted a project - moving it to the Trash - you can create a new project with that same name again. If you were to subsequently restore the project and the original name is taken, an integer suffix will be used to keep its name unique within the Workspace.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.