Planificación de regiones rígidas y flexibles - Modo avanzado
De un vistazo
- Aprenderás la diferencia entre el modo rígido-flexible estándar y el modo rígido-flexible avanzado, y cómo cambia la forma de crear y definir las regiones de la placa.
- Verás cómo colocar y editar regiones de placa en el modo de planificación de placa, incluida la asignación de nombres y apilados de capas, así como el uso de guías y del ajuste a objetos para lograr precisión.
- Conocerás atajos útiles, modos de colocación y ajustes de propiedades que te ayudarán a trabajar con mayor eficiencia en diseños complejos de PCB rígido-flexibles.
Colocación de una región de la placa
Una región de la placa es un objeto poligonal que se coloca mediante las técnicas estándar de colocación de objetos poligonales. La forma de la placa debe definirse con precisión, por lo que es importante que las regiones que la componen se creen exactamente según lo requerido. El siguiente vídeo muestra cómo crear regiones de la placa alineando sus bordes con guías del espacio de diseño colocadas previamente. La ventaja de esta técnica es que la ubicación de las guías del espacio de diseño puede definirse con precisión editando sus coordenadas en el panel Properties.
Se utilizan guías predefinidas del espacio de trabajo como referencias para colocar las regiones de la placa.
Las regiones de la placa se colocan y modifican en Board Planning Mode:
- Seleccione View » Board Planning Mode (o pulse el atajo 1) para acceder a Board Planning Mode. La región de la placa existente de forma predeterminada se mostrará como un rectángulo verde.
-
Seleccione Place » Board Region para colocar una nueva región (o haga clic en el botón
de Active Bar).
- Sitúe el cursor y haga clic para fijar el vértice inicial de la región de la placa. La región de la placa es un objeto poligonal, como una región o un polígono, y tiene el mismo proceso de colocación (y edición).
- Mueva el cursor para colocar el segundo vértice. El comportamiento predeterminado consiste en colocar dos bordes con cada clic, con una forma de esquina definida por el usuario entre ellos; pulse Spacebar para alternar la dirección de la esquina. Consulte la sección Placement Modes más adelante para obtener más detalles sobre cómo cambiar los modos de esquina.
- Siga moviendo el ratón y haciendo clic para colocar vértices y crear los bordes necesarios para definir la forma general de la región de la placa.
- Tras colocar el último vértice, haga clic con el botón derecho o pulse Esc para cerrar y completar la definición de la forma de la placa. No es necesario cerrar manualmente la forma de la placa, ya que el software la completará automáticamente conectando el último punto colocado con el punto inicial.
- Cada región de la placa recibe un nombre que la identifica de forma única. Introduzca un nombre adecuado en el campo Name del modo Región de la placa del panel Propiedades (la región de la placa debe estar seleccionada en el espacio de diseño para que sus propiedades se muestren en el panel).
-
Cada región de la placa debe tener un apilado de capas asignado. Al crear una nueva región de la placa, se le asignará el apilado de capas predeterminado, denominado
Board Layer Stack. Asigne el apilado de capas necesario en el modo Board Region del panel Properties. Los apilados de capas se definen y reciben su nombre en el Administrador de apilado de capas. - Si la PCB final requiere varias regiones de la placa, continúe definiendo regiones adicionales.
Además, puede pulsar la tecla Tab para pausar la colocación y acceder al modo Región de la placa del Properties panel , desde donde puede cambiar sus propiedades sobre la marcha. Haga clic en el botón de pausa superpuesto en el espacio de diseño para reanudar la colocación.
Placement Modes
Al redefinir la forma de la placa, hay cinco modos de esquina disponibles, cuatro de los cuales también tienen submodos de dirección de esquina. Durante la redefinición:
- Pulse Shift+Spacebar para recorrer los cinco modos de esquina disponibles.
- Pulse Spacebar para alternar entre los dos submodos de dirección de esquina.
-
Cuando esté en cualquiera de los modos de esquina en arco, mantenga pulsada la tecla
para reducir el arco o la tecla
para ampliarlo. Mantenga pulsada la tecla Shift mientras pulsa para acelerar el cambio de tamaño del arco.
- Pulse la tecla de acceso directo 1 para alternar entre colocar dos bordes por clic o un borde por clic. En el segundo modo, el borde discontinuo se denomina segmento de anticipación (como se muestra en la última imagen de la serie siguiente).
- Pulse la tecla Backspace para eliminar el último vértice.



Pulse Shift+Spacebar para recorrer los cinco modos de esquina disponibles; pulse la tecla de acceso directo 1 para alternar entre la colocación de dos bordes o un borde.
Propiedades de la región de placa

El modo Board Region del panel Properties.
Acciones
Estos controles se utilizan para añadir o eliminar la capa de cobertura (coverlay) de la región de placa actual. Para habilitar los botones Add y Remove Coverlay , la región de placa debe tener asignado un apilado de capas que tenga la opción Is Flex habilitada e incluya capas de cobertura en su conjunto de capas.
- Add Coverlay - Añadir polígonos de cobertura creados automáticamente a la región de placa seleccionada.
- Remove Coverlay - Eliminar los polígonos de cobertura creados automáticamente y definidos manualmente de la región de placa seleccionada.
Ubicación
- (X/Y) - Las coordenadas X e Y del primer vértice colocado al crear la región de placa, con respecto al origen actual del espacio de diseño. Edítelas para cambiar la posición X o Y de la región de placa. Los valores pueden introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
Propiedades
- Name - Nombre de esta región de placa, definido por el usuario. Asignar un nombre a cada región de placa resulta útil cuando hay varias regiones en el diseño.
- Layer Stack - Especifica qué apilado de capas está asignado a esta región de placa. La lista desplegable incluirá todos los apilados de capas (subapilados) definidos en el Administrador de apilados de capas.
- Color - Haga clic para abrir una paleta de colores y establecer o cambiar el color de las regiones de placa seleccionadas. Tenga en cuenta que los cambios de color se aplican a todas las regiones de placa que comparten el apilado de capas utilizado por la región de placa seleccionada.
- Priority - El valor de prioridad se utiliza para determinar qué región de placa se representa en último lugar. Utilícelo al diseñar una placa con una región flexible dentro de un recorte de placa en una región rígida: la región flexible debe tener un valor de prioridad superior al de la región rígida circundante (y el recorte de placa debe seguir el contorno de la región flexible situada en su interior).
- 3D Locked - Marque esta casilla para fijar esta región de placa al plegar la placa en el modo de vista 3D. Solo se puede bloquear una región de placa rígida.
Vértices del contorno
Esta sección se utiliza para modificar los vértices individuales del objeto de región de placa seleccionado. Puede modificar las ubicaciones de los vértices existentes, añadir nuevos vértices o eliminarlos según sea necesario. Se pueden definir conexiones en arco entre los vértices y también se permite exportar la información de los vértices a un archivo en formato CSV e importarla desde él (mediante el menú contextual).
-
Vertices Grid - Enumera todos los vértices definidos actualmente para la región de placa en términos de:
- Index - El índice asignado al vértice (no editable).
- X - La coordenada X (horizontal) del vértice. Haga clic para editarla.
- Y - La coordenada Y (vertical) del vértice. Haga clic para editarla.
-
Arc Angle (Neg = CW) - El ángulo de un arco trazado para conectar este vértice con el siguiente. De forma predeterminada, las conexiones son bordes rectos y este campo permanece vacío. Haga clic para editarlo e introduzca el ángulo de arco que necesite. Si introduce un valor positivo, el arco se trazará en sentido antihorario. Para trazar un arco en sentido horario, introduzca un valor negativo.
-
Add - Haga clic para añadir un nuevo vértice. El nuevo vértice se añadirá debajo de la entrada de vértice que tenga el foco y, al principio, tendrá las mismas coordenadas X,Y que dicha entrada. Haga clic en
para eliminar el vértice seleccionado.
Crear una región de placa a partir de un cuerpo 3D
También se pueden crear regiones de placa a partir de objetos de cuerpo 3D mediante el comando Create Board Region from 3D Body en el modo 3D. El procedimiento es el siguiente:
- Asegúrese de estar visualizando la placa en 3D (si no es así, utilice el atajo de teclado 3 para cambiar rápidamente a este modo).
- Seleccione el comando Design » Board Shape » Create Board Region from 3D body en los menús principales.
- Sitúe el cursor sobre el modelo 3D que desee utilizar para generar la región de placa de la PCB y haga clic o pulse Enter. El modelo se volverá transparente.
- Mueva el cursor sobre el modelo 3D para localizar una cara. Cuando se encuentre una superficie plana bajo el cursor, se volverá opaca y mostrará un borde azul fino.
- Una vez encontrada la cara adecuada, haga clic o pulse Enter : se creará la nueva región de placa (que sustituirá a la región de placa definida previamente en el espacio de diseño).
- Aparecerá el cuadro de diálogo Board Outline Creation Successful para confirmar que la creación se ha completado correctamente. Este cuadro de diálogo le permite ocultar la pieza del modelo y excluirla de la comprobación de reglas de diseño (DRC). También ofrece opciones para modificar la altura del modelo y alinear la cara con la superficie superior o inferior, o para mantener la posición sin cambios.
Crear una región de recorte de placa
Para crear un recorte interno en la placa, coloque una región de recorte de placa (Place » Define Board Cutout, o haga clic en el botón
de Active Bar). Un recorte de placa también es un objeto poligonal, por lo que su proceso de colocación es el mismo que el de la propia región de placa. Las imágenes siguientes muestran una región de placa con dos recortes de placa, que se convierten en aberturas en la placa al fabricarla.
Un recorte de placa colocado en una región de placa se convierte en una abertura en la placa terminada.
Dividir el contorno de la placa en regiones
Puede dividir una región de placa existente en dos regiones mediante un corte. Esto se hace cuando el editor de PCB está en Board Planning Mode.
La placa se ha dividido en tres regiones de placa mediante el comando Slice Region.
Para dividir una región de placa:
- Seleccione View » Board Planning Mode (o pulse el atajo 1) para acceder a Board Planning Mode.
-
Seleccione Design » Slice Board Region (o haga clic en el botón
de la barra activa) para acceder al modo Slice Board Region.
- Al seleccionar el comando, se activa el modo de división, similar al modo de colocación de pistas. Comenzando fuera de la región que desea dividir, haga clic para fijar una serie de vértices que definan la línea de división. Mientras define la división, pulse Shift+Spacebar para alternar entre los modos de esquina; pulse Spacebar para alternar entre los modos de esquina inicial y final, y utilice la tecla Backspace para eliminar la última esquina colocada. Sitúe el extremo de la línea de división más allá del borde de la región de placa. Cuando haya terminado de definir la división, haga clic con el botón derecho o pulse Esc para finalizar el comando.
-
Se abrirá un cuadro de diálogo de confirmación que indica el número de polígonos (regiones) que se dividirán y el número de polígonos (regiones) que se crearán. Haga clic en Yes para confirmar su creación.
Creación de regiones de placa a partir de objetos seleccionados
En función de la forma de la placa, puede resultar más eficiente construirla creando varias regiones de placa. Como se ha mencionado anteriormente, las regiones pueden colocarse de forma interactiva o crearse trazando un contorno definido por objetos de pista y arco. El siguiente vídeo muestra cómo definir tres regiones de placa a partir de objetos seleccionados. En el vídeo observará que se utiliza el mismo objeto para definir los bordes adyacentes donde se tocan las regiones, lo que garantiza que estas queden posicionadas con exactitud.
Un método habitual consiste en definir el contorno de las regiones mediante pistas y arcos y, a continuación, crear las regiones de placa a partir de los contornos seleccionados.
Conversión entre primitivas de dibujo 2D y objetos de definición de placa
Un método habitual para definir la forma de la placa y las regiones de placa necesarias en ella consiste en importar un dibujo de una aplicación de CAD mecánico. Por ejemplo, puede importar detalles mecánicos desde un archivo DWG para obtener un conjunto de líneas (pistas) en una capa mecánica que definan la forma de la placa, las regiones dentro de ella y, en un diseño rígido-flexible, la ubicación de las líneas de pliegue en las regiones flexibles.
El software incluye varios comandos que permiten crear objetos de definición de placa (región, recorte, línea de pliegue) a partir de primitivas de dibujo 2D, así como comandos complementarios para volver a convertir los objetos de definición de placa en primitivas de dibujo.
Notas:
- Los comandos para ambas direcciones están disponibles en el submenú Tools » Convert del modo View correspondiente (excepto el comando Create Board Region from Selected Objects, que se encuentra en el submenú Design » Board Shape).
-
Para convertir primitivas de dibujo 2D en objetos de definición de placa, cambie la vista a 2D Layout Mode.
- Las primitivas deben estar seleccionadas antes de ejecutar el comando.
- Las primitivas deben formar una figura cerrada para crear una región o un recorte. Consulte el recuadro de advertencia que aparece a continuación para obtener más información sobre los requisitos de esta figura.
-
Para convertir objetos de definición de placa en objetos de dibujo 2D, cambie la vista a Board Planning Mode.
- Estos comandos no requieren que los objetos estén seleccionados previamente, pero actuarán sobre el objeto seleccionado si ya hay uno.
- Si hay varias regiones de placa, la región desaparece al descomponerla en primitivas. Si solo hay una región de placa, se crearán las primitivas y la región de placa elegida se conservará (siempre debe haber una región de placa).
- Los objetos de dibujo 2D se crean en la capa mecánica de tipo Board Shape. Si en la placa no existe ninguna capa de este tipo, se añadirá una capa mecánica con su tipo de capa establecido en Board Shape. Obtenga más información sobre las capas mecánicas y los tipos de capa.
- Aunque no existe un comando específico para reagrupar un objeto descompuesto, puede utilizar el comando Undo para hacerlo.
Modificación de las regiones de placa
Cuando la PCB está configurada para utilizar el modo rígido-flexible estándar, la ubicación donde se unen dos regiones adyacentes se define mediante una línea de división azul que puede desplazarse. Este método no se utiliza en el modo rígido-flexible avanzado; en su lugar, cada región es una figura poligonal cerrada e independiente. Al tratarse de una figura poligonal, cada región puede ajustarse según sea necesario mediante las técnicas habituales de edición de figuras poligonales. Tenga en cuenta que no todos los comandos de edición de polígonos están disponibles para modificar una región de placa, incluidos los comandos para añadir y sustraer polígonos.
Aspectos que debe recordar al editar un objeto poligonal:
- Al hacer clic y arrastrar un vértice o un borde del polígono, hay tres modos de modificación disponibles: deslizamiento, división y curvado. Pulse Shift+Spacebar para alternar entre los modos mientras arrastra. El modo actual se muestra en la barra de estado y en el indicador Heads-Up.
- El comportamiento de ajuste del cursor se controla mediante la configuración actual de ajuste del cursor, que incluye la cuadrícula de ajuste actual, los objetos disponibles para el ajuste, la presencia de guías del espacio de trabajo y la configuración de ajuste a los ejes. Utilice estas funciones para obtener la forma deseada. Obtenga más información en Comprender el comportamiento de ajuste.
Asignación de un apilado de capas y edición del nombre de la región de placa
Related page: Definición del apilado de capas
Al crear una placa nueva, esta tendrá una única región, denominada Default Layer Stack Region. A esta región se le asignará el apilado de capas predeterminado denominado Board Layer Stack.
Al dividir la forma de una placa en varias regiones, a cada nueva región también se le asigna el apilado de capas predeterminado. Una vez definidos los apilados de capas necesarios en el Administrador de apilados de capas, se puede asignar a cada región su apilado y darle un nombre descriptivo.
Para asignar un apilado de capas y dar nombre a una región:
- Seleccione View » Board Planning Mode o pulse el atajo de teclado 1 para acceder a Board Planning Mode.
- Haga clic en la pestaña Multi-Layer situada en la parte inferior del espacio de trabajo para convertirla en la capa activa (si la pestaña de la capa no está visible, pulse L para abrir el panel Configuración de vista y habilitarla).
- Haga doble clic en la región de la placa para abrir el cuadro de diálogo Board Region, o haga un solo clic en la región de la placa y abra el panel Properties. Si la región no se selecciona y el cuadro de diálogo no se abre, asegúrese de que el Filtro de selección no esté excluyendo las regiones.
- Asigne el apilado de capas seleccionando el apilado necesario en la lista desplegable Layer stack.
- Edite el Name según sea necesario.

El nombre de la región de la placa y el apilado de capas asignado se muestran en el centro geométrico de dicha región. También se muestra (Flex) cuando el apilado asignado está configurado como flexible.