Diseño de alta velocidad
De un vistazo
- Comprende los principales factores del diseño de alta velocidad que Altium Designer te ayuda a gestionar, desde las terminaciones y las rutas de retorno hasta las vías, los pares diferenciales y el control de longitud.
- Descubre cómo utilizar el análisis de integridad de la señal antes y después del diseño físico para identificar posibles problemas de reflexión y afinar las decisiones sobre las terminaciones.
- Aprende cómo se utilizan xSignals, los perfiles de impedancia del apilado de capas y las reglas de diseño de enrutamiento para definir, medir y controlar las rutas críticas de alta velocidad.
Diseño de alta velocidad en Altium Designer
El diseño de placas de circuito impreso de alta velocidad es un proceso que consiste en equilibrar los requisitos de diseño del circuito, las tecnologías de los dispositivos y los materiales y métodos de fabricación para obtener una PCB capaz de transferir señales entre los componentes manteniendo su integridad.
Aspectos que se deben considerar
El proceso de enrutamiento de una placa con señales de alta velocidad requiere gestionar:
-
Los componentes de terminación que puedan ser necesarios
-
La definición de las señales a las que se deben aplicar reglas de diseño de alta velocidad
-
Las dimensiones mecánicas de las rutas para el enrutamiento con impedancia controlada
-
Las propiedades y dimensiones de los materiales de la placa
-
La cantidad y disposición de las capas en el apilado de capas
-
La trayectoria de retorno de cada señal de alta velocidad
-
El impacto y la configuración de las vías
-
La configuración y el enrutamiento de los pares diferenciales
-
La configuración y el control de las longitudes de las rutas
Análisis de integridad de señal antes y después del diseño físico
Al principio del proceso de diseño, es importante identificar las señales que podrían requerir adaptación de impedancias para poder incluir componentes de terminación adicionales antes de completar la colocación de los componentes. Dado que los pines de salida suelen tener una impedancia baja y los pines de entrada suelen tener una impedancia alta, puede ser necesario añadir componentes de terminación al diseño para lograr la adaptación de impedancias.
Altium Designer incluye un simulador de integridad de señal al que se puede acceder tanto durante la captura del diseño como durante el diseño físico de la placa, lo que permite realizar análisis de integridad de señal antes y después del diseño físico (Tools » Signal Integrity). El simulador de integridad de señal modela el comportamiento de la placa enrutada utilizando como datos de entrada para las simulaciones la impedancia característica calculada de las pistas, combinada con la información de los macromodelos de los búferes de E/S. El simulador se basa en un simulador rápido de reflexiones y diafonía, que genera simulaciones muy precisas mediante algoritmos de eficacia probada en la industria.
Dado que tanto la captura del diseño como el diseño de la placa utilizan un sistema de componentes integrado que vincula los símbolos esquemáticos con las huellas de PCB correspondientes, los modelos de simulación SPICE y los macromodelos de integridad de señal, el análisis de integridad de señal se puede ejecutar en la etapa de captura de esquemáticos, antes de crear el diseño de la placa. Cuando aún no existe un diseño de placa, la herramienta permite configurar las características físicas del diseño, como la impedancia característica deseada de las pistas, desde el simulador de integridad de señal. En esta etapa previa al diseño físico, el simulador de integridad de señal no puede determinar la longitud real de conexiones concretas, por lo que utiliza una longitud media de conexión definida por el usuario para realizar sus cálculos de líneas de transmisión. Si se elige cuidadosamente esta longitud predeterminada para que refleje las dimensiones de la placa prevista, se puede obtener una idea bastante precisa del comportamiento probable del diseño en cuanto a integridad de señal.
Se pueden identificar las redes con posibles problemas de reflexión y añadir al esquemático los componentes de terminación adicionales necesarios antes de pasar al diseño físico de la placa. Los valores de estos componentes se pueden ajustar con mayor precisión una vez realizado el análisis de integridad de señal posterior al diseño físico.

El motor de análisis de integridad de señal ayuda a identificar redes con posibles problemas de reflexión. Ten en cuenta que las mediciones se pueden realizar directamente sobre las formas de onda.
► Más información sobre la adaptación de impedancias de los componentes
Definición de las señales de alta velocidad
Main page: Definición de trayectorias de señales de alta velocidad con xSignals
El diseño de alta velocidad es el arte de gestionar el flujo de energía de un punto a otro de una placa de circuito. Como diseñador, debes poder centrar tu atención y aplicar las restricciones de diseño a una señal que viaja de un punto de la placa a otro. Sin embargo, esa señal en la que te centras no tiene por qué ser una única red de PCB. La señal podría ser una rama de A0 en un diseño que pretendes enrutar con una topología en T, mientras que la otra rama de A0 sería otra señal a la que también debes prestar atención, además de poder comparar las longitudes de las rutas de ambas señales. O bien, la señal podría incluir un componente de terminación en serie en su trayectoria (que el editor de PCB interpreta como un componente y dos redes de PCB) y, si esa señal forma parte de un par diferencial, su longitud debe compararse con la de la otra señal del par.
Puedes gestionar estos requisitos mediante una función denominada xSignals, donde una xSignal es, básicamente, una trayectoria de señal definida por el usuario. Selecciona el pad de origen y el pad de destino (en el espacio de trabajo o en el panel PCB) y, a continuación, haz clic con el botón derecho en cualquiera de ellos para definir esa trayectoria de señal como una xSignal. Además de definir interactivamente una xSignal mediante sus pads inicial y final, también puedes ejecutar el asistente inteligente xSignals Wizard, cuyos métodos heurísticos te ayudarán a configurar rápidamente un gran número de xSignals entre los componentes elegidos. Estas xSignals se pueden utilizar después para aplicar reglas de diseño a tus señales de alta velocidad. El software comprende la estructura de estas xSignals; por ejemplo, calcula la longitud total de varias redes conectadas a través de un componente de terminación, así como la distancia a través de dicho componente.
El panel PCB incluye un modo xSignal que se utiliza para examinar y gestionar las xSignals. El panel también proporciona información sobre la longitud de la señal y resalta las xSignals que están cerca del límite de cumplimiento (amarillo) o que incumplen (rojo) las restricciones de diseño aplicables. En la imagen siguiente, la diferencia entre las longitudes de las xSignals del par diferencial CLK1 supera lo permitido por la regla de diseño de igualación de longitudes aplicable. El panel incluye la Signal Length, que es una longitud precisa de punto a punto. Se resuelven las discrepancias habituales en el cálculo de longitudes, como las pistas dentro de los pads y los segmentos de pista superpuestos, y se utilizan distancias precisas de los tramos de las vías para calcular la longitud de la señal.

Utiliza el modo xSignals del panel PCB para gestionar y examinar tus xSignals. Observa la línea fina; indica la trayectoria de la señal a través de un componente en serie. (Imagen cortesía de FEDEVEL Open Source, www.fedevel.com)
Definición de las propiedades del enrutamiento
Main page: Enrutamiento con impedancia controlada
Tradicionalmente, los diseñadores de placas definían la anchura y el espesor del trazado introduciendo una dimensión para la anchura y seleccionando un espesor de cobre para esa capa. Por lo general, esto era suficiente, ya que solo había que garantizar que las pistas pudieran conducir la corriente y que se mantuvieran las distancias de aislamiento necesarias para la tensión aplicada. Este enfoque no es suficiente para las señales de alta velocidad de su diseño, para las que es necesario controlar la impedancia de los trazados.
El enrutamiento con impedancia controlada consiste en configurar las dimensiones de los trazados y las propiedades de los materiales de la placa para obtener una impedancia específica. Para ello, se define un perfil de impedancia adecuado y, a continuación, se asigna ese perfil a las redes críticas de alta velocidad mediante las reglas de diseño de enrutamiento.
Definición del perfil de impedancia
Main page: Configuración del apilado de capas para el enrutamiento con impedancia controlada
Los perfiles de impedancia se definen en el Layer Stack Manager (Design » Layer Stack Manager) del editor de PCB. El Layer Stack Manager se abre en un editor de documentos, del mismo modo que una hoja de esquemático, la PCB y otros tipos de documentos.
Una vez configuradas las propiedades de las capas, cambie a la pestaña Layer Stack Manager's Impedance para añadir o editar perfiles de impedancia de señales individuales o diferenciales.
Un perfil de impedancia de 50 Ω definido para redes individuales enrutadas en la capa superior; sitúe el cursor sobre la imagen para mostrar la configuración del mismo perfil para la capa L3.
Configuración de las reglas de diseño
La impedancia del trazado viene determinada por su anchura y espesor, así como por las propiedades de los materiales dieléctricos circundantes. A partir de las propiedades de los materiales definidas en el Layer Stack Manager, se calculan las anchuras de trazado necesarias al crear cada perfil de impedancia. Según las propiedades de los materiales, la anchura puede variar al cambiar de capa de enrutamiento. La necesidad de cambiar la anchura al cambiar de capa de enrutamiento se gestiona automáticamente mediante la regla de diseño de enrutamiento correspondiente, configurada en el Editor de reglas y restricciones de PCB (Design » Rules).
En la mayoría de los diseños de placas, habrá un conjunto específico de redes que deban enrutarse con una impedancia controlada. Un enfoque habitual consiste en crear una clase de redes o de pares diferenciales que incluya estas redes y, después, crear una regla de enrutamiento que se aplique a esa clase, como se muestra en las imágenes siguientes.
Normalmente, las anchuras mínima, máxima y preferida se definen manualmente, ya sea en los ajustes de restricciones de la parte superior para aplicarlas a todas las capas, o de forma individual para cada capa en la tabla de capas. Para el enrutamiento con impedancia controlada, en su lugar se activa la opción Use Impedance Profile y se selecciona el perfil de impedancia necesario en la lista desplegable. Al hacerlo, cambiará la sección Constraints de la regla. Lo primero que observará es que la sección de capas disponibles de la regla de diseño dejará de mostrar todas las capas de señal de la placa y solo mostrará las capas habilitadas en el perfil de impedancia seleccionado. Los valores de anchura preferida (y de separación del par diferencial) se actualizarán para reflejar las anchuras (y separaciones) calculadas para cada capa. Estos valores preferidos no se pueden editar, pero sí los valores mínimo y máximo; establezca valores menores y mayores adecuados, respectivamente.
Regla de diseño de anchura de enrutamiento
Para las redes de señal no diferencial, la anchura de enrutamiento se define mediante la regla de diseño Anchura de enrutamiento.
Al optar por usar un perfil de impedancia, las capas disponibles y las anchuras preferidas quedan controladas por el perfil seleccionado.
Regla de diseño de enrutamiento de pares diferenciales
El enrutamiento de pares diferenciales se controla mediante la regla de diseño Enrutamiento de pares diferenciales.
En un par diferencial, las capas disponibles, la anchura preferida y la separación preferida quedan controladas por el perfil seleccionado.
► Más información sobre Enrutamiento de pares diferenciales
Elección de la impedancia
¿Cómo saber qué impedancia objetivo seleccionar? Normalmente, viene determinada por la impedancia característica de la fuente de la familia lógica o tecnología utilizada. Por ejemplo, la lógica ECL tiene una impedancia característica de 50Ω, y la lógica TTL tiene un intervalo de impedancia de fuente de 70Ω a 100Ω. Una impedancia objetivo de entre 50Ω y 60Ω es habitual en muchos diseños y, para los pares diferenciales, es común una impedancia diferencial de 90Ω o 100 Ω. Recuerde: cuanto menor sea la impedancia, mayor será el consumo de corriente; cuanto mayor sea la impedancia, mayor será la probabilidad de emitir interferencias electromagnéticas (EMI) y mayor será la susceptibilidad de la señal a la diafonía.
Un par diferencial de 100Ω también puede considerarse como dos trazados de señal no diferencial de 50Ω y de la misma longitud. Esto no es del todo exacto debido al acoplamiento que se produce entre los trazados del par, que aumenta a medida que se acercan y reduce la impedancia diferencial del par. Para mantener una impedancia diferencial de 100Ω , se puede reducir la anchura de cada trazado, lo que aumenta ligeramente la impedancia característica de cada uno en unos pocos ohmios.
Definición de las propiedades de la placa
Main page: Gestión del apilado de capas
Los materiales utilizados para las capas de la placa, sus dimensiones, así como el número de capas y el orden en que se disponen, se definen en el Gestor del apilado de capas. Aquí se configuran las distintas capas necesarias para fabricar la placa final, incluidas las capas de cobre de señal y de plano, las capas dieléctricas que separan el cobre, las capas de recubrimiento y la serigrafía de componentes.

Todas las capas que se fabrican se definen en la pestaña Apilado del Gestor del apilado de capas.
Configuración de las vías
Main page: Definición de los tipos de vías
Como se menciona en la sección de descripción general de esta página, las vías afectan a la impedancia del trazado de señales y son un factor clave en el diseño de alta velocidad. Además de la longitud, el diámetro del orificio y el área del pad de la vía, que afectan a la impedancia que ve la señal, cualquier parte no utilizada del cuerpo de una vía puede actuar como un stub y contribuir a las reflexiones de señal. Para controlar este efecto, se pueden fabricar distintos tipos de vías entre capas, incluidas vías ciegas, enterradas, microvías y vías con salto de capa. Altium Designer admite todos estos tipos de vías.
Las vías se definen como parte del apilado de capas, en la pestaña Layer Stack Manager's Via Types. También se admite el retaladrado de los cuerpos de vía no utilizados, que se define en la pestaña Layer Stack Manager's Back Drills (obtenga más información sobre cómo configurar la placa para el retaladrado).
Todos los tipos de vías que se pueden fabricar se pueden definir en la pestaña Tipos de vía del Administrador del apilado de capas.
Se han realizado estudios cuantitativos para comprender el impacto de las vías, como la nota de aplicación AN529 de Altera, Técnicas de optimización de vías para diseños de canales de alta velocidad.
Como resumen de este estudio y de otras referencias, se ofrecen las siguientes directrices para ayudar a minimizar el impacto de las vías:
- Reduzca el tamaño del anillo anular de la vía donde el trazado de señal se conecta a ella. La nota de aplicación sugiere un diámetro de vía/orificio de 20/10 mil (0,5/0,25 mm) para las vías taladradas mecánicamente.
- Elimine los anillos anulares no utilizados (también conocidos como NFP o pads no funcionales) en las capas a las que la vía no está conectada. Utilice el comando Tools » Remove Unused Pad Shapes para hacerlo.
- Aumente la separación entre el cuerpo de la vía y las capas de plano adyacentes. Esto se controla mediante la regla de diseño de separación del plano de alimentación; la nota de aplicación sugiere de 40 a 50 mil (de 1,0 a 1,25 mm). Tenga en cuenta que esto aumenta el tamaño de las aberturas en esas capas de plano.
- Coloque vías de cosido junto a las vías de señal siempre que el trazado de señal tenga un cambio de capa que haga que la ruta de retorno pase a otra capa. Si la nueva capa del plano de referencia tiene la misma tensión que el plano de referencia original, ambos planos deben conectarse mediante una vía situada a menos de 35 mil (0,9 mm) de la vía de señal (de centro a centro).
- Cuando el trazado de señal tenga un cambio de capa y la nueva capa del plano de referencia tenga una tensión diferente, coloque condensadores de desacoplo junto a la vía de señal. Este condensador proporciona desacoplo directamente entre los dos planos, independientemente de sus tensiones. Tenga en cuenta que esta solución puede provocar el acoplamiento de ruido de un plano al otro, por lo que solo debe utilizarse como último recurso para reducir el área del bucle de la ruta de retorno.
- Elimine los stubs de las vías (la longitud adicional de la vía más allá de la capa en la que el trazado de señal accede a ella). Esto se consigue utilizando vías ciegas y enterradas adecuadas, o mediante el retaladrado de las vías durante la fabricación.
Gestión de la ruta de retorno de las señales de alta velocidad
Una ruta de retorno de buena calidad es esencial para cada señal de alta velocidad del diseño. Siempre que la ruta de retorno se desvía y no discurre por debajo del trazado de señal, se crea un bucle que genera interferencias electromagnéticas (EMI), cuya magnitud está directamente relacionada con el área del bucle.
Creación de planos de alimentación
- Se puede crear un plano de alimentación a partir de una capa de plano o de una capa de señal cubierta por uno o varios polígonos.
-
Creación de un plano de alimentación con una capa de plano:
- Las capas de plano se añaden en Layer Stack Manager; haga clic con el botón derecho en una capa existente para Insert layer above o Insert layer below y añadir una nueva capa de plano.
- Con la capa de plano seleccionada como capa activa, haga doble clic en cualquier punto del plano para abrir el cuadro de diálogo Dividir plano, donde se puede asignar la red.
- El software retranquea automáticamente el borde del plano respecto al borde de la placa la distancia especificada en la columna Pullback Distance para esa capa en Layer Stack Manager. Si esa columna no está visible, haga clic con el botón derecho en el encabezado de una columna existente para acceder al comando Select Columns.
- Una capa de plano se puede dividir en regiones independientes colocando líneas (Place » Line). Pulse Tab después de empezar a colocar el primer segmento de línea para establecer el ancho de la línea de división. Coloque los segmentos de línea de un borde de la placa al otro, o cree una forma cerrada para generar una isla. El software detectará automáticamente las formas independientes creadas por las líneas de división; haga doble clic en cada forma para asignarla a una red.
-
Creación de un plano de alimentación con polígonos en una capa de señal:
- Las capas de señal se añaden en Layer Stack Manager; haga clic con el botón derecho en una capa existente para Insert layer above o Insert layer below y añadir una nueva capa de señal.
- Si se necesitan zonas de alimentación independientes, puede resultar más sencillo cubrir toda la capa con un polígono y luego cortarlo (Place » Slice Polygon Pour). Pulse Tab después de empezar a colocar la línea de corte para abrir el cuadro de diálogo Restricciones de línea, donde puede establecer el ancho del corte; este ancho será la distancia entre los dos polígonos creados por la acción de corte. La línea de corte debe empezar y terminar fuera del polígono.
- Para volver a rellenar un polígono, haga clic con el botón derecho y seleccione Polygon Actions » Repour Selected en el menú contextual.
- Los polígonos también se pueden apartar (ocultar temporalmente); haga clic con el botón derecho y seleccione el comando correspondiente en el Polygon Actions submenú. Utilice esta función cuando necesite mover componentes y trazados.
- Puede resultar útil mostrar las distintas redes con colores diferentes, como se muestra en las imágenes siguientes. Esto se puede hacer en el esquema o en la PCB; obtenga más información sobre cómo aplicar color a las redes.
La primera imagen muestra una capa de plano dividida en zonas de 3v3 y 5v0; la segunda imagen muestra una capa de señal con un polígono de 3v3 y otro de 5v0. Se han asignado colores a las redes y se ha activado el resaltado.
El plano como ruta de retorno de señal
Una ruta de retorno de buena calidad es aquella en la que:
- No hay interrupciones, divisiones ni aberturas (huecos en el plano creados por una vía o un pin de orificio pasante) debajo del trazado de señal en el plano que proporciona la ruta de retorno (el plano más cercano a la señal de interés).
- Lo ideal es que la anchura de la ruta de retorno sea 3 veces la anchura del trazado de la señal o 3 veces la distancia entre el trazado y el plano, lo que sea menor. Aunque la mayor densidad de corriente se encuentra directamente debajo del trazado de la señal, también se extiende por el plano a ambos lados del trazado, con aproximadamente el 95 % de la corriente circulando dentro de una anchura equivalente a 3 veces la del trazado. Las interrupciones del plano dentro de esta región aumentan la impedancia de la ruta de retorno, y cualquier desviación de esta ruta creará un bucle. En términos de integridad de la señal, este aumento de la impedancia de la ruta de retorno afecta a la calidad de la señal tanto como un aumento de la impedancia de la ruta de la señal.
- Se ha minimizado el área del bucle. En general, es más importante reducir el área del bucle que minimizar la longitud del trazado de la señal. Si la ruta de retorno encuentra una zona sin cobre, considere modificar el trazado de la señal para adaptarlo a una ruta de retorno disponible.
- Cuando un plano de alimentación proporciona la ruta de retorno, la energía de retorno llegará finalmente a tierra a través de un condensador de desacoplo. Considere cuidadosamente la ubicación de los condensadores de desacoplo cerca del pin de origen de la señal para minimizar el tamaño de cualquier bucle que se cree.
Gestión de planos de alimentación y de tierra divididos y múltiples
Existe un consenso general en que un plano de tierra no debe dividirse a menos que haya un requisito específico para ello y se sepa cómo definirlo y gestionarlo. En su lugar, los componentes deben disponerse de forma que los componentes ruidosos queden separados de los sensibles al ruido, y también deben agruparse según la línea de alimentación que utilicen.
Otros aspectos que deben tenerse en cuenta sobre los planos de alimentación y de tierra son:
- Si el diseño requiere que un plano de tierra esté parcialmente dividido, las señales que atraviesen esas áreas deben trazarse por el puente (la zona que no tiene una división debajo).
- Si se intenta minimizar el ruido del circuito, es mejor utilizar planos de tierra adicionales que dividir un plano y, siempre que sea posible, incluir capas de plano tanto para las líneas de alimentación como para las de tierra de cada fuente de alimentación regulada.
- Si el diseño incluye varias líneas de alimentación, cada una distribuida en su propio plano, asegúrese de que cada plano de alimentación solo tenga como referencia su propio plano de tierra. No permita que un plano de alimentación se superponga al plano de tierra de otra línea de alimentación y lo tome como referencia. Esto crea un acoplamiento capacitivo que permite que el ruido pase de una fuente de alimentación a otra.
- Si el plano adyacente es un plano de alimentación que debe dividirse en áreas de distintas tensiones, puede ser necesario colocar un desacoplo directamente entre las dos áreas de tensión para proporcionar una ruta de retorno adecuada.
Visualización de planos divididos
Para facilitar la comprobación visual de las rutas de retorno, puede configurar la visualización de modo que resulte más sencillo examinar la ruta de retorno bajo los trazados de las señales críticas.

Comprobación de si las señales pasan sobre una línea de división al atravesar áreas de distintas tensiones del plano. Las cuatro redes resaltadas cruzan una división en el plano de alimentación VCC, lo que crea una interrupción en la ruta de retorno de esas señales.
Para hacerlo:
- Asigne un color a cada red de alimentación; obtenga más información en Aplicación de color a las redes.
- Limite la visualización de capas para mostrar solo las capas de señal y de plano pertinentes. Este conjunto de capas puede guardarse como un conjunto de capas; obtenga más información sobre cómo crear un conjunto de capas.
- Cambie a la capa de señal y Ctrl+Click en la red de interés para resaltarla (mantenga pulsado Shift al hacer clic para resaltar varias redes). La ventaja de resaltar en lugar de seleccionar es que el resaltado es persistente, por lo que las redes permanecerán resaltadas si hace clic en otro lugar; pulse Shift+C para borrar el conjunto de resaltado actual.
- El resaltado se consigue atenuando el resto de los objetos del espacio de diseño; el nivel de Dimmed Objects se establece en la sección Configuración de enmascaramiento y atenuación del panel View Configuration.
- Establezca la capa de plano como capa activa.
Las redes destacarán y será más fácil ver cualquier división o discontinuidad que se encuentre en la ruta de retorno, como líneas de división o zonas sin cobre creadas por pads de orificio pasante y vías.
Detección de interrupciones en la ruta de retorno
Las interrupciones o los estrechamientos en la ruta de retorno pueden detectarse mediante la regla de diseño de ruta de retorno. La regla de diseño de ruta de retorno comprueba que exista una ruta de retorno de señal continua en las capas de referencia designadas, por encima o por debajo de las señales a las que se aplica la regla. La ruta de retorno puede crearse a partir de rellenos, regiones y vertidos de polígonos colocados en la capa de señal de referencia, o puede ser una capa de plano.
Las capas de la ruta de retorno son las capas de referencia definidas en el Impedance Profile seleccionado en la regla de diseño de ruta de retorno. Estas capas se comprueban para garantizar que el Minimum Gap especificado (anchura más allá del borde de la señal) exista a lo largo de la ruta de la señal. Añada una nueva regla de diseño de ruta de retorno en la categoría de reglas High Speed.

Las capas de la ruta de retorno se definen en el Impedance Profile seleccionado; la anchura de la ruta (más allá del borde de la señal) se define mediante el Minimum Gap.
La imagen siguiente muestra los errores de ruta de retorno detectados para la señal NetX, con un ajuste de Minimum Gap de 0.1mm. Puede resultar más fácil localizar los errores de ruta de retorno si se configura el DRC Violation Display Style para mostrar los detalles de las infracciones, pero no la superposición de infracciones, en el cuadro de diálogo Preferencias – mostrar imagen. De este modo, se resaltan las ubicaciones exactas donde se ha incumplido la regla, en lugar de la totalidad de los objetos que la incumplen.
Comprobación de vías de la ruta de retorno
Cuando una señal de alta velocidad pasa de un plano de referencia a otro, también debe haber vías de retorno para transferir las señales de retorno entre los planos. Para comprobar si existe una vía de este tipo a una distancia específica de una vía de señal, defina si debe haber una vía de retorno dentro de una distancia determinada de una vía de la señal incluida en el ámbito de aplicación mediante la opción Max Stitch Via Distance de la regla de diseño de ruta de retorno correspondiente. La vía de retorno debe proporcionar una conexión a la capa de referencia definida en Layer Stack Manager para el perfil de impedancia correspondiente.
Con Max Stitch Via Distance definido en la regla, se comprueba la presencia de una vía de retorno dentro de la distancia especificada como parte de la comprobación de reglas de diseño (DRC) por lotes.

Ejemplo de incumplimiento de la restricción de distancia máxima de la vía de cosido. Aquí, una vía de la red DQS4R_N no tiene ninguna vía de retorno a la distancia especificada.
Configuración y enrutamiento de pares diferenciales
Main pages: Enrutamiento de pares diferenciales, Enrutamiento con impedancia controlada
Los pares diferenciales pueden definirse durante la captura del esquema o una vez que el diseño se haya transferido al diseño de la placa. Un requisito fundamental para definir un par en el esquema es incluir un _P o _N al final del nombre de cada una de las redes correspondientes. Los pares diferenciales se identifican en el esquema colocando un Differential Pair directive en cada red, o colocando uno en una Blanket directive, donde la directiva Blanket se superpone a un conjunto de etiquetas de red de tipo diferencial contenidas en ella, como se muestra en la imagen siguiente.
Se puede utilizar una directiva Blanket para configurar varias redes como miembros de pares diferenciales.
Trabajo con pares diferenciales:
- En el editor de PCB, los pares diferenciales pueden definirse en el modo Editor de pares diferenciales del panel PCB. Para simplificar el proceso de definición de las reglas de diseño que se aplican a los pares diferenciales, estos pueden asignarse a clases de redes o a clases de pares diferenciales; ambas se definen en el Explorador de clases de objetos.
- Para enrutar un par diferencial con impedancia controlada, cree un perfil de impedancia en Layer Stack Manager. Obtenga más información sobre el enrutamiento con impedancia controlada.
- Las propiedades del enrutamiento de pares diferenciales se definen mediante la regla de diseño de enrutamiento de pares diferenciales.
-
Para enrutar un par diferencial, utilice el comando de enrutamiento Par diferencial interactivo. Haga clic en el pad
_Po_Npara comenzar el enrutamiento y, a continuación, utilice Spacebar para alternar entre las formas de enrutamiento de salida disponibles. El comportamiento del enrutamiento es el mismo que para una sola red; pulse Shift+F1 para ver una lista de atajos de enrutamiento interactivo. Al acercarse a los pads de destino, pulse Ctrl+Click para completar el enrutamiento hasta los pads.
Reglas prácticas para pares diferenciales:
-
La igualación de longitudes es fundamental para que los pares diferenciales sean eficaces; mantenga las longitudes igualadas dentro de una tolerancia adecuada para la tecnología de señalización. Por ejemplo, iguale los pares USB 3.x con una tolerancia de entre 5 y 10 mil. Otra regla práctica consiste en igualar las longitudes de modo que la diferencia de retardo no supere el 20 % del tiempo de subida de la señal. La señalización diferencial funciona porque la energía de retorno fluye de vuelta a través del otro miembro del par; cuanto mayor sea la diferencia entre las longitudes, mayor será la cantidad de energía que retorne a través de la capa de plano más cercana.
-
Las discontinuidades en el acoplamiento, como cuando los miembros del par se enrutan por lados opuestos de un obstáculo, aumentan la impedancia. Puede ser preferible enrutar todo el par con un acoplamiento más débil (por ejemplo, con una separación de 2 veces el ancho de la pista de señal) para reducir la variación de impedancia debida a las discontinuidades del acoplamiento.
-
Mantenga alejadas las pistas agresoras, especialmente en las capas superficiales; procure dejar una separación de 3 veces el ancho de la pista de señal respecto a las redes potencialmente agresoras.
-
Como regla general, procure mantener una separación entre el par y otras señales de 2 veces el ancho de la pista de señal.
-
Mantenga los polígonos de tierra de la misma capa a una distancia de al menos 3 veces el ancho de la pista de señal.
-
Las reflexiones introducidas por las vías y las discontinuidades de acoplamiento se gestionan mediante el enrutamiento con impedancia controlada; para ello, se requiere un plano de referencia continuo debajo del recorrido de la señal.
-
Reduzca la separación entre la capa de señal y el plano para mejorar la inmunidad a la diafonía.
Control y ajuste de las longitudes de enrutamiento
Main pages: Ajuste de longitud, Regla de diseño de longitud, Regla de diseño de igualación de longitudes
Un requisito fundamental para gestionar señales de alta velocidad en una placa es controlar y ajustar sus longitudes de enrutamiento.
- Las longitudes absolutas pueden supervisarse mediante la regla de diseño de longitud, y las longitudes de enrutamiento relativas, mediante la regla de diseño de igualación de longitudes.
- Las longitudes actuales de un conjunto de redes y su cumplimiento de las reglas de diseño aplicables pueden comprobarse en el panel PCB, en el modo Nets (como se muestra a continuación).
- Si se ha definido una regla de longitud o una regla de igualación de longitudes, puede supervisar la longitud durante el enrutamiento interactivo o el ajuste de longitud mostrando el indicador de ajuste de longitud (Shift+G).
- Se admite el retardo causado por la longitud del pin dentro del encapsulado del dispositivo; para obtener más información, consulte Retardo del pin en el encapsulado.
- Las redes que incluyen componentes en serie en su recorrido se gestionan mediante la definición de xSignals.
Reglas de diseño
- Managing the Overall Route Lengths - La longitud total de enrutamiento de una red o un conjunto de redes puede supervisarse mediante una regla de diseño de longitud. Esta regla establece una longitud mínima y una máxima permitidas. Si la longitud de señal es inferior al mínimo permitido, se resalta en amarillo en el panel PCB (en el modo Nets); si supera el máximo permitido, se resalta en rojo.
- Managing the Relative Route Lengths - Las longitudes de enrutamiento relativas de un conjunto de redes pueden supervisarse mediante una regla de diseño de igualación de longitudes. Esta regla establece una tolerancia y utiliza como longitud de referencia el recorrido más largo del conjunto de redes al que se aplica. El resaltado amarillo de la longitud de señal en el panel indica que la longitud de esta señal es inferior a la longitud del recorrido más largo menos la tolerancia. El resaltado rojo indica que la longitud de esta señal es superior a la del recorrido más largo.
Para comprender cómo se resuelven los ajustes de estas dos reglas cuando ambas están presentes en un diseño, consulte la página Ajuste de longitud.
Supervisión de la longitud de enrutamiento
Las longitudes de enrutamiento actuales se muestran en el modo Redes del panel PCB y se actualizan a medida que se enruta. El valor de longitud Routed se volverá amarillo al acercarse a la longitud objetivo y rojo si la supera.
Si se ha definido una regla de longitud o una regla de igualación de longitudes, puede supervisar la longitud durante el enrutamiento interactivo o el ajuste de longitud mostrando el indicador de ajuste de longitud. Durante el enrutamiento, utilice el atajo Shift+G para mostrar u ocultar el indicador.
El indicador muestra la longitud enrutada actual como un número sobre el control deslizante, mientras que este muestra la longitud estimada. Durante el ajuste de longitud, Estimated Length = Current Routed Length; si utiliza el indicador durante el enrutamiento interactivo, Estimated Length = Routed Length + distance to target (length of connection line).
Los ajustes del indicador se calculan a partir de las restricciones definidas por las reglas aplicables.
-
El mínimo del indicador (borde izquierdo) es 45 (el menor
MinLimit) -
El máximo del indicador (borde derecho) es 48 (el mayor
MaxLimit) -
La barra amarilla izquierda (el mayor
MinLimit) es 46.58 -
La barra amarilla derecha (el menor
MaxLimit) es 47.58 (oculta tras la barra verde en la imagen anterior) -
La barra verde (
TargetLength) es 47.58 (longitud de enrutamiento de la red más larga del conjunto, igual aMaxLimit) - El control deslizante verde y el valor numérico superpuesto (longitud de enrutamiento actual) indican 47.197.
Ajuste de las longitudes de enrutamiento
Las longitudes de enrutamiento pueden ajustarse una vez completado el enrutamiento mediante el comando Interactive Length Tuning o el comando Interactive Diff Pair Length Tuning (menú Route). Estos comandos añaden secciones en acordeón al enrutamiento y permiten elegir entre tres formas.
Si hay una regla de longitud y una regla de igualación de longitudes aplicables, la herramienta de ajuste de longitud tiene en cuenta ambas y determina el conjunto de restricciones más estricto. Por lo tanto, si la longitud máxima especificada por la regla de longitud es inferior a la longitud más larga contemplada por la regla de igualación de longitudes, prevalece la regla de longitud y se utiliza su longitud durante el ajuste.
Para ver qué reglas se están aplicando o cambiar las propiedades del acordeón durante el ajuste de longitud, pulse Tab para abrir el modo Interactive Length Tuning del panel Properties, como se muestra a continuación. Observe el Target Length: este es el Max Limit de los ajustes de regla aplicables más estrictos.

Pulse Tab durante el ajuste de longitud para abrir el panel en el modo Interactive Length Tuning, donde puede seleccionar el modo de longitud objetivo y ajustar los parámetros del acordeón.
Para ajustar la longitud de una red, ejecute el comando y haga clic en cualquier punto de su recorrido. Mueva el cursor siguiendo el trazado de la ruta; a medida que lo haga, se añadirán secciones de ajuste en acordeón. Se seguirán añadiendo secciones de ajuste hasta que se cumplan los requisitos de longitud definidos por las reglas de diseño aplicables. Si el cursor sale de los límites de los acordeones de ajuste, las formas de acordeón desaparecerán; cuando el cursor vuelva a situarse dentro de los límites de la forma de acordeón, reaparecerán.
Obtenga más información sobre el ajuste de longitud.
Conclusión
Aunque no es posible establecer un conjunto universal de reglas aplicable a todos los diseños de alta velocidad, sí se pueden seguir buenas prácticas de diseño que le ayudarán a lograr buenos resultados. Varios expertos del sector imparten cursos de formación prácticos y populares sobre diseño de alta velocidad. Utilice los enlaces siguientes para obtener más información y explorar opciones de formación especializada.
Referencias
El autor agradece el trabajo de los siguientes expertos del sector; esta página es un intento de resumir sus conocimientos colectivos.
- Tiempos de propagación en microstrip
- División de planos para velocidad y potencia
- Efecto pelicular
- Reglas de diseño de pistas diferenciales: realidad frente a ficción
Artículos del Dr. Howard Johnson
- Inductancia de las vías
- Apilado de 10 capas
Libros y artículos de Lee W. Ritchey
- Bien a la primera
- Un análisis de la señalización diferencial y sus requisitos de diseño
- Los laminados de PCB influyen en las velocidades de transmisión de datos de alta velocidad, Parte 1, Parte 2
Artículos de In-Circuit Design - Barry Olney
- Enrutamiento de pares diferenciales
- La pura verdad sobre los puentes entre planos
- Colocación crítica
- Planificación del apilado (partes 1, 2 & 3)
- El apilado perfecto
Buenas prácticas en el diseño de placas de circuito - Tim Jarvis RadioCAD Limited
Diseño físico de PCB - Sitio web Learn EMC
Artículos de Keith Armstrong, Centro de Información sobre EMC (requiere registro gratuito)
Manual de encapsulado electrónico - Glenn R. Blackwell
Manual de circuitos impresos - Clyde Coombs y Happy Holden
Manual de HDI - Happy Holden y otros
Técnicas de optimización de vías para diseños de canales de alta velocidad - Nota de aplicación AN529 de Altera
Consideraciones de diseño de PCB de alta velocidad - Nota de aplicación TN 1033 de Lattice Semiconductor
Medición del tiempo de propagación de una señal - Chris Grachanen, EDN
El futuro de las estructuras de vías HDI, la distribución de energía y la gestión térmica en los circuitos impresos de próxima generación - Tom Buck TTM Technologies