Ubicación de componentes
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Comprenderás qué incluye la huella de un componente de PCB, desde los pads y los elementos de serigrafía hasta los cuerpos 3D opcionales.
- Aprenderás qué propiedades de los componentes en Altium Designer afectan a su colocación, orientación, asignación de capa e identificación.
- Verás cómo se gestionan los distintos tipos de componentes y las definiciones de área en el editor de PCB.
Se suele decir que el diseño de PCB consiste en un 90 % de colocación y un 10 % de enrutado. Aunque se podría debatir el porcentaje de cada uno, en general se acepta que una buena colocación de los componentes es fundamental para un buen diseño de la placa. Recuerda que también puede ser necesario ajustar la colocación a medida que realizas el enrutado.
La huella del componente define el espacio y los puntos de conexión necesarios para montar el componente físico en la placa de circuito impreso. Es un objeto de grupo formado por un conjunto de objetos primitivos simples, como pads, líneas y arcos, así como otros objetos de diseño.

La huella del componente define el montaje y las conexiones del componente en la PCB y también puede incluir objetos de cuerpo 3D para definir el componente real.
Los pads proporcionan los puntos de montaje y conexión para los pines del componente. A menudo se incluyen primitivas de diseño adicionales, como líneas y arcos, para definir el contorno del componente en la capa de serigrafía de componentes.
La huella del componente también puede incluir objetos de cuerpo 3D opcionales, que definen el espacio físico o la envolvente del componente real que se monta en la placa. Si el componente físico se ha definido mediante objetos de cuerpo 3D o modelos STEP importados, se puede realizar una comprobación tridimensional de las separaciones entre componentes.
Las huellas de componentes se crean en el editor de huellas de PCB colocando los objetos de diseño adecuados para crear la forma necesaria para montar y conectar el componente. El punto de referencia del componente es el origen del espacio de diseño del editor de huellas de PCB, que se puede establecer en el editor en el pin 1, en el centro geométrico o en una ubicación del componente definida por el usuario. Para obtener más información sobre la creación de huellas, consulta la página Creación de una huella de PCB.
Propiedades del componente

El modo Component del panel Properties.
Pestaña General
Ubicación
-
(X/Y)
-
X (primer campo): la coordenada X (horizontal) actual del punto de referencia del componente con respecto al origen actual del espacio de diseño. Edítala para cambiar la posición X del componente. El valor se puede introducir en unidades métricas o imperiales; incluye las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente. El punto de referencia de una huella de componente se establece en el editor de bibliotecas.
-
Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del componente con respecto al origen actual. Edítala para cambiar la posición Y del componente. El valor se puede introducir en unidades métricas o imperiales; incluye las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente. El punto de referencia de una huella de componente se establece en el editor de bibliotecas.
-
-
Rotation: el ángulo de rotación del componente (en grados), medido en sentido antihorario desde cero (la horizontal 3 o'clock). Edítalo para cambiar la rotación del componente. La resolución angular mínima es de 0,001°.
Propiedades
-
Layer: establece la capa en la que se coloca el componente. Los componentes se pueden asignar a la capa superior o a la inferior. Utiliza la lista desplegable para seleccionar otra capa. Al cambiar la capa, todas las primitivas del componente pasan a la capa opuesta correspondiente. Por ejemplo, al mover un componente de la capa superior a la inferior, los pads de una sola capa pasan de la capa superior a la inferior, las primitivas de la serigrafía superior se reasignan a la serigrafía inferior y las primitivas de una capa mecánica emparejada pasan a la otra capa mecánica de ese par. La orientación del componente se invertirá respecto al eje X y el texto de la serigrafía del componente se leerá desde la cara inferior.
-
Reuse Block: cuando el componente forma parte de un bloque de reutilización, este campo muestra el nombre del bloque de reutilización al que pertenece. Haz clic en el hipervínculo Reuse Block para ver las propiedades de este bloque de reutilización.
-
Designator: el designador del componente es una cadena alfanumérica de hasta 255 caracteres. Cada componente debe tener una cadena de designador única. Alterna
o
para mostrar u ocultar el designador. Haz clic en el hipervínculo Designator para abrir las propiedades del designador del componente.
-
Comment: el comentario del componente es una cadena alfanumérica de hasta 255 caracteres. Alterna
o
para mostrar u ocultar el comentario. Haz clic en el hipervínculo Comment para abrir las propiedades del comentario del componente.
-
Area: el área del componente colocado, expresada en las unidades actuales de la placa. El usuario puede definir el área; de lo contrario, se calcula automáticamente a partir del área de selección del componente:
-
Para definir el área del componente, edite Area en el panel Properties de la huella en el editor de huellas de PCB. Para transferir una huella actualizada a una PCB abierta, haga clic con el botón derecho en el nombre de la huella en el panel PCB Library y, a continuación, seleccione Update PCB With <ComponentName> en el menú contextual.
-
También puede definir manualmente el área de un componente ya colocado en una PCB seleccionando el componente e introduciendo después el valor en este campo.
-
Para cambiar de un área definida por el usuario a un área calculada para un componente colocado en una PCB, elimine el valor de este campo; el campo se rellenará automáticamente con el valor calculado.
-
El área calculada automáticamente es la que se resalta al hacer clic para seleccionar el componente. El área de selección se determina a partir de las geometrías de la capa Courtyard o, si esta capa no está presente, de la combinación de las geometrías de las capas de serigrafía y cobre y de los objetos de cuerpo 3D (se excluyen las cadenas de texto). Las imágenes superiores que se muestran a continuación presentan el área del componente cuando hay un contorno definido en la capa Courtyard; la imagen inferior muestra el área calculada a partir de las geometrías de las capas de serigrafía y cobre y de los objetos de cuerpo 3D.
► Obtenga más información sobre cómo se calcula el área de selección y sobre los demás modos disponibles para determinarla.
► Obtenga más información sobre cómo trabajar con capas mecánicas.
-
-
Description – descripción de este componente a nivel de componente. Normalmente, la descripción se define durante la creación del componente, pero también se puede editar o añadir al componente en el esquema. Esta es la descripción que se muestra en el panel Components.
-
Type – seleccione aquí uno de los siguientes tipos de componente para la huella del componente. Los tipos disponibles son:
-
Standard– estos componentes tienen propiedades eléctricas estándar, siempre se sincronizan entre el esquema y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y se incluyen en la lista de materiales (BOM). Un ejemplo es un componente eléctrico estándar, como una resistencia. -
Mechanical– estos componentes no tienen propiedades eléctricas, no se sincronizan (debe colocarlos manualmente en ambos editores) y se incluyen en la BOM. Un ejemplo es un disipador de calor. -
Graphical– estos componentes no tienen propiedades eléctricas, no se sincronizan (debe colocarlos manualmente en ambos editores) y not se incluyen en la BOM. Un ejemplo es el logotipo de una empresa. -
Net Tie (in BOM)– estos componentes se utilizan para cortocircuitar dos o más redes diferentes entre sí. Siempre se sincronizan entre el esquema y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y se incluyen en la BOM. Se diferencian de un componente estándar en que no se comprueba la conectividad creada por el cobre dentro de la huella: este cobre es el que permite cortocircuitar las redes. Nota: active la opción Verify Shorting Copper en el cuadro de diálogo Design Rule Checker para verificar que no haya cobre sin conectar dentro del componente. -
Net Tie– estos componentes se utilizan para cortocircuitar dos o más redes diferentes entre sí. Siempre se sincronizan entre el esquema y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y not se incluyen en la BOM. Se diferencian de un componente estándar en que no se comprueba la conectividad creada por el cobre dentro de la huella: este cobre es el que permite cortocircuitar las redes. Nota: active la opción Verify Shorting Copper en el cuadro de diálogo Design Rule Checker para verificar que no haya cobre sin conectar en el componente. -
Standard (No BOM)– estos componentes tienen propiedades eléctricas estándar, siempre se sincronizan entre el esquema y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y not se incluyen en la BOM. Un ejemplo es un componente de punto de prueba que desee excluir de la BOM. -
Jumper– estos componentes se utilizan para incluir puentes de alambre en un diseño de PCB, por ejemplo, en una PCB de una sola cara que no se puede enrutar por completo en una capa. Para este tipo de componente, la huella y los pines se sincronizan entre el esquema y la PCB, pero las asignaciones de redes no, y el componente se incluye en la BOM. Además de seleccionar esta opción a nivel de componente, ambos pads del componente deben tener su JumperID establecido en el mismo valor distinto de cero. Los componentes de tipo puente no necesitan estar cableados en el esquema; solo deben incluirse en él si son necesarios en la BOM. Si no son necesarios en la BOM, pueden colocarse directamente en la PCB, donde se establece Component Type, se establecen JumperIDs y se asigna manualmente Nets a los pads.
-
-
Design Item ID – muestra el ID del elemento de diseño del componente seleccionado. Este campo no se puede editar.
-
Source – muestra el documento de origen del componente. Haga clic en
para abrir un cuadro de diálogo que le permita buscar y seleccionar otro documento de origen.
-
Revision State – muestra el estado de la revisión del componente de la biblioteca del espacio de trabajo, tanto en términos de su estado del ciclo de vida como de su estado de revisión, es decir, si es la última revisión publicada de ese componente (
Up to date) o una revisión anterior (Out of date). -
Height – un campo de altura para el componente. Este campo definía la altura del componente de PCB antes de la introducción del objeto de cuerpo 3D; sin embargo, el modelo 3D proporciona un método superior para definir la altura del componente en tareas como la detección de colisiones en 3D. Tenga en cuenta que Altium MCAD CoDesigner utiliza el valor definido en este campo Height, no la altura del modelo 3D (más información).
-
3D Body Opacity – introduzca el porcentaje de opacidad deseado o utilice la barra deslizante.
-
Primitives – haga clic en el icono de candado asociado para bloquear o desbloquear.
– bloquear todas las primitivas del componente para que se pueda tratar como un único objeto.
– desbloquear para modificar las primitivas individuales que componen el componente. Después de editarlas, se deben volver a bloquear las primitivas del componente.
-
Strings – haga clic en el icono de candado asociado para bloquear/desbloquear.
– bloquear todas las cadenas de texto del componente.
– desbloquear para modificar las cadenas de texto del componente.
Huella
- Footprint Name – muestra el nombre de la huella correspondiente al componente seleccionado.
- Design Item ID – la identificación del componente seleccionado.
- Source – nombre del espacio de trabajo en el que se ha colocado el componente seleccionado.
- Description – descripción de la huella del componente, definida en el editor de huellas de PCB.
Opciones de intercambio
- Enable Pin Swapping – marque esta casilla para permitir la función de intercambio de pines.
- Enable Part Swapping – marque esta casilla para permitir la función de intercambio de unidades (p. ej., cuatro unidades de un CI de la serie 74).
Información de referencia del esquemático
- Designator – el designador del componente del esquemático con el que se ha vinculado este componente de PCB.
- Hierarchical Path – muestra dónde se encuentra este componente en la estructura jerárquica del esquemático.
- Channel Offset – cuando un diseño se transfiere por primera vez del esquemático a la PCB, se asigna un desplazamiento de canal único a cada componente de cada hoja del esquemático.
Pestaña Parámetros
- Table – muestra el Name, el Value y el Source de cada parámetro enumerado.
Designadores y comentarios de componentes
Los campos de designador y comentario son objetos de parámetro secundarios de un componente de PCB (pieza). El designador se utiliza para identificar de forma unívoca cada pieza colocada y distinguirla de todas las demás piezas colocadas en todos los documentos de PCB del proyecto. El comentario se utiliza para añadir información adicional a un objeto colocado. Tanto el comentario como el designador se configuran después de colocar el objeto de componente principal. No son objetos de diseño que se puedan colocar directamente.

Un objeto de designador colocado

Un objeto de comentario colocado
Los designadores de componentes de PCB 2D/3D se incrementarán automáticamente en una unidad durante la colocación si el componente inicial tiene un designador que termina en un carácter numérico. Cambie el designador del primer componente antes de colocarlo desde el panel Propiedades.
Para obtener incrementos alfabéticos o numéricos del designador distintos de 1, utilice la función Paste Array. Los controles de esta función se encuentran en el cuadro de diálogo Configurar matriz de pegado, al que se accede pulsando el botón Paste Array en el cuadro de diálogo Paste Special (Edit » Paste Special).
El método de edición gráfico permite seleccionar un objeto de designador o comentario colocado directamente en el espacio de diseño y cambiar su ubicación, rotación, orientación y tamaño.
Cuando se selecciona un objeto de designador o comentario, están disponibles los siguientes controles de edición:

Un designador seleccionado
- Haga clic y arrastre B para girar el designador/comentario alrededor de su punto de referencia A (indicado por la x pequeña).
- Haga clic y arrastre C para cambiar el tamaño del cuadro delimitador del designador/comentario en las direcciones vertical y horizontal simultáneamente.
- Haga clic y arrastre D para cambiar el tamaño del cuadro delimitador del designador/comentario en las direcciones vertical y horizontal por separado.
-
Haga clic en cualquier punto del designador/comentario alejado de los controles de edición y arrastre para cambiar su posición. Mientras lo arrastra, puede girar o reflejar el comentario:
- Pulse Spacebar para girar el designador/comentario en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. La rotación se realiza de acuerdo con el valor de Rotation Step definido en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Pulse las teclas X o Y para reflejar el designador/comentario respecto al eje X o al eje Y.
Las propiedades de un objeto de designador o comentario se pueden modificar en el modo Parameter del panel Properties.
Propiedades de los parámetros

El modo Parameter del panel Properties.
Ubicación
-
(X/Y)
-
X (primer campo) - la coordenada X (horizontal) actual del punto de referencia del designador respecto al origen actual del espacio de trabajo. Edite este valor para cambiar la posición X del designador. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
-
Y (segundo campo) - la coordenada Y (vertical) actual del punto de referencia del designador respecto al origen actual. Edite este valor para cambiar la posición Y del designador. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
-
- Rotation - el ángulo de rotación del designador (en grados) medido en sentido antihorario desde cero (la horizontal 3 o'clock). Edite este valor para cambiar la rotación del designador. La resolución angular mínima es de 0,001°.
Propiedades
-
Parameter type - muestra el tipo de parámetro (componente, símbolo de hoja, etc.) y el nombre del parámetro.
-
Name - el nombre del designador.
-
Value - utilice este campo para introducir el valor deseado del designador. Haga clic en el icono del ojo para alternar entre mostrar y ocultar el valor en el espacio de diseño.
-
Layer - utilice la lista desplegable para seleccionar la capa deseada. Active Mirror si lo desea.
-
Autoposition - utilice la lista desplegable para seleccionar la posición automática deseada con respecto al objeto asociado.
-
Text Height - utilice este campo para introducir la altura de texto deseada.
-
Font Type
-
TrueType - seleccione esta opción para utilizar las fuentes disponibles en su PC (en la carpeta \Windows\Fonts ). Las fuentes TrueType ofrecen compatibilidad completa con Unicode. De forma predeterminada, el software crea un vínculo a la fuente TrueType utilizada (no se almacena en el archivo PCB), lo que significa que la misma fuente debe estar presente en cada PC al que se traslade el diseño. Como alternativa, incruste las fuentes TrueType utilizadas en el archivo PCB mediante las opciones de la página Editor de PCB - Fuentes TrueType del cuadro de diálogo Preferences, donde también puede seleccionar una Substitution Font para utilizarla si una fuente no incrustada no está disponible.
-
Justification - utilice esta opción para establecer la ubicación del designador dentro del rectángulo del borde.
- Left - haga clic en el botón izquierdo para alinear el texto horizontal a la izquierda.
- Center - haga clic en el botón central para alinear el texto horizontal en el centro.
- Right - haga clic en el botón izquierdo para alinear el texto horizontal a la derecha.
- Above - haga clic en el botón superior para alinear el texto vertical en la parte superior.
- Middle - haga clic en el botón central para alinear el texto vertical en el centro.
- Below - haga clic en el botón inferior para alinear el texto vertical en la parte inferior.
-
Font - utilice la lista desplegable para seleccionar la fuente TrueType deseada. Utilice las opciones B (bold) y/o I (italic) para resaltar el texto según sea necesario.
-
Inverted - utilice para que el texto se muestre invertido y controlar el tamaño del borde que lo rodea. Puede utilizar las siguientes opciones para configurar aún más el texto:
-
Size (Width/Height) -
- Width - la anchura del rectángulo del borde.
- Height - la altura del rectángulo del borde.
-
Size (Width/Height) -
-
Inverted - utilice para que el texto se muestre invertido y controlar el tamaño del borde que lo rodea. Puede utilizar las siguientes opciones para configurar aún más el texto:
-
-
Stroke
-
Justification - utilice esta opción para establecer la ubicación del designador dentro del rectángulo del borde.
- Left - haga clic en el botón izquierdo para alinear el texto horizontal a la izquierda.
- Center - haga clic en el botón central para alinear el texto horizontal en el centro.
- Right - haga clic en el botón izquierdo para alinear el texto horizontal a la derecha.
- Above - haga clic en el botón superior para alinear el texto vertical en la parte superior.
- Middle - haga clic en el botón central para alinear el texto vertical en el centro.
- Below - haga clic en el botón inferior para alinear el texto vertical en la parte inferior.
-
Font - utilice la lista desplegable para seleccionar la fuente de trazos deseada. Las opciones son:
-
Default- una fuente vectorial sencilla diseñada para el trazado con pluma y el fototrazado vectorial. -
Sans Serif- una fuente compleja que ralentizará la generación de salidas vectoriales, como Gerber. -
Serif- una fuente compleja que ralentizará la generación de salidas vectoriales, como Gerber.
-
- Stroke Width - muestra la anchura del trazo.
-
Justification - utilice esta opción para establecer la ubicación del designador dentro del rectángulo del borde.
-
TrueType - seleccione esta opción para utilizar las fuentes disponibles en su PC (en la carpeta \Windows\Fonts ). Las fuentes TrueType ofrecen compatibilidad completa con Unicode. De forma predeterminada, el software crea un vínculo a la fuente TrueType utilizada (no se almacena en el archivo PCB), lo que significa que la misma fuente debe estar presente en cada PC al que se traslade el diseño. Como alternativa, incruste las fuentes TrueType utilizadas en el archivo PCB mediante las opciones de la página Editor de PCB - Fuentes TrueType del cuadro de diálogo Preferences, donde también puede seleccionar una Substitution Font para utilizarla si una fuente no incrustada no está disponible.
-
Border Mode
-
Margin - haga clic en este botón para habilitar la edición de la opción Borde del margen.
- Text Offset - la distancia que se desplaza el designador hacia dentro desde el borde o la esquina respecto a los que está justificado. Esta opción no tiene efecto cuando se elige el modo de justificación Center . Esta opción no está disponible para Margin.
-
Offset - haga clic en este botón para habilitar la edición de la opción Desplazamiento del texto.
- Margin Border - utilice esta opción para especificar el tamaño del borde del margen que rodea el designador. Esta opción no está disponible para Offset.
-
Margin - haga clic en este botón para habilitar la edición de la opción Borde del margen.
Disponibilidad de componentes en la PCB
Cuando el diseño se transfiere del editor de esquemas al editor de PCB, las huellas de los componentes de PCB se colocan automáticamente a partir de las bibliotecas disponibles. Esto se denomina Sincronización del diseño, un proceso para detectar y resolver las diferencias entre el esquema y la PCB.
Altium Designer ofrece un conjunto de herramientas que facilitan la colocación de la huella del componente requerido en el espacio de diseño de PCB. Consulte las siguientes páginas para obtener información sobre estas herramientas:
Exploración de componentes colocados
En el modo del panel PCB Components, sus tres regiones principales cambian para reflejar la jerarquía de componentes del diseño de PCB actual (en orden desde arriba):
- Component Classes
- Components dentro de una clase
- Component Primitives

Las regiones del panel PCB permiten realizar una selección de filtro acumulativa, desde las clases de componentes hasta los componentes individuales y las primitivas de los componentes.
Haga clic con el botón derecho en una entrada de componente o de primitiva de componente y, a continuación, elija el comando Properties (o haga doble clic directamente en la entrada) para acceder al panel Properties, en el que puede ver o modificar las propiedades del componente o de la primitiva según sea necesario.
Haga clic con el botón derecho en una entrada de clase de componentes y, a continuación, elija Properties (o haga doble clic directamente en la entrada) para abrir el cuadro de diálogo Editar clase de componentes de esa clase. Desde este cuadro de diálogo, puede ver o modificar los componentes que pertenecen a la clase, cambiarle el nombre o añadir clases adicionales.

Edición de una clase de componentes seleccionada.
La visualización o inclusión de cada tipo de primitiva de componente en la región Component Primitives del panel depende de si se ha habilitado la opción correspondiente a cada uno en el menú contextual al que se accede desde las regiones Components o Component Primitives.

Haga clic con el botón derecho en una entrada de componente o de primitiva de componente para seleccionar los elementos que desea incluir.
Durante la exploración, los componentes se pueden bloquear o desbloquear fácilmente haciendo doble clic en la casilla situada a la derecha de la columna Footprint en la región Components.

Bloquear o desbloquear desde el panel PCB evita tener que navegar por el panel Properties.
Cuadro delimitador de selección de componentes
Al hacer clic y seleccionar un componente, aparece el cuadro delimitador de selección. Para controlar qué capas se utilizan para definir el cuadro delimitador, se puede utilizar la opción PCB.ComponentSelection del cuadro de diálogo Advanced Settings. La opción admite tres modos (introduzca el valor 0, 1 o 2; el modo predeterminado es 2):
-
0 - legacy mode- este modo combina las geometrías de todas las capas, excepto las cadenas de texto del designador y del comentario de la serigrafía. -
1 - by layer mode- utiliza las geometrías de la primera de las capas enumeradas a continuación que contenga objetos, con la siguiente prioridad:-
Tipo de capa Courtyard
-
Capa de cuerpos 3D (los modelos STEP se almacenan en un objeto de cuerpo 3D cuyo tamaño corresponde al prisma rectangular más pequeño que contiene el modelo. Para la selección del componente, se utiliza este cuerpo 3D, no la forma del modelo STEP)
-
Capa de serigrafía más capas de cobre
-
Capas de cobre
-
-
2 - by graphic mode- este modo combina las geometrías detectadas en el tipo de capa Courtyard, la serigrafía, los objetos de cuerpo 3D y las capas de cobre. Se excluyen las cadenas de texto.
Adición de primitivas a un componente
Las primitivas seleccionadas se pueden añadir a un componente eligiendo el comando Tools » Convert » Add Selected Primitives to Component en los menús principales. Tras seleccionar el comando, elija el componente al que desea añadir las primitivas seleccionadas. Una vez confirmado, las nuevas primitivas se reconocerán como parte de un único objeto de componente y se podrán utilizar junto con las primitivas originales del componente.
Las primitivas del componente de destino deben estar desbloqueadas para realizar esta operación. Utilice el icono de candado Primitives en las propiedades del componente para desbloquearlas.
Descomposición de un componente en primitivas
Un componente se puede convertir en los objetos primitivos que lo constituyen mediante el comando Tools » Convert » Explode Component to Free Primitives de los menús principales, o haciendo clic con el botón derecho sobre un componente colocado (seleccionado o no) y eligiendo después el comando Component Actions » Explode Component To Free Primitives (o Explode Selected Components To Free Primitives) del menú contextual. Un componente descompuesto deja de ser un componente, por lo que se eliminarán el designador y el comentario, y el componente volverá a convertirse en las distintas primitivas que lo conformaban.
La descomposición no afecta al modelo de huella almacenado en la biblioteca de origen correspondiente, sino únicamente a las instancias convertidas de los componentes colocados en el documento PCB.
Acceso a enlaces a información de referencia
Cuando se han añadido enlaces a documentos con nombre al componente, se puede abrir la URL del documento o la página indicada, especificada mediante un parámetro de enlace URL subyacente definido, para el componente seleccionado o el componente situado bajo el cursor. Esta función permite que los enlaces a documentos con nombre transferidos desde los componentes del esquemático se presenten como enlaces con nombre del componente de PCB a archivos PDF, archivos de texto o páginas HTML. Esto ocurre cuando los enlaces a documentos con nombre del componente se han actualizado desde el esquemático a la PCB (Design » Update PCB Document). Durante ese proceso de actualización (mediante una ECO), los enlaces a documentos con nombre del esquemático se convierten en pares de parámetros ComponentLink (ComponentLinknDescription/ComponentLinknURL) para el componente de PCB correspondiente. Por ejemplo:
| Parámetro del componente del esquemático | Parámetros del componente de PCB | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
El número de índice del enlace (n) utilizado en los parámetros del componente definirá la posición del enlace del componente de PCB correspondiente en el References submenú. Con un componente seleccionado en la PCB, los pares de parámetros ComponentLink definidos se muestran en la sección Parameters del panel Properties.
Tras ejecutar el comando, se abrirá directamente la página de destino de la URL web o el documento indicado (si está disponible).

).